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1. Getting Started

1.1. What is LyX?

LyX is a document preparation system. It is a tool for producing beautiful manuscripts,
publishable books, business letters and proposals, and even poetry. It is unlike most
other “word processors” in the sense that it uses the paradigm of a markup language
as its core editing style. That means that when you type a section header, you mark it
as a “Section”, not as “Bold, 17 pt type, left justified, 5 mm space below”. LyX takes
care of the typesetting for you, so you deal only with concepts, not with mechanics.

This philosophy is explained in greater detail in the “Introduction”. If you haven’t
read it yet, you need to. Yes, we mean now.

The “Introduction” describes several things in addition to LyX’s philosophy: most
importantly, the format of all of the manuals. If you don’t read it, you will have a
bear of a time navigating this manual. You might also be better served looking in
one of the other manuals instead of this one. “Introduction” describes that, too.

1.2. How LyX Looks

Like most applications, [yX has the familiar menu bar across the top of its window.
Below it is a toolbar with a pulldown box and various buttons. There is, of course,
a vertical scrollbar and a main work area for editing documents.

Note that there is no horizontal scrollbar. This is not a bug or an oversight, but
intentional. When you read a book, you expect the end of a line to wrap around to
the next line. Text overflows onto new pages in a vertical fashion, hence the need for
only a vertical scrollbar. There are three cases where you might want a horizontal
scrollbar. The first case is large images. To avoid that they are displayed larger than
your screen, use in the image settings the option Scale on Screen in the tab IKTEX and
LyX options. The second and third cases are tables and equations which are wider
than the LyX window. You can use the arrow keys to scroll horizontally through the
table, but this doesn’t work for equations yet.

For a brief description of all Iy’ X menus and toolbar buttons, have a look at Ap-
pendix A.
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1.3. HELP

The help system consists of the IyX manuals. You can read all of the manuals from
inside IyX. Just select the manual you want to read from the Help menu.

1.4. Basic LyX Setup

Almost all features of Iy X can be configured via the menu Tools> Preferences. IyX
is able to inspect your system to see what programs, KTEX document classes and
BTEX packages are available. It uses this knowledge to give reasonable defaults for
the preferences settings. Although this configuration has already been done when
LyX was installed on your system, you might have some items that you installed
locally, e.g. new IXTEX classes, and which are not seen by LyX. To force LyX to
re-inspect your system, you should use Tools> Reconfigure. You should then restart
LyX to ensure that the changes are taken into account.

1.5. BTEX Setup

You can edit documents in IxyX without having IXTEX installed, but you will not to
able to create PDFs or print your documents unless you do have it installed. However,
some LyX documents use DocBook as the ‘backend’ that can produce PDFs and the
like, and every IyX document can always be output as plain text or as XHTML.

Some document classes may depend upon specific IfTEX or DocBook classes or
packages. Such document classes can be used even if you do not have the required
files installed, but you will not be able to produce certain kinds of output.

The BETEX packages that LyX has found on your system are listed in a file you can
view from the menu Help>LaTeX Configuration. If you are missing packages you need,
then you must install them and then reconfigure Iy’ X (menu Tools> Reconfigure). See
section 5.1 of the Customization manual for more information on installing additional

ETEX packages.



2. How to work with LyX

2.1. Basic File Operations

Under the File menu and in the standard toolbar are basic operations for any word
processor in addition to some more advanced operations:

. Newu

e New from Template

« Open @'

e Close

e Save E

o Save As

o Revert to saved
» Version Control
e Import

o Export

e Print &

e Exit

They all do pretty much the same thing as in other word processors, with a few minor
differences. The File>New from Template command not only prompts you for a name
for the new file, but also prompts you for a template to use. Selecting a template
will automatically set certain layout features for the document, features you would
otherwise need to change manually. They can be of use for certain classes, especially
those for writing letters (see sec. 3.1.2).

Note: There is no “default file” or document named “Untitled” or “scratch.” Un-
less you tell Iy X to open a file or create a new one, that big, blank space is just that
— a big, blank space.
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Revert to saved and Version Control are useful if more people work on the same
document at the same time!. Revert to saved will reload the document from disk.
You can of course also use it if you regret that you changed a document and want
to restore it to the last save. With Version Control you can register the changes you
made to a document so that others can identify them as your changes.

2.2. Basic Editing Features

Like most modern word processors, IyX can perform cut and paste operations on
blocks of text, can move by character, word, or page of text, and can delete whole
words as well as individual characters. The next four sections cover the basic IyX
editing features and how to access them. We will start with cut and paste.

As you might expect, the Edit menu and the standard toolbar has the cut and
paste commands, along with various other editing features. Some of these are special
and covered in later sections. The basic ones are:

° Cut&%

. Copy I§|_§|

g
e Paste “=

o Paste Recent

o Paste Special

e Find & Replace H

The first three are self-explanatory. You can also copy text between [y X and other
programs by cut, copy and paste. The submenu of Paste Recent shows you a list with
the last strings you have pasted.

The menu Edit> Paste Special > Plain Text, Join Lines will insert the text in the
clipboard so that the whole text is inserted as ome paragraph. A new paragraph is
started when there is a blank line in the file. Without Join Lines, the text is inserted
as Paragraphs, where the line breaks of the text will start a new paragraph.

The Edit>Find & Replace item opens the Find and Replace dialog. Once you have
found a word or expression, [yX selects it. Hitting the Replace button replaces the
selected text with the contents of the Replace with field. You can click the Find Next
button to skip the current word. Hit Replace All to replace all occurrences of the text
in the document automatically. The Case sensitive option can be used if you want
the search to consider the case of the search word. If the toggle is set, searching

'Tf you plan to do this, you should check out the Version Control feature in IyX also. Read
Additional Features.
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for “Test” will not match the word “test”. The Match whole words only option can
be used to force IyyX to only find complete words, e.g., searching for “star” will
not match “starlet”. LyX offers also an advanced Find & Replace feature that is
described in sec. 6.13.

Things like notes, floats, etc. (the so called “insets”) can be dissolved. This means
that the inset is deleted and its content is left as normal text. Dissolving an inset is
done by setting the cursor to the beginning of an inset and pressing Backspace or by
setting the cursor to the end and pressing Delete.

The content of an inset is selected using the shortcut Ctrl+Alt+A, the shortcut
Ctrl+A selects the whole document.

2.3. Undo and Redo

If you make a mistake, you can easily recover from it. LyX has a large-capacity
=y
undo/redo buffer. Select Edit>Undo or the toolbar button ' to undo sorne mistake.

If you accidentally undo too much, use Edit> Redo or the toolbar button I'*Ll to “undo
the undo.” The undo mechanism is currently limited to 100 steps to minimize memory
overhead.

Note that if you revert back all changes to arrive to the document as it was last
saved, the “changed” status of the document is unfortunately not reset. This is a
consequence of the 100 step undo limit, above.

Undo and Redo work on almost everything in LyX. But they will not undo or redo
text character by character, but by blocks of text.

2.4. Mouse Operations

These are the most basic mouse operations.
1. Motion
o Click the left mouse button once anywhere in the edit window. The cursor
moves to the text under the mouse.
2. Selecting Text

» Hold down the left mouse button and drag the mouse. IyX marks the text
between the old and new mouse positions. Use Edit> Copy to create a copy
of the text in IyyX’s buffer (and the clipboard).

» Re-position the cursor and then paste the text back into IyyX using Edit>
Paste.

3. Insets (Footnotes, Notes, Floats, etc.)

Right-click on them to set their properties. Also check the appropriate section
of this manual for more details.
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2.5. Navigating

LyX offers you several ways to navigate in documents:

e The Navigate menu lists all sections of the document as submenu entries that
you can click to jump to the corresponding document part.

o The ‘Outline’, which is accessed either by the menu DocumentrOutline or by

the toolbar button «,{;

e You can set bookmarks in your document under Navigate > Bookmarks and use
the same menu to return to them. Note that bookmarks are saved between
sessions.

The toolbar button kﬁl (also Navigate> Bookmarks> NavigateBack) jumps to the po-
sition in the document where you recently changed something. This is useful when
you have a large document and have navigated or scrolled to another document part
to look for something, and want to go back to your last editing position.

2.5.1. The OQOutliner

In the pull-down box at the top of the outline window, you can choose between several
different lists, including other TOC-like objects, such as lists of tables and figures,
but also lists of footnotes, or labels and cross-references (see sec.6.1), or notes, or
citations (see sec.6.5). Clicking on any of these will take you to the corresponding
object in your document.

Right-clicking on elements in the Outline will in many cases open a context menu
that will allow for direct modification of those elements. For example, with citations,
the context menu allows you to open the citation dialog and to modify the citation.
Right-clicking a change will allow you to accept or reject it. And so on.

The ‘Filter’ field at the top allows you to restrict which entries appear in the
Outline. For example, if you are displaying the list of Labels and References and
wish to see only references to subsections, you can enter the text “sub:” in the filter,
and only entries containing that text will be displayed.

At the bottom of the outline are several buttons and the like that allow you further
to control the display. The Sort option sorts the current list alphabetically. Otherwise,
the elements appear in the order in which they occur in the document. The Keep
option keeps it in the current view state. Keeping means that when you have e.g.
the subsections of section 2 and 4 shown and click on section 3, the subsections of
section 2 and 4 will still be shown. Without the Keep option they will be hidden to
highlight the clicked section 3. Finally, the slider at the left can be used to open the

Outline to a given “depth”. It is best just to experiment with it to see how it works.
&=
The = button refreshes the TOC (though this should not usually be necessary).

Next to it are buttons that allow you to change the position of sections in your
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document. The \b and @ buttons move sections up and down in the document.
So, for example, you can move section 2.5 before section 2.4 or after section 2.6.
LyX will then automatically renumber the sections to the new order. With the

1— 1=—
buttons ot and i (or the corresponding key bindings Tab and Shift-Tab) you can
change the level of sections. So you can for example make section 2.5 chapter 3 or
subsection 2.4.1.

2.6. Input / Word Completion

LyX provides completion of words by scanning all documents that are currently
opened. Every word that appears in these documents is added to a database that is
used to propose completions.

The input completion can be activated in the IyX preferences (menu Tools>
Preferences) in the section Editing®>Input Completion. With the option Automatic in-
line completion the proposed completion is shown directly behind the cursor. With
the option Automatic popup the completions are always shown in a popup. The cur-
sor completion indicator can be turned off by deselecting the option Cursor indicator.
With the general options you can define the delay time for the inline and popup
completion and choose if long completions should be abbreviated.

LyX shows a small triangle behind the cursor as an indicator that there are com-
pletions available. Press the Tab key to accept a proposed completion. If several
completions are possible, a popup is opened showing them. You can select a com-
pletion in the popup using the mouse or the arrow keys, and accept the chosen
completion be pressing Return.

The completion options for math in the preferences do the same as the correspond-
ing options for text. The special math option Autocorrection enables that characters
can be composed. If you for example want to insert the character =, you can then
input the characters “=>" to a formula to get it. So this is a quick alternative to the
insertion of commands or the usage of the math toolbar. A list with supported char-
acter combinations can be found in the file autocorrect that is somewhere in IyX’s
installation folder. Math autocorrection can at any time be turned on by pressing

7'7

the exclamation mark key ’!". Pressing Space turns it off.

2.7. Basic Key Bindings

There are at least two different primary binding maps: cua and emacs. IyX’s default
is cua, which can be changed in the Iy X preferences under Editing > Shortcuts.

Some keys, like Page Up, Page Down, Left, Right, Up and Down, do exactly what
you expect them to do. Other keys don’t:

Tab There is no such thing as a tab stop in IyX. If you do not understand
this, go read sections 3.2.1 and 3.3, especially section 3.3.6, right now. Yes,
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right now. If you're still confused, look in the Tutorial.
In IyX the Tab key is only used to accept propositions of the input com-
pletion.

Esc This is the “cancel key.” It’s used, generically, to cancel operations. Other
parts of the manual will go into greater detail about this.

Home and End These move the cursor, respectively, to the beginning and end of
a line, unless you are using the Emacs bindings where they jump to the
beginning or end of the file.

There are three modifier keys:

Control  (Denoted by “Ctrl” in the documentation files) This has a couple of different
uses, depending on which keys it is used in combination with:

o Backspace or Delete, it deletes an entire word instead of a single char-
acter.

o Left and Right, it moves by words instead of characters.

e Home and End, it moves to the beginning and the end of the document,
respectively.

Shift (Denoted by “Shift” in the documentation files) Use this with any of the
arrow keys to select the text between the old and new cursor positions.

Alt (Denoted by “Alt” in the documentation files) This is the Alt key on many
keyboards, unless your keyboard has a distinct Meta key. If you have both
keys, you will need to try out which one actually performs the Alt+ func-
tion.

This key does many different things, but it also activates the menu ac-
celerator keys. If you use this in combination with any of the underlined
letters in a menu or menu item, it selects that menu item.

For example, the sequence “Alt e s ¢” brings up the “Text Style” dialog.
Typing “Alt f” opens the File menu.

The Shortcuts manual lists all other things bound to the Alt key.

You will learn more and more key bindings and short-cut keys as you use LyX, because
most actions will prompt a small message in the status bar at the bottom of IyX’s
main window which describes the name of the action you have just triggered, and
any existing key bindings for that action. The LyX menus also list the defined key
bindings. The notation for the key bindings is very similar to the notation used in
this documentation, so you should not have any problems understanding it. However,
notice that Shift-modifiers are explicitly mentioned, so “Alt+P Shift+A” means Alt+P
followed by a capital A.

You can list or change the key bindings in the menu Tools > Preferences under Edit >
Shortcuts as explained in sec. C.2.2.2.
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3.1. Document Types

3.1.1. Introduction

Before you do anything else, before you ever start writing a document, you need to
decide what type of document you want to edit. Different types of documents use
different types of spacing, headings, numbering schemes, and so on. Additionally,
different documents use different paragraph environments, and format the title of
your document differently.

A document class describes a group of properties common to a particular set of
documents. By setting the document class, you automatically select these properties,
making it easier to create the type of document you want. If you don’t choose a
document class, IyyX picks one for you by default. So it is up to you to change the
class of your document.

Read on for info about the document classes you can choose from LyX, and how
to adjust their properties.

3.1.2. Document Classes

You can select a class using the Document > Settings> Document Class dialog. Select
the class you want to use, and make any fine tunings of the options you may need.

3.1.2.1. Overview

There are four standard document classes in IyX. They are:
Article for basic articles

Report for basic reports

Book for writing a book

Letter for US-style letters

There are also some non-standard classes, which LyX only uses if you have installed
the corresponding IXTEX class files, though most IXTEX distributions will include many
of these. Here are some of the classes. The full list with detailed explanations can
be found in chapter Special Document Classes in the Additional Features manual:
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A&A Journal articles in the style and format used in Astronomy & Astrophysics
ACS For submissions to the journals published by the American Chemistry Society
AGU For submissions to the journals published by the American Geophysical Union

AMS Layouts for articles and books in the style and format used by the American
Mathematical Society (AMS). There are three article layouts available. The
standard one uses a typical numbering scheme for theorems etc., that prepends
the section number to the number of the result. All result-type statements
(propositions, corollaries, and so on) are sequenced together, but definitions,
examples, and the like have their own sequence. The “sequential numbering”
scheme does not place the section number with each result, but numbers them
throughout the article in a single sequence. Each type of result gets its own
sequence. There is also a layout that dispenses with numbering of statements
altogether.

Beamer Layout for presentations

Broadway Layout for writing plays. It is not an existing I TEX document class, but
a new one that is distributed with LyX.

Chess Layout to write about chess games

Curriculum vitae classes to create curriculum vitae

Elsarticle Layout for journals of the Elsevier publishing group
Foils Used to make transparencies

Hollywood Used to type spec scripts for the US film industry. It is not an existing
KTEX document class, but a new one that is distributed with LyX.

IEEEtran Layout for the journals published by the Institute of Electrical and Elec-
tronics Engineers (IEEE)

IOP Layout for journals of the Institute of Physics publishing group
Kluwer Layout for journals of the Kluwer publishing group

KOMA-Script a replacement for the standard classes, offers many useful features
like caption formatting, automatic print space calculation etc. (Is used by this
document.)

Memoir another replacement for the standard classes

Powerdot Layout for presentations

10
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REVTeX is used to write articles for the publications of the American Physical
Society (APS), American Institute of Physics (AIP), and Optical Society of
America (OSA). This class is not completely compatible with all Iy X features.

Slides Used to make transparencies

SPIE Proceedings Layout for the journals published by The International Society
for Optical Engineering (SPIE)

Springer Layouts for journals of the Springer publishing group

We will not go into detail about how to use these different document classes here.
You can find details about the non-standard classes in Chapter 6 of the Additional
Features manual. Here, we will settle for a list of some of the common properties of
all of the document classes.

3.1.2.2. Availability

You will probably find that many of the document classes listed under Document >
Settings> Document Class are marked as “Unavailable”. If you open a document that
uses such a class, you will receive a warning saying that there are files that are
required to produce output that are not installed. So it may seem that something is
wrong.

Nothing is wrong. LyX includes many more document classes than you will ever
need to use, and some of them, like IOP, are highly specialized. IyX tries to support
as many different types of documents as possible, and it includes almost one hundred
different layout files, with a growing number. No IXTEX distribution will install by
default all files that might be needed by some document class. There are just too
many of them. That is why some of the document classes are unavailable.

If there is a document class you would like to use that is marked as "Unavailable”,
you just need to install the appropriate package files. The easiest way to find out
which files you need to install is to use that document class for a new file. IyX will
display a dialog that will list the missing files. See section “Installing new KTEX files”
in of the Customization manual for information on how to install them.

Although Ly X provides support for many different sorts of documents, it does not
include support for every document class people might want to use. For example,
many universities provide IKTEX class files to be used for dissertations submitted
to those universities. The IyX team cannot write layout files to support every one
of these. There are too many. Fortunately, users can write their own layout files,
and many users have done so. Chapter 5 of the Customization manual contains
information on how to create layout files.

3.1.2.3. Modules

Modules load additional features that are not by default available in the chosen
document class. For example you might want to write Braille (embossed printing)

11
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in a document. This is not available in any document class, so you have to load
the corresponding module in the Modules section of the Document>Settings dialog.
Highlighting a module in the dialog will bring up a description of what it does.

Some modules require KTEX packages or file format converters that are not always
installed by default. LyX will warn you if you do not have a needed package or
converter, and it will tell you what exactly you are missing. You can still use the
module while editing your file, but you will not be able to export to PDF or print
your document, since LyX will not be able to compile the BKTEX file without the
missing prerequisites. If you want to be able to produce this kind of output, then you
need to install the missing prerequisites and then reconfigure LyX by selecting Tools >
Reconfigure. See section “Installing new IXTEX files” of the Customization manual for
more information on installing needed packages.

Note: Some modules require other modules, and some pairs of modules are in-
compatible. IyX will advise you about these things.

3.1.2.4. Local Layout

Modules are to LyX much as packages are to TEX: They are intended to be used in
a variety of different documents. If you often find yourself needing the same sort of
thing in different documents, you should consider writing a module for this purpose.
Sometimes, however, a particular document has very special needs, but you need a
specific inset or character style only that one time. You want something that is like
a document’s own KTEX preamble. What you want is Iy X’s “Local Layout”. See
section Local Layout of the Customization manual for information on how to use it.

3.1.2.5. Properties

Each class has a default set of options. Here’s a quick table describing them:

\ | Page style | Sides | Columns | Max. sectioning level |

article Plain One One Section
report Plain One One Chapter
book | Headings | Two One Chapter
letter Plain One One none

You're probably also wondering what “Max. sectioning level” means. There are
several paragraph environments used to create section headings. Different document
classes allow different types of section headings. Only two use the Chapter heading;
the rest do not and begin instead with the Section heading. Some document classes,
such as the ones for letters, don’t use any section headings. In addition to Chapter
and Section headings, there are also Subsection headings, Subsubsection headings, and
so on. We will describe these headings fully in section 3.3.4.

12
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3.1.3. Document Layout

The most important properties of document classes are set in the menu Document >
Settings. There in the Class options field under Documents Class, you can enter special
options for your document class in a comma-separated list. This is only necessary if
LyX doesn’t support special options you want to use for your document. To learn
more about your favorite KXTEX-class and its options, you have to read its manual.

The drop box Headings style in the Document > Settings dialog under Page Layout
controls what sorts of headings and page numbers go on a page. You can choose
between the following five options:

Default  Use default page style of current class.
Empty No page numbers or headings.
Plain Page numbers only.

Headings Page numbers and either the current chapter or section title and number.
Whether LyX uses the current chapter or the current section depends on
the maximum sectioning level of the class.

Fancy This allows you to define fully customizable headers and footers if you have
the IXTEX-package fancyhdr installed. How they are defined is explained
in section 6.11.

The separation of paragraphs is described in section 3.2.2.

3.1.4. Paper Size and Orientation

You can find the following options in the menu Page Layout of the Document > Settings
dialog:

Paper Format What size paper to print on. The choices are

o Default
o AO- A6
« BO-B6
« CO-C6

o US letter, US legal, US executive
« JIS BO - JIS B6

e Custom
Orientation To choose whether to output as Landscape or as Portrait.

Two-sided document Adjusts the print space to print both sides of paper. That means
that the print space for odd- and even-numbered pages is different.

13
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3.1.5. Margins

Paper margins are set in the menu Document > Settings.

If you use a KOMA-Script document class, you can use the default settings. Be-
cause KOMA-Script calculates then the print space automatically by taking the paper
format and the font size into account.

3.1.6. Important Note

If you change a document class, yX has to convert everything into the new class.
That includes the paragraph environments. Some paragraph environments are stan-
dard, in so far as all of the document classes have them; but some classes have special
paragraph environments. If this is the case, and you change the document class, [yX
will mark the paragraphs whose styles it no longer understands as “unknown”. The
name of the style is retained, in case you should want to go back to the old class.
But these paragraphs will be output with no special formatting, so you will either
need to create a new style yourself or else convert these paragraphs manually to a
style present in your new document class.

3.2. Paragraph Indentation and Separation

3.2.1. Introduction

Before describing all of the various paragraph environments, we’d like to say a word
or two about paragraph indentation.

Everyone seems to have their own convention for separating paragraphs. Most
Americans indent the first line of a paragraph. Others don’t indent but put extra
space between the paragraphs. If you choose indentation for paragraphs the first
paragraph of a section, or after a figure, an equation, a table, a list, etc., is not
indented. Only a paragraph following another paragraph gets indented. Note that
the indentation behavior is different when you use another document language than
English. IXTEX takes care that the indentation follows the rules of the used language.

The space between paragraphs, like the line spacing, the space between headings
and text — in fact, all of the spacings for just about everything are pre-coded into
LyX. As we said, you don’t worry about how much space to add between what. LyX
takes care of that. In fact, these pre-coded vertical spacings aren’t a single number
but a range. That way, LyX can squish or stretch the space between lines to make
sure figures fit on a page with text, so that sections don’t start at the bottom of a
page, and so on.! However, pre-coded doesn’t mean you can’t change them. LyX
gives you the ability to globally change all of these pre-coded spacings. We will
explain more later.

'ATEX does this when LyX goes to produce a printable file.
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3.2.2. Paragraph Separation

To separate paragraphs, select Indent or Skip in the submenu Text Layout of the dialog
Document > Settings to indent paragraphs or add extra space between paragraphs,
respectively.

3.2.3. Fine-Tuning

You can also change the separation method of a single paragraph. Open the Editr>
Paragraph Settings dialog and toggle the Indent Paragraph option to change the state
of the current paragraph (shortcut undefiniert). If paragraphs have no indentation
but use extra space for separation, this button will be ignored (you can’t indent a
single paragraph by toggling this).

You should only need to change the indentation method for a single paragraph if
you need to do some fine-tuning.

3.2.4. Line Spacing

In the Document > Settings dialog you can set the line spacing in the submenu Text Lay-
out.?

3.3. Paragraph Environments

3.3.1. Overview

Paragraph environments correspond to the

\begin{ environment} ... \end{environment}
command sequence in KTEX files. If you don’t know IXTEX, or the concept of a
paragraph environment is totally alien to you, we urge you to read the Tutorial. The
Tutorial also contains many more examples than this section does.

A paragraph environment is simply a “container” for a paragraph which gives that
paragraph certain properties. This can include a particular style of font, different
margins, a numbering scheme, labels, and so on. Additionally, you can “nest” the
different environments inside one another, allowing one environment to inherit some
of the properties of another. The different paragraph environments totally replace
the need for messy tab stops, on the fly margin adjustment, and other hold-overs
from the days of typewriters. There are several paragraph environments that are
specific to a particular document type. We will only be covering the most common
ones here.

. Standard
To choose a new paragraph environment, use the pull-down box * at

the left end of the toolbar. LyX will change the environment of the entire paragraph

2You need to have the INTX-package setspace installed to use this feature.
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in which the cursor sits. You can also change the environment of an entire group of
paragraphs if you select them before choosing the new environment.

Note that hitting Return will typically create a new paragraph using the Stan-
dard paragraph environment. We say “typically” because if you are in one of these
environments:

¢ Quote

e Quotation
o Verse

o ltemize

o Enumerate
o Description
o List

Ly X keeps the old paragraph environment when you hit Return, rather than resetting
it to Standard. LyX will still reset the nesting depth, however. Usually, starting a
new paragraph resets both the paragraph environment and the nesting depth (for
more on nesting see section 3.4). At the moment, all this is context-specific; you're
better off expecting Return to reset the paragraph environment and depth. If you
want a new paragraph to keep the current environment and depth, use Alt+Return
instead.

3.3.2. Standard

The default paragraph environment is Standard for most classes. It creates a plain
paragraph. If InX resets the paragraph environment, this is the one it chooses. In
fact, the paragraph you're reading right now (and most of the ones in this manual)
are in the Standard environment.

You can nest a paragraph using the Standard environment in just about anything
else, but you can’t really nest anything in a Standard environment.

3.3.3. Document Title

A TTEX title page has three parts: the title itself, the name(s) of the author(s) and a
“footnote” for thanks or contact information. For certain types of documents, KTEX
places all of this on a separate page along with today’s date. For other types of
documents, the title “page” goes at the top of the first page of the document.

LyX provides an interface to the title page commands through the paragraph en-
vironments Title, Author, and Date. Here’s how you use them:

o Put the title of your document in the Title environment.
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e Put the author name in the Author environment.

o If you want the date to have a certain appearance, want to use a fixed date, or
want other text to appear in place of today’s date, put that text in the Date
environment. Note that using this environment is optional. If you don’t provide
any, KTEX will automatically insert today’s date. If you don’t want any date,
add the line

\date{}

to the preamble of your document (menu Document > Settings)

You can use footnotes to insert “thanks” or contact information.

3.3.4. Headings

There are several paragraph environments for producing section headings. [yX takes
care of the numbering for you.

3.3.4.1. Numbered Headings

There are 7 numbered types of section headings. They are:
1. Part
2. Chapter
3. Section
4. Subsection
5. Subsubsection
6. Paragraph
7. Subparagraph

LyX labels each heading with a series of numbers, separated by periods. The num-
bers describe where in the document you are. Unlike the other headings, parts are
numbered with Latin letters.

Headings all subdivide your document into different pieces of text. For example,
suppose you're writing a book. You group the book into chapters. [yyX does similar

grouping:
o Part is divided into either Chapters or Sections
o Chapters are divided into Sections
o Sections are divided into Subsections

o Subsections are divided into Subsubsections
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o Subsubsections are divided into Paragraphs
o Paragraphs are divided into Subparagraphs

Note: Not all document types use the Chapter heading as the maximum sectioning
level. In that case the Section is the top-level heading.

So, if you use the Subsubsection environment to label a new sub-subsection, IxX
labels it with its number, along with the number of the subsection, section, and, if
applicable, chapter that it’s in. For example: the fifth section of the second chapter
of this book has the label “2.5”.

3.3.4.2. Unnumbered Headings

The unnumbered section headings have a “*” at the end of their name. They work

the same as their numbered counterparts but will not appear in the table of contents,
see section 6.2.

3.3.4.3. Changing the Numbering

You can also alter which sectioning levels get numbered and which ones appear in
the Table of Contents. Now, this doesn’t remove any of the levels; that’s preset in
the document class. Certain classes start with Chapter and go down to the Subpara-
graph level. Others start at Section. Similarly, not all document classes number all
sectioning levels. Most don’t number Paragraph or Subparagraph. This is something
you can change.

Open the Document > Settings dialog. Under Numbering & TOC you will see two
counters. The one named Numbering controls how far down in the sectioning hierarchy
LyX numbers a section heading. The other one controls the appearance of the section
headings in the table of contents.

3.3.4.4. Short Titles of Headings

Some section or chapter titles, such as this one, can get quite long. This can cause
trouble when there is limited horizontal space. For example, if the header of the
page is set to show the current section title, a long title will protrude over the page
margins and look awful.

KETEX allows you to specify a short title for section headings. This short title is used
in the header and in the actual table of contents, avoiding the problem mentioned. To
specify a short title, use the menu Insert>Short Title. This will insert a box labeled
“opt” (stands for “optional”) which you can use to enter the short title text. This
also works for captions inside floats.

The title of this section is a good example of using this feature.
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3.3.4.5. Special Information

The following information applies to all section headings:

e You cannot do any nesting with these environments.
e You cannot use a margin note in any of these environments.
e You can only use inline math in these environments.

e You can use labels and cross-references to refer to their numbers.

3.3.5. Quotes and Poetry line spacing

LyX has three paragraph environments for writing poetry and quotations. They are
Quote, Quotation, and Verse. Forget the days of changing line spacing and twiddling
with margins. These three paragraph environments already have those changes built-
in. They all widen the left margin and add a bit of extra space above and below the
text they contain. They also allow nesting, so you can put a Verse in a Quotation, as
well as in some other paragraph environments.

There is another feature of these three paragraph environments: they do not reset
to Standard when you start a new paragraph. So, you can type in that poem and
merrily hit Return without worrying about the paragraph environment changing on
you. Of course, that means that, once you are done typing in that poem, you have
to change back to the Standard environment yourself.Quote and Quotation

Now that we’ve described the similarities of these three environments, it’s time for
the differences. Quote and Quotation are identical except for one difference: Quote
uses extra spacing to separate paragraphs and never indents the first line. Quotation
always indents the first line of a paragraph and uses the same line spacing throughout.

Here’s an example of the Quote environment:

This is in the Quote environment. I can keep writing, extending this line
out further and further until it wraps. See — no indentation!

Here’s the second paragraph of this quote. Again, there’s no indentation,
but there is extra space between me and the other paragraph.

Here’s another example, this time in the Quotation environment:

This is in the Quotation environment. If I keep writing, you will see
the indentation. If your country uses a writing style that shows off new
paragraphs by indenting the first line, then Quotation is the environment
for you! Well, you'd use it if you were quoting other text.

Here’s a new paragraph. I could ramble on and on, like a politician at
election time. If I did that, though, you’d get bored.

As the examples show, Quote is for those people who use extra space to separate
paragraphs. They should put quotes in the Quote environment. Those who use in-
dentation to mark a new paragraph should use the Quotation paragraph environment
for quoted text.
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3.3.5.1. Verse

Verse is a paragraph environment for poetry, rhymes, verses, and so on. Here’s an
example:

This is in Verse

Which I did not rehearse!

It could be much worse. This line could be long, very long, oh so long,
so very long that it wraps around. It looks okay on screen, but in the
printed version, the extra lines are indented a bit more than the first.
Okay, so it’s turned to prose and doesn’t rhyme anymore. So sue me.

To break a line
And make things look fine
Use Ctrl+Return.

As you can see, Verse does not indent both margins. Each stanza of the verse or
poem is in its own paragraph. To separate the individual lines of a stanza, use the
break-1line function Ctrl+Return.

3.3.6. Lists

LyX has four different paragraph environments for creating different kinds of lists. In
the Itemize and Enumerate environments, LyX labels your list items with bullets or
numbers, respectively. In the Description and List environments, IyX lets you provide
your own label. We will present the individual details of each type of list next after
describing some general features of all four of them.

3.3.6.1. General Features

The four paragraph environments for lists differ from the other environments in sev-
eral ways. First, IyX treats each paragraph as a list item. Hitting Return does not
reset the environment to Standard but keeps the current environment and creates a
new list item. The nesting depth is hereby kept. If you want to keep the paragraph
environment but reset the current nesting depth, you can use Alt+Return to break
paragraphs.

You can nest lists of any type inside one another. In fact, IyX changes the labels
on some list items depending on how it is nested. If you intend to use any of the list
paragraph environments, we suggest you read all of section 3.4.

3.3.6.2. Itemize

The first type of list we will describe in detail is the Itemize paragraph environment.
It has the following properties:

o Each item has a particular bullet or symbol as its label.
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— LyX uses the same symbol for all of the items in a given nesting level.

— The symbol appears at the beginning of the first line.

o The items can have any length. IyX automatically offsets the left margin of
each item. The offset is always relative to whatever environment the ltemize
list may be in.

o If you nest an Itemize environment inside another ltemize environment, the label
changes to a new symbol.

— There are four different symbols for up to a four-fold nesting.
— LyX always shows the same symbol on screen.

— See section 3.4 for a full explanation of nesting.

Of course, that explanation was also an example of an Itemize list. The ltemize
environment is best suited for lists where the order doesn’t matter.

We said that different levels use different symbols as their label. Here’s an example
of all four possible symbols.

o The label for the first level ltemize is a large black dot, or bullet.

— The label for the second level is a dash.
* The label for the third is an asterisk.
The label for the fourth is a centered dot.
x Back out to the third level.

— Back to the second level.
e Back to the outermost level.

These are the default labels for an Itemize list. You can customize these labels in the
Document > Settings dialog in the submenu Bullets.

Notice how the space between items decreases with increasing depth. We will
explain nesting and all the tricks you can do with different depths in section 3.4.

3.3.6.3. Enumerate

The Enumerate environment is used to create numbered lists and outlines. It has
these properties:

1. Each item has a numeral as its label.

a) The label type depends on the nesting depth.

2. IyX automatically counts the items for you and updates the label as appropri-
ate.
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3. Each new Enumerate environment resets the counter to one.

4. Like the ltemize environment, the Enumerate environment:

a) Offsets the items relative to the left margin. Items can have any length.
b) Reduces the space between items as the nesting depth increases.

c) Uses different types of labels depending on the nesting depth.

d) Allows up to a four-fold nesting.

Unlike the Itemize environment, Enumerate shows the different labels for each item in
LyX. Here is how Ly X labels the four different levels in an Enumerate:

1. The first level of an Enumerate uses Arabic numerals followed by a period.

a) The second level uses lower case letters surrounded by parentheses.
i. The third level uses lower-case Roman numerals followed by a period.
A. The fourth level uses capital letters followed by a period.

B. Again, notice the decrease in the spacing between items as the
nesting depth increases.

ii. Back to the third level
b) Back to the second level.

2. Back to the outermost level.

Once again, you can customize the type of numbering used in the Enumerate envi-
ronment. It involves adding commands to the IXTEX preamble (see the Additional
Features manual). As stated earlier, such customization only shows up in the printed
version, not in LyX.

There is more to nesting Enumerate environments than we’ve stated here. You
should read section 3.4 to learn more about nesting.

3.3.6.4. Description

Unlike the previous two environments, the Description list has no fixed label. Instead,
LyX uses the first “word” of the first line as the label. Here’s an example:

Example: This is an example of the Description environment.

LyX typesets the label in boldface and puts extra space between it and the rest of
the line.

With the first “word” it is meant that the first hit of the Space key ends the label if
you are at the beginning of the first line of an item. If you need to use more than one
word in the label use a Protected Blank. (Use either or the menu Insert > Formatting
Protected Space, see section 3.5.1 for more info.) Here is an example:
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Second Example: This one shows how to use a Protected Blank in the label of a
Description list item.

Usage: You should use the Description environment for things like definitions and
theorems. Use it when you need to make one word in particular stand out in
the text that describes it. It’s not a good idea to use a Description environment
when you have an entire sentence that you want to describe. You're better off
using ltemize or Enumerate and nesting several Standard paragraphs into them.

Nesting: You can nest Description environments inside one another, nest them in
other types of lists, and so on.

Notice that after the first line, IyX indents subsequent lines, offsetting them from
the first line.

3.3.6.5. The LyX List

The List environment is a IyX extension to ETEX.

Note: When you are using a KOMA-Script document class, like in this document,
the List environment is named Labeling.

Like the Description environment the List environment has user-defined labels for
each list item. There are the following properties of this list environment:

item labels LyX uses the first “word” of each line as the item label. The first Space
after the beginning of the first line of an item marks the end of the label.
If you need to use more than one word in an item label, use a protected
blank as described above.

margins As you can see, LyX uses different margins for the item label and the body
of the item text. The body of the text has a larger left margin, which is
equal to the default label width plus a little extra space.

label width IyX uses the width of the label, or the default width, whatever is larger.
If the label width is larger, the label “extends” into the first line. In other
words, the text of the first line isn’t aligned with the left margin of the
rest of the item text.

default width You can set the default label width to ensure that the text of all items
in a List environment has the same left margin.
To change the default width, select all items in the list. Now open the Edit>
Paragraph Settings dialog. The text in the box Longest label determines the
default label width. You can use the text of your largest label here, but
you can also use the letter “M” multiple times instead. The M is the widest
character and is a standard unit of widths in IXTEX. By using “M” as the
unit of width you don’t need to keep changing the contents of Longest label
every time you alter a label in a List environment.
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The predefined default width is the length of “00.00.0000” (equal to 6 M).
Note: Setting the cursor into a list item to change only its label width
will only change the width inside IyX but not in the output.

You should use the List environment the same way as the Description list: When you
need one word to stand out from the text that describes it. The List environment
gives you another way to do this, using a different overall layout.

You can nest List environments inside one another, nest them in other types of
lists, and so on. They work just like the other list paragraph environments. Read
section 3.4 to learn about nesting.

There is yet another feature of the List environment: As you can see in the exam-
ples, Ly X left-justifies the item labels by default. You can use additional HFills to
change how LyX justifies the item label. Hfills are documented in section 3.5.2. Here
are some examples:

Left The default for List item labels.
Right One HFill at the beginning of the label right justifies it.

Center One HFill at the beginning of the label and one at the end centers it.

3.3.7. Customized Lists

To use the features described in this section, you must load the module Customisable
Lists (enumitem) in the document settings. This loads the features of the IXTEX-
package enumitem.

3.3.7.1. Custom Enumerate Lists

The default numbering of numbered lists can be changed by adding an optional
argument (menu Insert>Short Title) to the first item of each level in the list. There
you add the command

label=\roman{enumi}

in TEX Code (shortcut Ctrl+L).3 enumi is hereby the counter of the enumeration in
the first level. The command \roman outputs the counter as small Roman numeral.
For capital Roman numerals replace in the command above \roman by \Roman.
For Arabic numerals use \arabic. To “number” items with capital or small Latin
letters use \ Alph or \alph, respectively.
Note: You can only number 26 items with Latin letters, because this numbering is
limited to single letters.

To change the numbering for the list sublevels, replace the ’i’ in the command by
the small Roman numeral of the level (enumi, enumii, enumiii, enumiv).

As example a list with custom numbering;:

3For more about TREX Code, look at section 6.10.
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#A# Level 1

A.1 Level 2
A.2 Level 2
1 Level 3
i) Level 4

For this list these commands were used:
label=\#\Alph{enumi}\#
label=\ Alph{enumi}.\arabic{enumii}
label=\bf{\arabic{enumiii} }
label=\emph{\roman{enumiv})}
where the command \emph{} makes the label emphasized and \bf{} makes it
bold.
Note: When you changed the label of a list level, it will be used for all following
lists until you change the definition.

3.3.7.2. Resumed Enumeration

Enumerations can be resumed after intermediate paragraphs:
1. first
2. second

regular text
3. resumed

To resume an enumeration, use the style Enumerate-Resume. Its numbering appears
in blue within IyX to indicate that it is a resumed list and that the numbering will
not be correct in IyX, but in the output.

Note: If there is no previous enumeration to resume, you will get a IXTEX error.

Perhaps you might want to resume the list with a different number than the next
one. Or you want to start a new enumeration with a defined number. This is possible
by adding an optional argument to the first list item of a normal enumeration. There,
insert the command

start=number

where number is the number with which you want to resume the list. An example:

1. first item
2. second item
Enumeration starting at a given value:

4. This enumeration starts at 4
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3.3.7.3. List Spacing

In some cases you might want less or more vertical space between the items of a list.
For example if the default space is too much in your opinion in this case:

o A bullet list

« with standard spacing

You can decrease the space by adding an optional argument to the first item of the
list. Add there the command nolistsep to get no additional list space like in this
example:

o A bullet list

o without additional

» vertical space
To add space you can use several other commands provided by the IXTEX-package
enumitem. For more info see its documentation, [12].

There are also many commands available to change the horizontal spacing and
indentation. Here is an example where the indentation was changed to that of the
paragraphs in the document and the label separation was set to 2cm so that the
number is in the page margin:

An enumeration

with negative indentation

3.3.7.4. Further Customization

You can also change the style of description lists. The command
font=definition
changes the description label font, the command
style=definition
sets the list style.
An example where the command
font=\itshape, style=nextline
is used:

lonizing radiation:
Ionizing radiation consists of particles or electromagnetic waves that are ener-
getic enough to detach electrons from atoms or molecules, therefore ionizing
them.

Reference counting:
In computer science, reference counting is a technique of storing the number
of references, pointers, or handles to a resource such as an object, block of
memory, disk space or other resource.

There are many more commands and features provided by the KTEX-package enu-
mitem. For more info see its documentation, [12].
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3.3.8. Letters
3.3.8.1. Address and Right Address: An Overview

Although IxX has document classes for letters, we've also created two paragraph
environments called Address and Right Address. To use the letter class, you need to
use specific paragraph environments in a specific order, otherwise IXTEX gags on the
document. In contrast, you can use the Address and Right Address paragraph environ-
ments anywhere with no problem. You can even nest them inside other environments,
though you can’t nest anything in them.

Of course, you're not limited to using Address and Right Address for letters only.
Right Address, in particular, is useful for creating article titles like those used in some
European academic papers.

3.3.8.2. Usage

The Address environment formats text in the style of an address, which is also used for
the opening and signature in some countries. Similarly, the Right Address environment
formats text in the style of a right-justified address, which is used for the sender’s
address and today’s date in some countries. Here’s an example of each:

Right Address

Who I am

Where I am

When is it? What is today?

That was Right Address. Notice that the lines all have the same left margin, which
LyX sets to fit the largest block of text on a single line. Here’s an example of the
Address environment:

Who are you
Where do I send this
Your post office and country

As you can see, both Address and Right Address add extra space between them-
selves and the next paragraph. If you hit Return in either of these environments,
LyX resets the nesting depth and sets the environment to Standard. This makes
sense, since Return is the break-paragraph function, and the individual lines of an
address are not paragraphs. Thus, you have to use break-1line (Ctrl4+Return or For-
matting Character > Line Break from the Insert menu) to start a new line in an Address
or Right Address environment.

3.3.9. Academic Writing

Most academic writing begins with an abstract and ends with a bibliography or list
of references. LyX contains paragraph environments for both of these.
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Abstract

This is an abstract. As you can see, it is
printed in a smaller font size than the other
paragraph types.

Also several paragraphs are possible in the
abstract.

This is a “Standard” paragraph to visualize the differ-
ences in the font size.

Figure 3.1.: Paragraph in the Abstract environment

3.3.9.1. Abstract

The Abstract environment is used for the abstract of an article. Technically, you could
use this environment anywhere, but you really should only use it at the beginning of
the document, after the title. Also, don’t bother trying to nest Abstract in anything
else or vice versa. It will not work. The Abstract environment is only useful in the
article and report document classes. The book document classes ignores the Abstract
completely, and it’s utterly silly to use Abstract in a letter document class.

The Abstract environment does several things for you. First, it puts the centered
label “Abstract” above the text. The label and the text of the abstract are separated
by some extra vertical space. Second, it typesets everything in a smaller font, just
as you'd expect. Lastly, it adds a bit of extra vertical space between the abstract
and the subsequent text. Well, that’s how it will appear on the LyX screen. The
appearance in the output depends on the used article or report class.

Starting a new paragraph by hitting Return does not reset the paragraph environ-
ment. The new paragraph will still be in the Abstract environment. So, you will have
to change the paragraph environment yourself when you finish entering the abstract
of your document.

We'd love to give you directly an example of the Abstract environment, but since
this document is in the “book” class, we can’t do this. We inserted it therefore as
figure 3.1. If you've never heard of an “abstract” before, you can safely ignore this
environment.

3.3.9.2. Bibliography

The Bibliography environment is used to list references. Technically, you could use this
environment anywhere, but you really should only use it at the end of the document.
Nesting Bibliography in anything else or vice versa will not work.

When you first open a Bibliography environment, IyX adds a large vertical space,
followed by the heading “Bibliography” or “References,” depending on the document
class. The heading is in a large boldface font. Each paragraph of the Bibliography en-
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vironment is a bibliography entry. Thus, hitting Return does not reset the paragraph
environment. Each new paragraph is still in the Bibliography environment.

There is another, usually better way to include references in your document by us-
ing a BibTEX database. For more information on that, and for a detailed description
of IyyX’s bibliography handling, have a look at section 6.5.

3.3.10. LyX-Code

The LyX-Code environment is another [y X extension. It type-sets text in a typewriter-
style font. It also treats the Space key as a fixed whitespace;* this is the only case in
which you can type multiple whitespaces in IxX. If you need to insert blank lines,
you will still need to use Ctrl4+Return (the break-1line function). Return breaks para-
graphs. Note, however, that Return does not reset the paragraph environment. So,
when you finish using the LyX-Code environment, you will need to change the para-
graph environment yourself. Also, you can nest the LyX-Code environment inside of
others.
There are a few quirks with this environment:

» You cannot use Ctrl4+Return at the beginning of a new paragraph (i. e. you can’t
follow Return with a Ctrl+Return).

e You can’t follow a Ctrl+Return with a Space.
— Use a Return to begin a new paragraph, then you can use a Space.
— Or: use instead.

e You can’t have an empty paragraph or an empty line. You must put at least
one Space in any line you want blank. Otherwise, XTEX generates errors.

» You cannot get the typewriter double quotes by typing " since that will insert
real quotes. You get the typewriter double quotes with Ctrl+".

Here is an example:

#include <stdio.h>

int main(void)

{
printf ("Hello World!'\n");
return O;

b

4In the LyX-Code environment, the Space key is treated as a Protected Blank instead of an end-of-
word marker.
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This is just the standard “Hello world!” program.

LyX-Code has one purpose: to typeset code, such as program source, shell scripts,
rc-files, and so on. Use it only in those very special cases where you need to generate
text as if you used a typewriter. For longer parts of programming code, use the listings
inset that is described in the chapter Program Code Listings of the Embedded Objects
manual.

3.4. Nesting Environments

3.4.1. Introduction

LyX treats text as a unified block with a particular context and specific properties.
This allows you to create blocks that inherit some of the properties of another block.
For example you have three main points in an outline, but point #2 also has two
subpoints. In other words, you have a list inside of another list, with the inner list
“attached” to item #2:

1. one

2. two
a) sublist — item #1
b) sublist — item #2

3. three

You put a list inside a list by nesting one list inside the other. Nesting an environment
is quite simple: Select Increase List Depth or Decrease List Depth from the Edit menu
to change the nesting depth of the current paragraph (the status bar will tell you
how far you are nested). Instead of the menu, you can also use the toolbar buttons

%n: and E: or the convenient key bindings Tab and Shift-Tab or Alt+Shift+Right
and Alt+Shift+Left to change the nesting level. The change will work on the cur-
rent selection if you have made one (allowing you to change the nesting of several
paragraphs at once), or the current paragraph.

Note that IxX only changes the nesting depth if it can. If it’s invalid to do so,
nothing happens if you try to change the depth. Additionally, if you change the depth
of one paragraph, it affects the depth of every paragraph nested inside of it.

Nesting isn’t limited to lists. In LyX, you can nest just about anything inside
anything else, as you're about to find out. This is the real power of nesting paragraph
environments.

3.4.2. What You Can and Can’t Nest

Before we fire a list of paragraph environments at you, we need to tell you a little bit
more about how nesting works.
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The question if nesting a paragraph environment is possible, is a bit more compli-
cated than a simple yes or no. There are three types of paragraph environments:

o Completely unnestable

o Fully nestable, you can nest them inside things and you can also nest other
things inside them.

o A third type, you can nest them into other environments, but you can’t nest
anything into them.

Here’s a list of the three types of nesting behavior, and which paragraph environments
have them:

Unnestable Can’t nest them. Can’t nest into them.
« Bibliography
o Abstract
o Title
e Author
e Date

Fully Nestable You can nest them. You can nest other things into them.

o Verse

o Quote

¢ Quotation
o ltemize

o Enumerate
o Description
o List

o LyX-Code

Nestable-Inside You can nest them inside other things. You can’t nest anything
into them.

» Standard
o Part

e Chapter
 Section

o Subsection

e Subsubsection
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o Paragraph

o Subparagraph

o Part*

o Chapter*

o Section*

o Subsection*

o Subsubsection*

o Right Address

« Address
Note: Although it is possible to nest numbered section headings like Chapter, Section,
etc. into e. g. lists, it is highly recommended not to do this because the aim is to create

well-structured documents following typesetting guidelines whereas nested section
headings violate this.

3.4.3. Nesting Other Things: Tables, Math, Floats, etc.

There are several things that aren’t paragraph environments, but which are affected
by nesting anyhow. They are:

e equations
o tables
o figures

(Note: Figures and tables in Floats are not affected by this. Have a look at section 4.6
for more information about Floats.)

LyX can treat these three objects as either a word or as a paragraph. If a figure,
table, or an equation is inline, it goes wherever the paragraph it is in goes.

On the other hand, if you have an equation, figure or table in a “paragraph” of its
own, it behaves just like a “nestable-inside” paragraph environment. You can nest it
into any environment, but you obviously can’t nest anything into it.

Here’s an example with a table:

1. Item One

a) This is (a) and it’s nested.

=

b) This is (b). The table is actually nested inside (a).
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2. Back out again.
If we hadn’t nested the table at all, the list would look like this:

1. Item One

a) This is (a) and it’s nested.

o

1. This is (b). The table is not nested inside (a). In fact, it’s not nested at all.

2. Back out again.

Notice how item (b) is not only no longer nested, but is also the first item of a new
list!

There’s another trap you can fall into: Nesting the table, but not going deep
enough. IyX then turns anything after the table into a new sublist.

1. Item One

a) This is (a) and it’s nested.

on

1. This is (b). The table is actually nested inside Item One, but not inside (a).

2. Back out again.

As you can see, item (b) turned into the first item of a new list, but a new list inside
item 1. The same thing would have happened to a figure or an equation. So, if you
nest tables, figures or equations, make sure you go to the right depth!
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3.4.4. Usage and General Features

Speaking of levels, IyX can perform up to a six-fold nesting. In other words, “level
#67 is the innermost possible depth. Here’s an example to illustrate what we mean:

1. level #1 — outermost

a) level #2
i. level #3
A. level #4
o level #5

— level #6

There are two exceptions to the six-fold nesting limit, and you can see both of them
in the example. Unlike the other fully-nestable environments, you can only perform
a four-fold nesting with the Enumerate and Itemize environments. For example, if we
tried to nest another Enumerate list inside item “A.”, we would get errors.

3.4.5. Some Examples

The best way to explain just what you can do with nesting is by illustration. We
have several examples of nested environments. In them, we explain how we created
the example, so that you can reproduce them.

3.4.5.1. Example 1: The Six-fold Way and Mixed Nesting

#1-a This is the outermost level. It’s a List environment.

#2-a This is level #2. We created it by using Alt+Return followed by Alt+Shift+Right.

#3-a Thisislevel #3. This time, we just hit Return, then used Alt+Shift+Right
twice in a row. We could have also created it the same way
as we did the previous level, by hitting Alt4+Return followed by

Alt+Shift+Right.

This is actually a Standard environment, nested inside of “#3-
a”. So, it’s at level #4. We did this by hitting Alt+Return,
then Alt+Shift+Right, then changing the paragraph environment
to Standard. Do this to create list items with more than one para-
graph — it also works for the Description, Enumerate, and Itemize
environments!

Here’s another Standard paragraph, also at level #4, made with
just a Alt+Return.
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#4-a This is level #4. We hit Alt+Return and changed the para-
graph environment back to List. Remember — we can’t nest
anything inside a Standard environment, which is why we're
still at level #4. However, we can keep nesting things inside

“#3-&”.
#5-a This is level #5. ..

#6-a ...and this is level #6. By now, you should
know how we made these two.

#5-b Back to level #5. Just hit Alt+Return followed by a
Alt+Shift+Left.

#4-b After another Alt+Return followed by a Alt+Shift+Left, we're
back at level #4.

#3-b Back to level #3. By now it should be obvious how we did this.
#2-b Back to level #2.

#1-b And last, back to the outermost level, #1. After this sentence, we will hit
Return and change the paragraph environment back to Standard to end the
list.

We could have also used the Description, Quote, Quotation, or even the Verse envi-
ronment in place of the List environment. The example would have worked exactly
the same.

3.4.5.2. Example 2: Inheritance

This is the IyX-Code environment, at level #1, the outermost
level. Now we will hit Re-

turn, then Alt+Shift+Right, after which, we will change to the Enu-
merate environment.

1. This is the Enumerate environment, at level #2.

2. Notice how the nested Enumerate not only inherits its
margins from its parent environment (LyX-Code), but also
inherits its font and spacing!

We ended this example by hitting Return. After that, we needed to reset the para-
graph environment to Standard and reset the nesting depth by using Alt+Shift+Left
once.

3.4.5.3. Example 3: Labels, Levels, and the Enumerate and ltemize
Environments

1. This is level #1, in an Enumerate paragraph environment. We're actually going
to nest a bunch of these.
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a) This is level #2. We used Alt+Return followed by Alt+Shift4+Right. Now,
what happens if we nest an Itemize environment inside of this one? It will
be at level #3, but what will its label be? An asterisk?

o No! It’s a bullet. This is the first Itemize environment, even though
it’s at level #3. So, its label is a bullet. (We got here by using
Alt+Return, then Alt+Shift+Right, then changing the environment to
ltemize.)

— Here’s level #4, produced using Alt+Return, then Alt+Shift-+Right.
We will do that again. ..

i. ...to get to level #5. This time, however, we also changed
the paragraph environment back to Enumerate. Notice the type
of numbering, it is lowercase Roman, because we are in the
thirdfold Enumerate environment (i.g. it is an Enumerate inside
an Enumerate inside an Enumerate).

ii. What happens if we don’t change the paragraph environment,
but decrease the nesting depth? What type of numbering does
LyX use?

iii. Oh, as if you couldn’t guess by now, we’re just using Alt+Return
to keep the current environment and depth but create a new
item.

iv. Let’s use Alt+Shift4Left to decrease the depth after the next
Alt-+Return.

i. This is level #4. Look what type of label IyX is using!

i. This is level #3. Even though we’ve changed levels, LiyX is still using
a lowercase Roman numeral as the label. Why?

ii. Because, even though the nesting depth has changed, the paragraph
is still a thirdfold Enumerate environment. Notice, however, that LyX
did reset the counter for the label.

b) Another Alt+Return Alt+Shift+Left sequence, and we’re back to level #2.
This time, we not only changed the nesting depth, but we also moved back
into the twofold-nested Enumerate environment.

2. The same thing happens if we do another Alt+Return Alt+Shift+Leftsequence
and return to level #1, the outermost level.

Lastly, we reset the environment to Standard. As you can see, the level number
doesn’t correspond to what type of labeling I5yX uses for the Enumerate and Itemize
environments. The number of other Enumerate environments surrounding it deter-
mines what kind of label [y/X uses for an Enumerate item. The same rule applies for
the ltemize environment, as well.
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3.4.5.4. Example 4: Going Bonkers

1. We're going to go totally nuts now. We will not nest as deep as in the other
examples, nor will we go into the same detail with how we did it. (level #1:
Enumerate)

(Return, Alt+Shift+Right, Standard: level #2) We will stick an encapsulated
description of how we created the example in parentheses someplace. For ex-
ample, the two key bindings are how we changed the depth. The environment
name is the name of the current environment. Either before or after this, we
will put in the level.

2. (Return, Enumerate: level #1) This is the next item in the list.

Now we will add verse.
It will get much worse.
(Return, Alt+Shift+Right, Verse: level #2)

Fiddle dee, Fiddle doo.
Bippitey boppitey boo!
(Alt+Return)

Here comes a table:

one-fish ‘ two-fish
red-fish ‘ blue-fish

(Alt+Return, Table, Alt+Shift+Right 3 times, Alt+Return, Verse, Alt+Shift+Left)

3. (Return, Enumerate: level #1) This is another item. Note that selecting a Table
resets the nesting depth to level #1, so we increased the nesting depth 3 times
to put the table inside the Verse environment.

We're now ending the Enumerate list and changing to Quotation. We're
still at level #1. We want to show you some of the things you can do
by mixing environments. The next set of paragraphs is a “quoted letter.”
We will nest both the Address and Right Address environments inside of
this one, then use another nested Quotation for the letter body. We will
use Alt+Return to preserve the depth. Remember that you need to use
Ctrl4+Return to create multiple lines inside the Address and Right Address
environments. Here it goes:

1234 Nowhere Rd.
Moosegroin, M'T 00100
9-6-96

Dear Mr. Fizlewitz:
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We regret to inform you that we cannot fill your order for 50 L
of compressed methane gas due to circumstances beyond our
control. Unfortunately, several of our cows have mysteriously
exploded, creating a backlog in our orders for methane. We will
place your name on the waiting list and try to fill your order
as soon as possible. In the meantime, we thank you for your
patience.

We do, however, now have a special on beef. If you are inter-
ested, please return the enclosed pricing and order form with
your order, along with payment.

We thank you again for your patience.

Sincerely,
Bill Hick

That ends that example!

As you can see, nesting environments in LyX gives you a lot of power with just a
few keystrokes. We could have easily nested an ltemize list inside of a Quotation or
Quote, or put a Quote inside of an Itemize list. You have a huge variety of options at
your disposal.

3.5. Spacing, pagination and line breaks

What is a space? While you might be used to pressing the space key anytime you
want to separate two words in ordinary word processors, [iyX offers you more spaces:
Spaces of different width and spaces which can or cannot be broken at the end of
a line. The following sections will show you some examples where those spaces are
useful.

3.5.1. Protected Space

The protected space: It is used to tell LyX (and BETEX) not to break the line at that
point. This may be necessary to avoid unlucky line breaks, like in:

Further documentation is given in section
6.5.

Obviously, it would be a good thing to put a protected space between “section” and
“6.5”. A protected space is set with Insert>Formatting>Protected Space (shortcut
Ctrl+Space).

3.5.2. Horizontal Space

All horizontal spaces can be inserted with the menu Insert> Formatting > Horizontal
Space. The length units are listed in Appendix D.
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3.5.2.1. Inter-word Space

Some languages (e. g. English) have the typographical convention to add extra space
after an end-of-sentence punctuation mark, and IxyX honors those conventions (see
section 3.9.3.1). Sometimes, you want a normal space nevertheless. In this case,
insert an inter-word space (shortcut Ctrl+Alt+Space).

3.5.2.2. Thin Space

A “thin space” is a blank which has half the size of a normal space (and it is also
“protected”). The typographical conventions in a lot of languages propose the use
of thin spaces in cases where normal spaces would be too wide, for instance inside
abbreviations:

D. E. Knuth has developed our beloved typesetting program.

or between values and units. Compare for example this:
10 kg (thin space)
10 kg (normal space
You can insert thin spaces also with the menu Insert>Formatting> Thin Space
(shortcut Ctrl+Shift+Space).

3.5.2.3. More Spaces

You can furthermore insert the following space types:

Negative thin space A line with a —<— Negative thin space between the arrows.
Enspace (0.5em) A line with a — <« Enspace (0.5em) space between the arrows.
Quad (1em) A line with a — <« Quad (1em) space between the arrows.

QQuad (2em) A line with a — + QQuad (2em) space between the arrows.
Custom space A line with— < 2cm space between the arrows.

Table 3.1 lists the different space sizes.

3.5.2.4. Horizontal Fills

Horizontal fills (HF1ills) are a special IxyX feature for adding extra space in a uniform
fashion. An HFill is actually a variable length space, whose length always equals the
remaining space between the left and right margins. If there is more than one HFill
on a line, they divide the available space equally between themselves.

Here are a few examples of what you can do with them:

This is on the left side This is on the right
Left Middle Right
Left 1/3 Left Right
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Table 3.1.: Width of the different horizontal spaces.

’ Space \ Width ‘
Normal 1/3em
Protected 1/3em
Thin 1/6 em

Negative thin | -1/6em

Enspace (0.5em) | 0.5em
Quad (1em) lem
QQuad (2em) 2em

That was an example in the Quote environment. Here— <is one in
a standard paragraph. It may or may not be apparent in the printed text, but it s
sitting in-between the two arrows.
HFills can be made visible when you choose one of the Fill Pattern in the space
dialog: The following patterns are available:
DOt o
Rule:
Left arrow: <
Right arrow:
Up brace:
Down brace:
Note: If an HFill is at the beginning of a line, and not in the first line in a
paragraph, LyX ignores it. This prevents HFills from accidentally being wrapped
onto a new line. If you need space in this case anyway, set the Protect option in the
space dialog.

~

3.5.2.5. Phantom Space

Sometimes you want to insert space with exactly the length of a phrase. E.g. you
want to create the following multiple choice question:

What is correct English?:

Mr. Edge would have been jumps the gun.
has to be jumped
jumps

So that the choices appear exactly after the phrase “Mr. Edge ”. To get this,
you can use the phantom insets available via the menu Insert > Formatting> Phantom.
In our case insert a horizontal phantom at the beginning of the last two lines and
insert “Mr. Edge ” into the phantom inset (note the space after “Edge”). A phantom
insets prints only the space of its content (like a placeholder). That is why it is
named “phantom”. The normal phantom outputs the width and height of the content
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as space, while the horizontal and vertical variant only outputs the corresponding
dimension.

3.5.3. Vertical Space

To add extra vertical space above or below a paragraph, use the Insert>Formatting >
Vertical Space dialog. There you find the following sizes:

SmallSkip, MedSkip and BigSkip are IXTEX sizes which depend on the font size of
the document. DefSkip is the skip adjusted in the dialog Document > Settings for the
paragraph separation. If you use indentation to separate paragraphs DefSkip is equal
to MedSkip.

VFill is a variable space, set so that the space is maximal within one page. An
example: You have only two short paragraphs on one page with a vfill between them.
Then the first paragraph is placed at the top of the page and the second one at the
bottom, because the space between them is then maximal. VFills work like HFills:
they fill the remaining vertical space on a page with blank space.® If there are several
VFills on a page, they divide the remaining vertical space equally between themselves.
You can therefore use VFills to center text on a page, or even place text 2/3 down a
page.

Custom are custom spaces in units explained in Appendix D.

Note: If the extra vertical space would be in the output at the top/bottom of a
page, the space is only added if you have also checked the option Protect.

3.5.4. Paragraph Alignment

You can change the paragraph alignment with the Edit>Paragraph Settings dialog.
There are five possibilities:

o Justified (shortcut undefiniert)
o Left (undefiniert)

« Right (undefiniert)

Center (undefiniert)

o Default (undefiniert)

The default in most cases is justified alignment, in which the inter-word spacing
is variable and each line of a paragraph fills the region between the left and right
margins. The other three alignments should be self-explanatory, and look like this:

This paragraph is right aligned,
this one is centered,

this one is left aligned.

5HFills are described in section 3.5.2.
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3.5.5. Forced Page Breaks

If you don’t like the way IXTEX does the page breaks in your document, you can
force a page break where you want one. Normally this will not be necessary, because
ITEX is good at page breaking. Only if you use a lot of Floats, XTEX’s page breaking
algorithm can fail.

We recommend not to use forced page breaks until the text is finished and until
you have checked in the preview to see if you really have to change the page breaking.

There are two types of page breaks: One that ends the page without any spe-
cial action. This can be inserted above or below a paragraph via the menu In-
sert> Formatting> New Page. The second type, that is inserted via the menu Insertr
Formatting> Page Break, ends a page but stretches the content of the page, so that
it fills out the complete page. This type is useful to avoid whitespace when a page
break produces a page on which only the last few lines are absent.

You might try to use a page break to ensure that a figure or table appears at the
top of a page. This is, of course, the wrong way to do it. IyX gives you a way of
automatically ensuring that your figures and tables appear at the top of a page (or
the bottom, or on their own page) without having to worry about what precedes or
follows your figure or table. See chapter 4 to learn more about Floats.

3.5.5.1. Clear Page Breaks

Rather than forced page breaks where the content behind the break is placed directly
on the next page, you can also clear pages while breaking them. That means that the
current paragraph is terminated and everything, including unprocessed floats, from
the earlier part of the document are placed behind it, if necessary by adding pages.

You can insert a clear page break with the menu Insert>Formatting> Clear Page.
When you have a two-sided document like a book, you can use the menu Insertr
Formatting> Clear Double Page to insert a clear page break that assures that the next
page is a right-hand page (odd-numbered), if necessary by adding a page.

3.5.6. Forced Line Breaks

Similar to page breaks there are two types of line breaks: One that simply breaks the
line. You can force this line break within a paragraph by selecting Insert > Formatting >
Ragged Line Break or with Ctrl4+-Return. Another type that is inserted via the menu
Insert > Formatting > Justified Line Break breaks the line and stretches it so that it fills
out the whole space between the page margins. This is useful to avoid “fringes” in
justified paragraphs due to possible whitespace introduced by line breaks.

You shouldn’t use forced line breaks to correct IXTEX’s line breaking, as IXTEX
is very good at line breaking. There are, however, a number of situations where
it is necessary to actively set a line break, e.g. in a poem or for an address (see
sections 3.3.5, 3.3.5.1 and 3.3.8.2).
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3.5.7. Horizontal Lines

In the dialog Insert>Formatting > Horizontal Line you can insert horizontal lines. The
line offset is the vertical distance between the line and the baseline of the current
text line or the paragraph. The line settings can be changed by left-clicking on the
line.

3.6. Characters and Symbols

You can directly enter all characters that are available on your keyboard. You can
also use special keyboard maps to be able to enter e. g. characters needed for French
with an English keyboard. See section 6.18.2 for information on how this is done.

For the case where you need a character that is not on your keyboard, you can use
the Symbols dialog via the menu Insert > Special Character>Symbols.

Note: Maybe not all symbols inserted with the symbols dialog can be displayed
when you are using a special screen font in [yX’s preferences. But the inserted
symbols will in every case be displayed in the output.

3.7. Fonts and Text Styles

3.7.1. Font Types

There are two types of fonts:

Vector fonts are fonts, built from outlines of the single glyphs (e.g. characters) in
the font. This means that each glyph is defined using mathematical curves that
are well suited for scaling to any requested size. This mathematical definition is
interpreted by the font renderer and the curve is filled out with pixels according
to the size and glyph. This means that vector fonts will look pretty good in all
sizes. Only at very small sizes where each pixel has to be very carefully com-
puted to provide a good image, it might be hard to provide a good rendering.
That could mean that one only needs to define one font size and scale them.
But to achieve a better quality, many fonts define several font sizes. That im-
proves the appearance because you need more details at large font sizes than
at small ones.

The font types TrueType, OpenType, and Type 1 are vector fonts.

Bitmap fonts on the other hand, are defined by bitmap graphics from the start, so
they will look good at all the sizes they are meant for. However, they don’t
scale well, because in order to scale a glyph, each pixel is enlarged into several
pixels. It is the same effect that happens if you try to enlarge a picture in a
picture manipulation program. In order to relieve this effect, bitmap fonts are
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typically provided in several fixed sizes typically from around 8 pixels high up
to 34 pixels or so high in steps according to what is believed to be useful. The
advantage of bitmap fonts is that no complicated computations are necessary
to display each glyph, so bitmap fonts are thus faster displayed than scalable
fonts. The disadvantage is that sizes that don’t exist as fixed versions have to
be scaled by doubling pixels, and thus look bad.

Bitmap fonts are named Type 3 in PostScript- and PDF-documents.

The result of all this is that bitmap fonts are best for the size they are designed
for, while scalable fonts are good for nearly all sizes. So one needs fewer font size
definitions for scalable fonts. That’s the reason why nearly all text rendering and
typesetting programs use scalable fonts.

To test which fonts are used in a PDF-document, you can have a look into its
document properties.

Many modern typesetting and markup languages have begun to move towards
specifying character styles rather than specifying a particular font. For example,
instead of changing to an italicized version of the current font to emphasize text, you
use an “emphasized style” instead. This concept fits in perfectly with IyX. In IyX,
you do things based on contexts, rather than focusing on typesetting details.

3.7.2. BTEX font support

Traditionally, BTEX uses its own fonts. That is to say, you cannot directly access the
fonts installed on your operating system, but you have to use specific fonts provided
by your IXTEX distribution. The reason is that BKTEX needs some extra information
about the fonts, which have to be provided by additional files and packages. The
downside of this is that your font choice is somewhat limited, compared to usual
word processors. On the other hand this comes with the advantage that the provided
fonts are generally of very good quality, and that KTEX files are very portable across
different machines. Also, the range of fonts supported by traditional IXTEX was
increased a lot meanwhile so that you can find packages for many free and commercial
fonts. In IxyX, only a subset of these are directly selectable via the user interface (see
section 3.7.3 for details). However, all others are available if you enter the respective
ITEX code in the document preamble (please refer to the documentation of your
desired font).

Recent developments brought some new IXTEX engines that are also able to directly
access fonts that are installed for your operating system, namely XeTEX and LuaTgEX.
Both engines are supported by LyX. By using them, you can use theoretically any
OpenType or TrueType font that is installed on your system. The next section
describes how to use these fonts.

Note: In practice, some fonts might fail due to bad metrics and other font defi-
ciencies; so you might have to experiment.

Note: XeTEX and especially LuaTgX, are still rather new and thus not as mature
as traditional ITEX or PDFTEX.
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3.7.3. Document Font and Font size

You can set the document fonts in the Document > Settings dialog. In the Fonts section
of the dialog, you can specify which font should be used for the three different font
shapes — roman (serif), sans serif and typewriter (monospaced) — you can specify
the base font size and scaling factors for (some) sans serif and typewriter fonts if this
is necessary to fit with the roman font.

If you select Use non-TeX fonts, you will have access to the fonts installed on your
operating system. This requires that you use PDF (XeTeX), PDF (LuaTeX) or DVI
(LuaTeX) as the output format, i.e. you will have to have either XeTEX or LuaTgX
installed (see section 3.7.2). You will then not have access to TEX’s own fonts. Note
that IxX then lists all available fonts in each of the three lists (roman, sans serif,
and typewriter), since IxyX cannot determine the family. Also note that the output
might fail with some of the listed fonts, due to the encoding of the fonts and/or font
failures. [yX cannot determine this in advance, so you might need to experiment.

If you use TEX fonts (which is the default), the possible options for the font include
Default and a list of fonts available with your KWTEX distribution. If you select Default,
the font that is preset by the current document class is used. In most cases, this will be
the standard TEX font, known as “Computer Modern” (cm) or “European Computer
Modern” (ec), but some classes preset different default fonts.

As cm and ec are bitmap fonts, they often looks pixelated in PDF output, especially
when you read the PDF in a zoomed size.% To get rid of pixelated fonts, you have to
use a vector font. Depending on how your document should look like, you can either:

o select the Latin Modern fonts, which is the recommended choice if you want to
keep the look of cm/ec. Latin Modern was developed for the KTEX community
in order to replace cm as the default font. It covers a huge range of glyphs
and several font shapes. Except for some details, where the appearance was
improved, Latin Modern looks identical to cm.”

o or select the AE (Almost European) fonts in (the rare) case that Latin Modern is
not available to you or does not work, and you still want to emulate the look
of cm/ec. AE is a virtual font. Virtual means that it “steals” outline cm-glyphs
from other fonts. This has the disadvantage that some characters are missing,
like the French guillemets (“«” and “»”)® and that accented characters are not
one glyph, but built of two characters, the accent and the letter. Therefore you
cannot search for words with accented characters in documents using the AE
fonts. If you search for example for the French word “réve” in a PDF, you will
not get any result, because the PDF-viewer searches for the glyph “ ¢ ” and not
for the glyph “ e + * "

6This problem doesn’t appear if you read PDFs in Adobe Reader version 6 or later, because this
program includes a special bitmap font renderer.

"One difference is improved kerning.

8Loading the IXTX-package aeguill with the document preamble line
\usepackage[ec]{aeguill}
will fix the guillemet problem.
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o If you do not like the look of cm/ec, you can of course select one of the other
provided vector fonts, e. g. Times Roman or Palatino. Most roman vector fonts
will automatically select matching sans serif and typewriter fonts,? but you can
also select your own.

The differences between roman, sans serif and typewriter fonts are explained
in section 3.7.5.

The font Times Roman was originally designed for newspapers. Its glyphs are
thus smaller than glyphs from other fonts in order to fit into the small newspaper
columns. Therefore Times Roman is not the optimal choice for larger documents
like books.

For the font size there are generally four possible values: Default, 10, 11 and 12.
Some classes provide additional sizes. The size of Default depends on the class you
are using. In the standard classes it is equal to the font size 10.

Note that the font size is the base size. That means that LyX scales all other
possible font sizes (such as those used in footnotes, super-, and subscripts) by this
value. You can fine-tune the font size of text parts via the Text Style dialog if needed.
The possible font sizes for text parts are explained in section 3.7.5.

The Default Family selection lets you specify whether the base font of your document
should be roman, sans serif or typewriter. The Default selection uses what is preset
by the class, the other selections override this. In most cases, Default is equal to
roman, but some classes (such as presentation classes) also use other defaults.

The LaTeX font encoding selection is an expert setting which lets you change the
value passed to the IXTEX-package fontenc (see also sec. C.6.3). Normally, you do
not need to change (or even understand) this. Unless you have specific reasons, use
Default.

With some fonts, the checkboxes Use Old Style Figures and Use True Small Caps
are available. These are extra features some fonts provide. If Use Old Style Figures is
checked, old style figures (also known as medieval or text figures) are used. Old style
figures are the numerals (0-9) with ascenders and descenders, which makes them fit
nicely with lower letters. Use True Small Caps determines that real small caps are
used instead of faked small caps made of scaled capitals. Real small caps are often
part of expert font sets; they generally look better than faked small caps but might
have to be purchased separately.

The field CJK allows users of the languages Chinese, Japanese, Korean (CJK) to
specify a font to display the script characters.!”

Note: When you choose a new font or font size, IiyX does not change the screen
font! You will only see a difference in the printed output; this is part of the WYSI-

9These are sometimes just matching other fonts (e.g., Times Roman selects Helvetica for sans serif
text), or different shapes of the same font, i.e. a real font family (e.g. in case of Latin Modern
oder Computer Modern).

10T he font will be the argument for the commands of the KTEX-package CJK. So this has no effect
for the document language Japanese that does not use CJK.

46



3.7. Fonts and Text Styles

WYM concept. I X’s screen fonts can be adjusted in the Tools> Preferences dialog,
see section C.1.2.

3.7.4. Using Different Character Styles

As we've already seen, [y X automatically changes the character style for certain

paragraph environments. LyX supports two character styles, Emphasized and Noun.

You can activate both of these styles via keybindings, the menus, and the toolbar.
To activate the Noun style, do one of the following:

e click on the toolbar button ﬂ@
« use the key binding Alt+Z K

These commands are all toggles. That is, if Noun style is already active, they deac-
tivate it.

One typically uses the Noun style for proper names. For example: “MATTHIAS
ETTRICH is the original author of IyX.”

A more widely used character style is the Emphasized style. You can activate (or
deactivate — it’s also a toggle) the Emphasized style by:

 clicking on the toolbar button I
« using the keybindings Ctrl+E

Normally the Emphasized style is equivalent to an italic font but some document
classes or I{TEX-packages use a different font.

We’ve been using the Emphasized style all over the place in this document. Here’s
one more example:

Do not overuse character styles!

It’s also a warning in addition to an example. One’s writing should parallel ordinary
conversation. Since we don’t all constantly scream at each other, we should also avoid
the common tendency to overuse character style.

You can always reset to the default font using the key binding Alt+Z Space or the
dialog Edit> Text Style.

3.7.5. Fine-Tuning with the Text Style dialog

There are always occasions when you will need to do some fine-tuning, so Ly X gives
you a way to create a custom character style. For example, an academic journal or
a corporation may have a style sheet requiring a sans-serif font be used in certain
situations. Also, writers sometimes use a different font to offset a character’s thoughts
from ordinary dialog.
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Before we document how to use custom character style, we want to issue a warning
yet again: Don’t overuse character styles!
Documents that overuse different fonts and sizes are not well readable and tend to
look as if someone has knocked huge holes in them.

To use custom character styles, open the Edit>Text Style> Customized dialog or

press the toolbar button . There are several boxes on this dialog, each corre-
sponding to a different font property that you can choose. You can choose an option
for one of these properties, or select No change, which keeps the current state of that
property. The item Reset will reset the property to whatever is the default. You can
use this to reset attributes across a bunch of different paragraph environments in a
snap.

The font properties, and their options (in addition to No change and Reset) are:

Family The “overall look” of the font. The possible options are:

Roman  This is the Roman font family. Normally a serif font. It’s also
the default family. (key binding Alt+Z R)

Sans Serif This is the Sans Serif font family. (key binding Alt+Z S)
Typewriter This is the Typewriter font family. (key binding Ctrl+Shift+P)

Series This corresponds to the print weight. Options are:

Medium This is the Medium font series. It’s also the default series.
Bold This is the Bold font series. (key binding Ctrl+B)

Shape As the name implies. Options are:

Upright  This is the Upright font shape. It’s also the default shape.
Italic This is the Italic font shape.

Slanted  This is the Slanted font shape (although it might not be visible
in LyX, this is different from italic).

Small Caps THIS IS THE SMALL CAPS FONT SHAPE.
Size Alters the size of the font. You will find no numerical values here; all
possible sizes are actually proportional to the document font size. Once

again, you don’t feed IyX the details, but a general description of what
you want to do. The options are:

T|ny This is the “Tiny” font size. (key blndlngS AIt"‘S T, A|t+s 1)
Smallest This is the “Smallest” font size. (key blndlng /—\|t+S 2)

Smaller  This is the “Smaller” font size. (key bindings Alt+S Shift+S, Alt+S
3)

Small This is the “Small” font size. (key bindings Alt+S S, Alt+S 4)
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Larger

Largest

Huge

Huger

Increase

Decrease
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This is the “Normal” font size. It’s also the default size. (key
bindings Alt+S N, Alt+S 5)

This is the “Large” font size. (key bindings Alt+S L, Alt+S
6)

This is the “Larger” font size. (key bindings Alt+S
Shift+L, Alt+S 7)

This is the “Largest” font size. (key binding
Alt+S 8)

This is the “Huge” font size. ey

bindings Alt+S H, Alt+S 9)
This is the “Huger” font size. ey
bindings Alt+S Shift+H, Alt+S 0)

This increases the size by one step (for instance, from “Largest”
to “Huge”). (key binding Alt+S +)

This decreases the size by one step (for instance, from “Normal”
to “Small”). (key binding Alt+S -)

We warn you yet again: don’t go crazy with this feature. You should almost never
need to change the font size. LyX automatically changes the font size for different
paragraph environments — use those instead. This is here for fine-tuning only!

Misc Here you can change a few other things at the character level. Options
are:
Emph This is text with emphasize on. This might seem like the same

Underbar

as Italic, but it is actually a bit different. Emphasized is a logical
attribute. That means every document class can define its own
font used for emphasized text. Normally this font is equal to
italic.

This is text with Underbar on. (key binding Ctrl+U, Alt+Z U)
Avoid using underbar if you can! It is a hangover from the
typewriter days, when you could not change fonts. One no longer
needs to emphasize text by underscoring characters. This is only
possible in [yX because some people may need it in order to
follow style sheets for journal submissions.

Double underbar This is text with Double underbar on. (key binding un-

definiert)
As we just warned you against using underbar, you can imagine
what we think about double underbar.
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Wavy underbar This is text with Wavy underbar on. (key binding un-
definiert)

Use this only if a journal absolutely insists on it. Keep antinau-
sea pills handy.

Strikeout Fhis-is-text-with-Strikeont-on- (key binding Ctrl+Shift+0)
This is frequently used to indicate an older version of text that
has been changed in the meantime.

Noun THis 1S TEXT WITH NOUN ON. Like Emph, this is a logical
attribute. Normally it’s equivalent to Small Caps.

Color You can adjust the color of the text with this control. Notice that not
all DVI-viewers are able to display colors. Besides No color, which is the
default “color” and means normally black, you can choose between Black,
White, Red, Green, Blue, Cyan, Magenta and Yellow text.

Language This is used to mark regions of text as having a different language from

the language of the document. Text marked in this way will be underlined
in blue to indicate the change (only within IyX).
If you have for example a longer German Text in your document, KTEX
respects the German hyphenation rules automatically. When using the
spell checking (see section 6.14) the German-marked text will be checked
according to the German dictionary.

So you have a huge number of combinations to choose from. Once you've chosen
a new character style via the Edit>Text Style dialog, the settings are saved. You

can activate them by using the toolbar button @ The button lets you apply your
custom character style even when the dialog isn’t visible.

To completely reset the character style to the default, use Alt+Z Space. If you
want to toggle only those properties that you have just changed (suppose you just
set the shape to “slanted” and the series to “bold”), set the Toggle all switch and
press Apply.

You should also know something about the differences between the three main font
types serif, sans serif, and typewriter:

o Typewriter is a so called “monospaced” font, which means every character has
the same width; the “i” is as wide as the “m”. Here is an example
typewriter text
no typewriter text

o Serif fonts use characters with serifs. These are the small “appendices” at the
ends of the strokes that form the character. The following example shows the
difference:
text with serifs
text without serifs
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Serifs facilitate quick and easy reading. These fonts are therefore used as default
(named roman).

 Sans serif is not recommended to use a base type. This font type is therefore
often only used for headings and short texts. We use it in this document to
highlight menu names.

“Toggling” refers to applying or removing font properties. When a property is marked
for toggling in the Text Style dialog, applying the style to text that already has the
property will cause the property to be removed. If you for example apply a style with
properties A, B and C to text that currently has font properties B, C, F and G, and
if B is set to toggle and C is set not to toggle, the text ends up with properties A,
C, F and G. “Never toggled” and “always toggled” mean that you do not control the
toggling behavior. For the properties on the left side of the dialog (“Family” etc.),
toggling behavior is up to you. If Toggle all is checked, all of the left side properties
are toggled; by default, none of them are. Finally, “Reset” is never toggled. If you
e.g. set “Series” to “Reset” and select Toggle all, then apply the style to bold face
text, the text will revert to the default series (“Medium”), no matter how many times
you apply the style.

We conclude with the same warning once again: Do not overuse the fonts! They
are, more often than not, a kludge and a bad substitute for good writing.

3.8. Printing and Previewing

3.8.1. Overview

Now that we have covered some of the basic features of document preparation using
LyX, you probably want to know how to print out your masterpiece. Before we tell
you that, we want to give you a quick explanation of what goes on behind-the-scenes.
We cover this information in much greater detail in the Additional Features manual
as well.

LyX uses the program IXTEX as its backend. ETEX is just a macro package for the
TEX typesetting system, but to prevent confusion, we will only refer to TEX. LyX is
what you use to do your actual writing. Then, IyX calls KTEX to turn your writing
into printable output. This happens in two stages:

1. First, IxyX converts your document to a series of text commands for KTEX,
generating a file with the extension, 7

13

.tex”.

2. Next, LyX calls KTEX to use the commands in the . tex file to produce printable
output.
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3.8.2. Output file formats
3.8.2.1. Simple text (ASCII)

This file type has the extension “.txt”. It contains your document as plain text
following the rules of the “American Standard Code for Information Interchange”
(ASCII).

You can export your document to ASCII with the menu File> Export > Plain text or
Filer> Export > Plain text (ps2ascii). The latter will first internally export to PostScript
and then do the conversion to ASCII.

3.8.2.2. BTEX

This file type has the extension “.tex” and contains all commands that are necessary
for the IXTEX program to process your document. If you know KTEX, you can use
it to find out IXIEX-Errors or to process it manually with console commands. The
ETEX-file is automatically created in IyX’s temporary directory whenever you view
or export your document.

You can export your document as a IXTEX-file using the menu File> Export>LaTeX.
The different BTEX export variants are explained in section A.1.13.

3.8.2.3. DVI

This file type has the extension “.dvi”. It is called “device-independent” (DVI),
because it is completely portable; you can move them from one machine to another
without needing to do any sort of conversion. DVIs are used for quick previews and
as pre-stage for other output formats, like PostScript.

DVI files do not contain images, they only link to them. So don’t forget to deliver
the images together with your DVIs. Because the DVI-viewer has to convert the
image in the background to make it visible when you scroll the DVI, this can slow
down your computer when you view the DVI. So we recommend using PDF for files
with many images.

You can export your document to DVI by the menu Filer>Export>DVI or Filer
Export>DVI (LuaTeX). The latter option uses the program LuaTgX. LuaTX is an
engine that provides direct Unicode support and support for direct font access (see
section 3.7.2). LuaTgX is still a work in progress, but it might develop into the next
standard TEX processor.

3.8.2.4. PostScript

¢

This file type has the extension “.ps” PostScript was developed by the company
Adobe as a printer language. The file therefore contains commands that the printer
uses to print the file. PostScript can be seen as a “programming language”; you can
calculate with it and draw diagrams and images.!! Due to this ability, the files are

1When you are interested to learn more about this, have a look at the IATEX-package pstricks.
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often bigger than PDFs.

PostScript can only contain images in the format “Encapsulated PostScript” (EPS,
file extension “.eps”). As LyX allows you to use any known image format in your
document, it has to convert them in the background to EPS. If you have e. g. 50 images
in your document, LyX has to do 50 conversions when you view or export your
document the first time. This might slow down your workflow with LyX. So if you
plan to use PostScript, you can insert your images directly as EPS to avoid this
problem.

You can export your document to PostScript using the menu File > Export > PostScript.

3.8.2.5. PDF

This file type has the extension “.pdf”. The “Portable Document Format” (PDF)
developed by Adobe was derived from PostScript. It is more compressed and it uses
fewer commands than PostScript. As the name “portable” implies, it can be processed
at any computer system and the printed output looks exactly the same.

PDF can contain images in its own PDF format and in the formats “Joint Pho-
tographic Experts Group” (JPG, file extension “.jpg” or “.jpeg”) and “Portable
Network Graphics” (PNG, file extension “.png”). You can also use any other image
format, because IiyX converts them in the background to one of these formats. But as
described in the section about PostScript, the image conversion will slow down your
workflow. So we recommend using images in one of the three mentioned formats.

You can export your document to PDF via the menu Filer> Export in different ways:

«

PDF (ps2pdf) This uses the program ps2pdf that creates a PDF from a PostScript-
version of your file. The PostScript-version is produced by the program dvips
which uses a DVI-version as intermediate step. So this export variant consist
of three conversions.

PDF (dvipdfm) This uses the program dvipdfm that converts your file in the back-
ground to DVI and in a second step to PDF.

PDF (pdflatex) This uses the program pdftex which converts your file directly to
PDF.

PDF (XeTeX) This uses the program XeTgX that converts your file directly to PDF.
XeTX is a new engine that provides direct Unicode support and support for
direct font access (see section 3.7.2). It is particularly good at typesetting
different scripts, for example vertically written Japanese.

PDF (LuaTeX) This uses the program LuaTgX which converts your file directly to
PDF. LuaTiX is an even newer engine, derived from pdflatex, that also provides
direct Unicode support and support for direct font access (see section 3.7.2).
LuaTEX is still a work in progress, but it might develop into the next standard

TEX processor.
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We recommend using PDF (pdflatex) because pdftex supports all the features of ac-
tual PDF-versions, is quick, stable, and works without problems. If you rely on
multiscript support and/or specific OpenType fonts, you might want to try out
PDF (XeTeX) or PDF (LuaTeX) instead, bearing in mind that these two programs
are not yet as mature as pdflatex.

3.8.2.6. XHTML

This file type has the extension “.xhtml”. It is a file suitable for viewing in web
browsers. It does not itself contain images and the like but only links to them, and
when LyX produces XHTML, it also generates corresponding images in formats suit-
able for the purpose. For the math output you can choose in the menu Document >
Settings> Output between different formats, which are described in section Math Out-
put in XHTML of the Additional Features manual.

XHTML output remains “under development”, and not all Iy X features are sup-
ported yet. See the chapter LyX and the World Wide Web, in the Additional Features
manual, for more information.

You can export your document as an XHTML file using the menu item Filer
Export > LyXHTML.

3.8.3. Previewing

To get a look at the final version of your document, with all of the page breaks in
place, the footnotes correctly numbered, and so on, use the menu View and choose

View or the toolbar button @D A viewing program will pop up showing the output
in the defined default output format, which is globally set in the preferences (see
sec. C.7.2) and can also be altered for single documents in the document settings (see
sec. B.20). Further output formats can be selected via View > Other Formats or the

toolbar button =4,
If you have changed your document, you can refresh the output in the same viewer
window using the menu View > Update or View > Update (Other Formats), respectively.
When you preview a file, the output file is only generated in IyX’s temporary
directory. To have a real output, export your document.

3.8.4. Printing the File from within LyX

Instead of exporting your file and then printing it, you can also print it directly from
within InyX. To print a file, select the menu File> Print or click on the toolbar button

ﬁ. IyX will internally call XTEX to produce a DVI. This file is then processed
by the program dvips to PostScript-file, which is finally printed using the program
Ghostscript. Due to these steps in the background, this method is not the fastest.
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You can choose to print only even-numbered or odd-numbered pages — this is
useful for printing on two sides: You can re-insert the pages after printing one set to
print on the other side. Some printers spit out pages face-up, others, face-down. By
choosing a particular order to print in, you can take the entire stack of pages out of
the printer without needing to reorder them.

You can set the parameters in the Print Destination box as follows:

Printer ~ This is the name of the printer to print to.'? The printer should understand
PostScript.

File The name of a file to print to. The output will be a PostScript file. It will
be written in IxX’s working directory unless you specify the full path.

3.9. A few Words about Typography

3.9.1. Hyphens, Dashes and Minus Signs

In IyX, the “~” character comes in four lengths: the hyphen, the en dash, the em
dash, and the minus sign:

name output inserted with

hyphen - “="in text

en dash - Insert > Special Character>Symbols
em dash — Insert > Special Character>Symbols
minus sign  — “=” in math mode

w_m»

You can alternatively generate the en and em dash by inserting the character
multiple times in a row. They will automatically be converted to the appropriate
length dash in the final output, but not in IxX. “--” gives a en dash, “---" a em
dash.

The three dash types are distinct from the minus sign, which appears in math

mode and has a length of its own. Here are some examples:

1. line- and page-breaks (hyphen)
2. From A-Z (en dash)
3. Oh — there’s a dash. (em dash)

2

4. 22 —yP =2 (minus sign)

12Note that this printer name is for the program dvips. That means dvips has to be configured for
this printer name. The default printer can be set in LyX’s preferences dialog, see section C.6.2.
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3.9.2. Hyphenation

Words are not hyphenated within IyX but automatically in the output. Hyphenation
is done by the I¥TEX-package babel following the rules of the document language.
ETEX hyphenates almost perfectly, it only has problems with text in the typewriter
font and with unusual constructs, like “h3knix/mOnOwall”. If BTEX cannot break
a word correctly, you can set hyphenation points manually. This is done with the
menu Insert > Formatting > Hyphenation Point. These extra hyphenation points are only
recommendations to I TEX. If no hyphenation is necessary, INXTEX will ignore them.
Sometimes you want to prevent words or constructs from being hyphenated. Imag-
ine that you are describing keybindings/shortcuts in your document in the form “A-b
¢”. BIEX would then see the hyphen “-” as a hyphenation possibility. Hyphenat-
ing at this point would look ugly. To prevent the shortcut from being hyphenated,
you can put it into a makebox as described in section “Prevent Hyphenation” of the

Embedded Objects manual.

3.9.3. Punctuation Marks
3.9.3.1. Abbreviations and End of Sentence

When IyX calls ITEX to generate the final version of your document, KTEX au-
tomatically distinguishes between words, sentences, and abbreviations. KTEX then
adds the “appropriate amount of space”. That means sentences get a little bit more
space between the period and the next word. Abbreviations get the same amount of
space after the period that a word gets after another word.

Unfortunately, the algorithm for figuring out what’s an abbreviation does not work

W

in all cases. If a “.” is at the end of a lowercase letter, it’s the end of a sentence; if
it’s at the end of a capitalized letter, it’s an abbreviation.
Here are some examples of correct abbreviations and of the end of a sentence:

« M. Butterfly
e Don’t worry. Be happy.
And here is an example of the algorithm going wrong:
e e.g. this is too much space!
e This is I. It’s okay.

You will not see anything wrong until you view a final version of your document.
To fix this problem, use one of the following:

1. Use an Inter-word Space after lowercase abbreviations (see section 3.5.2.1).

2. Use a Thin Space between two tokens of an abbreviation (see section 3.5.2.2).
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3. Use an End of sentence period found under the Insert>Special Character menu
to force the use of inter-sentence spacing. This function is also bound to Ctrl4-.
for easy access.

With the corrections, our earlier examples look like this:
o e.g. this is too much space!
o This is I. It’s okay.

Some languages don’t use extra spacing between sentences. If your language is such
a language, you don’t need to worry, because KTEX will take care of this.

For those that do need to bother, there is help to catch those sneaky errors: Check
out the Check TgX feature described in section Checking TgX of the Additional Fea-
tures manual.

3.9.3.2. Quotes

LyX usually sets quotes correctly. Specifically, it will use an opening quote at the
beginning of quoted text, and use a closing quote at the end. For example, “open
close”. The keyboard character, ", generates this automatically.

You can specify what character the " key produces using the submenu Language of
the Document > Settings dialog in the box Quote Style. There are six choices:

“Text"” Use quotes like this “double”
"Text" Use quotes like "this”
. lext” Use quotes like ,this“
. Text” Use quotes like ,this”
«Texty  Use quotes like «this»

»Text«  Use quotes like »this«

3.9.4. Ligatures

It is standard typesetting practice to group certain letters together and print them
as single characters. These groups are known as ligatures. Since IXTEX knows about
ligatures, your documents will contain them too in the output. Here are the standard
ligatures:

o ff
o fi
o fl
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o fi
o fil

Some languages uses other ligatures if the document font supports them.

Sometimes, you don’t want a ligature in a word. While a ligature may be okay in
the word, “graffiti,” it looks really weird in compound words, such as “cufflink” or
the German “Dorffest.” To break a ligature, use Insert>Formatting > Ligature Break.
This changes “cufflinks” to “cufflinks” and “Dorffest” to “Dorffest”.

3.9.5. LyX’s Proper Names

You will certainly have noticed that the word “I#TEX” always appears with characters
in different sizes and heights. IXTEX is the name of the program used by IyX and is
therefore recognized as a proper name when you type it in LyX as “LaTeX”. Note the
order of the upper-and lowercase letters! Iy X recognizes the following proper names:

LyX The name of the game, write “LyX” to produce it.

TEX The program used by KIEX, write “TeX” to produce it.

BTEX The program used by IyX, write “LaTeX” to produce it.

BTEX 2¢ The actual version of IXTEX, write “LaTeX2e” to produce it.

You might wonder why the IXTEX-version is “2¢”. It’s an old tradition in the TEX-
world to give programs geek version numbers. For example the version number of
TEX converges to the number 7: The actual version is “TEX-3.141592”, the previous
one was “TEX-3.14159".

If you don’t want to use proper names, e. g. in section headings, you can insert two

empty braces in TEX Code in the word. This will look in IyX like: T&T 1} X
For more about TEX Code, look at section 6.10.

3.9.6. Units

Generally the space between units and the number is smaller than the normal space
between two words. As you can see in the example below, it looks better when the
space is smaller. To get such a “half space” for units use the menu Insert > Formatting >
Thin Space (shortcut Ctrl+Shift+Space).
Here is an example to show the differences:
24 kW-h space between number and unit
24kW-h half space between number and unit
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3.9.7. Widows and Orphans

In the early days of word processors, page breaks went wherever the page happened
to end. There was no regard for what was actually going on in the text. You may
remember once printing out a document, only to find the heading for a new section
printed at the very bottom of the page, the first line of a new paragraph all alone at
the bottom of a page, or the last line of a paragraph at the top of a new page. These
bits of text became known as widows and orphans.

Clearly, yX can avoid breaking pages after a section heading. That’s part of the
advantage of paragraph environments. But what about widows and orphans, where
the page breaks leave one line of a paragraph all alone at the top or bottom of a page?
There are rules built into IXTEX governing page breaks, and some of those rules are
there to specifically prevent widows and orphans. This is the advantage [yX has in
using IXTEX as its backend.

There’s no way we can go into how TEX and KETEX decide to break a page, or
how you can tweak that behavior. Some IXTEX books listed in the bibliography (such
as [1] or [2]) may have more information. You will almost never need to worry about
this, however.
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4. Notes, Graphics, Tables, and
Floats

The issues of this chapter are described in detail in the Embedded Objects manual.
There you will also find tips and tricks for special cases.

4.1. Notes

LyX offers you a few types of notes to add to your document:

LyX Note This note type is for internal notes that will not appear in the output.

Comment This note also doesn’t appear in the output but it does appear as a EXTEX-

comment when you export the document to KTEX via the menu File> Export >
ATEX (xxx).

Greyed Out This note will appear in the output as text in a color which you can set
in the document settings under Colors> Greyed-out notes.

This is text! of a comment that appears in the output.

As you can see in the example, the first line of greyed out notes is a bit in-
dented and greyed out notes can have footnotes.

Notes are inserted with the toolbar button L=/ or the menu Insert> Note. Right-click
on the appearing note box to select the note type.

4.2. Footnotes

LyX uses boxes to display footnotes: When you insert a footnote using the menu

Insert > Footnote or the toolbar button ‘;l, you will see the following box: 20t !
This box is [yX’s representation of your footnote. If you left-click on the “foot”

IThis is an example footnote within a greyed out note. In this document the color of this note
type is set to blue.

61



This is
marginal
note.

a

4. Notes, Graphics, Tables, and Floats

label, the box will be opened and you can enter the footnote text into it. Clicking
on the box label again, will close the box. If you want to turn existing text into a
footnote, simply highlight it and click on the footnote toolbar button.

Here is an example footnote:?

The footnote will appear in the output as a superscript number at the text position
where the footnote box is placed. The footnote text is placed at the bottom of
the current page. The footnote number is calculated by IxX. The numbers are
consecutive, no matter in which chapter the footnote is in. IyX doesn’t support
other numbering schemes yet, but you can get other schemes using special BTEX-
commands. They are described in the Embedded Objects manual.

4.3. Marginal Notes

Marginal notes look and behave just like footnotes in [yyX. When you insert a margin

note via the menu Insert > Marginal Note or the toolbar button E\, you will see a box
with the label “margin” appearing within your text. This box is LyX’s representation
of your marginal note.

At the side of this sentence is an example marginal note.

Marginal notes appear at the right side in single-sided documents. In double-sided
documents they appear in the outer margin — left on even pages, right on odd pages.

For further information about marginal notes see section Margin Notes of the
Embedded Objects manual.

4.4. Graphics and Images

To insert an image in your document, place the cursor at the text position you want

and click on the toolbar icon Lk, or select Insertt> Graphics from the menu. Then a
dialog will appear to choose the file to load.

This dialog has numerous mostly self-explanatory parameters. The Graphics tab
allows you to choose your image file. The image can be transformed by setting a
rotation angle and a scaling factor. The scaling units are explained in Appendix D.

In the tab Clipping it is possible to set image coordinates to adjust the height and
width of the image in the output. The coordinates can also be calculated automati-
cally by pressing the button Get from file. The option Clip to bounding box will only
print the image region within the given coordinates. Normally you don’t need to take
care about image coordinates and can ignore the tab Clipping.

In the KTEX and LyX options tab ETEX experts can specify additional IXTEX options.
In this tab you can also specify the appearance of the image inside IyX. The option
Draft mode has the effect that the image doesn’t appear in the output, only a frame

2To close a footnote, click on the footnote box label.
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with the image size is printed. The option Don't unzip on export is explained in the
Embedded Objects manual in section Graphics Dialog.

The graphics dialog can be called at any time by clicking on an image. The image
will appear in the output exactly at the position where it is in the text. This is an
example image within a separate, horizontally centered paragraph:

If you need image captions or want to reference images, you have to put the image
into a float, see section 4.6.2.1.

4.4.1. Image Formats

You can insert images in any known file format. But as we explained in section 3.8.2,
every output document format allows only a few image formats. LyX therefore uses
the program ImageMagick in the background to convert the images to the right
format. To increase your workflow by avoiding these conversions in the background,
use only the image formats listed in the subsections of section 3.8.2.

Similar to fonts there are two types of image formats:

Bitmap images consist of pixel values, often in a compressed form. They are there-
fore not fully scalable and look pixelated in large zooms. Well-known bitmap
image formats are “Graphics Interchange Format” (GIF, file extension “.gif”),
“Portable Network Graphics” (PNG, file extension “.png”), and “Joint Photo-
graphic Experts Group” (JPG, file extension “. jpg” or “. jpeg”).

Scalable images consist of vectors and can therefore be scaled to any size without

data loss. The scaling ability is desired if you want to create presentations,
because presentations are always scaled by the beamer. Scaling is also useful
for online documents to let the user zoom into diagrams.
Scalable image formats can be “Scalable Vector Graphics” (SVG, file exten-
sion “.svg”), “Encapsulated PostScript” (EPS, file extension “.eps”), and
“Portable Document Format” (PDF, file extension “.pdf”). We say “can be”,
because you can convert any bitmap image format to PDF or EPS and the
result will not be scalable. In this case only a header with the image properties
is added to the original image.3

Normally one cannot convert a bitmap image into a scalable one, only vice versa.

3In the case of PDF, the original image is additionally compressed.
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4.4.2. Grouping of Image Settings

Each image can define a new group of image settings or join an existing group.
Images within such a group share their settings, so adjusting one image of the group
automatically also adjusts all other images of the group in the same way. So you
can for example change the size for a bunch of images without the need to manually
change each of them.

A new group can be set by entering a name in the Group Name field in the Graphics
dialog. Joining an existing group can be done using the context menu of the image
by checking the name of the desired group.

4.5. Tables

You can insert a table using either the toolbar button === or the menu Insert > Table.
A dialog will appear, asking you for the number of rows and columns. The default
table has lines around any cell and the first row appears separated from the rest of
the table. This separation appears due to a double line: The cells of the first row
have a line below them and the cells of the second row have a line above them. Here
is an example table:

| [1[2]3]

A
B
C

4.5.1. The Table dialog

You can alter a table by clicking on it with the right mouse button, which brings
up the table dialog. Here you can adjust the settings of the cell and row/column
respectively where the cursor is placed currently. Most of the dialog options also
work on selections. This means that if you select more cells, columns or rows the
action is done on all of your selection.

In addition to the table dialog, the table toolbar helps you in setting table properties.
It appears when the cursor is inside a table.

In the tab Table Settings of the table dialog you can set the alignment for the
current row. If you add a row or column, it will be inserted right beside or below the
current cell respectively. The vertical alignment of a column can only be adjusted
when a column width is given. A given width will allow the cell to have line breaks
and multiple paragraphs of text, see section 4.5.3.

You can mark multiple cells of one row/column as a multicolumn/row cell using
the check box Multicolumn or Multirow. This will merge the cells to one cell, spread
over more than one column/row. Multicolumn cells are treated as own rows, so that
the alignment, width, and border settings affect only the multicolumn cell. Here’s
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an example table with a multicolumn cell in the first row and one in the last row
without the upper border:

\ abc \ def ghi \ jkl \
A |B|C|D
1 21 3 4

Adept users can declare special IXTEX-arguments for the table. They are necessary
for special table formatting, like for multirow cells, explained in the tables section of
the Embedded Objects manual. You can also rotate the current cell or the whole table
90 degrees counterclockwise. These rotations are not visible in Iy/X but are visible in
the output.

Note: Most DVI-viewers are not able to display rotations.

The Borders tab allows you to add and delete border lines for the current row /column.
The button Default adds lines for all cell borders.

4.5.2. Longtables

If the table is too long to fit on one page, you can use the option Use long table in
the tab Longtable of the table dialog to split the table automatically over more pages.
Doing this enables some check boxes and you can now define:

Header: The current row and all rows above, that don’t have any special options
defined, are defined to be the header rows of all pages of the longtable; except
for the first page, if First header is defined.

First header: The current row and all rows above, that don’t have any special options
defined, are defined to be the header rows of the first page of the longtable.

Footer: The current row and all rows below, that don’t have any special options
defined, are defined to be the footer rows of all pages of the longtable; except
for the last page, if Last footer is defined.

Last footer: The current row and all rows below, that don’t have any special options
defined, are defined to be the footer rows of the last page of the longtable.

Caption: The first row is reset as a single column. You can now insert there the
table caption via the menu Insert> Caption. More about longtable captions can
be found in the Embedded Objects manual.

You can also specify a row where the table is split. If you set more than one option
in the same table row, you should be aware that only the first one is used in the given
table row. The others will then be defined as empty. In this context, first means first
in this order: Footer, Last footer, Header, First header. See the following longtable to
see how it works:
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Example Phone List (ignore the names)

NAME TEL.

Annovi Silvia 111
Bertoli Stefano 111
Bozzi Walter 111
Cachia Maria 111
Cachia Maurizio 111
Cinquemani Giusi 111
Colin Bernard 111
Concli Gianfranco 111
Dal Bosco Carolina 111
Dalpiaz Annamaria 111
Feliciello Domenico 111
Focarelli Paola 111
Galletti Oreste 111
Gasparini Franca 111
Rizzardi Paola 111
Lassini Giancarlo 111
Malfatti Luciano 111
Malfatti Valeriano 111
Meneguzzo Roberto 111
Mezzadra Roberto 111
Pirpamer Erich 111
Pochiesa Paolo 111, 222
Radina Claudio 111
Stuffer Oskar 111
Tacchelli Ugo 111
Tezzele Margit 111
Unterkalmsteiner Frieda 111
Vieider Hilde 111
Vigna Jirgen 111
Weber Maurizio 111
Winkler Franz 111
Annovi Silvia 555
Bertoli Stefano 555
Bozzi Walter 555
Cachia Maria 555
Cachia Maurizio 555
Cinquemani Giusi 555
Colin Bernard 555
continue ...




Example Phone List

NAME TEL.
Concli Gianfranco 555
Dal Bosco Carolina 555
Dalpiaz Annamaria 555
Feliciello Domenico 555
Focarelli Paola 555
Galletti Oreste 555
Gasparini Franca 555
Rizzardi Paola 555
Lassini Giancarlo 555
Malfatti Luciano 555
Malfatti Valeriano 555
Meneguzzo Roberto 555
Mezzadra Roberto 555
Pirpamer Erich 555
Pochiesa Paolo 555, 222
Radina Claudio 555
Stuffer Oskar 555
Tacchelli Ugo 555
Tezzele Margit 555
Unterkalmsteiner Frieda 555
Vieider Hilde 555
Vigna Jirgen 999
Weber Maurizio 555
Winkler Franz 555
End

4.5.3. Table Cells

4.5. Tables

A table cell can contain text, inline equations, a figure, or another table. All these
kinds of objects can be placed in the same cell. Font sizes and shapes can also be
altered. But you can’t put a special environment in a cell (like Section*; etc.), nor
set spacing options etc. for the cell’s paragraph.

To have multi-line entries in table cells, you have to declare a fixed width for the
column in the table dialog. Your text is then automatically split into multiple lines
and the cell is enlarged vertically when the length of the text exceeds the given width.
An example:
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1 2 3
This is a multi- | 5
line entry in a
table.

6 | This is longer | 7
Now.
8 | This is a multi- | 9
line entry in a
table.  This is
longer now.

Cutting and pasting between tables and table cells works reasonably well. You can
cut and paste even more than one row.* Selection with the mouse or with Shift plus
the arrow keys works as usual. You can also copy and paste the entire table as a
single unit by starting the selection from outside the table.

4.6. Floats

4.6.1. Introduction

A float is a block of text associated with some sort of label, which doesn’t have a
fixed location. It can “float” forward or backward a page or two, to wherever it fits
best. Footnotes and Margin Notes are also floats, because they can float to the next
page when there are too many notes on the page.

Floats make it possible to get a high quality layout. Images and tables can be
spread evenly over the pages to avoid whitespace and pages without text. As the
floating often destroys the context between the text and the image/table, every float
can be referenced in the text. Floats are therefore numbered. Referencing is described
in section 6.1.

To insert a float, use the menu Insert>Float. A box with a caption will be inserted
into your document. The label will automatically be translated to the document
language in the output. After the label you can insert the caption text. The image
or table is inserted above or below the caption in a separate paragraph within the
float. To keep your LyX-document readable, you can open and close the float box by

left-clicking on the box label. A closed float box looks like this: (a3 EETT) SN gray
button with a red label.

It is recommended to insert floats as a separate paragraph to avoid possible BTEX-
errors that can occur when the surrounding text is specially formatted.

4Note, that you cannot paste into a multicell selection because it would not be clear what to do
when pasting a single word in a selected 2x3.
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Figure 4.1.: A severely distorted platypus in a float.

4.6.2. Examples
4.6.2.1. Figure Floats

Figure 4.1 was created using the menu Insert> Float> Figure or the toolbar button
ﬂl The image was inserted by setting the cursor above the caption label and using
the menu Insert> Graphics or the toolbar button @ The image in the float was
horizontally centered by putting the cursor in front of or behind the image and using

the menu Edit> Paragraph Settings or the toolbar button Ii
This figure float also shows how to set a label and create a cross-reference to it.
As described in section 6.1, you can simply insert a label in the caption using the

1 |

menu Insert>Label or the toolbar button and refer to it using the menu Insert>

Cross-Reference or the toolbar button . It is important to use references to figure
floats, rather than using vague references like “the figure above”, because, as IXTEX
will reposition the floats in the final document, it might not be “above” at all.

Normally only one image is inserted in a figure float, but sometimes you might
want to use two images with separate subcaptions. This can be done by inserting
image floats into existing image floats. Note that only the main caption of the float
is added to the List of Figures as described in section 6.2.2. Figure 4.2 is an example
of a figure float with two images set side by side. You can also set the images one
below the other. Figure 4.2a and 4.2b are the subfigures.

4.6.2.2. Table Floats
_Tab_le floats can be inserted using the menu Insert > Float > Table or the toolbar button

% They have the same properties as figure floats except for the different label.
Table 4.2 is a table float.
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(a) Undefinable (b) Platypus

Figure 4.2.: Two distorted images.

Table 4.2.: A table float.

ot 2 1 3
Joe Mary Ted
fxzdx Z 2 1+1=2

70



4.7. Minipages

4.6.3. More Information

LyX offers you further float types as well as rotated floats. It also allows you to
change the float numbering scheme, to control the float placement and to change the
formatting and placement of the float caption. All these features are explained in
detail with many examples in chapter Floats of the Embedded Objects manual.

4.7. Minipages

KETEX provides a mechanism to produce essentially a page within a page, called
minipage. Within a minipage, all the usual rules of indentation, line wrapping,
etc. apply.

Minipages in LyX have their own collapsible box inserted via the menu Insert>
Box. Right-clicking on the box allows you to alter the width of the minipage and its
alignment within the page.

This s a minipage. The
text is set in an italic
style.

Minipages are often used
for text in another lan-
gquage or text that needs
another formatting.

If you place two minipages side-by-side, you can use Horizontal Fills as described in
section 3.5.2:

This is a minipage This is a minipage
with some stupid with some stupid
dummy text. This dummy text. This
dummy text is used dummy text is used
to increase the size to increase the size
of the minipage. of the minipage.

When you right-click on a minipage box, you can change the box from a minipage
to other box types. All box types and their settings are explained in detail in chapter
Bozes of the Embedded Objects manual.

71






5. Mathematical Formulas

The issues of this chapter are described in detail in the Math manual. There you will
also find tips and tricks for special cases.

5.1. Basic Math Editing

To create a math formula, you can just click on the toolbar icon E . That will create
a little blue rectangle, with purple markers around its corners. That blue rectangle
is the formula itself; the purple markers indicate what level of nesting within the
formula you are at. You can also choose a particular formula type to insert via the
Insert>Math menu.

Editing the parameters of a formula and adding math constructs can be done with
the math toolbar, that appears when the cursor is in a formula.

There are two main types of formulas, inline formulas and display formulas. Inline
formulas appear within a text line, like this one:

This is a line with an inline formula A = B in it.

Displayed formulas appear outside the text like if they were in a separate paragraph,
like this one:

A=BRB

You can only number and reference displayed formulas.

Ly X supports also many KTEX math commands. E.g. typing “\alpha”, followed
by a space, in a formula will create the Greek letter a. Typing commands might
sometimes be faster than using the Math Panel.

5.1.1. Navigating in Formulas

The best control over the cursor position within an existing formula is achieved with
the arrow keys. IyX uses small rectangles to indicate places where something can
be inserted. The arrow keys can be used to navigate between parts of a formula.
Pressing Space will leave a formula construct (a square root V2, or parentheses (f),

3 4
the formula. Tab can be used to move horizontally in a formula; for example, through
the cells of a matrix or the positions in a multi-line equation.

Space, printed in this document as “ ", seems to do nothing in a formula, since it
does not add a space between characters, but it does exit a nested structure. For this

or a matrix [ L2 ] ). Pressing Escape will leave the formula, placing the cursor after
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reason, you have to be careful about using Space. For example, if you want /2x + 1,
type \sqrt,,2x+1 and not \sqrt, 2x, +1, since in the latter case only the 2z will
be under the square root sign: v/2z + 1.

You can leave many parts of a formula, like this matrix, partially filled in, such as:

At

An

If you leave a fraction only partially filled in, or a subscript with nothing in it, the
results will be unpredictable, but most constructs don’t mind.

5.1.2. Selecting Text

You can select text within a formula in two different ways. Place the cursor at one
end of the string of text you want, and press Shift and a cursor movement key to
select text. It will be highlighted as with regular text selection. Alternatively, you
can select text with the mouse in the usual way. That text can then be cut or copied,
and then pasted within any formula, but not in a normal text region in LyX.

5.1.3. Exponents and Subscripts
0

You can use the math panel to add super- or subscripts (buttons 0 and On ),
but the much easier way is to use a command. To get 22, type in a formula x" 2.
The final Space puts the cursor back down on the base line of the expression. If you
type x 2y, you will get 2%, to get 2y, type x 2_.y. If you use characters in the
superscript, that could be accented with the hat “~”, you have to use an extra Space
to separate the hat and the character. E.g. if you want x%, type x _a. Subscripts
are similar: To get aq, type a_ 1.

5.1.4. Fractions
d

Create a fraction with either the command \frac or using the icon b in the
Math Panel. You will be presented with an empty fraction. The cursor is above
the fraction line. To move it to the bottom, simply press Down. To move back up,
press Up. Any math structure can be placed in a fraction, as this example shows:
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5.1.5. Roots

Roots can be created using the Math Panel button v or ¥O or the commands
\sqrt or \root. With the command \root you can produce roots of higher orders,
like cube roots, while \sqrt produces always a square root.

5.1.6. Operators with Limits

Sum (3°) and integral ([') operators are very often decorated with limits. These limits
can be entered in LyX by entering them as you would enter a super- or subscript,
directly after the symbol. The sum operator will automatically place its “limits” over
and under the symbol in displayed formulas, and on the side in inline formulas. Such
as Yo7, % = e, versus
' o 1
ano o€

Integral signs, however, will place the limits on the side in both formula types.

All operators with limits will be automatically re-sized when placed in display
mode. The placement of the limits can be changed by placing the cursor directly
behind the operator and hitting Alt+M L or using the menu Edit>Math > Change Lim-
its Type.

Certain other mathematical expressions have this “moving limits” feature as addi-
tion, such as

lim f(z),

which will place the x — oo underneath the “lim” in display mode. In inline formulas
it looks like this: lim, .. f(z).

Note that the lim-function was entered as the function macro \lim. Have a look
at section 5.1.9 for an explanation of function macros.

5.1.7. Math Symbols

Most math symbols can be found in the Math Panel under one of several categories;
including Greek, Operators, Relations, Arrows. There are also the additional symbols
provided by the American Mathematical Society (AMS).

If you know the IETEX-command for a construct or symbol you wish to use, you
don’t have to use the Math Panel; you can type the command directly into the formula.
LyX will convert it to the corresponding symbol or construct.

5.1.8. Altering Spacing
You may want to create spaces that differ from the standard spacing that KITEX

provides. To do this, press Ctrl+Space or use the Math Panel button ™*. This
generates a small space, and shows a small marker on the screen. For example, the
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Table 5.1.: Accent names and the corresponding commands.

’ Name ‘ Command ‘ Example ‘

circumflex \hat a
grave \grave a
acute \acute a
umlaut \ddot a
tilde \tilde a
dot \dot a
breve \breve a
caron \ check a
macron \bar a
vector \vec a

sequence a Ctrl4Space b: ab appears in LyX as ol . You can change the space
to different sizes when you set the cursor behind the space marker and hit space
again several times. With every space hit the size will be changed. Some markers
for the space size appear red in LyX, because they are negative spaces. Here are two
examples:

a Ctrl4+Space b and 3xSpace: a b

a Ctrl+Space b and 5xSpace: a

5.1.9. Functions

X
The Math Panel contains under the button tati a number of function macros, such

as sin, lim, etc. (you can also insert them in a formula by typing \sin etc.). Stan-
dard mathematical practice is that functions are printed upright to avoid confusions,
because sin does normally mean s -7 - n.

Using the function macros will also produce correct spacing around the function:
asin x is different from asinzx.

For some mathematical objects, like the limes, the macro changes where subscripts
are placed, as described in section 5.1.6.

5.1.10. Accents

In a formula you can insert accented characters in the same way as in text mode.
This may depend on your keyboard, or the bindings file you use. You can also
use BTEX commands to e.g. enter a even if your keyboard doesn’t have hat-accents
enabled. Our example is entered by typing \hat a in a formula. Table 5.1 shows
the equivalences between the accent names and the commands.

You can choose one of the accents by selecting an item from the Frame decorations

symbol set button i..i in the math panel; this will apply to any selection you have
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made within a formula too.

5.2. Brackets and Delimiters

There are several brackets available through IyX. For some purposes, using just the
keys [1{}() |<> should suffice. But if you want to surround a large structure, like a
matrix or a fraction, or if you have several layers of brackets, it is better to use the

math toolbar delimiter icon [[” For example, that is how you would construct the
brackets around a matrix:

1 2

3 4

and to make it easier to see the layers of parentheses. Below, the expression on the

left was entered using the delimiter icon [[” and the expression on the right was
entered using the () keys.

1 1
() O

14z

If you use the delimiter icon, the parentheses, and other brackets from that menu
will automatically re-size to accommodate the size of what is inside.

To construct brackets click on the button for the bracket you want on the left side
and right side. If you use the option Keep matched, the selected bracket type will be
used for the left and the right side. The selection will be shown below the button
field. If you want one side to not have a bracket, use the blank button. It will appear
in IyX with a dotted line, but nothing will be printed.

If you want to place brackets around math structures, like a square root, you can do
so by first highlighting (selecting) the structure that is to go inside the brackets. Then
choose the appropriate brackets for left and right and click on Insert. The parentheses
will be drawn around the selected structure. The most common bracket combinations
(parentheses, square brackets, and braces, on both sides) can be entered more quickly
using keyboard shortcuts. For example, to insert a pair of flexible parentheses on both
sides, select the structure and enter Alt+M (.

5.3. Arrays and Multi-line Equations

Matrices are entered in LyX using the Math Panel matrix button 8888, It will open a
dialog for you to choose the number of rows/columns. Here is an example:

N SO

2 3
5 6
8 9
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The parentheses aren’t automatic, but you can add them as described in section 5.2.
When you construct the matrix, you can decide whether the column entries will be
left-, right-, or center-justified. This alignment is set in the box Horizontal with the
letters “1”, “r”, and “c”. LiyX proposes a “c” for every column as default. For example,
the sequence “lcr” means that the first column will be left-justified, the second will be
centered, and the third column will be right-justified, because each letter corresponds
to the relevant column. The result will look like this:

this this column this column
column has hasright .
hasleft alignment center alignment  alignment

You can add more rows to an existing matrix by hitting Ctrl+Return while the
cursor is in the matrix. Adding or deleting columns can be done via the menu Edit>
Math or the math toolbar.

There are other arrays used in formulas, such as distinctions of cases. It can be
created with the menu Insert>Math> Cases Environment or the command \cases.
Here is an example:

-1 <0
flz)=350 2=0
1 x>0

Multi-line formulas are created when you press Ctrl4+-Return within a formula. In
an empty formula you can see that three blue boxes appear, one for each column.
When you press Ctrl+Return in a non-empty formula, the part before the relation
sign (equal sign “=” etc.) will be inserted automatically in the first column, the
relation sign is in the second column, and the rest in the third column. A new row is
created by every further hit of Ctrl4+-Return. Multi-line formulas are always displayed

formulas. Here is an example:

> = P+ -
a = Vbt—ct (5.1)

Note that the middle column is designed for relation signs so structures in this column
will be printed in a smaller size:

A

A
B B B

S/

The multi-line formula type described here is called eqnarray. There are other
multi-line types more suitable for certain situations, for example if you want a better
inter-line spacing than in formula (5.1). The other types are described in section 5.8.2.
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5.4. Formula Numbering and Referencing

To number a formula, set the cursor in the formula and use the menu Edit>Mathr
Toggle Numbering or the shortcut Alt+M N. The formula number appears in LyX as
“#7” within parentheses. The “#” denotes that the number will be calculated auto-
matically when the output is generated. The placement and format of the formula
number in the output depends on the document class. In this document the number
is printed together with the chapter number, separated by a dot:

1+1=2 (5.2)

Using Alt+M N in a numbered formula will switch off the numbering. You can only
number displayed formulas.

Multi-line formulas can be numbered line by line: Using the menu Edit>Math>
Toggle Numbering of Line or the shortcut Alt+M Shift+N will only toggle the num-
bering of the line where the cursor is:

IA
EN|
—~
ot
=~
~—

To number all lines use the shortcut Alt+M N.

Every displayed formula can be referenced by its number using a label. A label is
inserted with the menu Insert>Label when the cursor is in the formula. This opens
a dialog to enter the label. It is recommended to use the proposed “eq:” as the
first part of the label, because this helps later to identify the label type when you
have many labels in your document. We inserted in the following example the label
“eq:tanhExp” in the second line:

sinh(x)
cosh(x)
e’ — 1

= - 2.5

tanh(x) =

Every labeled line is automatically numbered. Therefore the label is shown in IyX
at the place of the formula number placeholder “#”. You can reference a labeled
formula using the menu Insert> Cross Reference. A dialog appears to choose a label
you want to refer to. The reference appears in yX as a gray cross-reference box and
in the output as the formula number:

This is a cross-reference to equation (5.5).

The properties of LyX’s cross-reference box are described in section 6.1. To delete
a label, set the cursor at the end in the labeled formula and press Del.
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Table 5.2.: Typefaces and the corresponding commands.

’ Font ‘ Command ‘
Roman \mathrm
Bold \mathbf
Italic \mathit
Typewriter \mathtt
BLACKBOARD \mathbb
Srattur \mathfrak
CALLIGRAPHIC | \mathcal
SansSerif \mathsf

5.5. User defined math macros

LyX allows you to define macros for formulas which is very useful when you have
equations of the same form in a document several times. Math macros are explained
in section Math Macros of the Math manual.

5.6. Fine-Tuning
5.6.1. Typefaces

The standard font for text is italic, for numbers the standard is roman. To set a
R~
font in a formula, use the Math Panel button AIFL, or enter its command, listed in

table 5.2, directly.

Note: You can only print capital letters in the typefaces Blackboard and Calli-
graphic.

When you use a typeface, a blue box is inserted in the formula. Every character in
this box will be printed in this typeface. Pressing Space within the box will set the
cursor outside, so that you have to use a protected space when you need a space in
the box. Here is an example where “N” in Blackboard denotes the set of numbers:

f(x)=+z;zeN

The typefaces are nestable, which can cause confusion. You can e. g. put a character
in Fraktur in a box for Typewriter: abcde
So it is better not to use this feature.

The typefaces have no effect on Greek letters: abcde
You can only print them emboldened using the command \ boldsymbol, which works
like the other typeface commands: afSvya B~y

\boldsymbol works for all symbols, letters, and numbers.

A number of other font options are available as well, in the menu Edit>Math>
Text Style.

80



5.7. Theorem Modules

5.6.2. Math Text

Typefaces are useful for entering some characters in some given font, but not for text.

For typing longer pieces of text use the math text, which is obtained using the entry
R~
Normal text mode of the Math Panel button Al (shortcut Alt+Z Space). Math text

appears in IxX in black instead of blue. You can use spaces and accents in math
text like in normal text. Here is an example:

fla) = {x if I say so

—z under Umstdnden

5.6.3. Font Sizes

There are four font styles (relative sizes) used in math-mode, which are automat-
ically chosen in most situations. These are called textstyle, displaystyle, scriptstyle,
and scriptscriptstyle. For most characters, textstyle and displaystyle are actually the
same size, but fractions, superscripts and subscripts, and certain other structures,
are set larger in displaystyle. Except for some operators, which resize themselves to
accommodate various situations, all text will be set in the styles that IXTEX thinks

are appropriate. These choices can be overridden by using the math panel button
o
B. A box for the size will be created in which you can insert the math structure.
1
29
The four styles are used in the following example:

1
For example, you can set 5, which is normally in textstyle, larger in displaystyle: 3

displaystyle, textstyle, scriptstyle, scriptseriptstyle.

All these math-mode font sizes are relative so that if the whole math inset is set in a
particular size with the menu Edit> Text Style, all sizes in the formula will be adjusted
relative to this size. Similarly, if the base font size of the document is changed, all
fonts will be adjusted to correspond. As an example here is a formula in the font size
“largest”:

_ oo 1
e—znzom

5.7. Theorem Modules

As of IyX 1.6, support for theorem-like environments has been moved out of the
document classes and into layout modules. As a result, theorem-like environments
can now easily be used with classes other than the AMS classes. See section 3.1.2.3
for more on layout modules.
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5.8. AMS-ETEX

[y X supports the packages provided by the American Mathematical Society (AMS)
that are in common use.

5.8.1. Enabling AMS-Support

Selecting the checkbox Use AMS math package in the Document > Settings dialog under
Math Options will include the AMS-packages in the document and make the facilities
available. AMS is needed for many math-constructs, so when you get IXTEX-errors
in formulas, ensure that you have enabled AMS.

5.8.2. AMS-Formula Types

AMS-IXTEX provides a selection of different formula types. LyX allows you to choose
between align, alignat, flalign, gather, and multline. We refer to the AMS-
documentation for an explanation of these formula types.
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6.1. Cross-References

One of IyX’s strengths is cross-references. You can reference every section, float,
footnote, formula, and list in the document. To reference a document part, you have
to insert a label into it. The label is used as an anchor and a name for the reference.
We want for example to refer to the second item of the following list:

1. First item
2. Second item
3. Third item

First we insert a label into the second item with the menu Insert > Label or by pressing

the toolbar button “-. A gray label box like this: fig This-158 ;o i serted and the

label window pops up asking for the label text. IxX offers as text the first words
of the item with a prefix, in our case the text “enu:Second-item”. The prefix “enu:”
stands for “enumerate”. The prefix depends on the document part where the label is
inserted, e. g. if you insert a label into a section heading, the suggested prefix will be

To reference the item, we refer to its label using the menu Insert > Cross-Reference or

the toolbar button m A gray cross-reference box like this: Ref sec:Contrib 5 5,
serted and the cross-reference window appears showing all the labels in the document.
We can now sort the labels alphabetically and then choose the entry “enu:Second-
item”. At the position of the cross-reference box the item number will appear in the
output.

Alternatively to Insert> Cross-Reference, you can right-click on a label and use in
the appearing context menu Copy as Reference. The cross-reference to this label is
now in the clipboard and can be pasted to the actual cursor position via the menu
Edit> Paste (shortcut Ctrl+V).

Here is our cross-reference: Item 2

It is recommended to use a protected space! between the cross-reference name and
the cross-reference to avoid ugly line breaks between them.

There are six formats of cross-references:

<reference>: prints the number, this is the default: 4.2

Ldescribed in section 3.5.1
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(<reference>): prints the number within two parentheses, this is the style normally
used to reference formulas, especially when the reference name “Equation” is
omitted: (5.5)

<page>: prints the page number: Page 70
on page <page>: prints the text "on page" and the page number: on page 70

<reference> on page <page>: prints the number, the text "on page', and the
page number: 4.2 on page 70

Formatted reference: prints a self defined cross-reference format.
Note: This feature is only available when you have the I¥TEX-package pret-
tyref or refstyle installed.
You can select which I¥TEX-package should be used for this feature by setting
the option Use refstyle (not prettyref) for cross-references in the menu Document >
Settings>Document Class. The package refstyle is the default and preferred
because prettyref supports only English documents. The format is specified
by using the command \newrefformat (prettyref) or \newref (refstyle) in
the KTEX preamble of the document. For example redefining all references to
figures (which have the label shortcut “fig”) can be done with this command
\newref{fig}{refcmd={Image on page \pageref{#1}}}
For more information about the format, have a look at the package documen-
tations, [16, 17].

Textual reference: prints the caption or the name of the reference: Two distorted
images.

<page> will not print the page number if the label is on the previous, the same, or
the next page. You will e. g. see the text “on this page” instead. The style <reference>
on page <page> will not print anything about the page if the label is on the same
page.

The number and current page of the referenced document part in the output is
automatically calculated by IXTEX. The varieties are adjusted in the field Format of
the cross-reference window, that appear when you click on the cross-reference.

You can only use the style <reference> to reference numbered document parts,
while the reference style <page> is always possible.

If you want to reference a section, put the label in the section heading; for floats
put the label in the caption; for footnotes put the label in it. Referencing formulas
is explained in section 5.4.

Right-clicking on a cross-reference opens a context menu. The entry Go to Label
sets the cursor before the referenced label. This entry will be renamed in the context
menu of the label to Go Back so that you can use it to set the cursor back to the

cross-reference. You can also go back with the toolbar button EH
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You can change labels at any time. References to the changed label will automat-
ically be updated so that you do not need to think about this.

If a cross-reference refers to a non-existent label, you will see two question marks
in the output instead of the reference.

References are described in detail in sec. “Referencing Floats” of the Embedded Ob-
jects manual.

6.2. Table of Contents and other Listings

6.2.1. Table of Contents

The Table of Contents (TOC) is inserted with the menu Insert> List/ TOC> Table of Con-
tents. Is is displayed in Iy X as a gray box. If you click on it, the Outline window
appears, showing you the TOC entries as outline, which allows you to move and re-
arrange sections in your documents. So this operation is an alternative to the menu
Document > Outline that is described in sec. 2.5.

The TOC in the document output lists every numbered section automatically. If
you have declared a short title for a section heading, as described in section 3.3.4.4,
it will be used in the TOC instead of the section heading. Section 3.3.4.3 describes
how the level is adjusted that defines which section types are listed in the TOC.
Unnumbered sections are not listed in the TOC.

6.2.2. List of Figures, Tables, and Algorithms

Table, figure, and algorithm lists are very much like the table of contents. You can
insert them via the Insert> List / TOC submenus. The list entries are the float captions
and the float number.

6.3. URLs and Hyperlinks
6.3.1. URLs

Links to web pages or email addresses can be inserted via the menu Insert>URL.

Here is an example URL: [y X’s homepage: http://www.lyx.org

You cannot change the style of the link text, the URL text will always be in the
style Typewriter. To be able to format the URL text, use hyperlinks as explained
in the next subsection.

Note: URLs must not end with a backslash, otherwise you get KTEX errors.

6.3.2. Hyperlinks

Hyperlinks can be inserted with the menu Insert > Hyperlink or with the toolbar button

The appearing dialog has two fields: Target and Name. The name is the
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printed text for the hyperlink. The hyperlink type can be a weblink like this: LyX’s
homepage, an Email address like this: lyx-docs mailing list, or a link to a file.

You can start applications via a hyperlink when you insert a weblink by adding
the prefix “run:” to the link target.

Hyperlinks will automatically be hyphenated if necessary in the PDF output, and
become clickable in the DVI and PDF-output. To set the format of the link text,
highlight the hyperlink inset and use the text style dialog. This is for example a
hyperlink with bold sans serif text: LyX’s homepage

The link text color can be changed, when the option Color links is set in the PDF
Properties dialog (menu Document > Settings> PDF Properties). The link text is for
example set in this document to blue by adding the option
urlcolor=blue
to the field Additional options in the PDF Properties dialog.

6.4. Appendices

Appendices are created with the menu Document>Start Appendix Here. This menu
sets the document from the current cursor position to the end as the appendix region.
The region is marked with a red borderline.

Every chapter (or section) within the appendix region is treated as an appendix,
numbered with a capital Latin letter. The appendix subsections are numbered with
this letter followed by a dot and the subsection number. All appendix sections can
be referenced as if they were normal sections, here two examples:

Appendix E; Appendix A.1.13

6.5. Bibliography

There are two ways of generating the bibliography in a IyX-document. You can
include a bibliography database,? which is explained in the next subsection, or you
can insert the bibliography manually, using the paragraph environment Bibliography,
which was described in section 3.3.9.2. If you want anything other than numerical
citations that are used in this document, like author-year citations, then you must
use a bibliography database.

6.5.1. The Bibliography Environment

Within the Bibliography environment, every paragraph begins with a gray bibliogra-
phy box labeled with a number. If you click on it, you will get a dialog in which you
can set a Key and a Label. The key is the symbolic name by which you will refer to
this bibliography entry. For example, our second entry in the bibliography is a book
about KTEX and we used “latexcompanion”, a short form of its title, as the key.

2Known under the name “BibTEX-database”.
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6.5. Bibliography

You can refer to the key of a bibliography entry using the menu Insert > Citation or

the toolbar button E A citation reference box is inserted and a citation window
will appear in which you can select one or more keys in the available key list. The
citation reference box will be labeled with the referenced key. When you click on the
box, the citation window appears and you can change the reference.

Citation references appear in the output as the number of the bibliography entry
with surrounding brackets. If you set a Label for the entry, the label will appear
instead of the number. Here are two examples; the first without a label, the second
with the label “Credits”:

Have a look at the BTEX Companion Second Edition: [1]

The Iy X-Team members are listed in the Credits: [Credits]

6.5.2. Bibliography databases (BibTgX)

Bibliography databases are useful if you use the same bibliography in different doc-
uments.® It also makes it very easy to have a uniform layout for all bibliography
entries. You can collect the bibliography of all relevant books and articles of your
working field in a database. This database can be used for different documents, and
by default only the entries cited in a particular document will appear in the bibliog-
raphy list for that document. This relieves you of the need to keep track of which
articles and books you have cited.

The database is a text file with the file extension “.bib”, containing the bibliography
in a special format. The format is explained in [8] and in KTEX books ([MG04, KDO03,
Lam94]). The file can be created using any text editor, but normally one uses a special
program to create and edit the entries in the database. A list of such programs is
maintained on the IyX Wiki at http://wiki.lyx.org/BibTeX/Programs.

To use a database, use the menu Inserti>List/ TOC>BibTeX Bibliography. A gray
box will be inserted and a window appears. In this window you can load one or
more databases and a style file. The option Add bibliography to TOC adds a table of
contents entry for the bibliography. In the Content drop box you can select whether
to include all the entries in the database in the document or just the cited references.

The style file is a text file with the file extension “.bst” that controls how the
bibliography entries will appear. Your I¥TEX distribution should provide several of
these, and many publishers provide their own style files, so that you don’t have to
take care of the layout. It is of course possible to write your own style file, but this
is something for experts.*

Inserting a citation reference works as described in the previous section.

To generate the bibliography from a database, LyX uses the program BibTEX. You
can choose which of its variants should be used by LyX as the processor either in the

3They are also useful for keeping a database of articles and notes concerning them. Most of the
database programs mentioned below allow you to store annotations and reviews along with
bibliographical information.

4For information on how this is done, have a look at
http://mirrors.ctan.org/biblio/bibtex/contrib/doc/btxhak.pdf.

87


http://wiki.lyx.org/BibTeX/Programs
http://mirrors.ctan.org/biblio/bibtex/contrib/doc/btxhak.pdf

6. More Tools

document settings under Bibliography or in IyX’s preferences under Output>LaTeX.
The following variants are possible:

biber provides full Unicode support, unlimited memory, does not work with other
bibliography packages (like e. g. natbib), only with the package biblatex; rec-
ommended for multilingual texts and for languages that don’t use Latin letters

bibtex the standard; does not allow special characters in bibliography entries that
are not possible to encode in a 7-bit encoding, limited memory, works with all
bibliography packages, except of biblatex

bibtex8 allows all characters that are possible to encode in a 8-bit encoding, larger
memory than bibtex, works with all bibliography packages

BibTEX can be controlled with options that you can add below the specification of
the variants. Before adding options, it is strongly recommended to read the manual
of BibTEX [7].

When you select the option Sectioned bibliography in the Document > Settings dialog,
it is possible to have multiple and sectioned bibliographies. This and other options
are explained in detail in section Customizing Bibliographies with BibTpX of the
Additional Features manual.

We use two bibliographies in this document to show the difference between the
two methods of creating them. As you can see, the bibliography that is created from
a database lists only the database entries that are referenced in the document. We
used the style file alphadin.bst to get the complicated German reference key scheme
in the bibliography.

6.5.3. Bibliography layout

In the citation reference dialog you can set a special citation format. For this feature
you need to enable the option Natbib in the Document > Settings dialog under Bibli-
ography. Setting a citation style for a reference will overwrite the default. For the
global citation format use the BibTEX style files as explained in the previous section.

You can also set text to appear before or after a citation reference, in the citation
reference window. Here is an example where the text “Chapter 3”7 appears after the
reference:

Have a look at [1, Chapter 3].

6.6. Index

An index entry is created if you use the menu Insert > Index Entry or the toolbar button

. A box is inserted containing the text that appears in the index. The word where
the cursor is in or the currently highlighted text is proposed by LyX as the index
entry.
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The index list is inserted in the document with the menu Insert>List / TOCp
Index List. A light blue box labeled “Index” will show the place where the index is
printed in the output. The index list box is not clickable like other LyX-boxes.

We give a short overview of the index commands in the next subsections. For a
detailed description of I¥TEX’s index mechanism, have a look at one of the KTEX
books [1, 2, 3].

6.6.1. Grouping Index Entries

Index entries are often grouped to offer the reader a fast search in the index. We
want to group for example the index entries for itemized and enumerated lists under
the entry “Lists”. First we create the entry “Lists” in section 3.3.6. In the text field
for the itemized list index entry in section 3.3.6.2, we insert the command

Lists ! Itemize

and the command

Lists ! Enumerate

for the enumerated list in section 3.3.6.3.

The exclamation mark “!” marks the grouping levels. You can have three levels;
every index level is indented a bit more. An index entry for the higher levels is not
required. If we don’t have an index entry for “Lists”, it will be printed anyway, but
without a page number.

6.6.2. Page Ranges

Normally an index entry will appear with the page number of the indexed section.
But sometimes you want to index more pages under the same entry. E.g. if we want
to index the paragraph environments, we create an index entry in section 3.3 with
the command

Paragraph environments|(

and another entry at the end of section 3.3.10 with the command

Paragraph environments|)

The commands “|(” and “|)” respectively start and end the index range. You can
also add the same index entry at different places in the document. They appear in
the output under one entry with a comma separated list of the pages of the indexed
document parts. An example is the index entry “Document ! Settings”.

6.6.3. Cross referencing

It is also possible to refer to another index entry. We referred for example in the
index entry “GIF” (in section 4.4.1) to the index entry “Image formats” in the same
section using the entry

GIF |see{Image formats}

where the braces have to be inserted as TEX Code. The text within the braces is
the referenced entry. The reference will appear in the output without a page number.
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6.6.4. Index Entry Order

If you use accented characters in the index entry the entries might not follow the
rules for the index order. The index entries are sorted alphabetically but ITEX® does
not know how to sort accents in different languages. We have created as an example
the three dummy index entries “maison”, “mais”, and “maitre”. They will be sorted
in the order mafis, maitre, maison but we want the order mais, maison, maitre. To
achieve this, we use the command

previous entry@current entry

In our case we want to have “maison” after “mais” and write therefore for the index
entry of maison:

mais@maison

The previous entry need not be a real existing entry. You can also use another

word to tell KTEX the entry order. See the next subsection for an example.

In some cases the index entry order is not correct when you are using the program
makeindex to generate the index (see sec.6.6.6). makeindex would for example print
the index entry for the IXTEX-package aeguill in sec. 3.7.3 after the index entries of
the other KTEX-packages although all these index commands start with “KTEX-
packages ! . The reason is that the index entry for aeguill is in a footnote. To fix
this makeindex bug, add these commands to the preamble of your document:

\let\ OrgIndex\index

\renewcommand*{\index}[1]{\OrgIndex{#1}}

6.6.5. Index Entry Layout

You can change the appearance of index entries via the text style dialog. You can
also format the page number using the character “|” followed by a IXTEX-command
without a backslash. We can write for example

italic page number:|textit

to get the page number in italic. Normally all EETEX-commands begin with a back-
slash, but in this special case “|command” means \command{page number}.
Have a look at section 6.10.2 to learn more about the IXTEX-syntax.

Note: Formatting single index entries only works when you use the program
makeindex to generate the index, see sec. 6.6.6. If you use xindy, this will not work for
anything other than bold or italic text. This is because xindy requires you to define
semantic elements before they can be used, see [1, p. 678 ff.] for details.

In general, we encourage you to not format page numbers directly as shown above.
Instead, you should define a macro in the preamble and use that. Maybe you want
all page references italic that refer to a definition of the indexed term, so that users
can easily find definitions. If so, put the following in the preamble

\newcommand{\IndexDef}[1]{\textit{#1}}

and write

5The index generating is done in the background by an extra program, see section 6.6.6.
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my entry|IndexDef

in the index entry. The advantage is that, if you change your mind later or if your
publisher insists that definitions must not be italic but bold, you just need to change
the macro in the preamble, not every single index entry.

You can also change the layout for the whole index. E.g. we marked the index
list box of this document as bold to get a bold font for all index entries. For more
advanced tasks you have to set up a so-called Index Style File, see the makeindex or
xindy documentation for details, [9, 10].

6.6.6. Index Program

If the index entry program xindy is installed, [yX uses it for index generation; other-
wise the program makeindex, that is part of every IXTEX distribution, is used.® Both
programs can be controlled by options that can be set in IyX’s preferences dialog,
see section C.6.3. The available options are listed and explained in [9, 10]. In this
dialog, you can also specify an alternative program to generate the index.

If you need specific options or an alternative index program only for a given docu-
ment, you can define the program and/or the options in Document > Settings > Indexes.
This is especially useful if you need to pass language-specific options to the index pro-
gram or if you need a specific layout style.

6.6.7. Multiple Indexes

In many fields it is common to have more than one index. For instance, you might
need to set up a separate “Index of Names” next to the standard index. BTEX does
not provide this possibility out of the box, but there are many packages that add this
feature. LyX uses the splitidx package to generate multiple indexes. The package
is included in all recent KTEX distributions. If yours does not ship it, consult the
TEX-catalogue, [5]. Note that the package does not only consist of a BTEX style,
but it also includes specific preprocessor programs that need to be installed as well.
Please consult the package’s manual for details.

To set up LyX for the use of multiple indexes, go to Document > Settings > Indexes
and select “Use multiple Indexes”. Note that the list of “Available Indexes” below
already contains the standard index. To add further indexes, add the name of the
index (in the form that should also appear as a heading) to the “New” input field
and press the “Add” button. The new index should now appear in the list as well.
If you like, you can attribute an alternative label color to the new index by selecting
the index in the list and hitting the “Alter Color...” button. The label color may
help you to differentiate between index entries of different indexes in the IiyX work
area.

6Makeindex is very old, no longer under development and has many pitfalls, notably that it was
developed with only the English language in mind. So it fails to sort anything other than a
monolingual English text correctly. We have shown above how to fix this sorting. However, if
you are writing in another than the English language, consider to use xindy.
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Once the document changes have been applied, you can find the new index list
in Insert>List / TOC and the Insert menu has a separate index entry for each of the
defined indexes. The workflow is basically the same as for the default index, but
there are some additional features:

o If you want to change the attribution of a specific index entry, right-clicking on
the entry will open a dialog where you can do that.

o By right-clicking on an index, you can change its type. Furthermore, you can
specify an index list to be a “Subindex”. If you do that, the heading of that
list will be decreased by one level. E.g.. if you use a book class, where the
standard index heading is defined as a chapter, subindexes will be defined as
sections and can thus be nested to the non-subindexes.

6.7. Nomenclature / Glossary

Sometimes you need to compile a list of symbols that are mentioned in your document
with a brief explanation of them — a so called nomenclature or glossary.
To be able to create nomenclatures, you need the BTEX package nomencl installed.
You find it in the TEX-catalogue, [5] or in the package manager of your KTEX-system.
A nomenclature entry is created if you place the cursor after a symbol entry and

then use the menu Insert > Nomenclature Entry or the toolbar button . A gray box
labeled “Nom?” is inserted and a window pops up asking for the nomenclature entry.
A nomenclature entry consists of two main entries. The first is the symbol that
you want to refer to. The second is the description of the symbol.
Note: You have to enter valid KTEX-code for all fields of the nomenclature dialog.

6.7.1. Nomenclature Definition and Layout

If you have symbols in formulas, you have to define them in the Symbol field as
ETEX-formulas. For example to get “o”, insert this:

$\sigma$

The “$” character starts/ends the formula. The KTEX-command for the Greek letter
is the name of the letter beginning with a backslash “\”. For capital Greek letters,
start the command also with a capital letter, like \ Sigma.

(A short introduction to the ITEX-syntax is given in section 6.10.2.)

You cannot use the Text Style dialog to format the description text; you have to
use IXTEpX-commands. For example the description of the nomenclature entry for the
“o” in this document is:
dummy entry for the character \textsf{sigma}

The command \textsf sets the fonts to sans serif. To get bold font use the command
\textbf, for typewriter use \texttt, for emphasized use \emph.
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6.7.2. Sort Order of Nomenclature Entries

The nomenclature entries are sorted alphabetically by the ETEX-code of the symbol
definition. This leads to undesired results when you for example have symbols in
formulas. Suppose you have nomenclature entries for the symbols a and o. They
will be sorted by “a” and “$\sigma$” — the o will be sorted before the a since the
character “$” is considered in sorting.

To control the sort order, you can edit the Sort as field of the nomenclature dialog.
Then the nomenclature entry will be sorted by this entry and not the symbol defini-
tion. For the example given, you can insert sigma in this field for the o, then a will
be located before o.

For subgrouping and tips for using sort entries see the nomencl documentation,

[15].

6.7.3. Nomenclature Options

The nomencl package offers some options to adjust the appearance of the nomen-
clature. Here are some of its options, for more have a look at its documentation:

13

refeq Appends the phrase “, see equation (eq)” to every nomenclature entry, where
eq is the number of the last equation in front of the nomenclature entry

refpage Appends the phrase “, page (page)” to every nomenclature entry, where page
is the number of the page on which the nomenclature entry appeared

intoc Inserts the nomenclature in the Table of Contents

To use one or more of the options, add them to the comma-separated document class
options list in the Document > Settings dialog. In this document the options refpage,
intoc are used.

You can also use the first two options above only for certain nomenclature entries
when you add one of the following commands as last entry to the Description field in
the nomenclature dialog:

\nomrefeq Like the refeq option
\nomrefpage Like the refpage option
\nomrefeqpage Short notation of \nomrefeq\nomrefpage

\nomnorefeq, \nomnorefpage, \nomnorefeqpage Turns off the corresponding op-
tions

Words like “page” are automatically translated for some document languages. If not,
add these lines to your IXTEX preamble:

\renewcommand{\eqdeclaration}[1]{, see equation\nobreakspace(#1)}
\renewcommand{\pagedeclaration}[1]{, page\nobreakspace{}#1}

and replace “see equation” and “page” by their translation.
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6.7.4. Printing the Nomenclature

To print the nomenclature, use the menu Insert>Lists / TOCr>Nomenclature. A box
labeled “Nomenclature” will show the place where the nomenclature is printed in the
output. By right-clicking on it, the amount of space for symbols can be altered. You
can choose between these settings:

Default a space of 1cm is used

Longest label width the width of the widest symbol of all nomenclature entries is
used

Custom custom space

In the printed output the title of the nomenclature appears as “Nomenclature”. If
you are not happy with the name, you can change it by redefining the command
\nomname in the preamble. For example, in order to change the name to List of
Symbols, add the following line to the preamble:
\renewcommand{\nomname }{List of Symbols}

6.7.5. Nomenclature Program

Ly X uses the program makeindex, that is part of every I{TEX distribution, to generate
the nomenclature. IxX’s preferences dialog allows you to specify another program or
to control makeindex by adding options, see section C.6.3. The available options are
listed and explained in [15, 9].

6.8. Branches

Sometimes it is useful to hide some document parts in the output. For example a
teacher who is setting an exam obviously doesn’t want the pupils to see the answers,
but having questions and answers in the same document will make the life of the
markers of that exam much easier.

For these cases LyX allows you to put text into branches. The text will then only
appear in the output when its branch is activated. To create a branch, either select
the menu Insert > Branch > Insert New Branch (if you just want to specify a new branch)
or go in the Document > Settings dialog to Branches, where you can specify and change
the name of the branch, its activation state (whether the content of the branch is
shown in the output or not), its background color inside IyX and whether the name
of the branch should be appended to the document file name on export if the branch
is active (see below for an example). Furthermore, the dialog lets you merge two
branches (just rename one branch to the name of the other) and to add “unknown
branches” (i.e. branches that were added to the document via copy and paste from
other documents, without having been defined) to the document’s branch list.

94



6.9. PDF Properties

Text that should be in a branch is set into branch inset boxes. These boxes are
inserted via the menu Insert> Branch where you can choose a branch. You can later
change the activation state of the branch by right-clicking on them.

Here is an example, where only the question text appears, the answer branch is
deactivated and therefore does not appear in the output:

Question: Who was the first physics Nobel prize winner?

If you activate Filename Suffix in Document > Settings > Branches, the name of the
active branches will be appended to the file name at export. Consider for example
a file “Exam.lyx” which has the above branches. If “Filename Suffix” is active, the
PDF export file would be called “Exam.pdf” if both the “Question” and “Answer”
branch were inactive, “Fxam-Question.pdf” if only the “Question” branch was active,
likewise “Exam-Answer.pdf” if only the “Answer” branch was active, and “Exam-
Question-Answer.pdf” if both branches were active. This helps you to easily export
different versions of your document without much hassle.

To use conditional output inside places where you cannot insert branch insets, like
inside equations, you can code special IXTEX definitions for each branch. For example
you can define for the question branch?

\newcommand{\question}[1]{#1}

\newcommand{\answer }[1]{}

and for the answer branch

\newcommand{\question}[1]{}

\newcommand{\answer } [1]{#1}

Now it is possible to use the commands \question{...} and \answer{...} to
obtain conditional output. Here is an example formula where only the \question
part appears:

x2—2x—2:>x1:1+\/§.

Inside math, the same effect can be achieved using math macros, see the Math
manual.

6.9. PDF Properties

The Document Settings dialog allows you in the PDF Properties to set up special
options for the PDF output of your document. All options there are provided by the
ETEX-package hyperref.

Using hyperref will link all cross-references in the DVI- and PDF-output. This
means that the reader of your document will be able to click on a table of contents
entry or on a reference and he is shown the referenced document part. You can specify
in the dialog tab Hyperlinks how the links will look and if links for bibliographical
backreferences are created. The backreferences will appear in the bibliography behind
the different entries, showing the number of the section, slide, or page where the entry
is referenced.

"For an introduction to the M TEX-syntax, see section 6.10.2.
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In the dialog tab Bookmarks you can set if PDF-bookmarks should be created for
every section of your document to make it easier for readers to navigate through the
document. You can decide if the bookmarks should be numbered like your document
sections or not. With the open bookmarks level you can specify what sectioning level
should be displayed in the bookmarks when opening the PDF. For example level 2
will display all sections and subsections, while level 1 will only display the sections.

The header information in the dialog tab General are saved together with the PDF
as file properties. Many programs are able to extract this information to e.g. auto-
matically recognize who the author is and what the PDF is about. This is very useful
to sort, classify, or use PDFs for bibliography issues. When the option Automatic fill
header is set, Iy X tries to extract the header information from your document title
and author settings.

The option Load in fullscreen mode will open the PDF in fullscreen mode, which is
useful for presentations.

PDF properties are also used in this document. When you look in its document
settings, you can see that some additional hyperref options are used. For an expla-
nation of them we refer you to the hyperref manual [14].

6.10. TgX Code and the BTEX Syntax

6.10.1. TEX Code Boxes

As IyX uses BTEX in the background, it supports many I¥TEX commands and con-
structs, but not all. KEIEX contains hundreds of packages that provide different
commands. All the time packages are being updated and new ones added. This has
the advantage that you can typeset nearly everything as there is for every problem
a BTEX-package. But LyX can of course not be up to date and support all packages
and their commands.

But don’t worry, you can use any KITEX-command directly in IxX inside the TEX
Code box. A TEX Code box is created by the menu Insert > TEX Code or by the toolbar

button E- (shortcut Ctrl4-L). The box can be opened by left-clicking and closed by
right-clicking on it and selecting Close Inset.

You can insert complete or incomplete commands as TEX Code. Incomplete means
that the command argument can be Standard LyX text. For example, if you want
to draw a frame around a word and are therefore using the ITEX-command \fbox,
you can write the command part \fbox{ in a TEX Code box before the word and
the closing brace } in a second TEX Code box behind the word. The word between
the two TEX Code boxes is then the argument as it is in the following example:

This 15 a ine with a ‘fhox{ framed | word.

gives

This is a line with a word.
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Note: At the end of I¥TEX-commands without parameters, you have to insert a
space to let WTEX know that the command is finished.

6.10.2. Short Introduction to the BKTEX Syntax

When you write larger documents or books, you will need to know something about
the ITEX-commands that LyX uses in the background. Because IXTEX is based on
commands, you can “program” your text. This has the advantage that the layout
of the document can be changed at any time if you know the right commands. E.g.
imagine you have to write a manual for a product and the deadline is the end of the
day. Your boss has just complimented you for your good work but wants to have
all caption labels bold. But you have over a hundred figure and table captions with
non-bold labels in your manual. Of course it is impossible to change all caption labels
manually in one day.

Now KETEX comes into play. As mentioned above, for every problem there exists a
KETEX-package. First you have to find out which and therefore look into the KTEX
package database, [FW].

As result you find that the package caption is what you need. To use a package,
you have to load it in the document preamble (menu Documentt>Settings) with the
command

\usepackage[options|{package name}

All ITEX commands begin with a backslash, the command argument is set within
two braces and the options are set within two brackets. Note that not all commands
have an argument and options.

In your case the package name is caption. After a look in the documentation
of the package, you know that the option labelfont=Dbf will change the font of all
caption labels to bold. So you add the command

\usepackage[labelfont=bf]{caption}

to the preamble and the problem is solved.®

Note that some document classes have built-in solutions for well-known problems
like your case. For example if you use a KOMA-Script class, you don’'t need the
package caption, you can instead write

\setkomafont{captionlabel }{\bfseries}

in the preamble and the problem is solved. So if you plan to write a large document,
you should have a look at the documentation of the document class you want to use.
(\setkomafont is an example of a command with more than one argument.)

Commands in the preamble affect the whole document, while commands in the text
affect only the text after the command or only the text used as command argument.
To insert a IfTEX-command in text, use the TEX Code box as described in the previous
section.

If you want to learn more about KTEX and its syntax, have a look at the KTEX-
books [1, 2].

8For more commands provided by the caption package, have a look at its documentation, [11].
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6.11. Customized Page Headers and Footers

To define a custom page header and footer line for your document, you need to set
the headings style to Fancy in the Document > Settings dialog under Page Layout. As
a second step add in the menu Document > Settings>Modules the module “Custom
Header/Footerlines”. This module offers the following 6 styles:

Left Header, Center Header, Right Header
Left Footer, Center Footer, Right Footer

for the different positions in the header/footer.

Normally, headers and footers are set up in the beginning of the document. But
you can change them anywhere you want to. Figure 6.1 shows the page layout and
where the header /footer styles will appear.

Left Header Center Header Right Header

The normal text on the page goes here. The running header is above the
text, and the footer is below (including footnotes). Headers/footers
typically contain things like the page number, title of the chapter, company
logo but your can use almost anything, except of floats.

Left Footer Center Footer Right Footer

Figure 6.1.: Page layout with custom header and footer line.

6.11.1. Definition

To define your header line, add all 3 header styles. The things you add to the styles
appear on uneven pages, the things in the optional arguments on even pages. For
single-sided documents, the optional arguments will not be used and can be omitted.
If you leave a style or its argument empty, nothing appears in the output. Defining
the footer line works similar.

For the definition, you will need some KTEX-commands that are inserted as TEX
code (menu Insert> TeX Code):

\thepage prints the current page number
\Roman{page} prints the current page number with capital roman numerals
\roman{page} prints the current page number with small roman numerals

\leftmark prints the current section number and title. If the document has chapters,
it prints the current chapter number and title instead. It is called “leftmark”
because it usually goes in a left header.

Magic code: XCIX
T =
-



6. More Tools

\rightmark prints the current subsection number and title. If the document has
chapters, it prints the current section number and title instead. It is normally
used in the right header.

6.11.2. Default header/footer

The custom header/footer is not empty by default. The default header contains the
chapter and section title and the center footer has the page number. In order to
remove unwanted entries from the header/footer, include the relevant header/footer
style in your document, but leave it blank. So, if you do not want a page number in
the footer, include a blank Center Footer style.

6.11.3. Appearance

The header and footer will appear on normal pages. Some pages are different. The
title page has a style of its own, and so does any page that starts a new part or
chapter in your book. Such pages will not have the custom headers/footers, but that
is normal. There is for example no need to print a header with the chapter name on
the chapter page where the chapter heading is in big bold letters anyway.

6.11.3.1. Header and footer decoration line

By default, you get a 0.4 pt thick line below the header and no footer line. This can
be changed in the document preamble with the commands \headrulewidth and
\footrulewidth in the following scheme:

\renewcommand{\headrulewidth}{thickness}

Where thickness is a size in standard units like pt or mm. If you don’t want a line,
set the thickness to 0 pt.

The lines can also be colored, but this requires more knowledge of IXIEX. If you
really need this, have a look at the Internet or in sec. 4.4 of the book [MGO04].

6.11.3.2. Several header/footer lines

In case you need more than one text line as a header/footer, you can do this by
adding a normal line break in the style definition. However, the default height of
the header/footer is only the one of one text line. To expand the height, redefine
the WTEX length \headheight or \footheight in this scheme in your document
preamble:

\setlength{\ headheight } {height }

Where height is a size in standard units. If you don’t know which amount of space
is needed for the height, define your header/footer and preview your document as
PDF. Then open the IXTEX logfile via the menu Document>LaTEX Log and look via
the button Next Warning if you find a warning of the package fancyhdr. If there is
such a warning, it contains the space that you need at least for your header/footer.
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6.11.4. This example

This example demonstrates what can be done with custom header/footers. Don’t use
it for your document as it is just an example. This example consists of the following
definition:

Left Header \rightmark, empty optional argument
Center Header empty, empty optional argument

Right Header empty, \leftmark in the optional argument
Left Footer empty, \thepage in the optional argument

Center Footer LyX’s user guide, “Magic code:

T = ?” in the optional argument

Right Footer \Roman{page}, empty optional argument
\headrulewidth set to 2 pt

In principle you can use almost everything in headers/footers, except floats. For more
special things like e. g. thumb-indexes, see the manual of the fancyhdr package, [13].

Magic code: CI
=
-
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6.12. Previewing Snippets of your Document

LyX allows you to generate previews of sections of your document on the fly so you
can see how they will look in the final document without having to break your train
of thought with viewing the output.

6.12.1. Prerequisites

To get previews working, you need the KTEX package preview-latex (on some
systems named simply preview) installed. If it is not already installed, you will find
it in the TEX-catalogue, [5] or in the package manager of your XTEX-system. You
obtain prettier results if you install the program pnmcrop from the netpbm package;
for IyX on Windows this program and also the IXTEX-package are automatically
installed together with LyX.

6.12.2. Enabling previews

If you would for example like to see in IjyX your math formulas typeset by KTEX, acti-
vate the option Display Graphics in the Tools> Preferences dialog under Look and feel >
Display. Then set Instant Preview to On. The Preview Size is the multiplication factor
for the size.

Previews are generated when you load a document into IyX and when you finish
editing an inset.

Note: Previews of an already loaded document are not in every case immediately
generated by activating the option Display Graphics. Reopening the documents will
fix such problems.

6.12.3. Selected document parts

Besides math there are other cases where you might like to see a preview, for example
things that [yyX cannot render like rotated parts or things that are not yet supported
by IyX. To do this, insert a preview inset via the menu Insert>Preview. Insert or
paste the stuff that you want to preview into this inset. The preview will be generated
when the cursor is outside the preview inset. If you click on the preview, you can
edit the previewed stuff.

An example: To create rotated boxes, you use the KTEX command \rotatebox
which is not yet supported by IyX.? Instead of the TEX Code boxes you want to see
in LyX the final rotated boxes, for example to adjust the rotation angle to fit with
the surrounding text. Therefore you create a preview inset and copy the text with
the rotated boxes into it. Here is the result:

9\rotatebox is explained in section Rotated and Scaled Bozes of the Embedded Objects manual.
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2.
&) B
& S
& ¥
This is a line framed text \ and a formula.
Previewing works also for colors. In this example a special framed, colored box
was created using the BTEX command \fcolorbox:!°

If IyX does not show a preview, make sure that you enabled previews as described
above and also make sure that TEX Code in the preview inset is valid and that you
loaded the BTEX packages in your document preamble that are required by the TEX
Code. If IyyX cannot create a preview, you will in most cases also not be able to view
your document due to BTEX errors. So if you have to use some TEX Code and don’t
know if it is correct, the preview inset is a nice method to check it without the need
to view the whole document.

6.12.4. KBTEX source code

You can preview the IXTEX source of the whole document or parts of it. Use the
menu View > View Source and a window will be shown where you can see the KTEX-
source code. The window shows the source of the whole paragraph where the cursor
is currently in. You can also select document parts in [X’s main window, then only
this selection (when it is more than one paragraph) is shown as source code. To view
the whole document as source, enable the corresponding option in the source view
window.

6.13. Advanced Find and Replace

6.13.1. Introduction

The advanced find and replace feature of IyX allows for searching of complex, format-
sensitive text segments and mathematics contents within IyX documents. It is an
enhancement of the standard (quick) find and replace feature. The key-features are:

» Both searching of text and of mathematical formulas is allowed, where the latter
is done by entering mathematics in the usual way; not only entire mathematical
formulas are found, but also parts occurring within more complex formulas

o Search may be format-insensitive, so that the searched text is found in any
context/style (standard text, section headings, notes, and even mathematics),
or it may be format-sensitive, so that, for example, a word entered with a
section heading will only be found within section headings

10\ fcolorbox is explained in section Colored Bozes of the Embedded Objects manual.
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e Search may be widened to a specific scope, i.e. a set of files which may be all
the children of the document being edited, all the open files, or all the manuals
available from the Help menu

o Replace may optionally preserve capitalization, so that the replaced text capi-
talization is adapted to the matching text (i. e. all lowercase, all uppercase, first
uppercase followed by lowercase)

6.13.2. Basic usage
The advanced find and replace feature is activated through the menu Edit>Find &

Replace (Advanced) (shortcut Ctrl4-Shift+F) or the toolbar button IL"{\ This opens
the Advanced Find and Replace dialog.

6.13.2.1. Searching for text

Enter into the Find IxX mini-editor a simple word, and search for occurrences of it
by clicking on the Find Next button at the bottom of the dialog (or just press the
Return key). The entered word is found both in text mode and in math mode, and in
emphasized, bold or normal face, and in both in section titles and in standard text.
Pressing repeatedly Enter keeps searching forward. Similarly, pressing Shift+Enter
searches for the entered text backwards.

While searching, the Case sensitive option allows matches to occur only with the
same case as entered in the Find editor. The Whole words option allows matches to
occur only at word boundaries.

6.13.2.2. Searching for mathematics

Mathematical formulas may be searched for by typing in the Find editor a mathemat-
ical formula, such as 22 or also something more complex like 11% When searching
for a formula, it is found both when it is alone and when it occurs in sub-formulas and
nested parts of sub-formulas, for example the mentioned segments would be found in

something like i

1+.’62

6.13.2.3. Style-aware search

It is also possible to search for text with specific styles. This is done by switching
to the Settings tab of the dialog and unchecking the Ignore format option. This way,
entering in the Find editor

e a plain word and searching for it would not find instances of the word occurring
in emphasized or boldface.
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« an emphasized or boldface word and searching for it would find the respective
instances with same face only, and within the same text style only. Note that,
for example, an emphasized text is found not only when occurring alone, but
also when it is contained in a longer emphasized sentence.

« a plain word in a section heading, and searching for it, finds occurrences of if
only within section headings. Also, if the text to search is given an emphasized
or bold face, in addition to a section style, then it is found only when occurring
with the same style.

» some mathematics in a displayed formula will only find instances of this formula
that are also displayed formulas (and not inline formulas).

6.13.2.4. Replace

The text segments matching the text entered in the Find editor may be replaced with
the text segments entered in the Replace editor. In order to find the next occurrence
and replace it, click on the Replace button or alternatively press Enter or Shift+Enter
while being in the Replace editor.

You can replace full-featured formatted LyX segments in place of the matching
text segments in your document. Typical scenarios in which to use this capability
may be (just to mention a few):

o replacing occurrences of a word with a customized formatted version of the
same word, for example replacing occurrences of a name like “func()” with its
typewriter version "func()";

« performing a notation rework of mathematical symbols, for example replacing
occurrences of “R” with “R” (you may want to enable the Whole words and Case
sensitive options and disable the Ignore format option in the Settings tab, in order
to avoid replacing all “R” letters occurring in normal text), or occurrences of

% with z; j, or occurrences of x[k] with 2.

6.13.3. Advanced usage

There is a regular expression (regexp) based searching facility.!! You can search for
regular expression by inserting a regexp inset into the Find editor. This is done via the
menu Insert > Insert Regular Expression while the cursor is in the Find editor. Characters
entered within regexp insets are matched according to the regular expression matching
rules'?, while text entered outside regexp insets is matched exactly against the same

LA good explanation of regular expressions is given in this Wikipedia entry:
http://en.wikipedia.org/wiki/Regular__expression.

12Under the constraint that any (sub)expression must match a well-formed IyX text segment,
i.e. when matching IATEX code, no segments with unbalanced {} braces are allowed to match
expressions.
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text in the document. Note that it is allowed to cut and paste regexp-mode insets as
usual. Examples of using such a feature may be:

1. Searching for all fractions with a given denominator: for example, entering in
the Find editor the fraction 7"z (where the . on the numerator is the match-
everything regular expression) finds all fractions with the given denominator.

2. Searching for all text with a given style: for example, after unchecking the
Ignore format option from the Settings tab, entering a .* regular expression and
adding for it an emphasized or bold face, finds all emphasized and bold face text,
respectively. Also, inserting a .x regular expression in a bullet or enumerated
list or a section heading, you can find all bullet or enumerated lists or section
headings.

Finally, references to (sub)expressions in regexp may be used as usual, enclosing parts
of the expression within round braces (), and referring back to them through \1, \2,
etc.. For example, try searching for the regexp ([a — z|+)[[: blank :]]\1 in order to
find word repetitions, if there are any.

Note that back references work both when occurring within the same regexp, and
when occurring in multiple different regexps, where the numbering of back-referenced
sub-expressions is absolute, i.e. \1 always refers to the first occurrence of () in all
entered regexps.

Note also that the use of back references in the replaced text is not (yet) imple-
mented.

6.14. Spell Checking

LyX has a built-in spell checker. The menu Tools> Spellchecker, the key F7 or the

AB

toolbar button Q_} starts the spell checking beginning from the current cursor posi-
tion. A sidebar will appear showing any incorrect (or unknown) word found, allowing
you to edit and replace it in a second line. Whenever an unknown word is found,
the word is highlighted and the text scrolled so that it is visible. In the spellchecker
sidebar, there is a box showing suggestions for a correction, if any could be found.
Clicking on one of the corrections will copy it to the Replacement field, double-click
directly invokes the replacement. Unknown but correctly typed words can be added
to the personal dictionary.

By default, the dictionary file used is determined by the document language that
is set in the Document>Settings dialog. You can specify the language of a word in
the spellchecker dialog by choosing a different one at the top of the dialog. IyX can
correctly spell check documents containing multiple languages. This work if you have
marked the different languages appropriately and have the spell checker dictionaries
installed. LyX automatically switches to the appropriate dictionary file.
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6.14.1. Further Settings

In IyX’s preferences dialog under Language Setting> Spellchecker you can set the
following things:

Spellchecker engine Select the library IyyX should use for spell checking. Depending
on your platform, aspell, hunspell or enchant!® are available. On Windows
only hunspell is available.

Alternative language If this field is not empty, [yX will always use the given lan-
guage for the spell checking, no matter what the document language is.

Escape characters Allows you to add non-standard characters that the spell checker
should escape, e.g. German umlauts. This should normally not be needed.

Accept compound words Prevent the spell checker from complaining about com-
pounded words like “passthrough”.

Spellcheck continuously Check the spelling of your document as you type it. Mis-
spelled words get underlined with a dotted red line. By right-clicking on an
underlined word, suggestions from the spellchecker appear in the context menu.
Choosing one of them will replace the misspelled word with the suggested word.

Spellcheck notes and comments If enabled, the spelling of non-printed document
contents is checked as well.

6.15. Thesaurus

LyX provides a multilingual thesaurus. It uses the same thesaurus framework as
LibreOffice, OpenOffice and Firefox (namely the MyThes!* thesaurus library, which
is included in IxX). Therefore, IyX can directly access OpenOffice thesaurus dictio-
naries, which are available for many languages.

This section describes how new dictionaries are installed and set up for the use
with LyX.

6.15.1. Setting up the thesaurus

The MyThes/OpenOffice thesauri consist of two files per language: A file with the
suffix *.dat containing the data and an index file with the suffix *.idz. The stan-
dardized file names include the language code for the given language (e.g. en_ EN
for English). For instance, the English files are named:

e th en EN v2.idx

13Enchant itself is a wrapper library having different configurable back-ends. Please consult the
documentation or man-page of it to learn more.
Mhttp://lingucomponent.openoffice.org/thesaurus.html

107


http://lingucomponent.openoffice.org/thesaurus.html

6. More Tools

e th en EN v2.dat

If you have LibreOffice or OpenOffice and its thesaurus installed, these files should
be already on your system. If not, you can get dictionaries either from http:
//www.lyx.org/trac/browser/dictionaries/trunk/thes or from the site http:
//extensions.services.openoffice.org/en/search/node/thesaurus.! Put the
*.idr and *.dat files of all languages you want to use into one directory (do not use
subfolders), and specify the path to this directory in Toolst> Preferencesr>Paths. Now
the thesaurus should be ready to use.

6.15.2. Using the thesaurus

To start the thesaurus, use the menu Tools> Thesaurus or the toolbar button Lh'-ll
while the cursor is at the word you want to look up or while a word is selected. A
dialog pops up showing you probably related words that you can use as a replace-
ment. The proposals are grouped into categories. Note that the thesaurus does not
only show synonyms, but also hyperonyms and hyponyms (such as plant for tree),
compounds (such as tree diagram) and antonyms (such as women for men), which
are marked as such.

The language is automatically chosen from the language at the cursor, but you can
also switch it in the dialog, as you can enter new words to look up directly there.

Note that the thesaurus cannot handle phrases (only compounds that are in the
dictionary, such as the above tree diagram), and you have to use the so called lemma
form, i.e. the form that is used in the dictionaries (for many languages: first person
singular indicative active for nouns, infinitive for verbs). For example looking up the
word forms reports or reporting yields no results, while results are shown for the word
form report. Your best bet is to highlight only the relevant parts of such word (e. g.
report in reports), then you get proposals without adjusting the query in the dialog,
and also the replacement will probably be correct (as only the highlighted part will
be replaced, thus the ending remains).

6.16. Change Tracking

When you work on a document collaboratively it is extremely useful to be able to see
changes that others have made highlighted in the document. You can then decide
if you want to accept a change or not. This can be achieved by turning on change
tracking in the menu Document > Change Tracking> Track Changes.

Changes made in the document will then be highlighted by strokes and colors:
underlined text is an addition, eaneeled-text is a deletion. The color depends on the

5Note that, as of OpenOffice 3.0, the files on http://extensions.services.openoffice.org
are usually packed in extension archives (*.ozt) that contain other files such as spellchecker
dictionaries besides the thesauri. These archives are simple zip files, so you can unpack them as
you would unpack a zip archive.
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author that made the change. You can change the color in IxyX’s preferences dialog
under Look and feel, Colors. The author and the date of the change are shown in
LyX’s status bar when the cursor is in changed text. The same information is shown

when you use the toolbar button m’
When change tracking is activated, you will see the review toolbar in LyX:

27 42 Y372 051=

The review toolbar as shown above contains from left to right the following buttons:

Document > Change Tracking> Track Changes
Document > Change Tracking>Show Changes in Output
Jumps to the next change

Document > Change Tracking > Accept Change
Document > Change Tracking> Reject Change
Document > Change Tracking>Merge Changes
Document > Change Tracking > Accept All Changes
Document > Change Tracking> Reject All Changes

Insert > Note> LyX Note

W o W F sl I

Navigate> Next Note

The review toolbar helps you to accept, reject, or merge changes — highlight the
change and press one of the desired toolbar buttons. When you merge changes, a
window pops up showing you information about the next change after the current
cursor position. So you don’t need to highlight a certain change. Within the merge
window you can decide to accept or reject changes and step to the next change. This
way you can jump through all the changes in the document.

The toolbar has two buttons to handle notes because notes are often important to
describe a change.

To show the made changes in the output you need the I¥TEX package dvipost
installed. You will find it in the TEX Catalogue, [5] or in the package manager of
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your KTEX-system.

6.17. Comparison of Documents

You can compare two different [yX files via the menu Tools>Compare. The compar-
ison result is a Iy X file with change tracking enabled showing the differences. In the
comparison dialog you can select from which document LyX should take the document
settings for the resulting difference file with the option Copy Document Settings from.
The option Enable change tracking features in the output enables the change tracking
option Show Changes in Output to visualize the differences also in the PDF output of
the difference file.

6.18. International Support

This section describes how to use IyX with any language you want. For some non-
western languages there are special Wiki-pages that explain how to set up LyX to
use them: [19, 20, 21, 22

Besides languages, IyyX also supports phonetic symbols, see section A.4.2.

6.18.1. Language Options

The Document > Settings dialog lets you set the language and character encoding for
your language.
Choose your language in the Language section of this dialog. The default is English.
Under Encoding you can choose the character encoding map you want to use for
ETEX export. The option Language Default is the preferred choice and works well in
most cases. For details about the different encoding options see section B.

6.18.2. Keyboard mapping configuration

If you have for example a U. S.-style keyboard and want to write in a language other
than English, you can use an alternate keymap. For example, if you have a U.S.-
style keyboard but want to write in Italian, you can configure LyX to use an Italian
keymap. The preferences dialog allows you to choose up to two keyboard mappings,
see section C.2.3. You can choose primary and secondary keyboard languages and
then select which one you want to use.

Finally, you may just want to change a few key mappings or create an entirely
different keymap (for Vulcan, for instance). You may, for example, normally write in
[talian on a U.S. keyboard but want to include an occasional quotation in German.
In such a case, you can write your own keyboard mapping or modify an existing
one to support the characters you want. This and many other customizations are
explained in the Customization manual.
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Table 6.2.: The 1latinl character set
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6.18.3. Character Tables

Table 6.2 shows the Latinl character set. You should be able to enter the characters
in the first eight columns directly from the keyboard.

There are a few things you need to know about this table. Here are some of the
details you will need to bear in mind when using characters from the Latinl character
set:

o Even if you have selected latinl in the Document > Settings dialog, users who
have only the Ti-fonts for BTEX [or who have the Ti-fonts but aren’t using
them| will still miss a few characters: DO, FO, DE, FE, AB, and BB — the
uppercase and lowercase eth and thorn, and the french quotes will not show

up.

The following is a full list of all of the accented characters LyX can display directly.
It includes not only the accented characters from the previous table, but also the
characters from IS08859-2 through 4.

e From IS08859-1:

CTAETIOUAgiony diaeresis
~AEIOUa¢ion circumflex
“AEIOUacion grave
"AETIOUY4éisuy acute
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~ANOansd tilde
.C¢ cedilla
- macron

e From IS08859-2 through 4:

HJ ﬁj@@gégé circumflex
SZ§RLCNfléh acute
iU# tilde
SSTRLGIIENKnk cedilla
EeAIOUaiou macron
OUst Hungarian umlaut

All the characters above are actively supported by TEX fonts. In addition TEX allows
diacritical marks on almost all characters. Also make sure you're using the T1 font-
encoding.
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This appendix lists all the available menus and describes their functionality. It is
designed as a quick reference if you are searching for a special topic inside the user’s
guide.

A.1. The File Menu

Under the File menu are the basic operations in addition to some more advanced
operations.

A.1.1. New

Creates a new document.

A.1.2. New from Template

This menu entry prompts you for a template to use. Selecting a template will auto-
matically set certain layout features for the document, features you would otherwise
need to change manually.

A.1.3. Open

Opens a document.

A.1.4. Open Recent

The submenu shows a list of the recently opened files. Click there on a file to open
it.

A.1.5. Close

Closes the current document.

A.1.6. Close All

Closes all opened documents.
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A.1.7. Save

Saves the actual document.

A.1.8. Save As

Saves the actual document under a new name to create a copy.

A.1.9. Save All

Saves all opened documents.

A.1.10. Revert to saved

Reloads the actual document from disk.

A.1.11. Version Control

This is used when multiple people are working on the same document or when one
person wants to keep a careful archive of changes. It is described in the section
Version Control in LyX of the Additional Features manual.

A.1.12. Import

Here you can import files from older LyX-versions, HTML-files, XTEX-files, NoWeb-
files, plain text files and comma separated, table-like text files (CSV). The files will
be imported as a new [yX-document.

When using the menu entry Plain Text, line breaks in the text will start a new
paragraph; when using the menu entry Plain Text, Join Lines, consecutive lines of text

will be imported to one big paragraph. A new paragraph will begin when there is a
blank line in the file.

A.1.13. Export

You can export your document to various file formats. The resulting files are placed in
the directory of your LyX-file. The menu entries are not the same on all installations.
They depend on the programs found by IyX during its configuration.

Here is a list of all available entries; some of them are explained in detail in sec-
tion 3.8.2:

CJK LyX format of the special LyX 1.4.x versions for Chinese, Japanese and Korean
(CJIK)
Since LyX 1.5.0 CJK support is fully integrated into LyX.

DocBook text file with code in the language SGML that is used for the markup
language DocBook
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DocBook (XML) text file with code in the language XML that is used for the
markup language DocBook

DraftDVI ETEX'’s native DVI-format. This format is not suitable if you have special
characters or spaces in files paths or file names in your document. LyX use this
format internally as a pre-stage to export to DVI.

DVI DVI-format that also allows the useage of special characters or spaces in files
paths or file names

DVI (LuaTeX) DVI-format using the program LuaTgX; supports Unicode and the
usage of non-TEX fonts; Note: not all DVI-viewers are currently able to display
this output format properly.

Graphviz Dot text file with code in the programming language Dot which is used to
draw visualizations of graphs via the program Graphviz

HTML HTML-format (the HTML-converter is a third-party product and may not
work in all cases)

HTML (MS Word) HTML-format specialized so that the result can be imported to
MS Word; as a consequence of this formulas will be embedded as bitmap fonts
and not in the format MathML.

LaTeX (LuaTeX) text file with the KTEX source that is compilable with the pro-
gram LuaTX

LaTeX (pdflatex) text file with the IXTEX source, additionally all images used in
the document will be converted to a format that is readable by the pdflatex
program (GIF, JPG, PDF, PNG)

LaTeX (plain) text file with the BTEX source code, additionally all images used in
the document will be converted to the EPS-format, only this format is readable
by the latex program

LaTeX (XeTeX) text file with the WTEX source that is compilable with the program
XeTiX

LilyPond book (LaTgX) text file with the KTEX source and also code in the syntax
of the music notation software LilyPond

LyX Archive (zip|tar.gz) creates a zip-archive or a tar.gz-archive file (depending
upon your system) that contains your document and all files that are necessary
to compile it (images, child documents, BibTgX files, etc.)

(1))

LyX z.y.x IyX-Document in a format readable by the IxX versions z.y.x (“z” and

[

y” represent the version number)
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LyXHTML HTML-format using [yX’s internal XHTML engine

NoWeb text file with code in the format of the literate programming language NoWeb

OpenDocument OpenDocument-formatted file, to be opened with LibreOffice, OpenOf-
fice, KOffice, Abiword, etc. (The OpenDocument-converter is a third-party prod-

uct and may not work in all cases)

PDF (dvipdfm) PDF-format using the program dvipdfm, produces internally a DVI-
file which is then converted to a PDF-file

PDF (LuaTeX) PDF-format using the program LuaTgX, produces PDF-files directly

PDF (pdflatex) PDF-format using the program pdflatex, produces PDF-files di-
rectly

PDF (ps2pdf) PDF-format using the program ps2pdf, produces internally a PostScript-
file which is then converted to a PDF-file

PDF (XeTeX) PDF-format using the program XeTgX, produces PDF-files directly
Plain text text format

Plain text (ps2ascii) text format, the document will first be converted to Postscript
format and then exported as text using the program ps2ascii

Postscript PostScript format using the program dvips

Sweave text file with the IXTEX source and also code in the statistical programming
language R. Using the R-function Sweave it is possible to use R-commands in

ETEX

If one of the menu entries DVI, PDF (pdflatex) or Postscript is missing, you need to
update your ITEX installation. After updating you have to reconfigure LyX, see
section 1.4.

A.1.14. Print

With this menu entry you can print your document to a file in PostScript format or
send it to a printer. The printer will also use the document in PostScript format.
The conversion to PostScript is done in the background by [yX using the program
dvips. For more information have a look at section 3.8.4.
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A.1.15. Fax

This menu entry will only appear if you have a fax program installed (on Windows you
additionally need to register its program path to LyX’s PATH prefix, see section C.3).
With this menu entry you can send your document to a fax program like hylapex or
kdeprintfax. The default format of the sent file is PostScript. The format can be
changed in IyX’s preferences as described in section C.7.1.

A.1.16. New and Close Window

Opens or closes a new instance of LyX.

A.1.17. Exit

Prompts you to save all unsaved documents and then exits.

A.2. The Edit Menu

A.2.1. Undo and Redo

Described in section 2.3.

A.2.2. Cut, Copy, Paste, Paste Recent, Paste Special

Described in section 2.2.

A.2.3. Select Whole Inset

Selects the content of the inset where the cursor is currently in. If the cursor is
outside of an inset, the whole document will be selected.

A.2.4. Select All

Selects the whole document.

A.2.5. Find & Replace (Quick)

Described in section 2.2.

A.2.6. Find & Replace (Advanced)

Described in section 6.13.
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A.2.7. Move Paragraph Up/Down

This shifts the paragraph where the cursor is currently in one paragraph up or down.

A.2.8. Text Style

Described in section 3.7.5.

A.2.9. Paragraph Settings

Enables you to set the paragraph alignment, line spacing and label width. These
settings only affect the paragraph in which the cursor is currently in.

You can also prevent the first line of the paragraph being indented if you have
chosen to separate paragraphs with indents in the Document> Settings dialog under
Text Layout.

A.2.10. Table Settings and Math

These two menus are only fully active if the cursor is inside a table or a formula.
Here you can change the properties of tables and formulas. The properties of tables
are described in section 4.5, the properties of formulas in chapter 5.

A.2.11. Increase / Decrease List Depth

These menu entries are only active if the cursor is in an environment that can be
nested. They increase/decrease the environment nesting level as explained in sec-
tion 3.4 and 3.3.4.3.

A.3. The View Menu

At the bottom of the View menu the opened documents are listed.

A.3.1. Open/Close all Insets

Opens/closes all insets in your document.

A.3.2. Unfold/Fold Math Macros

Unfolds/folds the current math macro.
Math macros are described in the Math manual.
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A.3.3. View Source

Opens a window showing the source code of the actual document, as described in
section 6.12.

A.3.4. View Messages

Opens a window showing console messages. This is useful for debugging IyX (i.e.,
hunt for errors in the program) or to see what is going on in the background while
KTEX is processing the document.

A.3.5. View

This menu entry generates the output in the format you have specified as default
output format either in the preferences (see sec. C.7.2) or in the document settings
(see sec. B.20) and opens it in an appropriate viewer. The viewer can be set or
changed in the preferences, see section C.7.2. The default viewers are set by LyX
when it is first configured. The default output format is PDF (pdflatex).

A.3.6. View (Other Formats)

With this submenu you can view your document in alternative output formats. The
menu contains a list of available formats in which you can view the actual document
with an external program. The menu entries are not the same on all installations
— it depends on the ITEX programs that are found while IyX was configured. All
possible formats are listed in section A.1.13. You should at least see the menu entry
DVI. If it is missing, you need to update or repair your BTEX installation. After
updating you have to reconfigure IyX, see section 1.4.

Invoking a menu will start a viewer program. The viewer can be set or changed in
the preferences, see section C.7.2. The default viewers are set by LyX when it is first
configured.

A.3.7. Update

This menu entry allows you to update the view with your latest changes (in the
default output format) without opening a new viewer window.

A.3.8. Update (Other Formats)

With this submenu you can update the view of alternative output formats of your
document without opening a new viewer window.
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A.3.9. View Master Document

This menu item is only visible if your document is included to another document,
which is then its “master” (see section Child Documents in the Embedded Objects
manual for more information on this topic). This item allows you to view the master
document from within its child. That is, if you are working on a child document
which is a chapter of a book, View Master generates the output of the whole book,
while View will just output the chapter alone.

The format used by this function is the default output format as specified in the
preferences (see sec. C.7.2) or in the document settings (see sec. B.20).

A.3.10. Update Master Document

This menu item is only visible if your document is included to another document,
which is then its “master” (see section Child Documents in the Embedded Objects
manual for more information on this topic). This item allows you to update the view
of a master document from within its child without the need to switch to the master
document itself.

The format used by this function is the default output format as specified in the
preferences (see sec. C.7.2) or in the document settings (see sec. B.20).

A.3.11. Split View

This will split IryX’s main window vertically or horizontally. This allows you to view
documents at the same time to compare them, or to view the same document, but
at different positions. You can even split the main window several times to view for
example 3 or more documents at the same time. To return to an unsplit view, use
the menu Close Current View.

A.3.12. Close Current View

Closes a split view.

A.3.13. Fullscreen

Using this menu entry or pressing F11 removes the menu bar and all toolbars so
that you will see nothing but your text. It furthermore displays Iy X’s main window
fullscreen. To return from fullscreen to the normal view, press F11, or right-click and
turn off the fullscreen mode in the context menu.

A.3.14. Toolbars

In this menu entry you can set the appearance of the different toolbars. All toolbars
and the Command Buffer can be turned on and off. The on state is denoted in the
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menu with a checkmark. The Review, Table, Math Panels, Math Macros and Math
toolbars can be additionally set to the state automatic that is denoted in the menu
with the suffix (auto).

In the on state the toolbar is permanently shown, in the automatic state the toolbar
is only shown when the cursor is in a certain environment or when a certain feature
is enabled. That means that the review toolbar will only be shown if change tracking
is activated, the math and table toolbars are only shown if the cursor is inside a
formula or table, respectively.

LyX’s toolbars and their buttons are explained in section A.9.

A.4. The Insert Menu
A.4.1. Math

Inserts math constructs that are explained in chapter 5 and the Math manual.

A.4.2. Special Character

Here you can insert the following characters:

Symbols Inserts any character that can be output by your KTEX system. Therefore
the number of character categories in this dialog and the available characters
depend on the IXTEX-packages you have installed.

Note: Not all characters will be visible in the Symbols dialog because none of
the screen fonts that you can set in the preferences dialog (see sec. C.1.2) can
display every character.

Ellipsis Inserts an ellipsis: ...

End of Sentence Inserts an end of sentence dot as described in section 3.9.3.1.

n

Ordinary Quote Inserts this quote: ', no matter what quote type you selected in the
Document > Settings dialog under Language.

Single Quote Inserts this quote: ’
Protected Hyphen Inserts a hyphen that is protected from line breaks: -
Breakable Slash Inserts a slash where also a line break can occur: /

Menu Separator Inserts the menu separator sign: >

Phonetic Symbols Creates a formula with a so called tipa inset. Here you can insert

commands to create IPA phonetic symbols. For this feature you must have the
KTEX-package tipa installed.
For more information about this feature we refer you to the documentation of
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tipa, [18] and this Wiki-page:
http://wiki.lyx.org/LyX/LinguistLyX

A.4.3. Formatting

Here you can insert the following format constructs:

Superscript Inserts a superscript: test® P

Subscript Inserts a subscript: testsy

Protected Space Inserts a protected space that is described in section 3.5.1.
Inter-word Space Inserts an inter-word space that is described in section 3.5.2.1.
Thin Space Inserts a thin space that is described in section 3.5.2.2.
Horizontal Space Inserts horizontal space, see section 3.5.2 for a description.
Horizontal Line Inserts a horizontal line, see section 3.5.7 for a description.
Vertical Space Inserts vertical space, see section 3.5.3 for a description.
Phantom Inserts Phantom space, see section 3.5.2.5.

Hyphenation Point Inserts a hyphenation point, see section 3.9.2.

Ligature Break Inserts a ligature break, see section 3.9.4.

Ragged Line Break Inserts a forced line break, see section 3.5.6.

Justified Break Inserts a forced line break that furthermore stretches the broken
text line to the page border, see section 3.5.6.

New Page Inserts a forced page break, described in section 3.5.5.

Page Break Inserts a forced page break that furthermore stretches the broken text
page to the page border, described in section 3.5.5.

Clear Page Inserts a clear page break, described in section 3.5.5.1.

Clear Double Page Inserts a clear doublepage break, described in section 3.5.5.1.

A.4.4. List / TOC

Various lists can be inserted with this menu entry. The table of contents, the algo-
rithm, figures and tables list are described in section 6.2. The index list is described
in section 6.6, the nomenclature in section 6.7 and the BibTEX bibliography in sec-
tion 6.5.2.
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A.4. The Insert Menu

A.4.5. Float

To insert floats, described in section 4.6.

A.4.6. Note

To insert notes, described in section 4.1.

A.4.7. Branch

Inserts branch insets as described in section 6.8.

A.4.8. Custom Insets

Inserts document class-specific insets. Such insets only exist if they are defined in the
layout file for a certain document class. An example is the document class “article
(Elsevier)” with three custom insets. The section Flez insets and InsetLayout of the
Customization manual explains how custom insets are defined.

A.4.9. File

This menu entry allows you to insert or include the contents of other files in your
document. How you can do this is explained in detail in the chapter External Stuff
of the Embedded Objects manual.

A.4.10. Box

Inserts a minipage box that is described section 4.7. All box types supported by LyX
are explained in detail in the chapter Bozes of the Embedded Objects manual.

A.4.11. Citation

Inserts a citation as described in section 6.5.

A.4.12. Cross-Reference

Inserts a cross-reference as described in section 6.1.

A.4.13. Label

Inserts a label as described in section 6.1.
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A.4.14. Caption

Inserts a caption in a float or longtable. Floats are described in section 4.6, captions
in longtables are described in the section Longtable Captions of the Embedded Objects
manual.

A.4.15. Index Entry

Inserts an index entry as described in section 6.6.

A.4.16. Nomenclature Entry

Inserts a nomenclature entry as described in section 6.7.

A.4.17. Table

Inserts a table. Tables are described in section 4.5.

A.4.18. Graphics

Inserts a graphic. Graphics are described in section 4.4.

A.4.19. URL

Inserts a URL as described in section 6.3.1.

A.4.20. Hyperlinks

Inserts a hyperlink as described in section 6.3.2.

A.4.21. Footnote

Inserts a footnote, see section 4.2.

A.4.22. Marginal Note

Inserts a marginal note, see section 4.3.

A.4.23. Short Title

Inserts a short title, see section 3.3.4.4.

A.4.24. TgX Code

Inserts a TEX Code box, see section 6.10.1 for a description.
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A.4.25. Program Listing

Inserts a program listings box. Program listings are explained in the chapter Program
Code Listings of the Embedded Objects manual.

A.4.26. Date

Inserts the actual date. The format depends on the date format of the language that
is used for LyX’s menus. LyX offers various ways to insert a date which are explained
and also compared in the section External Material of the Embedded Objects manual.

A.4.27. Preview

Inserts a preview inset, see section 6.12 for a description.

A.5. The Navigate Menu

This menu lists the existing chapters, sections, figures, tables, etc. of the current
document. This allows you to navigate easily through your document.

A.5.1. Bookmarks

With this menu entry you are able to define your own bookmarks. This is useful
when you are working on a large document and often have to jump e.g. between
section 2.5 and 6.3. To create bookmarks for this example, go to section 2.5 and use
the submenu Save Bookmark 1. Then go to section 6.3 and use Save Bookmark 2.
Now you can jump easily between these sections by using the menu or by the key
bindings Ctrl+1 and Ctrl+4-2.

You can also use bookmarks to jump between several opened documents. The
saved bookmarks are valid till the document is closed.

A.5.2. Next Note, Change, Cross-reference

Jump to the next note, change, or cross-reference following the current cursor posi-
tion.

A.5.3. Go to Label

Only active if the cursor is in front of a cross-reference. Sets the cursor before the
referenced label. (It is the same as if you right-click on a cross-reference box and use
Go to Label).
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A.5.4. Forward Search

This feature allows you to directly jump to the corresponding text part in the out-
put, see section Forward search in the Additional Features manual for a detailed
description.

A.6. The Document Menu

A.6.1. Change Tracking

Change Tracking is described in section 6.16.

A.6.2. LaTeX Log

After running KTEX by viewing or exporting a document, this menu will be enabled.
It shows the logfile of the used KTEX-program.

Here you can see how IXTEX works in the background. Fzperts will find in it reasons
for KTEX-errors.

A.6.3. Outline
Opens the TOC/Outline window as described in section 2.5 and 6.2.1.

A.6.4. Start Appendix Here

This menu will start the appendix of the document at the current cursor position as
described in section 6.4.

A.6.5. Compressed

Un/compresses the current document.

A.6.6. Settings

The document settings are described in appendix B.

A.7. The Tools Menu

A.7.1. Spellchecker

Spell checking is explained in section 6.14.
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A.7.2. Thesaurus

The thesaurus is described in section 6.15.

A.7.3. Statistics

Counts the words and characters in the actual document or the highlighted document
part.

A.7.4. TeX Information

Shows you a list of the document classes and styles installed in your KTEX-system.

A.7.5. Reconfigure

This menu entry reconfigures LyX; that is, yX looks for IXTEX-packages and pro-
grams it needs; see also section 1.4.

A.7.6. Preferences

The preferences dialog is described in detail in appendix C.

A.8. The Help Menu

This menu lists the documentation files of LyX in the language of IyX’s menus. If a
file is not available in this language, the English version will be listed.

The menu KTEX Configuration shows a LyX-document with information about the
IXTEX-packages and classes found by LyX (see also section 1.5).

A.9. Toolbars

How to show or hide toolbars is explained in section A.3.14.
It is also possible to define custom toolbars. This is described in the Additional
Features manual.

A.9.1. Standard Toolbar
- |Standard | 9 =l =4 ’2\_3,9 ) (C |f:_';_'| H % & & E@ @ = B B | @ ==

The standard toolbar as shown above contains from left to right the following
buttons:

Standard
pull-down box for the environments
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File> New

Filer Open
FilerSave

File> Print

Tools> Spellchecker
Edit>Undo

Edit> Redo

Edit> Cut

Edit> Copy

Edit> Paste

Edit> Find & Replace

Navigate> Bookmarks > Navigate Back
Emphasize text, function of the Edit> Text Style dialog
Set text to noun style, function of the Edit> Text Style dialog

Formats text using the current settings in the Edit> Text Style dialog
Insert>Math > Inline Formula

Insert > Graphics

Insert > Table

Toggle outline window on/off, Document > Outline

Toggle math toolbar on/off

Toggle table toolbar on/off



A.9. Toolbars

A.9.2. Extra Toolbar
EEEEEEEs «a BEOENER EEEE@®w ' @ | [2FEW

The extra toolbar as shown above contains from left to right the following buttons:

Default

-
I

Numbered list

i
|

Ttemized list

List

Description list

- Ml

=-— Edit>Increase List Depth
-— Edit> Decrease List Depth

ws Insert>Float > Figure

Insert > Float > Table

) Insert > Label

Insert > Cross-Reference
Insert > Citation
Insert>Index Entry

Insert > Nomenclature Entry
Insert > Footnote

Insert > Marginal Note

[ ) o W = [

Insert > Note > LyX Note
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Insert > Box

@ Insert > URL
B

Insert> TeX Code
= Insert > Math > Macro
g Insert > Filer> Child Document

Edit> Text Style

Edit> Paragraph Settings

Tools> Thesaurus

A.9.3. View / Update Toolbar

R EE BE

The view / update toolbar as shown above contains from left to right the following
buttons:

View > View

View > Update

(G
ey
E’ View > Master

View > Update Master

Document > Settings > Output > Synchronize with Output
o View> View (Other Formats)

|%* View > Update (Other Formats)

* These icons might look different for you if you do not use the default icon set.
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A.9.4. Other Toolbars

The change tracking toolbar is explained in section 6.16, the table toolbar in the
Embedded Objects manual, the math macro toolbar in the Math manual.
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B. The Document Settings

The document settings dialog contains submenus to set properties for the whole doc-
ument and is called with the menu Document > Settings. You can save your document
settings as default with the Save as Document Defaults button in the dialog. This will
create a template named defaults.lyx which is automatically loaded by LyX when
you create a new document without using a template.

The button Use Class Defaults resets the document settings to the default of the
document class. This affects mostly class options, the page layout and Numbering &
TOC.

The different submenus of the dialog are explained in the following sections.

B.1. Document Class

Here you set the document class, class options, a graphics driver, and a master
document. Document classes are described in section 3.1.2.

With the button Local Layout you can load you own layout-file, that is not in IyX’s
layouts folder and thus not recognized by IyX as layout for a document class. For
more about layout-files, see the chapter Installing New Document Classes, Layouts,
and Templates of the Customization Handbook.

Some classes use special class options by default. If this is the case, they are
listed in the field Predefined and you can decide to use them or not. If you do not
exactly know what the default class options are for, it is recommended to leave them
untouched. The Graphics driver is used for KTEX’s graphics, color and page layout
packages. If using Default, the default driver for the ETpX-packages is used. It is
recommended that you use the default unless you know what you are doing.!

Specifying a master document is necessary if the current document is a child or
subdocument. The master document will be used by LyX in the background if the
child document is opened without its master. This way child documents are always
compilable. More about master and child documents is explained in the section Child
Documents of the Embedded Objects manual.

There is also an option to suppress the date and one to use the IXTEX-package
refstyle instead of prettyref for cross-references, see sec.6.1.

"'When you want to use one of the following drivers
dvi2ps, dvialw, dvilaser, dvitops, psprint, pubps, In
you first have to activate them in your IMTEX distribution, see section Driver support in
http://mirrors.ctan.org/macros/latex/required /graphics/grfguide.pdf.
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B.2. Child Documents

This submenu is only visible when your document includes child documents. Please
refer to the section Child Documents of the Embedded Objects manual for details.

B.3. Modules

Modules are explained in section 3.1.2.3.

B.4. Local Layout

See section 3.1.2.4 for a description.

B.5. Fonts

The document font settings are described in section 3.7.

B.6. Text Layout

You can specify if paragraphs should be separated by indentations or vertical skips.
The line spacing and the number of text columns can also be specified here.

Note that LyX will not show two columns or the set up line spacing on screen. That
would be impractical, often unreadable and is not part of the WYSIWYM concept.
However, it will be as you specified it in the output.

B.7. Page Layout

A description of this menu is given in section 3.1.4 and 3.1.3.

B.8. Page Margins

Here you can adjust the paper margins, see section 3.1.5.

B.9. Language

The document language and quote styles are set here. The encoding specifies how
the document content is exported to IXTEX (the LyX file is always encoded in utf8).
All characters that cannot be encoded using the specified encoding will be exported
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as IXTEX-commands (this can fail if a I¥TEX-command is not known for a particular
character).?

If you use the option Language Default, [yyX determines the encoding of a text
part from the language of this text. If the document contains text in more than one
language you may get more than one encoding in the IXTEX file. If you do not use this
option then the complete document will always use exactly one encoding. Checking
this option is the preferred setting.

LyX also supports Unicode output, which is particularly useful if you need lots
of special symbols or non-alphabetic scripts, respectively. If you want to use this
(and your I¥TEX installation supports Unicode), choose one of the four utf8 variants
from the list below. Unfortunately the Unicode support of standard KITEX is quite
incomplete, so it is not uncommon that a file with lots of Unicode symbols works
fine with Language Default (when LyX uses its list of known KTEX-commands), but
does not work with a fixed utf8 encoding (when the list of known ETEX-commands
is not used, because all Unicode symbols can be encoded in utf8). The situation
is much better with XeTEX and LuaTgX, two new alternative engines to standard
KETEX. Both engines support Unicode natively. IyX now also supports these two
engines (via the output formats PDF (XeTeX), PDF (LuaTeX) and DVI (LuaTgX), see
section 3.8.2). So if you are using many special or accented characters and Language
Default fails, you might try out one of these new engines.

The Language package determines the KITEX-package that is used for hyphenation
and the translation of strings like “Part”. The possible settings are:

Default uses the language package that is selected in Toolsr> Preferences> Language
Settings (see section C.5.1).

Automatic selects the most suitable language package for the view/export format
you will use. In many cases this will be babel. If the newer package polyglos-
sia is more appropriate (is the case when using XeTEX and/or non-TEX fonts),
this package will be used instead of babel.

Always Babel uses babel even if polyglossia would be more appropriate.

Custom allows you to specify a language package command of your choice. For
example if you want to use a language-specific package like ngerman (for
German texts), type in
\usepackage{ngerman}

None will not use a language package. This is necessary for some document classes
for scientific articles.

Here is a list with the important encodings:

2The known commands are defined in a text file (unicodesymbols). You can add commands for
unknown symbols to that file yourself, see the Customization manual for details.
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Language Default (no inputenc) Same as Language Default, but the XTEX-package
inputenc is not used. When using this, you probably need to load some ad-
ditional packages manually in the preamble and specify the used encoding for
text parts in foreign languages in TEX code.

ASCII the ASCII encoding, covers only plain English (7-bit ASCII). LyX converts
all other characters into KXTEX commands, which may result in a big file when
lots of IXTEX-commands are needed.

Arabic (CP 1256) MS Windows code page for Arabic and Farsi
Arabic (ISO 8859-6) for Arabic and Farsi
Armenian (ArmSCII8) for Armenian

Baltic (CP 1257) MS Windows code page for Estonian, Latvian and Lithuanian,
the same as the [SO-8859-13 encoding

Baltic (ISO 8859-13) for Estonian, Latvian and Lithuanian, a superset of the ISO-
8859-4 encoding

Baltic (ISO 8859-4) (latin 4) for Estonian, Latvian and Lithuanian, a subset of the
[SO-8859-13 encoding

Central European (CP 1250) MS Windows code page for ISO 8859-2 (latin2)

Central European (ISO 8859-2) (latin 2) covers Albanian, Croatian, Czech, Ger-
man, Hungarian, Polish, Romanian, Slovak and Slovenian

Chinese (simplified) (EUC-CN) for simplified Chinese, used especially on UNIX
OSes, since 2001 this encoding is officially replaced by the encoding GB18030,
as GB18030 is not available for IXTEX you should try to use the encoding Uni-
code (CJK) (utf8)

Chinese (simplified) (GBK) for simplified Chinese, is the same as the Windows
code page CP 936 except for the Euro currency sign, since 2001 this encoding
is officially replaced by the encoding GB18030, as GB18030 is not available for
ITEX you should try to use the encoding Unicode (CJK) (utf8)

Chinese (traditional) (EUC-TW) for traditional Chinese

Cyrillic (CP 1251) MS Windows code page for Cyrillic

Cyrillic (1SO 8859-5) covers Belorussian, Bulgarian, Macedonian, Serbian and Ukrainian
Cyrillic (KOI8-R) standard Cyrillic especially for Russian

Cyrillic (KOI18-U) Cyrillic for Ukrainian
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Cyrillic (pt 154) Cyrillic for Kazakh
Greek (ISO 8859-7) for Greek

Hebrew (CP 1255) MS Windows code page for Hebrew, a superset of the ISO-8859-
8 encoding

Hebrew (ISO 8859-8) for Hebrew

Japanese (CJK) (EUC-JP) EUC-JP encoding for Japanese, uses the KTEX-package
CJK, when using this, set the document language to Japanese (CJK)

Japanese (CJK) (JIS) JIS encoding for Japanese, uses the ITEX-package CJK,
when using this, set the document language to Japanese (CJK)

Japanese (non-CJK) (EUC-JP) EUC-JP encoding for Japanese, uses the KTEX-
package japanese, when using this, set the document language to Japanese

Japanese (non-CJK) (JIS) JIS encoding for Japanese, uses the IXTEX-package japanese,
when using this, set the document language to Japanese

Japanese (non-CJK) (SJIS) SJIS encoding for Japanese, uses the KTEX-package
japanese, when using this, set the document language to Japanese

Korean (EUC-KR) for Korean

Southern European (ISO 8859-3) (latin 3) covers Esperanto, Galician, Maltese and
Turkish

South-Eastern European (ISO 8859-16) (latin 10) covers Albanian, Croatian, Finnish,
French, German, Hungarian, Irish Gaelic, Italian, Polish, Romanian and Slove-
nian, is designed to cover many languages and characters with diacritics

Thai (TIS 620-0) for Thai

Turkish (1SO 8859-9) (latin 5) for Turkish, is like the ISO-8859-1 encoding where
the Icelandic letters are replaced by Turkish ones

Unicode (CJK) (utf8) Unicode utf8 with the IKXTgX-package CJK (for the lan-

guages Chinese, Japanese and Korean)

Unicode (XeTgX) (utf8) Unicode utf8 to be used with XeTgX and LuaTgX, which
use Unicode directly, without the help of the KTEX-package inputenc. IyX
automatically selects this encoding if you export or preview XeTEX or LuaTgEX.
Normally you do not need to set this encoding manually.

Unicode (ucs-extended) (utf8x) Unicode utf8 based on the XTEX-package ucs (com-
prehensive, including Latin, Greek, Cyrillic and CJK scripts).
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Unicode (utf8) Unicode utf8 based on the IXTEX-package inputenc. Currently only
a limited range of characters (mainly for Latin scripts) is supported.

Western European (CP 1252) MS Windows code page for ISO 8859-1 (latinl)

Western European (ISO 8859-1) (latin 1) covers the languages Albanian, Catalan,
Danish, Dutch, English, Faroese, Finnish, French, Galician, German, Icelandic,
Irish, Italian, Norwegian, Portuguese, Spanish and Swedish; better use the ISO-
8859-15 encoding instead

Western European (ISO 8859-15) (latin 9) like the ISO-8859-1 encoding, but with
the Euro currency sign, the ce-ligature and some characters used for French and
Finnish

Finally, the dialog lets you select a specific language package for the current docu-
ment. See sec. C.5.1 for more information on the language package.

B.10. Colors

Here you can alter the font color for the main text (default: black) and for Greyed out
notes (default: light grey). The button Reset sets the color back to the default.

You can also change the background color for the pages (default: white) and for
Shaded boxes (default: red).

The colors are not shown within LyX, only in the output. (This Greyed out note
appears blue in the output.)

Note, if you change the main text font color and use the option Color links in the
document settings under PDF properties, you probably also need to change the link
font color by using Additional options in the PDF properties. For example the option

linkcolor=black

sets the link text color to black. For more information, see the manual of the
ITEX-package hyperref, [14].

You can adapt the main text font color and the page background for every page in
your document if you use these commands as TEX Code behind a forced page break:

» For the page color:
\pagecolor{color name}

o For the text color:
\color{color name}

The color name can hereby be one of these: black, blue, cyan, green, magenta,
red, white, yellow

If you have changed a text or background color, you can use them under the following
names:
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o For the page background color:
page__backgroundcolor

e For the main text color:
document__ fontcolor

o For the Shaded box background color:
shadecolor

o For the Greyed out note text color:
note_ fontcolor

To see how to define and use custom colors, see section Colored Cells of the Embed-
ded Objects manual.

B.11. Numbering & TOC

Here you can adjust the numbering depth of section headings and the section depth
in the table of contents as described in section 3.3.4.3.

B.12. Bibliography

Here you can specify a citation style using the IXTEX packages natbib or jurabib.
You can enable a sectioned bibliography using the KTEX package bibtopic and you
can customize how the bibliography of the given document is being generated. For a
further description see section 6.5.

B.13. Indexes

Here, you can customize how the index of your document is being generated and you
can define additional indexes. Please refer to section 6.6 for details.

B.14. PDF Properties

The PDF properties are explained in section 6.9.

B.15. Math Options

These options will force IyX to use the KTEX-packages amsmath, esint, mathdots
und mhchem or to use them automatically when they are needed.

amsmath is needed for many constructs, so when you get IXTEX-errors in formulas,
ensure that you have enabled AMS math.
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esint is used for special integral characters, see section Big Operators of the Math
manual.

mathdots is used for special ellipses, see section FEllipses of the Math manual.

mhchem is used for chemical equations, see section Chemical Symbols and Equations
of the Math manual.

B.16. Float Placement

The float placement options are described in section Float Placement of the Embed-
ded Objects manual.

B.17. Listings

The listings settings are explained in chapter Program Code Listings of the Embed-
ded Objects manual.

B.18. Bullets

Here you can adjust the characters for the itemize levels. The itemize environment
is described in section 3.3.6.2.

B.19. Branches

Branches are described in section 6.8.

B.20. Output

Here you can define some output specifics for the current document:

Default Output Format: The format that is used when you hit “View”, “Update”,
“View Master Document” and “Update Master Document” in the View menu or
the toolbar. The default is set in Tools > Preferencest> File Formats, see sec. C.7.2.

Synchronize with Output settings for the menu Navigate > Forward search. For a de-
tailed description see section Reverse DVI/PDF search of the Additional Fea-
tures manual.

XHTML Output Options settings for the export format LyXHTML. Strict XHTML 1.1
will assure that the output follows exactly version 1.1 of the XHTML standard.
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The different Math output settings are described in detail in section Math Out-
put in XHTML of the Additional Features manual. The scaling is used for the
size of equations in the output.

B.21. LaTeX Preamble

In this text field you can enter commands to load special IXTEX-packages or to define
ETEX-commands. The preamble is a thing for ¥ TEX-experts. You should not enter
commands here until you exactly know what you are doing.

An introduction to the WTEX-syntax is given in section 6.10.2.
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C. The Preferences Dialog

The preferences dialog is called with the menu Toolst> Preferences. It has the following
submenus.

C.1. Look and Feel

C.1.1. User Interface
C.1.1.1. User Interface File

The appearance of the menus and toolbars can be changed by choosing a user interface
(ui) file. A ui-file is a text file where the toolbars and menus are listed. The toolbar
buttons and menu entries are specified in the files stdtoolbars.inc and stdmenus.inc,
respectively. Both files are loaded by the default.ui file. To create your own menu
and toolbar layout, start with a copy of these files and edit the entries.

The syntax of the .inc-files is straightforward: The Menubar, Menu and Toolbar
entries must be finished with an explicit End. They may contain Submenu, Item,
Optltem, Separator, Icon, and in the case of the “file lastfiles” menu a Lastfiles entry.
The syntax for the entries is:

Item “menu or button name” “IyX-function”
All LyX-functions are listed in the menu Help>LyX Functions.

An example: Assuming you use the menu Navigate>Bookmarks quite often and
therefore want six available bookmarks, you can add the line

Item “Save Bookmark 6” “bookmark-save 6”
to the “navigate bookmarks” menu in the .inc-file to have the sixth bookmark.

C.1.1.2. Icon Set

Here you can change the appearance of [y7X’s toolbar buttons. The currently available
icon sets are compared in this image.

C.1.1.3. Automatic help

The option Enable tool tips in main work area enables tool tips showing the content of
closed insets like index entries or footnotes.
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C.1.1.4. Session

With the option Restore window layouts and geometries [y X’s main window will be
opened with the size and layout that was used in the last LyX session.

The option Restore cursor positions sets the cursor to the position in the file where
it was at the end of the last session.

The option Load opened files from last session opens all files that were opened in
the last LiyX session.

The button Clear all session information deletes all information from previous [yX
sessions (cursor positions, names of last opened documents, etc.).

C.1.1.5. Documents

Backup original documents when saving creates a backup copy of the file in the state
when it was opened or when it was saved the last time. It is stored in the same folder
as your document or in the Backup directory, see C.3. The backup file has the file
extension “.lyx~".

With the option Backup documents, every, you can specify the time between backup
saves.

Save documents compressed by default saves the files always in a compressed format.

Maximum last files is the number of last opened files that IyX should display in the
menu File>Open Recent.

If the option Open documents in tabs is not used, then every file will be opened in
its own new instance of IyX.

The option Single instance is only active if a IyXServer pipe' is specified. If it
is checked, IyX documents will be opened in the same running instance of LyX.
Otherwise a new Iy X instance is created for each file.

With the option Single close-tab button there will only be one button (D) at the
right side of the tab bar to close tabs. Otherwise every document tab has its own
close button.

Note: For the last option you have to restart LyX before the change takes effect.

C.1.2. Screen Fonts

These fonts are used to display your documents on the screen.

Note: This section only deals with the fonts inside the IyX window. The fonts
that appear on the output are independent from these fonts, and set in the menu
Document > Settings > Fonts.

By default, IyX uses Times as roman (serif) font, Arial or Helvetica (depends
on the system) as sans serif font and Courier as typewriter font.

You can change the font size with the Zoom setting.

1See sec. C.3 for information about LyXServer pipes.
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The Font Sizes are calculated as letter height in units of points. 72 points have the
size of 1inch, see Appendix D. The default font sizes are the same as if a document
font size of 10 pt were used. The sizes are explained in detail in section 3.7.3.

With the option Use Pixmap Cache to speed up font rendering enabled, Iy X needs
to redraw the screen less often. This results in better performance, especially on slow
systems. On the other hand, the characters might look more fuzzy on screen. So
whether you enable this or not depends on whether you prefer speed over aesthetics.
Note that the Pixmap Cache is only available and useful under Mac OS and Windows.

C.1.3. Colors

Here you can change all the colors used by [yX. Choose an item in the list and use
the Alter button.

By using the option Use system colors the color scheme of your OS or window
manager is used. The colors cursor, selection, table line, text, URL label and URL text
are then not customizable and thus not listed.

C.1.4. Display

Here you can specify if graphics inside LyX are displayed.

Instant Preview enables previewing snippets of your document. This feature is
described in section 6.12.

The option Mark end of paragraphs displays a pilcrow (9) at the end of every
paragraph.

C.2. Editing

C.2.1. Control
C.2.1.1. Editing

The option Cursor follows scrollbar sets the cursor to the top of the currently displayed
document part when scrolling.

You can adjust the width of the cursor. If you set the value to zero the thickness
of the cursor scales relative to the zoom value you choose for the screen fonts.

Scroll below end of document is self-explanatory.

In IyX one can jump from word to word by pressing Ctrl+arrow key. With the
option Use Mac-style for cursor moving between words the cursor jumps from the end
of a word to the end of the next word. Normally it jumps from the beginning to the
beginning.

The option Sort environments alphabetically sorts the entries in the pull-down box
for the paragraph environments.

The option Group environments by their category groups the entries in the pull-down
box for the paragraph environments.
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The math macro editing option determines the editing style, see the section Math
Macros of the Math manual.

C.2.1.2. Fullscreen

Here you can specify what is hidden in the fullscreen mode. The option Limit text
width specifies the width of the text in fullscreen mode. This way you can display
the text smaller than the screen; the text then appears centered.

C.2.2. Shortcuts
C.2.2.1. Bind File

Bindings are used to bind a LyX-function to a key. Several binding files are available:
cua.bind typical set of PC keyboard shortcuts

(x)emacs.bind set of bindings like they are used in the editor programs Emacs
(XEmacs)

mac.bind set of bindings for Mac OS systems.

There are also bind-files designed for special document classes, like broadway.bind,
and bind files for special languages. The names of language bind-files begin with a
language code, e.g. “pt” for Portuguese. If you use IxyX in a certain language, IxyX
will try to use the appropriate bind-file.

Some bind-files, like math.bind, have only a small scope. When looking at the end
of the file cua.bind, you can see that they are included to keep the overview in the

bind-file.

C.2.2.2. Editing Shortcuts

To add new or modify existing keybindings to your own taste you can use the table
in the dialog that lists all IyyX-functions and the bound shortcuts. To find functions
easily, they are grouped by categories and the dialog provides the field Show key-
bindings containing. In this field you can insert a keyword for a function you want to
edit. Insert there for example as keyword “paste” and you get the 4 different existing
shortcuts for the 3 different functions that contain “paste” in their name. As you can
see, one function can have more than one shortcut. All IyyX-functions are also listed
in the file LyX Functions that you will find in the Help menu.

To add e. g. the shortcut Alt4+Q for the function textstyle-apply, select the function
and press the Modify button. A dialog pops up where you can add the shortcut by
using it. So press Alt+Q to define the shortcut. Modifying an existing shortcut is
done the same way. You can also bind multiple functions to one shortcut by modifying
an existing binding and adding the different function names as a semicolon separated
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list. LyX will then use the first function that is enabled in the current document
part. The binding for the function command-alter is an example of this.
Alternatively you can also edit shortcuts by modifying bind-files with a text editor.
The syntax of the entries is:
\bind “key combination” “LyX-function”

C.2.3. Keyboard / Mouse

Normally keyboard settings have to be done in a menu of your operating system. For
the case that this is not possible, IyyX provides keyboard maps. If you have e.g. a
Czech keyboard but want to write with it like with a Romanian one, you can use the
keyboard map file named romanian.kmap.

Note: Keyboard maps are only provided as makeshift and don’t work on all
systems.

You can furthermore specify here the Wheel scrolling speed. The standard value is
1.0, higher values speed up the scrolling, lower ones slow it down.

In the section Scroll wheel zoom you can select a key for zooming. When this key
is pressed and the mouse wheel is rotated, the text is zoomed.

C.2.4. Input Completion

Input completion is described in sec. 2.6.

C.3. Paths

Working directory This is yX’s working directory. It is the default when you Open,
Save or Save as files.

Document templates This directory will be opened when you use the menu Filer
New from Template.

Example files This directory will be opened when you use the button Examples in
the Filer Open dialog.
Note: The Examples button does not exist when using [xX on Mac OS and
Windows systems.

Backup directory Backup copies will be saved to this directory. If no directory is
given but backups are enabled as described in section C.1.1.5, the Working
directory will be used to save the backups.

Backup files have the ending “lyx~".

LyXServer pipe Here you can enter the name of a so-called UNIX-pipe. This pipe
is used to send data from external programs to LyX.
Example: You add a BibTgX-database test.bib to your document. You can
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edit this file with the program JabRef. In JabRef you have to use the same
Unix-Pipe for LyX in its preferences under External programs. If you want to
get one entry of the database as citation, select it in JabRef and click on the
LyX-symbol. The entry will now be inserted as citation at the current cursor
position in your LyX file. JabRef and IxyX need of course to be run the same
time.

The pipe is also used for the Single instance feature, see sec. C.1.1.5.

To use the Iy XServer-Pipe on Windows, you must use this pipe name:

\\-\pipe\lyxpipe
Temporary directory Temporary files will be saved in this directory.

Thesaurus dictionary Directory where the thesaurus dictionaries are located. You
only need to specify it if the thesaurus does otherwise not work or if you want
to use custom/alternative dictionaries.

Hunspell dictionary Directory where the dictionaries of the spell checker program
Hunspell are located. You only need to specify it if you are using Hunspell and
spell checking does otherwise not work or if you want to use custom/alternative
dictionaries. For [ryX on Windows Hunspell is the only available spell checker
and should work without specifying a directory.

PATH prefix This field contains a list of paths to external programs. When IxX
needs to use an external program, it looks in this list where to find it on the
system. The path list is automatically set up on Windows and Mac systems
when IyX is configured, so that you normally don’t have to modify it. On
Unix / Linux systems, the path list will need to be set only if there are external
programs you wish to use that are not in your normal system path ($PATH).

TEXINPUTS prefix The TEXINPUTS environment variable allows to use external
files which are included to a LyX document via commands in TEX code or in
the document preamble. This prefix includes by default the document direc-
tory (represented by a single dot 7). The prefix can contain any list of paths
separated by the default separator of the OS (*:" on UNIX like systems and ’;’
on Windows). If files are included, the paths listed in the TEXINPUTS prefix
will be scanned for the input files. Note that any non-absolute path listed in
the TEXINPUTS prefix is considered to be relative to the directory of your

LyX file. It is recommended to include always "’ as one of the paths, otherwise
compilation may fail for some documents.

C.4. Identity

Here you can insert your name and email address. The identity will be used when
you have enabled change tracking as described in section 6.16, to mark changes you
make as yours.
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C.5. Language Settings

C.5.1. Language

User Interface language Here you can select the language of [y X’s menus. You find
the actual translation status here: http://www.lyx.org/I18n

Language package determines which IXTEX package should be loaded to handle lan-
guage issues. Language issues that are handled by this package include proper
hyphenation as well as localization of dates and text strings such as “Chapter”
and “Table”. The most widespread language package is babel, it is the default
language package in classic ITEX. More recent typesetting engines such as
XeTEX and LuaTgEX come with the alternative language package polyglossia
that is more suited for the multi-script support of these engines. Furthermore,
there are also specific language packages for languages not covered by babel.
The available selections are described in sec. B.9.

Command start If a special KTEX-package is needed to write in a certain docu-
ment language, you can here specify the command to start the package. An
example is the start command \begin{arabtext} that is needed to write Arabic
using the package ArabTgX, see [19]. The default is the babel command
\selectlanguage{$$lang}.

Command end Counterpart to Command start. Some packages, like the default,
don’t have an end command since the start command toggles the package on
and off.

Default Decimal Point Define the default decimal point for the use in tables (deci-
mal point alignment).

Set languages globally When this option is set, the languages used in the document
will be added as options to the document class options, so that they can be
used by all IXTEX-packages. Otherwise they will only be used as options for the
babel package.

Auto begin When this option is set, documents start with the chosen document
language. When this option is not set, the Command start is explicitly set to
the beginning of the document in the IXTEX-output. This assures that the
correct language is used when you use another Command start than the default.

Auto end Counterpart to Auto begin. When it is not set, the Command end is set to
the end of the document.

Mark foreign languages Text marked formatted in a language different from the
document language will be underlined in blue.
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Enable RTL support Enables the use of languages, written from right to left (RTL),
like Arabic, Hebrew, Farsi.

Cursor movement When writing RTL, you can define if the left and right arrow keys
move the cursor visually to the left or right, respectively, or logically. Logical
means that the cursor is moved to the left when pressing the right arrow key
and the cursor is inside text in an RTL language.

C.5.2. Spellchecker

The spellchecker settings are explained in section 6.14.

C.6. Outputs
C.6.1. General

Output line length sets the maximum number of characters printed in one line when
using the menu File> Export > Plain text. Setting the line line length to 0 means
all text is printed in one endless line.

Date format The date format can be one or a mixture of the formats listed here:
http://unixhelp.ed.ac.uk/CGI/man-cgi?date
For example the format
%d /%om /Yoy
prints the date as day/month/year.

Overwrite on export Setting what [yX is allowed to overwrite on export.

Forward search Commands that will be used for the menu Navigate > Forward search.
For a detailed description see section Reverse DVI/PDF search of the Addi-
tional Features manual.

C.6.2. Printer

Default printer Here you can specify the name of your default printer. The name
will be used when the Printer command is executed.
Note: You can leave this field empty on Windows systems because it has no
effect.

Printer command is the command IxX /ETEX uses for printing. The default is
dvips on most systems.

Printer Command Options Here you can specify printer options. A list of printer
options with explanations can be found in the documentation of the program
that provides the Printer command you are using.
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C.6. Outputs

Adapt output to printer This option works only for the Printer command “dvips”. It
activates a configuration file for dvips. This is an option only for dvips experts.

C.6.3. LaTeX

Use LaTeX font encoding This is the default encoding of the document font. T1
is the default and covers western languages and symbols. T2A, T2B, T2C, LCY
and X2 are used for Cyrillic. Combinations of the encodings are possible, like
“T1, T2B”. The font encoding is normally automatically loaded by the language
packages Iy X sets up in the background. So there is no need to change the
default encoding.

Default paper size This is the paper size that is used for new documents. The
Default value depends on your BETEX-system setup.

DVI viewer paper size options They only have an effect when the program xdvi is
used as DVI-viewer, read its manual to find out more.

Here you can also specify options and commands with parameters for processors. But
before you change something, it is strongly recommended to read the manuals of the
applications.

Bibliography generation Settings for the generation of the bibliography, see sec-
tion 6.5.2.

Index generation Settings for the generation of the index, see section 6.6.6.

Nomenclature command Command for the program that generates the nomencla-
ture, see section 6.7.5.

CheckTeX command Command for the program Check TEX that is described in the
section Checking TEX of the Additional Features manual.

There are additionally the following options:

Use Windows-style paths in BTEX files Uses paths in the notation of Windows,
that means that “\” is used instead of “/” to separate folders. This option
is enabled by default when you use LyX on Windows.

Reset class options when document class changes Removes all manually set doc-

ument class options in the Document > Settings dialog when changing the doc-
ument class.
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C. The Preferences Dialog

C.7. File Handling

C.7.1. Converters

Here you find the list of defined converter commands to convert material from one
format to another. You can modify converters or create new ones. To modify a
converter, select it, change the entry of the field Converter and/or Extra flag and
press the Modify button. To create a new converter, select an existing one, select a
different format in the To format drop-down list, modify the Converter field and press
the Add button.

If the Converter File Cache is enabled, conversions will be cached as long as specified
in the field Maximum Age (in days). This means that images don’t need to be converted
again when you reopen a document; the converted images from the cache will be used
instead.

More about converters, like the flags that can be used in the converter definition,
is described in the section Conwverters of the Customization manual.

C.7.2. File Formats

Here you find the list of defined file formats that IyX can handle. You can modify
the viewer and editor program that should be used for certain formats.

Furthermore, you can define the Default output format that is used when you use
View, Update, View Master Document or Update Master Document in the View menu
or the toolbar.

More about formats and their options is described in the section Formats of the
Customization manual.

Since all conversions from one format to another take place in IyX’s temporary
directory, it is sometimes necessary to modify a file before copying it to the temporary
directory so that the conversion may be performed. This is done by specifying a
Copier. More about this is described in the section Copiers of the Customization
manual.
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D. Units available in LyX

To understand the units described in this documentation, D.1 explains all units avail-
able in IyX.

Table D.1.: Units

unit | name/description
mm millimeter
cm centimeter
in inch
pt point (72.27pt = 1in)
pc pica (1pc = 12pt)
sp scaled point (65536 sp = 1pt)
bp big point (72bp = 1in)
dd didot (72dd ~ 37.6 mm)
cc cicero (1cc = 12dd)
Scale% % of original image width
text% % of text width
col% % of column width
page% % of paper width
line% % of line width
theight% % of text height
pheight% % of paper height
ex height of letter x in current font
em width of letter M in current font
mu math unit (1mu = 1/18em)
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Nomenclature

a dummy entry for the character a, page 93
Alt Alt or Meta key, page 8

Ctrl Control key, page 8

Esc Escape key, page 8

Shift Shift key, page 8

Tab Tabulator key, page 7

o dummy entry for the character sigma, page 93
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Abstracts, 28
AMS math, 82
Appendix, 86

Backup
Directory, 147
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Bibliography, 28, 86
BibTgX, 87
Databases, 87
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Bindings, see Key Bindings
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Branches, 94
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Change Tracking, 108
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Character Styles, 47
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background, 138
Change tracking, 109
LyX screen, 145
main text, 138
Text, 50
Comparison of documents, 110
Converters, 152
Copiers, 152
Cross references, 83
Customization
of menus, 143
of toolbars, 143

Dashes, 55
Date Format, 150
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Branches, 94

Change Tracking, 108
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Font, 45
Header/Footer line, 99
Language, 110
Layout, 13

Local Layout, 12
Margins, 14

Modules, 11

Paper size, 13
Preview, 54, 102

Settings, 9, 11-15, 18, 21, 41, 45,

o7, 82, 88, 110, 133
Title, 16
Types, 9
Dummy entries
italic page number:, 90
mafis, 90
maison, 90
maitre, 90
my entry, 91

This is an italic dummy entry, 90

Editing, 4
EPS, see Image formats
External Material, 123

File formats, 52, 152
ASCII, 52
DVI, 52
KETEX, 52
PDF, 53
PostScript, 52
File handling, 152
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Key Bindings, 7, 146
Editing, 146
Keyboard Map, 147

Language
Encoding, 134
Options, 110
Phonetic symbols, 121
Settings, 149
KETEX Syntax, 97
KETEX-packages
amsmath, 139
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bibtopic, 139
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dvipost, 109
enumitem, 24, 26, 158
esint, 139
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preview-latex, 102
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KETEX-packages
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Layout Modules, 81



Letters, 27
Ligatures, see Typography
Line breaks, 42
Lists, 20
Customization, 26
Customized, 24
Description, 22
Enumerate, 21
Custom, 24
Resumed, 25
[temize, 20
LyX list, 23
Spacing, 26
Longtables, 65
Caption, 124
IyX
Basics, 9
Proper names, 58
Reconfigure, see Reconfiguration of
LyX

Marginal notes, 62
Margins, 14
Math, 73
Accents, 76
AMS, 82
Arrays, 77
Basics, 73
Brackets, 77
Delimiters, 77
Exponents, 74
Font sizes, 81
Formula numbering, 79
Fractions, 74
Functions, 76
Integrals, 75
Limits, 75
Macros, 80
Matrices, 77
Multi-line Equations, 77, 82
Navigating, 73
Referencing formulas, 79
Roots, 75
Spaces, 75

Index

Subscripts, 74
Sums, 75
Symbols, 75
Text, 81
Typefaces, 80
Menu
Document, 126
Edit, 117
File, 113
Help, 127
Insert, 121
Navigate, 125
Tools, 126
View, 118
Minipages, 71
Mouse Operations, 5

Navigating, 6
Nesting
Environments, 30
Examples, 34
Tables etc., 32
Nomenclature, 92
Layout, 92
Options, 93
Printing, 94
Program, 94
Sort order, 93
Notes, 61

Outline, 85

Page breaks
Clear, 42
Forced, 42
Paragraph
Environments, 15
Indentation, 14
Line spacing, 15
LyX code, 29
Separation, 15
Settings, 118
Verse, 20
Paragraph environments, 15-30
Paste, 4
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PDF, 53, 63

PDF properties, 95
Phonetic symbols, 121
PNG, see Image formats
Poetry, 20

Preferences, 2, 143
Printer, 150

Program listings, 125
Punctuation marks, 56

Quotation, 19
Quotes, see Typography

Reconfiguration of IyX, 127
Reconfiguration of IyX, 2, 12, 116, 119

Redo, 5
Replace, 4, 103

Section headings, 17
Numbered, 17
Short titles, 18
Unnumbered, 18

Settings
Color, 145
Date format, 150
Display, 145
Editing, 145
Keyboard Map, 147
Language, 149
KETEX, 151
Paths, 147, 151
Printer, 150
Shortcuts, 146

Shortcuts, see Key Bindings

Spaces
Inter-word, 39
inter-word, 56
Protected, 38
Thin, 39
thin, 56

Spacing, 38
Fills, 39, 41
Horizontal, 38
Phantom, 40
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Vertical, 41
Spell checking, 106
SVG, see Image formats

Table of contents, 85
Tables, 64
Cells, 67
Longtables, 65
TEX Code, 96
TEX Information, 127
Text Style, 47
Thesaurus, 107
Toolbar, 120
Extra, 129
Macro, 131
Review, 109
Standard, 127
Table, 131
View / Update, 130
Typography, 55
Ligatures, 57
Quotes, 57
Units, 58

Widows and orphans, 59

Undo, 5
Units, 153
URLs, 85

Word completion, see Input completion

Word count, 127
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