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1. Figures

1.1. Graphics Dialog

To insert an image into your document, place the cursor at the text position you want

||
and click on the toolbar icon B or use the menu Insert> Graphics. Then a dialog
will appear to choose the file to load. The image will appear in the output exactly
at the position where it is in the text.

The graphics dialog can be called at any time by clicking on an image. This dialog
has three tabs:

Graphics Here you can choose an image file and adjust its appearance in the output.
The available units for the image size are explained in appendix A.
You can rotate images counter-clockwise by setting a rotation angle and a
rotation origin. The image will also be rotated inside LyX.
Images can be scaled by using a percentage value or by setting the width and
height explicitly. If you set only the width or only the height, the other size
will be determined automatically. If you set both, then the image will be
transformed to the given size, possibly distorting it. To prevent the image from
distortion, use the option Maintain aspect ratio. The image will then be scaled
so that its width and height don’t exceed the specified dimensions.
Images can be opened in a program of your choice by right-clicking on it and
choosing the entry Edit externally in the context menu. The program can be set
for every image format in the file format settings in IyX’s preferences.

Clipping Alternatively to the usage of scaling units it is possible to set image coordi-
nates to adjust the height and width of the image in the output. The coordinates
can also be calculated automatically by pressing the button Get from File. The
option Clip to bounding box will only print the image region within the given
coordinates. Normally you don’t need to worry about image coordinates and
can ignore this tab.

ETEX and LyX options In this tab you can modify the appearance of the image
within Iy X and BETEX experts can specify additional XTEX options.
The option Draft mode makes the image appear in the output only as a frame
with the size of the image.
The Don't unzip on export option only affects zipped EPS-graphics, e. g. x.¢eps. gz.
When the option is used the images will not be unzipped on export, since IXTEX
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can handle them as they are.

Zipped EPS-graphics are useful to save disk space when you choose PostScript
as output format, see appendix B.2. To zip EPS-graphics, use the following
commands in a UNIX-shell or a Windows console:

gzip X.eps

zgrep %%Bounding x.eps.gz > x.eps.bb

The second command creates the bounding box file “x.eps.bb” that is needed
by ETEX for zipped graphics.

In the section Graphics Group you can define or join an image settings group.
Images within such a group share their settings, so adjusting one image of the
group automatically also adjusts all other images of the group in the same way.
So you can for example change the size for a bunch of images without the need
to manually change each of them. Joining an existing group can also be done
using the context menu of the image by checking the name of the desired group.

This is an example image in EPS format! within a separate, horizontally centered
paragraph:

This is the same image like the one above but in draft mode:

4D__LyXSVN_LyX2_0x_lib_doc_clipart_mobius|. pdf

Image formats are explained in section 1.3.



1.2. Figure Floats

1.2. Figure Floats

For general explanations about floats, have a look at section 3.1.

The toolbar button -ﬂ- and the menu Insert>Float> Figure inserts a float with a
caption that has the label “Figure #:” (# is the actual number). You can insert the
image above the caption, like in Figure 1.1 or below the caption, like in Figure 1.2.
More about caption placement is described in section 3.10.

Figure 1.1 and 1.2 are examples of referenced figures. Figures can be referenced in
the text by referencing their label. To do this insert a label in the caption using

the menu Insert>Label or the toolbar button . You can now refer to the label

using the menu Insert> Cross reference or the toolbar button ==I. It is important to
use references to floats, rather than using vague references like “the figure above”,
because KTEX will reposition the floats in the final document and it might not be
“above” at all.

Referencing is explained in detail in section 3.4.

Normally only one image is inserted to a figure float, but sometimes you might want
to use two images with separate subcaptions. This can be done by inserting image
floats into existing image floats. Note that only the main caption of the float is added
to the List of Figures. Figure 1.3 is an example of a figure float with two images set
side by side. You can also set the images one below the other. Figure 1.3a and 1.3b
are the subfigures.

Figure 1.1.: A severely distorted platypus in a float.
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Figure 1.2.: M.C. Escher on acid.

(a) Undefinable structure. (b) A Platypus.

Figure 1.3.: Two distorted images. Both images are in the image settings group
named “distorted”.



1.3. Image Formats
1.3. Image Formats

You can insert images in any known file format. But as explained in appendix B, each
output document format allows only a few image formats. LyX uses therefore the
program ImageMagick in the background to convert the images to the right format.
To increase your work flow by avoiding these conversions in the background, you
could choose to use only the image formats that can directly be embedded in the
output file format. The output file formats are explained in appendix B.

Similar to fonts there are two types of image formats:

Bitmap images consist of pixel values, often in a compressed form. They are there-
fore not fully scalable and look pixelated in large zooms. Well-known bitmap
image formats are “Graphics Interchange Format” (GIF, file extension “.gif”),
“Portable Network Graphics” (PNG, file extension “.png”), and “Joint Photo-
graphic Experts Group” (JPG, file extension “. jpg” or “. jpeg”).

Vector images consist of vectors and can therefore be scaled to any size without

data loss. The scaling ability is necessary if you want to create presentations,
because presentations are always scaled by the video projector. Scaling is also
useful for online documents to let the user zoom into diagrams.
Well-known scalable image formats are “Scalable Vector Graphics” (SVG, file
extension “.svg”), “Encapsulated PostScript” (EPS, file extension “.eps”),
“Portable Document Format” (PDF, file extension “.pdf”), and “Windows
Metafile” (WMF, file extension “.wmf”). We wrote “can be”, because you can
convert any bitmap image to a PDF or EPS-image and the result will still be a
bitmap image. In such cases only a header with the image properties is added
to the original image?. The PDF-files generated by Adobe Photoshop are for
example bitmap images.

¢

Normally it is not possible to convert a bitmap image into a scalable one, only vice
versa. Only the image formats PDF and EPS can directly be embedded to PDF
and PostScript output files, respectively. SVG and WMF-images are recalculated
to bitmaps when the output file is generated because there is currently no adequate
WMF /SVG—PDF/EPS converter available.

2In the case of PDF, the original image is additionally compressed.






2. Tables

2.1. Introduction

You can insert a table using either the toolbar button == or the menu Insertr
Table. The toolbar button offers you a graphical selection: move the mouse to set
the column/row number of the table that should be created and then press a mouse
button. When you use the menu to create a table, a dialog will appear, asking you
for the number of rows and columns.

The default table has lines around any cell and the first row appears separated from
the rest of the table. This separation occurs due to a double line: The cells of the
first row have a line below them and the cells of the second row have a line above
them. Here is an example table:

_(12]3]
A
B
C

2.2. Table Dialog

You can alter a table by clicking on it with the right mouse button, which brings
up the table dialog. Here you can adjust the settings of that cell and row/column
respectively where the cursor is currently placed. Most of the dialog options also
work on selections. This means if you select more cells, columns or rows, the action
is done for the whole selection. Note that there is a difference between selecting the
contents of the cell, and the cell itself.

With the dialog option Immediate Apply every change you make in the dialog is
directly applied. If you move the cursor to another table cell the dialog will then also
be updated with the parameters of the new cell. If you change length values in the
dialog you must press return to get the change applied.

You can alter tables with the following tabs of the table dialog:

Table Settings Here you can set the table width, and the horizontal alignment and
the width of the current column. The alignment At Decimal Separator is de-
scribed in section 2.13.2. When you have set a width you can also adjust the
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vertical alignment of the current row. A given width will allow the cell to have
line breaks and multiple paragraphs of text, see section 2.8.1. If you set no
width, the column is as wide as the content of its widest cell.

Furthermore, you can mark one or multiple cells of one row as a multicolumn
cell, see section 2.8.2 or the cells of one column as multirow cell, see section 2.8.3.
The rotate check boxes rotate the current cell, a selection, or the whole table
counter-clockwise by 90°. The rotation is not shown within LyX, only in the
output.

Note: Not all DVI-viewers are able to display rotations.

The table-wide vertical alignment is used for tables within text lines:
1

LA

A line with tables with different alignments:

11| A

A
It is also possible to enter a KIEX-argument which is needed for special table
formattings, see section 2.8.2.2 and 2.11.

Borders In this tab you can add and delete border lines for the current row/column.

Using the style option Formal will convert the table to a formal table as described
in section 2.9.
You can also add space here to table rows as described in section 2.13.1.

Longtable This tab is to make a table a so called “longtable” that can run over

several pages. Sections 2.6 and 2.7 describe the longtable features in detail.

2.3. Table Toolbar

The table toolbar is an alternative to the table dialog to be able to alter tables faster.
It should normally appear at the bottom of LyX’s main window when the cursor is
inside a table. You can alternatively switch it on to appear always, by right-clicking
in IyX’s main menu bar.

The toolbar has the following icons:

C1EH Bl 22

oo

adds a row below the current cell or selection
adds a column right beside the current cell or selection
deletes the current row or selection

deletes the current column or selection

adds a line at the top of the current cell / row or of a selection

adds a line at the bottom of the current cell / row or of a selection
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2.4. Edit Table Menu

adds a line at the left side of the current cell / row or of a selection
adds a line at the right side of the current cell / row or of a selection

adds lines around the current or selected cells - if the current cell no
multicolumn cell this also affects the current row and column

deletes all lines of the current or selected cells - if the current cell no
multicolumn cell this also affects the current row and column

left-aligns the content of the current cell / column

centers the content of the current cell / column horizontally
right-aligns the content of the current cell / column

aligns the content of the current column at a character
aligns the content of the current cell vertically to the top
centers the content of the current cell vertically

aligns the content of the current cell vertically to the bottom
rotates the current cell or selection counter-clockwise by 90°
rotates the whole table counter-clockwise by 90°

sets the current cell or selection as a multicolumn

sets the current cell or selection as a multirow

Note: For the output the vertical alignment of the first cell in a row is used for all
following cells in the row.

2.4. Edit Table Menu

In addition to the table dialog and toolbar, the menu Edit> Table allows you to add
and delete border lines for the current row/column and to set the current selection
as multicolumn. The menu is only available when the cursor is inside a table.
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Table 2.1.: A table float.

Lt [ 2 [ s
Joe Mary Ted
[ %da la b] 1+1=2

c d

2.5. Table Floats

For general explanations about floats, have a look at section 3.1.

Table floats can be inserted using the menu Insert > Float > Table or the toolbar button

£

The float appears as a collapsible box with a caption that has the label “Table #:”
(# is the actual table number). You can insert tables in the float above or below the
caption.

Table 2.1 is an example table within a table float.

Having the caption above the table is the common rule that is unfortunately not
supported in IXTEX’s standard classes. This means that, if you are using the document
classes article, book, letter, or report, there will be no space between the caption and
the table. To insert the needed space, add the following option to the load command
of the WTEX-package caption in your document preamble!:

tableposition=top

The package caption, which is described in section 3.9, is used to adjust the caption
format.

Tables can be cross-referenced in the text by referencing their label. To do this insert

a label in the caption using the menu Insert>Label or the toolbar button . You
can now refer to the label using the menu Insert > Cross reference or the toolbar button

L.‘-.

Referencing is explained in detail in section 3.4.

2.6. Longtables

If the table is too long to fit on one page, you can use the option Use long table in
the tab Longtable of the table dialog to split the table automatically over more pages.
Doing this enables the following options:

1For more information have a look at section 3.10.

10



2.6. Longtables

Header: The current row is defined to be a header row that appears on all pages
of the longtable; except for the first page, if First header is defined. This is
therefore called the main header.

First header: The current row is defined to be a header row that appears on the first
page of the longtable.

Footer: The current row is defined to be a footer row that appears on all pages of
the longtable; except for the last page, if Last footer is defined.

Last footer: The current row is defined to be a footer row that appears on the last
page of the longtable.

Caption: The current row contains the table caption. The row is reset as single
column and a caption is inserted. More about longtable captions is explained
in sec. 2.6.3.

You can also specify a row where the table is split. See the following longtable to see
how it works:

Example Phone List (ignore the names)
NAME TEL.
Annovi Silvia, 111
Bertoli Stefano 111
Bozzi Walter 111
Cachia Maria 111
Cachia Maurizio 111
Cinquemani Giusi 111
Colin Bernard 111
Concli Gianfranco 111
Dal Bosco Carolina 111
Dalpiaz Annamaria 111
Feliciello Domenico 111
Focarelli Paola 111
Galletti Oreste 111
Gasparini Franca 111
Rizzardi Paola 111
Lassini Giancarlo 111
Malfatti Luciano 111
Malfatti Valeriano 111
Meneguzzo Roberto 111
Mezzadra Roberto 111
Pirpamer Erich 111

continued on next page

11
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Example Phone List
NAME TEL.
Pochiesa Paolo 111, 222
Radina Claudio 111
Stuffer Oskar 111
Tacchelli Ugo 111
Tezzele Margit 111
Unterkalmsteiner Frieda 111
Vieider Hilde 111
Vigna Jirgen 111
Weber Maurizio 111
Winkler Franz 111
Annovi Silvia 555
Bertoli Stefano 555
Bozzi Walter 555
Cachia Maria 555
Cachia Maurizio 555
Cinquemani Giusi 555
Colin Bernard 555
Concli Gianfranco 555
Dal Bosco Carolina 555
Dalpiaz Annamaria 555
Feliciello Domenico 555
Focarelli Paola 555
Galletti Oreste 555
Gasparini Franca 555
Rizzardi Paola 555
Lassini Giancarlo 555
Malfatti Luciano 555
Malfatti Valeriano 555
Meneguzzo Roberto 955
Mezzadra Roberto 555
Pirpamer Erich 555
Pochiesa Paolo 5b5, 222
Radina Claudio 555
Stuffer Oskar 555

continued on next page




2.6. Longtables

Example Phone List
NAME TEL.
Tacchelli Ugo 555
Tezzele Margit 555
Unterkalmsteiner Frieda 555
Vieider Hilde 555
Vigna Jirgen 999
Weber Maurizio 555
Winkler Franz 555
end

2.6.1. Footnotes in Longtables

Footnotes can be inserted to every longtable cell. They appear at the bottom of the
page where the table cell with the footnote appears. Table 2.6 has for example a
footnote.

2.6.2. Longtable Alignment

The horizontal alignment of longtables can be set in the table settings dialog. For
left- and right-alignment the table will be directly at the page border. To add space
between the table and the border one has to set the alignment to center and change
the value of the IXTEX-lengths \LTleft or \LTright by inserting this line as TEX-
Code before the longtable:

\setlength{\LTleft } {value}

The value can have any of the units listed in Table A.1. \LTleft controls the hor-
izontal distance from the left page border to the longtable, \LTright the distance
from the right side. The default value for both lengths is \fill, which is in this case
the same as an horizontal fill in LyX.

The following longtable was centered and \LTleft set to 0.1\columnwidth:

1 2 3 4 )

asd | s S s | asd
asd | s S s | asd
asd | s S s | asd

asd | asd | asd | asd | asd

13



2. Tables

2.6.3. Longtable Captions

A longtable cannot be put into a table float because floats can only be on one page.
But the caption environment of floats can also be used for longtables when you use
the longtable option Caption as described in sec. 2.6. Only one table row can contain
the caption.

Here is a short longtable to see how it works:

Table 2.2.: Longtable with caption

1 2 3 4 )

asd | s S s | asd
asd | s S s | asd
asd | s S s | asd

asd | asd | asd | asd | asd

Note 1: The table number is increased for every longtable, even if you did not set
a caption for it. For this reason you could have the case that e.g. Table 2.4 follows
Table 2.1 in the list of tables if there are two longtables without captions. To avoid
this you can add the following command in TEX-Code after every longtable without
a caption:

\addtocounter{table}{-1}

This is not needed when none of your longtables has a caption and you add the
following code to the document preamble:

\let\myEnd\endlongtable
\renewcommand{\endlongtable}{\myEnd\addtocounter{table}{-1}}

Note 2: If you are using hyperref in the PDF Properties of the Document Settings
dialog to link cross-references, the link to a longtable caption will always point to the
beginning of the document.

2.6.3.1. References to Longtables

Table 2.3.: Referenced longtable

1 2 3 4 )

asd | s S s | asd
asd | s S s | asd
asd | s S s | asd

asd | sad | asd | asd | asd

14



2.6. Longtables

To reference a longtable, insert a label into the caption.
This is a reference to Table 2.3.

The caption layout can be set together with all other captions of your document
using the KTEX-package caption, see section 3.9.

2.6.3.2. Caption Width

The maximal width of caption lines is defined by the length \LTcapwidth. Its
default value is 4in. To change it add the following command to your document
preamble or as TEX-Code into your document before the longtable that should be
affected

\setlength{\LTcapwidth}{width}
where the width could have one of the units listed in appendix A.
The following tables show the difference:

Table 2.4.: long full title with default width long full title with default width long
full title with default width

1 2 3 4 5
asd | s S s | asd
asd | s S s | asd
asd | s S s | asd
asd | sad | asd | asd | asd

Table 2.5.: long full title
with width set
to 5cm  long
full title with
width set to
5cm long full
title with width
set to 5cm

asd S S S asd
asd S S s | asd
asd | s S s | asd

asd | sad | asd | asd | asd

15
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Note: When the KTEX-package caption is used, as in this document, the full page
width is used for the caption when you use the default value of 4 in for \ LTcapwidth.
To get in this case exactly a 4in wide caption, you can either use a value slightly differ-
ent from 4.0in, e. g. 3.991in, or the WTEX-command \ captionsetup{width=value}
that is provided by the caption-package.

2.6.3.3. Different Captions for Table Pages

When the table captions for the following pages should differ from the one of the first
table page, insert a caption with the TEX-Code command

\caption*{caption text}\\%

in a dummy caption row that is marked as a header. Table 2.6 is an example of a
longtable with different heading where the second caption doesn’t include the table
number.

Table 2.6.: Example Phone List

Example Phone List (ignore the names)
NAME TEL.
Annovi Silvia 111
Bertoli Stefano 111
Bozzi Walter 111
Cachia Maria 111
Cachia Maurizio 111
Cinquemani Giusi 111
Colin Bernard 111
Concli Gianfranco 111
Dal Bosco Carolina 111
Dalpiaz Annamaria 111
Feliciello Domenico 111
Focarelli Paola 111
Galletti Oreste 111
Gasparini Franca 111
Rizzardi? Paola 111
Lassini Giancarlo 111
Malfatti Luciano 111
Malfatti Valeriano 111

continued on next page

2Example footnote
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Continued Example Phone List

Example Phone List

NAME TEL.
Meneguzzo Roberto 111
Mezzadra Roberto 111
Pirpamer Erich 111
Pochiesa Paolo 111, 222
Radina Claudio 111
Stuffer Oskar 111
Tacchelli Ugo 111
Tezzele Margit 111
Unterkalmsteiner | Frieda 111
Vieider Hilde 111
Vigna Jirgen 111
Weber Maurizio 111
Winkler Franz 111
Annovi Silvia 555
Bertoli Stefano 555
Bozzi Walter 555
Cachia Maria 555
Cachia Maurizio 555
Cinquemani Giusi 555
Colin Bernard 555
Concli Gianfranco 555
Dal Bosco Carolina 555
Dalpiaz Annamaria 555
Feliciello Domenico 555
Focarelli Paola 555
Galletti Oreste 555
Gasparini Franca 555
Rizzardi Paola 555
Lassini Giancarlo 555
Malfatti Luciano 555
Malfatti Valeriano 555
Meneguzzo Roberto 955

continued on next page

2.6. Longtables

17
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Continued Example Phone List

Example Phone List
NAME TEL.
Mezzadra ‘ Roberto 555

2.7. Special Longtable Issues

2.7.1. Longtable Calculation

ETEX calculates the height of table pages and their page breaks using so called chunks.
Chunks are parts of tables that held at the same time in ETEX’s memory. The default
value was historically set to only 20 table rows. If you are using longtables with many
pages this may slow down the creation of your document. You can safely increase
the chunk size to values of 100-1000 by adding this command line to your document
preamble:

\setcounter{LTchunksize}{100}

2.7.2. Floats and Longtables

There might be problems when a float appears on the same page where a longtable
starts. To avoid such a situation, insert a “clear page” (menu Insert>Formatting>
Clear Page) before your longtable.

2.7.3. Forced Page Breaks

By default tables are only broken between rows. If you have a cell with multiples
lines and want to have a page break within the cell, insert the new line command
“\\” as TEX-Code at the point of the cell where it can be broken. Before the \\
command you have to insert in TEX-Code as many “&” characters as the number of
the following table columns. The & is the character to separate table cells. Write
in TEX-Code after each & the content of the corresponding following cell and delete
the content of these cells.

After the \\ command, insert as many & characters as the number of table columns
before the current column. In Table 2.7 the cell that should be broken is in the second
column followed by another column. Therefore the following command was inserted
in the cell as TEX-Code after “Castelchiodato,”:
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& 111\\ \newpage
&

The “111” in the third column of the row was deleted. \newpage is only needed
when a page break should definitely occur at this position, otherwise it would be a
conditional break. If your footer row of the longtable has for a certain reason no
upper line but you would have a horizontal line where the cell is broken, use this
command instead:

& 111\\
\hline &

When the cell to be broken is in the last column, the command
\setlength{\parfillskip } {Opt}

must be inserted as TEX-Code at the beginning of the cell. This ensures that the
part of the cell that will be displayed on the new page appears with the full width.

Table 2.7.: Table with forced page break in table cell

Example Phone List (ignore the names)
NAME TEL.

Annovi Silvia 111
Bertoli Stefano 111
Bozzi Walter 111
Cachia Maria 111
Cachia Maurizio 111
Cinquemani Giusi 111
Colin Bernard 111
Concli Gianfranco 111
Dal Bosco Carolina 111
Dalpiaz Annamaria 111
Feliciello Domenico 111
Focarelli Paola 111
Galletti Oreste 111
Gasparini Franca 111
Lassini Giancarlo 111
Malfatti Luciano 111
Malfatti Valeriano 111
Meneguzzo Roberto 111
Mezzadra Roberto 111
Pirpamer Erich 111

continued on next page
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Continued Example Phone List

Example Phone List

NAME TEL.
Pochiesa Paolo 111, 222
Radina Claudio 111
Rizzardi Paolo, 11. First 111
von
Montecompatri,

11. First von
Sulmona und
Vivaro, 10.
Fiirst von
Rossano, 5.
Herzog von
Canemorte, 11.
Herzog von
Palombara, 5.
Herzog von
Castelchiodato,

continued on next page
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Continued Example Phone List

Example Phone List

NAME TEL.

11. Herzog von
Poggionativo,
11. Markis von
Mentana,
Norma,
Civitella,
Pratica,
Moricone und
Percille, 11.
Graf von
Valinfreda, 11.
Baron von
Cropalati, 11.
Herr von
Scarpa,
Edelmann von
Rom, Patrizier
von Venedig,

Neapel und

Genua
Stuffer Oskar 111
Tacchelli Ugo 111
Tezzele Margit 111
Unterkalmsteiner Frieda 111
Vieider Hilde 111
Vigna Jirgen 111
Weber Maurizio 111
Winkler Franz 111
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2.8. Multiple Lines, Columns and Rows

2.8.1. Multiple Lines in Table Cells

Table 2.8.: Table with multiple lines in cells

Im}ltiple bl e
lines

d e | f

g h|i

Setting a fixed width for a column enables you to enter text as a paragraph with
multiple lines and hyphenation.

To produce Table 2.8, create a 3x3 table, mark the first cell and right-click on it. In
the appearing table dialog we set a cell width of 2.5 cm and choose centered for the
vertical and horizontal alignment. The vertical alignment is used for all cells of the
row. As our text is smaller than 2.5 cm, only one line will appear. To get two lines, a
justified line break (shortcut Ctrl+Shift+Return) was added. If the text is wider than
the set cell width, it will automatically be broken to several lines.

If you have a long word in a cell with a fixed width, it cannot be hyphenated by
ETEX if it is the first entry. Therefore you need to insert something to prevent the
word not being the first entry. So add a horizontal space of 0 pt before the word. As
the space is zero, it doesn’t change the output. Table 2.9 shows the effect.

Table 2.9.: Table with and without hyphenation

very-

verylongtablecellwoiel longtablecell- | b | c
d e | f word

g h|i d e| f

g h|i

2.8.2. Multicolumns
2.8.2.1. Multicolumn Basics

To merge cells over multiple columns, select as many cells within a row as you want

11
L=

to merge and use either the table-toolbar button [T

, or the menu Edit> Table>
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Multicolumn, or right click on the marked cells and choose Multicolumn in the context
menu.

Multicolumns have there own cell settings. That means changing cell borders, cell
alignment, and the width only affects the multicolumn. Here is an example table

with a multicolumn cell in the first row and one in the last row without the upper
border:

’ abc ‘ def ghi ‘ jkl ‘
A |B|lC/|D
1 (2 3|4

2.8.2.2. Multicolumn Calculations

LyX supports multicolumns directly, but we have to take account of the cell width of
the columns spanned by the multicolumn cell.

Table 2.10.: Table with centered multicolumn text above two columns that have
exactly half the width of the multicolumn cell

multiple lines .
multicolumn
d e f
g h 1

To create for example Table 2.10, mark the first two cells in the first row of a 3x3 table
and right-click on them. Now choose for this cell multicolumn, centered alignment
and a width of 2.5cm in the table dialog. The merged columns should have exactly
half the width of the multicolumn cell, so that you would set a width of 1.25cm
for the first column. The second column has then automatically a width of 1.25cm
(multicolumn width - width of first column). This was done for Table 2.11.

You can see that the first column is not half the width of the multicolumn cell, it is
a bit bigger. The reason is that the specified width of a cell W, is not its total width

Table 2.11.: Table where the spanned table columns are not exactly half the width
of the multicolumn cell

multiple lines | c
multicolumn
d e f
g h i
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Wiot because a cell is always a bit larger than specified. Appendix D explains this in
detail.

The width Wy, which the user needs to set when n columns are spanned can be
calculated, so that each column has a total width of Wit multicolumn /7

Wyn = (Wymulticolumn + (1 — 1) - (12.4pt))/n (2.1)

In our case we have n = 2, Wynulticolumn = 2.5 cm and the default values for the
lengths, so that equation 2.1 becomes

Wyo =1.25cm — 6.2pt (2.2)

To enable calculations in ITEX, the I¥TEX-package calc must be loaded with the
document preamble line

\usepackage{calc}

LyX does not allow you to calculate lengths in the Width field of the table dialog.
Therefore you have to format the column by inserting a IXTgX-argument in the dialog.
Here is an overview about the arguments:

o p{width} creates cell with a fixed width, its text is vertically top-aligned

o m{width} creates cell with a fixed width, its text is vertically centered

o b{width} creates cell with a fixed width, its text is vertically bottom-aligned
By entering a KXTpX-argument, all cell settings set in the table dialog are overwritten.
Note: Due to a bug, LyX shows the overwritten settings anyway.

As the text should be horizontally centered, the command \ centering is added. You
can now enter the following I¥TEX-argument for the first spanned column:

>{\centering}m{1.25cm-6.2pt }

The command >{ } means, that the commands inside the braces are applied before
the cell is created.

Although we have chosen centered alignment for the text of the multicolumn cell, it
is still left aligned. This is because LyX only applies the alignment to single columns.
So for the multicolumn cell we have to use the BIEX-argument

>{\centering}m{2.5cm}

2.8.3. Multirows

To merge cells over multiple rows, select as many cells within a column as you want

to merge and use either the table-toolbar button _I_, or the menu Edit> Tabler>
Multirow, or right click on the marked cells and choose Multirow in the context menu.

Here is an example table with a multirow in the first column:
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2.8. Multiple Lines, Columns and Rows

a long cell entry | b | ¢

@D
-+

multirow

The width of multirow cells is set by setting the width and alignment for the whole
column. The Vertical Offset shifts the content of the multirow up/down if the offset
is positive/negative.

If the column of a multirow cell has no explicit width, the multirow cell inherits the
alignment of the column. Otherwise it is by default left-aligned. To override the
default, renew the command \multirowsetup with the command

\renewcommand{\multirowsetup }{\centering}

in the document preamble. Then all entries of multirow cells in the document are
centered. If centering is only needed for several tables, you can renew the command
in a TEX-Code box just before the table instead of the preamble. If the text should
be right-aligned, replace \centering by \raggedleft. To return to left-alignment
\raggedright is used.

This is an example table with a right-aligned multirow cell that has a vertical offset
of -4mm and is in a 3cm wide column:

a long cell entry | b | ¢
t n|m

e| f

multirow | b | i

To start a new line in a multirow you can use a forced line break (shortcut Ctrl+Return)
but this will not respect the cell lines as demonstrated in this table:

aaa cce

aaa ddd
rpng celt

eece

Therefore be careful with forced line breaks.

2.8.4. Cells with diagonal line(s)

To tell the reader what is meant by column and row headings in a table, it is helpful
to split the first cell of the table by one or two diagonal lines. This can be achieved
by loading the KTEX-package diagbox in the document preamble. The package
provides the command \diagbox that is inserted as TEX-Code and that can take 2
or 3 arguments:
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\diagbox[options]|{lower left}{upper right}

\diagbox[options|{lower left}{upper left}{upper right}

The first scheme divides the cell by a single diagonal line and the arguments are
placed below and above this line. The second scheme divides the cell by 2 lines.

Here is an example table where \diagbox is used in the 2-argument scheme in the

first cell:
Parameter Thickness in nm | Transparency in % | Hardness in MPa
Name
Perfect Green 45 80 504
Dark Multi-P 60 72 982
Crystal Clear Pro 18 86 374

The 3-argument scheme is for example useful for cross-tables of sports leagues or
distances:

Result Team away
Tigers | Panthers | Falcons
Team home
Tigers — 1:3 0:1
Panthers 3:1 — 0:0
Falcons 1:0 0:0 —

For larger cross-tables one might use split cells in 2 or every corner of the table like
in this example:

Result Team away Team home Result
Tigers | Panthers | Falcons
Team home Team away
Tigers — 1:3 0:1 Tigers
Panthers 3:1 — 0:0 Panthers
Falcons 1:0 0:0 — Falcons
Team home Team away
Tigers | Panthers | Falcons
Result Team away Team home Result

To rotate the diagonal lines, the command option dir=direction is used. direction is
either NE, DE, SW or NW and represent a point of a compass. SW is for example
the south-west corner. Thus in the lower left cell of the above table the command

\diagbox[dir=SW]{Team home}{Result}{Team away}
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2.8. Multiple Lines, Columns and Rows

is used. If no direction is given, it will be NW.

The necessary width of split cells is automatically calculated. Thus if you set a fixed
column width smaller than the calculated one, the cell’s content will protrude the
cell borders:

Parameter .
mﬁhmkness in nm
Name

Perfect Green 45

If you need a certain width for columns with a split cell, use the command option
width=3cm (replace '3cm’ by the width you need). In the following table the width
of the first column is set to 4cm. For \diagbox a width of 4cm + 2 \tabcolsep is
necessary because the overall width is the width for the text (in this case the 4 cm)
plus two times the separation of the text and the cell border. The calculation of the
width cannot be done in the command option of \diagbox so one needs to create a
new length which can be used later. This is done with the TEX-Code commands

\newlength{\diagtest}
\setlength{\diagtest }{4cm+2\tabcolsep}

To enable calculations in KTEX one needs to load the package calc in the document
preamble.

In this table you can now use the command
\diagbox[width=\diagtest]{A}{B}
in the first cell:

Thickness in nm

A

Perfect Green 45

Note that the split cell needs to be the widest one in the column. Otherwise the
length of the diagonal line cannot be calculated correctly like in this table:

B

Thickness in nm

A
Perfect Green 45

In this case use the width option of the \ diagbox command. It is then not necessary
to add 2\tabcolsep because the cell width is now the width of the column. In this
table a width of 3 cm is used:

B

Thickness in nm

A
Perfect Green 45
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For multiple text lines in split cells one needs some extra height to fit the text to the
cell. This can be achieved with the \diagbox option height=3cm (replace '3cm’
by the height you need). In the following table the command

\diagbox[width=3cm,height=1.4cm]|{A\\B}{C\\D}

is used in the first cell. The command \\ creates hereby the line break.?

A C

D Thickness in nm
B
Perfect Green 45

For more info about the KTEX-package diagbox, see its documentation, [7].

2.9. Formal Tables

Tables are often typeset in books similar to Table 2.12. This kind of tables is called
“formal”. To make a table a formal table use the option Formal in the Borders tab of
the table dialog.

Table 2.12.: Example booktabs-table

System Chip1 Chip 2
Detector thickness in pm 300 300 700

Edge angle in ° 3.55 2.71  7.99

Spatial resolution in pm  4.26  10.17 10.56

MTF at fiax 0.53 037 0.39
LSF-spatial resolution

in pm 129.7  52.75 50.78

in % of pixel size 76.3 959 923

Spaces to table rows can be added using the Borders tab of the table dialog as de-
scribed in section 2.13.1.

Unlike normal tables, formal tables have no vertical table lines. The horizontal table
lines can be set as for normal tables but they appear with different widths in the
output:

3Breaking lines with Ctrl+Return is only possible when the column has a fixed width.
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The first and the last table line have a default width of 0.08 em while the other lines
have a default width of 0.05 em.

The default widths can be changed with the following preamble lines

\let\mytoprule\toprule
\renewcommand{\toprule}{\mytoprule[width]}

This example is for the first line, the so called toprule. If you want to change the
width for the last line, replace toprule by bottomrule. To change the width for the
other lines replace toprule by midrule. You can use all units listed in appendix A
to set the width.

Lines that do not span all table columns can be created by setting a table line for
multicolumn cells. LyX will then internally use the command \cmidrule to create
this line. Its full scheme is

\cmidrule[width](trim){startcol-endcol}

The options of \cmidrule are currently not supported by IxyX so you have to use
TEX-Code to be able to use them. \cmidrules can manually be created by inserting
the command as TEX-Code as the first cell entry of the first cell of a row. The line
is then drawn in the output above the current row.

The default for the width is 0.03 em. Startcol is the number of the column where the
line starts and endcol the column number where the line ends. The endcol always
needs to be specified, also when the line should span only one column. The optional
parameter trim could be either I{trimwidth}, or r{trimwidth} where the trimwidth is
also optional. Using for example the parameter I{2pt} means that the line is trimmed
from its left end by 2 pt. If you don’t specify the trimwidth the lines are trimmed by
the default of 0.5em.

Table 2.12 was created using the commands
\cmidrule(r){2-2}\cmidrule(1){3-4}

at the beginning of the second row and
\cmidrule(1{10pt}){1-1}

in the sixth row.

You might want to have overlapping \cmidrules as in in Table 2.13. This can be
achieved with the TEX-Code command

\morecmidrules
The command that was used for the second row of Table 2.13 is
\cmidrule(r){2-2}\cmidrule(l){3-4}\morecmidrules\cmidrule{2-4}

The command for the sixth row is
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2. Tables
\midrule\morecmidrules\cmidrule{3-4}

If you are in any way not satisfied with the border line spacing, you can use the
following command to produce lines that span over all table columns:

\specialrule{width}{space above}{space below}
For more information about these features, refer to the manual of the IXTEX-package

booktabs [5].

Table 2.13.: Special booktabs-table

System Chip 1 Chip 2

Detector thickness in pm 300 300 700

Edge angle in ° 3.55 2.71 799
Spatial resolution in pm  4.26  10.17 10.56
MTF at fiax 0.53 037 0.39

LSF-spatial resolution
in pm 129.7  52.75 50.78
in % of pixel size 76.3 959 923

2.10. Vertical Table Alignment

To align tables vertically in a text line, the table must be inside a box. The box can
then be vertically aligned as described in section 5.2.

In the following example the tables are inside a minipage* box that has a width of
15 col%:

o test test|a |d| g
a|d g b h
blel|h f i
c|f|i
al|d|g

e test| b|e|h
c|f|i

4Minipages are described in section 5.4.
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a|ld|g ald|e
b (§] h b e h
e test fli test| ¢ | £ |1

As you will see, the content of the first and last table row is not correctly aligned. To
get this alignment, the minipage box must be set into a raisebox®. In the example
above the second table in the first item is aligned using the TEX-Code-command

\raisebox{0.85\baselineskip }{

before the box. After the box the closing brace } is inserted as TEX-Code. For the
second table in the last item the command

\raisebox{-0.32\baselineskip }{
is used.

Note: The alignment of the table row content to the surrounding text line is not
exact. The required value for the \raisebox command for this alignment depends
on the document font, the font size, and the table line thickness.

2.11. Colored Tables

2.11.1. Colored Celis

Table 2.14.: Table colored without using the package colortbl

b|c
e | f
h|i

If you only need colored text, mark the cells and choose a color in the menu Edit>
Text Style. This was used to create Table 2.14. In any other case you have to use the
ETEX-package colortbl.

To create colored tables, colortbl must be loaded in the preamble with the line
\usepackage{colortbl}

The color of a column is adjusted with the command

\columncolor{name of color}

inside the command >{ }. More about the command >{} is contained in sec-
tion 2.8.2.2.

5Raiseboxes are described in section 5.6.2.
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The following color names are predefined:

red, green, yellow, blue, cyan, magenta, black and white

If you add the options
usenames,dvipsnames

to the document class options in the document settings, you can additionally use
further 61 colors. These colors are listed in appendix C. One of these colors, Maroon,
is used as example in Table 2.15.

You can also define your own color with the command

\definecolor{color name}{color model}{color values}

The color model can be

cmyk: cyan, magenta, yellow, black
rgh: red, green blue
gray gray

and the color values are comma separated numbers between 0 and 1 describing the
factor for the corresponding color of the color model.

You can e. g. define the color "darkgreen' in the preamble with
\definecolor{darkgreen}{cmyk}{0.5, 0, 1, 0.5}

and the color "lightgray" with
\definecolor{lightgray } {gray}{0.8}

Lines are colored with the command

\rowcolor{name of color}

and cells are colored with the command

\cellcolor{name of color}

Both commands are inserted at the beginning of a cell as TEX-Code.

To color characters in the table, mark the cells and use the IyX menu Edit > Text Style.
If a cell contains TEX-Code mark only the characters, otherwise the colored TEX-Code
will cause I¥TEX-errors.

Note: Not all DVI-viewers are able to display self-defined colors.

To create Table 2.15 do the following: The color of the first column should be dark-
green. So insert

>{\columncolor{darkgreen}\centering}c
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as BTEX-argument for this column. The first row should be light blue, therefore the
TEX-Code command

\rowcolor{cyan}

is inserted to the first cell of this row. Note that this overwrites the column color
for the first cell. The last cell of the last row is colored maroon by inserting the

TEX-Code command
\cellcolor{Maroon}

The characters could now be colored using the menu Edit> Text Style.

Table 2.15.: Table colored using the package colortbl

2.11.2. Colored Lines

As described in section 2.13.4, the line thickness for all lines in a table can be adjusted
with the length \arrayrulewidth. It is set to 1.5 pt for all tables of this section.

To color vertical lines for example with green, create the following column format in
the document preamble, according to the description in section 2.13.3:

\newcolumntype{W }{!{\color{green}\vline}}

For Table 2.16 the KTEX-argument WcW was used for the last column and Wec for
the other columns.

If you want to have several colors, define more column formats.

Table 2.16.: Table with colored vertical lines

sd

sd
sd

To color horizontal lines for example with red, as in Table 2.17, insert these commands
in TEX-Code before the table or table float:

\let\myHlineC\hline
\renewcommand{\hline}
{\arrayrulecolor{red}\ myHlineC\arrayrulecolor{black}}
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Table 2.17.: Table with colored horizontal lines

sd

sd

sd

To return to the default line color black, insert this command in TEX-Code after the
table or table float:

\renewcommand{\hline } {\myHlineC}

Table 2.18 is an example with colored vertical and horizontal lines.

Table 2.18.: Table with colored lines

sd

sd

sd

2.12. Table Width Calculation

For wide tables it is sometimes difficult to assure that the table does not protrude
over the page margin. Setting a fixed width for every column of the table is the
solution, but what amount of space is needed for each column?

The table width Wi, can be calculated: Every column has the width of the spec-
ified column width Wegumn (that the content of the column can consume) plus two
times the separation between the column content and the column border (IXTEX
length \tabcolsep, default 6 pt) plus the width of a border line (TEX length \ar-
rayrulewidth, default 0.4pt): So if all n columns have the same width, the table
width is

Wiable = 7 (Weolumn + 2\tabcolsep + \arrayrulewidth) + \arrayrulewidth (2.3)

The available width for a table is the space between the page margins or the width
of a text column (for a two-column document) (KTEX length \columnwidth). If
all table columns should have the same width and W, should be 1\columnwidth,
Weolumn can easily be calculated.

To be able to perform calculations you need to load the IXTEX-package calc in the
document preamble. To set the width in the table dialog you have to use the field
ATEX argument. The command scheme for this field is the same that is explained in
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section 2.8.2.2. For a table with 5 columns with an uniform width and centered text,
enter there for each column the command

>{\centering }p{(1\columnwidth-62.4pt)/5}
For a table with 5columns where 2 should have 0.75 times the width than the 3
others, the calculation is
\columnwidth = 3 Weoumn + 2+ 0.75 Weolumn + \arrayrulewidth
+ 5 (2\tabcolsep + \arrayrulewidth)
= 4.5 Weotmn + 62.4 pt
\columnwidth — 62.4 pt

column — 2.4
Weol 15 (2.4)
In the table therefore the command
>{\centering }p{(1\columnwidth-62.4pt) /\real{4.5}}
is used for the wider columns and
>{\centering}p{(1\columnwidth-62.4pt) /\real{4.5}*\real{0.75}}
for the smaller ones:
| 1 | 2 3 | 4 | 5 |
111111 1111111 2222 22222 333333 333333
111111 222222 333333 33333
111111111 222222222 3333333 333
111171 11111 2222222 22
1111 22222

2.13. Table Customization

2.13.1. Row Spacing

You can add vertical space to table rows in the Borders tab of the table dialog. You
find there three possibilities:

Top of row will add space above the characters of the table row. If the table is
a formal table® LyX will insert as default 0.5em space. For normal tables
the inserted space will unfortunately destroy the vertical table lines as in the
following table:

A

3mm space top of row

C

6Formal tables are explained in section 2.9.
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So inserting space in the top of row for normal tables is only useful when you
don’t have vertical lines.

Bottom of row will add space below the characters of the table row. If the table
is a formal table LyX will insert as default 0.5 em space, for normal tables the
default size is 2 pt.

Between rows adds space between the current and the following row. If the table
is a formal table IyX will insert as default 0.5em space. For normal tables
the inserted space will unfortunately destroy the vertical table lines as in the
following table:

A

J 3mm space between row |

1 3mm space between row 1

So inserting space between rows for normal tables is only useful when you don’t
have vertical lines.

When you want to add extra height to all cells of all tables, you can do this with the
following preamble lines:

\ @ifundefined{extrarowheight }

{\usepackage{array}}{}
\setlength{\extrarowheight } {height }

But this has the disadvantage that the cell texts are no longer exactly vertically cen-
tered. (The package array will be loaded automatically by IyX when you use self
defined table formats. To avoid that it being loaded twice the command \ @ifunde-
fined is used in the above command.)

If you are using font sizes larger than the normal size, the table borders are often
too close to the letters. This can be corrected by inserting the command \strut in
TEX-Code at the beginning of a table row. Table 2.19 illustrates the effect.

2.13.2. Special Cell Alignment

Sometimes it looks better when the cell entries of a column are aligned with a special
character, e. g. with the decimal separator as in Table 2.20. This alignment is achieved

.00
by setting the cursor into the column and then either pressing the toolbar button -#
or setting the alignment in the table settings to At Decimal Separator. The alignment
character can be a character of your choice and is specified in the table settings.

For alignments at characters in formulas this method does not work because the field
to specify the alignment character does not allow formulas. In this case one need
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Table 2.19.: Vertical alignment of text with large font sizes.

(b) Table using
the command

(a) Normal table. \strut.
Normal, g Normal, g
Large Large
Larger Larger

Largest
Huge
Huger Huge
Huger

Largest

Table 2.20.: Table cells of a column aligned with the decimal separator.

heading

12.6
0.68
-123.0

to use the method from Table 2.21. This table was created with a 4x2 table. The
heading is a centered multicolumn. The first column is right-aligned and contains
the first part including the operator. The second column is left aligned and contains
the rest. A small space was added at the beginning of each cell of the second column
to get the space that is usually around operators. To omit the space that is normally
between two table columns, the following I¥TEX-argument was used for the second
column:

@{}1

Table 2.22 shows some example alignments. For the alignment with the relation sign,
a small space was added like for the second column of Table 2.21.

2.13.3. Customized Cell/Column Format

Calculating the required width for normal columns as described in section 2.12 or
for spanned columns as described in section 2.8.2.2 is very annoying if you have
several tables where a calculation is necessary. To make life easier, you can define a
cell/column format in the preamble, that can be used in all tables of the document.
The format is defined with the command
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2. Tables

Table 2.21.: Table cells of a column aligned with the operators.

heading

1246
0—68
~123/0

Table 2.22.: Several table cell alignments.

units ‘ exponents ‘ relations
12x24 bottles 10-107%7 (t) o< Y(t)
1024 x 768 Pixels | 5.78-107 A # Brea
32x6 cm -33.5-10* | sin(a) > sin(f)

\newcolumntype{name of format } number of arguments]{commands}
The format name may only consist of one letter. The letters b, ¢, [, m, p and r are

predefined and cannot be used. But all letters are allowed as capitals.

For vertically and horizontally centered multicolumn cells with a fixed width you can
define the cell format

\newcolumntype{M}[1]{>{\centering\hspace{Opt}}m{#1}}

where \ hspace{0pt} avoids the problem of hyphenating the first word, as described
in section 2.8.1. Now you can simply enter

M{width}

as BTEX-argument in the table dialog to create a multicolumn.

For cells spanned by a multicolumn cell, you can define the format

\newcolumntype{S}[2]{>{\centering\hspace{Opt}}
m{ (#1-+(2\tabcolsep+\arrayrulewidth)*(1-#2))/#2}}

This format uses equation (2.1) to calculate the required width so that each spanned
cell has the same width.

You can now enter
S{width of multicolumn cell}{number of spanned columns}

as IXTEX-argument of the column.

For colored columns, you can define

\newcolumntype{K}[1]{>{\columncolor{#1}\hspace{Opt}}c}
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2.13. Table Customization

The “c” at the end creates a column with a flexible width whose text is horizontally
centered. You can now enter

K{color name}

as WTEX-argument.

To create Table 2.23 use the KTEX-arguments
M{2.5cm}

for the first column and the multicolumn,
K{red}

for the last column, and

S{2.5cm}{2}

for the cells in the second column.

Table 2.23.: Table using user-defined table formats

very- ) .
longtablecell- mmmple lines
word multicolumn

d o f

h ) i

2.13.4. Line Thickness

The line thickness for all lines in a table can be adjusted with the length \ar-
rayrulewidth. To set for example a line thickness of 1.5 pt, as in Table 2.24, insert
the command

\setlength{\arrayrulewidth}{1.5pt}

in TEX-Code before the table or table float. The changed thickness is valid for all
subsequent tables. To use the default value again, set \arrayrulewidth to 0.4 pt in
TEX-Code after the table or table float.

To set the line thickness to 1.5 pt only for horizontal lines, as in Table 2.25, insert
these commands in TEX-Code before the table or table float:

\let\myHline\hline

\renewcommand{\hline}
{\noalign{\global\arrayrulewidth 1.5pt}
\myHIline\noalign{\global\arrayrulewidth 0.4pt}}
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2. Tables

Table 2.24.: Table with 1.5 pt thick lines

sd

sd

sd

Table 2.25.: Table with 1.5 pt thick horizontal lines

sd

sd

sd

To return to the default line thickness, insert this command in TEX-Code after the
table or table float:

\renewcommand{\ hline}{\myHline}

To set the line thickness to 1.5 pt only for vertical lines, create the following column
format in the document preamble, according to the description in section 2.13.3:

\newcolumntype{V }{!{\vrule width 1.5pt}}
For Table 2.26 the KTEX-argument

VeV

was used for the last column and

Ve

for the other columns.

Table 2.26.: Table with 1.5 pt thick vertical lines

sd

sd

sd
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2.13.5. Dashed Lines

Table 2.27.: Table with dashed lines

labic|d]e]
,fghai}]p
k|l rm|njo
pqir 7Si<
t u;V W‘X

ILyX does not natively support dashed lines, so you have to use TEX-Code. As a
prerequisite the ITEX-package arydshln must be loaded in the document preamble
with the command

\usepackage{arydshln}

To make a vertical line dashed, enter the colon “:” together with the character for
the horizontal alignment as BTEX-argument in the table cell dialog.

For a horizontal dashed line add the command

\hdashline

in TEX-Code as first element of the first cell in the table row.
For dashed multicolumn lines use the command
\cdashline{line number}

in TEX-Code as the first element of the first cell in the table row. If you have for
example a multicolumn spanning columns 2 to 4 and you want to have a dashed line
above, add the command

\cdashline{2-4}

as the first element of the first cell in the row of the multicolumn.

Table 2.27 was created using “:c” as KITEX-argument of the third column. The TEX-
Code command \hdashline was inserted in the first cell of the third row and the
TEX-Code command

\cdashline{4-5} was inserted in the first cell of the fourth row.

Tables with dashed lines can also be colored as shown by Table 2.28.

The coloring of lines, columns and lines works as decribed in section 2.11. Coloring
horizontal lines works analogically as described there as well, one only needs to replace
in the commands \myHlineC by \myHdashline and \hline by \hdashline; so
one uses the command
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2. Tables

Table 2.28.: Colored table with dashed lines

\let\myHdashline\hdashline
\renewcommand{\hdashline}
{\arrayrulecolor{red}\myHdashline\arrayrulecolor{black}}

To color \cdashline, the command is

\let\myCdashline\cdashline
\renewcommand{\cdashline}[1]
{\arrayrulecolor{red}\myCdashline{#1}\arrayrulecolor{black}}

To get back the black line color, one needs to insert the following commands as
TEX-Code behind the table:

For \hdashline

\renewcommand{\hdashline }{\myHdashline}
and for \cdashline
\renewcommand{\cdashline}{\myCdashline}
To color the gaps between the dashes the command
\dashgapcolor{color}

can be used in front of a table as TEX-Code. color is hereby the name of a defined
color. The command

\nodashgapcolor
unsets the changes made by \dashgapcolor.

Note: If there are multiple commands in a cell, the command of arydshln needs to
be the first one in the cell. Therefore in cell &k of Table 2.28 the command \ hdashline
is before \rowcolor.

Note: The KTEX-package arydshln must be loaded in the document preamble
before the WTEX-package colortbl.

For more information about dashed lines see the documentation of arydshln, [4].
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3. Floats

3.1. Introduction

A float is a block of text associated with some sort of label, which doesn’t have a
fixed location. It can “float” forward or backward a page or two, to wherever it fits
best. Footnotes and Margin Notes are also floats because they can float to the next
page when there are too many notes on the page.

Floats allow a high quality layout. Images and tables can be spread evenly among
the pages to avoid white space and pages without text. As the floating often destroys
the context between the text and the image/table, every float can be referenced in
the text. Floats are therefore numbered. Referencing is described in section 3.4.

To insert a float, use the menu Insert> Float. This inserts the Caption inset, a box with
a label. The label will automatically be translated to the document language in the
output. After the label you can insert the caption text. The image or table is inserted
above or below the caption in a separate paragraph within the float. More about the
caption placement is contained in section 3.10. To keep your [yX-document readable,
you can open and close the float box by left-clicking on the box label. A closed float

box looks like this: 192 FE#e 5 oray button with a red label.

It is recommended that you insert floats as separate standard paragraphs to avoid
possible KTEX-errors that can occur when the surrounding text is specially formatted.

Existing figures or tables can be put into a float by highlighting them and then
pressing the corresponding toolbar button for a new float.

3.2. Float Types

Besides figure and table floats that are described in sections 1.2 and 2.5 respectively,
LyX offers the float types Algorithm and Wrap. The latter are explained in sec. 6.1.

3.2.1. Algorithm Floats

This float type is inserted with the menu Insert>Float> Algorithm. It is used for
program codes and descriptions of algorithms and can be seen as an alternative
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3. Floats

Algorithm 3.1 Example Algorithm float

for I in 1..N loop
Sum:= Sum + A(I); /*comment*/
end loop

to program code listings that are explained in chapter 8. A possible environment
for algorithms is the LyX-Code, described in IyX’s Userguide. Algorithm 3.1 is an
example of an algorithm float where -4 mm vertical space was added at the end of
the float to have the bottom rule exactly below the last text line.

The float label is not automatically translated into the document language. If your
document is not in English, you have to do this manually by adding the following
line to the document preamble:

\floatname{algorithm } {your name}
where your name is the word “algorithm” in your language.

To insert the list of algorithms you can use the menu Insert > List / TOC» List of Algo-
rithms when your document has the same language as [yyX’s menu names. In other
cases use this command in TEX-Code instead:

\listof{algorithm}{your name}
where your name is the word “List of Algorithms” in your language.

Algorithm floats are not by default numbered in the scheme “chapter.algorithm” as is
the case for table and figure floats in many document-classes. To number algorithm
floats in the same scheme, add this command to your document preamble:

\numberwithin{algorithm}{chapter}

To be able to use the command \numberwithin, set in the tab Math Options in the
document settings the option Use AMS math package.

3.3. Float Numbering

Floats are usually numbered either independently from the sections the floats are
in, or in the scheme “chapter.number” or “section.number”. This depends on the
document class used.

To change section-independent numbering, you can use this command in the docu-
ment preamble:

\renewcommand{\thetable}{\roman{table}}

\thetable is the command that prints the table number. For figure floats, the
command would be \thefigure. \roman in the command above prints the table
number as a small roman number.
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To change the numbering scheme for example to “subsection.number”, use this com-
mand in the preamble:

\numberwithin{table}{subsection}

To be able to use the command \numberwithin, set in the tab Math Options in the
document settings the option Use AMS math package.

Please also have a look at section 4.2.1 for the details and important notes about the
numbering commands.

3.4. Referencing Floats

To reference a float, insert a label into its caption using the menu Insert>Label or

the toolbar button “'. A grey label box like this one: fg ThiS-183 o1 16 inserted

and the label window pops up asking for the label text. LyX offers as text the first
words of the caption with a prefix. The prefix depends on the float type, e.g. for
figure floats the prefix will be "fig:".

The label is used as anchor and name for the reference. YOll can refer to the label

H

using the menu Insert > Cross-reference or the toolbar button |=*2I. The cross-reference
window appears showing all labels of the document. If you have multiple LyX-
documents opened, choose the one you are working on from the drop-list at the top
of the dialog. You can now sort the labels alphabetically and then choose one. A grey

cross-reference box like this one: Wef SECCOMAl i) ho ingerted. At the position of
the cross-reference box the float number will appear in the output.

It is recommended that you use a protected space between the cross-reference name
and its number to avoid line breaks between them. If a cross-reference refers to
a non-existing label, you will see two question marks in the output instead of the
reference.

You can change labels at any time by clicking on the label box. References to the
changed label will automatically update their links to the new label text.

The button Go to Label in the cross-reference window sets the cursor before the
referred label. The button text changes then to Go Back and you can use it to set
the cursor back to the cross-reference.

3.4.1. Cross-Reference Formats

There are six varieties of cross-references:

<reference>: prints the float number, this is the default: 1.3
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(<reference>): prints the float number within two parentheses, this is the style
normally used to reference formulas, especially when the reference name “Equa-
tion” is omitted: (2.1)

<page>: prints the page number: Page 4
on page <page>: prints the text "on page" and the page number: on page 4

<reference> on page <page>: prints the float number, the text "on page', and
the page number: 1.3 on page 4

Formatted reference: prints a self-defined cross-reference format.
Note: This feature is only available when you have the I¥TEX-package pret-
tyref or refstyle installed.
You can select which I¥TEX-package should be used for this feature by setting
the option Use refstyle (not prettyref) for cross-references in the menu Docu-
ment > Settings> Document Class. The format is specified by adding the com-
mand \newrefformat (prettyref) or \newref (refstyle) to the preamble of
the document. For example redefining all references to figures (which have the
label shortcut “fig”) can be done with this command
\newref{fig}{refcmd={Image on page \pageref{#1}}}
For more information about the format, have a look at the package documen-
tations, [17, 19].

Textual reference: prints the caption of the reference: Two distorted images. Both
images are in the image settings group named “distorted”.

<page> will not print the page number if the label is on the previous, the same, or
the next page. You will e. g. see the text “on this page” instead. The style <reference>
on page <page> will not print anything about the page if the label is on the same
page.

The number and current page of the part of the document referred to in the output
is automatically calculated by ETEX. The varieties are adjusted in the field Format
of the cross-reference window that appears when you click on the cross-reference box.

Note: It is recommended to use the IXTEX-package refstyle because prettyref does
not know all of IyX’s possible label shortcuts! and is not internationalized.

Note: Due to a bug in the KTEX-package varioref version 1.4w, some cross-reference
formats will cause KTEX errors for document languages that make the period char-
acter active (like French). For a workaround, see

http://wiki.lyx.org/LaTeX/LatexBugs#toc5.
3.4.2. Automatic Reference Naming

The BTEX-package hyperref, that is enabled in the PDF Properties of the Document
Settings dialog, provides a very useful feature that cross-references automatically

l4fig:” is for example LyX’s shortcut for labels in figure captions.
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3.5. Float Placement

include the name of the referenced floats (or text parts like section). So you will save
having to write e. g. the name “Figure” before every reference to a figure. To use this
feature, enable hyperref and insert this line to the IXTEX preamble:

\AtBeginDocument{\renewcommand{\ref}[1]{\mbox{\autoref{#1}}}}

When you prefer other reference names than the default ones, for example you want
instead of “section” the name “sec. “, you can redefine the name by inserting this in
the preamble:

\addto\extrasenglish{\renewcommand{\sectionautorefname}
{sec.\negthinspace}}

When you are using another document language than English, replace
\extrasenglish by \extras*** where *** is the name of the language used.

To get automatic names, but not for certain reference types, for example not for
equations, use this preamble code:

\addto\extrasenglish{\renewcommand*{\equationautorefname}[1]{}}
More about this topic can be found in hyperref’s documentation [11].

Note: Automatic reference naming cannot be used when you use cross-references in
the Formatted reference style, as described in section 3.4.1.

The Math manual is an example where automatic reference naming is used.

3.4.3. Reference Position

If you use hyperref in the PDF Properties of the Document Settings dialog to link
cross-references in the output, you will see that clicking on an image float reference
jumps to the image label. The caption will be the first text part on the screen, so that
you cannot see the image without scrolling. This is because the reference link anchor
is placed at the position of the label. With the use of the package hypcap, which
is part of the IfTEX-package oberdiek, the link anchor is placed at the beginning of
a float. To use this feature for figure floats, load hypcap in the document preamble
with the line

\usepackagel[figure]{hypcap}

You can also use hypcap for all float types but this is not recommended for stability
reasons. For more information, have a look at hypcap’s manual [10].

Note: hypcap has no effect on references to subfigures.

3.5. Float Placement

Right-clicking on a float-box and clicking on Settings opens a dialog where you can
alter the placement options that BKITEX uses for positioning the float.
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The option Span columns is only useful for two-column documents: If you select it,
the float will span both columns on the page instead of being confined to just one.
The option Rotate sideways is used to rotate floats, see section 3.6.

You can use one or more of the following options in the float dialog to set the place-
ment for a particular float when you uncheck the option Use default placement:

Here if possible try to place the float on the position where it has been inserted
Top of page try to place the float at the top of the current page

Bottom of page try to place the float at the bottom of the current page

Page of floats try to place the float on its own page

The order of the above option is always used by EIEX. That means, if you use the
default placement, KTEX will first try out Here if possible, then Top of page, and then
the others. If you do not use the default, IXTEX will try only the checked options but
in the same order. If none of the 4 placements is possible the procedure is internally
repeated trying to put the float on the following page.

By default, each option has its own rules:

Top of page only floats occupying less than 70 % of the page can be placed at the top
of a page (\topfraction)

Bottom of page: only floats occupying less than 30 % of the page can be placed at
the bottom of a page. (\bottomfraction)

Page of floats: only if more than 50 % of the page is occupied by floats, several floats
can be set together on a page. (\floatpagefraction)

If you don’t like these rules, you can ignore them by using the additional option
Ignore IKTEX rules.

You can also redefine the rules with BTEX-commands that are given in parentheses
after the rules description above. To increase for example the often too small default
of the bottom-rule to 50 % of the page, add this line to your document preamble:

\renewcommand{\bottomfraction}{0.5}

Sometimes you might need, under all circumstances, a float to be placed exactly at
the position where it is inserted. For this case you can use the option Here definitely.
Use this option very rarely and only if the document is almost ready to be printed,
because the float is then no longer able to “float” when you change your document
and this will often destroy the page layout.

There are no placement options for text wrap floats, because they are always sur-
rounded by the text of a certain paragraph.

Sometimes you have the problem that a float is placed at the top of a page while
its corresponding section starts at the middle of the page, so that the reader could
think the float is part of the previous section. To avoid this the BEIEX-command
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3.6. Rotated Floats

\suppressfloats can be used. It suppresses a given float placement for the page
where it is inserted and can therefore be used to avoid floats being set before a
section starts. To get this, add these commands to your document preamble:

\let\mySection\section
\renewcommand{\section }{\suppressfloats[t]\mySection}

You can define the same for all section headings, like chapters and subsections. This
definition is not recommended to be used for small text parts like subsubsections
because KTEX may then have problems finding a suitable placement.

In some cases it is required to have all figures/tables at the end of the document.
For this purpose the IXTEX-package endfloat was developed. It puts all figure and
table floats at the end of the document into their own sections. At the original float
position a text hint like “[Figure 3.2 about here.]” is inserted. The endfloat-package
is loaded in the preamble with the line

\usepackage[options]{endfloat}

There are various package options to format the created figure/table sections. For
more information we refer you to the endfloat documentation [8].

Note: endfloat doesn’t provide an automatic translation for the text hint, you have
to do this manually, see section 4 in [§].

Note: There is currently a bug in endfloat when the caption contains a German
“B”. Use in this case the command “\ss” in TEX-Code instead of “8”.

For more details about float placements, have a look at TEX books, [1, 2, 3].

3.6. Rotated Floats

Especially for wide tables you might have floats rotated. To rotate a whole float
including the caption, right-click on the float-box and use the option Rotate sideways.

Rotated floats are always placed on a page of their own (or column of their own; in
case you have a multi-column document). You can let them span several columns
using the float settings option Span columns. Floats are rotated so that you can read
them from the outside margin. To force a certain rotation direction for all pages, you
can add either the option figuresleft or figuresright to the document class options.

Referencing rotated floats is the same as for normal floats, the caption format is also
the same: Table 3.1 is an example of a rotated table float.

Note: Not all DVI-viewers are able to display rotated floats.
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Table 3.1.: Rotated table

:mm:_uiojimi
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3.7. Subfloats

Table 3.2.: Two subtables placed side by side.

(a) This is subtable a. (b) This is subtable b.
’test‘b‘c‘d‘e‘ ’e‘d‘c‘b‘test‘

Table 3.3.: Two subtables placed one above the other. (a) table with 4 cells, (b)
table with 5 cells.

(a)
’test ‘ test ‘ test ‘ test‘
(b)
[a]bcfd]e]

3.7. Subfloats

Subfloats are for example used when a figure consists of several images. They are
created by inserting a float into an existing float. The placement of the subfloats can
be controlled in the same way as for paragraphs as shown in table 3.2 and 3.3.

Referencing subfloats works as for normal floats: Table 3.2a and 3.2b are subtables
of table 3.2.

3.8. Floats Side by Side

To place floats side by side, as in Figures 3.1 and 3.2, only one float is used. In it
two minipage boxes are inserted.? The width is set to 45-50 column% and the box
alignment to Bottom for each minipage. The minipage boxes contain the image and
the caption in the same way as they are in a float. The only difference is that the
image unit Column Width % is now calculated according to the width of the minipage
boxes.

3.9. Caption Formatting

The Caption environment is the default paragraph environment for Floats. On the
LyX screen captions appear as a label, e. g. “Figure #:” followed by the caption text.
“#7 is the actual reference number. By default the label and the number are in the

2Minipages are explained in section 5.4.
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Figure 3.1.: Float on the left side. Figure 3.2.: Float on the right side.

same font as the caption text and a colon follows the number to divide the label from
the text. This caption format is not suitable for all document formats.

To change the default caption format, load the KTEX-package caption in the docu-
ment preamble with this line:

\usepackage[format definition]{caption}

To have for example the label and the number in sans-serif bold font and the table
captions always above the table as in this document, use the following command:

\usepackage[labelfont={bf,sf}, tableposition=top|{caption}

You can also define different caption formats for the different float types. In this case
load the caption package without format specific options and define the different
formats with the help of the command

\captionsetup[float type]{format definition}

in the document preamble. For example the caption formats of Figure 3.3 and Ta-
ble 3.4 can be created using these commands in the document preamble:

\usepackage[tableposition=top]{caption}

\captionsetup|figure]{labelfont={tt}, textfont=it, indention=1cm,%
labelsep=period}

\captionsetup[table|{labelfont={bf,sf} }

Note: The option tableposition=top has no effect when a KOMA-Script docu-
ment class is used. In this case the document class option captions=tableheading
must be used.

For more information about the package caption we refer to its documentation [6].
To change the label name from e. g. “Figure” to “Image” use this preamble command:
\renewcommand{\ fnum@figure} {Image~\thefigure}

where \thefigure inserts the figure number and “~” creates a protected space.
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3.10. Caption Placement

If you are using a KOMA-Script document class (article (KOMA-Script), book
(KOMA-Script), letter (KOMA-Script), or report (KOMA-Script) ), you can alterna-
tively to the caption package use KOMA-Script’s built-in command \setkoma-
font. For example, to have the caption label in bold, add this command to your
document preamble:

\setkomafont{captionlabel }{\bfseries}

For more information about \setkomafont we refer to the KOMA-Script docu-
mentation [12].

3.10. Caption Placement

The common caption placement rule is:
Figure: Caption is set below the figure
Table: Caption is set above the table

Having the caption above the table is unfortunately not supported in BTEX’s standard
classes. That means if you are using the document classes article, book, letter, or report
there will be no space between the caption and the table. To insert the necessary
space, add the following option to the load command of the BTEX-package caption
in your document preamble?:

tableposition=top

If you are using a KOMA-Script document class (article (KOMA-Script), book
(KOMA-Script), letter (KOMA-Script), or report (KOMA-Script) ), you can alterna-
tively to the caption package set the document class option captions=tableheading.

It is also possible to set the caption beside a figure or table. To get this the ITEX-
package sidecap has to be loaded in the document preamble with the line

\usepackage[option|{sidecap}

If you set no option, the caption is placed on the side of the outer page margin — to
the right on odd pages, to the left on even pages. You can change the placement to
inner margin with the option innercaption. To force the placement always to the
right or left, use the option rightcaption or leftcaption, respectively.

To place in [yX the caption of a float on the side, it is necessary to add these
commands to the document preamble:

3See section 3.9 for more information of the package caption.
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\newcommand{\ TabBesBeg}[1][1.0]{%
\let\MyTable\table
\let\MyEndtable\endtable
\renewenvironment{table}[1]{\begin{SCtable}[#1]##1}{\end{SCtable}}}

\newcommand{\ TabBesEnd }{%
\let\table\MyTable
\let\endtable\ MyEndtable

\newcommand{\FigBesBeg}[1][1.0]{%
\let\MyFigure\figure
\let\MyEndfigure\endfigure
\renewenvironment{figure}[1]{\begin{SCfigure}[#1]|#+#1}{\end{SCfigure}}}

\newcommand{\FigBesEnd }{%
\let\ figure\MyFigure
\let\endfigure\ MyEndfigure}

The commands allow you to redefine the floats so that the caption is set on the side.
For figure floats use the command

\FigBesBeg

in TEX-Code before the float. And insert the command

\FigBesEnd

in TEX-Code at the point where you want to get back to the original float definition.
For table floats use the corresponding commands

\TabBesBeg and \ TabBesEnd

Figure 3.4 and Table 3.5 are examples where the caption is set beside.

You can see in the examples that the caption text appears at the top of the floats
for table floats and at the bottom for figure floats. To change this, you can use the
command

\sidecaptionvpos{float type}{placement}

in the document preamble or in TEX-Code before the float. The float type is either
figure or table, the placement can be “t” for top, “c” for center, or “b” for bottom. To
have for example the caption of figure floats vertically centered, use the command

\sidecaptionvpos{figure}{c}
This was used for Figure 3.5.

The default caption width is the width of the image/table. For thin image/tables,
like in Table 3.5, this leads to captions that are too thin. You can increase the width
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3.11. Listings of Floats

by specifying a factor that will be multiplied with the image/table width to get the
caption width. The caption width will automatically be recalculated in case it would
protrude over the page or column margin due to the specified width. The factor can
either be given as optional argument for \FigBesBeg:

\FigBesBeg|factor]

or in the definition of \FigBesBeg by replacing the 1.0 with another value. If
you do the latter, your factor will be the default if \FigBesBeg is used without an
argument. For Table 3.6 the factor 5 was used.

Note: For floats with captions set beside, you cannot use the float placement option
Here definitely because it is not supported by sidecap.
For more information about the package sidecap we refer to its documentation [20].

Note: The IXTEX-package hypcap, described in section 3.4.3, has no effect on floats
with the caption set beside.

3.11. Listings of Floats

Similar to the table of contents where the sections of the document are listed, there
are listings for all float types, like the figures of the documents. You can insert them
via the Insert>List / TOC sub menus.

The list entries are the float captions or its short title, the float number, and the page
number where they appear in the document.

You can find the list of figures and tables at the end of this document.

95



3. Floats

Figure 3.3.. This is an example figure caption that is longer than one line to
show the different caption format. Here a self-defined caption

format is used.

Table 3.4.: This is an example table caption that is longer than one line to show the
different caption format. Here the standard caption format for tables in

this document is used.

Figure 3.4: This is a caption
beside a figure.

Table 3.5: ThlS a b C
is a d o

cap-
tion f - & - h
be- ! J
side a
table.

Table 3.6: This is a caption is wider than the one in Table 3.5. | 4 b ¢
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Figure 3.5.: This is a vertically centered caption beside a figure.
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4. Notes

4.1. LyX Notes

Notes are inserted with the toolbar button =/ or the menu Insert > Note. There are
three types of notes:

LyX Note This note type is for internal notes that won’t appear in the output. Its
note-box looks like this:

Hote \Thig iz text in a note box that doesn't appear in the output.

Comment This note also doesn’t appear in the output but it appears as KTEX-
comment, when you export the document to KTEX via the menu File> Export >
KTEX (pdflatex) / (plain). Its note-box looks like this:

Comment This iz text in a note box that only appears as comment in LaTe3-files,

Greyed Out This note will appear in the output as grey text. Its note-box looks like
this:

Greyed 0ut Thig iz text of a comment that appears in the output as grey text.

1

As you can see in the example, the first line of greyed out notes is a bit in-
dented and greyed out notes can have footnotes.

When you use the toolbar button ~=J to insert notes, a LyX Note is inserted. You can
switch between the three note types by right-clicking on the note-box. If you want
to turn existing text into a note, mark it and click on the note toolbar button. To
change a note to text, press the backspace key when the cursor is in the first position
of a note, or press the delete key when the cursor is in the very last position of the
note, respectively.

IThis is an example footnote within a greyed out note.
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4. Notes

You can change the text color of the greyed out notes in the menu Documentr
Settingst Colors.

4.2. Footnotes

Footnotes can be inserted using the toolbar button ‘;l or the menu Insert > Footnote.

You will then see the following footnote-box: 0L L where you can enter the footnote

text. If you want to turn existing text into a footnote, mark it and click on the
footnote toolbar button. To change a footnote to text, press the Backspace key when
the cursor is in the first position of a footnote, or press the Delete key when the cursor
is in the very last position of the footnote, respectively.

Here is an example footnote:?

The footnote will appear in the output as a superscript number at the text position
where the footnote box is placed. The footnote text is placed at the bottom of
the current page. The footnote number is calculated by KIEX; the numbers are
consecutive. Whether the footnote number is reset for every chapter depends on
your document class.

Footnotes can be referenced like floats: Insert a label into the footnote and cross-
reference this label in the text as described in section 3.4.
This is a cross-reference of Footnote 2.

Footnotes in tables are not printed by KEIEX due to technical reasons. However
there exists another method to print them: Instead of the footnote the command
\footnotemark{} is inserted as TgX-code. The text of the footnote is entered as
an argument of the TEX-code command \footnotetext after the table.

This was done for the following table with the command

\footnotetext{Printed table footnote.}

This an example text.?

This an example text.*

Footnotes in longtables are described in section 2.6.1.

Footnotes in minipage boxes are printed, but inside the box and with a different
numbering because a minipage box is like a page inside a page. (For more about
minipages, see section 5.4.) To get a footnote in the minipage that is output at the
bottom of the page like normal footnotes, also use the method of \footnotemark{}
and \footnotetext.

2This is an example footnote.

4Printed table footnote.
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This an example text in a minipage.®
This an example text in a minipage.’

“Footnote in the minipage.

To refer to the same footnote several times without printing the footnote text every
time, use the command \footnotemark[number] in TEX-code.

As you do not know the number of the repeating footnote while you are writing the
text, you have to store its number. For the following footnote mark example, these
commands were inserted in TEX-code after Footnote 2 to store the footnote number:

\newcounter{MyRepeatFoot}
\setcounter{MyRepeatFoot }{\thefootnote}

The footnote mark was then created with this command:
\footnotemark[\theMyRepeatFoot]
Here is a repeated footnote:?

If you want to repeat the previous footnote, you can omit the storage of the footnote
number and just use this command instead:

\footnotemark[\thefootnote]

Here is another repeated footnote:

4.2.1. Footnote Numbering

To reset the footnote number back to 1 after each section, add this command to your
document preamble:

\@addtoreset{footnote}{section}

The following preamble command changes the footnote numbering style to small
roman numerals:

\renewcommand{\thefootnote}{\roman{footnote}}
This is a footnote with roman numbering:"!

To change the numbering style to capital roman numerals replace in the command
above \roman by \Roman. To “number” footnotes with capital or small Latin
letters use \ Alph or \alph, respectively. To “number” footnotes with symbols use
\fnsymbol.

Note: You can only number 26 footnotes with Latin letters, because this numbering
is limited to single letters.
Note: You can only number 9 footnotes with symbols.

5Footnote outside the minipage.
ViThis is an example footnote with roman numbering.
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To return to the default numbering style after you have changed to another one, use
\arabic instead of \roman in the command above.

If you want to have footnotes numbered in the scheme “chapter.footnote”, add the
following command to your document preamble:

\numberwithin{footnote}{chapter}

To be able to use the command \numberwithin, set in the tab Math Options in the
document settings the option Use AMS math package.

This is another example footnote:*7

Note: \numberwithin always prints out the footnote number as arabic number;
previous redefinitions to get non-arabic numbers are overwritten.

So to get for example the scheme “chapter.\Roman{footnote}”, use this command
instead of \numberwithin:

\renewcommand{\thefootnote}{\thechapter.\Roman{footnote}}

4.2.2. Footnote Placement

If you have several footnotes in one page, they appear without vertical space between
them at the bottom of the page. To make them more readable you can e.g. add
1.5 mm space with the following preamble command:

\let\myFoot\footnote
\renewcommand{\footnote}[1]{\myFoot{#1\vspace{1l.5mm}}}

In a two-column document the footnotes appear at the bottom of every column, see
Figure 4.1. If the footnotes should only appear at the bottom of the right column, as
in Figure 4.2, use the IXTEpX-package ftnright with this command in the document
preamble:

\usepackage{ftnright}

In some scientific literature it is usual to collect the footnotes and print them in a
separate paragraph at the end of a section, as in Figure 4.3. They are then called
“endnotes”. To use endnotes instead of footnotes in your document, load in the
menu Document > Settings > Modules the module Foot to End. To insert the collected
footnotes, insert the command

\theendnotes
in TEX-Code at the end of a section or chapter.

47This is a footnote numbered in the scheme “chapter.footnote”.
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Das dSpektrum wird tourlertranstormiert.
Die Fouriertransformation wird verwendet,
um die iiberlagerten Signale (Netzwerk,
- Losungsmittel) zu trennen. Nachdem wir
S(t) = Sp(t) / P(¢,t)ei¢ d¢  (2) die Phasenverschiebung bestimmen konn-

—0 ten, interessiert uns nun das Aussehen des

wobei Sy das Signal ohne Gradient Ausgangssignals. Im Experiment haben wir
ist und die Normierungsbedingung es mit sehr vielen Teilchen zu tun, so dass

Sei nun S unser normiertes Ausgangssignal
und P die Phasenverteilungsfunktion, so
ergibt sich die Beziehung

Fourier transformation 3Fourier transformation
2Phase distribution function 4Phase distribution function

1

Figure 4.1.: Standard footnote placement in two-column documents.

Das Spektrum wird touriertranstormiert.
Die Fouriertransformation wird verwendet,
um die iiberlagerten Signale (Netzwerk,
Losungsmittel) zu trennen. Nachdem wir
die Phasenverschiebung bestimmen konn-

S(t) = So(t) /OO P(¢,t)ei¢ do 2) ten, interessiert uns nun das Aussehen des

man {iber alle Phasen integrieren muss.
Sei nun S unser normiertes Ausgangssignal
und P die Phasenverteilungsfunktion, so
ergibt sich die Beziehung

1. Fourier transformation
wobei Sy das Signal ohne Gradient 2. Phase distribution function

ist und die Normierungsbedingung 3. Fourier transformation
I P(p,t)dg = 1 gilt. Nun diirfen 4. Phase distribution function

1

Figure 4.2.: Footnote placement in two-column documents when the ETEX-package
ftnright is used.

The paragraph heading for the endnotes isn’t automatically translated into the doc-
ument language, this must be done manually. The following preamble command
translates the default English “Notes” into the German “Anmerkungen”:

\renewcommand{\notesname}{Anmerkungen}
The numbering of endnotes can be changed like the footnote numbering as described
in section 4.2.1; just replace the command \thefootnote by \theendnote. To reset

the endnote number use the command \@addtoreset as described in section 4.2.1
and replace the command parameter footnote by endnote.

For endnotes there is the command \endnotemark[number]| similar to the com-
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This is a
margin note.

4. Notes

man tiber alle Phasen integrieren muss.
Sei nun S unser normiertes Ausgangssignal Notes
und P die Phasenverteilungsfunktion, so
ergibt sich die Beziehung 'Fourier transformation
oo . 2 C . .
S(t) _ So(t)/ P(gb, t)el(b dgb (2) Phase distribution function
— 0o

3Fourier transformation

wobei Sy das Signal ohne Gradient “Phase distribution function
ist und die Normierungsbedingung
[, P(é,t)dg = 1 gilt. Nun diirfen

Figure 4.3.: Endnotes — footnotes are printed in a separate paragraph at the end of
sections or chapters.

mand \footnotemark, that is described in section 4.2.

Footnotes can also be placed in the page margin and the footnote text alignment can
be changed, see the KTEX-package footmisc, [9] for more information about this.

For various further footnote formatting issues have a look at XTEX-books, [1, 2, 3]. If
you are using a KOMA-Script document class, you can adjust all footnote settings
using class-specific commands, see [12].

4.3. Margin Notes

Margin notes look and behave in LyX like footnotes. They are inserted via the

menu Insert>Marginal Note or the toolbar button El A grey box with the red label
“margin” appears where you can enter the text of the margin note.

At the side is an example margin note.

Margin notes appear at the right side in single-sided documents. In double-sided
documents they appear in the outer margin — left on even pages, right on odd pages.
The text of margin notes is aligned opposite to the outer margin — right-aligned when
the note appears in the left margin. The first line of the margin note is placed at the
position of the text line where it is inserted in the document.

To place the margin note in the inner margin, add the command
\reversemarginpar

in TEX-Code before a margin note. The new placement is valid for all subsequent
margin notes.

Note: There is often not enough space in the inner margin so that the notes are not
correctly displayed in the output.

64

This is a
margin not
in the inne
margin.



4.3. Margin Notes

To return to the default placement insert the command
\normalmarginpar

in TEX-Code.Note: The command is ignored when it is within a paragraph where
also the command \reversemarginpar is inserted.

Similar to the case described in section 2.8.1, long words cannot be hyphenated when
they are the first word in a margin note. To avoid this, insert 0 pt horizontal space
before the word.

Note: Margin notes can normally not be used inside tables, floats, and footnotes.

This restriction can be evaded by using the KTEX-package marginnote. By adding
these two lines to your document preamble, the command used by IyX for margin
notes is redefined to use the command provided by the marginnote-package:

\usepackage{marginnote}

\let\marginpar\marginnote

This is also used in this document because marginnote has another useful feature:
You can set a vertical offset for the note. This is often needed when too many margin

notes are too close together or for a better page layout. The offset is set in IyX as
TEX-Code directly after the margin note in the scheme

[offset]

where the offset is a length with one of the units listed in Table A.1. A negative
value shifts the note up, a positive value shifts it down. For example the margin note
beside this text line is shifted up 1.5 cm with the TEX-Code-command “[-1.5cm]”

With marginnote you can also change the alignment of the text in the margin note.
For example the commands

\renewcommand*{\raggedleftmarginnote}{\centering}
\renewcommand*{\raggedrightmarginnote}{\centering}

set the alignment to centered. \raggedleftmarginnote denotes margin notes that
appear at the left side. The default is

\renewcommand*{\raggedleftmarginnote}{\raggedleft}
\renewcommand*{\raggedrightmarginnote}{\raggedright}

For the other features of marginnote refer to its documentation [15].

You can adjust the layout of margin notes by changing its definition. To create for
example a header for all margin notes with the underlined, sans-serif, and bold header
text “Attention!” add this to your document preamble:
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4. Notes

\let\myMarginpar\marginpar
Attention! \renewcommand{\marginpar}[1]{\myMarginpar{%
This is a  \Rspace{0pt}\textsf{\textbf{\underbar{Attention!}}}%
margin note \vspace{1l.5mm}\\#1}}
with a
defined
heading.
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5. Boxes

5.1. Introduction

Boxes are used to format a block of text. Boxes can be used to write documents with
multiple languages, see section 5.4, to frame texts, see section 5.2.3, to prevent words
from being hyphenated, see section 5.6.1, to align text, see section 5.6.2, or to set the
background color of texts, see section 5.7.

Boxes can be inserted with the menu Insert>Box or the toolbar button =.. A grey

box with the label Box (Minipage): Box(Minipage) il be inserted. The box type
can be specified by right-clicking on the box and selecting Settings. The box dialog
offers the Inner Box types Makebox, Parbox and Minipage. The type Minipage is the
default for new boxes and is explained in section 5.4; the type Parbox is described in
section 5.5 and the type Makebox in 5.6.1.

Boxes are not numbered and can therefore not be referenced like floats or footnotes.
Note: Boxes must not be the item in an Itemize or Description environment.

Note: For an unknown reason you can only set the Inner Box type to None when you
use a framed box. Boxes without an Inner Box type and without frames are explained
in section 5.6.1.

5.2. Box Dialog

5.2.1. Size

In the box dialog you can adjust the box geometry in the fields Width and Height.
The available units for the geometry are explained in Table A.1. The field Height
offers the following additional sizes:

Depth This is the plain text “height”. It ignores the total depth when there are
multiple text lines in the box:

Box
1 Depth
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5. Boxes

Height This is the height of the text that is inside the box. A value of e. g. 2 for this

size will set the box height to 2 times the text height:

Total Height This is the Height + Depth:

Box height set
to 2 Height

Box height set
to 1 Total Height

Width This sets the width of the box as height:

5.2.2. Alignment

Box
height set
to
1 Width

When you have chosen an Inner Box, the vertical box alignment can be:

Top This is an example text line.

This box
is top-
aligned.

This box

Middle This is an example text line. |is middle-

aligned.

This is an example text line.

This is an example text line.

This box
is
bottom-

Bottom This is an example text line. | aligned.

This is an example text line.

Note: The vertical box alignment can be lost in the output when you have two boxes
in a line and one has e. g. a shadow and the other one not.

The horizontal box alignment can be set via LyX’s paragraph dialog when you set

the box into its own paragraph.

When you have chosen an Inner Box, the box content can be aligned vertically to:

top This is an example text line.
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5.2. Box Dialog

This box
text is
middle-
aligned.

middle This is an example text line. This is an example text line.

This box
text is
bottom-
aligned.

bottom This is an example text line. This is an example text line.

This box

stretch This is an example text line. | text is | This is an example text line.

stretched.

To stretch the box content, it must consist of more than one paragraph. In the
example above every text line is in an own paragraph.

To align the box content horizontally you can use IyX’s paragraph dialog when you
have chosen an Inner Box.

This box

text is

stretched.

If you have not set an Inner Box, you can align the box content horizontally in the
box dialog.

’ This box text is horizontally stretched.

5.2.3. Decoration

The type of the box can be specified in the box dialog in the drop-down list Decoration.
The following types are possible:

No frame Nothing is drawn.
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Simple rectangular frame This draws a rectangular frame around the box. The
frame line thickness has the size of \fboxrule. | Rectangular box

Oval box, thin This draws an oval frame around the box. The frame line thickness
has the size 0.4 pt. [ Oval box, thin j

Oval box, thick This draws an oval frame around the box. The frame line thickness
has the size 0.8 pt. [ Oval box, thick]

Drop shadow This draws a rectangular frame with a shadow around the box. The
frame line thickness has the size of \fboxrule, the shadow has a width of 4 pt.

Shadow box '

Shaded background This draws a box with a red background. Unlike colored boxes®,
it always uses the whole column width and the box is set as its own paragraph.

Double rectangular frame This draws a double-line rectangular frame around the
box. The line thickness of the inner frame is 0.75 \ fboxrule, the thickness of the
outer frame is 1.5 \fboxrule. The distance between the lines is 1.5 \fboxrule + 0.5 pt.
Double
rectangular box

LyX’s box label will reflect the different frame types. To be able to use all types, the
KETEX-package fancybox must be installed.

When you use the decoration simple rectangular frame and no inner box, you can
allow page breaks within a box. Note that then, unlike other framed boxes, the
frame always uses the whole column width, the box is set as its own paragraph, and
\fboxrule and \fboxsep have no effect on this box type. The frame line thickness
has the size of \FrameRule.

Allow page break box

5.3. Box Customization

The default value for the size \fboxrule is 0.4 pt. It can be changed with the following
command in TEX-code to e.g. 2 pt:

\setlength{\fboxrule}{2pt}

1

see sec. 5.7
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5.3. Box Customization

Rectangular box
with
\fboxrule =2pt

The space between the frame and the box content is for all frame styles by default
3 pt. You can change it by setting the length \ fboxsep to another value. For example
the command

\setlength{\fboxsep}{10pt}
sets the value to 10 pt, as with the following box:

Rectangular box
with
\fboxsep =10 pt

The diameter of the round corners of the oval boxes can be set with the command
\cornersize. The command

\cornersize*{1lcm}
sets the diameter to 1cm. The command
\cornersize{num}

sets the diameter to num x minimum(width and height of box). The default is \cor-
nersize{0.5}.

Oval box with \cor-
nersize=1.5cm

The size of the shadow can be adjusted by changing the length \shadowsize. It it
set to 2 pt for the following box by this command:

\setlength{\shadowsize}{2pt}

Shadow box with
\shadowsize =2 pt

The default value for the size \FrameRule is 0.4 pt. The default space between the
note content and the frame is 9 pt and can be changed with the value of \FrameSep.
For example the frame appearance of the following box is set with the TEX-Code
commands

\setlength{\FrameRule}{5pt}
\setlength{\FrameSep}{0.5cm}
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This is text in an allow page break box.

For shaded background boxes the default space between the box content and the
box border is 3pt and can be changed with the value of \fboxsep. The default
background color red can either be changed locally with the command \define-
color{shadecolor} or globally with the menu Tools > Preferencest Colors > shaded box.
The scheme of the \definecolor command is explained in section 2.11.2 For exam-
ple the appearance of the following shaded background box is set with the TEX-Code
commands

\setlength{\fboxsep}{0.5cm}
\definecolor{shadecolor }{cmyk}{0.5,0,1,0.5}

This is yellow text in a shaded background box with dark green background.

Changed lengths and widths are valid for all boxes following the commands that
change them.

5.4. Minipages

Minipages are treated by IXTEX as pages within pages and can therefore for example
have their own footnotes.

Minipages are useful when you write documents with different languages.

Below are two example minipages side by side. Their width is set to 45 col% and they
are separated by a horizontal fill, that was inserted via the menu Insert> Special For-
matting > Horizontal Fill.

2Note that \definecolor requires the ¥ TEX-package color in the preamble, see section 5.7.
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Dies ist ein deutscher Text. Dies ist
ein deutscher Text. Dies ist ein deut-
scher Text. Dies ist ein deutscher Text.
Dies ist ein deutscher Text. Dies ist
ein deutscher Text. Dies ist ein deut-
scher Text. Dies ist ein deutscher Text.
Dies ist ein deutscher Text. Dies ist
ein deutscher Text. Dies ist ein deut-
scher Text. Dies ist ein deutscher Text.
Dies ist ein deutscher Text®. Dies ist
ein deutscher Text. Dies ist ein deut-
scher Text.

%Dies ist eine deutsche Fufinote.

5.5. Parboxes

This is an English Text. This is an
English Text. This is an English Text.
This is an English Text. This is an
English Text. This is an English Text.
This is an English Text. This is an
English Text. This is an English Text.
This is an English Text. This is an
English Text. This is an English Text.
This is an English Text. This is an
English Text. This is an English Text.
This is an English Text.® This is an
English Text.

®This is an English footnote.

The document-wide paragraph settings are ignored within minipages. That means
that there will be no space between paragraphs in minipages although you set it to
e.g. MedSkip in the document settings.

Minipages can also be used to set a background color for text parts, see section 5.7.2.

Note: You cannot have floats or margin notes inside minipages but minipages can
be used inside tables, floats, and other boxes.

5.5. Parboxes

Parboxes are very similar to minipages with the difference that they cannot have
footnotes.

This a text within a parbox.
This a text within a parbox.

This footnote won’t ap-

pear:?

5.6. Boxes for Words and Characters

5.6.1. Prevent Hyphenation

You can use the box type Makebox to prevent words or text from being hyphenated.
Here is an example text:

This line is an example to show how you can prevent the hyphenation of “veryvery-
longword”.
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To prevent the hyphenation of the word “veryverylongword”, put the word into a
box, set the Inner box to Makebox and its width to 1 Width.

This is the result:

This line is an example to show how you can prevent the hyphenation of “veryverylongword”.
You can alternatively set the command “\-“ as TEX-Code directly before the word:

This line is an example to show how you can prevent the hyphenation of “veryverylongword”.

Of course the word now protrudes over the side margin. To avoid this, add via
the menu Insert > Formatting > Ragged Line Break (shortcut Ctrl+Return) a line break
before the word:

This line is an example to show how you can prevent the hyphenation of
“veryverylongword”.

5.6.2. Vertical Alignhment

With the help of the command \raisebox you can align words, characters or other
boxes vertically relative to the surrounding text. \raisebox is used with the following
scheme:

\raisebox{lift } [height|[depth]{box content}
The lift can be a positive value to raise the box or a negative value to lower the box.

To align for example the word “preventing” so that the bottom of the “deepest”

W

character “p” is at the baseline, insert the command
\raisebox{\depth}{

in TEX-Code before the word. After the word insert a closing brace “}” in TEX-Code.
This is the result:

This is a text line with the word “pPreventing” as a raised word.

When you raise or lower characters in a line, the line distance will be spread:

This is a text line with the word “preventing” as a lowered word.
“testing”
This is a text line with the word as a raised word.

If you want to prevent this for a certain reason, set the box height to a zero value.
For example use

\raisebox{-\depth}[0Opt]{

This is a text line with the word “jgsijagiing” as a lowered word.
This is a text line with the word as a raised word.
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5.7. Colored Boxes

5.7. Colored Boxes

5.7.1. Color for Text

To color the background of text the text must be put into a so called “colorbox”.
This requires that the HTEX-package color is loaded in the document preamble with
the command

\ @ifundefined{textcolor}
{\usepackage{color}}{}

The package color will be loaded automatically by Iy X when you color text.*
Colorboxes are created with the command \colorbox. This will be used with the
following scheme:

\colorbox{color}{box content}

The box content can also be a box and colorboxes can also be within other boxes.

The following colors are predefined:
black, blue, cyan, green, magenta, red, white, and yellow.
You can also define your own color as described in section 2.11.

To have e. g. a red background for a word, insert the command
\colorbox{red }{

before the word in TEX-Code. After the word insert a closing brace “}” in TEX-Code.
This is the result:

This is a line where the word _ has a red background.

If you would like the box frame in a different color, you can use the command \fcol-
orbox with the following scheme:

\fcolorbox{frame color}{box color}{box content}

\fcolorbox is an extension to \colorbox. The frame thickness and the space be-
tween the frame and the box content can be adjusted with the lengths \fboxrule
and \fboxsep, respectively, as described in section 5.2.3.

For the following example the command
\fcolorbox{cyan}{magenta}{
was used.

Here is an example where the frame line thickness was set to 1 mm:

4To avoid it being loaded twice the command \ @ifundefined is used.
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Of course you can also have colored text inside a colorbox:

This is colored text within a colored, framed box.

Note: Text in colorboxes cannot have line breaks. To color multiple text lines or
paragraphs, use a box inside a colorbox as described in the following.

5.7.2. Color for Paragraphs

To set the background color for more than one text line, put the text into a minipage.
Before the minipage insert the \colorbox command

\colorbox{color }{
in TEX-Code. After the minipage insert a closing brace “}” in TEX-Code.
This is text with background color. This is text with background color.

The text can have footnotes® and can include tables and figures.

a ! 3
b2’7|
1 § €

%Another example footnote

5.8. Rotated and Scaled Boxes

To use the commands described in this section, the I¥TEX-package graphicx needs
to be loaded in the document preamble with the command

\ @ifundefined{rotatebox}
{\usepackage{graphicx}}{}

Note: Some DVI-viewers can’t display rotated or scaled material.

Note: Floats mustn’t be inside a rotated or scaled box.

5.8.1. Rotated Boxes

To rotate material, you can put it into a rotated box. Such a box is created using
the command \rotatebox in TEX-Code with the following scheme:
\rotatebox|[rotation origin|{rotation angle}{box content}

The rotation origin is specified in the form origin=position. The following positions
are possible: ¢ (center), [ (left), r (right), b (bottom), ¢ (top), along with meaningful
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5.8. Rotated and Scaled Boxes

combinations of the four base positions. For example It means that the rotation
origin is at the top left corner of the box. When no rotation origin is specified, the
position [ will be used. The rotation angle is a number that can be negative that
specifies the angle in degrees. The rotation direction is counterclockwise.

In the following example the command \rotatebox|origin=c]{60}{ was inserted
as TEX-Code before the text “with rotated”; after the text the box was closed by a
closing brace } in TEX-Code.

This is a line

The box content can also be another box or an inline formula:

D

i

S
This is a line framed text \YV and a formula.

or an image or table:

This is a line

with a rotated image and table.

5.8.2. Scaled Boxes

To scale material the commands \scalebox and \resizebox can be used as TEX-
Code.

\scalebox is used with the following scheme:
\scalebox{horizontal}|vertical]{box content}

Horizontal and vertical are the corresponding scaling factors. If no vertical scaling
factor is given, the horizontal factor will also be used as the vertical one.

The command \scalebox{2}{Hello} creates for example a double size HGHO,
compared with the document text size.
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\scalebox{2}[1]{Hello} on the other hand distorts the Hello.

If the scaling factor is negative, the box content will be mirrored. Therefore the
command \scalebox{-1}[1]{Hello} can be used to create mirror writing: ollsH
\scalebox{1}[-1]{Hello} reflects the el at the base line.

Equivalent to \scalebox{-1}[1]{box content} there exists the command
\reflectbox{box content}.

The command \resizebox is used to scale the box to a defined width and height.
The command scheme is:

\resizebox{width}{height}{box content}

If one of the two command arguments given is an exclamation mark !, the size is set
so that the aspect ratio of the box content is kept.

The command \resizebox{2cm}{lcm}{Hello} produces: HeHO
The command \resizebox{2cm}{!}{Hello} produces: HeHO

Note: When arguments of \scalebox or \resizebox are set to zero, no ¥XTgX-errors
occur when exporting the document but the exported files can not or only partly be
displayed.

The boxes can be combined in any order. E. g. the command

\rotatebox|origin=c|{-45}{\resizebox{2cm}{!}{\reflectbox{Hello} } }
produces:

O
%,

Images, tables, and inline formulas are allowed as box content:

o,
6& %,

When the global formula style fleqn is used in the document®, display style formulas
can also be scaled.

SWhen “fleqn” is added to the document class options.
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6. Objects Surrounded by Text

6.1. Wrap Floats

This float type is used if you want to wrap text around
a figure or table so that it only occupies some fraction
of the column width. It can be inserted using the menu
Insert > Floats> Figure Wrap Float or Table Wrap Float
if the M TEX-package wrapfig is installed.! The set-
tings of the float can be modified by right-clicking on
the float box. The mandatory settings are the float
Placement and its Width. Optional are the Overhang
that specifies how much the float is set into the para-
graph / page margin, and the Line span that specifies
how many text lines the float will approximately need. The line span is often hard
to approximate; so it is better only to use it when you encounter float placement
problems. You can furthermore decide if IXTEX is allowed to let the float float within
the paragraph or to surrounding paragraphs. Figure 6.1 is an example text wrap
float with a width of 40 col%, 1 cm overhang, set to the left.

Figure 6.1.: This is a figure wrap
float.

Note: Text wrap float floats are fragile! E. g. having a figure too close to the bottom
of the page can mess things up in such a way that the float does not appear in the
output or that it is placed over some other text.

In general, the following applies for wrap floats:

e They should not be placed in paragraphs that run over a page break. That
means that wrap floats are better inserted in their exact place when the doc-
ument is almost finished and you are able to estimate where page breaks will
appear.

o They should either be placed in their own paragraph before the paragraph
where they should wrap into or within a paragraph.

o In consecutive paragraphs they may cause troubles, so ensure that there is a
text paragraph between them as separator.

o They are not allowed in section headings or tables.

o Their numbering and referencing works as described in chap. 3.

nstalling a WIEX-package is explained it in the ATEX Configuration manual.
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6. Objects Surrounded by Text
6.2. Surrounded Fixed Objects

The wrap floats described in sec. 6.1 have these positions in the paragraph:

BB text text B

or
text text text text

To get an object exactly at the position where it is inserted, for example to get one
of these positions:

text text || text text || text EB& text || text text text
B text || text B || text text text || text B  text

text text text text text text text

B text || text BA  text || text E&
text text || text text text || text text

you can use the BTEX-package picinpar. Here is an example:

It was in the spring of the year 1894 that all London was interested, and the fashion-
able world dismayed, by the murder of the Honourable Ronald Adair under most un-
usual and inexplicable cir- TN cumstances. The public
has already learned those . particulars of the crime
which? came out in the police investigation, but a
good deal was suppressed upon that occasion, since

the case for the prosecu-

tion was so overwhelm-
ingly strong that it was not necessary to bring forward all the facts. Only now, at the
end of nearly ten years, am I allowed to supply those missing links which make up the
whole of that remarkable chain.

Surrounded fixed objects are used to let text float around them, at which the object’s
position in the paragraph can be determined by the number of lines above it. In
contrary to floats is it not possible to have a numbered caption.

A fixed object is inserted by adding the command
\begin{window}[2,c,{

as TEX-Code at the beginning of the paragraph. The first parameter in the bracket,
here '2’, defines the number of lines above the object, the second, here ’c’, the position
of the object. The positions 'l ’c¢’ and "1’ (for left, center, right) are possible. Behind
the command you insert the object. In this example an image with a width of 40 %

2Footnote of the paragraph with the fixed object.
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6.3. Initials

of the text column width was inserted. The object can also be a table, a box or an
equation. Behind the object the command

},description text]
{

is inserted. Note that the “{}” is in the second line. The description text is optional.
The text surrounding the object must be in the same paragraph as the object, so it
must begin directly after the {}. At the end of the paragraph insert the command:

\end{window }

Within a paragraph with a fixed object, you cannot insert footnotes in the normal
way. You have to use instead the command \footnotemark inside the paragraph
and outside the command \footnotetext as described in sec. 4.2.

6.3. Initials

To use initials, you must have the IXTpX-package lettrine installed and use the
module Initials in your document (menu Document> Settings>Modules). To insert an
initial, use the style Initial. This style has a mandatory and an optional argument.
The mandatory argument is inserted via the menu Insert > Short Title and contains the
letter that is the initial. To use also the optional argument, insert another argument
in front of the mandatory argument. This one contains parameters to modify the
initial. For more information about the possible parameters see the documentation
of lettrine, [13]. The style itself contains the text that is surrounding the initial.
The usual style is hereby that the word whose first letter is the initial, is printed with
SMALL CAPS. To tell BTEX where this word is finished, add a closing brace '}’ as
TEX-Code behind it. At the end of the style there must be an opening brace '{’ as

TEX-Code.

Here are some examples:

1. No optional argument, the initial is the letter "I’ in the math font Frattur:

/~T was in the spring of the year 1894 that all London was interested, and
J the fashionable world dismayed, by the murder of the Honourable Ronald
Adair under most unusual and inexplicable circumstances. The public has
already learned those particulars of the crime which came out in the police
investigation, but a good deal was suppressed upon that occasion, since the
case for the prosecution was so overwhelmingly strong that it was not necessary
to bring forward all the facts.
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2. Only one line is surrounding the initial, which is formed by two letters in
standard font and no text is printed in small caps:

It was in the spring of the year 1894 that all London was interested, and the
fashionable world dismayed, by the murder of the Honourable Ronald Adair
under most unusual and inexplicable circumstances. The public has already
learned those particulars of the crime which came out in the police investigation,
but a good deal was suppressed upon that occasion, since the case for the
prosecution was so overwhelmingly strong that it was not necessary to bring
forward all the facts.

3. Magenta, hanging initial over 3 lines in the math font CALLIGRAPHIC,
the text “t was in the spring” is in SMALL CAPS; to color the initial, you must
insert this command before the initial:

\renewcommand{\ LettrineFontHook } {\ color{color}}
where the second color can be “red”, “blue”, “green”, “yellow”, “cyan”, “ma-
genta”, “black” or “white”, and add this command to the document preamble:

\ @ifundefined{textcolor}
{\usepackage{color}}{}

T WAS IN THE SPRING of the year 1894 that all London was interested,
and the fashionable world dismayed, by the murder of the Honourable
Ronald Adair under most unusual and inexplicable circumstances. The

public has already learned those particulars of the crime which came out in
the police investigation, but a good deal was suppressed upon that occasion,
since the case for the prosecution was so overwhelmingly strong that it was not
necessary to bring forward all the facts.
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7. External Document Parts

With the menu Insert> File you can insert external material into your document. This
can be:

LyX Document Another IyyX document; its content is directly inserted to your doc-
ument.

Plain Text A text document; each line is inserted in your document as a separate
paragraph.

Plain Text, Join Lines A text document; text lines are inserted in your document
continuously but an empty text line creates a new paragraph.

External Material Files in various formats.

Child Document [yX or KTEX-documents.

7.1. External Material

The external material feature allows you to insert files into your document without
converting them to a format that can be read by the document output format. LyX
takes care of the necessary conversions. This is similar to images that can be inserted
in various image formats in Iy’X documents. When you have enabled Instant Preview
in IyX’s preferences under Look and feel> Graphics, the external material types Dia
and Xfig are directly shown in LyX.

External material can be inserted via the External Material dialog that is accessi-
ble with the menu Insert> File> External Material. Currently the following file types
(Templates) are allowed:

ChessDiagram This template supports chess position diagrams made with the pro-
gram XBoard.

Date This inserts the date in the form Day-Month-Year. This is a date inserted as
external material: 12-02-2012

The date is not shown within [yX, only in the output. There are two other
methods of inserting a date: Via menu Insert>Date and with the IXTEX com-
mand \today as TEX-Code. The different methods are compared in Table 7.1.

Dia This template supports diagrams created with the program Dia.
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7. External Document Parts

GnumericSpreadsheet With this template you can insert spreadsheets /tables in

the format of Gnumeric, OpenDocument, Microsoft Office XML and Office
Open XML. For this feature LyX must have found the program ssconvert
during its configuration. This program is part of Gnumeric, so that you must
have Gnumeric installed, also if you don’t have tables in the Gnumeric for-
mat. For examples and possible limitations have a look at LyX’s example file
spreadsheet.lyzx.

LilyPond This template is used for music notation typeset with the program

LilyPond. For LyX’s extended support for LilyPond have a look at LyX’s
example file lilypond.lyzx.

PDFPages With this template you can insert PDF documents to your document.
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To specify the range of pages that should be included, use the option pages
in the Option field in the KTEX and LyX options tab. The argument of this
option is a comma separated list, containing page numbers (insert as option
pages={3,5,6,8}), ranges of page numbers (pages={4-9}) or any combina-
tion. To insert empty pages use {}. E.g. pages={3,{},8-11,15} will insert
page 3, an empty page, and pages 8, 9, 10, 11 and 15. Page ranges are specified
in the syntax start-stop. This selects all pages from start to stop. Omitting
start defaults to the first page; omitting stop defaults to the last page of the
document. The last page can also be selected with the keyword last. (This
is only permitted in a page range.) So pages=- will insert all pages of the
document and pages=last-1 will insert all pages in reverse order. If the pages
option is not specified, only the first page of the PDF is inserted.

The option noautoscale inserts the pages with their original size, if this option
is not given, the pages will be resized to fith the width of the page of your doc-
ument. In the tab Size and Rotation you can specify the width and height of the
input pages and their rotation. If another width than 100 Scale% is used, the
option noautoscale will be overwritten. For more info and possible options,
have a look into the documentation of the KTEX-package pdfpages [16].

To use this template in a Beamer presentation you need to first insert an End-
Frame environment and in a subsequent paragraph a TEX-Code box contain-
ing the command \setbeamertemplate{background canvas}{}. Then you
can insert as many paragraphs containing the PDFPages template as you wish.
Behind the included PDF pages you can resume the Beamer presentation by
beginning a new frame or by starting a new section. To avoid stray blank pages
prior to the PDF pages, make sure to use the Default alignment for the para-
graph containing the template.

Here is an included PDF which is rotated by -5°:


http://en.wikipedia.org/wiki/Gnumeric
http://en.wikipedia.org/wiki/OpenDocument
http://en.wikipedia.org/wiki/Microsoft_Office_XML_formats
http://en.wikipedia.org/wiki/Office_Open_XML
http://en.wikipedia.org/wiki/Office_Open_XML
http://en.wikipedia.org/wiki/LilyPond

font size than the other
baragraph types.

Also Several baragraphg are possible in the
abstract,

This is a “Standarq” baragraph tq Visualize the differ-
€nces in the font Size.



7. External Document Parts

Rasterlmage This can be used for bitmap images. The image can be treated in the
External material dialog like the images that are usually included via the Graphics
dialog as described in section 1.1. The difference to the normal image input is
that only raster images are allowed; that means that PDF and EPS-images are

Skandard
not supported. Here is an inserted raster image:

XFig This template supports images created with the program Xfig.

Table 7.1.: Comparison of the date input methods.

Document format | External Material>Date | Insert>Date command \today
LyX as inset box as date as TEX-Code inset box
ETEX as date as date as command
DVI, PDF, PS as date as date as date

When you use the option Draft in the File tab of the External Material dialog, only
the path to the inserted file is shown in the output.

External material is displayed in Iy X either as a box like this: 2 CaiEkn or as

image, depending on the option Show in LyX in the ATEX and LyX options tab of the
dialog.

The Customization manual explains how you can define your own templates.

7.2. Child Documents

Child documents are used if you have a long document consisting of several larger
parts or sections. For maintenance it is often useful and sometimes even required
to split the document into several files that can be revised separately. The different
documents are then the so called “child documents”, and a master document connects
them to print the full document or parts of it. A child document inherits elements
from its master, for example the IXTEX preamble, the bibliography, and labels for
cross-references.

To be able to work on child documents without the need to open their master, specify
in the child document the master in the menu Document > Settings > Document Class.
This master document will then be used in the background by LyX when you edit
the child document.

Included documents are displayed in Iy X as a box like this: e e
To include child documents in a master document use the menu Insert > File > Child Doc-
uments. A dialog pops up where you can choose between four include methods:
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7.2. Child Documents

Include You can include IxyX- and I¥TEX-documents. When you press the Edit but-
ton in the Child Document dialog, the included document will be opened in IyX
in a new file tab so that you can modify it.

Here is a child document inserted using Include:
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7. External Document Parts

7.2.1. External Subsection 1

This is a small dummy child document to show how files can be inserted into another

document.
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7.2. Child Documents

The section numbering includes the sections of the included files in the order they are
inserted in the master document. The included example document has for example
a subsection that is numbered as a subsection of this section. Labels of included
documents can be referenced: Subsection 7.2.1.

The preamble of the child document is ignored; only the preamble of the master doc-
ument is used. Branches in child documents will be ignored by the master document
when the master document does not have a branch with the same name. Included
documents are inserted starting on a new page and ending with a page break.

Note: If you have included a IyX- or IXTEX-file, you are warned when you ex-
port/view the document in case the child document uses another document class
than the master document as this will lead to unexpected outputs.

Input This method is very similar to the Include method. The differences are:

o Input files don’t start with a new page and don’t end with a page break.

o Input files can be previewed in IyX when Instant Preview is enabled in
LyX’s preferences under Look and feel > Graphics.

e You cannot exclude Input files via the menu Document > Settingst Child
Documents.

Here is a child document inserted using Input:

7.2.2. External Subsection 2

This is another small dummy child document to show how files can be inserted into
a document.

Verbatim With this method any text file can be included. The file is shown in the
output with its source code; no command used in the text is invoked. You can
use the option Mark spaces in output that displays the character “” for every
space character in the source code. The difference from the method via the
menu Insert > File> Plain Text is that the document content is not shown in IyX.

Here is a child document inserted as Verbatim:

This is a small dummy child text document to show how files can be inserted into a do«

Here is a child document inserted as Verbatim using the Mark spaces in output option:

Thisisyasmall dummy, ,child text document, ,to show how files ,can be inserted into a doc

Note: As you can see in the examples above, the text of the documents included as
verbatim is not broken at the end of the document lines.
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Listings This type is described in chapter 8.

Note: Including the same document twice in a document using different methods
could cause BKTEX-problems.

If you want to view/export only selected children of your master document, either
because you want to save compiling time or because you want to distribute single
chapters of the book you are just writing, you can exclude children from the output.
This is done via the menu Documentt>Settings> Child Documents. You can exclude/
include children by double-clicking on the include to output column of the respective
child document in the list (note that this only works for documents embedded via
“Include”; not with “Input”). If the option Maintain counters and references is enabled,
LyX will assure that all page numbers, references etc. are correct as if the whole
document was processed. This is useful if you want the selected sub-documents to
look exactly as in the context of the whole document. However, LyX needs to process
the whole document in the background for this feature. So if you want to save compile
time and if counters and references do not need to be correct, disable this checkbox.

Alternatively, you can put each included file into a branch.! By enabling/disabling
branches you can decide which included files will appear in the output. This has the
advantage that it also works with Input’ed sub-documents. However, counters and
references will not be maintained with this approach.

IBranches are described in section Branches of the Iy X Userguide.
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8. Program Code Listings

To include and typeset program code you can use the Listings inset that can be
inserted via the menu Insert>Program Listing. The IXTEX-package listings provides
a powerful and flexible way to insert program source code into your document.

Right-clicking on a listings inset opens the context menu containing where you can
set the listings format.

By default, a listing starts a new paragraph in the output. The placement option
Inline listing prints the listing inline like this: int a=>5;

The option Float creates a listings float where you can specify the placement options
“h” “t”) “b” and “p” corresponding to the float placement options described in
section 3.5. The placement options can be mixed and are inserted without any
separation, e.g. “htbp”. The option “h” has sometimes no effect, but you don’t need
to use the Float option in this case as also non-float listings can have captions and
be referenced.

You can add captions to listings with the menu Insert>Caption. Listings can be
referenced like floats: Listing 8.1

Listing 8.1: Example Listing float

# Example listing float

def func (param):
"this is_a_ python function
pass

Y

When you have set a programming language in the listings dialog, the keywords of
this language will be recognized and specially typeset in the output. In the example
listings the Python keyword “det” is recognized and printed bold in the output.

Note: If you don’t get bold keywords when using typewriter fonts, your typewriter
font probably doesn’t provide a bold shape. In this case select a different one in
the menu Document > Settingst> Fonts. (The fonts LuziMono, BeraMono and Courier
provide bold shapes.)

In section Line numbering of the listings dialog you can specify the line numbering
style. You can insert a number to specify which lines are numbered in the field Step.
When you insert e. g. “3”, only every 3rd line will be numbered.

You can furthermore specify a range of lines; only these will then appear in the
output. The option Extended character table should be used when you use national
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characters like the German umlauts in the listing.
Here is an example listing with left line numbering, step “3”, language “Python”,
options “Extended character table” and “Space as symbol”, range lines 3-8:

Lo pass

def func (param):

"This, isa ,German ,word: Tschiufl’
pass

def func (param):

"this, is a python function’

When you have tabulators in your listing, you can specify the number of characters
that are spanned by a tabulator in the field Tabulator size.

Note: Due to a bug in the listings package the line numbering is shifted by a line
by every previous listing. That’s the reason why the lines 2 and 5 are numbered in
the above listing and not the lines 3 and 6.

It is also possible to print lines from a file as listing. To do this, use the menu Insert >
File Child Document and choose the type Listings.! In the child document dialog
you can specify the listing parameters in a text box. To show a list of all available
parameters, type in a question mark “?” in the text box.

To reference child document listings, write a label text into the corresponding field of
the child document dialog. The label can then be referenced using the menu Insert >
Cross-Reference.

Listing 8.2 is an example for a listing of a file; there the lines 10- 15 of this [yX file
are listed.

Listing 8.2: Lines 10 - 15 of this LyX file

% set fonts for nicer pdf view
\IfFileExists{lmodern.sty}
{\usepackage{lmodern}}{}

\fi % end if pdflatex is wused

Inserting a formula into a listing can be done the following way:

1. Open the listings dialog and add
mathescape=true
to the field of the Advanced tab.

2. Create a formula outside the listing

!The other child document types are described in section 7.2.
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3. Copy the content of the formula (not the formula inset) to the clipboard (short-
cut Ctrl+C)

4. In the listing write “$$” and copy from the clipboard between the dollar-signs
(shortcut Ctrl+V)

Listing 8.3: Example Listing float containing a formula

# Fxample listing float
def func (param):

1
# s 32

pass

Global listings settings can be set in the Document > Settings > Listings dialog. To get
there a list of available options, type in a question mark “7”.

For more information about the listings package, we refer to its documentation [14].
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A. Units available in LyX

To understand the units described in this documentation, Table A.1 explains all units
available in IyX.

Table A.1.: Units

unit name/description
mm millimeter
cm centimeter
in inch
pt point (72.27pt = 1in)
pc pica (1pc = 12pt)
sp scaled point (65536sp = 1pt)
bp big point (72bp = 1in)
dd didot (1dd = 0.376 mm)
cc cicero (1cc = 12dd)
Scale% % of original image width
text% % of text width
col% % of column width
page% % of paper width
line% % of line width
theight% % of text height
pheight% % of paper height
ex height of letter x in current font
em width of letter M in current font
mu math unit (1 mu = 1/18em)
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B. Output File Formats with
Graphics

B.1. DVI

This file type has the extension “.dvi”. It is called “device-independent” (DVI),
because it is completely portable; you can move them from one machine to another
without needing to do any sort of conversion. At the time when this file-format was
developed, this was no matter of course. DVIs are used for quick previews and as
pre-stage for other output formats, like PostScript.

Note: DVI-files do not contain images; they will only be a linked. So don’t forget
this, if you move your .dvi file to another computer. This property can also slow
down your computer when you view the DVI, because the DVI-viewer has to convert
the image in the background to make it visible when you scroll in the DVI. So it is
recommended that you use PDF for files with many images.

You can export your document to DVI by using the menu File> Export>DVI. You can
view your document as DVI via the View menu.

B.2. PostScript

4

This file type has the extension “.ps”. PostScript was developed by the company
Adobe as a printer language. The file therefore contains commands that the printer
uses to print the file. PostScript can be seen as a “programming language”; you can
calculate with it and draw diagrams and images!. Due to this ability, the files are
often bigger than PDFs.

PostScript can only contain images in the format “Encapsulated PostScript” (EPS,
file extension “.eps”). As LyX allows you to use any known image format in your
document, it has to convert images in the background to EPS. If you have e.g. 50 im-
ages in your document, [xX has to do 50 conversions whenever you view or export
your document. This will slow down your work flow with IyX drastically. So if
you plan to use PostScript, you can insert your images directly as EPS to avoid this
problem.

'Tf you are interested to learn more about this, have a look at the INTgX-package PSTricks [18].
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You can export your document to PostScript using the menu File > Export > Postscript.
You can view your document as PostScript via the View menu or by using the toolbar

button I:G

B.3. PDF

This file type has the extension “.pdf”. The “Portable Document Format” (PDF)
was developed by Adobe as a derivative of PostScript. It is more compressed and it
uses fewer commands than PostScript. As the name “portable” implies, it can be
processed at any computer system and the printed output looks exactly the same.

PDF can contain images in its own PDF format, in the format “Joint Photographic
Experts Group” (JPG, file extension “. jpg” or “. jpeg”), and in the format “Portable
Network Graphics” (PNG, file extension “.png”). Nevertheless you can use any other
image format, because IyX converts them in the background to one of these formats.
But as described in the section about PostScript, the image conversion will slow
down your work flow. So it is recommended that you use images in one of the three
mentioned formats.

You can export your document to PDF via the menu Filer> Export in three different
ways:

PDF (ps2pdf) This uses the program ps2pdf that creates a PDF from a PostScript-
version of your file. The PostScript-version is produced by the program dvips
which uses a DVI-version as intermediate step. So this export variant consists
of three conversions.

PDF (dvipdfm) This uses the program dvipdfm that converts your file in the back-
ground to DVI and in a second step to PDF.

PDF (pdflatex) This uses the program pdftex that converts your file directly to
PDF.

It is recommended that you use PDF (pdflatex) because pdftex supports all features
of actual PDF-versions, is quick and works stable. The program dvipdfm is not under
development and therefore a bit outdated.

You can view your document as PDF via the View menu or by using the toolbar

button -*‘%} (that uses PDF (pdflatex)).
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C. List of dvips color names

Color name Color name

D Apricot
” BlueViolet
” CadetBlue

D Dandelion

” Fuchsia

” JungleGreen
” Mahogany
B Mulberry
” OrangeRed
” PineGreen

” RawSienna
” RoyalBlue

” Violet

D YellowOrange

- Aquamarine
Bl BrickRed

E| CarnationPink
- DarkOrchid
Goldenrod
Lavender

- Maroon
- NavyBlue
- Orchid

- Plum

- RedOrange
- RoyalPurple
- Sepia

- TealBlue

- VioletRed

Color name
- Bittersweet
- Brown

- Cerulean

- Emerald

- Gray

- LimeGreen

E| Melon

- OliveGreen
E| Peach

- ProcessBlue
B Redviolet
- RubineRed

- SkyBlue
|| Thistle

- WildStrawberry

Color name

- BlueGreen

- BurntOrange
- CornflowerBlue
- ForestGreen
D GreenYellow

- Mahogany
- MidnightBlue

- Orange

- Periwinkle

- Purple

- Rhodamine

E Salmon
D SpringGreen

- Turquoise

E YellowGreen

99






D. Explanation of Equation (2.1)

We can calculate the total width of n table cells Wi as follows:
Wiotn =1 - (Wyp + 2 - \tabcolsep) + (n + 1) - \arrayrulewidth (D.1)

where W,,, is the given width of all cells, \tabcolsep is the ETEX-length between
the cell text and the cell border (its default value is 6 pt). \arrayrulewidth is the
thickness of the cell border line, the default is 0.4 pt.

Following equation (D.1), the total width of a multicolumn Wiug muy is

Wiot mutt = Wymut + 2 - \tabcolsep + 2 - \arrayrulewidth (D.2)

By setting equation (D.1) and (D.2) equal we can calculate the needed given width
W, when n columns are spanned, so that each column has a total width of Wi muie /7

Wymut + (1 —n) - (2 - \tabcolsep + \arrayrulewidth)
n

(D.3)

Wyn =
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Boxes
Alignment, 68
Box Dialog, 67
Color, 75
Customization, 70
Decoration, 69
for Characters, 73
for Vertical Alignment, 74
Introduction, 67
Minipages, 72
Parboxes, 73
Raiseboxes, 74
rotated, 76
scaled, 77
Size, 67
to Prevent Hyphenation, 73

Caption
Formatting, 51
Placement, 53
Color
for Paragraphs, 76
for Table Cells, 31
for Table Lines, 33
for Text, 75

DVI, see File Formats

Endnotes, 62

EPS, see Image formats

External Document Parts, 83
Child Documents, 86
External Material, 83

Figures, 1
Floats, 3

Graphics Dialog, 1
Image Formats, 5
rotated, 1, 76
scaled, 1, 77
Settings grouping, 2
File Formats
DVI, 97
PDF, 98
PostScript, 97
Files
Include, 86
Floats, 43
Algorithms, 43
Caption Formatting, 51
Caption Placement, 53
Figures, 3
Float Lists, 55
Introduction, 43
Listings, 91
Numbering, 44
Placement, 47
References, 45
Rotating, 49
Side by side, 51
Subfloats, 51
Tables, 10
Wrap Floats, 79
Footnotes, 60
Numbering, 61
Placement, 62

GIF, see Image formats
Graphics, see Figures

Image Formats, 5
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Initials, 81
JPG, see Image formats

BTEX-packages

arydshln, 41, 103
booktabs, 30, 103

calc, 24, 27, 34

caption, 10, 15, 16, 52, 103
color, 75

colortbl, 31, 42
diagbox, 103

endfloat, 49, 103
fancybox, 70

footmisc, 64, 103
ftnright, 62

graphicx, 76

hypcap, 47, 55
hyperref, 14, 46, 47, 103
KOMA-Script, 52, 53, 64, 103
lettrine, 81, 103
listings, 91, 103
marginnote, 65, 103
oberdiek, 47

pdfpages, 84, 103
picinpar, 25, 80
prettyref, 46, 103
PSTricks, 103

refstyle, 46, 103
sidecap, 53, 103
wrapfig, 79

Listings, 91
Longtables, 10

Alignment, 13

Calculation, 18

Caption Width, 15

Captions, 14

Different Captions for Pages, 16
Floats, 18

Footnotes, 13

Forced Page Breaks, 18
References, 14

Multicolumns, 22

Calculations, 23
Multiple Lines in Table Cells, 22
Multirows, 24

Notes
Footnotes, 60
LyX Notes, 59
Margin Notes, 64

PDF, 5, 98

PNG, see Image formats
PostScript, see File Formats
Program Code, 91

References

Automatic Reference Naming, 46

Formats, 45
Reference Position, 47
to Figures, 3
to Floats, 45
to Tables, 10

Rotated material, 76

Scaled material, 77
Surrounded by text, 79
Fixed objects, 80
Initials, 81
Wrap Floats, 79
SVG, see Image formats

Table, 7
Alignment, 30
Color, 31
Customization, 35
Dialog, 7
Edit Menu, 9
Floats, 10
Formal, 28
Introduction, 7
Linebreaks, 22
Longtables, 10
Multicolumns, 22
Multirows, 24
Toolbar, 8
Width, 7
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Table Color
for Cells, 31
for Lines, 33

Table Customization, 35
Cell/Column Format, 37
Dashed Lines, 41
Line Thickness, 39
Rotating, 76
Row Spacing, 35
Scaling, 77
Special Cell Alignment, 36

Units, 95

107



	Contents
	1 Figures
	1.1 Graphics Dialog
	1.2 Figure Floats
	1.3 Image Formats

	2 Tables
	2.1 Introduction
	2.2 Table Dialog
	2.3 Table Toolbar
	2.4 Edit Table Menu
	2.5 Table Floats
	2.6 Longtables
	2.6.1 Footnotes in Longtables
	2.6.2 Longtable Alignment
	2.6.3 Longtable Captions
	2.6.3.1 References to Longtables
	2.6.3.2 Caption Width
	2.6.3.3 Different Captions for Table Pages


	2.7 Special Longtable Issues
	2.7.1 Longtable Calculation
	2.7.2 Floats and Longtables
	2.7.3 Forced Page Breaks

	2.8 Multiple Lines, Columns and Rows
	2.8.1 Multiple Lines in Table Cells
	2.8.2 Multicolumns
	2.8.2.1 Multicolumn Basics
	2.8.2.2 Multicolumn Calculations

	2.8.3 Multirows
	2.8.4 Cells with diagonal line(s)

	2.9 Formal Tables
	2.10 Vertical Table Alignment
	2.11 Colored Tables
	2.11.1 Colored Cells
	2.11.2 Colored Lines

	2.12 Table Width Calculation
	2.13 Table Customization
	2.13.1 Row Spacing
	2.13.2 Special Cell Alignment
	2.13.3 Customized Cell/Column Format
	2.13.4 Line Thickness
	2.13.5 Dashed Lines


	3 Floats
	3.1 Introduction
	3.2 Float Types
	3.2.1 Algorithm Floats

	3.3 Float Numbering
	3.4 Referencing Floats
	3.4.1 Cross-Reference Formats
	3.4.2 Automatic Reference Naming
	3.4.3 Reference Position

	3.5 Float Placement
	3.6 Rotated Floats
	3.7 Subfloats
	3.8 Floats Side by Side
	3.9 Caption Formatting
	3.10 Caption Placement
	3.11 Listings of Floats

	4 Notes
	4.1 LyX Notes
	4.2 Footnotes
	4.2.1 Footnote Numbering
	4.2.2 Footnote Placement

	4.3 Margin Notes

	5 Boxes
	5.1 Introduction
	5.2 Box Dialog
	5.2.1 Size
	5.2.2 Alignment
	5.2.3 Decoration

	5.3 Box Customization
	5.4 Minipages
	5.5 Parboxes
	5.6 Boxes for Words and Characters
	5.6.1 Prevent Hyphenation
	5.6.2 Vertical Alignment

	5.7 Colored Boxes
	5.7.1 Color for Text
	5.7.2 Color for Paragraphs

	5.8 Rotated and Scaled Boxes
	5.8.1 Rotated Boxes
	5.8.2 Scaled Boxes


	6 Objects Surrounded by Text
	6.1 Wrap Floats
	6.2 Surrounded Fixed Objects
	6.3 Initials

	7 External Document Parts
	7.1 External Material
	7.2 Child Documents
	7.2.1 External Subsection 1
	7.2.2 External Subsection 2


	8 Program Code Listings
	A Units available in LyX
	B Output File Formats with Graphics
	B.1 DVI
	B.2 PostScript
	B.3 PDF

	C List of dvips color names
	D Explanation of Equation (2.1)
	Bibliography
	Index

