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1. Getting Started

1.1. What is LyX?

[yX is a document preparation system. It is a tool for producing beautiful manuscripts,
publishable books, business letters and proposals, and even poetry. It is unlike most
other “word processors” in the sense that it uses the paradigm of a markup language
as its core editing style. That means that when you type a section header, you mark
it as a “Section”, not “Bold, 17 pt type, left justified, 5 mm space below”. LyX takes
care of the typesetting for you, so you deal only with concepts, not the mechanics.

This philosophy is explained in much greater detail in the “Introduction”. If you
haven’t read it yet, you need to. Yes, we mean now.

The “Introduction” describes several things in addition to LyX’s philosophy: most
importantly, the format of all of the manuals. If you don’t read it, you’ll have a bear
of a time navigating this manual. You might also be better served looking in one of
the other manuals instead of this one. “Introduction” describes that, too.

1.2. How LyX Looks

Like most applications, IryyX has the familiar menu bar across the top of its window.
Below it is a toolbar with a pulldown box and various buttons. There is, of course, a
vertical scrollbar and a main work area for editing documents.

Note that there is no horizontal scrollbar. This is not a bug or an oversight, but
intentional. When you read a book, you expect the end of a line to wrap around to
the next line. Text overflows onto new pages in a vertical fashion, hence the need for
only a vertical scrollbar. There are three cases where you might want a horizontal
scrollbar. The first case is large figures, displayed WYSIWYG. This, however, is due
to a flaw in the routine that displays graphics on the IyX screen in a WYSIWYG
fashion; it should rescale the graphics to fit in the window, just as you’d need to rescale
graphics to fit on a page. The second and third cases are tables and equations which
are wider than the IyX window. You can use the arrow keys to scroll horizontally
through the table, but this doesn’t work for equations yet.

For a brief description of all IxX menus and toolbar buttons, have a look at Ap-
pendix A. Most of them are self-explanatory and you’ll find them listed in the corre-
sponding sections of this documentation.
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1.3. HELP

The help system consists of the I)yX manuals. You can read all of the manuals from
inside IyX. Just select the manual you want read from the Help menu.

1.4. Basic LyX Setup

There are several features of IiyX that can be configured from inside LyX, without
resorting to configuration files. First, IiyX is able to inspect your system to see what
programs, IXTEX document classes and KIEX packages are available. It uses this
knowledge to give reasonable defaults to several Preferences settings. Although this
configuration has already been done when [yX was installed on your system, you
might have some items that you installed locally, e. g. new IXTEX classes, and which
are not seen by LyX. To force LyX to re-inspect your system, you should use Tools>
Reconfigure. You should then restart [y X to ensure that the changes are taken into
account.

1.5. BTEX Setup

LyX needs several KIEX packages to work properly. The packages found on the
system by IyX are listed in the file LaTeX Configuration that will be created when
using the menu Helpr>LaTeX Configuration. You should install the required missing
packages and then reconfigure LyX.
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2.1. Basic File Operations

Under the File menu and in the standard toolbar are basic operations for any word
processor in addition to some more advanced operations:

o New _.E

e New from_Template

e Open 5

¢ Close

e Save E

o Save As

e Revert to saved
« Version Control
e Import

o Export

e Print Cﬁ

o Exit

They all do pretty much the same thing as in other word processors, with a few minor
differences. The File>New from_Template command not only prompts you for a name
for the new file, but also prompts you for a template to use. Selecting a template
will automatically set certain layout features for the document, features you would
otherwise need to change manually. They can be of use for certain classes, especially
those for writing letters (see section 3.1.2).

Note: There is no “default file” or document named “Untitled” or “scratch.” Unless
you tell LyX to open a file or create a new one, that big, blank space is just that —
a big, blank space.
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Revert to saved and Version Control are useful if more people work on the same
document at the same time!. Revert to saved will reload the document from disk.
You can of course also use it if you regret that you changed a document and want to
restore it to the last save. With Version Control you can there register the changes
you made to a document so that others can identify them as your changes.

2.2. Basic Editing Features

Like most modern word processors, Iy X can perform cut and paste operations on
blocks of text, can move by character, word, or page of text, and can delete whole
words as well as individual characters. The next four sections cover the basic IyX
editing features and how to access them. We'll start with cut and paste.

As you might expect, the Edit menu and the standard toolbar has the cut and paste
commands, along with various other editing features. Some of these are special and
covered in later sections. The basic ones are:

o Cut %
Copy

o

Paste P%

« Paste Recent

Paste Special

i.
« Find & Replace %

The first three are self-explanatory. One thing to note: whenever you delete a block
of text that you've selected, it’s automatically placed in the clipboard. That is, the
Delete and Backspace keys also functions as the Cut command. Also, if you’ve selected
text, be careful: If you hit a key, LyX will completely delete the selected text and
replace it with what you just typed. You'll have to do an Undo to get back the lost
text.

You can also copy text between LyX and other programs by cut, copy and paste.
The submenu of Paste Recent shows you a list with the last strings you have pasted.

The menu Edit>Paste Special>Plain Text, Join Lines will insert the text in the
clipboard so that the whole text is inserted as one paragraph. A new paragraph is
started when there is a blank line in the file. Without Join Lines, the text is inserted
as Paragraphs, where the line breaks of the text will start a new paragraph.

The Edit>Find & Replace item opens the Find and Replace dialog. Once you have
found a word or expression, IyX selects it. Hitting the Replace button replaces the

'Tf you plan to do this, you should check out the Version Control feature in Iy’X also. Read
Additional Features.
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selected text with the contents of the Replace with field. You can click the Find Next
button to skip the current word. Hit Replace All to replace all occurrences of the text
in the document automatically. The Case sensitive option can be used if you want
the search to consider the case of the search word. If the toggle is set, searching for
“Test” will not match the word “test”. The Match whole words only option can be
used to force LyX to only find complete words, i.g., searching for “star” will not
match “starlet”

Things like notes, floats, etc., the so called insets can be dissolved. This means
that the inset is deleted and its content is left as normal text. Dissolving an inset is
done by setting the cursor to the beginning of an inset and pressing Backspace or by
setting the cursor to the end and pressing Delete.

2.3. Undo and Redo

If you make a mistake, you can easily recover from it. LyX has a large-capacity
undo/redo buffer. Select Edit>Undo or the toolbar button [@to undo some mistake.

If you accidentally undo too much, use Edit > Redo or the toolbar button @ to “undo
the undo.” The undo mechanism is currently limited to 100 steps to minimize memory
overhead.

Note that if you revert back all changes to arrive to the document as it was last
saved, the “changed” status of the document is unfortunately not reset. This is a
consequence of the 100 step undo limit, above.

Undo and Redo work on almost everything in IxX. But they won’t undo or redo
text character by character, but by blocks of text.

2.4. Mouse Operations

These are the most basic mouse operations.

1. Motion

o Click the left mouse button once anywhere in the edit window. The cursor
moves to the text under the mouse.

2. Selecting Text

« Hold down the left mouse button and drag the mouse. LiyX marks the text
between the old and new mouse positions. Use Edit> Copy to create a copy
of the text in I X’s buffer (and the clipboard).

e Re-position the cursor and then paste the text back into LyX using Edit>
Paste.

3. Insets (Footnotes, Notes, Floats, etc.)
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Right-click on them to set their properties. Also check the appropriate section
of this manual for more details.

4. Tables

Single click the right mouse button to open a dialog that will allow you to
manipulate the table.

2.5. Navigating
LyX offers you two ways to navigate in documents:

e The menu Navigate lists all sections of the document as submenu entries that
you can click to jump to the corresponding document part.

e The menu Documentt>Outline or the toolbar button @

The outline window shows you the content of the document’s table of contents (TOC)
that is described in section 6.2.1. You can click there on entries to jump to the
corresponding document part. In the pull-down box at the top of the outline window,
you can choose between different lists of document objects, like the list of footnotes.
Some of them, the list of tables, figures, and algorithms can also be added to the
document, see section 6.2.2. The Sort option sorts the current list, and the Keep
option keeps it in the current view state. Keeping means that when you have e.g.
the subsections of section 2 and 4 shown and click on section 3, the subsections of
section 2 and 4 will still be shown. Without the Keep option they will be hidden to
highlight the clicked section 3.

With the buttons _ and _ at the bottom of the outline window you can change
the position of sections in your document. So you can for example move section 2.5
before section 2.4. LyX will then automatically renumber the sections to the new

1,— 1=
order. With the buttons #11and #% or the corresponding key bindings Tab and
Shift-Tab you can change the sectioning level of sections. So you can for example
make section 2.5 to chapter 3 or to subsection 2.4.1.

The toolbar button ﬁ jumps to the position in the document where you recently
changed something. This is for example useful when you have a large document and
navigated or scrolled to another document part to look for something, and want to
go back to your last editing position.

2.6. Input / Word Completion

LyX provides completion of words by scanning all documents that are currently
opened. Every word that appears in these documents is added to a database that is
used to propose completions.



2.7. Basic Key Bindings

By default IyX shows a small triangle behind the cursor as indicator that there are
completions available. You can then press the Tab key to use this completion. When
several completions are possible, a popup is opened showing them. You can select a
completion in the popup using the mouse or the arrow keys, and accept the chosen
completion be pressing Return.

In the preferences dialog, that is opened with the menu Tools> Preferences, the
cursor completion indicator can be turned off in the section Editing> Input Completion
by deselecting the option Cursor indicator. With the option Automatic inline completion
the proposed completion is shown directly behind the cursor position. To accept this
proposal, use the Tab key. With the option Automatic popup the completions are
always shown in a popup. LyX offers some more completion settings for experts that
are described in sec. C.2.4.

2.7. Basic Key Bindings

There are at least two different primary binding maps: CUA and Emacs. LyX’s
default is CUA.

Some keys, like Page Up, Page Down, Left, Right, Up, and Down, do exactly what
you expect them to do. Other keys don’t:

Tab There is no such thing as a tab stop in LyX. If you don’t understand this,
go read sections 3.2.1 and 3.3, especially section 3.3.6, right now. Yes,
right now. If you're still confused, look in the Tutorial.

Esc This is the “cancel key.” It’s used, generically, to cancel operations. Other
parts of the manual will go into greater detail about this.

Home and End These move the cursor, respectively, to the beginning and end of a
line, unless you are using the Emacs bindings where they jump to the
beginning or end of the file.

There are three modifier keys:

Control (Denoted by “Ctrl” in the documentation files) This has a couple of dif-
ferent uses, depending on which keys it’s used in combination with:

o With Backspace or Delete, it deletes an entire word instead of a single
character.

o With Left and Right, it moves by words instead of characters.
o With Home and End, it moves to the beginning and the end of the

document, respectively.

Shift (Denoted by “Shift” in the documentation files) Use this with any of the
motion keys to select the text between the old and new cursor positions.



2. How to work with LyX

Alt (Denoted by “Alt” in the documentation files) This is the Alt key on
many keyboards, unless your keyboard has a distinct Meta key. If you
have both keys, you will need to try out which one actually performs the
Alt+ function. This key does many different things, but it also activates
the menu accelerator keys. If you use this in combination with any of the
underlined letters in a menu or menu item, it selects that menu item.

For example, the sequence “Alt e s ¢” brings up the “Text Style” menu.
Typing “Alt f” opens the File menu.

The Shortcuts manual lists all other things bound to the Alt key.

You'll learn more and more keybindings and short-cut keys as you use LyX, because
most actions will prompt a small message in the status bar at the bottom of LyX’s
main window which describe the name of the action, you've just triggered, and any
existing keybindings for that action. The IyX menus also list the defined keybind-
ings. The notation for the keybindings is very similar to the notation used in this
documentation, so you should not have any problems understanding it. However,
notice that Shift-modifiers are explicitly mentioned, so “Alt+P Shift-A” means Alt+P
followed by a capital A.

You can list or change the keybindings in the menu Tools> Preferences under Edit-
ing>Shortcuts as explained in sec. C.2.2.2.
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3.1. Document Types

3.1.1. Introduction

Before you do anything else, before you ever start writing a document, you need to
decide what type of document you want to edit. Different types of documents use
different types of spacing, headings, numbering schemes, and so on. Additionally,
different documents use different paragraph environments, and format the title of
your document differently.

A document class describes a group of properties common to a particular set of
documents. By setting the document class, you automatically select these properties,
making it easier to create the type of document you want. If you don’t choose a
document class, Iy X picks one for you by default. So it is up to you to change the
class of your document.

Read on for info about the document classes you can choose from IyX, and how
to adjust their properties.

3.1.2. Document Classes

You can select a class using the Document > Settings dialog. Select the class you want
to use, and make any fine tunings of the options you may need.

3.1.2.1. Overview

There are four standard document classes in IyX. They are:
Article for basic articles

Report for basic reports

Book for writing a book

Letter for US-style letters

There are also some non-standard classes, which IyX only uses if you have installed
them. Here are some of the classes; the full list with detailed explanations can be
found in chapter Special Document Classes in the Additional Features manual:

A&A Journal articles in the style and format used in Astronomy & Astrophysics
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AASTeX For submissions to the journals published by the American Astronomical
Society

AMS Layouts for articles and books in the style and format used by the American
Mathematical Society (AMS). There are three article layouts available. The
standard one uses a typical numbering scheme for theorems etc., that prepends
the section number to the number of the result. All result-type statements
(propositions, corollaries, and so on) are sequenced together, but definitions,
examples, and the like have their own sequence. The “sequential numbering”
scheme does not place the section number with each result, but numbers them
throughout the article in a single sequence. Each type of result gets its own
sequence. There is also a layout that dispenses with numbering of statements
altogether.

Beamer Layout for presentations

broadway Layout for writing plays. It is not an existing KWTEX document class, but
a new one which is distributed with LyX.

curriculum vitae classes to create curriculum vitae
Dinbrief Letters in format of the DIN (German industry norm)

dtk Layout for Die TXnische Komédie, the journal of the German TEX user Group
(Dante)

Elsevier Layout for journals of the Elsevier publishing group
Foils Used to make transparencies
g-brief Letters in format of the DIN (German industry norm)

hollywood Used to type spec scripts for the US film industry. It is not an existing
ETEX document class, but a new one which is distributed with LyX.

IEEEtran Layout for the journals published by the Institute of Electrical and Elec-
tronics Engineers (IEEE)

IOP Layout for journals of the Institute of Physics publishing group
Kluwer Layout for journals of the Kluwer publishing group

KOMA-Script a replacement for the standard classes, offers many useful features
like caption formatting, automatic print space calculation etc.

Memoir another replacement for the standard classes

paper Used with the paper ITEX document class

10
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Powerdot Layout for presentations

REVTeX is used to write articles for the publications of the American Physical Soci-
ety (APS), American Institute of Physics (AIP), and Optical Society of America
(OSA). This class is not completely compatible with all IyX features.

Slides Used to make transparencies

SPIE Proceedings Layout for the journals published by The International Society
for Optical Engineering (SPIE)

Springer Layouts for journals of the Springer publishing group

TUGboat Layout for TUGboat, the journal of the international TEX user Group
(TUG)

We won’t go into any detail about how to use these different document classes here.
You can find all the details about the non-standard classes in the Additional Features
manual. Here, we will settle with a list of some of the common properties of all of
the document classes.

3.1.2.2. Modules

Modules load additional features to a document that are not by default available in
the chosen document class. For example you might want to write Braille (embossed
printing) in a document. This is of course not available in any document class, so
you have to load the corresponding module in the Modules section of the Document >
Settings dialog. Highlighting a module in the dialog will bring up a description of the
module.

Note: Some modules require I¥TEX packages that are not always installed by
default. IyX will warn you if you do not have the needed package.

Note also: Some modules require other modules, and some pairs of modules are
incompatible. IyX will advise you about these things.

3.1.2.3. Properties

Each class has a default set of options. Here’s a quick table describing them:

| | Page style | Sides | Columns | Max. sectioning level |

article Plain One One Section
report Plain One One Chapter
book Headings | Two One Chapter
letter Plain One One none

11
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You're probably also wondering what “Max. sectioning level” means. There are
several paragraph environments used to create section headings. Different document
classes allow different types of section headings. Only two use the Chapter heading;
the rest do not and begin instead with the Section heading. Some document classes,
such as the ones for letters, don’t use any section headings. In addition to Chapter
and Section headings, there are also Subsection headings, Subsubsection headings, and
so on. We'll describe these headings fully in section 3.3.4.

3.1.3. Document Layout

The most important properties of documents classes are set in the menu Document >
Settings. There in the Options field under Documents Class, you can enter special
options for your document class in a comma-separated list. This is only necessary if
LyX doesn’t support special options you want to use for your document. To learn
more about your favorite KXIEX-class and its options, you have to read its manual.

The drop box Headings style in the Document > Settings dialog under Page Layout
controls what sorts of headings and page numbers go on a page. You can choose
between the following five options:

Default Use default page style of current class.
Empty No page numbers or headings.
Plain Page numbers only.

Headings Page numbers and either the current chapter or section title and number.
Whether [yX uses the current chapter or the current section depends on
the maximum sectioning level of the class.

Fancy This allows you to create fully customizable headers and footers if you
have the fancyhdr package installed. At the moment, support in LyX is
limited to this setting. To use the full power of this package, you have to
add code to your document preamble. Check the documentation for the
fancyhdr package for more details, [12].

The Separation of paragraphs is described in section 3.2.1.

3.1.4. Paper Size and Orientation

You'll find the following options in the menu Page Layout of the dialog of the Docu-
ment > Settings menu:

Paper Format What size paper to print on. The choices are

o Default

o A3, A4, A5

12
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- B3, B4, B5
o US letter

o US legal

o US executive

¢ Custom

Orientation Two toggle buttons choose whether to print the output as Landscape or
as Portrait.

Two-sided document Adjusts the print space to print both sides of paper. That means
that the print space for odd- and even-numbered pages is different.

3.1.5. Margins

Paper margins are set in the menu Document > Settings.

If you use a KOMA-Script document class, you can use the default settings. Be-
cause KOMA-Script calculates then the printspace automatically by taking the paper
format and the font size into account.

3.1.6. Important Note

If you change a document class, IxX has to convert everything into the new class.
That includes the paragraph environments. Some paragraph environments are stan-
dard; all of the document classes have them; but some classes have special paragraph
environments. If this is the case, and you change the document class, IyX will mark
the paragraphs whose styles it no longer understands as “unknown”. The name of
the style is retained, in case you should want to go back to the old class. But these
paragraphs will be output with no special formatting, so you will either need to create
a new style yourself or else to convert these paragraphs manually to a style present
in your new document class.

3.2. Paragraph Indentation and Separation

3.2.1. Introduction

Before describing all of the various paragraph environments, we’d like to say a word
or two about paragraph indentation.

Everyone seems to have their own convention for separating paragraphs. Most
Americans indent the first line of a paragraph. Others don’t indent but put extra
space between the paragraphs. If you choose indentation for paragraphs the first
paragraph of a section, or after a figure, an equation, a table, a list, etc., is not

13
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indented. Only a paragraph following another paragraph gets indented. Note that
the indentation behavior is different when you use another document language than
English. IXTEX takes care that the indentation follows the rules of the used language.

The space between paragraphs, like the line spacing, the space between headings
and text — in fact, all of the spacings for just about everything are pre-coded into
LyX. As we said, you don’t worry about how much space to add between what. LyX
takes care of that. In fact, these pre-coded vertical spacings aren’t a single number
but a range. That way, [yyX can squish or stretch the space between lines to make
sure figures fit on a page with text, so that sections don’t start at the bottom of a
page, and so on.? However, pre-coded doesn’t mean you can’t change them. IyX
gives you the ability to globally change all of these pre-coded spacings. We’ll explain
more later.

3.2.2. Paragraph Separation

To separate paragraphs, select Indent or Skip in the submenu Text Layout of the dialog
Document > Settings to indent paragraphs or add extra space between paragraphs,
respectively. The size of the skips can be defined in the dialog, for the indentation
you have to add this line to your document preamble:

\setlength{\parindent }{Length}

where length is a value in one of the units listed in Appendix D.1. The default
length is 30 pt.

3.2.3. Fine-Tuning

You can also change the separation method of a single paragraph. Open the Edit>
Paragraph Settings dialog and toggle the Indent Paragraph option to change the state
of the current paragraph (shortcut Alt+A 1). If paragraphs have no indentation but
use extra space for separation, this button will be ignored (you can’t indent a single
paragraph by toggling this).

You should only need to change the indentation method for a single paragraph if
you need to do some fine-tuning.

3.2.4. Line Spacing

In the Document > Settings dialog you can set the line spacing in the submenu Text Lay-
out.?

ATEX does this when LyX goes to produce a printable file.
2You need to have the INTEX-package setspace installed to use this feature.
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3.3. Paragraph Environments

3.3.1. Overview

Paragraph environments correspond to the

\begin{ environment} ... \end{environment}
command sequence in IXTEX files. If you don’t know IXTEX, or the concept of a
paragraph environment is totally alien to you, we urge you to read the Tutorial. The
Tutorial also contains many more examples than this section does.

A paragraph environment is simply a “container” for a paragraph which gives that
paragraph certain properties. This can include a particular style of font, different
margins, a numbering scheme, labels, and so on. Additionally, you can “nest” the
different environments inside one another, allowing one environment to inherit some
of the properties of another. The different paragraph environments totally replace
the need for messy tab stops, on the fly margin adjustment, and other hold-overs
from the days of typewriters. There are several paragraph environments which are
specific to a particular document type. We'll only be covering the most common ones

here.

. * |standard
To choose a new paragraph environment, use the pull-down box - at

the left end of the toolbar. LyX will change the environment of the entire paragraph
in which the cursor sits. You can also change the environment of an entire group of
paragraphs if you select them before choosing the new environment.

Note that hitting Return will typically create a new paragraph using the Standard
paragraph environment. We say “typically” because if you are in one of these envi-
ronments:

¢ Quote

¢ Quotation
o Verse

o ltemize

o Enumerate
o Description
o List

LyX keeps the old paragraph environment when you hit Return, rather than resetting
it to Standard. LyX will still reset the nesting depth, however. Usually, starting a new
paragraph resets both the paragraph environment and the nesting depth (for more
on nesting see section 3.4). At the moment, all this is context-specific; you're better
off expecting Return to reset the paragraph environment and depth. If you want a
new paragraph to keep the current environment and depth, use Alt+Return instead.

15
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3.3.2. Standard

The default paragraph environment is Standard for most classes. It creates a plain
paragraph. If LyX resets the paragraph environment, this is the one it chooses. In
fact, the paragraph you're reading right now (and most of the ones in this manual)
are in the Standard environment.

You can nest a paragraph using the Standard environment in just about anything
else, but you can’t really nest anything in a Standard environment.

3.3.3. Document Title

A TTEX title page has three parts: the title itself, the name(s) of the author(s) and a
“footnote” for thanks or contact information. For certain types of documents, KTEX
places all of this on a separate page along with today’s date. For other types of
documents, the title “page” goes at the top of the first page of the document.

LyX provides an interface to the title page commands through the paragraph en-
vironments Title, Author, and Date. Here’s how you use them:

o Put the title of your document in the Title environment.
o Put the author name in the Author environment.

o If you want the date to have a certain appearance, want to use a fixed date, or
want other text to appear in place of today’s date, put that text in the Date
environment. Note that using this environment is optional. If you don’t provide
any, IXTEX will automatically insert today’s date. If you don’t want any date,
add the line

\date{}

to the preamble of your document (menu Document> Settings)

You can use footnotes to insert “thanks” or contact information.

3.3.4. Headings

There are several paragraph environments for producing section headings. IyX takes
care of the numbering for you.

3.3.4.1. Numbered Headings

There are 7 numbered types of section headings. They are:
1. Part
2. Chapter

3. Section
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4. Subsection
5. Subsubsection
6. Paragraph
7. Subparagraph

LyX labels each heading with a series of numbers, separated by periods. The num-
bers describe where in the document you are. Unlike the other headings, parts are
numbered with Latin letters.

Headings all subdivide your document into different pieces of text. For example,
suppose you're writing a book. You group the book into chapters. LyX does similar
grouping:

o Part is divided in either Chapters or Sections
e Chapters are divided into Sections
 Sections are divided into Subsections

o Subsections are divided into Subsubsections
o Subsubsections are divided into Paragraphs

o Paragraphs are divided into Subparagraphs

Note: Not all document types use the Chapter heading as the maximum sectioning
level. In that case the Section is the top-level heading.

So, if you use the Subsubsection environment to label a new sub-subsection, IyX
labels it with its number, along with the number of the subsection, section, and, if
applicable, chapter that it’s in. For example: the fifth section of the second chapter
of this book has the label “2.5".
3.3.4.2. Unnumbered Headings
There are 5 types of unnumbered section headings. They are:

1. Part*

2. Chapter*

3. Section*

4. Subsection*

5. Subsubsection*

The “*” after each name means that these headings are not numbered. They work
the same as their numbered counterparts but won'’t appear in the table of contents,
see section 6.2.

17
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3.3.4.3. Changing the Numbering

You can also alter which sectioning levels get numbered and which ones appear in
the Table of Contents. Now, this doesn’t remove any of the levels; that’s preset in
the document class. Certain classes start with Chapter and go down to the Subpara-
graph level. Others start at Section. Similarly, not all document classes number all
sectioning levels. Most don’t number Paragraph or Subparagraph. This is something
you can change.

Open the Documentt>Settings dialog. Under Numbering & TOC you’ll see two
counters. The one named Numbering controls how far down in the sectioning hierarchy
LyX numbers a section heading. The other one controls the appearance of the section
headings in the table of contents.

3.3.4.4. Short Titles of Headings

Some section or chapter titles, such as this one, can get quite long. This can cause
trouble when there is limited horizontal space. For example, if the header of the page
is set to show the current section title, a long title will protrude over the page margins
and look awful.

KETEX allows you to specify a short title for section headings. This short title is used
in the header and in the actual table of contents, avoiding the problem mentioned. To
specify a short title, use the menu Insert>Short Title. This will insert a box labeled
“opt” (stands for “optional”) which you can use to enter the short title text. This
also works for captions inside floats.

The title of this section is a good example of using this feature.

3.3.4.5. Special Information

The following information applies to all section headings:
e You cannot do any nesting with these environments.
¢ You cannot use a margin note in any of these environments.
e You can only use inline math in these environments.

¢ You can use labels and cross-references to refer to their numbers.

3.3.5. Quotes and Poetry line spacing

LyX has three paragraph environments for writing poetry and quotations. They are
Quote, Quotation, and Verse. Forget the days of changing line spacing and twiddling
with margins. These three paragraph environments already have those changes built-
in. They all widen the left margin and add a bit of extra space above and below the
text they contain. They also allow nesting, so you can put a Verse in a Quotation, as
well as in some other paragraph environments.
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There is another feature of these three paragraph environments: they do not reset
to Standard when you start a new paragraph. So, you can type in that poem and
merrily hit Return without worrying about the paragraph environment changing on
you. Of course, that means that, once you're done typing in that poem, you have to
change back to the Standard environment yourself.

3.3.5.1. Quote and Quotation

Now that we’ve described the similarities of these three environments, it’s time for

the differences. Quote and Quotation are identical except for one difference: Quote

uses extra spacing to separate paragraphs and never indents the first line. Quotation

always indents the first line of a paragraph and uses the same line spacing throughout.
Here’s an example of the Quote environment:

This is in the Quote environment. I can keep writing, extending this line
out further and further until it wraps. See — no indentation!

Here’s the second paragraph of this quote. Again, there’s no indentation,
but there is extra space between me and the other paragraph.

Here’s another example, this time in the Quotation environment:

This is in the Quotation environment. If I keep writing, you’ll see the
indentation. If your country uses a writing style that shows off new para-
graphs by indenting the first line, then Quotation is the environment for
you! Well, you’d use it if you were quoting other text.

Here’s a new paragraph. I could ramble on and on, like a politician at
election time. If I did that, though, you’d get bored.

As the examples show, Quote is for those people who use extra space to separate
paragraphs. They should put quotes in the Quote environment. Those who use in-
dentation to mark a new paragraph should use the Quotation paragraph environment
for quoted text.

3.3.5.2. Verse

Verse is a paragraph environment for poetry, rhymes, verses, and so on. Here’s an
example:

This is in Verse
Which I did not rehearse!

It could be much worse. This line could be long, very long, oh so long,
so very long that it wraps around. It looks okay on screen, but in the
printed version, the extra lines are indented a bit more than the first.
Okay, so it’s turned to prose and doesn’t rhyme anymore. So sue me.

To break a line
And make things look fine
Use Ctrl+Return.
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As you can see, Verse does not indent both margins. Each stanza of the verse or
poem is in its own paragraph. To separate the individual lines of a stanza, use the
break-line function Ctrl+Return.

3.3.6. Lists

LyX has four different paragraph environments for creating different kinds of lists. In
the ltemize and Enumerate environments, [yX labels your list items with bullets or
numbers, respectively. In the Description and List environments, [x/X lets you provide
your own label. We'll present the individual details of each type of list next after
describing some general features of all four of them.

3.3.6.1. General Features

The four paragraph environments for lists differ from the other environments in several
ways. First, LyX treats each paragraph as a list item. Hitting Return does not reset
the environment to Standard but keeps the current environment and creates a new
list item. The nesting depth is hereby kept. If you want to keep the paragraph
environment but reset the current nesting depth, you can use Alt+Return to break
paragraphs.

You can nest lists of any type inside one another. In fact, IyX changes the labels
on some list items depending on how it is nested. If you intend to use any of the list
paragraph environments, we suggest you read all of section 3.4.

3.3.6.2. Iltemize

The first type of list we’ll describe in detail is the Itemize paragraph environment. It
has the following properties:

o Each item has a particular bullet or symbol as its label.

— LyX uses the same symbol for all of the items in a given nesting level.
— The symbol appears at the beginning of the first line.
o The items can have any length. IyX automatically offsets the left margin of

each item. The offset is always relative to whatever environment the Itemize
list may be in.

o If you nest an ltemize environment inside another Itemize environment, the label
changes to a new symbol.

— There are four different symbols for up to a four-fold nesting.
— LyX always shows the same symbol on screen.

— See section 3.4 for a full explanation of nesting.
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Of course, that explanation was also an example of an Itemize list. The ltemize
environment is best suited for lists where the order doesn’t matter.

We said that different levels use different symbols as their label. Here’s an example
of all four possible symbols.

o The label for the first level Itemize is a large black dot, or bullet.

— The label for the second level is a dash.
x The label for the third is an asterisk.
The label for the fourth is a centered dot.
* Back out to the third level.

— Back to the second level.
« Back to the outermost level.

These are the default labels for an Itemize list. You can customize these labels in the
Document > Settings dialog in the submenu Bullets.

Notice how the space between items decreases with increasing depth. We’ll explain
nesting and all the tricks you can do with different depths in section 3.4.
3.3.6.3. Enumerate

The Enumerate environment is used to create numbered lists and outlines. It has
these properties:

1. Each item has a numeral as its label.
a) The label type depends on the nesting depth.

2. IyX automatically counts the items for you and updates the label as appropri-
ate.

3. Each new Enumerate environment resets the counter to one.

4. Like the Itemize environment, the Enumerate environment:

a) Offsets the items relative to the left margin. Items can have any length.
b) Reduces the space between items as the nesting depth increases.

c¢) Uses different types of labels depending on the nesting depth.

d) Allows up to a four-fold nesting,.

Unlike the ltemize environment, Enumerate shows the different labels for each item in
LyX. Here is how LyX labels the four different levels in an Enumerate:

1. The first level of an Enumerate uses Arabic numerals followed by a period.
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a) The second level uses lower case letters surrounded by parentheses.
i. The third level uses lower-case Roman numerals followed by a period.
A. The fourth level uses capital letters followed by a period.

B. Again, notice the decrease in the spacing between items as the
nesting depth increases.

ii. Back to the third level
b) Back to the second level.

2. Back to the outermost level.

Once again, you can customize the type of numbering used in the Enumerate envi-
ronment. It involves adding commands to the KTEX preamble (see the Additional
Features manual). As stated earlier, such customization only shows up in the printed
version, not in LyX.

There is more to nesting Enumerate environments than we’ve stated here. You
should read section 3.4 to learn more about nesting.

3.3.6.4. Description

Unlike the previous two environments, the Description list has no fixed label. Instead,
LyX uses the first “word” of the first line as the label. Here’s an example:

Example: This is an example of the Description environment.

LyX typesets the label in boldface and puts extra space between it and the rest of
the line.

With the first “word” it is meant that the first hit of the Space key ends the label if
you are at the beginning of the first line of an item. If you need to use more than one
word in the label use a Protected Blank. (Use either Ctrl+Space or the menu Insert>
Formatting > Protected Space, see section 3.5.1 for more info.) Here is an example:

Second Example: This one shows how to use a Protected Blank in the label of a
Description list item.

Usage: You should use the Description environment for things like definitions and
theorems. Use it when you need to make one word in particular stand out in
the text that describes it. It’s not a good idea to use a Description environment
when you have an entire sentence that you want to describe. You're better off
using Itemize or Enumerate and nesting several Standard paragraphs into them.

Nesting: You can nest Description environments inside one another, nest them in
other types of lists, and so on.

Notice that after the first line, [yX indents subsequent lines, offsetting them from
the first line.
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3.3.6.5. The LyX List

The List environment is a [yX extension to IXTEX.

Note: When you are using a KOMA-Script document class, like in this document,
the List environment is named Labeling.

Like the Description environment the List environment has user-defined labels for
each list item. There are the following properties of this list environment:

item labels LyX uses the first “word” of each line as the item label. The first Space
after the beginning of the first line of an item marks the end of the label.
If you need to use more than one word in an item label, use a protected
blank as described above.

margins  As you can see, LyX uses different margins for the item label and the body
of the item text. The body of the text has a larger left margin, which is
equal to the default label width plus a little extra space.

label width LyX uses the width of the label, or the default width, whatever is larger.
If the label width is larger, the label “extends” into the first line. In other
words, the text of the first line isn’t aligned with the left margin of the
rest of the item text.

default width You can set the default label width to ensure that the text of all items
in a List environment have the same left margin.
To change the default width, select all items in the list. Now open the
Edit> Paragraph Settings dialog. The text in the box Longest label deter-
mines the default label width. You can use the text of your largest label
here, but you can also use the letter “M” multiple times instead. The M is
the widest character and is a standard unit of widths in WTEX. By using
“M” as the unit of width you don’t need to keep changing the contents of
Longest label every time you alter a label in a List environment.
The predefined default width is the length of “00.00.0000” (equal to 6 M).
Note: Setting the cursor into a list item to change only its label width
will only change the width inside IyX but not in the output.

You should use the List environment the same way like the Description list: When
you need one word to stand out from the text that describes it. The List environment
gives you another way to do this, using a different overall layout.

You can nest List environments inside one another, nest them in other types of
lists, and so on. They work just like the other list paragraph environments. Read
section 3.4 to learn about nesting.

There is yet another feature of the List environment: As you can see in the examples,
Iy X left-justifies the item labels by default. You can use additional HFills to change
how LyX justifies the item label. Hfills are documented in section 3.5.2. Here are
some examples:
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Left The default for List item labels.
Right One HFill at the beginning of the label right justifies it.

Center  One HFill at the beginning of the label and one at the end centers it.

3.3.7. Letters
3.3.7.1. Address and Right Address: An Overview

Although IxX has document classes for letters, we've also created two paragraph
environments called Address and Right Address. To use the letter class, you need to
use specific paragraph environments in a specific order, otherwise IXTEX gags on the
document. In contrast, you can use the Address and Right Address paragraph environ-
ments anywhere with no problem. You can even nest them inside other environments,
though you can’t nest anything in them.

Of course, you're not limited to using Address and Right Address for letters only.
Right Address, in particular, is useful for creating article titles like those used in some
European academic papers.

3.3.7.2. Usage

The Address environment formats text in the style of an address, which is also used for
the opening and signature in some countries. Similarly, the Right Address environment
formats text in the style of a right-justified address, which is used for the sender’s
address and today’s date in some countries. Here’s an example of each:

Right Address

Who I am

Where I am

When is it? What is today?

That was Right Address. Notice that the lines all have the same left margin, which
LyX sets to fit the largest block of text on a single line. Here’s an example of the
Address environment:

Who are you
Where do I send this
Your post office and country

As you can see, both Address and Right Address add extra space between themselves
and the next paragraph. If you hit Return in either of these environments, IxX resets
the nesting depth and sets the environment to Standard. This makes sense, since Re-
turn is the break-paragraph function, and the individual lines of an address are not
paragraphs. Thus, you have to use break-line (Ctrl+Return or Formatting Charac-
ter> Line Break from the Insert menu) to start a new line in an Address or Right Address
environment.
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3.3.8. Academic Writing

Most academic writing begins with an abstract and ends with a bibliography or list
of references. [yX contains paragraph environments for both of these.

3.3.8.1. Abstract

The Abstract environment is used for the abstract of an article. Technically, you could
use this environment anywhere, but you really should only use it at the beginning of
the document, after the title. Also, don’t bother trying to nest Abstract in anything
else or vice versa. It won’t work. The Abstract environment is only useful in the
article and report document classes. The book document classes ignores the Abstract
completely, and it’s utterly silly to use Abstract in a letter document class.

The Abstract environment does several things for you. First, it puts the centered
label “Abstract” above the text. The label and the text of the abstract are separated
by some extra vertical space. Second, it typesets everything in a smaller font, just
as you'd expect. Lastly, it adds a bit of extra vertical space between the abstract
and the subsequent text. Well, that’s how it will appear on the X screen. The
appearance in the output depends on the used article or report class.

Starting a new paragraph by hitting Return does not reset the paragraph environ-
ment. The new paragraph will still be in the Abstract environment. So, you will have
to change the paragraph environment yourself when you finish entering the abstract
of your document.

Abstract

This is an abstract. As you can see, it is
printed in a smaller font size than the other
paragraph types.

Also several paragraphs are possible in the
abstract.

This is a “Standard” paragraph to visualize the differ-
ences in the font size.

Figure 3.1.: Paragraph in the Abstract environment

We’d love to give you directly an example of the Abstract environment, but since
this document is in the “book” class, we can’t do this. We inserted it therefore as
figure 3.1. If you've never heard of an “abstract” before, you can safely ignore this
environment.

3.3.8.2. Bibliography

The Bibliography environment is used to list references. Technically, you could use this
environment anywhere, but you really should only use it at the end of the document.
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Nesting Bibliography in anything else or vice versa won’t work.

When you first open a Bibliography environment, [y X adds a large vertical space,
followed by the heading “Bibliography” or “References,” depending on the document
class. The heading is in a large boldface font. Each paragraph of the Bibliography en-
vironment is a bibliography entry. Thus, hitting Return does not reset the paragraph
environment. Each new paragraph is still in the Bibliography environment.

There is another, usually better way to include references in your document by using
a BibTEX database. For more information on that, and for a detailed description of
LyX’s bibliography handling, have a look at in section 6.5.

3.3.9. LyX-Code

The LyX-Code environment is another LyX extension. It type-sets text in a typewriter-
style font. It also treats the Space key as a fixed whitespace;® this is the only case in
which you can type multiple whitespaces in LyX. If you need to insert blank lines,
you'll still need to use Ctrl+Return (the break-line function). Return breaks para-
graphs. Note, however, that Return does not reset the paragraph environment. So,
when you finish using the LyX-Code environment, you’ll need to change the paragraph
environment yourself. Also, you can nest the LyX-Code environment inside of others.
There are a few quirks with this environment:

* You can’t use Ctrl+Return at the beginning of a new paragraph (i.g. you can’t
follow Return with a Ctrl4-Return).

e You can’t follow a Ctrl4+Return with a Space.
— Use a Return to begin a new paragraph, then you can use a Space.
— Or: use Ctrl+Space instead.

e You can’t have an empty paragraph or an empty line. You must put at least
one Space in any line you want blank. Otherwise, INXTEX generates errors.

e You cannot get the typewriter double quotes by typing " since that will insert
real quotes. You get the typewriter double quotes with Ctrl+".

Here’s an example:

#include <stdio.h>

int main(void)

{
printf ("Hello World!'\n");
return O;

}

3In the LyX-Code environment, the Space key is treated as a Protected Blank instead of an end-of-
word marker.
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This is just the standard “Hello world!” program.

LyX-Code has one purpose: to typeset code, such as program source, shell scripts,
rc-files, and so on. Use it only in those very special cases where you need to generate
text as if you used a typewriter.

3.4. Nesting Environments

3.4.1. Introduction

LyX treats text as a unified block with a particular context and specific properties.
This allows you to create blocks that inherit some of the properties of another block.
For example you have three main points in an outline, but point #2 also has two
subpoints. In other words, you have a list inside of another list, with the inner list
“attached” to item #2:

1. one

2. two
a) sublist — item #1
b) sublist — item #2

3. three

You put a list inside a list by nesting one list inside the other. Nesting an environment
is quite simple: Select Increase List Depth or Decrease List Depth from the Edit menu
to change the nesting depth of the current paragraph (the status bar will tell you
how far you are nested). Instead of the menu, you can also use the toolbar buttons

Fog—

=4 and g: or the convenient key bindings Tab and Shift-Tab or Alt+Shift+Right
and Alt+Shift+Left to change the nesting level. The change will work on the cur-
rent selection if you have made one (allowing you to change the nesting of several
paragraphs at once), or the current paragraph.

Note that Iy X only changes the nesting depth if it can. If it’s invalid to do so,
nothing happens if you try to change the depth. Additionally, if you change the depth
of one paragraph, it affects the depth of every paragraph nested inside of it.

Nesting isn’t limited to lists. In LyX, you can nest just about anything inside
anything else, as you're about to find out. This is the real power of nesting paragraph
environments.

3.4.2. What You Can and Can’t Nest

Before we fire a list of paragraph environments at you, we need to tell you a little bit
more about how nesting works.

The question if nesting a paragraph environment is possible, is a bit more compli-
cated than a simple yes or no. There are three types of paragraph environments:
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o Completely unnestable

o Fully nestable, you can nest them inside things and you can also nest other
things inside them.

e A third type, you can nest them into other environments, but you can’t nest
anything into them.

Here’s a list of the three types of nesting behavior, and which paragraph environments
have them:

Unnestable Can’t nest them. Can’t nest into them.
» Bibliography
o Abstract
o Title
e Author
e Date

Fully Nestable You can nest them. You can nest other things into them.

o Verse

o Quote

o Quotation
o ltemize

o Enumerate
o Description
o List

o LyX-Code

Nestable-Inside You can nest them inside other things. You can’t nest anything into
them.

 Standard

o Part

o Chapter
 Section

o Subsection
 Subsubsection
« Paragraph

o Subparagraph
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o Part*

o Chapter*

o Section*

o Subsection*

o Subsubsection*

o Right Address

« Address
Note: Although it is possible to nest numbered section headings like Chapter, Section,
etc. to e. g. lists, it is highly recommended not to do this because the aim is to create

well structured documents following typesetting guidelines whereas nested section
headings violate this.

3.4.3. Nesting Other Things: Tables, Math, Floats, etc.

There are several things that aren’t paragraph environments, but which are affected
by nesting anyhow. They are:

* equations
« tables
o figures

( Note: Figures and tables in Floats are not affected by this.  Have a look at
section 4.6 for more information about Floats.)

LyX can treat these three objects as either a word or as a paragraph. If a figure,
table, or an equation is inline, it goes wherever the paragraph it is in goes.

On the other hand, if you have an equation, figure or table in a “paragraph” of its
own, it behaves just like a “nestable-inside” paragraph environment. You can nest it
into any environment, but you obviously can’t nest anything into it.

Here’s an example with a table:

1. Item One
a) This is (a) and it’s nested.

on

b) This is (b). The table is actually nested inside (a).
2. Back out again.

If we hadn’t nested the table at all, the list would look like this:

29



3. LyX Basics

1. Item One

a) This is (a) and it’s nested.

on

1. This is (b). The table is not nested inside (a). In fact, it’s not nested at all.

2. Back out again.

Notice how item (b) is not only no longer nested, but is also the first item of a new
list!

There’s another trap you can fall into: Nesting the table, but not going deep
enough. LyX then turns anything after the table into a new sublist.

1. Ttem One

a) This is (a) and it’s nested.

a) This is (b). The table is actually nested inside Item One, but not inside

(a).
2. Back out again.

As you can see, item (b) turned into the first item of a new list, but a new list inside
item 1. The same thing would have happened to a figure or an equation. So, if you
nest tables, figures or equations, make sure you go to the right depth!

3.4.4. Usage and General Features

Speaking of levels, LyX can perform up to a six-fold nesting. In other words, “level
#6” is the innermost possible depth. Here’s an example to illustrate what we mean:

1. level #1 — outermost
a) level #2
i. level #3
A. level #4
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o level #5
— level #6

There are two exceptions to the six-fold nesting limit, and you can see both of them
in the example. Unlike the other fully-nestable environments, you can only perform
a four-fold nesting with the Enumerate and ltemize environments. For example, if we
tried to nest another Enumerate list inside item “A., we would get errors.

3.4.5. Some Examples

The best way to explain just what you can do with nesting is by illustration. We
have several examples of nested environments. In them, we explain how we created
the example, so that you can reproduce them.

3.4.5.1. Example 1: The Six-fold Way and Mixed Nesting
#1-a  This is the outermost level. It’s a List environment.

#2-a  This is level #2. We created it by using Alt+Return followed by
Alt+Shift+Right.

#3-a  This is level #3. This time, we just hit Return, then used
Alt+Shift+Right twice in a row. We could have also created it
the same way as we did the previous level, by hitting Alt+Return
followed by Alt+Shift+Right.

This is actually a Standard environment, nested inside of “#3-
a”. So, it’s at level #4. We did this by hitting Alt+Return, then
Alt+Shift+Right, then changing the paragraph environment to
Standard. Do this to create list items with more than one
paragraph — it also works for the Description, Enumerate, and
Itemize environments!

Here’s another Standard paragraph, also at level #4, made with

just a Alt+Return.

#4-a  This is level #4. We hit Alt+Return and changed the
paragraph environment back to List. Remember —
we can’t nest anything inside a Standard environment,
which is why we're still at level #4. However, we can
keep nesting things inside “#3-a”.

#5-a  This is level #5. ..

#6-a ...and this is level #6. By now, you
should know how we made these two.

#5-b  Back to level #5. Just hit Alt+Return followed
by a Alt+Shift+Left.
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#4-b  After another Alt+Return followed by a Alt+Shift+Left,
we're back at level #4.

#3-b  Back to level #3. By now it should be obvious how we did
this.

#2-b  Back to level #2.

#1-b  And last, back to the outermost level, #1. After this sentence, we’ll hit Return
and change the paragraph environment back to Standard to end the list.

We could have also used the Description, Quote, Quotation, or even the Verse environ-
ment in place of the List environment. The example would have worked exactly the
same.

3.4.5.2. Example 2: Inheritance

This is the IyX-Code environment, at level #1, the outermost
level. Now we’ll hit Re-

turn, then Alt+Shift+Right, after which, we’ll change to the Enu-
merate environment.

1. This is the Enumerate environment, at level #2.

2. Notice how the nested Enumerate not only inherits its
margins from its parent environment (LyX-Code), but also
inherits its font and spacing!

We ended this example by hitting Return. After that, we needed to reset the para-
graph environment to Standard and reset the nesting depth by using Alt+Shift+Left
once.

3.4.5.3. Example 3: Labels, Levels, and the Enumerate and Itemize
Environments

1. This is level #1, in an Enumerate paragraph environment. We're actually going
to nest a bunch of these.

a) This is level #2. We used Alt+Return followed by Alt+Shift+Right. Now,
what happens if we nest an ltemize environment inside of this one? It will
be at level #3, but what will its label be? An asterisk?

o No! It’s a bullet. This is the first Iltemize environment, even though it’s
at level #3. So, its label is a bullet. (We got here by using Alt+Return,
then Alt+Shift+Right, then changing the environment to ltemize.)

— Here’s level #4, produced using Alt+Return, then Alt+Shift+Right.
We’ll do that again. ..
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i. ...to get to level #5. This time, however, we also changed
the paragraph environment back to Enumerate. Notice the type
of numbering, it is lowercase Roman, because we are in the
thirdfold Enumerate environment (i. g. it is an Enumerate inside
an Enumerate inside an Enumerate).

ii. What happens if we don’t change the paragraph environment,
but decrease the nesting depth? What type of numbering does
LyX use?

iii. Oh, as if you couldn’t guess by now, we're just using Alt+Return
to keep the current environment and depth but create a new
item.

iv. Let’s use Alt+Shift+Left to decrease the depth after the next
Alt+Return.

i. This is level #4. Look what type of label LyX is using!

i. This is level #3. Even though we’'ve changed levels, IyX is still using
a lowercase Roman numeral as the label. Why?

ii. Because, even though the nesting depth has changed, the paragraph
is still a thirdfold Enumerate environment. Notice, however, that [yX
did reset the counter for the label.

b) Another Alt+Return Alt+Shift+Left sequence, and we’re back to level #2.
This time, we not only changed the nesting depth, but we also moved back
into the twofold-nested Enumerate environment.

2. The same thing happens if we do another Alt+Return Alt+Shift+Leftsequence
and return to level #1, the outermost level.

Lastly, we reset the environment to Standard. As you can see, the level number
doesn’t correspond to what type of labeling Iy X uses for the Enumerate and Itemize
environments. The number of other Enumerate environments surrounding it deter-
mines what kind of label 15X uses for an Enumerate item. The same rule applies for
the ltemize environment, as well.

3.4.5.4. Example 4: Going Bonkers

1. We're going to go totally nuts now. We won’t nest as deep as in the other
examples, nor will we go into the same detail with how we did it. (level #1:
Enumerate)

(Return, Alt+Shift+Right, Standard: level #2) We'll stick an encapsulated de-
scription of how we created the example in parentheses someplace. For example,
the two keybindings are how we changed the depth. The environment name is
the name of the current environment. Either before or after this, we’ll put in
the level.
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2. (Return, Enumerate: level #1) This is the next item in the list.

Now we’ll add verse.
It will get much worse.

(Return, Alt+Shift+Right, Verse: level #2)

Fiddle dee, Fiddle doo.
Bippitey boppitey boo!
(Alt+Return)

Here comes a table:

one-fish ‘ two-fish
red-fish ‘ blue-fish

(Alt+Return, Table, Alt+Shift+Right 3 times, Alt+Return, Verse, Alt+Shift+Left)

3. (Return, Enumerate: level #1) This is another item. Note that selecting a Table
resets the nesting depth to level #1, so we increased the nesting depth 3 times
to put the table inside the Verse environment.

We’re now ending the Enumerate list and changing to Quotation. We're
still at level #1. We want to show you some of the things you can do
by mixing environments. The next set of paragraphs is a “quoted let-
ter” We’ll nest both the Address and Right Address environments inside
of this one, then use another nested Quotation for the letter body. We’ll
use Alt+Return to preserve the depth. Remember that you need to use
Ctrl+Return to create multiple lines inside the Address and Right Address
environments. Here it goes:

1234 Nowhere Rd.
Moosegroin, MT 00100
9-6-96

Dear Mr. Fizlewitz:

We regret to inform you that we cannot fill your order for 50 L,
of compressed methane gas due to circumstances beyond our
control. Unfortunately, several of our cows have mysteriously
exploded, creating a backlog in our orders for methane. We will
place your name on the waiting list and try to fill your order
as soon as possible. In the meantime, we thank you for your
patience.

We do, however, now have a special on beef. If you are inter-
ested, please return the enclosed pricing and order form with
your order, along with payment.

We thank you again for your patience.



3.5. Spacing, pagination and line breaks

Sincerely,
Bill Hick

That ends that example!

As you can see, nesting environments in Ly X gives you a lot of power with just a few
keystrokes. We could have easily nested an ltemize list inside of a Quotation or Quote,
or put a Quote inside of an Itemize list. You have a huge variety of options at your
disposal.

3.5. Spacing, pagination and line breaks

What is a space?” While you might be used to pressing the space key anytime you
want to separate two words in ordinary word processors, [y X offers you more spaces:
Spaces of different width and spaces which can or cannot be broken at the end of
a line. The following sections will show you some examples where those spaces are
useful.

3.5.1. Protected Space

The protected space: It is used to tell IyX (and TEX) not to break the line at that
point. This may be necessary to avoid unlucky linebreaks, like in:

Further documentation is given in section
6.5.

Obviously, it would be a good thing to put a protected space between “section” and
“6.5”. A protected space is set with Insert>Formatting>Protected Space (shortcut
Ctrl+Space).

3.5.2. Horizontal Space

All horizontal spaces can be inserted with the menu Insert> Formatting > Horizontal
Space. The length units are listed in Appendix D.

3.5.2.1. Inter-word Space

Some languages (e.g. English) have the typographical convention to add extra space
after an end-of-sentence punctuation mark, and IyX honors those conventions (see
section 3.9.3.1). Sometimes, you want a normal space nevertheless. In this case,
insert an inter-word space (shortcut Ctrl4+Alt+Space).
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Table 3.1.: Width of the different horizontal spaces.

’ Space \ Width ‘
Normal 1/3em
Protected 1/3em
Thin 1/6 em

Negative thin | -1/6em

Enspace (0.5em) | 0.5em
Quad (1em) lem
QQuad (2em) 2em

3.5.2.2. Thin Space

A “thin space” is a blank which has half the size of a normal space (and it is also
“protected”). The typographical conventions in a lot of languages propose the use
of thin spaces in cases where normal spaces would be too wide, for instance inside
abbreviations:

D. E. Knuth has developed our beloved typesetting program.

or between values and units. Compare for example this:
10kg (thin space)
10 kg (normal space
You can insert thin spaces also with the menu Insert>Formatting> Thin Space
(shortcut Ctrl+Shift4Space).

3.5.2.3. More Spaces

You can furthermore insert the following space types:

Negative thin space A line with a —<— Negative thin space between the arrows.
Enspace (0.5em) A line with a — < Enspace (0.5em) space between the arrows.
Quad (1em) A line with a — < Quad (1em) space between the arrows.

QQuad (2em) A line with a — < QQuad (2em) space between the arrows.
Custom space A line with— + 2cm space between the arrows.

Table 3.1 lists the different space sizes.

3.5.2.4. Horizontal Fills

Horizontal fills (HFills) are a special Ly X feature for adding extra space in a uniform
fashion. An HFill is actually a variable length space, whose length always equals the
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remaining space between the left and right margins. If there is more than one HFill
on a line, they divide the available space equally between themselves.
Here a few examples what you can do with them:

This is on the left side This is on the right
Left Middle Right
Left 1/3 Left Right
That was an example in the Quote environment. Here— <is one in

a standard paragraph. It may or may not be apparent in the printed text, but it s
sitting in-between the two arrows.

HFills can be made visible when you choose one of the Fill Pattern in the space
dialog: The following patterns are available:

DOt

Rule:

Left arrow: <

Right arrow:
Up brace:
Down brace:
Note: If an HFill is at the beginning of a line, and not in the first line in a
paragraph, IxX ignores it. This prevents HFills from accidentally being wrapped
onto a new line. If you need space in this case anyway, set the Protect option in the
space dialog.

3.5.2.5. Phantom Space

Sometimes you want to insert space with exactly the length of a phrase. E.g. you
want to create the following multiple choice question:

What is correct English?:

Mr. Edge would have been jumps the gun.
has to be jumped
jumps

So that the choices appear exactly after the phrase “Mr. Edge 7. To get this,
you can use the IXTEX-command \phantom in TEX Code®. In our case write the
command \phantom{Mr. Edge } (note the space after “Edge”) at the beginning
of the last two lines. The command prints out the phrase within the two braces, but

invisible. That is why it is named “phantom”.?

4See sec. 6.10 for more information about TEX-Code.
SThere exists also the commands \hphantom and \vphantom, but this too special for the Iy X
User Guide. If you are interested in knowing more about this, have a look at [1, 2].
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3.5.3. Vertical Space

To add extra vertical space above or below a paragraph, use the Insert> Formatting >
Vertical Space dialog. There you find the following sizes:

SmallSkip, MedSkip and BigSkip are IXTEX sizes which depend on the font size of
the document. DefSkip is the skip adjusted in the dialog Document > Settings for the
paragraph separation. If you use indentation to separate paragraphs DefSkip is equal
to MedSkip.

VFill is a variable space, set so that the space is maximal within one page. An
example: You have only two short paragraphs on one page with a vfill between them.
Then the first paragraph is placed at the top of the page and the second one at the
bottom, because the space between them is then maximal. VFills work like HFills:
they fill the remaining vertical space on a page with blank space.® If there are several
VFills on a page, they divide the remaining vertical space equally between themselves.
You can therefore use VFills to center text on a page, or even place text 2/3 down a
page.

Custom are custom spaces in units explained in Appendix D.

Note: When the extra vertical space would be in the output at the top/bottom
of a page, the space is only added if you have also checked the option Protect.

3.5.4. Paragraph Alignment

You can change the paragraph alignment with the Edit>Paragraph Settings dialog.
There are five possibilities:

o Justified (shortcut Alt+A J)

o Left (Alt+A L)

Right (Alt+A R)

Center (Alt+A C)
o Default (Alt+A E)

The default in most cases is justified alignment, in which the inter-word spacing

is variable and each line of a paragraph fills the region between the left and right

margins. The other three alignments should be self-explanatory, and look like this:
This paragraph is right aligned,

this one is centered,

this one is left aligned.

SHFills are described in section 3.5.2.
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3.5.5. Forced Page Breaks

If you don’t like the way ITEX does the pagebreaks in your document, you can force
a page break where you want one. Normally this will not be necessary, because IXTEX
is good at page breaking. Only if you use a lot of Floats, KIEX’s page breaking
algorithm can fail.

We recommend not to use forced pagebreaks until the text is finished and until you
have checked in the preview to see if you really have to change the page breaking.

There are two types of pagebreaks: One that ends the page without any spe-
cial action. This can be inserted above or below a paragraph via the menu In-
sert> Formatting> New Page. The second type, that is inserted via the menu Insert >
Formatting> Page Break, ends a page but stretches the content of the page, so that
it fills out the complete page. This type is useful to avoid whitespace when a page
break produces a page on which only the last few lines are absent.

You might try to use a page break to ensure that a figure or table appears at the
top of a page. This is, of course, the wrong way to do it. LyX gives you a way of
automatically ensuring that your figures and tables appear at the top of a page (or
the bottom, or on their own page) without having to worry about what precedes or
follows your figure or table. See chapter 4 to learn more about Floats.

3.5.5.1. Clear Page Breaks

Rather than forced pagebreaks where the content behind the break is placed directly
on the next page, you can also clear pages while breaking them. That means that the
current paragraph is terminated and everything, including unprocessed floats, from
the earlier part of the document are placed behind it, if necessary by adding pages.

You can insert a clear page break with the menu Insert>Formatting> Clear Page.
When you have a two-sided document like a book, you can use the menu Insertr
Formatting> Clear Double Page to insert a clear page break that assures that the next
page is a right-hand page (odd-numbered), if necessary by adding a page.

3.5.6. Forced Line Breaks

Similar to page breaks there are two types of line breaks: One that simply breaks the
line. You can force this line break within a paragraph by selecting Insert > Formatting >
Ragged Line Break or with Ctrl4+Return. Another type that is inserted via the menu
Insert > Formatting > Justified Line Break breaks the line and stretches it so that it fills
out the whole space between the page margins. This is necessary to avoid “fringes”
in justified paragraphs due to whitespace introduced by line breaks.

You shouldn’t use forced line breaks to correct IXTEX’s line breaking, as ITEX
is very good at line breaking. There are, however, a number of situations where
it is necessary to actively set a line break, e.g. in a poem or for an address (see
sections 3.3.5.1, 3.3.5.2 and 3.3.7.2).
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3.5.7. Horizontal Lines

In the dialog Insert > Formatting > Horizontal Line you can insert horizontal lines that
span the whole width of the document or column.

3.6. Characters and Symbols

You can directly enter all characters that are available on your keyboard. You can
also use special keyboard maps to be able to enter e. g. characters needed for French
with an English keyboard. See section 6.15.2 for information on how this is done.

For the case where you need a character that is not on your keyboard, you can use
the Symbols dialog via the menu Insert>Special Character>Symbols.

Note: Maybe not all symbols inserted with the symbols dialog can be displayed
when you are using a special screen font in LyX’s preferences. But the inserted
symbols will in every case be displayed in the output.

3.7. Fonts and Text Styles

3.7.1. Font Types

There are two types of fonts:

Vector fonts are fonts, built from outlines of the single glyphs (i.g. characters) in
the font. This means that each glyph is defined using mathematical curves that
are well suited for scaling to any requested size. This mathematical definition is
interpreted by the font renderer and the curve is filled out with pixels according
to the size and glyph. This means that outline fonts will look pretty good
in all sizes. Only at very small sizes where each pixel has to be very carefully
computed to provide a good image, it might be hard to provide a good rendering.
That could mean that one only needs to define one font size and scale them. But
to achieve a better quality, many fonts define several font sizes. That improves
the appearance because you need more details at large font sizes than at small
ones.

The font types TrueType, OpenType, and Type 1 are vector fonts.

Bitmap fonts on the other hand, are defined by bitmap graphics from the start, so
they will look good at all the sizes they are meant for. However, they don’t
scale well, because in order to scale a glyph, each pixel is enlarged into several
pixels. It is the same effect that happens if you try to enlarge a picture in a
picture manipulation program. In order to relieve this effect, bitmap fonts are
typically provided in several fixed sizes typically from around 8 pixels high up
to 34 pixels or so high in steps according to what is believed to be useful. The
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advantage of bitmap fonts is that no complicated computations are necessary
to display each glyph, so bitmap fonts are thus faster displayed than scalable
fonts. The disadvantage is that sizes that don’t exist as fixed versions have to
be scaled by doubling pixels, and thus look bad.

Bitmap fonts are named Type 3 in PostScript- and PDF-documents.

The result of all this, is that bitmap fonts are best for the size they are designed
for, while scalable fonts are good for nearly all sizes. So one need fewer font size
definitions for scalable fonts. That’s the reason why nearly all text rendering and
typesetting programs use scalable fonts.

To test which fonts are used in a PDF-document, you can have a look into its
document properties.

Many modern typesetting and markup languages have begun to move towards
specifying character styles rather than specifying a particular font. For example,
instead of changing to an italicized version of the current font to emphasize text, you
use an “emphasized style” instead. This concept fits in perfectly with [yX. In [yX,
you do things based on contexts, rather than focusing on typesetting details.

3.7.2. Document Font and Font size

You can set the document fonts in the Document>Settings dialog. There you can
specify which font should be used for the three different font shapes roman (serif),
sans serif, and typewriter and its scalings.

The possible options for the font include default and a list of fonts available on your
system. default uses the standard TEX fonts, known as “Computer Modern” (cm) or
“European Computer Modern” (ec).

As cm and ec are bitmap fonts, they often looks pixelated in PDF output, especially
when you read the PDF in a zoomed size.” To get rid of pixelated fonts, you have to
use a vector font. There are three ways to use one:

e One way is to use the AE fonts. AE is a virtual font. Virtual means that it
“steals” outline cm-glyphs from other fonts. This has the disadvantage that
some characters are missing, like the French guillemets (“«” and “»”)® and that
accented characters are not one glyph, they are build of two characters, the
accent and the letter. Therefore you can’t search in documents using the AE
fonts for words with accented characters. If you search for example for the
French word “breve” in a PDF, you won’t get any result, because the PDF-
viewer searches for the glyph “ ¢ ” and not for the glyph “e + ™ "

"This problem doesn’t appear if you read PDFs in Adobe Reader version 6 or later, because this
program includes a special bitmap font renderer.

8Loading the IXTX-package aeguill with the document preamble line
\usepackage[ec]{aeguill}
will fix the guillemet problem.
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o Another possibility is to use three different outline fonts?: Times Roman as
roman font, Helvetica scaled to 92 or 95% as sans serif font, and courier as
typewriter font.

The differences between roman, sans serif, and typewriter fonts are explained
in section 3.7.4.

The font Times Roman was originally designed for newspapers. That means its
glyphs are smaller than the ones from other fonts to fit into the small newspaper
columns. Therefore Times Roman is not the optimal choice for larger documents
like books.

o The best solution is to use the Latin Modern (1m) fonts. These fonts were
developed for the TEX community to replace cm as the default font. In most
cases they look the same as cm'®, but 1m covers a vast number of characters
over the other two families cm and ec.

For the font size there are four possible values: default, 10, 11, and 12. The size of
default depends on your IXTEX-system, normally it is equal to the font size 10.

The font sizes are the base size. That means that [yX scales all other possible font
sizes (such as those used in footnotes, super-, and subscripts) by this value. You can
fine-tune the font size of text parts via the Text Style dialog if needed. The possible
font sizes for text parts are explained in section 3.7.4.

The field CJK allows users of the languages Chinese, Japanese, Korean (CJK) to
specify a font to display the script characters.!!

Note: When you choose a new font or font size, LyX does not change the screen
font! You will only see a difference in the printed output; this is part of the WYSI-
WYM concept. IyX’s screen fonts can be adjusted in the Tools> Preferences dialog,
see section C.1.2.

3.7.3. Using Different Character Styles

As we've already seen, Iy X automatically changes the character style for certain

paragraph environments. LyX supports two character styles, Emphasized and Noun.

You can activate both of these styles via keybindings, the menus, and the toolbar.
To activate the Noun style, do one of the following;:

¢ click on the toolbar button w

o use the key binding Alt+C C

90ther fonts, like Latin Modern or Computer Modern, consist of these three main font types
sans serif, typewriter, and serif.

100ne difference is improved kerning for the 1m fonts.

1 The font will be the argument for the commands of the I TEX-package CJK. So this has no effect
for the document language Japanese that doesn’t use CJK.
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These commands are all toggles. That is, if Noun style is already active, they deac-
tivate it.

One typically uses the Noun style for proper names. For example: “MATTHIAS
ETTRICH is the original author of IyX.”

A more widely used character style is the Emphasized style. You can activate (or
deactivate — it’s also a toggle) the Emphasized style by:

 clicking on the toolbar button E
« using the keybindings Ctrl4+E

Normally the Emphasized style is equivalent to an italic font but some document
classes or WTEX-packages use a different font.

We’ve been using the Emphasized style all over the place in this document. Here’s
one more example:

Don’t overuse character styles!

It’s also a warning in addition to an example. One’s writing should parallel ordinary
conversation. Since we don’t all constantly scream at each other, we should also avoid
the common tendency to overuse character style.

You can always reset to the default font using the key binding Alt+C Space or the
dialog Edit> Text Style.

3.7.4. Fine-Tuning with the Text Style dialog

There are always occasions when you will need to do some fine-tuning, so Iy X gives
you a way to create a custom character style. For example, an academic journal
or a corporation may have a style sheet requiring a sans-serif font be used in certain
situations. Also, writers sometimes use a different font to offset a character’s thoughts
from ordinary dialog.

Before we document how to use custom character style, we want to issue a warning
yet again: Don’t overuse character styles!

Documents that overuse different fonts and sizes are not well readable and tend to
look as if someone has knocked huge holes in them.

To use custom character styles, open the Edit> Text Style dialog. There are several
boxes on this dialog, each corresponding to a different font property which you can
choose. You can choose an option for one of these properties, or select No change,
which keeps the current state of that property. The item Reset will reset the property
to whatever is the default. You can use this to reset attributes across a bunch of
different paragraph environments in a snap.

The font properties, and their options (in addition to No change and Reset) are:

Family The “overall look” of the font. The possible options are:
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Roman This is the Roman font family. Normally a serif font. It’s also
the default family. (key binding Alt+C R)

Sans Serif This is the Sans Serif font family. (key binding Alt+C S)
Typewriter This is the Typewriter font family. (key binding Ctrl+Shift+P)

Series This corresponds to the print weight. Options are:

Medium This is the Medium font series. It’s also the default series.
Bold This is the Bold font series. (key binding Ctrl+B)

Shape As the name implies. Options are:

Upright This is the Upright font shape. It’s also the default shape.
Italic This is the Italic font shape.

Slanted This is the Slanted font shape (although it might not be visible
in yX, this is different from italic).

Small Caps THIS IS THE SMALL CAPS FONT SHAPE.
Size Alters the size of the font. You’'ll find no numerical values here; all possible
sizes are actually proportional to the document font size. Once again, you

don’t feed IyX the details, but a general description of what you want to
do. The options are:

Tiny This is the “Tiny” font size. (k€Y bindings Alt+S T, Alt+S 1)

Smallest  This is the “Smallest” font size. (key binding Alt+S 2)

Smaller ~ This is the “Smaller” font size. (key bindings Alt+S Shift+S, Alt+S 3)
Small This is the “Small” font size. (key bindings Alt+S S, Alt+S 4)

Normal This is the “Normal” font size. It’s also the default size. (key
bindings Alt+S N, Alt+S 5)

Large This is the “Large” font size. (key bindings Alt+S L, Alt+S 6)
Larger This is the “Larger” font size. (key bindings Alt+S Shift+L, Alt+S

Largest  1'his is the “Largest” font size. (key binding
Alt+S 8)

nee  1his Is the “Huge” font size. (e
bindings Alt+S H, Alt+S 9)

nger  10iS 1S the “Huger” font size. (e
bindings Alt+S Shift+H, Alt+S 0)

We'll warn you yet again: don’t go crazy with this feature. You should almost never
need to change the font size. yX automatically changes the font size for different
paragraph environments — use that instead. This is here for fine-tuning only!
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Misc Here you can change a few other things at the character level. Options
are:
Emph This is text with emphasize on. This might seem like the

Underbar

Noun

same as [talic, but it is actually a bit different. Emphasized
is a logical attribute. That means every document class can
define its own font used for emphasized text. Normally this
font is equal to italic.

This is text with Underbar on. (key binding Ctrl4+-U, Alt+C U)

Avoid using underbar if you can! It’s a hangover from the type-
writer days, when you couldn’t change fonts. We no longer
need to emphasize text by underscoring characters. It’s only
included in LyX because some people may need it in order to
follow style sheets for journal submissions.

THIS 1S TEXT WITH NOUN ON. Like Emph, this is a logical
attribute. Normally it’s equivalent to Small Caps.

Color You can adjust the color of the text with this control. Notice that not
all DVI-viewers are able to display colors. Besides No color, which is the
default “color” and means normally black, you can choose between Black,
White, Red, Green, Blue, Cyan, Magenta and Yellow text.

Language This is used to mark regions of text as having a different language from
the language of the document. Text marked in this way will be underlined
in blue to indicate the change (only within IyX).

So you have a huge number of combinations to choose from. Once you've chosen a
new character style via the Edit> Text Style dialog, the settings are saved. You can

activate them using the toolbar button FD+nt. The button lets you toggle the state of
your custom character style even when the dialog isn’t visible.

To completely reset the character style to the default, use Alt+C Space. If you
want to toggle only those properties that you have just changed (suppose you just set
the shape to “slanted” and the series to “bold”), set the Toggle all switch and press

Apply.

You should also know something about the differences between the three main font
types serif, sans serif, and typewriter:

o Typewriter is a so called “monospaced” font, that means every character has the

same width, the

@
1

is as wide as the “m”. Here is an example

typewriter text
no typewriter text

o Serif fonts use characters with serifs. These are the small “appendices” at the
ends of the strokes that form the character. The following example will show

the difference:
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text with serifs

text without serifs

Serifs facilitate quick and easy reading. These fonts are therefore used as default
(named roman).

o Sans serif don’t use serifs. This font type is therefore often used for headings
and short texts. We use it in this document to highlight menu names.

We conclude with the same warning once again: Don’t overuse the fonts. They are,
more often than not, a kludge and a bad substitute for good writing.

3.8. Printing and Previewing
3.8.1. Overview

Now that we have covered some of the basic features of document preparation using
LyX, you probably want to know how to print out your masterpiece. Before we tell
you that, we want to give you a quick explanation of what goes on behind-the-scenes.
We cover this information in much greater detail in the Additional Features manual
as well.

LyX uses the program KTEX as its backend. ITEX is just a macro package for the
TEX typesetting system, but to prevent confusion, we’ll only refer to IXTEX. LyX is
what you use to do your actual writing. Then, [y X calls KTEX to turn your writing
into printable output. This happens in two stages:

1. First, InyX converts your document to a series of text commands for KTEX,
generating a file with the extension,

2

.tex”.

2. Next, KTEX uses the commands in the .tex file to produce printable output.

3.8.2. Output file formats
3.8.2.1. ASCII

This file type has the extension “.txt”. It contains your document as plain text
following the rules of the “American Standard Code for Information Interchange”

(ASCII).
You can export your document to ASCII by the menu File> Export>ASCII.

3.8.2.2. BTEX

This file type has the extension “.tex” and contains all commands that are necessary
for the IXTEX program to process your document. If you know KEIEX, you can use
it to find out ITEX-Errors or to process it manually with console commands. The
KTEX-file is automatically created in LyX’s temporary directory whenever you view
or export your document.

You can export your document as I¥TEX-file using the menu File> Export>LaTeX.
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3.8.2.3. DVI

This file type has the extension “.dvi”. It is called “device-independent” (DVI),
because it is completely portable; you can move them from one machine to another
without needing to do any sort of conversion. DVIs are used for quick previews and
as pre-stage for other output formats, like PostScript.

DVI files do not contain images, they only link them. So don’t forget to deliver the
images together with your DVIs. Because the DVI-viewer has to convert the image
in the background to make it visible when you scroll the DVI, this can slow down
your computer when you view the DVI. So we recommend to use PDF for files with
many images.

You can export your document to DVI by the menu File > Export>DVI.

3.8.2.4. PostScript

4

This file type has the extension “.ps”. PostScript was developed by the company
Adobe as a printer language. The file contains therefore commands that the printer
uses to print the file. PostScript can be seen as a “programming language”; you can
calculate with it and draw diagrams and images.'?> Due to this ability, the files are
often bigger than PDFs.

PostScript can only contain images in the format “Encapsulated PostScript” (EPS,
file extension “.eps”). As LyX allows you to use any known image format in your
document, it has to convert them in the background to EPS. If you have e.g 50 images
in your document, IxyX has to do 50 conversions whenever you view or export your
document. This will slow down your workflow with IyX drastically. So if you plan
to use PostScript, you can insert your images directly as EPS to avoid this problem.

You can export your document to PostScript using the menu File > Export > PostScript.

3.8.2.5. PDF

This file type has the extension “.pdf”. The “Portable Document Format” (PDF)
developed by Adobe was derived from PostScript. It is more compressed and it uses
fewer commands than PostScript. As the name “portable” implies, it can be processed
at any computer system and the printed output looks exactly the same.

PDF can contain images in its own PDF format and in the formats “Joint Pho-
tographic Experts Group” (JPG, file extension “.jpg” or “.jpeg”) and “Portable
Network Graphics” (PNG, file extension “.png”). You can although use any other
image format, because LiyX converts them in the background to one of these formats.
But as described in the section about PostScript, the image conversion will slow
down your workflow. So we recommend to use images in one of the three mentioned
formats.

You can export your document to PDF via the menu Filer> Export in three different
ways:

12\When you are interested to learn more about this, have a look at the IATEX-package pstricks.
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PDF This uses the program ps2pdf that creates a PDF from a PostScript-version
of your file. The PostScript-version is produced by the program dvips which
uses a DVI-version as intermediate step. So this export variant consist of three
conversions.

PDF (dvipdfm) This uses the program dvipdfm that converts your file in the back-
ground to DVI and in a second step to PDF.

PDF (pdflatex) This uses the program pdftex that converts your file directly to
PDF.

We recommend to use PDF (pdflatex) because pdftex supports all the features of
actual PDF-versions, is quick, stable, and works without problems. The program
dvipdfm is no longer under development and therefore a bit outdated.

3.8.3. Previewing

To get a look at the final version of your document, with all of the pagebreaks in
place, the footnotes correctly numbered, and so on, use the menu View and choose a
file type. A viewing program will pop up showing the output. For View>DVI you can

use the toolbar button (shortcut Ctrl+D), for View>PDF (pdflatex) the toolbar

button -}LD , and for View> Postscript the toolbar button (shortcut Ctrl+T).

If you have changed your document, you can refresh the output in the same viewer
window using the menu View > Update.

When you preview a file, the output file is only generated in LyX’s temporary
directory. To have a real output, export your document.

3.8.4. Printing the File from within LyX

Instead of exporting your file and then printing it, you can also print it directly from
within IyX. To print a file, select the menu File> Print or click on the toolbar button

Cg. LyX will internally call IXTEX to produce a DVI. This file is then processed
by the program dvips to PostScript-file, which is finally printed using the program
Ghostscript. Due to these steps in the background, this method is not the fastest.

You can choose to print only even-numbered or odd-numbered pages — this is
useful for printing on two sides: You can re-insert the pages after printing one set to
print on the other side. Some printers spit out pages face-up, others, face-down. By
choosing a particular order to print in, you can take the entire stack of pages out of
the printer without needing to reorder them.

You can set the parameters in the Print Destination box as follows:
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Printer This is the name of the printer to print to.!® The printer should under-
stand PostScript.

File The name of a file to print to. The output will be a PostScript file. It will
be written in IxX’s working directory unless you specify the full path.

3.9. A few Words about Typography

3.9.1. Hyphens

In IyX, the “-” character comes in four lengths: the hyphen, the en dash, the em
dash, and the minus sign:

name output inserted with

hyphen - “=7in text

en dash - Insert > Special Character>Symbols
em dash — Insert > Special Characterr>Symbols
minus sign — “=” in math mode

w_»

You can alternatively generate the en and em dash by inserting the character
multiple times in a row. They will automatically be converted to the appropriate
length dash in the final output, but not in LyX. “--7 gives a en dash, “---7 a em
dash.

The three dash types are distinct from the minus sign, which appears in math mode

and has a length of its own. Here are some examples of the “~* in use:
1. line- and page-breaks (hyphen)
2. From A-7Z (en dash)
3. Oh — there’s a dash. (em dash)
4. 2% —y? = 22 (minus sign)

3.9.2. Hyphenation

Words aren’t hyphenated within [yX but automatically in the output. Hyphenation
is done by the IXTEX-package babel following the rules of the document language!.

ETEX hyphenates almost perfectly, it only has problems with text in the typewriter
font and with unusual constructs, like “h3knix/mOnOwall”. If BTEX can’t break

13Note that this printer name is for the program dvips. That means dvips has to be configured for
this printer name. The default printer can be set in LiyX’s preferences dialog, see section C.6.1.

4For German readers: That’s one of the main differences between the languages German and
German (new spelling) in the Document>Settings dialog.
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a word correctly, you can set hyphenation points manually. This is done with the
menu Insert > Formatting > Hyphenation Point. These extra hyphenation points are only
recommendations to IXTEX. If no hyphenation is necessary, IXTEX will ignore them.

Sometimes you want to prevent words or constructs to be hyphenated. Imagine
that you are describing keybindings/shortcuts in your document in the form “A-b
¢”. IXTEX would then see the hyphen “-” as hyphenation possibility. Hyphenating at
this point would look ugly. To prevent the shortcut from being hyphenated, you can
put it into the argument of the IXTEX-box-command \mbox, because text within
[XTEX-boxes can’t be hyphenated. As Iy X doesn’t support \mbox, you have to use
TEX Code. The result looks in IyX like:

wbox{ A-bc }
To learn more about TEX Code, have a look at section 6.10.

3.9.3. Punctuation Marks
3.9.3.1. Abbreviations and End of Sentence

When LyX calls ETEX to generate the final version of your document, KTEX au-
tomatically distinguishes between words, sentences, and abbreviations. KEIEX then
adds the “appropriate amount of space”. That means sentences get a little bit more
space between the period and the next word. Abbreviations get the same amount of
space after the period as a word uses.

Unfortunately, the algorithm for figuring out what’s an abbreviation does not work
in all cases. If a “.” is at the end of a lowercase letter, it’s the end of a sentence; if
it’s at the end of a capitalized letter, it’s an abbreviation.

Here are some examples of correct abbreviations and the end of a sentence:
o M. Butterfly
e Don’t worry. Be happy.
And here’s an example of the algorithm going wrong:
e e.g. this is too much space!
e This is I. It’s okay.

You won’t see anything wrong until you view a final version of your document.
To fix this problem, use one of the following:

1. Use an Inter-word Space after lowercase abbreviations (see section 3.5.2.1).
2. Use a Thin Space between two tokens of an abbreviation (see section 3.5.2.2).

3. Use an End of sentence period found under the Insert>Special Character menu
to force the use of inter-sentence spacing. This function is also bound to Ctrl4.
for easy access.
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With the corrections, our earlier examples look like this:
e e.g. this is too much space!
o This is I. It’s okay.

Some languages don’t use extra spacing between sentences. If your language is such
a language, you don’t need to worry, because IXTEX will take care of this.

For those that do need to bother, there is help to catch those sneaky errors: Check
out the Check TEX feature described in section Checking TEX of the Additional Fea-

tures manual.

3.9.3.2. Quotes

LyX usually sets quotes correctly. Specifically, it will use an opening quote at the
beginning of quoted text, and use a closing quote at the end. For example, “open
close”. The keyboard character, ", generates this automatically.

You can change the behavior of the " key using the submenu Language of the dialog
Document > Settings dialog.

You can also select quotes for different languages in the box Type option. There
are six choices:

“Text" Use quotes like this “double” or ‘single’
"Text" Use quotes like "this” or ’this’
,» lext” Use quotes like ,,this“ or ,this’
,» lext” Use quotes like ,,this” or ,this’
« Texty Use quotes like «this» or <this»
» Text« Use quotes like »this« or »this«

These settings affect what character the " key produces.

3.9.4. Ligatures

It is standard typesetting practice to group certain letters together and print them
as single characters. These groups are known as ligatures. Since IXTEX knows about
ligatures, your documents will contain them too in the output. Here are the standard
ligatures:

o ff
o fi
o fl

51



3. LyX Basics

o fii
o fil

Some languages uses other ligatures if the document font supports them.

Sometimes, you don’t want a ligature in a word. While a ligature may be okay in
the word, “graffiti,” it looks really weird in compound words, such as “cufflink” or
the German “Dorffest.” To break a ligature, use Insert>Formatting> Ligature Break.
This changes “cufflinks” to “cufflinks” and “Dorffest” to “Dorffest”.

3.9.5. LyX’s Proper Names

You will certainly have noticed that the word “IXTEX” always appears with characters
in different sizes and heights. KTEX is the name of the program used by LyX and is
therefore recognized as a proper name when you type it in Iy X as “LaTeX”. Note the
order of the upper-and lowercase letters! Ly X recognizes the following proper names:

LyX The name of the game, write “LyX” to produce it.

TEX The program used by KIEX, write “TeX” to produce it.

BTEX The program used by LyX, write “LaTeX” to produce it.

BTEX 2¢ The actual version of ITEX, write “LaTeX2e” to produce it.

You might wonder why the ITEX-version is “2¢”. It’s an old tradition in the TEX-
world to give programs geek version numbers. For example the version number of
TEX converges to the number 7: The actual version is “TEX-3.141592”, the previous
one was “TEX-3.14159".

If you don’t want to use proper names, e. g. in section headings, you can insert two

empty braces in TEX Code in the word. This will look in IyX like: T&T 1} X
For more about TEX Code, look at section 6.10.

3.9.6. Units

Generally the space between units and the number is smaller than the normal space
between two words. As you can see in the example below, it looks better when the
space is smaller. To get such a “half space” for units use the menu Insert > Formatting
Thin Space (shortcut Ctrl+Shift+Space).
Here’s an example to show the differences:
24 kW-h space between number and unit
24kW-h half space between number and unit
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3.9.7. Widows and Orphans

In the early days of word processors, page breaks went wherever the page happened
to end. There was no regard for what was actually going on in the text. You may
remember once printing out a document, only to find the heading for a new section
printed at the very bottom of the page, the first line of a new paragraph all alone at
the bottom of a page, or the last line of a paragraph at the top of a new page. These
bits of text became known as widows and orphans.

Clearly, LyX can avoid breaking pages after a section heading. That’s part of the
advantage of paragraph environments. But what about widows and orphans, where
the page breaks leave one line of a paragraph all alone at the top or bottom of a page?
There are rules built into BTEX governing page breaks, and some of those rules are
there to specifically prevent widows and orphans. This is the advantage LyX has in
using KTEX as its backend.

There’s no way we can go into how TEX and IXTEX decide to break a page, or how
you can tweak that behavior. Some IXTEX books listed in the bibliography [such as [1]
or [2]] may have more information. You will almost never need to worry about this,
however.
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4. Notes, Graphics, Tables, and
Floats

The issues of this chapter are described in detail in the Embedded Objects manual.
There you’ll also find tips and tricks for special cases.

4.1. Notes

LyX offers you a few types of notes to add to your document:

LyX Note This note type is for internal notes that won’t appear in the output.

Comment This note also doesn’t appear in the output but it appears as IXTEX-

comment, when you export the document to KTEX via the menu File> Export >
KTEX (pdflatex) / (plain).

Greyed Out This note will appear in the output as grey text.
This is text! of a comment that appears in the output as grey text.

As you can see in the example, the first line of greyed out notes is a bit in-
dented and greyed out notes can have footnotes.

Notes are inserted with the toolbar button or the menu Insert>Note. Right-click
on the appearing note box to select the note type.

4.2. Footnotes

ILyX uses boxes to display footnotes: When you insert a footnote using the menu

Insert > Footnote or the toolbar button L=_, you’ll see the following box: foot 1 hjs
box is IyX’s representation of your footnote. If you left-click on the “foot” label,
the box will be opened and you can enter the footnote text into it. Clicking on the

IThis is an example footnote within a greyed out note. In this document the greyed out note color
is redefined to blue. How this can be done is explained in the Embedded Objects manual.
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box label again, will close the box. If you want to turn existing text into a footnote,
simply mark it and click on the footnote toolbar button.

Here’s an example footnote:?

The footnote will appear in the output as a superscript number at the text position
where the footnote box is placed. The footnote text is placed at the bottom of the
current page. The footnote number is calculated by IyX, the numbers are consecutive,
no matter in which chapter the footnote is in. IyX doesn’t support other numbering
schemes yet, but you can get another scheme using special IXTEX-commands. They
are described in the Embedded Objects manual.

4.3. Marginal Notes

Marginal notes look and behave just like footnotes in Iy X. When you insert a mar-

gin note via the menu Insert>Marginal Note or the toolbar button i__L you’ll see a
grey box with a red label “margin” appearing within your text. This box is LyX’s
representation of your marginal note.

At the side is an example marginal note.

Marginal notes appear at the right side in single-sided documents. In double-sided
documents they appear in the outer margin — left on even pages, right on odd pages.

4.4. Graphics and Images

To insert an image in your document, place the cursor at the text position you want

and click on the toolbar icon = or select Insertr> Graphics from the menu. Then a
dialog will appear to choose the file to load.

This dialog has numerous mostly self-explanatory parameters. The Graphics tab
allows you to choose your image file. The image can be transformed by setting a
rotation angle and a scaling factor. The scaling units are explained in Appendix D.

In the tab Clipping it is possible to set image coordinates to adjust the height and
width of the image in the output. The coordinates can also be calculated automati-
cally by pressing the button Get from file. The option Clip to bounding box will only
print the image region within the given coordinates. Normally you don’t need to take
care about image coordinates and can ignore the tab Clipping.

In the BTEX and LyX options tab IXTEX experts can specify additional IXTEX op-
tions. You can also specify here the appearance of the image inside IiyX. The option
Draft mode has the effect that the image doesn’t appear in the output, only a frame
with the image size is printed. The option Don’t unzip on export is explained in the
Embedded Objects manual in section Graphics Dialog.

2To close a footnote, click on the footnote box label.
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4.4. Graphics and Images

The graphics dialog can be called at any time by clicking on an image. The image
will appear in the output exactly at the position where it is in the text. This is an
example image within a separate, horizontally centered paragraph:

If you need image captions and want to reference images, you have to put the image
into a float, see section 4.6.1.1.

4.4.1. Image Formats

You can insert images in any known file format. But as we explained in section 3.8.2,

every output document format allows only a few image formats. LyX uses therefore

the program ImageMagick in the background to convert the images to the right

format. To increase your workflow by avoiding these conversions in the background,

you can use only the image formats listed in the subsections of section 3.8.2.
Similar to fonts there are two types of image formats:

Bitmap images consist of pixel values, often in a compressed form. They are there-
fore not fully scalable and look pixelated in large zooms. Well-known bitmap
image formats are “Graphics Interchange Format” (GIF, file extension “.gif”),
“Portable Network Graphics” (PNG, file extension “.png”), and “Joint Photo-
graphic Experts Group” (JPG, file extension “. jpg” or “. jpeg”).

Scalable images consist of vectors and can therefore be scaled to any size without

data loss. The scaling ability is necessary if you want to create presentations,
because presentations are always scaled by the beamer. Scaling is also useful
for online documents to let the user zoom into diagrams.
Scalable image formats can be “Scalable Vector Graphics” (SVG, file extension
“.svg”), “Encapsulated PostScript” (EPS, file extension “.eps”), and “Portable
Document Format” (PDF, file extension “.pdf”). We say it can be, because
you can convert any bitmap image format to PDF or EPS and the result won'’t
be scalable. In this cases only a header with the image properties is added to
the original image?.

Normally one can’t convert a bitmap image into a scalable one, only vice versa.

3In the case of PDF, the original image is additionally compressed.

o7



4. Notes, Graphics, Tables, and Floats

4.4.2. Grouping of Image Settings

Each image can define a new group of image settings or join an existing group.
Images within such a group share their settings, so adjusting one image of the group
automatically also adjusts all other images of the group in the same way. So you
can for example change the size for a bunch of images without the need to manually
change each of them.

A new group can be set by entering a name in the Group Name field in the Graphics
dialog. Joining an existing group can be done using the context menu of the image
by checking the name of the desired group.

4.5. Tables
=23

You can insert a table using either the toolbar button "= or the menu Insertr> Table.
A dialog will appear, asking you for the number of rows and columns. The default
table has lines around any cell and the first row appears separated from the rest of
the table. This separation appears due to a double line: The cells of the first row
have a line below them and the cells of the second row have a line above them. Here’s
an example table:

4.5.1. The Table dialog

You can alter a table by clicking on it with the right mouse button, which brings
up the table dialog. Here you can adjust the settings of the cell and row/column
respectively where the cursor is placed currently. Most of the dialog options also
work on selections. This means that if you select more cells, columns or rows the
action is done on all of your selection.

Additionally to the table dialog, the table toolbar helps you in setting table prop-
erties. It appears when the cursor is inside a table.

In the tab Table Settings of the table dialog you can set the alignment for the
current row. If you add a row or column, it will be inserted right beside or below the
current cell respectively. The vertical alignment of a column can only be adjusted
when a column width is given. A given width will allow the cell to have line breaks
and multiple paragraphs of text, see section 4.5.3.

You can mark multiple cells of one row as a multicolumn cell using the check box
Multicolumn. This will merge the cells to one cell, spread over more than one column.
Multicolumn cells are treated as own rows, so that the alignment, width, and border
settings affect only the multicolumn cell. Here’s an example table with a multicolumn
cell in the first row and one in the last row without the upper border:
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4.5. Tables

] abc \ def ghi \ jkl ‘
A |B|C|D
1 123 | 4

At the moment [y X doesn’t support multirow cells. Adept users can declare special
KETEX-arguments for the table. They are necessary for special table formatting, like
for multirow cells, explained in the tables section of the Embedded Objects manual.
You can also rotate the current cell or the whole table 90 degrees counterclockwise.
These rotations are not visible in IyX but in the output.

Note: Most DVI-viewers are not able to display rotations.

The Borders tab allows you to add and delete border lines for the current row/column.
The button Default adds lines for all cell borders.

4.5.2. Longtables

If the table is too long to fit on one page, you can use the option Use long table in
the tab Longtable of the table dialog to split the table automatically over more pages.
Doing this enables some check boxes and you can now define:

Header: The current row and all rows above, that don’t have any special options
defined, are defined to be the header rows of all pages of the longtable; except
for the first page, if First header is defined.

First header: The current row and all rows above, that don’t have any special options
defined, are defined to be the header rows of the first page of the longtable.

Footer: The current row and all rows below, that don’t have any special options
defined, are defined to be the footer rows of all pages of the longtable; except
for the last page, if Last footer is defined.

Last footer: The current row and all rows below, that don’t have any special options
defined, are defined to be the footer rows of the last page of the longtable.

Caption: The first row is reset as single column. You can now insert there the table
caption via the menu Insertr> Caption. More about longtable captions can be
found in the Embedded Objects manual.

You can also specify a row where the table is split. If you set more than one option in
the same table row, you should be aware of the fact that only the first one is used in
the given table row. The others will then be defined as empty. In this context, first
means first in this order: Footer, Last footer, Header, First header. See the following
longtable to see how it works:
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60

Example Phone List (ignore the names)

NAME TEL.

Annovi Silvia 111
Bertoli Stefano 111
Bozzi Walter 111
Cachia Maria 111
Cachia Maurizio 111
Cinquemani Giusi 111
Colin Bernard 111
Concli Gianfranco 111
Dal Bosco Carolina 111
Dalpiaz Annamaria 111
Feliciello Domenico 111
Focarelli Paola 111
Galletti Oreste 111
Gasparini Franca 111
Rizzardi Paola 111
Lassini Giancarlo 111
Malfatti Luciano 111
Malfatti Valeriano 111
Meneguzzo Roberto 111
Mezzadra Roberto 111
Pirpamer Erich 111
Pochiesa Paolo 111, 222
Radina Claudio 111
Stuffer Oskar 111
Tacchelli Ugo 111
Tezzele Margit 111
Unterkalmsteiner Frieda 111
Vieider Hilde 111
Vigna Jirgen 111
Weber Maurizio 111
Winkler Franz 111
Annovi Silvia 555
Bertoli Stefano 555
Bozzi Walter 555
Cachia Maria, 555
Cachia Maurizio 555
Cinquemani Giusi 555
Colin Bernard 555
continue ...




Example Phone List

NAME TEL.
Concli Gianfranco 555
Dal Bosco Carolina 555
Dalpiaz Annamaria 555
Feliciello Domenico 555
Focarelli Paola 555
Galletti Oreste 555
Gasparini Franca 555
Rizzardi Paola 555
Lassini Giancarlo 555
Malfatti Luciano 555
Malfatti Valeriano 555
Meneguzzo Roberto 555
Mezzadra Roberto 555
Pirpamer Erich 555
Pochiesa Paolo 555, 222
Radina Claudio 555
Stuffer Oskar 555
Tacchelli Ugo 555
Tezzele Margit 555
Unterkalmsteiner Frieda 555
Vieider Hilde 555
Vigna Jurgen 999
Weber Maurizio 555
Winkler Franz 555
End

4.5.3. Table Cells

4.5. Tables

A table cell can contain text, inline equations, a figure, or another table. All these
kinds of objects can be placed in the same cell. Font sizes and shapes can also be
altered. But you can’t put a special environment in a cell (like Section*, etc.), nor
set spacing options etc. for the cell’s paragraph.

To have multi-line entries in table cells, you have to declare a fixed width for the
column in the table dialog. Your text is then automatically split into multiple lines
and the cell is enlarged vertically when the length of the text exceeds the given width.
An example:
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1 2 3
4 | This is a multi- | 5
line entry in a

table.
6 | This is longer | 7
NOw.

8 | This is a multi- | 9
line entry in a
table.  This is
longer now.

Cutting and pasting between tables and table cells works reasonably well. You can
cut and paste even more than one row.* Selection with the mouse or with Shift plus
the arrow keys works as usual. You can also copy and paste the entire table as a
single unit by starting the selection from outside the table.

4.6. Floats

A float is a block of text associated with some sort of label, which doesn’t have a
fixed location. It can “float” forward or backward a page or two, to wherever it fits
best. Footnotes and Margin Notes are also floats, because they can float to the next
page when there are too many notes on the page.

Floats make it possible to get a high quality layout. Images and tables can be
spread evenly over the pages to avoid whitespace and pages without text. As the
floating often destroys the context between the text and the image/table, every float
can be referenced in the text. Floats are therefore numbered. Referencing is described
in section 6.1.

To insert a float, use the menu Insert>Floats. A box with a caption that has e.g.
the label “Figure #:” (# is the actual number) will be inserted into your document.
The label will automatically be translated to the document language in the output.
After the label you can insert the caption text. The image or table is inserted above
or below the caption in a separate paragraph within the float. To keep your LyX-
document readable, you can open and close the float box by left-clicking on the box

label. A closed float box looks like this: 128 Figure gray button with a red label.

It is recommended to insert floats as a separate paragraph to avoid possible KTEX-
errors that can occur when the surrounding text is specially formatted.

4Note, that you cannot paste into a multicell selection because it would not be clear what to do
when pasting a single word in a selected 2x3.
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Figure 4.1.: A severely distorted platypus in a float.

Figure 4.2.: M.C. Escher on acid.

4.6.1. Float Types
4.6.1.1. Figure Floats

The menu Insert>Float> Figure inserts a float with the label “Figure #:”. Set the
cursor above this label (or before it and press enter) and insert the image as described
above to get the caption printed below the image. This is what we did for Figure 4.1.
If you want the caption to be above the image, set the cursor at the end of the caption,
press enter and insert the image. This was done in Figure 4.2.

This figure float also shows how to set a label and create a cross-reference to it. As
described in section 6.1, you can simply insert a label in the caption using the menu
Insert>Label and refer to it using the menu Insert> Cross-Reference. It is important
to use references to figure floats, rather than using vague references like “the figure
above”, because as KTEX will reposition the floats in the final document; it might
not be “above” at all.

Normally only one image is inserted in a figure float, but sometimes you might
want to use two images with separate subcaptions. This can be done by inserting
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(a) Undefinable (b) Platypus

Figure 4.3.: Two distorted images.

Table 4.2.: A table float.

L2 3
Joe Mary Ted
[ 22dz ‘C‘ Z 1+1=2

image floats into existing image floats. Note that only the main caption of the float
is added to the List of Figures. Figure 4.3 is an example of a figure float with two
images set side by side. You can also set the images one below the other. Figure 4.3a
and 4.3b are the subfigures.

Note that the caption is added to the List of Figures as described in section 6.2.2.

4.6.1.2. Table Floats

Table floats can be inserted using the menu Insert > Float> Table. They have the same
properties as figure floats except for the different label. Table 4.2 is an example of a
table float.

4.6.1.3. Algorithm Floats

This float type is inserted with the menu Insert> Float> Algorithm. It is used for
program codes and descriptions of algorithms. A possible environment for algorithms
is the LyX-Code, described in section 3.3.9.

Note: that the float label is not automatically translated into the document
language. You have to do this manually by adding the following line
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\floatname{algorithm } {your name}
to the document preamble (menu Document>Settings). your name is the word
“algorithm” in your language.

4.6.1.4. Wrap Floats

This float type is used if you want to “wrap” text
around a figure so that it only occupies some frac-
tion of the column width. It can be inserted using
the menu Insert> Float>Wrap Float if the ETEX-
package wrapfig is installed.” The width and
placement of the float is adjusted by right-clicking
on the float box. Figure 4.4 is for example a fig-
ure wrap float with a width of 40col%.® Some
space was added under the caption to separate it
better from the surrounding text.

Note: Wrap floats might be fragile! E. g. having a figure too close to the bottom
of the page can mess things up so that the float doesn’t appear in the output or that
it is placed over some other text. In general:

Figure 4.4.: This is a wrapped fig-
ure.

o Wrap floats should not be placed in paragraphs that run over a page break.
That means that wrap floats should preferably be inserted in the exact place
when the document is nearly ready and you are able to estimate where page
breaks will appear.

o Wrap floats should either be placed in their own paragraph before the paragraph
where they should wrap into, or within a paragraph.

o Wrap floats in consecutive paragraphs may cause trouble, so make sure that
there is a text paragraph between them as separator.

o Wrap floats are not allowed in section headings or tables.

4.6.2. Rotated Floats

Especially for wide tables you might have floats rotated. To rotate a whole float
including the caption, right-click on the float-box and use the option Rotate sideways.

Rotated floats are always placed on their own pages (or columns, when you have
a multicolumn document). You can let them span several columns using the float
settings option Span columns. Floats are rotated so that you can read them from the
outside margin. Forcing the rotation direction is explained in the Embedded Objects
manual.

SInstalling a IXTX-package is explained it in the BTpX Configuration manual.
6 Available units are explained in Appendix D.
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Referencing rotated floats is the same like for normal floats; the caption format is
also the same: Table 4.3 is an example of a rotated table float.
Note: Not all DVI-viewers are able to display rotated floats.

4.6.3. Float Placement

Right-clicking on a float-box opens a dialog where you can alter the placement options
that IXTEX uses for positioning the float.
The option Span columns is only useful for two-column documents: If you select it,
the float will span both columns on the page instead of being confined to just one.
The option Rotate sideways is used to rotate floats, see section 4.6.2.

You can use one ore more of the following options in the float dialog to set the
placement for a particular float when you uncheck the option Use default placement:

Here if possible: try to place the float at the position where it is inserted
Top of page: try to place the float at the top of the current page
Bottom of page: try to place the float at the bottom of the current page
Page of floats: try to place the float at an own page

The order of the above option is always used by I¥TEX. That means, if you use the
default placement, IXTEX will first try out Here if possible, then Top of page, and then
the others. If you don’t use the default, B'TEX will try only the checked options but
in the same order. If none of the 4 placements are possible the procedure is internally
repeated but it is tried to put the float on the following page.

By default, each option has its own rules:

Top of page only floats occupying less than 70 % of the page can be placed at the
top of a page

Bottom of page: only floats occupying less than 30 % of the page can be placed at
the bottom of a page.

Page of floats: only if more than 50 % of the page are occupied by floats, several
floats can be set together on a page.

If you don’t like these rules, you can ignore them by using the additional option
Ignore IXTEX rules.

Sometimes you might need, under all circumstances, a float to be placed exactly at
the position where it is inserted. For this case you can use the option Here definitely.
Use this option very rarely and only if the document is nearly ready to be printed.
Because the float is then no longer able to “float” when you change your document,
this will often destroy the page layout.

There are no placement options for text wrap floats, because they are always sur-
rounded by the text of a certain paragraph.

For more details about float placements, have a look at BTEX books like [1, 2, 3].
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4.7. Minipages

KETEX provides a mechanism to produce essentially a page within a page, called mini-
page. Within a minipage, all the usual rules of indentation, line wrapping, etc. apply.

Minipages in [yX have their own collapsible box inserted via the menu Insert>
Box. Right-clicking on the box allows you to alter the width of the minipage and its
alignment within the page.

This is a minipage. The
text is set in an italic
style.

Minipages are often used
for text in another lan-
guage or text that needs
another formatting.

If you place two minipages side-by-side, you can use Horizontal Fills as described in
section 3.5.2:

This is a minipage This is a minipage
with some stupid with some stupid
dummy text. This dummy text. This
dummy text is used dummy text is used
to increase the size to increase the size
of the minipage. of the minipage.

When you right-click on a minipage box, you can change the box from a minipage
to other box types. All box types and their settings are explained in detail in chapter
Bozxes of the Embedded Objects manual.

68



5. Mathematical Formulas

The issues of this chapter are described in detail in the Math manual. There you’ll
also find tips and tricks for special cases.

5.1. Basic Math Editing

a+b
To create a math formula, you can just click on the toolbar icon € . That will create

a little blue rectangle, with purple markers around its corners. That blue rectangle
is the formula itself; the purple markers indicate what level of nesting within the
formula you are at. You can also choose a particular formula type to insert via the
Insert > Math menu.

Editing the parameters of a formula and adding math constructs can be done with
the math toolbar, that appears when the cursor is in a formula.

There are two main types of formulas: Inline formulas appear within a text line,
like this one:

This is a line with an inline formula A = B in it.

Displayed formulas appear outside the text like as if they were in an own paragraph,
like this one:

A=DB

You can only number and reference displayed formulas.

LyX supports also many KTEX math commands. E.g. typing “\alpha”, followed
by a space, in a formula will create the Greek letter av. So typing commands might
sometimes be faster than using the Math Panel.

5.1.1. Navigating in Formulas

The best control over the cursor position within an existing formula is achieved with
the arrow keys. LyX uses small rectangles to indicate places where something can
be inserted. The arrow keys can be used to navigate between parts of a formula.
Pressing Space will leave a formula construct (a square root V2, or parentheses (f),

or a matrix . Pressing Escape will leave the formula, placing the cursor after

1 2

3 4 )
the formula. Tab can be used to move horizontally in a formula; for example, through
the cells of a matrix or the positions in a multi-line equation.

Space, printed in this document as “ ", seems to do nothing in a formula, since it
does not add a space between characters, but it does exit a nested structure. For this
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5. Mathematical Formulas

reason, you have to be careful about using Space. For example, if you want /2x + 1,
type \sqrt ,2x+1 and not \sqrt 2x,,+1, since in the latter case only the 2z will
be under the square root sign: v/2z + 1.

You can leave many parts of a formula, like this matrix, partially filled in, such as:

A1

An

If you leave a fraction only partially filled in, or a subscript with nothing in it, the
results will be unpredictable, but most constructs don’t mind.

5.1.2. Selecting Text

You can select text within a formula in two different ways. Place the cursor at one
end of the string of text you want, and press Shift and a cursor movement key to
select text. It will be highlighted as with regular text selection. Alternatively, you
can select text with the mouse in the usual way. That text can then be cut or copied,
and then pasted within any formula, but not in a normal text region in [yX.

5.1.3. Exponents and Subscripts

You can use the math panel to add super- or subscripts, but the much easier way
is to use a command. To get x2, type in a formula x~2, . The final Space puts the
cursor back down on the base line of the expression. If you type x~ 2y, you will get
%Y, to get 2y, type X 2_y. If you use characters in the superscript, that could be
accented with the hat “7”, you have to use an extra Space to separate the hat and
the character. E.g. if you want 2 type x _a. Subscripts are similar: To get aq,
type a_ 1.

5.1.4. Fractions

a
Create a fraction with either the command \ frac or using the icon b in the Math Panel.
You will be presented with an empty fraction. The cursor is above the fraction line.
To move it to the bottom, simply press Down. To move back up, press Up. Any math
structure can be placed in a fraction, as this example shows:
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5.1.5. Roots

Roots can be created using the Math Panel button¥O or the commands \sqrt or
\root. With the command \root you can produce roots of higher orders, like cube
roots, while \sqrt produces always a square root.

5.1.6. Operators with Limits

Sum (3°) and integral () operators are very often decorated with limits. These limits
can be entered in IyyX by entering them as you would enter a super- or subscript,
directly after the symbol. The sum operator will automatically place its “limits” over
and under the symbol in displayed formulas, and on the side in inline formulas. Such
as y..2, % = e, Versus

<1

)

—n!
Integral signs, however, will place the limits on the side in both formula types.

All operators with limits will be automatically re-sized when placed in display
mode. The placement of the limits can be changed by placing the cursor directly
behind the operator and hitting Alt+M L or using the menu Edit>Math > Change Lim-
its Type.

Certain other mathematical expressions have this “moving limits” feature as addi-
tion, such as

lim f(x),

which will place the z — oo underneath the “lim” in display mode. In inline formulas
it looks like this: lim, ., f(x).

Note that the lim-function was entered as the function macro \lim. Have a look
at section 5.1.9 for an explanation of function macros.

5.1.7. Math Symbols

Most math symbols can be found in the Math Panel under one of several categories;
including Greek, Operators , Relations, Arrows. There are also the additional symbols
provided by the American Mathematical Society (AMS).

If you know the BIEX-command for a construct or symbol you wish to use, you
don’t have to use the Math Panel, but can type the command directly into the formula.
LyX will convert it to the corresponding symbol or construct.

5.1.8. Altering Spacing
You may want to create spaces that differ from the standard spacing that IXTEX

provides. To do this, type Ctrl+Space or to use the Math Panel button ™*. This
generates a small space, and shows a small marker on the screen. For example, the
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Table 5.1.: Accent names and the corresponding commands.

’ Name ‘ Command ‘ Example ‘

circumflex \hat a
grave \grave a
acute \acute a
umlaut \ddot a
tilde \tilde a
dot \dot a
breve \breve a
caron \ check a
macron \bar a
vector \vec a

sequence a Ctrl4-Space b: ab appears in [yX as o . You can change the space
to different sizes when you set the cursor behind the space marker and hit space
again several times. With every space hit the size will be changed. Some markers
for the space size appear red in IyX, because they are negative spaces. Here are two
examples:

a Ctrl4+Space b and 3xSpace: a b

a Ctrl+Space b and 5xSpace: d

5.1.9. Functions

P
The Math Panel contains under the button tati a number of function macros, such

as sin, lim, etc. (you can also insert them in a formula by typing \sin etc.). Stan-
dard mathematical practice is, that functions are printed upright to avoid confusions,
because sin does normally mean s -7 - n.

Using the function macros will also produce correct spacing around the function:
asin x is different from asinx

For some mathematical objects, like the limes, the macro changes where subscripts
are placed, as described in section 5.1.6.

5.1.10. Accents

In a formula you can insert accented characters in the same way as in text mode.
This may depend on your keyboard, or the bindings file you use. You can also
use KIEX commands to e.g. enter a even if your keyboard doesn’t have hat-accents
enabled. Our example is entered by typing \hat_ a in a formula. Table 5.1 shows
the equivalences between the accent names and the commands.

You can choose one of the accents by selecting an item from the Frame decorations

symbol set button i..i in the math panel ; this will apply to any selection you have
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made within a formula too.

5.2. Brackets and Delimiters

There are several brackets available through IyX. For most purposes, using just the
keys [J{}() |<> should suffice. But if you want to surround a large structure, like a
matrix or a fraction, or if you have several layers of brackets, it is better to use the

math toolbar delimiter icon "]] For example, that’s how you would construct the
brackets around a standard matrix such as:

5

and to make it easier to see the layers of parentheses as in:

1

1+ ()

The parentheses, and other brackets from that menu will automatically re-size to
accommodate the size of what is inside.

To construct brackets click on the button for the bracket you want on the left side
and right side. If you use the option Keep matched, the selected bracket type will be
used for the left and the right side. The selection will be shown below the button
field. If you want one side to not have a bracket, use the blank button. It will appear
in LyX with a dotted line, but nothing will be printed.

If you want to place brackets around math structures, like a square root, you can do
that by highlighting (selecting) the structure that is to go inside the brackets. Then
choose the appropriate brackets for left and right and click on Insert. The parentheses
will be drawn around the selected structure.

5.3. Arrays and Multi-line Equations

ooo
Matrices are entered in LyX using the Math Panel matrix button BEE | It will open a
dialog for you to choose the number of rows/columns. Here is an example:

S S
co Ot N
© o w

The parentheses aren’t automatic, but you can add them as described in section 5.2.
When you construct the matrix, you can decide whether the column entries will be
left-, right-, or center-justified. This alignment is set in the box Horizontal with the
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letters “I”, “r”, and “c”. LiyX proposes a “c” for every column as default. For example,
the sequence “Irc” means that the first column will be left-justified, the second will be
centered, and the third column will be right-justified, because each letter corresponds
to the relevant column. The result will look like this:

this this column this column
column has hasright .
hasleftalignment center alignment  alignment

You can add more rows to an existing matrix by hitting Ctrl+Return while the
cursor is in the matrix. Adding or deleting columns can be done via the menu Edit>
Math or the math toolbar.

There are other arrays used in formulas, such as distinctions of cases. It can be
created with the menu Insert>Math>Cases Environment or the command \cases.
Here is an example:

-1 =<0
flx)=40 =0
1 x>0

Multi-line formulas are created when you press Ctrl4+Return within a formula. In
an empty formula you can see that three blue boxes appear, one for each column.
When you press Ctrl+Return in a non-empty formula, the part before the relation
sign (equal sign “=" etc.) will be inserted automatically to the first column, the
relation sign is in the second column, and the rest in the third column. A new row is
created by every further hit of Ctrl4+-Return. Multi-line formulas are always displayed
formulas. Here is an example:

a> = (B*+ A0 -A)
a = Vbt—ct (5.1)

To change the column assignment of the formula parts, place the cursor where you
want to start the shift and hit Ctrl-Tab. It shifts everything in the column which is
right beside the current cursor position to the next column. Note that the middle
column is designed for relation signs, structures within this column will be printed in
a smaller size:

A

B

A

B

S/

The multi-line formula type described here is called eqnarray. There are other
multi-line types being more suitable for certain situations, for example if you want
a better inter-line spacing than in formula (5.1). The other types are described in
section 5.8.2.
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5.4. Formula Numbering and Referencing

To number a formula, set the cursor in the formula and use the menu Edit>Math>
Toggle Numbering or the shortcut Alt+M N. The formula number appears in LyX
as “#” within parentheses. The “#” denotes, that the number will be calculated
automatically when the output is generated. The placement and format of the formula
number in the output depends on the document class. In this document the number
is printed together with the chapter number, separated by a dot:

1+1=2 (5.2)

Using Alt+M N in a numbered formula will switch off the numbering. You can only
number displayed formulas.

Multi-line formulas can be numbered line by line: Using the menu Edit>Math>
Toggle Numbering of Line or the shortcut Alt+M Shift+N will only toggle the num-
bering of the line where the cursor is:

= 3-2 (5.3)
2 = 4-2
< 7 (5.4)

To number all lines use the shortcut Alt+M N.

Every displayed formula can be referenced by its number using a label. A label is
inserted with the menu Insert>Label when the cursor is in the formula. This opens a
dialog to enter the label. It is recommended to use the proposed “eq:” as first part
of the label, because this helps later to identify the label type when you have many
labels in your document. We inserted in the following example the label “eq:tanhExp”
in the second line:

sinh(z)
cosh(x)
e? —1

= = 2.5

tanh(z) =

Every labeled line is automatically numbered. Therefore the label is shown in [yX
at the place of the formula number placeholder “#”. You can reference a labeled
formula using the menu Insert> Cross Reference. A dialog appears to choose a label
you want refer to. The reference appears in [yX as a grey cross reference box and in
the output as the formula number:

This is a cross-reference to equation (5.5).

The properties of IiyX’s cross-reference box are described in section 6.1. To delete
a label, set the cursor in the labeled formula, use the menu Insert>Label and delete
the label in the appearing dialog.

1This is a unintuitive and will be fixed in the next version of Ly X.

75



5. Mathematical Formulas

Table 5.2.: Typefaces and the corresponding commands.

’ Font ‘ Command ‘
Roman \mathrm
Bold \mathbf
Italic \mathit
Typewriter \mathtt
BLACKBOARD \mathbb
Srattur \mathfrak
CALLIGRAPHIC | \mathcal
SansSerif \mathsf

5.5. User defined math macros

LyX allows you to define macros for formulas which is very useful when you have
equations of the same form in a document several times. Math macros are explained
in section Math Macros of the Math manual.

5.6. Fine-Tuning
5.6.1. Typefaces

The standard font for text is italic, for numbers the standard is roman. To set a

R~
font in a formula, use the Math Panel button FIfl, or enter its command, listed in

table 5.2, directly.
Note: You can only print capital letters in the typefaces Blackboard and Calli-
graphic.

When you use a typeface, a blue box is inserted in the formula. Every character in
this box will be printed in this typeface. Pressing Space within the box, will set the
cursor outside, so that you have to use a protected space when you need a space in
the box. Here an example where “N” in Blackboard denotes the set of numbers:

f)=vVz;zeN

The typefaces are nestable, which can cause confusion. You can e. g. put a character
in Fraktur in a box for Typewriter: abcde
So it is better not to use this feature.

The typefaces have no effect on Greek letters: abcde
You can only print them emboldened using the command \boldsymbol, which works
like the other typeface commands: afSvya B~y

\boldsymbol works for all symbols, letters, and numbers.

A number of other font options are available as well, in the menu Edit>Math>
Text Style.
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5.6.2. Math Text

Typefaces are useful for entering some characters in some given font, but not for text.

For typing longer pieces of text use the math text, which is obtained using the entry
A~
Normal text mode of the Math Panel button Fifil (shortcut Alt+C Space). Math text

appears in LyX in black instead of blue. You can use spaces and accents in math text
like in normal text. Here is an example:

o) = {x if I say so

—z unter Umstidnden

5.6.3. Font Sizes

There are four font styles (relative sizes) used in math-mode, which are automat-
ically chosen in most situations. These are called textstyle, displaystyle, scriptstyle,
and scriptscriptstyle. For most characters, textstyle and displaystyle are actually the
same size, but fractions, superscripts and subscripts, and certain other structures,
are set larger in displaystyle. Except for some operators, which resize themselves to
accommodate various situations, all text will be set in the styles that IXTEX thinks

are appropriate. These choices can be overridden by using the math panel button
o
B A box for the size will be created in which you can insert the math structure.
1
29
The four styles are used in the following example:

1
For example, you can set 35, which is normally in textstyle, larger in displaystyle: 3

displaystyle, textstyle, scriptstyle, scriptscriptstyte.

All these math-mode font sizes are relative, that means, if the whole math inset is
set in a particular size with the menu Edit> Text Style, all sizes in the formula will
be adjusted relative to this size. Similarly, if the base font size of the document is
changed, all fonts will be adjusted to correspond. As an example here is a formula in
the font size “largest”:

_ oo 1
G—anom

5.7. Theorem Modules

As of IyX 1.6, support for theorem-like environments has been moved out of the
document classes and into layout modules. As a result, theorem-like environments
can now easily be used with classes other than the AMS classes. See section 3.1.2.2
for more on layout modules.
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5.8. AMS-ETEX

Iy X supports the packages provided by the American Mathematical Society (AMS)
that are in common use.

5.8.1. Enabling AMS-Support

Selecting the checkbox Use AMS math package in the Document > Settings dialog under
Math Options will include the AMS-packages in the document, and make the facilities
available. AMS is needed for many math-constructs, so when you get IXTEX-errors in
formulas, assure that you have enabled AMS.

5.8.2. AMS-Formula Types

AMS-IXTEX provides a selection of different formula types. Iy X allows you to choose
between align, alignat, flalign, gather, and multline. We refer to the AMS-
documentation for an explanation of these formula types.
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6.1. Cross-References

One of LyX’s strengths are cross-references. You can reference every section, float,
footnote, formula, and list in the document. To reference a document part, you have
to insert a label into it. The label is used as anchor and name for the reference. We
want for example to refer to the second item of the following list:

1. First item
2. Second item
3. Third item

First we insert a label into the second item with the menu Insert > Label or by pressing

the toolbar button @ A grey label box like this: BEThis-138 o 5 serted and the

label window pops up asking for the label text. IyX offers as text the first words
of the item with a prefix, in our case the text “enu: Second-item”. The prefix “enu:”
stands for “enumerate”. The prefix depends on the document part where the label is
inserted, e.g. if you insert a label into a section heading, the prefix will be “sec:”.
To reference the item, we refer to its label using the menu Insert> Cross-Reference

or the toolbar button tﬂ A grey cross-reference box like this: Ref. sec:Contrib g 5,
serted and the cross-reference window appears showing all the labels in the document.
We can now sort the labels alphabetically and then choose the entry “enu:Second-
item”. At the position of the cross-reference box the item number will appear in the
output.

Alternatively to Insertr Cross-Reference, you can right-click on a label and use in
the appearing context menu Copy as Reference. The cross-reference to this label is
now in the clipboard and can be copied to the actual cursor position via the menu
Edit> Paste (shortcut Ctrl+V).

Here is our cross-reference: Item 2

It is recommended to use a protected space! between the cross-reference name and
its number to avoid ugly line breaks between them.

There are six varieties of cross-references:

<reference>: prints the float number, this is the default: 4.3

ldescribed in section 3.5.1
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(<reference>): prints the float number within two parentheses, this is the style nor-
mally used to reference formulas, especially when the reference name “Equation”
is omitted: (5.5)

<page>: prints the page number: Page 64
on page <page>: prints the text "on page" and the page number: on page 64

<reference> on page <page>: prints the float number, the text "on page', and
the page number: 4.3 on page 64

Formatted reference: prints a self defined cross-reference format.
Note: This feature is only available when you have the BTEX-package pret-
tyref installed.

<page> will not print the page number if the label is on the previous, the same, or
the next page. You will e. g. see the text “on this page” instead. The style <reference>
on page <page> will not print anything about the page if the label is on the same
page.

The number and current page of the referenced document part in the output, is
automatically calculated by I¥TEX. The varieties are adjusted in the field Format of
the cross-reference window, that appear when you click on the cross-reference.

You can only use the style <reference> to reference numbered document parts,
while the reference style <page> is always possible.

If you want to reference a section, put the label in the section heading; for floats
put the label in the caption; for footnotes put the label in it. Referencing formulas is
explained in section 5.4.

Right-clicking on a cross-reference opens a context menu. The entry Go to Label
sets the cursor before the referenced label. This entry will be renamed in the context
menu of the label to Go Back so that you can use it to set the cursor back to the

cross-reference. You can also go back with the toolbar button ﬁ

You can change labels at any time. References to the changed label will automat-
ically be updated so that you do not need to take care about this.

If a cross-reference refers to a non-existent label, you will see two question marks
in the output instead of the reference.

References are described in detail in the Embedded Objects manual.

6.2. Table of Contents and other Listings

6.2.1. Table of Contents

The Table of Contents (TOC) is inserted with the menu Insert > List/ TOC> Table of Con-
tents. Is is displayed in [yX as a gray box. If you click on it, the Outline window
appears, showing you the TOC entries as outline to move and rearrange sections in

80



6.3. URLs and Hyperlinks

your documents. So this operation is an alternative to the menu Document> Outline
that is described in sec. 2.5.

The TOC in the document output lists every numbered section automatically. If
you have declared a short title for a section heading, as described in section 3.3.4.4,
it will be used in the TOC instead of the section heading. Section 3.3.4.3 describes
how the level is adjusted that defines which section types are listed in the TOC.
Unnumbered sections are not listed in the TOC.

6.2.2. List of Figures, Tables, and Algorithms

Table, figure, and algorithm lists are very much like the table of contents. You can
insert them via the Insert>List / TOC submenus. The list entries are the float captions
and the float number.

6.3. URLs and Hyperlinks

6.3.1. URLs

Links to web pages or email addresses can be inserted via the menu Insert>URL.

Here is an example URL: [yX’s homepage: http://www.lyx.org

You cannot change the style of the link text, the URL text will always be in the
style Typewriter. To be able to format the URL text, use hyperlinks as explained
in the next subsection.

Note: URLs must not end with a backslash, otherwise you get ETEX errors.

6.3.2. Hyperlinks

Hyperlinks can be inserted with the menu Insert > Hyperlink or with the toolbar button

The appearing dialog has two fields: Target and Name. The name is the
printed text for the hyperlink. The hyperlink type can be a weblink like this: LyX’s
homepage, an Email address like this: lyx-docs mailing list, or a link to a file.

You can start applications via a hyperlink when you insert a weblink, but add the
prefix “run:” to the link target.

Hyperlinks will automatically be hyphenated if necessary in the PDF output, and
become clickable in the DVI and PDF-output. To set the format of the link text,
highlight the hyperlink inset and use the text style dialog. This is for example a
hyperlink with bold sans serif text: LyX’s homepage

The link text color can be changed, when the option Color links is set in the PDF
Properties dialog (menu Document>Settings>PDF Properties). The link text is for
example set in this document to blue by adding the option
urlcolor=blue
to the field Additional options in the PDF Properties dialog.
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6.4. Appendices

Appendices are created with the menu Document > Start Appendix Here. This menu
sets the document from the current cursor position to the end as the appendix region.
The region is marked with a red borderline.

Every chapter (or section) within the appendix region is treated as an appendix,
numbered with a capital Latin letter. The appendix subsections are numbered with
this letter followed by a dot and the subsection number. All appendix sections can
be referenced as if they were normal sections, here two examples:

Appendix E; Appendix A.1.13

6.5. Bibliography

There are two ways of generating the bibliography in a [yX-document. You can
include a bibliography database,? which is explained in the next subsection, or you
can insert the bibliography manually, using the paragraph environment Bibliography,
which was described in section 3.3.8.2. If you want anything other than numerical
citations that are used in this document, like author-year citations, then you must
use a bibliography database.

6.5.1. The Bibliography Environment

Within the Bibliography environment, every paragraph begins with a gray bibliogra-
phy box labeled with a number. If you click on it, you will get a dialog in which you
can set a Key and a Label. The key is the symbolic name by which you will refer to
this bibliography entry. For example, our second entry in the bibliography is a book
about KTEX and we used “latexcompanion”, a short form of its title, as key.

You can refer to the key of a bibliography entry using the menu Insert > Citation or

the toolbar button % A citation reference box is inserted and a citation window
will appear in which you can select one or more keys in the available key list. The
citation reference box will be labeled with the referenced key. When you click on the
box, the citation window appears and you can change the reference.

Citation references appear in the output as the number of the bibliography entry
with surrounding brackets. If you set a Label for the entry, the label will appear
instead of the number. Here are two examples; the first without a label, the second
with the label “Credits™:

Have a look at the XTEX Companion Second Edition: [1]

The LyX-Team members are listed in the Credits: [Credits]

2Known under the name “BibTEX-database”.
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6.5.2. Bibliography databases (BibTgX)

Bibliography databases are useful if you use the same bibliography in different doc-
uments.® It also makes it very easy to have a uniform layout for all bibliography
entries. You can collect the bibliography of all relevant books and articles of your
working field in a database. This database can be used for different documents, and
only the entries cited in a particular document will appear in the bibliography list
for that document. This relieves you of the need to keep track of which articles and
books you have cited.

The database is a text file with the file extension “.bib”, containing the bibliography
in a special format. The format is explained in [8] and in IXTEX books ([MG04, KDO03,
Lam94]). The file can be created using any text editor, but normally one uses a special
program to create and edit the entries in the database. A list of such programs is
maintained on the InX Wiki at http://wiki.lyx.org/BibTeX/Programs.

To use a database, use the menu Insert>List/ TOCw>BibTeX Bibliography. A grey
box will be inserted and a window appears. In this window you can load one or
more databases and a style file. The option Add bibliography to TOC adds a table of
contents entry for the bibliography. In the Content drop box you can select what part
of the database should be output.

The style file is a text file with the file extension “.bst” that controls how the
bibliography entries will appear. Your KTEX distribution should provide several of
these, and many publishers provide their own style files, so that you don’t have to
take care of the layout. It is of course possible to write your own style file, but this
is something for experts.*

Inserting a citation reference works as described in the previous section.

To generate the bibliography from a database, Iy’X uses the program BibTEX. This
program can be controlled with options that you can add in IyX’s preferences dialog
under Outputs>LaTeX in the BibTeX command field. Before adding options, it is
strongly recommended to read the manual of BibTEX [7].

When you select the option Sectioned bibliography in the Document > Settings dialog,
it is possible to have multiple and sectioned bibliographies. This and other options
are explained in detail in section Customizing Bibliographies with BibTpX of the
Additional Features manual.

We use two bibliographies in this document to show the difference between the two
methods of creating them. As you can see, the bibliography that is created from a
database lists only the database entries that are referenced in the document. We used
the style file alphadin.bst to get the complicated German reference key scheme in the
bibliography.

3They are also useful simply for keeping a database of articles and notes concerning them. Most of
the database programs mentioned below allow you to store annotations and reviews along with
bibliographical information.

4For information how this is done, have a look at
http://www.ctan.org/get/biblio/bibtex/contrib/doc/btxhak.pdf.
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6.5.3. Bibliography layout

In the citation reference dialog you can set a special citation format. For this feature
you need to enable the option Natbib in the Document > Settings dialog under Bibli-
ography. Setting a citation style for a reference will overwrite the default. For the
global citation format use the BibTEX style files as explained in the previous section.

You can also set text, that should appear before or after a citation reference, in
the citation reference window. Here an example where we set the text “Chapter 3”
to appear after the reference:

Have a look at [1, Chapter 3].

6.6. Index

An index entry is created if you use the menu Insert>Index Entry or the toolbar

button T . A gray box labeled “ldx” is inserted containing the text that appears
in the index. The word where the cursor is in or the currently highlighted text is
proposed by IyX as the index entry.

We give a short overview of the index commands in the next subsections. For a
detailed description of KTEX’s index mechanism, have a look at one of the IXTEX
books [1, 2, 3].

You can change index entries by clicking on the index box.

The index list is inserted in the document with the menu Insert>List / TOCp
Index List. A light blue box labeled “Index” will show the place where the index is
printed in the output. The index list box is not clickable like other LyX-boxes.

6.6.1. Grouping Index Entries

Index entries are often grouped to offer the reader a fast search in the index. We
want to group for example the index entries for itemized and enumerated lists under
the entry “Lists”. First we create the entry “Lists” in section 3.3.6. In the text field
for the itemized list index entry in section 3.3.6.2, we insert the command

Lists ! Itemize

and the command

Lists ! Enumerate

for the enumerated list in section 3.3.6.3.

The exclamation mark “!” marks the grouping levels. You can have three levels;

every index level is indented a bit more. An index entry for the higher levels is not
required. If we don’t have an index entry for “Lists”, it will be printed anyway, but
without a page number.
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6.6.2. Page Ranges

Normally an index entry will appear with the page number of the indexed section.
But sometimes you want to index more pages under the same entry. E.g if we want
to index the paragraph environments, we create an index entry in section 3.3 with
the command

Paragraph environments|(

and another entry at the end of section 3.3.9 with the command

Paragraph environments|)

The commands “|(” and “|)” respectively start and end the index range. You can
also add the same index entry at different places in the document. They appear in
the output under one entry with a comma separated list of the pages of the indexed
document parts. An example is the index entry “Document ! Settings”.

6.6.3. Cross referencing

It is also possible to refer to another index entry. We referred for example in the
index entry “GIF” (in section 4.4.1) to the index entry “Image formats” in the same
section using the entry

GIF |see{Image formats}

where the braces have to be inserted as TEX Code. The text within the braces is
the referenced entry. The reference will appear in the output without a page number.

6.6.4. Index Entry Order

You can use accented characters in the index entry, but the entries might then not
follow the rules for the index order. The index entries are sorted alphabetically, but
IXTEX® doesn’t know how to sort accents in different languages. We have created as
an example the three dummy index entries “maison”, “mais”, and “maitre”. They
will be sorted in the order mais, maitre, maison, but we want the order mais, maison,
maitre. To achieve this, we use the command

previous entry@current entry

In our case we want to have “maison” after “mais” and write therefore for the index
entry of maison:

mais@maison

The previous entry needn’t to be a real existing entry, you can also use another
word to tell KTEX the entry order, see the next subsection for an example.

In some cases the index entry order is not correct when you are using the program
makeindex to generate the index (see sec.6.6.6). makeindex would for example print
the index entry for the IXTEX-package aeguill in sec. 3.7.2 after the index entries of

5The index generating is done in the background by an extra program, see section 6.6.6.
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the other IXTEX-packages although all these index commands start with “KTEX-
packages ! “ The reason is that the index entry for aeguill is in a footnote. To fix
this makeindex bug, add these commands to the preamble of your document:
\let\OrgIndex\index
\renewcommand*{\index}[1]{\OrgIndex{#1}}

6.6.5. Index Entry Layout

You can change the appearance of index entries via the text style dialog. You can
also format the page number using the character “|” followed by a I¥TEX-command
without a backslash. We can write for example

italic page number:|textit

to get the page number in italic. Normally all BTEX-commands begin with a back-
slash, but in this special case “|command” means \command{page number}.
Have a look at section 6.10.2 to learn more about the IXTEX-syntax.

Note: Formatting single index entries only works when you use the program
makeindex to generate the index, see sec.6.6.6. If you use xindy, however, this won'’t
work for anything other than bold or italic text. This is because xindy requires to
define semantic elements before they can be used, see [1, p. 678 ff.] for details.

In general, we encourage you to not format page numbers directly as shown above.
Instead of this, you should define a macro in the preamble and use that. Consider why
you want some page numbers to be bold. Maybe you want all page references italic
that refer to a definition of the indexed term, so that users can easily find definitions.
If so, put the following in the preamble

\newcommand{\IndexDef}[1]{\textit{#1}}

and write

my entry|IndexDef

in the index entry. The advantage is that, if you change your mind later or if your
publisher insists that definitions must not be italic but bold, you just need to change
the macro in the preamble, not every single index entry.

You can also change the layout for the whole index. E.g. we marked the index
list box of this document as bold to get a bold font for all index entries. For more
advanced tasks you have to set up a so-called Index Style File, see the makeindex or
xindy documentation for details, [9, 10].

6.6.6. Index Program

When the index entry program xindy, which is only available for Linux, is installed,
LyX uses it for index generation; otherwise the program makeindex, that is part of
every KTEX distribution, is used. Both programs can be controlled by options that
can be set in Iy X’s preferences dialog, see section C.6.4. The available options are
listed and explained in [9, 10]. You can also specify there another program to generate
the index.
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makeindex is very old, no longer under development and has many pitfalls, notably
that it was developed with only the English language in mind. So it fails to sort
anything other than a monolingual English text correctly. We have shown above how
to fix this sorting. However, if you are writing in another language and using Linux,
consider to use xindy.

6.7. Nomenclature / Glossary

Sometimes you need to compile a list of symbols that are mentioned in your document
with a brief explanation of them — a so called nomenclature or glossary.
To be able to create nomenclatures, you need the IXTEX package nomencl installed.
You find it in the TEX Catalogue, [5] or in the package manager of your IXTEX-system.
A nomenclature entry is created if you place the cursor after a symbol entry and

then use the menu Insert > Nomenclature Entry or the toolbar button &= A gray box
labeled “Nom” is inserted and a window pops up asking for the nomenclature entry.
A nomenclature entry consists of two main entries. The first is the symbol that
you want to refer to. The second is the description of the symbol.
Note: You have to enter valid I{TEX-code for all fields of the nomenclature dialog.

6.7.1. Nomenclature Definition and Layout

When you have symbols in formulas, you have to define them in the Symbol field as
KTEX-formulas. For example to get “o”, insert this:

$\sigma$

The “$” character starts/ends the formula. The IXTEX-command for the Greek letter
is the name of the letter beginning with a backslash “\”. For capital Greek letters,
start the command also with a capital letter, like \ Sigma.

(A short introduction to the KTEX-syntax is given in section 6.10.2.)

You cannot use the Text Style dialog to format the description text but have to use
ETEX-commands. For example the description of the nomenclature entry for the “o”
in this document is:
dummy entry for the character \textsf{sigma}

The command \textsf sets the fonts to sans serif. To get bold font use the command
\textbf, for typewriter use \texttt, for emphasized use \emph.

6.7.2. Sort Order of Nomenclature Entries

The nomenclature entries are sorted alphabetically by the ETEX-code of the symbol
definition. This leads to undesired results when you for example have symbols in
formulas. Suppose you have nomenclature entries for the symbols a and o. They

will be sorted by “a” and “$\sigma$” — the o will be sorted before the a since the
character “$” is considered in sorting.
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To control the sort order, you can edit the Sort as field of the nomenclature dialog.
Then the nomenclature entry will be sorted by this entry and not the symbol defini-
tion. For the example given, you can insert sigma in this field for the o, then a will
be located before o.

For subgrouping and tips for using sort entries see the nomencl documentation,
[14].

6.7.3. Nomenclature Options

The nomencl package offers some options to adjust the appearance of the nomen-
clature. Here are some of its options, for more have a look at its documentation:

refeq Appends the phrase “, see equation (eq)” to every nomenclature entry, where
eq is the number of the last equation in front of the nomenclature entry

refpage Appends the phrase “, page (page)” to every nomenclature entry, where page
is the number of the page on which the nomenclature entry appeared

intoc Inserts the nomenclature in the Table of Contents

There are furthermore the options croatian, danish, english, french, german,
italian, polish, portuguese, russian, spanish, and ukrainian to print the refer-
ence texts and the nomenclature title in the corresponding language.

To use one or more of the options, add them to the comma-separated document
class options list in the Document > Settings dialog. In this document the option intoc
is used.

You can also use the first two options above only for certain nomenclature entries
when you add one of the following commands as last entry to the Description field in
the nomenclature dialog:

\nomrefeq Like the refeq option

\nomrefpage Like the refpage option

\nomrefeqpage Short notation of \nomrefeq\nomrefpage

\nomnorefeq, \nomnorefpage, \nomnorefeqpage Turns off the corresponding op-

tions

6.7.4. Printing the Nomenclature

To print the nomenclature, use the menu Insert> Lists / TOCr>Nomenclature. A light
blue box labeled “Nomenclature” will show the place where the nomenclature is printed
in the output. Like the index list box, the nomenclature list box is not clickable.

In the printed output the title of the nomenclature appears as “Nomenclature”.
If you are not happy with the name, you can change it by redefining the command
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\nomname in the preamble. For example, in order to change the name to List of
Symbols, add the following line to the preamble:
\renewcommand{\nomname}{List of Symbols}

If you are unhappy with the amount of space for symbols, you can alter it by adding
the following line to the preamble:

\renewcommand{\nomlabelwidth}{width}

where the width is a value with one of the units listed in Appendix D. The default
value is 1 cm.

6.7.5. Nomenclature Program

[yX uses the program makeindex, that is part of every IXTEX distribution, to generate
the nomenclature. LyX’s preferences dialog allows you to specify another program or
to control makeindex by adding options, see section C.6.4. The available options are
listed and explained in [14, 9].

6.8. Branches

Sometimes it is useful to hide some document parts in the output. For example a
teacher who is setting an exam obviously doesn’t want the pupils to see the answers,
but having questions and answers in the same document will make the life of the
markers of that exam much easier.

For these cases LyX allows you to put text into branches. The text will then only
appear in the output when its branch is activated. To create a branch, go in the
Document > Settings dialog to Branches. The name of the branch, its activation state
and the background color of the branches inside [yyX can be specified in this dialog.

Text that should be in a branch is set into branch inset boxes. These boxes are
inserted via the menu Insert> Branch where you can choose a branch. You can later
change the branch of the boxes by right-clicking on them.

Here is an example, where only the question text appears, the answer branch is
deactivated and does therefore not appear in the output:

Question: Who was the first physics Nobel prize winner?

To use conditional output inside places where you cannot insert branch insets, like
inside equations, you can code special KTEX definitions for each branch. For example
you can define for the question branch®

\newcommand{\question}[1]{#1}

\newcommand{\answer }[1]{}

and for the answer branch

\newcommand{\question}[1]{}

\newcommand{\answer }[1]{#1}

SFor an introduction to the KTEX-syntax, see section 6.10.2.
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Now it is possible to use the commands \question{...} and \answer{...} to
obtain conditional output. Here is an example formula where only the \question
part appears:

=2 —2=1,=1+V3.

Inside math, the same effect can be achieved using math macros, see the Math
manual.

6.9. PDF Properties

The Document Settings dialog allows you in the PDF Properties to set up special
options for the PDF output of your document. All options there are provided by the
ETEX-package hyperref.

Using hyperref will link all cross-references in the DVI- and PDF-output. This
means that the reader of your document will be able to click on a table of contents
entry or on a reference and he is shown the referenced document part. You can specify
in the dialog tab Hyperlinks how the links will look like and if links for bibliographical
backreferences are created. The backreferences will appear in the bibliography behind
the different entries, showing the number of the section, slide, or page where the entry
is referenced.

In the dialog tab Bookmarks you can set if PDF-bookmarks should be created for
every section of your document to make it easier for readers to navigate through the
document. You can decide if the bookmarks should be numbered like your document
sections or not. With the open bookmarks level you can specify what sectioning level
should be displayed in the bookmarks when opening the PDF. For example level 2
will display all sections and subsections, while level 1 will only display the sections.

The header information in the dialog tab General are saved together with the PDF
as file properties. Many programs are able to extract this information to e.g. auto-
matically recognize who the author is and what the PDF is about. This is very useful
to sort, classify, or use PDFs for bibliography issues. When the option Automatic fill
header is set, [yX tries to extract the header information from your document title
and author settings.

The option Load in fullscreen mode will open the PDF in fullscreen mode, which is
useful for presentations.

PDF properties are also used in this document. When you look in its document
settings, you can see that some additional hyperref options are used. For an expla-
nation of them we refer you to the hyperref manual [13].
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6.10. TgX Code and the BTEX Syntax

6.10.1. TEX Code Boxes

As Iy X uses HTEX in the background, it supports many ITEX commands and con-
structs, but not all. I¥TEX contains of hundreds of packages which provide different
commands. All the time packages are being updated and new ones added. This has
the advantage that you can typeset nearly everything as there is for every problem a
ETEX-package. But LyX can of course not be up to date and support all packages
and their commands.

But don’t worry, you can use any KITEX-command directly in LyX inside the TEX
Code box. A TEX Code box is created by the menu Insert > TEX Code or by the toolbar

TeX

button
it.

. The box can be opened by left-clicking and closed by right-clicking on

You can insert complete or incomplete commands as TEX Code. Incomplete means
that the command argument can be Standard LyX text. For example, if you want to
draw a frame around a word are therefore using the ITEX-command \fbox, you can
write the command part \fbox{ in a TEX Code box before the word and the closing
brace } in a second TEX Code box behind the word. The word between the two TEX
Code boxes is then the argument as it is in the following example:

Thiz 15 a line with a \fhox{ framed } word.

gives

This is a line with a word.

Note: At the end of I¥TEX-commands without parameters, you have to insert a
space to let BTEX know that the command is finished.

6.10.2. Short Introduction to the BPTEX Syntax

When you write larger documents or books, you will need to know something about
the ITEX-commands that LyX uses in the background. Because KTEX is based on
commands, you can “program” your text. This has the advantage that the layout of
the document can be changed at any time if you know the right commands. E.g.
imagine you have to write a manual for a product and the deadline is the end of the
day. Your boss just has complimented you for your good work but wants to have
all caption labels bold. But you have over hundred figure and table captions with
non-bold labels in your manual. Of course it’s impossible to change all caption labels
manually in one day.

Now KTEX comes into play. As mentioned above, for every problem there exists
a ITgX-package. First you have to find out which and therefore look in the IXTEX
package database, [FW].

As result you know that the package caption is what you need. To use a package,
you have to load it in the document preamble (menu Document > Settings) with the
command
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\usepackage[options]{package name}

All KTEX commands begin with a backslash, the command argument is set within
two braces, and the options are set within two brackets. Note that not all commands
have an argument and options.

In your case the package name is caption. After a look in the documentation
of the package, you know that the option labelfont=Dbf will change the font of all
caption labels to bold. So you add the command

\usepackage[labelfont=bf]{caption}

to the preamble and the problem is solved.”

Note that some document classes have built-in solutions for well known problems
like your case. For example if you use a KOMA-Script class, you don’t need the
package caption, you can instead write

\setkomafont{captionlabel }{\bfseries}

in the preamble and the problem is solved. So if you plan to write a large document,
you should have a look at the documentation of the document class you want to use.
(\setkomafont is an example of a command with more than one argument.)

Commands in the preamble affect the whole document, while commands in the text
affect only the text after the command or only the text used as command argument.
To insert a KTEX-command in text, use the TEX Code box as described in the previous
section.

If you want to learn more about IXTEX and its syntax, have a look at the EIEX-
books [1, 2].

6.11. Previewing Snippets of your Document

LyX allows you to generate previews of sections of your document on the fly so you
can see how they’ll look in the final document without having to break your train of
thought with Viewr DVI.

If you would for example like to see in LyX your math formulas typeset by KTEX,
install the ATEX-package preview-latex as explained below, and turn on Instant pre-
view in the Toolsr Preferences dialog under Look and feel> Display. The Preview Size
is the multiplication factor for the size.

Previews are generated when you load a document into [3X and when you finish
editing an inset. Previews of an already loaded document are not generated just by
selecting the Instant preview check box, you have to reopen the documents to activate
the previews.

LyX will generate previews of math insets. It will also generate previews of included
insets if you select the Show preview check box in the insert dialog. This is useful if
you wish to generate a preview of a IWTEX figure, for example.

To get previews working, you need the KTEX package preview-latex (on some
systems named simply preview) installed. If it is not already installed, you will find

"For more commands provided by the caption package, have a look at its documentation, [11].
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it in the TEX Catalogue, [5] or in the package manager of your KTEX-system. You
obtain prettier results if you install the program pnmcrop from the netpbm package;
for IyX on Windows this program is automatically installed together with IyX.

You can furthermore preview the EIEX source of the whole document or parts of
it. Use the menu View > View Source and a window will be shown where you can see
the KTEX-source code. The window shows the source of the whole paragraph where
the cursor is currently in. You can also select document parts in [y X’s main window,
then only this selection (when it is more than one paragraph) is shown as source code.
To view the whole document as source, enable the corresponding option in the source
view window.

6.12. Spell Checking

IyX itself has no built-in spell checker. Rather it uses one of the external programs
aspell, ispell, hspell, or pspell as backend. This section assumes you have al-
ready installed and set up one of these programs. aspell can be seen as the successor
to ispell, and contrary to ispell, it supports multiple languages in parallel, so it is
recommended to use aspell. hspell is a Hebrew spell-checker. The used spell checker
and its settings are specified in Iy X’s preferences under Language Settings.

For IyX on Windows, the selection box for the spell checking program is greyed
out in the preferences dialog because only aspell can be used.

The menu Tools> Spellchecker or the toolbar button HB‘E,! starts the spell checking
beginning from the current cursor position. A dialog window will appear showing any
incorrect (or unknown) word found, allowing you to edit and replace it in a second
line. Whenever an unknown word is found, the word is highlighted and the text
scrolled so that it is visible. In the spell checker dialog, there is also a box showing
suggestions for a correction, if any could be found. Clicking on one of the corrections
will copy to the Replace field, double-click invokes directly the replacement. Unknown
but correctly typed words can be added to the personal dictionary.

By default, the dictionary file used is determined by the document language that is
set in the Document > Settings dialog. If you do not have a dictionary for the document
language, spell checking will bring an error message. In this case, you can specify
another dictionary file in the dialog by specifying a different Alternative language in
preferences dialog.

After a spell check you will be informed about the number of checked words.

Limitations

It is not possible to change the spelling of a particular word globally, rather than
having to change the spelling separately for each occurrence of the word. But you
can use the Find & Replace dialog for that.
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Iy X cannot correctly spell check documents containing multiple languages. This
does work with pspell, assuming you have marked the different languages appropri-
ately.

Further Settings

The Spellchecker section in the preferences dialog has some additional options:

Escape characters Allows you to add non-standard characters that the spell checker
should consider, e. g. German umlauts although you are spell checking an En-
glish document. This should not normally be needed.

Personal dictionary to use a different file as your personal dictionary instead of the
spell checker’s default choice

Accept compound words Prevent the spell checker from complaining about com-
pounded words like “passthrough”.

Use input encoding Uses the document encoding that is set in the Documentr
Settings dialog under Language also for the spellchecker.® Only enable this if
you use ispell and can’t spell check words with international letters in them.
There have been reports that this does not work with all dictionaries, so this is
disabled by default.

6.13. Thesaurus

Thesaurus currently only works when you use the document language English.
To start the thesaurus, highlight one word or set the cursor behind it, and use the

menu Tools> Thesaurus or the toolbar button L}.I A dialog pops up showing you
possibly related words that you can use as replacement.

The related words shown may not really be related to the word you are currently
checking; scrolling in the proposal list might help in some cases to find related words.

The thesaurus only works for single words, and also only when it is in the singular
form. For example starting the thesaurus with the word “reports” leads to no results,
while results are shown for the word “report”. To avoid this, you can highlight only
the part “report” of the word “reports” to get results.

6.14. Change Tracking

When you work on a document collaboratively it is extremely useful to be able to see
changes that others have made highlighted in the document. You can then decide

8The encodings are explained in section B.
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if you want to accept a change or not. This can be achieved by turning on change
tracking in the menu Document > Change Tracking> Track Changes.

Changes made in the document will then be highlighted by strokes and colors:
underlined text is an addition, canceled text is a deletion. The color depends on the
author that made the change. You can change the color in I X'’s preferences dialog
under Look and feel, Colors. The author and the date of the change are shown in
LyX’s status bar when the cursor is in changed text. The same information is shown

—
when you use the toolbar button =1
When change tracking is activated, you will see the review toolbar in LyX:

A = v x =200 3

The review toolbar as shown above contains from left to right the following buttons:

Document > Change Tracking> Track Changes
Document > Change Tracking> Show Changes in Output
Jumps to the next change

Document > Change Tracking > Accept Change
Document > Change Tracking > Reject Change
Document > Change Tracking> Merge Changes
Document > Change Tracking> Accept All Changes
Document > Change Tracking Reject All Changes

Insert > Note > LyX Note

M m o G II]I r & g ﬂ

Navigater> Next Note

The review toolbar helps you to accept, reject, or merge changes — highlight the
change and press one of the desired toolbar buttons. When you merge changes, a
window pops up showing you information about the next change behind the current
cursor position. So you don’t need to highlight a certain change. Within the merge
window you can decide to accept or reject changes and step to the next change. This
way you can jump through all the changes in the document.
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The toolbar has two buttons to handle notes because notes are often important to
describe a change.

To show made changes in the output you need the IXTEX package dvipost installed.
You will find it in the TEX Catalogue, [5] or in the package manager of your ETEX-
system.

6.15. International Support

This section describes how to use LyX with any language you want. For some non-
western languages there are special Wiki-pages that explain how to set up LyX to use
them: [18, 19, 20, 21]

Besides languages, LyX also supports phonetic symbols, see section A.4.2.

6.15.1. Language Options

The Document>Settings dialog lets you set the language and character encoding for
your language.
Choose your language in the Language section of this dialog. The default is English.
Under Encoding you can choose the character encoding map you want to use for
ETEX export. The option Language Default is the preferred choice and works well in
most cases. For details about the different encoding options see section B.

6.15.2. Keyboard mapping configuration

If you have for example a U.S.-style keyboard and want to write in a language other
than English, you can use an alternate keymap. For example, if you have a U.S.-
style keyboard but want to write in Italian, you can configure IyX to use an Italian
keymap. The preferences dialog allows you to choose up to two keyboard mappings,
see section C.2.3. You can choose primary and secondary keyboard languages and
then select which one you want to use.

Finally, you may just want to change a few key mappings or create an entirely
different keymap (for Vulcan, for instance). You may, for example, normally write in
[talian on a U.S. keyboard but want to include an occasional quotation in German. In
such a case, you can write your own keyboard mapping or modify an existing one to
support the characters you want. This and many other customizations are explained
in the Customization manual.

6.15.3. Character Tables

Table 6.2 shows the Latinl character set. You should be able to enter the characters
in the first eight columns directly from the keyboard.
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Table 6.2.: The 1atinl character set

&3
S
)
S

[ e lo= ool ]olw]m]w]

40 Co ‘ DO
00 ola@lP]| " |p clA|blalo
01 L1 1]A|Q|alq i || A|[N|4&a|qn
02 «l2[B|IR|[b]r ¢|2[AlO]a]o
03 #13]C|S|c|s £13[A]O0]al]é¢
04 $ 4 D T d t jot A O a 0
05 %15 E|U]e|u Y| plAlO]4&a]os
06 & | 6 F \Y% f A% : ﬂ bed) O & | o0
07 TG I W g | w § Clx|¢ |~
05 (|8|H|X|h|x ; E|lO0]e]|o
09 ) 9 I Y 1 y © E|U]|é u
0a 11Tzl z alolE|Uleln
0B +1; K| [ [k|{ «|» [E|JU&é|q
oc < LN [ 1] — %[ IT[U|i]a
op sl=[M] ] [m]} W I |Y]ily
oE | >|N| " |[n]|~ %1 P1]Dp
OF / 710 _|o N A | B3 1|y

There are a few things you need to know about this table. Here are some of the
details you’ll need to bear in mind when using characters from the Latinl character
set:

o Even if you have selected latinl in the Document Settings dialog, users who
have only the Ti-fonts for TEX [or who have the Ti-fonts but aren’t using

them| will still miss a few characters: D0, FO, DE, FE, AB, and BB — the
uppercase and lowercase eth and thorn, and the french quotes won’t show up.

The following is a full list of all of the accented characters IiyX can display directly.
It includes not only the accented characters from the previous table, but also the
characters from I808859-2 through 4.

e From IS08859-1:

TAETIOUAéiod diaeresis
~AEIOUa&aéion circumflex
“AEIOUacion grave
"AEIOUY4aéisuy acute
~ANOano tilde
.Cc cedilla
N macron
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e From IS08859-2 through 4:

HJ ﬁj@@gégé circumflex
SZ&RLONfléh acute
IiU1 tilde
SsTtRLGIIENKnk cedilla
EeAIOUaiou macron
OUst Hungarian umlaut

All the characters above are actively supported by TEX fonts. In addition TEX allows
diacritical marks on almost all characters. Also make sure you're using the T1 font-
encoding.
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This appendix lists all the available menus and describes their functionality. It is
designed as a quick reference if you are searching for a special topic inside the user’s
guide.

A.1. The File Menu

Under the File menu are the basic operations in addition to some more advanced
operations. At the end of the menu the four last opened documents are listed.

A.1.1. New

Creates a new document.

A.1.2. New from Template

This menu entry prompts you for a template to use. Selecting a template will auto-
matically set certain layout features for the document, features you would otherwise
need to change manually.

A.1.3. Open

Opens a document.

A.1.4. Open Recent

The submenu shows a list of the recently opened files. Click there on a file to open
it.

A.1.5. Close

Closes the current document.

A.1.6. Close All

Closes all opened documents.
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A.1.7. Save

Saves the actual document.

A.1.8. Save As

Saves the actual document under a new name to create a copy.

A.1.9. Save All

Saves all opened documents.

A.1.10. Revert to saved

Reloads the actual document from disk.

A.1.11. Version Control

This is used when more people are working on the same document. It is described in
the section Version Control in LyX of the Additional Features manual.

A.1.12. Import

You can import there files from older Ly X-versions, HTML-files, KTEX-files, NoWeb-
files, plain text files, and comma separated, table like, text files (CSV) as a new
LyX-document. The files will be imported as new IyyX-document.

When using the menu entry Plain Text, line breaks in the text will start a new
paragraph; when using the menu entry Plain Text, Join Lines, consecutive lines of text

will be imported to one big paragraph. A new paragraph will begin when there is a
blank line in the file.

A.1.13. Export

You can export your document to various file formats. The resulting files are placed in
the directory of your [y X-file. The menu entries are not the same on all installations.
They depend on the programs found by [yX while its configuration.

Here is a list of all available entries; some of them are explained in detail in sec-
tion 3.8.2:

CJK LyX format of the special LyX 1.4.x versions for Chinese, Japanese, and Korean
(CJK); (Since LyX 1.5.0 CJK support is fully integrated to LyX.)

DVI DVI-format

HTML HTML-format (the HTML-converter is a third-party product and doesn’t
work in all cases)
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HTML (MS Word) HTML-format specialized so that the result can be imported to
MS Word, as consequence of this formulas will be embedded as bitmap fonts
and not in the format MathML.

LaTeX (pdflatex) text file with the BETEX source, additionally all images used in
the document will be converted to a format that is readable by the pdflatex
program (GIF, JPG, PDF, PNG)

LaTeX (plain) text file with the IXTEX source code, additionally all images used in
the document will be converted to the EPS-format, only this format is readable
by the latex program

(A7)

LyX l.y.x IyX-document in a format readable by the LyX versions l.y.x (“y” is
replaced by the version number)

OpenDocument OpenDocument-formatted text file, to be opened with OpenOffice,
KOffice, Abiword, etc. (the OpenDocument-converter is a third-party product
and doesn’t work in all cases)

PDF (dvipdfm) PDF-format using the program dvipdfm
PDF (pdflatex) PDF-format using the program pdflatex
PDF (ps2pdf) PDF-format using the program ps2pdf
Plain text text format

Plain text (ps2ascii) text format, the document will first be converted to Postscript
format and then exported as text using the program ps2ascii

Postscript PostScript format using the program dvips
Custom custom format

The program dvipdfm produces internally a DVI-file which is then converted to a
PDF-file. It is a bit out of date and therefore the output could look different from
what you want. pdflatex produces PDF-files directly and supports the latest PDF-
file formats.

If one of the menu entries DVI, PDF (pdflatex) or Postscript is missing, you need
to update your KTEX installation. After updating you have to reconfigure IyX, see
section 1.4.

The menu Custom allows you to export your file by using special command line
options for the export program.
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A.1.14. Print

With this menu entry you can print your document to a file in PostScript format or
send it to a printer. The printer will also use the document in PostScript format.
The conversion to PostScript is done in the background by LyX using the program
dvips. For more information have a look at section 3.8.4.

A.1.15. Fax

This menu entry will only appear when you have a fax program installed (on Win-
dows you additionally need to register its program path to IxX’s PATH prefix, see
section C.3). With this menu entry you can send your document to a fax program
like hylapex or kdeprintfax. The default format of the sent file is PostScript. The
format can be changed in LyX’s preferences as described in section C.7.1.

A.1.16. New and Close Window

Opens or closes a new instance of LyX.

A.1.17. Exit
Prompts you to save all unsaved documents and then exits.

A.2. The Edit Menu
A.2.1. Undo and Redo

Described in section 2.3.

A.2.2. Cut, Copy, Paste, Paste Recent, Paste Special

Described in section 2.2.

A.2.3. Select All

Selects the whole document.

A.2.4. Find & Replace

Described in section 2.2.

A.2.5. Move Paragraph Up/Down

This shifts the paragraph where the cursor is currently in one paragraph up or down.
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A.2.6. Text Style

Described in section 3.7.4.

A.2.7. Paragraph Settings

Enables you to set the paragraph alignment, line spacing and label width. These
settings only affect the paragraph in which the cursor is currently.

You can also prevent the first line of the paragraph being indented if you have
chosen to separate paragraphs with indents in the Document > Settings dialog under
Text Layout.

A.2.8. Table Settings and Math

These two menus are only fully active when the cursor is inside a table or a formula.
Here you can change the properties of tables and formulas. The properties of tables
are described in section 4.5, the properties of formulas in chapter 5.

A.2.9. Increase / Decrease List Depth

These menu entries are only active when the cursor is in an environment that can
be nested. They increase/decrease the environment nesting level as explained in
section 3.4 and 3.3.4.3.

A.3. The View Menu

The View menu contains a list of available formats in which you can view the actual
document with an external program. The menu entries for the viewing formats are
not the same on all installations — it depends on the BTEX programs that are found
while IyX was configured. All possible formats are formats listed in section A.1.13.
You should at least see the menu entries DVI and PDF (pdflatex). If one of the two
is missing, you need to update your IXTEX installation. After updating you have to
reconfigure IyX, see section 1.4.

Invoking a menu will start a viewer program. The viewer can be set or changed in
the preferences, see section C.7.2. The default viewers are set by LyX while it is first
configured.

At the bottom of the View menu the opened documents are listed.

A.3.1. Open/Close all Insets

Opens/closes all insets in your document.
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A.3.2. Unfold/Fold Math Macros

Unfolds/folds the current math macro.
Math macros are described in the Math manual.

A.3.3. View Source

Opens a window showing the source code of the actual document, as described in
section 6.11.

A.3.4. Update

This menu entry allows you to update the view with your latest changes without
opening a new view window.

A.3.5. Split View

This will split LyX’s main window vertically or horizontally. This allows you to view
documents the same time to compare them, or to view the same document, but at
different positions. You can even split the main window several times to view for
example 3 or more documents at the same time. To return to an unsplit view, use
the menu Close Current View.

A.3.6. Close Current View

Closes a split view.

A.3.7. Fullscreen

Using this menu entry or pressing F11 removes the menu bar and all toolbars so
that you will see nothing but your text. It furthermore displays IiyX’s main window
fullscreen. To return from fullscreen to the normal view, press F11, or right-click and
turn off the fullscreen mode in the context menu.

A.3.8. Toolbars

In this menu entry you can set the appearance of the different toolbars. All toolbars
and the Command Buffer can be turned on and off. The on state is denoted in the
menu with a checkmark. The Review, Table, Math Panels, and Math toolbars can be
additionally set to the state automatic that is denoted in the menu with the suffix
(auto).

In the on state the toolbar is permanently shown, in the automatic state the toolbar
is only shown when the cursor is in a certain environment or when a certain feature
is enabled. That means that the review toolbar will only be shown when change
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A.4. The Insert Menu

tracking is activated, the math and table toolbars are only shown when the cursor is
inside a formula or table, respectively.
LyX’s toolbars and their buttons are explained in section A.9.

A.4. The Insert Menu

A.4.1. Math

Inserts math constructs that are explained in chapter 5 and the Math manual.

A.4.2. Special Character

Here you can insert the following characters:

Symbols Inserts any character that can be output by your BTEX system. Therefore
the number of character categories in this dialog and the available characters
depend on the BTEX-packages you have installed.

Note: Not all characters will be visible in the Symbols dialog because none of
the screen fonts that you can set in the preferences dialog (see sec. C.1.2) can
display every character.

Ellipsis Inserts an ellipsis: ...

End of Sentence Inserts an end of sentence dot as described in section 3.9.3.1.

Y

Ordinary Quote Inserts this quote: ”, no matter what quote type you selected in the
Document > Settings dialog under Language.

4

Single Quote Inserts this quote:
Protected Hyphen Inserts a hyphen that is protected from line breaks: -
Breakable Slash Inserts a slash where also a line break can occur: /

Menu Separator Inserts the menu separator sign:

Phonetic Symbols Creates a formula with a so called tipa inset. Here you can insert
commands to create IPA phonetic symbols. For this feature you must have the
ETEX-package tipa installed.

For more information about this feature we refer to the documentation of tipa,

[15] and this Wiki-page:
http://wiki.lyx.org/LyX/LinguistLyX
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A.4.3. Formatting

Here you can insert the following format constructs:

Superscript Inserts a superscript: test®P

Subscript Inserts a subscript: testsy

Protected Space Inserts a protected space that is described in section 3.5.1.
Inter-word Space Inserts an inter-word space that is described in section 3.5.2.1.
Thin Space Inserts a thin space that is described in section 3.5.2.2.
Horizontal Space Inserts horizontal space, see section 3.5.2 for a description.
Horizontal Line Inserts a horizontal line, see section 3.5.7 for a description.
Vertical Space Inserts vertical space, see section 3.5.3 for a description.
Hyphenation Point Inserts a hyphenation point, see section 3.9.2.

Ligature Break Inserts a ligature break, see section 3.9.4.

Ragged Line Break Inserts a forced line break, see section 3.5.6.

Justified Break Inserts a forced line break that furthermore stretches the broken
text line to the page border, see section 3.5.6.

New Page Inserts a forced page break, described in section 3.5.5.

Page Break Inserts a forced page break that furthermore stretches the broken text
page to the page border, described in section 3.5.5.

Clear Page Inserts a clear page break, described in section 3.5.5.1.

Clear Double Page Inserts a clear doublepage break, described in section 3.5.5.1.

A.4.4. List / TOC

Various lists can be inserted with this menu entry. The table of contents, the algo-
rithm, figures, and tables list are described in section 6.2. The index list is described
in section 6.6, the nomenclature in section 6.7, and the BibTEX bibliography in sec-
tion 6.5.2.

A.4.5. Float

To insert floats, described in section 4.6.
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A.4.6. Note

To insert notes, described in section 4.1.

A.4.7. Branch

Inserts branch insets as described in section 6.8.

A.4.8. Custom Insets

Inserts document class-specific insets. Such insets only exist when they are defined in
the layout file for a certain document class. An example is the document class “article
(Elsevier)” with three custom insets. The section Flex insets and InsetLayout of the
Customization manual explains how custom insets are defined.

A.4.9. File

This menu entry allows you to insert or include the contents of other IyX files in
your document. How you can do this is explained in detail in the chapter Ezternal

Stuff of the Embedded Objects manual.

A.4.10. Box

Inserts a minipage box that is described section 4.7. All box types supported by LyX
are explained in detail in the chapter Bozes of the Embedded Objects manual.

A.4.11. Citation

Inserts a citation as described in section 6.5.

A.4.12. Cross-Reference

Inserts a cross-reference as described in section 6.1.

A.4.13. Label

Inserts a label as described in section 6.1.

A.4.14. Caption

Inserts a caption in a float or longtable. Floats are described in section 4.6, captions
in longtables are described in the section Longtable Captions of the Embedded Objects
manual.
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A.4.15. Index Entry

Inserts an index entry as described in section 6.6.

A.4.16. Nomenclature Entry

Inserts a nomenclature entry as described in section 6.7.

A.4.17. Table

Inserts a table. Tables are described in section 4.5.

A.4.18. Graphics

Inserts a graphic. Graphics are described in section 4.4.

A.4.19. URL

Inserts an URL as described in section 6.3.1.

A.4.20. Hyperlinks

Inserts a hyperlink as described in section 6.3.2.

A.4.21. Footnote

Inserts a footnote, see section 4.2.

A.4.22. Marginal Note

Inserts a marginal note, see section 4.3.

A.4.23. Short Title

Inserts a short title, see section 3.3.4.4.

A.4.24. TgX Code

Inserts a TEX Code box, see section 6.10.1 for a description.

A.4.25. Program Listing

Inserts a program listings box. Program listings are explained in the chapter Program
Code Listings of the Embedded Objects manual.
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A.4.26. Date

Inserts the actual date. The format depends on the date format of the language that
is used for LyX’s menus. LyX offers various ways to insert a date which are explained
and also compared in the section Ezternal Material of the Embedded Objects manual.

A.5. The Navigate Menu

This menu lists the existing chapters, sections, figures, tables, etc. of the current
document. This allows you to navigate easily through you document.

A.5.1. Bookmarks

With this menu entry you are able to define your own bookmarks. This is useful when
you are working on a large document and often have to jump e. g. between section 2.5
and 6.3. To create bookmarks for this example, go to section 2.5 and use the menu
Save Bookmark 1. Then go to section 6.3 and use Save Bookmark 2. Now you can
jump easily between these sections by using the menu or by the key bindings Ctrl+1
and Ctrl+2.

You can also use bookmarks to jump between several opened documents. The
saved bookmarks are valid till the document is closed.

A.5.2. Next Note, Change, Cross-reference

Jump to the next note, change, or cross-reference following the current cursor position.

A.5.3. Go to Label

Only active when the cursor is in front of a cross-reference. Sets the cursor before
the referenced label, the same as if you right-click on a cross-reference box.

A.6. The Document Menu

A.6.1. Change Tracking
Change Tracking is described in section 6.14.

A.6.2. LaTeX Log

After running BTEX by viewing or exporting a document, this menu will be enabled.
It shows the logfile of the used KTEX-program.

Here you can see how BETEX works in the background. Ezperts will find in it reasons
for KTEX-errors.
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A.6.3. Outline
Opens the TOC/Outline window as described in section 2.5 and 6.2.1.

A.6.4. Start Appendix Here

This menu will start the appendix of the document at the current cursor position as
described in section 6.4.

A.6.5. Compressed

Un/compresses the current document.

A.6.6. Settings

The document settings are described in appendix B.

A.7. The Tools Menu

A.7.1. Spellchecker
Spell checking is explained in section 6.12.

A.7.2. Thesaurus

The thesaurus is described in section 6.13.

A.7.3. Statistics

Counts the number of words and characters in the actual document or the highlighted
document part.

A.7.4. TeX Information

Shows you a list of the classes and styles installed in your KTEX-system.

A.7.5. Reconfigure

This menu entry reconfigures LiyX; that is, IX looks for IXTEX-packages and needed
programs it needs; see also section 1.4.

A.7.6. Preferences

The preferences dialog is described in detail in appendix C.
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A.9. Toolbars

A.8. The Help Menu

This menu opens the documentation files of IiyX in the language of LyX’s menus.
The menu BTEX Configuration shows a Iy X-document with information about the
BTEX-packages and classes found by LyX (see also section 1.5).

A.9. Toolbars

How to show or hide toolbars is explained in section A.3.8.
It is also possible to define custom toolbars. This is described in the Additional
Features manual.

A.9.1. Standard Toolbar
. Standard YIS L HEXZEXR EfotmeE ¢H

The standard toolbar as shown above contains from left to right the following
buttons:

Standard
pull-down box for the paragraph environments

..E Filer> New
5’ File> Open
E File>Save
CQ File> Print

HB‘% Tools > Spellchecker
[ﬁ Edit>Undo

@ Edit> Redo

% Edit> Cut

Edit> Copy

F@ Edit> Paste

Edit> Find & Replace

LV

Navigate > Bookmarks > Navigate Back
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Emphasize text, function of the Edit> Text Style dialog
Set text to noun style, function of the Edit > Text Style dialog
Formats text using the current settings in the Edit> Text Style dialog

Insert > Math > Inline Formula

Insert > Graphics

Insert > Table

Toggle outline window on/off, Document > Outline
Toggle math toolbar on/off

Toggle table toolbar on/off

A.9.2. Extra Toolbar

T == BEH2BE & EEEE S WYY

B

The extra toolbar as shown above contains from left to right the following buttons:

LIPS
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Numbered list

[temized list

List

Description list
Edit > Increase List Depth

Edit> Decrease List Depth

Insert> Float > Figure



) SR [

- #

g

z &

A.9.3. View / Update Toolbar

EH®OBE®

Insert> Float > Table

Insertr> Label

Insert > Cross-Reference
Insert > Citation

Insert > Index Entry

Insert > Nomenclature Entry

Insert > Footnote

Insert > Marginal Note
Insert > Note > LyX Note
Insert > Box

Insert> URL
Insert>TeX

Insert > Math > Macro

Insert > Filer> Child Document

Edit> Text Style
Edit > Paragraph Settings

Tools> Thesaurus

A.9. Toolbars

The view / update toolbar as shown above contains from left to right the following
buttons:

dui

View > DVI
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vi View > Updater> DVI
View>PDF
View > Updater PDF

View > Postscript

> @D ¥

5 View > Update > Postscript

A.9.4. Other Toolbars

The change tracking toolbar is explained in section 6.14, the table toolbar in the
Embedded Objects manual, the math macro toolbar in the Math manual.
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The document settings dialog contains submenus to set properties for the whole doc-
ument and is called with the menu Document>Settings. You can save your document
settings as default with the Save as Document Defaults button in the dialog. This will
create a template named default.lyx which is automatically loaded by LyX when
you create a new document without using a template.

The different submenus of the dialog are explained in the following.

B.1. Document Class

Here you set the document class, class options, a graphics driver, and a master
document. Document classes are described in section 3.1.2. Some classes use some
class options by default. If this is the case, they are listed in the field Predefined and
you can decide to use them or not. If you don’t exactly know what the default class
options are for, it is recommended not to touch them. The graphics driver is used for
KETEX’s graphics, color and page layout packages. When using Default, the default
driver for the BTEX-packages is used. It is recommended that you use the default
unless you know what you are doing.!

Specifying a master document is necessary when the current document is a child or
subdocument. This master document will be used by LyX when the child document
is opened without its master. This way child documents are always compilable. More
about master and child documents is explained in the section Child Documents of the
Embedded Objects manual.

B.2. Modules

Modules are explained in section 3.1.2.2.

B.3. Fonts

The document font settings are described in section 3.7.

"'When you want one of the following drivers
dvi2ps, dvialw, dvilaser, dvitops, psprint, pubps, In
you first have to activate them in your INTEX distribution, see sec.2 in
http://tug.ctan.org/get/macros/latex /required/graphics/griguide.pdf.
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B. The Document Settings

B.4. Text Layout

You can specify if paragraphs should be separated by indentations or vertical skips.
The line spacing and the number of text columns can here also be specified.

Note that IyX won’t show two columns or the set up line spacing on screen. That’s
impractical, often unreadable, and not part of the WYSIWYM concept. However, it
will be as you specified it in the output.

The listings settings are explained in the corresponding section in the Embedded
Objects manual.

B.5. Page Layout

A description of this menu is given in section 3.1.4 and 3.1.3.

B.6. Page Margins

Here you can adjust the paper margins, see section 3.1.5.

B.7. Language

The document language and quote styles are set here. The encoding specifies how
the document content is exported to KTEX (the LyX file is always encoded in utf8).
All characters that cannot be encoded using the specified encoding will be exported
as I¥TEX-commands (this can fail if a KTEX-command is not known for a particular
character).?

If you use the option Language Default, Iy X determines the encoding of a text
part from the language of this text. If the document contains text in more than one
language you may get more than one encoding in the IXTEX file. If you do not use this
option then the complete document will always use exactly one encoding. Checking
this option is the preferred setting unless you use XeTpX? (see below).

LyX also supports Unicode output, which is particularly useful if you need lots of
special symbols or non-alphabetic scripts, respectively. If you want to use this (and
your TEX installation supports Unicode, for that matter), choose one of the four
utf8 variants from the list below. Unfortunately the Unicode support of standard
ETEX is quite incomplete, so it is not uncommon that a file with lots of Unicode

2The known commands are defined in a text file. You can add commands for unknown symbols to
that file yourself, see the Customization manual for details.

3XeTEX is a TEX typesetting engine, an alternative for WTEX. It natively supports Unicode while
its input file is assumed to be in UTF-8 encoding. More about using LyX with XeTEX can be
found in [17].
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symbols works fine with Language Default (when IxX uses its list of known KTEX-

commands), but does not work with a fixed utf8 encoding (when the list of known

ITEX-commands is not used, because all Unicode symbols can be encoded in utf8).
Here is a list with the important encodings:

Language Default (no inputenc) Same as Language Default, but the IXTEX-package
inputenc is not used. When using this, you probably need to load some ad-
ditional packages manually in the preamble and specify the used encoding for
text parts in foreign languages in TEX code.

ASCII the ASCII encoding, covers only plain English (7-bit ASCII). Ly X converts
all other characters into IXTEX commands, which may result in a big file when
lots of KTEX-commands are needed.

Arabic (CP 1256) MS Windows code page for Arabic and Farsi
Arabic (ISO 8859-6) for Arabic and Farsi
Armenian (ArmSCII8) for Armenian

Baltic (CP 1257) MS Windows code page for Estonian, Latvian, and Lithuanian,
the same as the ISO-8859-13 encoding

Baltic (ISO 8859-13) for Estonian, Latvian, and Lithuanian, a superset of the ISO-
8859-4 encoding

Baltic (ISO 8859-4) (latin 4) for Estonian, Latvian, and Lithuanian, a subset of the
[SO-8859-13 encoding

Central European (CP 1250) MS Windows code page for ISO 8859-2 (latin2)

Central European (ISO 8859-2) (latin 2) covers Albanian, Croatian, Czech, Ger-
man, Hungarian, Polish, Romanian, Slovak, and Slovenian

Chinese (simplified) (EUC-CN) for simplified Chinese, used especially on UNIX
OSes, since 2001 this encoding is officially replaced by the encoding GB18030,
as GB18030 is not available for KTEX you should try to use the encoding Uni-
code (CJK) (utf8)

Chinese (simplified) (GBK) for simplified Chinese, is the same as the Windows code
page CP 936 except for the Euro currency sign, since 2001 this encoding is
officially replaced by the encoding GB18030, as GB18030 is not available for
IXTEX you should try to use the encoding Unicode (CJK) (utf8)

Chinese (traditional) (EUC-TW) for traditional Chinese
Cyrillic (CP 1251) MS Windows code page for Cyrillic

Cyrillic (1SO 8859-5) covers Belorussian, Bulgarian, Macedonian, Serbian, and Ukrainian
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Cyrillic (KOI8-R) standard Cyrillic especially for Russian
Cyrillic (KOI18-U) Cyrillic for Ukrainian

Cyrillic (pt 154) Cyrillic for Kazakh

Greek (ISO 8859-7) for Greek

Hebrew (CP 1255) MS Windows code page for Hebrew, a superset of the ISO-8859-
8 encoding

Hebrew (ISO 8859-8) for Hebrew

Japanese (CJK) (EUC-JP) EUC-JP encoding for Japanese, uses the KTEX-package
CJK, when using this, set the document language to Japanese (CJK)

Japanese (CJK) (JIS) JIS encoding for Japanese, uses the KTEX-package CJK,
when using this, set the document language to Japanese (CJK)

Japanese (non-CJK) (EUC-JP) EUC-JP encoding for Japanese, uses the KTEX-
package japanese, when using this, set the document language to Japanese

Japanese (non-CJK) (JIS) JIS encoding for Japanese, uses the NTEX-package japanese,
when using this, set the document language to Japanese

Japanese (non-CJK) (SJIS) SJIS encoding for Japanese, uses the KTEX-package
japanese, when using this, set the document language to Japanese

Korean (EUC-KR) for Korean

Southern European (ISO 8859-3) (latin 3) covers Esperanto, Galician, Maltese,
and Turkish

South-Eastern European (ISO 8859-16) (latin 10) covers Albanian, Croatian, Finnish,
French, German, Hungarian, Irish Gaelic, Italian, Polish, Romanian, Slovenian,
is designed to cover many languages and characters with diacritics

Thai (TIS 620-0) for Thai

Turkish (1SO 8859-9) (latin 5) for Turkish, is like the ISO-8859-1 encoding where

the Icelandic letters are replaced by Turkish ones

Unicode (CJK) (utf8) Unicode utf8 with the KTEX-package CJK (for the lan-
guages Chinese, Japanese and Korean)

Unicode (XeTgX) (utf8) Unicode utf8 to be used with XeTgX, which uses Unicode
directly, without the help of the IXTEX-package inputenc *

4More about using IyX with XeTEX can be found in [17].
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Unicode (ucs-extended) (utf8x) Unicode utf8 based on the ¥TEX package ucs (com-
prehensive, including Latin, Greek, Cyrillic and CJK scripts).

Unicode (utf8) Unicode utf8 based on the KTEX-package inputenc. Currently only
a limited range of characters (mainly for Latin scripts) is supported.

Western European (CP 1252) MS Windows code page for ISO 8859-1 (latinl)

Western European (ISO 8859-1) (latin 1) covers the languages Albanian, Catalan,
Danish, Dutch, English, Faroese, Finnish, French, Galician, German, Icelandic,
Irish, Italian, Norwegian, Portuguese, Spanish, and Swedish; better use the
[SO-8859-15 encoding instead

Western European (ISO 8859-15) (latin 9) like the ISO-8859-1 encoding, but with
the Euro currency sign, the ce-ligature and some characters used for French and
Finnish

B.8. Numbering & TOC

You can adjust here the numbering depth of section headings and the section depth
in the table of contents as described in section 3.3.4.3.

B.9. Bibliography

You can specify here a citation style using the KIEX-packages natbib or jurabib.
For a further description see section 6.5.

B.10. PDF Properties

The PDF properties are explained in section 6.9.

B.11. Math Options

These options will force IyX to use the ITEX-packages amsmath and esint or to
use them automatically when they are needed.

amsmath is needed for many constructs, so when you get I TEX-errors in formulas,
ensure that you have enabled AMS.

esint is used for special integral characters.

B.12. Float Placement

The float placement options are described in section 4.6.3.

119



B. The Document Settings

B.13. Bullets

Here you can adjust the characters for the itemize levels. The itemize environment
is described in section 3.3.6.2.

B.14. Branches

Branches are described in section 6.8.

B.15. LaTeX Preamble

In this text field are entered commands to load special KTpX-packages or to define
BETEX-commands. The preamble is a thing for BTEX-experts. You should not enter
commands here until you exactly know what you are doing.

An introduction to the IfTEX-syntax is given in section 6.10.2.
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C. The Preferences Dialog

The preferences dialog is called with the menu Tools> Preferences. It has the following
submenus.

C.1. Look and Feel

C.1.1. User Interface
C.1.1.1. User Interface File

Note: You have to restart LyX before the change of the user interface file take effect.

The appearance of the menus and toolbars can be changed by choosing a user
interface (ui) file. An ui-file is a text file where the toolbars and menus are listed.
The toolbar buttons and menu entries are specified in the files stdtoolbars.inc and
stdmenus.inc, respectively. Both files are loaded by the default.ui file. To create your
own menu and toolbar layout, start with a copy of these files and edit the entries.

The syntax of the .inc-files is straightforward: The Menubar, Menu and Toolbar
entries must be ended with an explicit End. They may contain Submenus, Items,
Optltems, Separators, Icons, and in the case of the “file” menus a Lastfiles entry. The
syntax for the entries is:

Item “menu or button name” “IyX-function”
All IyX-functions are listed in [27].

An example: Assuming you use the menu Navigater Bookmarks quite often and
therefore want six available bookmarks, you can add the line

Item “Save Bookmark 6” “bookmark-save 6”
to the navigate menu section in the .inc-file to have the sixth bookmark.

C.1.1.2. Automatic help

The option Enable tool tips in main work area enables tool tips showing the content of
closed insets like index entries or footnotes.

C.1.1.3. Session

With the option Allow saving / restoring of window layout and geometries [yX’s main
window will be opened with the size and layout that was used in the last LyX session.
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The option Restore cursor positions sets the cursor to the position in the file where
it has been the last time.

The option Load opened files from last session opens all files that were opened in
the last LyX session.

C.1.1.4. Documents

When the option Backup documents is set, you can specify the time between backup
saves.

Maximum last files is the number of last opened files that IyX should display in the
menu File>Open Recent.

When the option Open documents in tabs is not used, then every file will be opened
in its own new instance of LyX.

C.1.2. Screen Fonts

These fonts are used to display your documents on the screen.

Note: This section only deals with the fonts inside the LyX window. The fonts
that appear on the output are independent from these fonts, and set in the menu
Document > Settings > Fonts.

By default, Iy X uses Times as roman (serif) font, Arial or Helvetica (depends
on the system) as sans serif font, and Courier as typewriter font.

You can change the font size with the Zoom setting. You can also change the font
zoom outside the preferences dialog for the current IyX session by pressing Ctrl and
scrolling the mouse wheel.

Screen DPI is the screen resolution in dpi (dots per inch). The Font Sizes are
calculated as letter height in units of points. 72points have the size of 1inch, see
Appendix D.

The default Font Sizes are the same as if a document font size of 10 pt would be
used. The sizes are explained in detail in section 3.7.2.

With the option Use Pixmap Cache to speed up font rendering enabled, [y/X needs
to redraw the screen less often. This results in better performance, especially on slow
systems. On the other hand, the characters might look more fuzzy on screen. So
whether you enable this or not depends on whether you prefer speed over aesthetics.
Note that the Pixmap Cache is only available and useful under Mac OS and Windows.

C.1.3. Colors

You can here change all the colors used by LyX. Choose an item in the list and use
the Alter button.

C.1.4. Display
Here you can specify if graphics inside IiyX are displayed.
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C.2. Editing

Instant Preview enables previewing snippets of your document. This feature is
described in section 6.11.

The option Mark end of paragraphs displays a pilcrow (§) at the end of every
paragraph.

C.2. Editing

C.2.1. Control
C.2.1.1. Editing

The option Cursor follows scrollbar sets the cursor to the top of the currently displayed
document part when scrolling.

The option Sort environments alphabetically sorts the entries in the pull-down box
for the paragraph environments.

The option Group environments by their category groups the entries in the pull-down
box for the paragraph environments.

The math macro editing option determines the editing style, see the section Math
Macros of the Math manual.

C.2.1.2. Fullscreen

Here you can specify what is hidden in the fullscreen mode. The option Limit text
width specifies the width of the text in fullscreen mode. This way you can display the
text smaller than the screen, the text appears then centered.

C.2.2. Shortcuts
C.2.2.1. Bind File

Bindings are used to bind a IyyX-function to a key. Several binding files are available:
cua.bind typical set of PC keyboard shortcuts

(x)emacs.bind set of bindings like they are used in the editor programs Emacs
(XEmacs)

mac.bind set of bindings for Mac OS systems.

There are also bind-files designed for special document classes, like broadway.bind,
and bind files for special languages. The name of language bind-files begin with a
language code, e.g. “pt” for Portuguese. If you use LyX in a certain language, IyX
will try to use the appropriate bind-file.

Some bind-files, like math.bind, have only a small scope. When looking at the end
of the file cua.bind, you can see that they are included to keep the overview in the
bind-file.
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C.2.2.2. Editing Shortcuts

To add new or modify existing keybindings to your own taste you can use the table
in the dialog that lists all LyX-functions and the bound shortcuts. To find functions
easily, they are grouped by categories and the dialog provides the field Show key-
bindings containing. In this field you can insert a keyword for a function you want to
edit. Insert there for example as keyword “paste” and you get the 4 different existing
shortcuts for the 3 different functions that contain “paste” in their name. As you can
see, one function can have more than one shortcut. All LyX-functions are also listed
in the file LyX Functions that you will find in the Help menu.

To add e. g. the shortcut Alt+Q for the function textstyle-apply, select the function
and press the Modify button. A dialog pops up where you can add the shortcut by
using it. So press Alt+Q to define the shortcut. Modifying an existing shortcut is
done the same way. You can also bind multiple functions to one shortcut by modifying
an existing binding and adding the different function names as a semicolon separated
list. LyX will then use the first function that is enabled in the current document part.
The binding for the function command-alter is an example of this.

Alternatively you can also edit shortcuts by modifying bind-files with a text editor.
The syntax of the entries is:

\bind “key combination” “ILyX-function”

C.2.3. Keyboard / Mouse

Normally keyboard settings have to be done in a menu of your operating system. For
the case that this is not possible, IyX provides keyboard maps. If you have e.g. a
Czech keyboard but want to write with it like with a Romanian one, you can use the
keyboard map file named romanian.kmap.
Note: Keyboard maps are only provided as makeshift and don’t work on all

systems.

Besides this, you can specify here the Wheel scrolling speed. The standard value is
1.0, higher values speed up the scrolling, lower ones slow it down.

C.2.4. Input Completion

Input completion is described in sec.2.6. The completion options for math do the
same as the corresponding options for text. With the general options you can define
the delay time for the inline and popup completion and choose if long completions
should be abbreviated or not.

C.3. Paths

Working directory This is IyX’s working directory. It is the default when you Open,
Save or Save as files.
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C.4. Identity

Document templates This directory will be opened when you use the menu Filer
New from Template.

Example files This directory will be opened when you use the button Examples in
the FilerOpen dialog.
Note: The Examples button does not exist when using Iy’X on MacOS and
Windows systems.

Backup directory Backup copies will be saved to this directory. When no directory
is given but backups are enabled as described in section C.1.1.4, the Working
directory will be used to save the backups.

The backup files have the ending “lyx~".

LyXServer-Pipe Here you can enter the name of a Unix-pipe. This pipe is used to
send data from external programs to LyX.
Note: This feature doesn’t work on Windows systems.

Temporary directory Temporary files will be saved in this directory.

PATH prefix This field contains a list of paths to external programs. When [yX
needs to use an external program, it looks in this list where to find it on the
system. The path list is automatically set up on Windows and Mac systems
when LyX is configured, so that you normally don’t have to modify it. On
Unix / Linux systems, the path list will need to be set only if there are external
programs you wish to use that are not in your normal system path ($PATH).

C.4. ldentity

Here you can insert your name and email address. The identity will be used when
you have enabled change tracking as described in section 6.14, to mark changes you
make as yours.

C.5. Language Settings

C.5.1. Language

User Interface language Here you can select the language of IyX’s menus. Unfor-
tunately this doesn’t work on Mac and Windows. It works on Linux for the
languages into IyX’s menus and dialogs are translated. You find the actual
translation status here: http://www.lyx.org/I18n

Default language is the language used in new documents

Language package is a IXTEX-command to load a I¥TEX-package that handles lan-
guage issues. The default is the IXTEX-command \usepackage{babel} that loads
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the package babel.!

babel automatically translates in the background the text labels of documents
to the document language. A text label is, for instance, the word “Table” at
the beginning of every table caption.

Command start When a special KTEX-package is needed to write in a certain doc-
ument language, you can here specify the command to start the package. An
example is the start command \begin{arabtext} that is needed to write Arabic
using the package ArabTgX, see [18]. The default is the babel command
\selectlanguage{$$lang}.

Command end Counterpart to Command start. Some packages, like the default,

don’t have an end command since the start command toggles the package on
and off.

Use babel Whether babel is used or not.

Global When this option is set, the languages used in the document will be added as
options to the document class options, so that they can be used by all I¥TEX-
packages. Otherwise they will only be used as options for the babel package.

Auto begin When this option is set, the documents starts with the chosen document
language. When this option is not set, the Command start is explicitly set to the
beginning of the document in the I¥TEX-output. This assures that the correct
language is used when you use another Command start than the default.

Auto end Counterpart to Auto begin. When it is not set, the Command end is set to
the end of the document.

Mark foreign languages Text marked formatted in a language different from the
document language will be underlined blue.

Enable RTL support Enables the use of languages, written from right to left (RTL),
like Arabic, Hebrew, Farsi.

Cursor movement When writing RTL, you can define if the left and right arrow keys
move the cursor visually to the left or right, respectively, or logically. Logical
means that the cursor is moved to the left when pressing the right arrow key
and the cursor is inside text in an RTL language.

C.5.2. Spellchecker

The spellchecker settings are explained in section 6.12

IFor an introduction to the IXTEX-Syntax, have a look at section 6.10.
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C.6. Outputs

C.6. Outputs
C.6.1. Printer

Default printer Here you can specify the name of your default printer. The name
will be used when the Printer command is executed.
Note: You can leave this field empty on Windows systems because it has no
effect.

Adapt output to printer This option works only for the Printer command “dvips”. It
activates a configuration file for dvips. This is an option only for dvips experts.

Printer command is the command IyX / X¥TEX uses for printing. The default is on
most systems dvips.

Printer Command Options Here you can specify printer options. A list of printer
options with explanations can be found in the documentation of the program
that provides the Printer command you are using.

C.6.2. Date Format

The date format can be one or a mixture of the formats listed here:
http://unixhelp.ed.ac.uk/CGI/man-cgi?date

For example the format

%d/%m /%y

prints the date as day/month /year.

C.6.3. Plain Text

Output line length sets the maximum number of characters printed in one line when
using the menu Filer> Export > Plain text. Setting the line line length to 0 means
all text is printed in one endless line.

roff command defines an additional command used to produce better ASCII tables
with the groff/troff/nroff UNIX-commands (refer to their manuals for more
information about them). Setting this as empty tells yX to use the internal
formatter.

C.6.4. LaTeX

TeX encoding This is the default encoding of the document font. T1 is the default
and covers western languages and symbols. T2A, T2B, T2C, LCY, and X2 are
for Cyrillic. Combinations of the encodings are possible, like "T1, T2B”. The
font encoding is normally automatically loaded by the language packages 12X
sets up in the background. So there is no need to change the default encoding.
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Default paper size This is the paper size that is used for new documents. The
Default value depends on your BTEX-system setup.

You can also specify here commands with parameters for the listed applications. But
before you change something, it is strongly recommended to read the manuals of the
applications. Currently the following commands can be set:

CheckTeX command Command for the program CheckTEX that is described in the
section Checking TpX of the Additional Features manual.

BibTeX command Command for the program BibTEX that generates the bibliogra-
phy, see section 6.5.2.

Index command Command for the program that generates the index, see section 6.6.6.

Nomenclature command Command for the program that generates the nomencla-
ture, see section 6.7.5.

DVI viewer paper size options They only have an effect when the program xdvi is
used as DVI-viewer.

There are additionally the following options:

Use Windows-style paths in BTEX files Uses paths in the notation of Windows,
that means that “\” is used instead of “/” to separate folders. This option
is enabled by default when you use IyX on Windows.

Reset class options when document classes changes Removes all manually set doc-
ument class options in the Document > Settings dialog when changing the docu-
ment class.

C.7. File Handling

C.7.1. Converters

Here you find the list of defined converter commands to convert material from one
format to another. You can modify them or create new ones. To modify a converter,
select it, change the entry of the field Converter and/or Extra flag, and press the
Modify button. To create a new converter, select an existing one, select a different
format in the From format drop-down list, modify the Converter field, and press the
Add button.

When the Converter File Cache is enabled, conversions will be cached as long as
specified in the field Maximum Age (in days). This means that images don’t need
to be converted again when you reopen a document; the converted images from the
cache will be used instead.

More about converters, like the variables and flags that can be used in the converter
definition, is described in the section Converters of the Customization manual.
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C.7.2. File Formats

Here you find the list of defined file formats that IyX can handle. You can modify
the viewer and editor program that should be used for certain formats.

More about formats, like the options that can be used in the format definition, is
described in the section Formats of the Customization manual.

Since all conversions from one format to another take place in IyX’s temporary
directory, it is sometimes necessary to modify a file before copying it to the temporary
directory in order that the conversion may be performed. This is done by specifying
a Copier. More about this is described in the section Copiers of the Customization
manual.
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D. Units available in LyX

To understand the units described in this documentation, D.1 explains all units avail-
able in IyX.

Table D.1.: Units

unit | name/description
mm millimeter
cm centimeter
in inch
pt point (72.27pt = 1in)
pc pica (1pc = 12pt)
sp scaled point (65536 sp = 1pt)
bp big point (72bp = 1in)
dd didot (72dd ~ 37.6 mm)
cc cicero (1cc = 12dd)
Scale% % of original image width
text% % of text width
col% % of column width
page% % of paper width
line% % of line width
theight% % of text height
pheight% % of paper height
ex height of letter = in current font
em width of letter M in current font
mu math unit (1mu = 1/18em)
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Nomenclature

a dummy entry for the character a
Alt Alt or Meta key

Ctrl Control key

Esc Escape key

Shift Shift key

Tab Tabulator key

o dummy entry for the character sigma
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my entry, 86

This is an italic dummy entry,
86

Editing, 4
EPS, see Image formats
External Material, 107

File formats, 46, 129
ASCII, 46
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PostScript, 47
File handling, 128
File Operations, 3
Find, 4
Floats, 62
Algorithm floats, 64
Captions, 62
Figure floats, 63
Placement, 66
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Rotating, 65
Table floats, 64
Text Wrap Floats, 65
Font
Screen, 122
Size, 41
Types, 40
Fonts
Bitmap-, 40
Vector-, 40
Footnotes, 55
Formulas, see Math

GIF, see Image formats

Glossary, see Nomenclature
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Hyperlinks, 81
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Formats, 57
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Index
Cross referencing, 85
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Page ranges, 85
Program, 86
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Instant preview, 92
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JPG, see Image formats

Key Bindings, 7, 123
Editing, 124
Keyboard Map, 124

Language
Encoding, 116
Options, 96
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Phonetic symbols, 105

Settings, 125
ETEX Syntax, 91
IETEX-packages

amsmath, 119

babel, 49

caption, 91, 135

CJK, 118

dvipost, 96

esint, 119

fancyhdr, 12, 135

hyperref, 90, 136

inputenc, 117, 119

japanese, 118

jurabib, 119

natbib, 119

nomencl, 87, 136

prettyref, 80

preview-latex, 92

tipa, 105, 136

ucs, 119

wrapfig, 65, 136
ETEX-packages

aeguill, 41

pstricks, 47

setspace, 14
Layout Modules, 77
Letters, 24

Ligatures, see Typography

Line breaks, 39
Lists, 20
Description, 22
Enumerate, 21
Itemize, 20
LyX list, 23
Longtables, 59
Caption, 107
LyX
Basics, 9
Proper names, 52

Reconfigure, see Reconfigura-

tion of LyX

Marginal notes, 56
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Macros, 76

Matrices, 73
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Referencing formulas, 75

Environments, 15
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Settings, 103
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Document, 109 Y
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) Printer, 127
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Program listings, 108
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Minipages, 68 Reconfiguration of LyX, 110
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Unnumbered, 17
Settings
Color, 122
Date format, 127
Display, 122
Editing, 123
Keyboard Map, 124
Language, 125
BTEX, 127
Paths, 124, 128
Printer, 127
Shortcuts, 123
Shortcuts, see Key Bindings
Spaces
Inter-word, 35
inter-word, 50
Protected, 35
Thin, 36
thin, 50
Spacing, 35
Fills, 36, 38
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Phantom, 37
Vertical, 38
Spell checking, 93
SVG, see Image formats

Table of contents, 80
Tables, 58
Cells, 61
Longtables, 59
TEX Code, 91
TEX Information, 110
Text Style, 42, 43
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Toolbar, 104
Extra, 112
Macro, 114
Review, 95
Standard, 111
Table, 114
View / Update, 113
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Quotes, 51
Units, 52
Widows and orphans, 53

Undo, 5
Units, 131
URLs, 81

Word completion, see Input com-

pletion
Word count, 110
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