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1. Introduction

This document explains LyX’s math features and is furthermore a collection of IXTEX-
commands used for mathematical characters and constructs. The explanations are
designed for the usage of commands. It is therefore required that you have read the
section Mathematical Formulas of the User’s Guide.

Most of the characters and many constructs explained in this manual are also ac-
cessible via the menu Insert>Math, or the math toolbar. But everybody who has to
write lots of formulas will notice that it is much faster to use commands instead of
the math toolbar. Therefore this manual is focused on commands but also mentions
the corresponding toolbar buttons when available.

If not specially mentioned the commands are only available within formulas. To
be able to use all commands explained in this document, the option Use AMS math
package must be used in the document settings (menu Document > Settings > Math Op-
tions).!

This document doesn’t list all Ap4S-math commands? for lucidity reasons.

2. General Instructions

To create an inline formula that is embedded into a text line, use one of the shortcuts

a+b
Ctrl+M, Alt+C M, Alt+M M or the toolbar button —¢

To create a display style formula that will appear bigger and in an own paragraph,
use one of these shortcuts: Ctrl+Shift+M, Alt-++M D.

To change a display style formula to an inline formula, set the cursor into the formula
and use one of the shortcuts Ctrl4+M, Alt+C M, Alt+M M or the menu Edit> Math>
Change formula type. The same way is used to change an inline formula to a display
style formula.

To display parts of an inline formula in the size of a display style formula, enter the
command \displaystyle to a formula. Then a new blue box appears in which the
desired formula part is inserted.

Only inline formulas are allowed inside tables.

The math toolbar can be turned on in the menu View> Toolbars. When you click
there on “Math” the toolbar will be shown permanently at the bottom; this state is
visualized in the Toolbars menu with a checkmark. When you click in this state again

!The option Use AMS math package automatically only uses AA(S-math when math constructs are
found that are supported by LyX.

2A list with all A\(S-math commands is in the file amsguide.ps, which is part of every TEX
standard installation.


ftp://ctan.tug.org/tex-archive/macros/amstex/doc/amsguide.ps

on “Math” in the Toolbars menu, the math toolbar is only shown when the cursor is
within a formula; this state is visualized by the renaming of the menu entry from
“Math” to “Math (auto)”.

The TEX-mode is invoked by pressing the toolbar button TeX or by using the menu
Insert> TeX Code (shortcut Ctrl+L).

To change the KTEX-preamble, use the menu Document > Settingst>LaTeX Preamble.

To edit matrices, case differentiations and multiline formulas subsequently, the menus
Edit>Math and Edit> Rows & Columns, or the table toolbar can be used. When lines
and columns are swapped via the menu, the column or line where the cursor is in is
exchanged with the column to the right or the line below, respectively. Is the cursor
in the last column or row, the exchange is done with the column to the left or the
line above.

To write text in formulas® mathematical text is used. This mode is invoked with the
shortcut Alt+C Space or by the insertion of the command \text. The text appears
black in IyX and can therefore be distinguished from the other formula parts that
appear blue. In the output mathematical text is set upright, in contrary to other
formula parts.

Command Scheme

Most of the IXTEX-commands for math constructs have the following scheme:
\commandname[optional argument|{required argument}

A command starts always with a backslash ,\“ To omit optional arguments, also
omit the associated brackets. The braces around the required arguments are named in
this document as TEX-braces. If you add in a formula a left brace to a command name,
LyX creates automatically a TEgX-brace. In all other cases TEX-braces are created in
formulas with the command \ {. TEX-braces appear red in IyX, in contrary to normal
braces that appear blue. In TEX-mode no command is needed to get TEX-braces.
TEX-braces don’t appear in the output.

When commands without arguments, like commands for symbols are entered in TEX-
mode, a space character must always be behind the command to end it. This space
doesn’t appear in the output. When the space should appear in the output, the space
must be followed by a protected space in normal text.

A protected space is inserted with Ctrl+Space.

3For multiline formulas the command \intertext is used, see sec. 18.7.



Syntax Explanation

e The symbol* | denotes a space character to be input.

e An arrow like — denotes the usage of the corresponding arrow key on the

keyboard.

Available units

Table 1: Available units

| Unit | Name / Description

mm Millimeter

cm Centimeter

in Inch (1in = 2,54 cm)

pt Point (72.27pt = 1in)

pc Pica (1pc = 12pt)

sp scaled point (65536sp = 1pt)

bp big point (72bp = 1in)

dd Didot (1dd = 0.376 mm)

cc Cicero (1cc = 12dd)

ex | Height of letter “z” in the current font
em | width of letter “M” in the current font
mu math unit (1 mu = /1sem)

4This visible space character can be created with the command \textvisiblespace, inserted in

TEX-mode.



3. Basic Functions

3.1. Exponents and Indices

_ 7 or via the math toolbar button On ,

DD

13

Indices are created with an underscore

exponents with a caret “~” or via the math toolbar button

’ command \ Result ‘

B_V By
B™V BY
BT A BA

As the caret is in some languages an accent, vowels will be accentuated in this case
and not set as exponents®. To get in this case exponents, press Space after the caret
as in the last example.

3.2. Fractions

a
Fractions are generated with the command \frac or via the math toolbar button b.
The font size is adjusted automatically, depending on whether the fraction is in an

[m]
inline or display style formula. With the math toolbar button T you can select
different fraction types.

With the command \dfrac a fraction can be created that has in any case the size of
a display style formula. With \tfrac the fraction appears always with the size of an
inline formula. An example:

A line with the fraction 3 that was created with the command \frac.

1
A line with the fraction 3 that was created with the command \dfrac.

’ Command \ Result ‘
\frac A|B 4
A
\dfrac A|B B
\dfrac e \frac 1{2]]3 632

5Depending on the used keyboard settings this can also happen for other characters than vowels.



For nested fractions the command \cfrac can be used. Here is an example:

created with \frac created with \cfrac
A A
E —
F
j - —
* D

The command for the example above is:
\cfrac A |B+\cfrac C+\cfrac E/F|D

\cfrac sets the fraction always in the size of a displayed formula, also when it is part
of another fraction.

It is possible to specify the alignment of the numerator. The command \cfracleft is
used to left align it, the command \cfracright to right-align it. \cfrac centers the
numerator. These fractions demonstrate the different alignments:

A A A

B+C" B+C B+C

Note: \cfracleft and \cfracright are no real KTEX commands but represent
the command \cfrac[alignment]|{numerator}{denominator} . Therefore you
cannot use them in TEX code.

It is often advantageous to combine \cfrac and \frac:

A

C+Z
B4+ _F
* D

For inline fractions with a sloped fraction stroke you can use the command \nicefrac:
5/31 or \unitfrac: 5/31 There is furthermore the command \unitfracthree that offers
to write a fraction in combination with a number: 21/3

Note: \unitfracthree is not a real ¥TEX command but the command
\unitfrac[number|{numerator }{denominator} . Therefore you cannot use it

in TEX code.

How to define own fractions where the fraction stroke can be changed, is explained
in sec. 23.4.

3.3. Roots

Square roots are created with \sqrt or the math toolbar button v all other roots
with the command \root or with the math toolbar button va.



] Command \ Result ‘

\sqrt, A-B | VA—-B
\root. 3JA-B | VA—B

A square root can also be created with \root when the root index field is left empty.

With certain indices the distance to the root is too small, like in this formula: /B
The S touches the root. To avoid this, the commands \leftroot and \uproot are
used with the following scheme:

\leftroot{distance} and \uproot{distance}

Distance is the number of Big Points (unit bp; 72 bp = 1inch), that the index should
be moved to the left or top, resp.. The commands are written to the index. This way
the command

\root\leftroot{-1—\uproot{2—\beta ,—B

produces a correct typeset formula: VB

3.4. Binomial Coefficients

Binomial coefficients are inserted with the command \binom or with the submenu

o

of the math toolbar button T . Analog to fractions (\frac) there are besides \bi-
nom the commands \dbinom and \tbinom. For other brackets around binomial
coeficients there are the commands \brace and \brack.

[ Command \Result\
\binom A|B

\dbinom AL (B)
\tbinom AIB | (3)
\brack AIB | 3]
\brace. A|B | {3}

3.5. Case Differentiations

\ Command \ Result ‘
\cases A—B>0 {A B >0
A forz>0
Ctrl4-Ret
\cases, ,Ctrl+Return {B for & = 0




u
After inserting \cases or the usage of the math toolbar button {D you can create

new lines with the shortcut Ctrl+-Return or the table toolbar button E

The command \cases is also available via the menu Insert > Math > Cases-Environment.

3.6. Negations

By inserting of \not every character can be displayed canceled. The characters are
quasi accentuated by a slash.

’ Command \ Result ‘
\not= #
\not \le e
| \not \parallel | [} |

The last example shows, that not all negations look good. Therefore there are for
some negations special commands (see sec. 13.1 and sec. 14).

3.7. Placeholders
When displaying e. g. isotopes® the following problem occurs:

Indices created with sub- and superscripts: §°F

correct indices: F

The shorter index is by default placed below or above the first character of the longer
index. To avoid this there is the command \phantom or the math toolbar button’

% that creates one or more phantom characters. When inserting \ phantom a small
blue box appears that is superposed with two red arrows. The arrows indicate that
the complete width and height of the box content will be created as placeholder.
Phantom characters are accordingly placeholders with the size of the characters.

’ Command ‘ Result ‘
A19u7\phant0m41—>94F 18F
7235, \phantom, 23—9 F 20F

\Lambda™ \phantom, ii—t _ MMt | A},

6Typesetting isotopes and chemical symbols is described in sec. 20.

“can be found in the submenu of the toolbar button ™



Furthermore there are the commands \ vphantom (toolbar button I) and \hphan-

tom (toolbar button H) \hphantom creates only space for the maximal height of

the characters in the box but not for its width. \vphantom creates only space for
the width of the box content. Therefore the boxes of both commands have only one
red arrow.

For example creates \vphantom a\int space for the height of the integral sign,®
because this is the larger character. An example application is in sec. 18.1.4.

3.8. Lines

’ Command \ Result ‘
\overline A+B A+ B
\underline ,A+B A+ B

\overline \underline A+B | A+ B

In the last example it doesn’t matter if first \overline or \underline is inserted.
To double underline e. g. results, one uses \underline twice.

It is possible to place up to 6 lines above or below characters.

Custom lines can be created using the command \rule which has the following
scheme:

\rule[vertical offset]{length}{thickness}

The optional vertical offset shifts the line upwards (or downwards, when the value
is negative). The units listed in Table 1 can be used for the values. Here are two
example lines created with the commands

\rule[-2ex]{3cm}{2pt} and \rule{2cm}{1pt}:

This is a sentence — with two lines.

\rule can also be used for text when it is inserted in TEX-mode.

3.9. Ellipses

There are different types of ellipses available.? For listings dots at the baseline are
used (\ldots), while for operations dots are needed that are on the same height as
the operators (\cdots). When using the command \dots, IXTEX decides on the basis
of the next character what type is used.

8The command \int creates an integral sign, see sec. 10.1.

9n the math toolbar in the submenu of the button * * *



] Command \ Result ‘

A 1, ,\dots ,A n A, A,
A 1 +\dots +A n A4+ A,
A_1,\ldots ,A_n A, A,
A_1, +\cdots +A_n Al +---4+ A,
\vdots
\ddots :
Ay o A
3x3 matrix with the different dots o :
Anl T Anm

The ellipses available in menu Insert>Special Character are \ldots.

Specially for matrices there are ellipses that span over several columns. They are
created with the command \ hdotsfor, that has the following scheme:
\hdotsfor[distance]{number of columns}

The number of columns specifies how many columns should be spanned. Distance is
a factor for the distance between the dots.

In the following matrix the command \hdotsfor[2]{4} was inserted in the first box
of the second line, to get an ellipsis with a dot distance twice as long as with the
command \dots:

qg w e T

Note that the matrix fields that should be spanned must be empty, otherwise you
get WTEX-errors.

Furthermore you can fill with the command \ dotfill the rest of a line with dots. The
effect of these commands is the same like with \hfill, see sec. 8.2.

For example the command A\dotfill B produces

A B
Analog to \dotfill there is for a line the command \ hrulefill:
A B

To use the commands for text, they have to be inserted in TEX-mode.

4. Matrices

Matrices can be inserted via the math toolbar button BeEa or the menu Insert > Math >
Matrix. You will be asked for the number of matrix columns and rows and the



alignment. The vertical alignment is hereby only of importance for matrices in inline
formulas:

The first matrix is top and the

, the second middle

QW=
BlGEw)
~ T Q
N

A D G J

B E H K

third bottom C F I L aligned.

The horizontal alignment specifies how the column entries should be aligned. It is set
by entering a letter for every column. [ denotes left aligned, ¢ centered and r right
aligned. To create for example a 4Xx4 matrix where the first column is left aligned,
the second and third are centered and the last one is right aligned, one enters for the

horizontal alignment lccr. Normally are in a matrix all columns centered, therefore
the default is for every column is a c.

Horizontal alignment:

10000 D G 10000 D G 10000 D G
n: B 10000 H ,ccc: B 10000 H [ rrr: B 10000 H
C F 10000 C F 10000 C F 10000

To add or delete rows and columns subsequently, the math toolbar buttons %E, EH’,
etc., or the menu Edit> Rows & Columns can be used. New rows can also be created
with Ctrl4+-Return.

Parentheses around a matrix can can either be created with the commands \left
and \right (shortcut Alt+M Parenthesis), see sec.5.1.2, or by using the following
commands:

’ Command \ Result ‘ ’ Command \ Result ‘
. . 0 -i . . 0 -i
\bmatrix, 2 X 2 matrix _— \vmatrix 2 X2 matrix -
. . 0 - . . 0 -
\Bmatrix, 2X2 matrix L0 \ Vmatrix, 2 X 2 matrix .
. . 0 - . . 0 -
\pmatrlxu2 X 2 matrix < {0 ) \matrlxg X 2 matrix L0

When e. g. \viatrix is inserted, a blue box appears between two vertical lines where
the matrix is inserted.

As all multiline formulas are matrices, the length \arraycolsep that is described in
sec. 18.1.2 can also be used to change the column separation of matrices.

10



To change the row separation, the command \arraystretch is used. It is used as
follows:

\renewcommand{\arraystretch}{stretch factor}

The command \renewcommand assigns the stretch factor to the predefined com-
mand \arraystretch. To double e.g. the row separation, use the factor 2. This is
then used for all following matrices. To go back to the original separation, assign the
factor 1 to \arraystretch.

To set matrices into a text line, the command \smallmatrix is used. When it is
inserted a blue box with two dashed lines appears. In this box the matrix is inserted.

This is a matrix (4 B) in a text line.

5. Brackets and Delimiters

5.1. Vertical Brackets and Delimiters

’ Command \ Result ‘ ’ Command \ Result ‘

( ( ) )

{ { } }

[ [ ] ]
\langle ( \rangle )
\lceil [ \rceil 1
\Ifloor | \rfloor |

/ / \\ \

| | \| |

Note: In TEX-mode the command \textbackslash must be used for the backslash,
because the command \\ produces there a line break.

For all characters listed above the size can be adjusted with the commands described
in the following two subsections. When using these commands, the characters < and
> can directly be used instead of the commands \langle and \rangle.

5.1.1. Manual Bracket Size

The bracket size can be specified manually by the KTEX-commands \big, \Big,
\bigg and \Bigg. \big denotes the smallest and \Bigg the largest bracket size.

These commands are used to emphasize levels of brackets:
all brackets in the same size: ((A+ B)(A — B))®

c
this looks better: ((A + B)(A— B))

11



For the second formula the command \Big((A+B)(A-B)\Big) " /C has been used.

Here is an overview about all bracket sizes:

\Bigg(\exp\bigg<\Big[\big{\In(3x)\big} 2. \sin(x)\Big|] " _A.\bigg>\Bigg) 0,5

)

Besides the \big-commands there is the variant \bigm that adds a bit more space
between the bracket and its content, and the variant \bigl-\bigr, that don’t add
additional space. The [ at the end of the command \bigl is for a left bracket; for
a right bracket this will be replaced by an r. A left or right bracket can each be an
opening or closing bracket.

0,5

(exp < [{ In(3x) }2 sin(x)

In the following table is a comparison of the variants:

’ Command \ Result ‘
\Bigm(\bigm(\In(3x)\bigm)"2.\ Bigm) <<ln(3x)>2)
\Big(\big(\In(3x)\big) 2 \Big) | ((In(32))’)
((me))

\Bigl(\bigl(\In(3x)\bigr) "2, \Bigr)
\bigl)\In(3x)\bigr( )In(3z)

5.1.2. Automatic Bracket Size

Brackets with variable size can be inserted with the commands \left and \right

or via the math toolbar button [[” Directly behind \left and \right the wanted
bracket must be inserted. The bracket size will then automatically be calculated for
the output.

normal bracket: The command \In(\frac ,A|C ) creates

multiline bracket: The command \In\left(\frac ,A]C \right) creates
A
(2
n<c>

12



Instead of \left and \right the shortcut Alt+M Bracket can be used. This has the
advantage that you can see in LyX immediately the real bracket size and that the

matching right bracket will be created too.
The command for the last example would then be: \In Alt+M (\frac A]C

To omit a left or right bracket, a dot is inserted for the omitted bracket. For example
the command \left.\frac ,A|B, \right} creates:

)
B
The commands \left and \right will be converted by IxX to brackets in the right

size when the document is reloaded and an omitted bracket will appear as dashed
line.

Because all popular KTEX-Distributions use eTEX, an extension to IXTEX, the com-
mand \middle is additionally available for all brackets and limits. With this com-
mand the height of the following character is adapted to the one of the surrounding
brackets, what is e. g. needed for physical vectors:

(ofs=3.20)

For physical vectors there is a special ¥ TEX-package, described in sec. 23.3.

5.2. Horizontal Brackets

’ Command ‘ Result ‘
3
\overbrace A+B, "3 A+ B
A+ B

\underbrace A+B,, 5

5
C

. et

\overbrace \underbrace A+B_w.. . 7.7 .C | A+ B,
7

In the last example it doesn’t matter if \overbrace or \underbrace is inserted at
first.

When brackets are needed that overlap each other, multiline formulas, as described
in sec. 18, must be used:

A = gggg+ bbgq+ dddd
| ———

r

| ——
s

13



In the first row the formula is inserted together with the first brace. It is hereby
important that the space command'® \: is inserted before the first d, because the
brace that ends behind the ¢ prevents that the following “+” is surrounded by space.!!
In the second row the second brace is inserted. As it should begin before the b, first
the command \hphantom{gggg+\:} is inserted.!? This space is needed because
the “47 is also surrounded by space in the formula. The brace is placed under the
command \hphantom{bbqq+dddd}.

It gets more complicated when brackets overlap each other, like in the following
example:

S

—_—N—
A = gggg + bbqq + dddd
—_—

T

The first formula row is the same as the second row of the previous example, with
the difference that the brace is above. The second row contains the formula together
with the second brace. To avoid that there is space between the upper brace in the
first row and the formula, the row spacing need to be reduced. This is not easily
possible due to a bug in IyX'™. As solution for the problem, the global formula
row separation \jot must be changed to -6 pt before the formula with the command
\setlength{\jot}{-6pt} in TEX-mode. \jot is set back after the formula to the
standard value of 3 pt using the same command. More about the row separation in
formulas is explained in sec. 18.1.1.

6. Arrows

—

Arrows can be inserted via the math toolbar button or the commands listed in

the following subsections.

108pace commands are explained in sec. 8.1.
Hhecause a bracket is not handled as character, see sec. 10.3
2more about \hphantom see sec. 3.7

BLyX-bug #1505
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6.1. Horizontal Arrows

’ Command \ Result ‘ ’ Command \ Result ‘
\gets “— \to —

\ Leftarrow = \Rightarrow =
\longleftarrow — \longrightarrow —
\Longleftarrow — \Longrightarrow —
\leftharpoonup ; \rightharpoonup —

\leftharpoondown — \rightharpoondown —
\hookleftarrow — \hookrightarrow —
’ Command \ Result ‘ ’ Command ‘ Result ‘

\leftrightarrow “ \mapsto =
\ Leftrightarrow & D

- \longmapsto |
\longleftrightarrow | <+—

. \leadsto ~
\Longleftrightarrow | <= \dasharrow —
\rightleftharpoons =

Arrows used as accent like e. g. vector arrows are listed in sec. 7.

Furthermore there are the labeled arrows \xleftarrow and \xrightarrow. When
inserting one of these commands in a formula, an arrow with two blue boxes appear
where the label can be inserted. The length of the arrow adapts to the label width.

’ Command \ Result ‘

F(a)\xleftarrow, x=alx>0—F(x) | F(a) % F(z)

F(x)\xrightarrow, x=alx>0—F(a) | F(x) % F(a)

6.2. Vertical and diagonal Arrows

’ Command \ Result ‘
\uparrow 1 ] Command \ Result ‘
\Uparrow f \nearrow S
\updownarrow ) \searrow N
\Updownarrow x \swarrow N4
\Downarrow (8 \nwarrow N
\downarrow {

Vertical arrows can be used also as delimiter together with the commands described
in sec.5.1.1 and sec.5.1.2.

15



7. Accents

Accents can be inserted via the math toolbar button i.i or the commands listed in
the following subsections.

7.1. Accents for one Character!?

’ Command ‘Result‘

’ Command \ Result ‘

\dot, A A . 7
o A ¥ \tilde.A | A
[ N
hat, A A
\dddot A | A \a -
\ddddot A | A \check A | 4
\ AL 7 \acute A A
vec, :
\bar A ki \grave A A
- - \breve A A
\mathring, A A

You can directly insert accents like é to formulas. LyX will transform them to the
corresponding accent command. For umlauts it is better to insert a quotation mark
before the vowel. These two characters are then treated by ITEX as one character
when the formula part with the umlaut is marked as German. In contrary to \ddot,
with this method “real” umlauts are created as demonstrated in the following exam-
ple:

’ Command \ Result ‘

((i

7

\ddot, i i

Another advantage to \ddot is that umlauts can directly be converted to mathemat-
ical text because the accent commands above are not allowed in mathematical text.
To convert an accented character to mathematical text, only the character under the
accent may be converted. This applies also for all other conversions, e. g. to italic or
bold.

In mathematical text, umlauts and other accented characters can directly be inserted.

7.2. Accents for Operators

With the commands \overset and \underset characters can be placed above or
below an operator, respectively, to accent it. With the command \sideset characters
can be set before and behind an operator. The command scheme is:

Maccents in text see sec. 16.2
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\sideset{character before}{character behind}

\sideset must always be before the operator that should be accented. You can accent
with several characters and even with other operators and symbols. To place with
\sideset for example only characters behind an operator, write nothing between the
first braces but don’t omit the braces.

For example the command \sideset{—\{'—\sum__k=1,,"n produces:

The command \overset, \maltese ta produces:

a

e

As seen in the last example, with \overset and \underset also symbols and char-
acters can be accented; with \sideset this is not possible.

7.3. Accents for several Characters

\ Command | Result | | Command | Result |
\overleftarrow A=B 1=B \overrightarrow, A=B A=B
\underleftarrow, A=B A=2B \underrightarrow A=B | A= B
\overleftrightarrow, A=B Iy \widetilde , A=B A=B
\underleftrightarrow A=B | A = B \widehat A=B A—B

With these commands as many characters as you like can be accented. But the
accents \widetilde and \widehat will only be set in the output with a length of
three characters, as shown in the following example:

e~

A+B=C-D

With the commands \overset and \underset described in the previous subsection
it is also possible to accent several characters. The command \underset,  A=B]***
creates:

A=B

ok sk
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8. Space

8.1. Predefined Space

Sometimes it is necessary to insert horizontal space to a formula. This is done by in-
“wo»n

serting a protected space (shortcut Ctrl+Space). 7 appears and by pressing Space
several times one can select one of eight different space sizes. The spaces can also be

inserted using the math toolbar button ™ or special commands. Independent from
the inserted command, one can select the size again by pressing Space afterwards.

Command \, \: \; | \quad | \qquad | \!
Ngmber. of Space keystrokes after 0 1 9 3 4 5
inserting the protected space
Result AB|AB|AB|A B | A B | AB

The last size seem to produce no space. It is displayed red in IyX contrary to the
other sizes, because it is a negative space. There are two more negative spaces:

Command \negmedspace | \negthickspace
Number of Space keystrokes after
. . 6 7
inserting the protected space
Result AB AB

Negative spaces can lead to characters overlapping each other. Thus they can be
used to enforce ligatures, what is e. g. useful for summation operators:

’ Command \ Result ‘

\sum\sum f kl S5 fu
\sum\negmedspace\sum, f kl | >3 fu

Relations like for example equal signs, are always surrounded by space. To suppress
this, the equal sign is placed into a TEX-brace. The following example demonstrates
this:

normal equation A=B

equation without space A=B

The command for the last formula is: A\{=—B

Spaces are needed for physical units, because the space between the value and the
unit is the smallest one and not a normal space. For units in text, the smallest space
is inserted via the menu Insert > Formatting> Thin Space (shortcut Ctrl+Shift+Space).

An example to visualize the difference:

24 kW-h space between value and unit
24kW-h smallest space between value and unit
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8.2. Variable Space!®

Space with a defined length can be inserted with the command \hspace. Then a
long “ 7 appears. The length can be specified by left-clicking on the “ ”. The length
may also be negative. To insert so many space that the formula uses all available

space, the command \hfill is used.

| Command (\hspace length) | Result |
A=B\hspace —A\not=C (3cm) | A=B A#£C
A\hspace —A\not=A (-1 mm) A #£ A

| A=A\hfill B=B A=A B=DB]|

In the last example the available space is given by the longest column entry of the
table. In an inline formula the space depends on the length of the line in which \ hfill
is inserted. Thus, when the line uses the full width, no space will be created. \hfill
only has an effect on displayed formulas when the formula style Indented is used.
(Formula styles are explained in sec. 17.)

Besides \hfill, there are the commands \dotfill and \hrulefill that fill the space
with a pattern, see sec. 3.9 for an example.

For text, variable space can be inserted via the menu Insert > Formatting > Horizontal Space:
This is a line with 2 cm space.

This is a line with maximum space.

8.3. Space besides inline Formulas

The space that surrounds inline formulas can be adjusted with the length \math-
surround. The value of a length is set with the command \setlength that has the
following scheme:

\setlength{length name}{value}

To set \mathsurround to the value 5mm, the command
\setlength{\mathsurround }{5mm}

is inserted in TEX-mode. 5 mm space will now be set around all inline formulas:
This is a line with an inline formula A =B  with 5 mm surrounding space.

To return to the predefined value, \mathsurround is set to the value 0 pt.

5for vertical space in formulas see sec. 18.1.1
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0. Boxes and Frames

Boxes for text are described in chapter Boxes in the Embedded Objects manual.

09.1. Boxes with Frame

It is possible to frame formulas or parts of it with the commands \fbox and \ boxed.

When one of these commands is inserted to a formula, a blue box appears within
a frame to enter formula parts. For \fbox an additional formula has to be created
by Ctrl+M within this box, because the box content will otherwise be treated as
mathematical text. When \boxed is used, a new formula is automatically created
inside the frame.

The command \fbox is not suitable to frame displayed formulas because the formula
will always be set in the size of the text. \boxed is in contrary not suitable to frame
inline formulas, because the formula will always be set in the size of a displayed
formula.

As extension to \fbox there is the command \framebox where additionally the
frame width and the alignment can be specified. \framebox is used in the following
scheme:

\framebox[frame width][position]{box content}

The position can either be [ or r. [ left aligns, r right aligns the formula in the box.
When no position is given, the formula will be centered.

Is no width given, also no position can be given. In this case the frame width is
adjusted to the box content like for \fbox.

When the command \framebox is inserted, a box appears containing three blue
boxes. The first two boxes are surrounded by brackets and denote the two optional
arguments. The third box is for formula parts like for \fbox.

’ Command ‘ Result ‘
\beXLCtI’H—M \HltLA:B fA =B
\bOXGdJ\iIltuA:B /A — B

A+\fbox B A+
\framebox, 20mm——Ctrl+M \frac A]B

S/

The frame thickness can also be adjusted. To do this the following commands have
to be inserted in TEX-mode before the formula
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\fboxrule “thickness” \fboxsep “distance”

“distance” specifies the minimal distance between the frame and the first character
in the box. An example for this is the following framed formula:

Before this formula the commands

\fboxrule 2mm \fboxsep 3mm

were inserted in TEX-mode. The given values are used for all following boxes.
To return to the standard frame size, the command

\fboxrule 0.4pt \fboxsep 3pt

is inserted in TEX-mode before the next formula.

0.2. Boxes without Frame

For boxes without a frame there are the following box commands: \mbox, \make-
box and \raisebox

With \raisebox a box can be super- or subscripted. But in contrary to normal
super- and subscripting, the characters in the box keep their font size. \raisebox is
used in the following scheme:

\raisebox{height } {box content}

When the box should contain a formula, an extra formula is needed like for \fbox.
Note: For \raisebox this extra formula is created by pressing Ctrl4+M twice instead
of once because LyX doesn’t yet support \raisebox directly.

’ Command ‘ Result ‘
H\raisebox{2mm—\{al— lo 10
H\raisebox{-2mm—\{al—lo H o

’ A=\raisebox{-2mm—\{Ctrl+M Ctrl+M \sqrt, B ‘ A= VB ‘

The command \mbox is equivalent to \fbox and \makebox is equivalent to \frame-
box, with the difference that there is no frame.
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9.3. Colored Boxes

To be able to use all commands explained in this section, the KTEX-package color!®
has to be loaded in the IWTEX-preamble with the line!”

\usepackage{color}

To color boxes, the command \colorbox is used in the following scheme:
\colorbox{color}{box content}

The box content can also be a box and a \colorbox can also be part of another box
(see the 2nd and 3rd example). When the box should contain a formula, an extra
formula has to be created, the same way as for \raisebox.!8

One of the following predefined colors can be chosen:

black, blue, cyan, green, magenta, red, white and yellow

’ Command \ Result ‘

\colorbox{yellow—\{A=B A=B

\colorbox{green—\{\fbox A=B

\fbox.\colorbox{green—\{Ctrl+M Ctrl+M \int C=D | | [ €' = D

\colorbox only colors the box but not the characters in the box. To color all charac-
ters, the whole formula is highlighted and the wanted color is chosen in the Text Style

dialog. The dialog can be called with the toolbar button ab or the menu Edit>
Text Style> Customized. The formula number has then the same color as the formula.
When the formula number should get another color than the formula characters, the
color must be changed within the formula.

/A—B (1)
=

16The 4TEX-package color is part of every IXTEX standard installation.

"When text is colored somewhere in the document with a predefined color, LyX loads the I TEX-
package color automatically. Thus it is possible that the package is loaded twice, but this
doesn’t arise problems.

An example:

18This also applies for the command \fcolorbox.
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Formula (1) is completely colored red.
Formula (2) was first completely colored green to set the color for the formula number.
Subsequently the formula characters were colored red.

To color the frame different than the rest of the box, the command \fcolorbox is
used in the following scheme:

\fcolorbox{frame color}{color}{box content}

So \fcolorbox is an extension of the command \colorbox. The frame width is set,
like for \framebox, with \fboxrule and \fboxsep. An example:

This formula was created with the command
\fcolorbox{cyan—\{magenta—\{A=B.

To use other colors than the predefined ones, they have to be defined first.
One can for example define the color “darkgreen” with the KIEX-preamble line:
\definecolor{darkgreen}{cmyk}{0.5, 0, 1, 0.5}

cmyk is the color space that denotes the colors cyan, magenta, yellow and black.
The four comma separated numbers are the portion factor for the corresponding
colors of the color space. The factors can be in the range of 0-1. Instead of cmyk
also the color space rgb can be used for definitions. rgb denotes red, green and
blue, so that there are in this case three portion factors for the corresponding colors.
Furthermore there is the color space gray with one portion factor for the gray value.

As example a framed box with the new defined color darkgreen where the characters
have been colored yellow:

Self-defined colors can also be used for text with the help of the command \ textcolor:
This sentence is “darkgreen”.

\textcolor is used in the scheme \textcolor{color}{characters to color}.

9.4. Paragraph Boxes

A box that can contain several lines and paragraphs, a so called paragraph box

i[ans
(parbox), can be created with the menu Insert>Box or the toolbar button IT
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The following example shows a framed parbox in a line:

This is a paragraph box.
It is exactly 5cm long and
can also contain formulas:

[Ads=C

This is a line with a parbox.

Such a box is created by right-clicking on the gray box inset. A dialog pops up
showing the box properties. In our case set: Decoration: Recangular box, Inner Boz:
Parbox, Width: 5cm, Vertical Box Alignment: Middle

In BTEX a parbox is created with the command \parbox that has the following
scheme:

\parbox[position|{width}{box content}

The positions b and ¢ are possible. b for bottom means that the box is aligned within
the surrounding text with its last line. With ¢ for top this is done with the first line.
When no position is given, the box will be vertically centered, see section Bozes of
the Embedded Objects manual for examples.

To frame formulas completely, including the formula number, the formula must be set
into a parbox. To do this, the command \fbox{\parbox{\linewidth-2\fboxsep-
2\fboxrule}{ is inserted in TEX-mode before the formula. \linewidth is hereby
the line width set for the document. Because the frame is outside the parbox, 2 times
the frame separation and the frame thickness must be subtracted from the line width.
As this is not automatically done by IyX due to a bug!®, TEX-mode has to be used.
To be able to multiply and subtract in arguments, the ITjEX-package calc® must be
loaded in the IXTEX-preamble with the line

\usepackage{calc}

Behind the formula both boxes are closed by entering }} in TgX-mode. Here is an
example:

As a parbox is used as argument of \fbox, there is in this case no difference between
\fbox and \boxed.

OLyX-bug #4483

2calc is part of every IIEX standard installation.
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Paragraph boxes are very useful to comment formulas directly. To do this, \parbox
is used in combination with the command \tag. (more about \tag see sec. 19.4)

An example of a formula commented with \ parbox:

This is a description. It
S5v —T7b = 3b is distinctly separated from
the formula and multiline.

Such a formula must be inserted completely in TEX-mode because IyX does not
yet support the command \parbox in formulas. The formula is created with the
following command sequence:

The command \[5x-7Tb=3b\tag*\{\parbox{5cm}{ is inserted in TEX-mode.?!
Then the description follows as normal text and finally } }\] is inserted in TEX-mode.
The commands \[ and \] hereby create a displayed formula.

The advantages of \ parbox can be seen in this example that was “commented” using
the mathematical textmode:

bx — 7b = 3bThis is a description. It is not separated from the formula ...

10. Operators

10.1. Big Operators

To be able to use all integral operators listed here, the option Use esint package
automatically must be set in the document settings under Math Options.

’ Command \ Result ‘ ’ Command \ Result ‘
\int Ik \sum >
\oint ¢ \prod I1
\ointctrclockwise ¢ \coprod I
\ointclockwise ¢ \bigodot [0
\sqint i \bigotimes | ®
\fint f \bigoplus @
\landupint s \bigwedge A
\landdownint 4 \bigvee V
\bigcap N \bigsqcup | L]
\bigcup U \biguplus O]

All big operators can also be inserted via the math toolbar button I

2'When the formula style Indented is used, \tag*\{ can also be replaced by \hfill. (formula
styles see sec. 17)
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The operators are called big because they are bigger than the sometimes equal look-
ing binary operators. All big operators can have limits as described in the next
subsection.

For all integral operators there is a second version available, ending on op: \intop,
\ointop etc.. These operators are different from \int etc. in the style the operator
limits are displayed, see sec. 10.2.

Advice for Integrals

The letter d in an integral is an operator, that therefore has to be set upright. This
is done by highlighting the d and using the keyboard shortcut Alt+C R?2. Finally the
smallest space is inserted before the d, as this is usual for operators. An example:

incorrect: [ A(z)dx
correct: [ A(z)dx

For multiple integrals there are the following commands:

’ Command \ Result ‘ ’ Command \ Result ‘
\iint If \iiint IIr
\oiint ¢ \iiiint i
\sqiint tf \dotsint | [~

10.2. Operator Limits

Limits are created by super- and subscripts:

’ Command \ Result ‘

\prod™\infty, —_ 0—A(x) | TIg° A(x)

Limits of inline formulas are set right beside the operator. Limits in displayed for-
mulas are set above or below the operator, except for integral limits.

To force that the limits are set beside the operator, the cursor is set directly behind
the operator and the limits type is changed with the menu Edit > Math> Change Limits
Type to Inline (shortcut Alt+M L). An example:

The default limits type is this:

D

2
=0 Z

22Font styles see sec. 11.1
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This is how it looks when the limits type was changed to Inline:

o 1

Z90:0 ?

For integrals, except those ending with op like \intop, \ointop etc., the limits are
by default set beside the operator. But for multiple integrals the limits are often set
below the operator. In the following example the limits type was therefore set to
Display and so set below the integrals:

// XdV = U (5)

To specify conditions for limits, the commands \subarray and \substack are used.
To create for example this expression

>k (6)
0<k<1000
keN

the following has to be done:

First the command \sum ™ n,,__ is typed in. One is now in a blue box under the
summation operator and insert there the command \subarray,,, The blue box is
now within a purple box and now several lines can be written among each other. A
new line is created by inserting a line break (Ctrl+Return). When now

0<k<1000 Ctrl4+Return

is typed in, a new box appears below for the new line.

The alignment of the lines can be changed to left aligned with the table toolbar or
the menu Edit>Rows &Columns. To get right alignment, \hfill , is inserted at the
beginning of the line.

The command \substack is equivalent to \subarray with the difference that the
lines are always centered.

Like in formula (6) there can be too much space beside an operator, because the
characters following the operator are set beside the limits.

To avoid this, the following macro can be used in the KTEX-preamble:

\def\clap#1{\hbox to Opt{\hss #1\hss}}
\def\mathclap {\mathpalette \mathclapinternal}

\def\mathclapinternal #1#2{\clap{$\mathsurround =0pt #1{#2}$}}

This defines the command \mathclap that sets the width of the limit to 0 pt. The
command scheme is

\mathclap{limit}
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where the limit can consist of several conditions.

Applied on formula (6), one uses the command

\sum__\mathclap{\substack, 0<k<1000 Ctrl4+Return

to create the lower limit.

operator:

The summand is now directly behind the summation

>

0<k<1000
keN

How to use one limit for several operators is described in sec. 10.4.

10.3. Binary Operators

Binary operators are surrounded by space when there is a character before and behind

them.
’ Command \ Result ‘ ’ Command \ Result ‘ ’ Command \ Result ‘

+ + \nabla \Y \oplus ®

- — \bigtriangledown \V4 \ominus s

\pm + \bigtriangleup A \otimes ®
\mp F \Box O \oslash %)
\cdot : \cap N \odot ©)
\times X \cup U \amalg 11
\div = \dagger T \uplus W

* * \ddagger I \setminus \
\star * \wr ! \sqcap M
\cire o \bigcirc O \sqcup LJ
\diamond o \wedge A \triangleleft 4
\bullet o \vee v \triangleright >

All binary operators can also be inserted via the math toolbar button +

To typeset the Laplace operator also \Delta or \nabla~2 (V?) can be used instead
of \bigtriangleup .

The character Menu Separator from the menu Insert > Special Character is the operator
\triangleright.

10.4. Self-defined Operators

With the help of the command \DeclareMathOperator custom operators can be
defined in the IXTEX-preamble. Its command scheme is:
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\DeclareMathOperator{new command }{display}

Display can be characters or symbols that define how the operator looks in the output.
To define a big operator a * is set behind the command. All self-defined big operators
can have limits as described in sec. 10.2.

For example the IXTpX-preamble line
\DeclareMathOperator*{\Lozenge}{\blacklozenge}

defines the command \Lozenge, that inserts a big operator consisting of the lozenge
symbol from sec. 13.2:

¢
n=1
The command for this formula is: \Lozenge™ \infty—_n=1
When self-defined operators are not used several times in the document, they can also

be defined with the commands \mathop and \mathbin, which have the following
scheme:

\mathop{display} and \mathbin{display}
\mathop defines big operators, \mathbin binary operators.

\mathop can e.g. be used to use one limit for several operators:

The command for the formula above is:
\mathop{\sum\negmedspace\sum, — N _i,j=1

11. Fonts

11.1. Font Styles

Latin letters in formulas can be set in one of the following font styles:

’ Command \ Result \ shortcut ‘
\mathbb_ ABC ABC Alt+C C
\mathbf AbC AbC Ctrl+B

\boldsymbol JAbC | AbC | Ctrl+Alt+B, Alt+C B
\mathcal ,ABC ABC Ctrl+E
\mathfrak AbC 2AbC -
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] Command \Result\ shortcut ‘

\mathit ,AbC | AbC -
\mathrm ,AbC | AbC Alt+C R
\mathsf ,AbC | AbC Alt+C S
\mathtt_,AbC | AbC | Ctrl+Shift+P

Note: The styles \mathbb and \mathcal can only be used for big letters.
Predefined is the style \mathnormal.

The style commands work also for letters in mathematical constructs:

b
A= —
¢

Characters in mathematical text don’t appear in a math font style but in the text

font style \textrm. That their style can’t be set correctly via the text style dialog
is a bug in IyX.?3

Instead of the style commands the dialog Edit>Math > Text Style or the toolbar button
RS
A can be used.

11.2. Bold Formulas

To make a complete formula bold, the command \mathbf from the previous sub-
section cannot be used, because it doesn’t work for small Greek letters. Furthermore
it prints Latin letters always upright, like in the following equation:

2
/ f(0) =T equation with \mathbf
To display the formula correctly, the command \boldsymbol is used:

2
/ f@ =r equation with \boldsymbol

It is also possible to set the formula in a boldmath environment. This environ-
ment is created by inserting the command \boldmath in TgX-mode. To end the
environment, the command \unboldmath is inserted in TEX-mode.

2
/ f(@ =r equation in a boldmath environment

BLyX-bug #4629
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11.3. Colored Formulas

Formulas can be colored like normal text: Highlight a formula or a formula part and
use the Text Style dialog. Here is a formula in magenta:

.- VB
/Adl; B In (%)

You can also define your own colors as described in sec.9.3. They can be used with
the TEX code command \textcolor in the scheme

\textcolor{color}{characters or formula}

The following example was colored completely dark green and partly red:

Due to a bug in LyX only complete formulas can be colored with self-defined colors.?*

11.4. Font Sizes

For characters in formulas there are, analog to characters in text, the following size
commands:

\Huge, \huge, \LARGE, \Large, \large, \normalsize, \small,
\footnotesize, \scriptsize and \tiny

The size produced by the commands depends on the document font size, that corre-
sponds with the command \normalsize. The other commands produce smaller or
larger sizes than \normalsize. The font size can however not exceed a certain value.
Is for example the document font size 12 pt, the command \Huge switches to the
same size as \huge.

A size command is inserted in TEX-mode before the formula and sets the size for
all following formula and text characters. To switch back to the initial size, the
command \normalsize is inserted behind the formula in TEX-mode.

AUT,yX-bug #5269
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Within a formula the size can be changed using the following size commands:

’ Command \ Result ‘
\displaystyle Epot, = i
n2
\textstyle Epot, = ; fi%
\scriptstyle Epoty = %
\scriptscriptstyle Epoty = %

After entering these commands, a blue box appears in which the formula parts are
inserted.

There is a further method to change the font size, that though only works for symbols
or letters in mathematical text. To use it, one of the above text size commands is
inserted in mathematical text. All following characters until the end of the mathe-
matical text or until another size command will have the selected size. Two examples:

C
M AKA.,

Before both formulas the command \ huge was inserted. The command for the second

formula is:
\maltese /A Alt+M M \Large \maltese \textit ,A——
Alt+M M \tiny \maltese \textit A

If a symbol cannot be displayed in different sizes, it will always be displayed in the
default size.
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12. Greek Letters

All Greek letters can also be inserted via the toolbar button .

12.1. Small Letters

’ Command ‘ Result ‘

’ Command \ Result ‘ ’ Command \ Result ‘

\alpha o \fota ‘ \varrho 0
\beta o] \kappa r \sigma o
\varkappa ” .

\gamma ~y \varsigma S
\delta 5 \lambda A \tau

\epsilon € \mu K \upsilon Z
. \nu v .

\varepsilon € i ¢ \phi o)

\zeta ¢ (})ﬂ : \varphi @

\eta n i - \chi X

\theta 0 Tvarpi \psi P

pi w
\vartheta vV \rho , \omega w

How to create upright Greek letters is explained in sec. 23.9.

12.2. Big Letters

’ Command \ Result ‘

’ Command \ Result ‘

Gamma r ,
\\Delta A \Sigma >
\Theta 5 \ Upsilon T
\Lambda A \Ph.l @
Xi = \Psi v
\Pi i \Omega Q

That the big Greek letters appear upright is caused by a design bug when TEX was
developed. To get correct italic big letters, begin every command with var. For
example the command \varGamma produces: I’

12.3. Bold Letters

Greek letters cannot be set with different font styles like Latin letters. They can only
be made bold with the command \boldsymbol.
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’ Command \ Result ‘
\ Upsilon\boldsymbol\Upsilon | TY
\theta\boldsymbol\theta 00

13. Symbols?®

Many of the symbols listed in this section can also be inserted via the toolbar buttons

W and F .

13.1. Mathematical Symbols

’ Command \ Result ‘ ’ Command \ Result ‘ ’ Command \ Result ‘
\neg - \forall N \prime /
\Im ) \exists 3 \backprime \
\Re R \nexists 3 \mho O

\aleph N \emptyset 0 \triangle A
\partial 0 \varnothing %) \angle 4
\infty 00 \dag T \measuredangle £

\wp © \ddag I \sphericalangle <
\imath 1 \complement C \top T
\jmath J \Bbbk I's \bot 1

13.2. Miscellaneous Symbols

’ Command \ Result | Command \ Result | Command \ Result ‘
\flat b \hbar h \diamondsuit &
\natural b \hslash h \Diamond O
\sharp i \ clubsuit & \heartsuit Q
\surd V \spadesuit [ ) \P q
\checkmark v \bigstar * \copyright ©
\yen ¥ \blacklozenge ¢ \circledR ®
\pounds £ \blacktriangle A \maltese M
$ $ \blacktiangledown v \diagup /
§ § \bullet ) \diagdown AN

More symbols are listed in sec. 16.4.

Some symbols can be displayed in different sizes, see sec. 11.4.

25 A list with all symbols of most of the INTEX-packages can be found in [4].
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13.3. The Euro-Symbol €

To use the Euro symbol in formulas, the KTEX-package eurosym must be installed
and loaded with the ITEX-preamble line

\usepackage[gennarrow|{eurosym}
The Euro symbol can now be inserted with the command \euro.

The Euro symbol can directly be inserted with the € key in mathematical text,
without having eurosym installed. When eurosym is installed, \euro can also be
inserted in TEX-mode. The official currency symbol can then be inserted with the
command \officialeuro, that is only available in TEX-mode.

An overview about the different Euro symbols:

] Command \ Result \

formula \euro €
mathematical text € €
TEX-mode \officialeuro €

14. Relations

All relations can also be inserted via the toolbar button =.

] Command \ Result ‘ ] Command \ Result ‘ ] Command \ Result ‘

< < = = > >
e < o= | # e S
\11 < \equiv = \gg >
\prec < \sim ~ \succ >
\preceq = \simeq ~ \succeq =
\subset C \approx R \supset D
\subseteq C \cong = \supseteq D
\sgsubseteq C \bowtie D<] \sqgsupseteq J
\in € \notin ¢ \ni >
\vdash = \perp 1 \dashv -
\smile — \propto x \frown ~
\lhd < \asymp = \rhd >
\unlhd g \doteq = \unrhd >
\gtrless = \circeq = \lessgtr <
\mid | \models = \parallel |
\nmid 1 \widehat= = \nparallel e

The characters \lhd and \rhd are bigger than the equal looking operators \trian-
gleleft and \triangleright, respectively.
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Relations are, in contrary to symbols, always surrounded by space.

Relations with labels can be created with the command \stackrel:

’ Command \ Result ‘

T—00
~

A(r)\stackrel r\to\infty J\approx , B | A(r) =~ B

15. Functions

15.1. Predefined Functions

In general, variables are set italic in mathematical expressions, but not function
names, because sin could be misunderstood as s-i-n. Therefore there are predefined
functions, that are additionally a bit separated from prefactors. They are inserted as
commands starting with a backslash before their name.

] Command \ Result H Command \ Result ‘
| Asin(x)+B | Asin(z) + B || A\sin(x)+B | Asin(z) + B |

The following functions are predefined:

’ Command \ Command \ Command \ Command ‘

\sin \sinh \arcsin \sup
\cos \cosh \arccos \inf
\tan \tanh \arctan \lim
\cot \coth \arg \liminf
\sec \min \deg \limsup
\csc \max \det \Pr
\In \exp \dim \hom
\lg \log \ker \ged

B
They can also be inserted with the math toolbar button taIIJ1

15.2. Self-defined Functions

To use a function that is not predefined, like for example the sign function sgn(x),
there are two possibilities:
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o Define the function by inserting the following line to the IXTjX-preamble?
\DeclareMathOperator{\sgn}{sgn}

Now the new defined function can be called with the command \sgn.

o Write the formula as usual, mark the formula name, in our example the letters

sgn, and change it to mathematical text. At last a space is inserted between
prefactor and function.

The result is the same with both methods as with a predefined function?’:

’ Command \ Result ‘
| A\sgn(x)+B | Asgn(z) + B |
A\, sgn (x)+B | Asgn(z)+ B
~—
Alt+M M

The first method is more suitable when the self-defined function should be used
several times.

15.3. Limits

For limits there are defined besides \lim, \liminf and \limsup furthermore the
following functions:

’ Command \ Result ‘

\varliminf | lim
\varlimsup | lim
\varprojlim JHm
\varinjlim lim

The limit is created by inserting a subscript. It is set right beside the function in an
inline formula:

Command Result
\lim_ x\to A, x=B lim, ;oo =B
In a displayed formula the limit is set below the formula, as usual:

limxz =B
r—A

26For more about \DeclareMathOperator see sec. 10.4.

2TIn IyX self-defined functions are displayed red, predefined ones black.
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15.4. Modulo-Functions

The modulo-function is special, because it exists in four variants.

The variants in a displayed formula:

Command Result
a\mod, b a mod b
a\pmod, b a (mod b)
a\bmod b a mod b
a\pod, b a (b)

In an inline formula less space is set before the function names for all variants.

16. Special Characters

16.1. Special Characters in Mathematical Text

The following commands can only be used in mathematical text or in TEX-mode:

’ Command \ Result ‘ ’ command \ Result ‘
\oe 0 \o 3
\OE E \O %)
\ae & \1 1
\AE B \L L
\aa a I i
\AA A i ;

\i 1 \j ]

The characters A and @ can also be inserted via the math toolbar button F .

An exception are the commands ! and 7¢, because they can be inserted in IxX
directly to text.

16.2. Accents in Text

With the following commands all letters can be accented. The commands must be
inserted in TEX-mode.
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] Command \ Result ‘ ] Command \ Result ‘

“e é \H e ¢
\‘e e \e ¢
\"e é \~e ¢
\=e e \.e ¢
\u e ¢ \vie ¢
\b e e \d e e
\t ee ee \c e ¢

With the command \t also two different characters can be accented. The command
\t. sz creates: sz

The accents ¢ , > and ~ can in combination with vowels directly be inserted with the
keyboard without using TgX-mode. The same applies for the tilde?® ~ in combination
with a , n , or o.

The commands \b , \c , \d , \H , \t , \u, \v and accents that are inserted
directly with the keyboard are also available in mathematical text. For the other
accents there are special math commands to be used in formulas, see sec. 7.1.

Furthermore, with the command \textcircled all numbers and letters can be set
into a circle, quasi accented with a circle, similar to the copyright symbol.

’ Command \ Result ‘
\textcircled{w} W)
\Large \textcircled{\normalsize\protect\raisebox{-1.5pt }{W}} @

One has to take care that the character fits in the circle. \Large?® specifies thereby
the size of the circle. With the help of \raisebox® the character can be centered.

16.3. Minuscule Numbers

Minuscule numbers are created with the command \oldstylenums. The command
can be used in formulas and in TEX-mode. The command scheme is:
\oldstylenums{number}

The command \oldstylenums{0123456789 produces: 0123456789

28This only applies for keyboards where the tilde is defined as accent.

2gee sec. 11.4

30gee sec. 9.2
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16.4. Miscellaneous special Characters

The following characters can only be inserted to formulas by using commands:

\ Command \ Result \
\ o .
\ N

“U\cire

The degree sign ° can nevertheless be directly inserted if the I TEX-preamble contains
the following line?!:

\DeclareInputtext{176}{\ifmmode™\circ\else\textdegree\fi}

17. Formula Styles

e There are two different alignment styles:

Centered is the predefined standard

Indented for this the option fleqn must be inserted in the menu Document
Settings under Document Class

When Indented is used, the indentation can be adjusted with the length
\mathindent. Should the distance be 15mm, the following command line
is inserted in the KTEX-preamble

\setlength{\mathindent }{15mm}
When no length is specified, the predefined value of 30 pt will be used.

e And two different numbering styles:

Right is the predefined standard

Left for this the option leqno must be inserted in the menu Document > Settings
under Document Class

fleqn and leqno can also be used together. In this case both options are inserted,
separated by a comma.

The chosen styles are used for all displayed formulas of the document. When both,
centered and indented formulas should be created in a document, the style Centered
is used. The indented formulas are then set in a flalign environment, see sec. 18.2.3.

31More about this is described in sec. 23.10.
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18. Multiline Formulas

18.1. General

In IyX multiline formulas are created by pressing Ctrl4Return inside a formula.
This creates either an eqnarray environment that is described in sec.18.3 or,
when the option Use AMS math package in the document settings is selected, an
align environment that is described in sec. 18.2.1.

There are other multiline formula environments that can be created via the menu
Insert>Math. These environments are described in the following sections.

In all multiline formula environments a new line is created by pressing Ctrl+Return.

To add or delete lines, the math toolbar buttons ﬁ or Eh‘, respectively, or the menu
Edit> Rows & Columns can be used.

18.1.1. Line Separation

There is sometimes not enough space in multiline formulas between the lines:

B*(B® — 217 + 2x5 — 2r}) + 4aga® 4+ dwgxD = -42°B’ + 4dzox B
4a? (B + a3) + 4wz (D — B?) + B (B* = 202 + 22 — 2r}) = 0

In ITEX additional line space is specified as optional argument of the new line com-
mand. This is not yet possible in LyX?3?, therefore the whole formula must be inserted
in TEX-mode. To add in our example space, the command \\[3mm)] is inserted at
the end of the first line. One gets:

B*(B® — 217 + 2x5 — 2r}) + 4aga® 4+ dwgxD = -42°B’ + 4oz B

42° <B2 + x%) + 4oz (D — B2) + B? (B2 — 27’; + 225 — 27",%) =0

To set the line separation for all lines in a formula, the length \jot is changed. The
definition is: line separation = 6 pt + \jot. Predefined for \jot is the value 3pt. To
create 3mm additional line separation as in the previous example, the command

\setlength{\jot } {3mm-+3pt}

is inserted in TEX-mode before the formula. This requires that the IXTEX-package
calc®® was loaded in BTEX-preamble with the line

325ee LyX-bug #1505

33calc is part of every IIEX standard installation.
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\usepackage{calc}
One gets:

B*(B® — 212 + 2ag — 2r}) + daga® 4+ dwgxD = -42°B’ + 4oz B?
42 (B + a3) + 4zox (D — B?) + B (B* = 22 + 223 — 2r}) = 0

To get back to the predefined distance, \jot is set to the value 3 pt.

18.1.2. Column Separation

Multiline formulas form a matrix. A formula in the eqnarray environment is for
example a matrix with three columns. By changing the column separation in this
environment, the space beside the relation sign can be changed.

The column separation is specified with the length \arraycolsep according to:
column separation = 2 \arraycolsep
Thus, the command

\setlength{\arraycolsep}{lcm}

inserted in TEX-mode, sets for all following formulas a column separation of 2 cm. To
get back to the predefined distance, \arraycolsep is set to 5 pt.

A formula with 2 cm column separation:

A = B
C £ A

A formula with the predefined column separation for matrices of 10 pt:

A = B
C # A

18.1.3. Long Formulas

Long formulas can be typeset using these methods:

e When one side of the equation is much shorther than the line width, this one
is chosen for the left side and the right side is typeset over two lines:

h? h? h? e?
H = Wsg+Wino+ Wp— — A — Ay — —Apm —
B+ + b 2777,0 le ! 2m2 2 47T80|I' — Rl‘
62 62

— 7
47T€0|I'—R2| +47T€0|R1—R2| ( )
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The minus sign at the beginning of the second line does normally not appear
as operator because it is the first character of the line. Thus it would not be
surrounded by space and could not be distinguished from the fraction bar. To
avoid this, 3pt space was inserted behind the minus sign with the command
\ hspace.?

o When both sides of the equation are too long, the command \lefteqn is used.

It is inserted to the first column of the first line and effects that all further
insertions overwrite the following columns:

42 (B2 + ) + 4wz (D — B?) + B> (B® — 22 + 225 — 21}) + D

- B*-2B 7’;—x2+2xox—x3+7“§—x2—|—2x0x—x3

2
2 2 _ .2
Tyt 2roxr — g — rk)

:B2+2(r§—|—2x0x—x8—7“2)+ ( Iz (8)

After the insertion of \lefteqn, the cursor is in a purple box that is a bit shifted
to the left from the blue one. In this the formula is inserted.

The content of the further lines is inserted to the second or another formula
column. The greater the column number where it was inserted, the larger the
indentation.

Note the following when using \lefteqn:

* The formula doesn’t use the full page width. When e. g. the term —B? is
added to the first line in the above example, it would have been outside
the page margin. To better use the width, negative space can be inserted
at the beginning of the first line.

* Due to a bug in IiyX the cursor cannot be set with the mouse into the first
line.®> One can only set the cursor at the beginning of the line and move
it with the arrow keys.

o Other methods to set long formulas are offered by the environments described

in sec. 18.5 and sec. 18.6.

18.1.4. Multiline Brackets

For brackets spanning multiple lines the following problem occurs:

A = sin(x) Hl—l—
e It

-4+ B— D]

34

more about \hspace see sec. 8.2

35LyX-bug #1429
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The closing bracket is smaller than the opening bracket because brackets with variable
size may not span multiple lines.

To set the bracket size for the second line correctly, the first line is ended with
\right. and the second line with \left.’¢. After \left. the command \vphan-
tom \prod~ \infty | R=1} isinserted, because the multiplication operator with
its limits is the largest symbol in the first line and this should be the size for the
bracket in the second line.

The result is this:
< 1
A = sin(z) [H =+
e I

...+B_D]

18.2. Align Environments

Align environments can be used for every kind of multiline formulas. They are spe-
cially useful to set several formulas side by side.

Align environments consist of columns. The odd columns are right aligned, the even
ones left aligned. Every line in an Align environment can be numbered.

Align environments are created via the menu Insert>Math. With the menu Edit>
Math>Change Formula Type already existing formulas can be converted to Align
environments.

H L]
To add or delete columns, the math toolbar buttons ﬁ:', or ¥ respectively, or the
menu Edit>Rows & Columns can be used.

18.2.1. Standard align Environment

This Align environment is created by presssing Ctrl+Return in a formula or by the
menu Insert>Math>AMS align Environment.

An example for two formulas set side by side, that are created with a four column
align environment:

A =sin(B) C=D

C+#A B#D
As it can be seen, the formulas in this environment are placed so as if there would

be a \hfill*" before the first and after every even column. When the formula style
Indented? is used, the formula is set without the \hfill before the first column.

36for more about \left and \right see sec. 5.1.2
3"more about \hfill see sec. 8.2

38formula styles see sec. 17
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18.2.2. Alignat Environment

The alignat environment has no predefined column separation. It can be inserted
manually with the spaces that are described sec. 8.

The above example in the alignat environment where 1 cm space was inserted at the
beginning of the second formula:

A = sin(B) C=D
C#A B +# D

Because the column separation can be set separately for every column, this environ-
ment is especially suitable to set three and more formulas side by side.

18.2.3. Flalign Environment

In this environment the first two columns are always set as much as possible to the
left and the last two ones to the right. An example:

X:—l Y:—2 Z:4

By creating a flalign environment with an odd number of columns where an empty
TEX-brace is inserted to the last column, several formulas in a document can be set
to the left, although the formula style Centered is used. As example the indented
formula (5):

// Xdv =U (9)

The first two columns contain the formula. To indent it as with the formula style
Indented, 30 pt space was inserted at the beginning of the first column.

18.3. Eqgnarray Environment

When this environment has been created, three blue boxes appear. The content of
the first box is right aligned, the content of the last one left aligned. The content of
the middle box appears centered and a bit smaller, because it is designed to insert
there only relation characters.

ABC  ,p. ABC
D P D
AB AB AB
A = A
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18.4. Gather Environment

This environment consists of only one centered column. Every line can be numbered.

A=1 (10)
X =-1 (11)

18.5. Multline Environment

The multline environment consists, like the gather environment, of only one column.
But the first line is left aligned, the last one right aligned. All other lines are centered.
Therefore this environment is suitable for long formulas. As example formula (8) in
the multline environment:

42? (B2 + ) + 4wox (D — B?) + B* (B* = 2 + 205 — 21}) + D?

— B?>-2B rg—x2+2x0x—x3+7’2—x2+2x0x—x§

2
2 2 2

B2

=B*+2 (rﬁ + 2707 — T3 — ri) + (12)

In the output only the last (first) line of a multline environment appears numbered
when the document numbering is right (left).

With the commands \shoveright and \shoveleft a centered line can be right or left
aligned, respectively. The commands are used as follows:

\shoveright{line content} and \shoveleft{line content}

The length \multlinegap specifies the distance of the first line from the left page
margin. Predefined is the length 0 pt.

As example the above formula where the command
\setlength{\multlinegap } {2cm}

was inserted in TEX-mode before:

42? (B2 + ) + 4wz (D — B?) + B> (B* — 22 + 205 — 21}) + D

—B2—QB\/T§—$2+2I0I—I%+T§—$2+21’0$—J}(2)

2 2 _ .2
(rg + 2x0x — 1[5 — T3

)2
— (13)

:B2+2(r§+2x0x—x3—ri)+

The second line was left aligned using \shoveleft.

3 numbering styles see sec. 17
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18.6. Multiline Formula Parts

To display only parts of a formula with multiple lines, one of the following environ-
ments are used: aligned, alignedat, gathered or split. They can be inserted via
the menu Insert>Math or by using the commands described in this section.

The first three have the same properties as the corresponding multiline formula en-
vironments, but it is possible to set further formula parts beside them. An example:

AxAp >
Uncertainty relations
AEAt >

NSNS

To get this formula, a displayed formula is created where the command \aligned is
inserted. A purple box appears around the blue formula box where now columns and
lines can be added. Outside the multiline environment other formula parts can be
set, like the brace.

The aligned environment is also suitable for long formulas whose lines are horizontally
aligned. Using aligned in a displayed formula has the advantage that the formula
number is vertically centered behind the lines. As example formula (7) in the aligned
environment:
h? h? h? e?
H=W, Wi + Wp — A — Ay — Ay — ————
sB + + b 27’)7,0 2m1 ! 2m2 2 47T€0|I' — R1’

e? e?

B 47T€0|I' - R2| + 47T€0|R1 - R2|

(14)

To use the environments alignedat, gathered, or split, the command \alignedat,
\gathered, or \split are inserted, respectively. The split environment has the same
properties as the aligned environment but it can only have two columns.

18.7. Text in multiline Formulas

In the Align environments, and the multline and gather environment, text can be
inserted that will appear in a separate line and doesn’t affect the column alignment.
To do this, the command \intertext is used in the following scheme:

\intertext{text}

The text should not be longer than a line because it cannot be hyphenated. As IyX
doesn’t yet support \intertext directly, the text is written as mathematical text.
\intertext must hereby be at the beginning of a line and appears in the output
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above this line. An example where the text was inserted at the beginning of the
second line:

I= a\/§/027T \/ 1+ cos(¢) do (15)

integrand is symmetric to ¢ = m, therefore

= 2a\/§/7T 1+ cos(¢) do (16)

19. Formula Numbering

19.1. General

Numbered formulas can be created with the menu Insert > Math > Numbered Formula
(shortcut Ctrl+Alt N). Existing formulas can be numbered with the menu Edit>
Math > Toggle Numbering (shortcut Alt+M N). The formula number is displayed in
LyX behind the formula as number sign in parentheses. The number sign is replaced
in the output by the formula number.

When numbering is turned on in multiline formulas, all lines will be numbered. But
the numbering can be controlled with the menu Edit > Math > Toggle Numbering of Line
(shortcutAlt+M Shift+N) for every line.

Except for inline formulas, all formulas can be numbered with two different styles,
see sec. 17.

19.2. Cross-References

All labeled formulas can be cross-referenced. A label is added by the menu Insert>

Label or the toolbar button @ The cursor must hereby be inside a displayed formula.
A dialog pops up displaying the prefix eq: in a text field. The label is inserted there
behind the prefix. The predefined prefix means “equation” and makes it easier to
find labels in large documents because it marks it as formula label to divide it from
e.g. section labels. To change a label, the menu Insert> Label is used again.

The name of the label is displayed in IyyX within two parentheses behind formula. A
formula with a label is always numbered.

Cross-references are inserted via the menu Insert > Cross-Reference or with the toolbar

button . A formula cross-reference appears in the output as formula number.
When in the cross-reference dialog window the format (<reference>) is chosen,
the cross-reference appears in the output as formula number in parentheses.
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By right-clicking on a cross-reference in IyX, one jumps to the formula that is refer-
enced.

Here are as examples cross-references to formulas of the following subsections:
The equations (something) and (17b) are equivalent. In (W) big Latin letters are
used for the numbering in contrary to (XXI).

When the argument of \tag® contains a box like in sec. 9.4, the formula cannot be
referenced.

19.3. Subnumbering

With the help of the commands \begin{subequations} and \end{subequations}
formulas can be subnumbered. Both commands are inserted in TEX-mode.

An example:

A=C-B (17)
B=C-A (17a)
C=A+B (17b)

To create the example, the following is done:
1. first formula is inserted

2. \addtocounter{equation}{-1} \begin{subequations}
is inserted after the first formula

3. second formula is inserted
4. third formula is inserted
5. \end{subequations} is inserted after the third formula

Every formula between the commands \begin and \end is subnumbered as a, b,
¢, ... For multiline formulas every line will be subnumbered. All subnumbered
formulas are treated as one numbered formula. But as every numbered formula
increases the counter equation by one, the command \addtocounter is needed to
decrease it. Otherwise the formulas (17), (17a), (17b) would be numbered as (17),
(18a), (18b).

By inserting the commands in TEX-mode, a space is created between the first two
formulas. To revert this -5mm vertical space is inserted after the command \be-
gin{subequations}. When the formula style Indented*! is used, -7mm space is
inserted instead.

40\ tag is described in sec. 19.4.

4formula styles see sec. 17
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Here is an example for a multiline formula where the numbering was turned off for
the second line:

A = (B-2)?*=(B-2)(B-2) (18a)
= B*-7ZB-BZ+7*
= B?-2BZ + 7* (18b)

19.4. User-defined Numbering

With the standard numbering parentheses are set around the formula number. To
replace the parentheses for example by vertical bars, the following line is added to

the BTEX-preamble:
\def\tagform@#1{\maketag@Q@Q@{|#1|}}

To use other characters, the vertical bars besides the #1 are replaced by one ore
more characters. To get only the formula number the vertical bars are omitted.

When there should be an expression of your choice instead of the consecutive formula
number in parentheses behind the formula, the command \tag is used:

A+B=C (something)

In this example the command \tag, something was inserted to the formula.

When the command \tag* something is inserted instead, the star prevents the
parentheses around the expression:

A+B=C something

To restart the formula numbering with new document parts or sections, the following
command is used:

\@addtoreset{equation}{part}
resp.
\ @addtoreset{equation}{section}

To be able to use these commands in TEX-mode, the “@” character has to be made
“active” for WTEX using the command \ makeatletter. The command \makeatother
reverts this. So the command sequence in TEX-mode is:

\makeatletter
\@addtoreset{equation}{section}
\makeatother

In the BTEX-preamble \makeatletter and \makeatother can be omitted as they
are automatically internally inserted by LyX.
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To revert \@addtoreset, the file remreset.sty?? has to be loaded in the KTEX-
preamble with the line

\usepackage{remreset }

Then the command \@removefromreset can be used with the same scheme as
\@addtoreset.

Sometimes formulas should be numbered in the following form:
(section number.formula number)
The formula number should start with every section with “17.

For this case there is the command \numberwithin, which is used with the following
scheme:

\numberwithin{counter }{sectioning}

Counter denotes what kind of numbering is affected, sectioning denotes what number
is before the dot.

Thus in our case the following KIEX-preamble or TEX-Code line is used:
\numberwithin{equation}{section}
This is the result:

A+B=C (19.19)
To number e. g. tables so that the number of the part is the sectioning,
\numberwithin{table}{part} is used.

To go back to the standard numbering or to prevent this kind of numbering when it
is defined by the document class, the following command is inserted as TEX-Code or
to the KTEX-preamble:

\renewcommand{\theequation}{\arabic{equation}}
or

\renewcommand{\thetable}{\arabic{table}}

\numberwithin uses internally the command \ @addtoreset, described above, that
also needs to be reverted.

19.5. Numbering with Roman Numbers and Letters

Formulas can also be numbered with Roman numbers and Latin letters. To number
for example with small Roman numbers, the command

\renewcommand{\theequation}{\roman{equation}}

42remreset is part of the INTEX-package carlisle that is part of every IXTEX standard installation.
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is inserted before the formula in TEX-mode. \renewcommand redefines the prede-
fined command \theequation to the command \roman{equation}.** equation
is the formula counter. When the command \the is used as prefix for a counter,
the value of the counter is output as Arabic number. When a formula is num-
bered, KTEX sets internally the command \theequation behind the formula. \ro-
man{equation} outputs the counter as small Roman number.

All formulas behind the command \renewcommand are now numbered Roman. To
switch to numbering with big Roman numbers, the command is inserted again, but
\roman is replaced by \Roman. To “number” with small Latin letters there is the
command \alph, for big ones there is the command \ Alph.

Note: Only maximal 26 formulas can be numbered with Latin letters in one docu-
ment.

A = small roman (xx)
B = big Roman (XXI)
C = small Latin (v)

D = big Latin (W)

To switch back to the default numbering, insert the command:

\renewcommand{\theequation}{\arabic{equation}}
E = Arabic (24)

As you see, formulas are numbered serially independent from the numbering style.
When then numbering should start with “1” when the style is changed, new equation
counters have to be defined. A description about this can be found in the file Formula-
numbering.lyx.

20. Chemical Symbols and Equations

An example text from chemistry:

The SO? ™ -ion reacts with two Na*-ions to sodium sulfate (NaySO,). The
chemical equation for this is:

2Na™ +S0O3~ — NaySO, (25)

43The command \renewcommand has the same scheme like the command \newcommand that
is described in sec. 22.1.
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This chemical equation can directly be created as formula. To avoid that the symbols
appear italic, everything is highlighted and changed by the shortcut Alt+C R to the
upright font style.**

A more convenient way to typeset chemical formulas is to use the command \ ce that
is available when the IXTEX-package mhchem is installed. After inserting \ce to
a formula a new blue box appears where chemical formulas can be inserted in an
intuitive way.

’ Command \ Result ‘
\ce H2CO3 H,CO,
\ce SO472- SO;~
\ce (NH4)2S (NH,),S
\ce. KCr(SO4)2.12H20 KCr(SO, ), 12 H,0
\ce A-B\dbond C\tbond, D A-B=C=D
\ce 7227) 90—Th+ 2'Tht
\ce CO2 4, CL<=>2CO CO, +C=2CO
\ce CO2 4+, C, ~->[\alpha][\beta] 2CO} | CO,+ C %) 2CO

Note: Inserting a formula to a \ce box will lead to TEX errors. In this case TEX
code has to be used like for \ce{$\mu\hyphen$Cl}: u-Cl

Using \ce the command for equation (25) is:
\ce 2Na+ + ,S0472- , -> Na2S04

To create multiline chemical equations first a multiline formula is created as described
in sec. 18. Afterwards the command \ ce is used in every small blue box of the formula.
(26) and (27) are an example of a multi-stage chemical reaction where every equation
has its own number.

TEOS+40 — Si(OH), + 4C,H,0 (26)
Si(OH), — SiO, + 2H,0 (27)

Besides \ce the mhchem package provides the command \cf that has to be used
for special cases. For more information about \cf and more examples have a look at
the documentation of mhchem, [6].

44font styles see sec. 11.1
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21. Diagrams

LyX supports two types of commutative diagrams: amscd and xymatrix that are
explained in the following.

21.1. Amscd Diagrams

Diagrams of this type visualize relations by vertical and horizontal lines or arrows:

A B > C
F < E D

To get them, the command \CD is inserted to a formula. A blue box appears with
two dashed lines where further commands can be inserted. With Ctrl+Return a new
line is created. Horizontal relations are inserted in odd, vertical in even formula lines.

To create the relations there are the following commands:
o @< creates a left arrow, @>>> a right arrow and @= a long equal sign
o @AAA creates an up arrow, @VVYV an down arrow and @| a vertical equal
sign
e @. is a placeholder for non-existent relations
All arrows can be labeled as follows:

o Is text inserted between the first and second < or >, resp., it is placed above
the arrow. When it is inserted between the second and third one, it appears
under the arrow.

o When text for vertical arrows is inserted between the first and second A or V,
resp., it is placed left beside the arrow. When it is inserted between the second
and third one, it appears right beside the arrow. If the text contains an A or
V., these letters must be set into a TEX-brace.

As example a diagram with all possible relations:

A— 4B — C F
| ]
D E-‘*,sFr__¢C

The command for this is:

\CD A@>j>>B@>>k>C@=F Ctrl+Return
QAmMAAQ@.@QVV\{V—-V@Q| Ctrl+Return
DA<<j<EQ@Q>k>>FQ=C
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21.2. Xymatrix Diagrams

To be able to use xymatrices, the WTEX-package xypic must be installed. A xymatrix
is created by inserting the command \xymatrix in a formula. Then you are able to
add new matrix columns and rows like for normal matrices, see sec. 4.

In contrary to amscd diagrams, xymatrices supports diagonal and curved arrows, and
much more. All possibilities to create commutative diagrams and decorations are ex-
plained in detail in the X Y-pic manual that you find in the menu Help > Specific Man-
uals> XY-pic Manual.

22. User-defined Commands

Note: The names of user-defined commands and macros may only consist of Latin
letters.

22.1. The Command \newcommand

Many TEX-commands are too long to be used frequently. But it is possible to define
with the command \newcommand new shorter commands.

The command scheme of \newcommand is:

\newcommand{new command name } [number of arguments|[optional value]
{command definition}

Note: Assure that the name of the new command is not already used in your
document or by IXTEX-packages that you use. When you for example define the
command \le for \Leftarrow, you get an error message because \le is already
defined as command for “<”.

The number of arguments is an integer in the range 0-9 and specifies how many
arguments the new command should have. With the optional value a value for an
optional argument can be predefined. When this is done, the first argument of the
new command is automatically an optional one.

Here are some examples:
 To define the command \gr for \ Longrightarrow, the KTEX-preamble line is:
\newcommand{\gr}{\Longrightarrow}

o To define the command \us for \underline, the argument (that should be
underlined) must be taken into account. For this the preamble line is:

\newcommand{\us}[1]{\underline{#1}}

The character # acts as argument placeholder, the 1 behind it denotes that it
is the placeholder for the first argument.
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« For \framebox one can e.g. define the command \fb:
\newcommand{\fb}[3]{\framebox#1#2{$#3%$}}

The two Dollar signs creates the extra formula needed for \framebox, see
sec.9.1.

o To create a new command for \fcolorbox where the color for the box needn’t
to be specified, the argument for the color is defined optional:

\newcommand{\cb}[3][white]{\fcolorbox{#2} {#1}{$#3%}}

When the color is not specified when using \cb, the predefined color white
will be used.

A test of the new defined commands:

’ Command ‘ Result ‘
A\ngB A — B
\us{ABcd ABcd

\fb{[2cm]—\{—=\{\int A=B |[ [A=B

\cb{red—\{\int A=B [A=B

\cb[green|\{red—\{\int. A=B | [[A=B

22.2. Math Macros

User-defined commands are especially convenient for complex expressions. When you
are for example dealing in a document with quadratic equations, the same solution
type occurs several times. The general form of a quadratic equation is

0=A+pA+gq

The general form of the solution is

p p2
Mo=—=211/— —
1,2 5 | q

To define a command for the solution formula where only the three parameters A,

p and ¢ need to be specified and the index of A can be given optionally, the IXTEX-

preamble line is

\newcommand{\qG}[4][1,\,2]{#2_{#1}=-\frac{#3}{2}\pm
\sart{\frac{#37{2} }{4}-#4}}

To create with this the solution formula, the command
\gG{\lambda—\{p—\{q is inserted to a formula.
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The definition of the new command is unintuitive because one has to know the
schemes of all used ITEX commands, e.g. that a fraction is inserted in ITEX as
\frac{numerator}{denominator}. Furthermore one can easily forget a brace
in the definition and cannot see in IiyX what the new command is doing. To avoid
these problems Iy X offers the possibility to use math macros instead of the command
\newcommand.

A math macro is created by using the menu Insert>Math>Macro or the toolbar but-
oo

ton *= . The math macro toolbar appears together with the following box where the
macro is defined:

\mewemacroname: = E[”E

\newmacroname is the default name of the macro that should be changed to some-
thing sensible. The wanted formula is inserted in the first blue box. An argument
placeholder is inserted with the command \#argumentnumber, e.g \#1 or by

using the macro toolbar button H} Argument placeholders are displayed red. Max-
imum 9 arguments are possible. Optional arguments are created with the toolbar

button l]{}. The first non-optional argument can be transformed to an optional one

with the toolbar button 1 Tn the second blue box the appearance of the macro in
LyX can be defined. Normally you want to see it as it is defined, so the box is kept
empty. But when you have created a macro that needs lot of space on the screen,
you can insert in the box for example

aG: \#1, \#2 , \#3, \#4

For the macro only the arguments with the macro name in front of them will then be
displayed in IxyX, leading to a better overview. The formula appears in the output
as defined in the first box.

The appearance of macros in formulas can furthermore be changed for single macros
by setting the cursor in the macro and using the menu View > (Un)fold Math Macro.

To use a macro, the macro name is inserted as command to a formula, in our case
\qG. Our macro looks in LyX like this:

[Ih = - %:I:nllf

Here is our macro example with the arguments z, In(x) and B:

i
70

In(x) In(x)?
S _B
e 2 1

LyX offers in the menu Tools> Preferences > Editing > Control different styles to edit
macros. To find the style that suits you the most, choose a style and set the cursor
in a macro formula to see the difference.
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A math macro is transformed internally to a \newcommand command when ex-
porting the document. The created \newcommand command is not placed in the
ETEX-preamble, therefore macros can only be used in formulas that are in the doc-
ument below the macro definition box.

Math macros can also be directly be created from a \newcommand command.
When writing for example the command

\newcommand{\larrow }[2]{\xleftarrow[#2]{#1}}

in IyX as normal text, highlighting it completely and using then the shortcut Ctrl4+M,
the command will be transformed to a math macro. Using this method you need to
be careful that the \newcommand command is typed correctly, otherwise you get
a faulty macro leading to KTEX errors.

Math macros currently yet have the problem that further formulas in macro defi-
nitions are handled wrongly. Therefore the example \fb from sec.22.1 cannot be
created as macro.

When the cursor is in a macro definition box, you will see the macro toolbar in LyX:
3 K3 oo 00 00 KE KE 0E

The macro toolbar contains from left to right the following buttons:

H}= Edit> Math > Macro Definition > Remove Last Argument
H} Edit> Math > Macro Definition>Append Argument

(] Edit>Math>Macro Definition > Make First Non-Optional into
Optional Argument

[IM} Edit>Math>Macro Definition > Make Last Optional into
Non-Optional Argument

[I{} Edit> Math > Macro Definition > Remove Optional Argument
[]{} Edit> Math > Macro Definitiont Insert Optional Argument

}[ﬁ Edit> Math > Macro Definition > Remove Last Argument
Spitting Out To The Right

}{% Edit>Math > Macro Definition>Append Argument
Eating From The Right
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}[? Edit> Math > Macro Definition> Append Optional Argument
Eating From The Right
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23. Tips

23.1. Negative Numbers

Negative numbers often look ugly in formulas because the minus sign before the
number is set with the same length as the minus operator sign. When writing the
negative number in normal text, the minus sign appears correctly.

Thus, the problem disappears when converting the minus sign to mathematical text.

An example to visualize the problem:

normal text: x = -2
formula;: z = —2

’ solution: =z = -2

23.2. Comma as decimal Separator
In BTEX a comma inside a formula is used, according to the English convention, as
number group separator. So there will be space added behind all commas in formulas.

To avoid this, the comma is highlighted and changed to mathematical text (shortcut
Ctrl4+M).

To use all formula commas in the document as decimal separator, the file icomma.sty*®
is loaded with the IXTEX-preamble line

\usepackage{icomma}

23.3. Physical Vectors

Predefined vectors are offered by the I¥TEX-package braket that is loaded with the
IATEX-preamble line

\usepackage{braket }

The following commands are defined:

’ Command \ Result ‘
\Bra{\psi (V]
\Ket{\psi )

\Braket{\psi|\phi | (¢|¢)

4jcomma is part of the INTEX-package was.
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The command \Braket assures that all vertical bars are set in the size of the sur-
rounding brackets:
3
J=2M >
<¢‘ 27

The effect of \Braket can also be achieved using the command \middle, that is
described in sec. 5.1.2.

23.4. Self-defined Fractions

To define custom commands for fractions, the command \genfrac is used in the
following scheme:

\genfrac{left bracket}{right bracket }{fraction bar thickness}{style}
{numerator }{denominator}

The style is a number in the range of 0- 3.

| Number | Style (Size) |
0 display style formula
1 inline formula
2 small
3 tiny

When no style is given, the size is adjusted to the surrounding environment like for
the command \frac.

When no fraction bar thickness is given, the predefined value of 0.4 pt will be used.

For example, the commands \dfrac and \tbinom from sec. 3.2 are defined with the
commands

\newcommand{\dfrac}[2]{\genfrac{ }{ }H{}{O0}{#1}{#2}}

and

\newcommand{\tbinom}[2]{\genfrac{(}{) }{Opt }{1}{#1}{#2}}

To define a fraction where the fraction bar thickness can be given as optional argu-
ment, the following line is inserted to the KTEX-preamble:

\newcommand{\fracS}[3][[{\genfrac{}{ H{#1}H{}{#2}{#3}}
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A test:

Command \fracS[Imm]\{A — \{B \fracS[5mm]\{A — \{B
A
A
Result — B
B
B

As one can see, the distance of the numerator and the denominator to the fraction
bar is round about three times the bar thickness.

23.5. Canceled Formulas

To cancel formulas or formula parts, the BTEX-package cancel has to be loaded with
the IXTEX-preamble line

\usepackage[samesize|{cancel }

There are four ways to cancel formulas:

’ Command ‘ Result ‘

\cancel{\int, A=B [A=T
\bcancel{\int  A=B TA=B
\xcancel{\int A=B A=

\cancelto{1—\{\int, A=B | [4=TF"

\cancelto is especially suitable to visualize the reduction of fractions within formu-
las:
(ro+bB)* a5+ B* -1}
1+
(1+ b2)3‘

23.6. Formulas in Section Headings

When formulas are used in section headings, the following has to be taken into ac-
count:

When hyperref support is enabled in the document settings dialog under PDF Prop-
erties, PDF-bookmarks are created for every section heading in the table of contents.
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If a section heading contains formulas, they are incorrectly displayed in the bookmark
text, because formulas in bookmarks infringe the PDF conventions.

Both problems can be solved by inserting at the end of the section heading a short
title with the menu Insert > Short Title. Short titles are used as alternative for multiline
section headings to keep the table of contents clearly arranged. Only the short title
appears in the table of contents and therefore also in the PDF-bookmark.

When formulas should be used in the table of contents but hyperref is used, one
can use the following command in TEX-mode:

\texorpdfstring{part}{alternative}

Part is the part of the heading that shouldn’t appear in the PDF-bookmark. This
can be characters, formulas, footnotes, but also cross-references. The alternative is
used instead of the part for the bookmark.

Here are two example headings:
23.6.1. Heading without formula in table of contents /—1 =i
23.6.2. Heading with formula in table of contents /—1 =i

In the first heading a short title was used, in the second one \texorpdfstring.

To get the same formatting as for the other headings, the complete heading was set
into a boldmath environment*S.

23.7. Formulas in multi-column Text

Formulas in multi-column text are often too wide to fit into a column and thus
need to be set over the whole page width. This is done by using the IXTEX-package
multicol?”, that is loaded with the IATEX-preamble line

\usepackage{multicol}

Note herby that the setting Two-column document in the menu Document > Settings
under Text Layout must not be selected.

Before the multi-column text the command
\begin{multicols}{column number}

is written in TEX-mode. The column number is a number in the range of 2-10.
Before the formula the multi-column text is ended by inserting the command

\end{multicols}

46

see sec.11.2

4"multicol is part of every M TEX standard installation.
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in TEX-mode.

Due to the command some space is automatically added before the formula.

To

revert this, -6 mm vertical space is inserted before the formula. When the formula
style Indented”® is used, -9 mm space is inserted instead.

As example a multi-column text with a displayed formula:

Das Spektrum wird fouriertransformiert.
Die Fouriertransformation wird verwen-
det, um die tberlagerten Signale (Netz-
werk, Losungsmittel) zu trennen. Nach-
dem wir die Phasenverschiebung bestim-
men konnten, interessiert uns nun das
Aussehen des Ausgangssignals. Im Expe-

5(t) = Soft) [

— 00

wobei Sy das Signal ohne Gradient
ist und die Normierungsbedingung
ffooo P(¢,t)de = 1 gilt. Nun dirfen wir
aber nicht den Relaxationsprozess aufler
Acht lassen. Direkt nach dem 7/2-rf-Puls

riment haben wir es mit sehr vielen Teil-
chen zu tun, so dass man iiber alle Pha-
sen integrieren muss. Sei nun S unser nor-
miertes Ausgangssignal und P die Pha-
senverteilungsfunktion, so ergibt sich die
Beziehung

o0

P(¢,t)e” do (28)
beginnt sich die Magnetisierung zu ent-
fokussieren, wodurch sich das Signal zu-
sitzlich abschwécht. Diese Abschwéachung
verlauft exponentiell in Abhéngigkeit der
so genannten T)-Zeit.

23.8. Formulas with Description of Variables

To describe variables within a formula, like in formula (29), a 2Xn matrix is used
with left aligned columns for the n used variables.*® To set the description in a
smaller size, before the matrix e.g. the command \footnotesize is inserted.>

When the formula style Indented® is used, a \hfill’? is inserted before and after
the matrix to have the same separation of the matrix from the equation and the side
margin.

When the formula style Centered is used, the method described in sec.18.2.3 is
used to indent formulas. Formula (29) consists of five columns whereas in the first

48formula styles see sec. 17
“Omatrices see sec. 4

0font sizes see sec. 11.4
5lformula styles see sec. 17

52\ hfill only works in formulas with the style Indented, see sec. 8.2.
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two columns contain the equation, the third the matrix and the last one an empty

TEX-brace.

p  density
Fr=p-V-g V' volume (29)

g gravitational acceleration

23.9. Upright small Greek Letters

Most of the math fonts only provide italic small Greek letters. But for symbols of
elementary particles like pions and neutrinos, upright Greek letters are needed. The
file upgreek.sty®® that is loaded with the IXTjzX-preamble line

\usepackage{upgreek}

provides them. They are created when the command for a small Greek letters is
started with up. For example the command \uptau creates this: T

With these commands reactions of elementary particles can be typeset:

T = u + vy,

The upright letters are more bold and wider than the italic ones. They should
therefore not be used for units like “pm”.

23.10. Text Characters in Formulas

In some cases you might want to insert text characters directly into formulas. When
for example the centered dot - is often used in formulas like v = 5 - 10° Hz, one
would have to insert the command \cdot® all the time, because this character is
defined in all encodings as text character. But the encoding can be changed by this
KTEX-preamble line:

\Declare Inputtext{183}{\ifmmode\cdot\else\textperiodcentered\fi}

The character encoding (menu Document > Settings>Language) specifies what char-
acter appears when a keyboard key is pressed. When the key for the character ’ -’ is
pressed, internally the command \textperiodcentered is used. But this command
is not available in a formula so that you would get I{TEX-errors. With the changed
encoding the right command is chosen automatically, depending on if the character
was inserted into a formula or not.

The encoding of several characters is saved in definition files. Fore example the
encoding latin9 is defined in the file latin9.def that is in the installation folder of

S3upgreek is part of the IWTEX-package was.

54gee sec. 10.3
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BETEX. Encodings should only be changed via the BTEX-preamble and not in the
definition files. Otherwise own documents could not be edited by other IxyX users
working on other computers.

Besides the centered dot, in this document the degree sign ° is defined with the
following K TEX-preamble line so that it can directly be inserted to a formula:

\DeclareInputtext{176}{\ifmmode™\circ\else\textdegree\fi}
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A. Typographic Advice

This section is a summary of the most important typographic rules, listed in ISO
55
norms.

Physical units are always set upright®®, no matter if they appear in italic text:
30km/h

Between the value and the unit is the smallest space, see sec. 8.1.

This convention is automatically fulfilled when the command \unittwo is used.
When it is entered to a formula, two boxes appear. In the first one the value is
inserted, in the second one the unit, and one gets as above: 30 km/h. Note that
\unittwo is not a real BTEX command but the command \unit[value]{unit},
therefore you cannot use it in TEX code.

Percent and perthousand signs are set like physical units:
1,2 %o alcohol in blood

The degree sign follows directly on the value: 15°, but not when it is used in
units: 15°C

In numbers with more than four digits the smallest space is inserted before
every third digit to group them: 18473 588

For dimensions like 120x90x40 cm the multiplication sign “x” is used. It is
available either via the command \times or via the menu Insert>Special Char-
acter > Symbols.

Functions with names consisting of several letters are set upright to avoid con-
fusions, see sec. 15.1.

Indices consisting of several letters, are set upright: FEi;,
Components of matrices are set italic: Hy

The differentiation/integration operator 'd’, the Euler’s number e’ and the
imaginary unit i’ should be set upright, to avoid mixing them up with other
variables.

The character that denotes a FOURIER transformation is inserted either by the
command \mathscr ,\ {F or via the menu Insert>Special Character>Symbols >
Letterlike Symbols: .7

To be able to use the command \mathscr, the XTEX package mathrsfs needs
to be loaded with the ITEX-preamble line \usepackage{mathrsfs}.

5This collection was partly taken from the German semi-official dictionary called “Duden” [8] that
lists some of the ISO rules. More rules are listed in [9)].

56done with font styles, see sec. 11.1
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B. Synonyms

Some characters and symbols can be created with several commands. Here is a list

of the synonym commands:

68

] Command \ equivalent to ‘

\ast *
\choose \binom
\geq \ge
\lbrace {
\Ibracket [
\leftarrow \gets
\leq \le
\lor \vee
\neq \not=
\slash /
\vert ]

] Command \ equivalent to ‘
\backslash \\
\dasharrow | \dashrightarrow

\land \wedge
\rbrace }
\rbracket ]

\rightarrow \to

\Inot \neg
\ne \not=
\owns \ni
\square \Box
\ Vert \|
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\hdotsfor, 9 \Roman, 52
\hfill, 19 \raisebox, 21
\hphantom, 8 \renewcommand, 11
\hrulefill, 9 \renewcommand, 52
\hspace, 19, 43 \right, 10, 12, 44

I \roman, 52
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\intertext, 47 \rule, 8
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\ng 10, igv 44 \sideset, 16
\lefteqn, \smallmatrix, 11
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\linewidth, 24
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\mathbin, 29
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\mathindent, 40 \tag, 50
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\middle, 13 \textb'ackslash, 11
- exteircled,
\multlinegap, 46 iz E | I d2 ??931
N extcolor, 23,
\newcommand, 55 \textvisiblespace, 3
\nicefrac, 5 \tfrac, 4
\not, 7 U
\numberwithin, 51 sunbddmath, 30
O underbrace, 13
\officialeuro, 35 \underline, 8
\oldstylenums, 39 \underset, 16, 17
\overbrace, 13 \unitfrac, 5
\overline, 8 \uproot, 6
\overset, 16, 17 \Y%
p \vphantom, 8, 44
\parbox, 24 X
\phantom, 7 \xleftarrow, 15

\prod, 25 \xrightarrow, 15



Comparisons, see Relations
Cross-references
to formulas, 48

Delimiters, 11

Diagrams
amscd, b4
xymatrix, 55

Ellipses, 8
Exponents, 4

Font
size, 31
style, 29
Fonts, 29
Formula
bold, 30
canceled, 62
colored, 31
display style, 1
in multi-column text, 63
in section headings, 62
inline, 1
long, 42
multiline, 41
align environment, 44
alignat environment, 45
Column separation, 42
eqnarray environment, 45
flalign environment, 45
formula parts, 47
gather environment, 46
Line separation, 41
multline environment, 46
text, 47

numbering, see Formula numbering

styles, 40

underlined, 8

with description of variables, 64
Formula numbering, 48

self-defined delimiters, 50

subnumbering, 49

user-defined, 50

with letters, 51
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with Roman numbers, 51
Fractions, 4
self-defined, 61
Frames, see Boxes
Functions
modulo-, 38
predefined, 36
self-defined, 36

Greek letters, 33
big, 33
bold, 33
small, 33
upright, 65

Indices, 4
Integrals, 25
Isotopes, see Chemical characters

KETEX-preamble, 2
Limits, 37
Lines, 8

Macros, 56

Toolbar, 58
Mathematical text, 2
Matrices, 9
Minuscule numbers, 39

Negations, 7
Numbers
negative, 60

Operators, 25
big, 25
binary, 28
Limits, 26
self-defined, 28

Packages
braket, 60
calc, 24, 41
cancel, 62
carlisle, 51
color, 22
eurosym, 35



hyperref, 62, 69
icomma, 60
mathrsfs, 67
mhchem, 53, 69
multicol, 63
remreset, 51
upgreek, 65
was, 60, 65

Placeholders, 7

Relations, 35
Roots, 5

Space
besides inline formulas, 19
horizontal, 18
predefined, 18
variable, 19
Special characters, 38
miscellaneous, 40
Subscripts, see Indices
Sums, 25
Superscripts, see Exponents
Symbols, 34
chemical, 52
Euro-symbol, 35
mathematical, 34
miscellaneous, 34
Synonyms, 68

TEX-braces, 2
TEX-mode, 2
Text

colored, 23

in formulas, 2, 47, 65
Tilde, 39
Tips, 60
Typographic advice, 67

Umlauts, 16

User-defined commands, 55
Math macros, 56
\newcommand, 55

Vectors, 16

physical, 60
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