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1. Getting Started

1.1. What is LyX?

[yX is a document preparation system. It is a tool for producing beautiful manuscripts,
publishable books, business letters and proposals, and even poetry. It is unlike most
other “word processors” in the sense that it uses the paradigm of a markup language
as its core editing style. That means that when you type a section header, you mark
it as a “Section”, not “Bold, 17 pt type, left justified, 5 mm space below”. LyX takes
care of the typesetting for you, so you deal only with concepts, not the mechanics.

This philosophy is explained in much greater detail in the “Introduction”. If you
haven’t read it yet, you need to. Yes, we mean now.

The “Introduction” describes several things in addition to IyX’s philosophy: most
importantly, the format of all of the manuals. If you don’t read it, you’ll have a bear
of a time navigating this manual. You might also be better served looking in one of
the other manuals instead of this one. “Introduction” describes that, too.

1.2. How LyX Looks

Like most applications, IjyX has the familiar menu bar across the top of its window.
Below it is a toolbar with a pulldown box and various buttons. There is, of course,
a vertical scrollbar and a main work area for editing documents. Near the bottom of
the window is a small window containing a single line of text. This is the minibuffer,
which really means “command buffer”. Type M-x when you need to type a command
in the minibuffer.

Note that there is no horizontal scroll bar. This is not a bug or an oversight, but
intentional. When you read a book, you expect the end of a line to wrap around to
the next line. Text overflows onto new pages in a vertical fashion, hence the need for
only a vertical scrollbar. There are three cases where you might want a horizontal
scrollbar. The first case is large figures, displayed WYSIWYG. This, however, is due
to a flaw in the routine that displays graphics on the IyX screen in a WYSIWYG
fashion; it should rescale the graphics to fit in the window, just as you’d need to rescale
graphics to fit on a page. The second and third cases are tables and equations which
are wider than the IyX window. You can use the arrow keys to scroll horizontally
through the table, but this doesn’t work for equations yet.

For a brief description of all IyX menus and toolbar buttons, have a look at Ap-
pendix A. Most of them are self-explanatory and you’ll find them listed in the corre-
sponding sections of this documentation.
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1.3. HELP

The help system consists of the IiyX manuals. You can read all of the manuals from
inside IyX. Just select the manual you want read from the Help menu.

1.4. Basic LyX Setup

There are several features of IiyX that can be configured from inside LyX, without
resorting to configuration files. First, IiyX is able to inspect your system to see what
programs, IXTEX document classes and KIEX packages are available. It uses this
knowledge to give reasonable defaults to several Preferences settings. Although this
configuration has already been done when [yX was installed on your system, you
might have some items that you installed locally, e.g. new IXTEX classes, and which
are not seen by IyX. To force IiyX to re-inspect your system, you should use Toolsr
Reconfigure. You should then restart [yX to ensure that the changes are taken into
account.

1.5. BTEX Setup

LyX needs several KIEX packages to work properly. The packages found on the
system by IxyX are listed in the file LaTeX Configuration that will be created when
using the menu Help>LaTeX Configuration. You should install the required missing
packages and then reconfigure LyX.



2. How to work with LyX

2.1. Basic File Operations

Under the File menu are basic operations for any word processor in addition to some
more advanced operations:

o New

¢ New from_Template
» Open

o Close

o Save

o Save As

e Revert to saved
» Version Control
e Import

o Export

e Print

o Exit

They all do pretty much the same thing as in other word processors, with a few minor
differences. The File>New from_Template command not only prompts you for a name
for the new file, but also prompts you for a template to use. Selecting a template
will automatically set certain layout features for the document, features you would
otherwise need to change manually. They can be of use for certain classes, especially
those for writing letters (see section 3.1.2).

Note: There is no “default file” or document named “Untitled” or “scratch.” Unless
you tell LyX to open a file or create a new one, that big, blank space is just that —
a big, blank space.
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Revert to saved and Version Control are useful if more people work on the same
document at the same time!. Revert to saved will reload the document from disk.
You can of course also use it if you regret that you changed a document and want to
restore it to the last save. With Version Control you can there register the changes
you made to a document so that others can identify this as your changes.

2.2. Basic Editing Features

Like most modern word processors, LyX can perform cut and paste operations on
blocks of text, can move by character, word, or screenful of text, and can delete
whole words as well as individual characters. The next four sections cover the basic
LyX editing features and how to access them. We'll start with cut and paste.

As you might expect, the Edit menu has the cut and paste commands, along with
various other editing features. Some of these are special and covered in later sections.
The basic ones are:

o Cut

 Copy

o Paste

o Paste Recent
o Paste Special

e Find & Replace

The first three are self-explanatory. One thing to note: whenever you delete a block
of text that you've selected, it’s automatically placed in the clipboard. That is, the
Delete and Backspace keys also functions as the Cut command. Also, if you’ve selected
text, be careful: If you hit a key, LyX will completely delete the selected text and
replace it with what you just typed. You'll have to do an Undo to get back the lost
text.

You can also copy text between LyX and other programs by cut, copy and paste.
The submenu of Paste Recent shows you a list with the last strings you have pasted.

The menu Edit>Paste Special>Plain Text, Join Lines will insert the text in the
clipboard so that the whole text is inserted as one paragraph. A new paragraph is
started when there is a blank line in the file. Without Join Lines, the text is inserted
as Paragraphs, where the line breaks of the text will start a new paragraph.

The Edit>Find & Replace item opens the Find and Replace dialog. Once you've
found a word or expression, [yX selects it. Hitting the Replace button replaces the
selected text with the contents of the Replace with field. You can click the Find Next

'Tf you plan to do this, you should check out the Version Control feature in IyX also. Read
Ezxtended Features.



2.3. Undo and Redo

button to skip the current word. Hit Replace All to replace all occurrences of the text
in the document automatically. The Case sensitive option can be used if you want
the search to consider the case of the search word. If the toggle is set, searching for
“Test” will not match the word “test”. The Match whole words only option can be
used to force IyX to only find complete words. I.e., searching for “star” will not
match “starlet”

Things like notes, floats, etc., the so called insets can be dissolved. This means
that the inset is deleted and its content is left as normal text. Dissolving an inset is
done by setting the cursor to the beginning of an inset and pressing Backspace or by
setting the cursor to the end and pressing Delete.

2.3. Undo and Redo

If you make a mistake, you can easily recover from it. LyX has a large-capacity
undo/redo buffer. Select Edit>Undo to undo some mistake. If you accidentally undo
too much, use Edit>Redo to “undo the undo.” The undo mechanism is currently
limited to 100 steps to minimize memory overhead.

Notice that if you revert back all changes to arrive to the document as it was last
saved, the “changed” status of the document is unfortunately not reset. This is a
consequence of the 100 step undo limit, above.

The Undo and Redo work on almost everything in LyX. They have some quirks,
too. They won’t Undo or Redo text character by character, but by blocks of text.
That can take some getting used to; you'll have to play with Undo and Redo to get
a feel for just how much they’ll undo/redo, and after time, you’ll surely appreciate
how it works.

2.4. Mouse Operations

This are the most basic mouse operations.

1. Motion

o Click the left mouse button once anywhere in the edit window. The cursor
moves to the text under the mouse.

2. Selecting Text

« Hold down the left mouse button and drag the mouse. Iy X marks the text
between the old and new mouse positions. Use Edit> Copy to create a copy
of the text in LyX’s buffer (and the clipboard).

« Re-position the cursor and then paste the text back into [y X using Editr
Paste.
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3. Insets (Footnotes, Notes, Floats, etc.)

Single click the left mouse button to open or close any of these. Right-click on
them to set its properties. Also check the appropriate section of this manual
for more details.

4. Tables

Single click the right mouse button to open a dialog that will allow you to
manipulate the table.

2.5. Basic Key Bindings

We’re not going to cover all of the keybindings. Be aware that there are at least two
different primary binding maps: CUA and Emacs. Iy X’s default is CUA.

Some keys, like Page Up, Page Down, Left, Right, Up, and Down, do exactly what
you expect them to do. Other keys don’t:

Tab

Esc

There is no such thing as a tab stop in Iy/X. If you don’t understand this,
go read sections 3.2.1 and 3.3, especially section 3.3.6, right now. Yes,
right now. If you're still confused, look in the Tutorial.

This is the “cancel key.” It’s used, generically, to cancel operations. Other
parts of the manual will go into greater detail about this.

Home and End These move the cursor, respectively, to the beginning and end of a

line, unless you are using the Emacs bindings where they jump to the
beginning or end of the file.

There are three modifier keys:

Control

Shift

Meta

(Denoted by “C” in the documentation files) This has a couple of different
uses, depending on which keys it’s used in combination with:

o With Backspace or Delete, it deletes an entire word instead of a single
character.

o With Left and Right, it moves by words instead of characters.
e With Home and End, it moves to the beginning and the end of the

document, respectively.

(Denoted by “S” in the documentation files) Use this with any of the
motion keys to select the text between the old and new cursor positions.

(Denoted by “M” in the documentation files) This is the Alt key on many
keyboards, unless your keyboard has a distinct Meta key. If you have
both keys, you will need to try out which one actually performs the Meta-
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function. This key does many different things, but it also activates the
menu accelerator keys. If you use this in combination with any of the
underlined letters in a menu or menu item, it selects that menu item.

For example, the sequence “M e s c¢” brings up the “Text Style” menu.
Typing “M f” opens the File menu.

There are also other things bound to the Meta- key, but you’ll have to
check in the Reference manual for more info.

You'll learn more and more keybindings and short-cut keys as you use LyX, because
most actions will prompt a small message in the status bar at the bottom of IyX’s
main window which describe the name of the action, you've just triggered, and any
existing keybindings for that action. The notation for the keybindings is very similar
to the notation used in this documentation, so you should not have any problems
understanding it. However, notice that Shift-modifiers are explicitly mentioned, so
“M-p S-A” means Meta-p followed by a capital A. “S-C-s” means Shift-Control-s.
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3.1. Document Types

3.1.1. Introduction

Before you do anything else, before you ever start writing a document, you need to
decide what type of document you want to edit. Different types of documents use
different types of spacing, headings, numbering schemes, and so on. Additionally,
different documents use different paragraph environments, and format the title of
your document differently.

A document class describes a group of properties common to a particular set of
documents. By setting the document class, you automatically select these properties,
making it easier to create the type of document you want. If you don’t choose a
document class, LyX picks one for you by default. So, it behooves you to change the
class of your document.

Read on for info about the document classes you can choose from IxX, and how
to adjust their properties.

3.1.2. Document Classes

3.1.2.1. Overview

There are four standard document classes in IyX. They are:
Article for basic articles

Report for basic reports

Book for writing a book

Letter for US-style letters

There are also some non-standard classes, which IyX only uses if you have installed
them. Here are some of the classes, the full list with detailed explanations can be
found in chapter Special Document Classes in the Extended Features manual:

A&A Journal articles in the style and format used in Astronomy & Astrophysics

AASTeX For submissions to the journals published by the American Astronomical
Society
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AMS Layouts for articles and books in the style and format used by the American
Mathematical Society (AMS). There are three article layouts available. The
standard one uses a typical numbering scheme for theorems etc., that prepends
the section number to the number of the result. All result-type statements
(propositions, corollaries, and so on) are sequenced together, but definitions,
examples, and the like have their own sequence. The “sequential numbering”
scheme does not place the section number with each result, but numbers them
throughout the article in a single sequence. Each type of result gets its own
sequence. There is also a layout that dispenses with numbering of statements
altogether.

Beamer Layout for presentations

broadway Layout for writing plays. It is not an existing KWTEX document class, but
a new one which is distributed with LyX.

curiculum vitae classes to create curriculum vitae
Dinbrief Letters in format of the DIN (German industry norm)

dtk Layout for Die TeXnische Komédie, the journal of the German TEX user Group
(Dante)

Elsevier Layout for journals of the Elsevier publishing group
Foils Used to make transparencies
g-brief Letters in format of the DIN (German industry norm)

hollywood Used to type spec scripts for the US film industry. It is not an existing
ITEX document class, but a new one which is distributed with IyX.

IEEEtran Layout for the journals published by the Institute of Electrical and Elec-
tronics Engineers (IEEE)

IOP Layout for journals of the Institute of Physics publishing group
Kluwer Layout for journals of the Kluwer publishing group

koma-script a replacement for the standard classes, offers many useful features like
caption formatting, automatic print space calculation etc.

Memoir another replacement for the standard classes
paper Used with the paper IXTEX document class

Powerdot Layout for presentations

10
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REVTeX is used to write articles for the publications of the American Physical Soci-
ety (APS), American Institute of Physics (AIP), and Optical Society of America
(OSA). This class is not completely compatible with all IyX features.

Slides Used to make transparencies

SPIE Proceedings Layout for the journals published by The International Society
for Optical Engineering (SPIE)

Springer Layouts for journals of the Springer publishing group

TUGboat Layout for TUGboat, the journal of the international TEX user Group
(TUG)

We won’t go into any detail about how to use these different document classes here.
You can find all the details about the non-standard classes in the Eztended Editing
manual. Here, we will settle with a list of some of the common properties of all of
the document classes.

3.1.2.2. Selecting a Class

You can select a class using the Document > Settings dialog. Select the class you want
to use, and make any fine tunings of the options you may need.

3.1.2.3. Properties

Each class has a default set of options. Here’s a quick table describing them:

’ H Pagestyle \ Sides \ Columns \ Max. sectioning level ‘

article Plain One One Section
report Plain One One Chapter
book | Headings | Two One Chapter
letter Plain One One none

You're probably also wondering what “Max. sectioning level” means. There are
several paragraph environments used to create section headings. Different document
classes allow different types of section headings. Only two use the Chapter heading;
the rest do not and begin instead with the Section heading. Some document classes,
such as the ones for letters, don’t use any section headings. In addition to Chapter
and Section headings, there are also Subsection headings, Subsubsection headings, and
so on. We'll describe these headings fully in section 3.3.4.

11
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3.1.3. Document Layout

The most important properties of documents classes are set in the menu Document >
Settings. There in the Options field under Documents classes, you can enter special
options for your document class in a comma-separated list. This is only necessary if
IyX doesn’t support special options you want to use for your document. To learn
more about your favorite KXTEX-class and its options, you have to read its manual.

Under Page Layout the Pagestyle controls what sorts of headings and page numbers
go on a page. You can choose between the following five options:

Default
Empty
Plain

Headings

Fancy

Use default pagestyle of current class.
No page numbers or headings.
Page numbers only.

Page numbers and either the current chapter or section title and number.
Whether [yX uses the current chapter or the current section depends on
the maximum sectioning level of the class.

This allows you to create fully customizable headers and footers if you
have the fancyhdr package installed. At the moment, support in IxX is
limited to this setting. To use the full power of this package, you have to
add code to your document preamble. Check the documentation for the
fancyhdr package for more details, [9].

The Separation of paragraphs is described in section 3.2.1.

3.1.4. Paper Size and Orientation

You’ll find the following options in the menu Page Layout of the dialog of the Docu-
ment > Settings menu:

Papersize

What size paper to print on. The choices are

o Default

o A3, A4, A5

- B3, B4, B5

o US letter

o US legal

o US executive

¢ Custom

12
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Orientation Two toggle buttons choose whether to print the output as Landscape or
as Portrait.

Two-sided document Adjusts the print space to print both sides of paper. That means
that the print space for odd- and even-numbered pages is different.

3.1.5. Margins

Paper margins are set in the menu Document > Settings.

If you use a koma-script document class, you can use the default settings. Because
koma-script calculates then the printspace automatically by taking the paper format
and the font size into account.

3.1.6. Important Note

If you change a document class, IxyX has to convert everything into the new class.
That includes the paragraph environments. Some paragraph environments are stan-
dard; all of the document classes have them; but some classes have special paragraph
environments. If this is the case, and you change the document class, IyX sets the
missing paragraph environments to Standard and places an error box at the beginning
of the paragraph. Just click on them and you’ll get a message dialog that tells you
about the conversion and why it failed.

3.2. Paragraph Indentation and Separation

3.2.1. Introduction

Before describing all of the various paragraph environments, we’d like to say a word
or two about paragraph indentation.

Everyone seems to have their own convention for separating paragraphs. Most
Americans indent the first line of a paragraph. Others don’t indent but put extra
space between the paragraphs. If you choose indentation for paragraphs the first
paragraph of a section, or after a figure, an equation, a table, a list, etc., is not
indented. Only a paragraph following another paragraph gets indented. Note that
the indentation behavior is different when you use another document language than
English. BTEX takes care that the indentation follows the rules of the used language.

The space between paragraphs, like the line spacing, the space between headings
and text — in fact, all of the spacings for just about everything are pre-coded into
LyX. As we said, you don’t worry about how much space to add between what. IyX
takes care of that. In fact, these pre-coded vertical spacings aren’t a single number
but a range. That way, IyX can squish or stretch the space between lines to make
sure figures fit on a page with text, so that sections don’t start at the bottom of a

13
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page, and so on.! However, pre-coded doesn’t mean you can’t change them. IyX

gives you the ability to globally change all of these pre-coded spacings. We’ll explain
more later.

3.2.2. Paragraph Separation

To separate paragraphs, select Indent or Skip in the submenu Text Layout of the dialog
Document > Settings to indent paragraphs or add extra space between paragraphs,
respectively. The size of the skips can be defined in the dialog, for the indentation
you have to add this line to your document preamble:

\setlength{\parindent }{Length}

where length is a value in one of the units listed in Appendix C.1. The default
length is 30 pt.

3.2.3. Fine-Tuning

You can also change the separation method of a single paragraph. Open the Edit>
Paragraph Settings dialog and toggle the Indent Paragraph option to change the state
of the current paragraph. If paragraphs have no indentation but use extra space
for separation, this button will be ignored (you can’t indent a single paragraph by
toggling this).

You should only need to change the indentation method for a single paragraph if
you need to do some fine-tuning.

3.2.4. Line Spacing

In the Document > Settings dialog you can set the line spacing in the submenu Text Lay-
out.?

3.3. Paragraph Environments

3.3.1. Overview

The paragraph environments correspond to the various

\begin{ environment} ... \end{environment}
command sequences in an ordinary ETEX file. If you don’t know IXTREX, or the concept
of a paragraph environment is totally alien to you, we urge you to read the Tutorial.
The Tutorial also contains many more examples than this section does.

A paragraph environment is simply a “container” for a paragraph which gives that
paragraph certain properties. This can include a particular style of font, different
margins, a numbering scheme, labels, and so on. Additionally, you can “nest” the

ATEX does this when LyX goes to produce a printable file.
2You need to have the INTEX-package setspace installed to use this feature.
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different environments inside one another, allowing one environment to inherit some
of the properties of another. The different paragraph environments totally replace
the need for messy tab stops, on the fly margin adjustment, and other hold-overs
from the days of typewriters. There are several paragraph environments which are
specific to a particular document type. We'll only be covering the most common ones
here.

To choose a new paragraph environment, use the pull-down box on the left end of
the toolbar. X will change the environment of the entire paragraph in which the
cursor sits. You can also change the environment of an entire group of paragraphs if
you select them before choosing the new environment.

Note that hitting Return will typically create a new paragraph using the Standard
paragraph environment. We say “typically” because if you are in one of these envi-
ronments:

e Quote

o Quotation
o Verse

o ltemize

o Enumerate
o Description

o List

Iy X keeps the old paragraph environment when you hit Return, rather than resetting
it to Standard. LyX will still reset the nesting depth, however. Usually, starting a new
paragraph resets both the paragraph environment and the nesting depth (for more
on nesting see section 3.4). At the moment, all this is context-specific; you're better
off expecting Return to reset the paragraph environment and depth. If you want a
new paragraph to keep the current environment and depth, use M-Return instead.

3.3.2. Standard

The default paragraph environment is Standard for most classes. It creates a plain
paragraph. If LyX resets the paragraph environment, this is the one it chooses. In
fact, the paragraph youre reading right now (and most of the ones in this manual)
are in the Standard environment.

You can nest a paragraph using the Standard environment in just about anything
else, but you can’t really nest anything in a Standard environment.

15
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3.3.3. Document Title

A TTEX title page has three parts: the title itself, the name(s) of the author(s) and a
“footnote” for thanks or contact information. For certain types of documents, ETEX
places all of this on a separate page along with today’s date. For other types of
documents, the title “page” goes at the top of the first page of the document.

IyX provides an interface to the title page commands through the paragraph en-
vironments Title, Author, and Date. Here’s how you use them:

o Put the title of your document in the Title environment.
e Put the author name in the Author environment.

« If you want the date to have a certain appearance, want to use a fixed date, or
want other text to appear in place of today’s date, put that text in the Date
environment. Note that using this environment is optional. If you don’t provide
any, WTEX will automatically insert today’s date. If you don’t want any date,
add the line

\date{}

to the preamble of your document (menu Document > Settings)

You can use footnotes to insert “thanks” or contact informations.

3.3.4. Headings

There are several paragraph environments for producing section headings. LyX takes
care of the numbering for you.

3.3.4.1. Numbered Headings
There are 7 numbered types of section headings. They are:
1. Part
2. Chapter
3. Section
4. Subsection
5. Subsubsection
6. Paragraph

7. Subparagraph

16
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[yX labels each heading with a series of numbers, separated by periods. The num-
bers describe where in the document you are. Unlike the other headings, parts are
numbered with Latin letters.

Headings all subdivide your document into different pieces of text. For example,
suppose you're writing a book. You group the book into chapters. LyX does similar

grouping:

Part is divided in either Chapter or Section
e Chapters are divided into Sections

Sections are divided into Subsections

Subsections are divided into Subsubsections

o Subsubsections are divided into Paragraphs

o Paragraphs are divided into Subparagraphs

Note: Not all document types use the Chapter heading as the maximum sectioning
level. In that case the Section is the top-level heading.

So, if you use the Subsubsection environment to label a new sub-subsection, [yX
labels it with its number, along with the number of the subsection, section, and, if
applicable, chapter that it’s in. For example: the fifth section of the second chapter
of this book has the label “2.5”.

3.3.4.2. Unnumbered Headings
There are 5 types of unnumbered section headings. They are:
1. Part*line spacing
2. Chapter*
3. Section*
4. Subsection*

5. Subsubsection*

The “*” after each name means that these headings are not numbered. They work
the same as their numbered counterparts but won'’t appear in the table of contents,
see section 6.2.

17



3. LyX Basics

3.3.4.3. Changing the Numbering

You can also alter which sectioning levels get numbered and which ones appear in
the Table of Contents. Now, this doesn’t remove any of the levels; that’s preset in
the document class. Certain classes start with Chapter and go down to the Subpara-
graph level. Others start at Section. Similarly, not all document classes number all
sectioning levels. Most don’t number Paragraph or Subparagraph. This is something
you can change.

Open the Document>Settings dialog. Under Numbering & TOC you’ll see two
counters. The one named Numbering controls how far down in the sectioning hierarchy
LyX numbers a section heading. The other one controls the appearance of the section
headings in the table of contents.

3.3.4.4. Short Titles of Headings

Some section or chapter titles, such as this one, can get quite long. This can cause
troubles when there is limited horizontal space. For example, if the header of the
page is set to show the current section title, a long title will protrude over the page
margins and look awful.

KETEX allows you to specify a short title for section headings. This short title is used
in the header and in the actual table of contents, avoiding the problem mentioned. To
specify a short title, use the menu Insert>Short Title. This will insert a box labeled
“opt” (stands for “optional”) which you can use to enter the short title text. This
also works for captions inside floats.

The title of this section is a good example of using this feature.

3.3.4.5. Special Information

The following information applies to all section headings:
e You cannot do any nesting with these environments.
* You cannot use a margin note in any of these environments.
e You can only use inline math in these environments.

¢ You can use labels and cross-references to refer to their numbers.

3.3.5. Quotes and Poetryline spacing

LyX has three paragraph environments for writing poetry and quotations. They are
Quote, Quotation, and Verse. Forget the days of changing line spacing and twiddling
with margins. These three paragraph environments already have those changes built-
in. They all widen the left margin and add a bit of extra space above and below the
text they contain. They also allow nesting, so you can put a Verse in a Quotation, as
well as in some other paragraph environments.
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There is another feature of these three paragraph environments: they do not reset
to Standard when you start a new paragraph. So, you can type in that poem and
merrily hit Return without worrying about the paragraph environment changing on
you. Of course, that means that, once you're done typing in that poem, you have to
change back to the Standard environment yourself.

3.3.5.1. Quote and Quotation

Now that we’ve described the similarities of these three environments, it’s time for

the differences. Quote and Quotation are identical except for one difference: Quote

uses extra spacing to separate paragraphs and never indents the first line. Quotation

always indents the first line of a paragraph and uses the same line spacing throughout.
Here’s an example of the Quote environment:

This is in the Quote environment. I can keep writing, extending this line
out further and further until it wraps. See — no indentation!

Here’s the second paragraph of this quote. Again, there’s no indentation,
but there is extra space between me and the other paragraph.

Here’s another example, this time in the Quotation environment:

This is in the Quotation environment. If I keep writing, you’ll see the
indentation. If your country uses a writing style that shows off new para-
graphs by indenting the first line, then Quotation is the environment for
you! Well, you'd use it if you were quoting other text.

Here’s a new paragraph. I could ramble on and on, like a politician at
election time. If I did that, though, you’d get bored.

As the examples show, Quote is for those people who use extra space to separate
paragraphs. They should put quotes in the Quote environment. Those who use in-
dentation to mark a new paragraph should use the Quotation paragraph environment
for quoted text.

3.3.5.2. Verse

Verse is a paragraph environment for poetry, rhymes, verses, and so on. Here’s an
example:

This is in Verse
Which I did not rehearse!

It could be much worse. This line could be long, very long, oh so long,
so very long that it wraps around. It looks okay on screen, but in the
printed version, the extra lines are indented a bit more than the first.
Okay, so it’s turned to prose and doesn’t rhyme anymore. So sue me.
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To break a line
And make things look fine
Use C-Return.

As you can see, Verse does not indent both margins. Each stanza of the verse or
poem is in its own paragraph. To separate the individual lines of a stanza, use the
break-line function C-Return.

3.3.6. Lists

LyX has four different paragraph environments for creating different kinds of lists. In
the ltemize and Enumerate environments, [yX labels your list items with bullets or
numbers, respectively. In the Description and List environments, [yX lets you provide
your own label. We’'ll present the individual details of each type of list next after
describing some general features of all four of them.

3.3.6.1. General Features

The four paragraph environments for lists differ from the other environments in several
ways. First, yX treats each paragraph as a list item. Hitting Return does not reset
the environment to Standard but keeps the current environment and creates a new
list item. The nesting depth is typically reset, however. If you want to keep both the
current nesting depth and paragraph environment, you should use M-Return to break
paragraphs.

You can nest lists of any type inside one another. In fact, IyX changes the labels
on some list items depending on how it is nested. If you intend to use any of the list
paragraph environments, we suggest you read all of section 3.4.

3.3.6.2. Itemize

The first type of list we’ll describe in detail is the Itemize paragraph environment. It
has the following properties:

o Each item has a particular bullet or symbol as its label.
— LyX uses the same symbol for all of the items in a given nesting level.

— The symbol appears at the beginning of the first line.

o The items can have any length. IyX automatically offsets the left margin of
each item. The offset is always relative to whatever environment the Itemize
list may be in.

o If you nest an ltemize environment inside another Itemize environment, the label
changes to a new symbol.

— There are four different symbols for up to a four-fold nesting.

20



3.3. Paragraph Environments

— LyX always shows the same symbol on screen.

— See section 3.4 for a full explanation of nesting.

Of course, that explanation was also an example of an Itemize list. The ltemize
environment is best suited for lists where the order doesn’t matter.

We said that different levels use different symbols as their label. Here’s an example
of all four possible symbols. Note that those of you reading this manual within [yX
won’t see any difference.

o The label for the first level ltemize is a large black dot, or bullet.

— The label for the second level is a dash.
x The label for the third is an asterisk.
The label for the fourth is a centered dot.
* Back out to the third level.

— Back to the second level.

« Back to the outermost level.

These are the default labels for an Itemize list. You can customize these labels in the
Document > Settings dialog in the submenu Bullets.

Notice how the space between items decreases with increasing depth. We’ll explain
nesting and all the tricks you can do with different depths in section 3.4.

3.3.6.3. Enumerate

The Enumerate environment is used to create numbered lists and outlines. It has
these properties:

1. Each item has a numeral as its label.
a) The type of numeral depends on the nesting depth.

2. IyX automatically counts the items for you and updates the label as appropri-
ate.

3. Each new Enumerate environment resets the counter to one.

4. Like the ltemize environment, the Enumerate environment:

a) Offsets the items relative to the left margin. Items can have any length.
b

) Reduces the space between items as the nesting depth increases.
c¢) Uses different types of labels depending on the nesting depth.
)

d) Allows up to a four-fold nesting.
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Unlike the Itemize environment, Enumerate shows the different labels for each item in
LyX. Here is how LyX labels the four different levels in an Enumerate:

1. The first level of an Enumerate uses Arabic numerals followed by a period.

a) The second level uses lower case letters surrounded by parentheses.
i. The third level uses lower-case Roman numerals followed by a period.
A. The fourth level uses capital letters followed by a period.

B. Again, notice the decrease in the spacing between items as the
nesting depth increases.

ii. Back to the third level
b) Back to the second level.

2. Back to the outermost level.

Once again, you can customize the type of numbering used in the Enumerate environ-
ment. It involves adding commands to the IXTEX preamble (see the Extended Features
manual). As stated earlier, such customization only shows up in the printed version,
not in LyX.

There is more to nesting Enumerate environments than we’ve stated here. You
should read section 3.4 to learn more about nesting.

3.3.6.4. Description

Unlike the previous two environments, the Description list has no fixed label. Instead,
LyX uses the first “word” of the first line as the label. Here’s an example:

Example: This is an example of the Description environment.

LyX typesets the label in boldface and puts extra space between it and the rest of
the line.

With the first “word” it is meant that the first hit of the Space key ends the label
if you are at the beginning of the first line of an item. If you need to use more than
one word in the label use a Protected Blank. (Use either C-Space or the menu Insert>
Formatting > Protected Space, see section 3.5.6.2 for more info.) Here is an example:

Second Example: This one shows how to use a Protected Blank in the label of a
Description list item.

Usage: You should use the Description environment for things like definitions and
theorems. Use it when you need to make one word in particular stand out in
the text that describes it. It’s not a good idea to use a Description environment
when you have an entire sentence that you want to describe. You're better off
using Itemize or Enumerate and nesting several Standard paragraphs into them.
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Nesting: You can nest Description environments inside one another, nest them in
other types of lists, and so on.

Notice that after the first line, IxX indents subsequent lines, offsetting them from
the first line.

3.3.6.5. The LyX List

The List environment is a IiyX extension to IXTEX.
Like the Description environment the List environment has user-defined labels for
each list item. There are the following properties of this list environment:

item labels LyX uses the first “word” of each line as the item label. The first Space
after the beginning of the first line of an item marks the end of the label.
If you need to use more than one word in an item label, use a protected
blank as described above.

margins  As you can see, LyX uses different margins for the item label and the body
of the item text. The body of the text has a larger left margin, which is
equal to the default label width plus a little extra space.

label width IyX uses the width of the label, or the default width, whatever is larger.
If the label width is larger, the label “extends” into the first line. In other
words, the text of the first line isn’t aligned with the left margin of the
rest of the item text.

default width You can set the default label width to ensure that the text of all items
in a List environment have the same left margin.
To change the default width, select all items in the list. Now open the
Edit> Paragraph Settings dialog. The text in the box Longest label deter-
mines the default label width. You can use the text of your largest label
here, but you can also use the letter “M” multiple times instead. The M is
the widest character and is a standard unit of widths in EXTRX. By using
“M” as the unit of width you don’t need to keep changing the contents of
Longest label every time you alter a label in a List environment.
The predefined default width is the length of “00.00.0000” (equal to 6 M).
Note: Setting the cursor into a list item to change only its label width
will only change the width inside IyX but not in the output.

You should use the List environment the same way like the Description list: When
you need one word to stand out from the text that describes it. The List environment
gives you another way to do this, using a different overall layout.

You can nest List environments inside one another, nest them in other types of
lists, and so on. They work just like the other list paragraph environments. Read
section 3.4 to learn about nesting.
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There is yet another feature of the List environment: As you can see in the examples,
LyX left-justifies the item labels by default. You can use additional HFills to change
how LyX justifies the item label. We'll document HFills later in section 3.5.1. Here
are some examples:

Left The default for List item labels.
Right One HFill at the beginning of the label right justifies it.

Center  One HFill at the beginning of the label and one at the end centers it.

3.3.7. Letters
3.3.7.1. Address and Right Address: An Overview

Although IxyX has document classes for letters, we've also created two paragraph
environments called Address and Right Address. To use the letter class, you need to
use specific paragraph environments in a specific order, otherwise IXTEX gags on the
document. In contrast, you can use the Address and Right Address paragraph environ-
ments anywhere with no problem. You can even nest them inside other environments,
though you can’t nest anything in them.

Of course, you're not limited to using Address and Right Address for letters only.
Right Address, in particular, is useful for creating article titles like those used in some
European academic papers.

3.3.7.2. Usage

The Address environment formats text in the style of an address, which is also used for
the opening and signature in some countries. Similarly, the Right Address environment
formats text in the style of a right-justified address, which is used for the sender’s
address and today’s date in some countries. Here’s an example of each:

Right Address

Who I am

Where I am

When is it? What is today?

That was Right Address. Notice that the lines all have the same left margin, which
LyX sets to fit the largest block of text on a single line. Here’s an example of the
Address environment:

Who are you
Where do I send this
Your post office and country

As you can see, both Address and Right Address add extra space between themselves
and the next paragraph. If you hit Return in either of these environments, LyX resets
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Abstract

This is an abstract. As you can see, ist is
printed in a smaller font size than the other
paragraph types.

Also several paragraphs are possible in the
abstract.

This is a “Standard” paragraph to visualize the differ-
ences in the font size.

Figure 3.1.: Paragraph in the Abstract environment

the nesting depth and sets the environment to Standard. This makes sense, since
Return is the break-paragraph function, and the individual lines of an address are not
paragraphs. Thus, you have to use break-line (C-Return or Formatting Character>
Line Break from the Insert menu) to start a new line in an Address or Right Address
environment.

3.3.8. Academic Writing

Most academic writing begins with an abstract and ends with a bibliography or list
of references. [yyX contains paragraph environments for both of these.

3.3.8.1. Abstract

The Abstract environment is used for the abstract of an article. Technically, you could
use this environment anywhere, but you really should only use it at the beginning of
the document, after the title. Also, don’t bother trying to nest Abstract in anything
else or vice versa. It won’'t work. The Abstract environment is only useful in the
article and report document classes. The book document classes ignores the Abstract
completely, and it’s utterly silly to use Abstract in a letter document class.

The Abstract environment does several things for you. First, it puts the centered
label “Abstract” above the text. The label and the text of the abstract are separated
by some extra vertical space. Second, it typesets everything in a smaller font, just
as you'd expect. Lastly, it adds a bit of extra vertical space between the abstract
and the subsequent text. Well, that’s how it will appear on the LyX screen. The
appearance in the output depends on the used article or report class.

Starting a new paragraph by hitting Return does not reset the paragraph environ-
ment. The new paragraph will still be in the Abstract environment. So, you will have
to change the paragraph environment yourself when you finish entering the abstract
of your document.
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We'd love to give you directly an example of the Abstract environment, but since
this document is in the “book” class, we can’t do this. We inserted it therefore as
figure 3.1. If you've never heard of an “abstract” before, you can safely ignore this
environment.

3.3.8.2. Bibliography

The Bibliography environment is used to list references. Technically, you could use this
environment anywhere, but you really should only use it at the end of the document.
Nesting Bibliography in anything else or vice versa won’t work.

When you first open a Bibliography environment, [xX add a large vertical space,
followed by the heading “Bibliography” or “References,” depending on the document
class. The heading is in a large boldface font. Each paragraph of the Bibliography en-
vironment is a bibliography entry. Thus, hitting Return does not reset the paragraph
environment. Each new paragraph is still in the Bibliography environment.

For a detailed description of I5X’s bibliography handling, have a look at in sec-
tion 6.5.

3.3.9. LyX-Code

The LyX-Code environment is another IyX extension. It type-sets text in a typewriter-
style font. It also treats the Space key as a fixed whitespace;® this is the only case in
which you can type multiple whitespaces in LyX. If you need to insert blank lines,
you'll still need to use C-Return (the break-line function). Return breaks paragraphs.
Note, however, that Return does not reset the paragraph environment. So, when
you finish using the LyX-Code environment, you'll need to change the paragraph
environment yourself. Also, you can nest the LyX-Code environment inside of others.
There are a few quirks with this environment:

e You cannot use C-Return at the beginning of a new paragraph (i.e. you can’t
follow Return with a C-Return).

e You can’t follow a C-Return with a Space.

— Use a Return to begin a new paragraph, then you can use a Space.

— Or: use C-Space instead.

e You can’t have an empty paragraph or an empty line. You must put at least
one Space in any line you want blank. Otherwise, INXTEX generates errors.

¢ You cannot get the typewriter double quotes by typing " since that will insert
real quotes. You get the typewriter double quotes with C-" (or C-q if you use
Emacs-like key bindings).

3In the LyX-Code environment, the Space key is treated as a Protected Blank instead of an end-of-
word marker.
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Here’s an example:

#include <stdio.h>

int main(void)

{
printf ("Hello World!\n");
return O;

3

This is just the standard “Hello world!” program.

LyX-Code has one purpose: to typeset code, such as program source, shell scripts,
rc-files, and so on. Use it only in those very special cases where you need to generate
text as if you used a typewriter.

3.4. Nesting Environments

3.4.1. Introduction

[yX treats text as a unified block with a particular context and specific properties.
This allows you to create blocks that inherits some of the properties of another block.
For example you have three main points in an outline, but point #2 also has two
subpoints. In other words, you have a list inside of another list, with the inner list
“attached” to item #2:

1. one

2. two
a) sublist - item #1
b) sublist - item #2

3. three

You put a list inside of a list by nesting one list inside the other. Nesting an environ-
ment is quite simple: Select Increase List Depth or Decrease List Depth from the Edit
menu to change the nesting depth of the current paragraph (the status bar will tell
you how far you are nested). Instead of the menu, you can also use the toolbar but-

tons =4 and }—‘ or the convenient key bindings S-M-Right and S-M-Left to change
the nesting level. The change will work on the current selection if you have made one
(allowing you to change the nesting of several paragraphs at once), or the current
paragraph.

Note that Iy X only changes the nesting depth if it can. If it’s invalid to do so,
nothing happens if you try to change the depth. Additionally, if you change the depth
of one paragraph, it affects the depth of every paragraph nested inside of it.
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Nesting isn’t limited to lists. In LyX, you can nest just about anything inside
anything else, as you're about to find out. This is the real power of nesting paragraph
environments.

3.4.2. What You Can and Can’t Nest

Before we fire a list of paragraph environments at you, we need to tell you a little bit
more about how nesting works.

The question if nesting a paragraph environment is possible, is a bit more compli-
cated than a simple yes or no. There are three types of paragraph environments:

o Completely unnestable

« Fully nestable, you can nest them inside of things and you can also nest other
things inside of them.

e A third type, you can nest them into other environments, but you can’t nest
anything into them.

Here’s a list of the three types of nesting behavior, and which paragraph environments
have them:

Unnestable Can’t nest them. Can’t nest into them.

o Part

o Chapter
 Section
 Subsection
 Subsubsection
o Paragraph

o Subparagraph
o Part*

o Chapter*

o Section*

o Subsection*
o Subsubsection*
 Bibliography
o Abstract

o Title

o Author
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e Date

Fully Nestable You can nest them. You can nest other things into them.

o Verse

« Quote

e Quotation
o Itemize

e Enumerate
o Description
o List

o LyX-Code

Nestable-Inside You can nest them inside of other things. You can’t nest anything
into them.

o Standard
o Right Address
e Address

The Caption environment doesn’t really fit anywhere, since it’s only used inside of
Table Floats and Figure Floats.

3.4.3. Nesting Other Things: Tables, Math, Floats, etc.

There are several things that aren’t paragraph environments, but which are affected
by nesting anyhow. They are:

e equations
o tables

o figures

( Note: If you put a figure or a table in a Float, this is no longer true. Have a look
at section 4.6 for more informations about Floats.)

LyX can treat these three objects as either a word or as a paragraph. If a figure,
table, or an equation is inline, it goes wherever the paragraph it is in goes.

On the other hand, if you have an equation, figure or table in a “paragraph” of its
own, it behaves just like a “nestable-inside” paragraph environment. You can nest it
into any environment, but you obviously can’t nest anything into it.

Here’s an example with a table:

1. Ttem One
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a) This is (a) and it’s nested.

b) This is (b). The table is actually nested inside (a).

2. Back out again.
If we hadn’t nested the table at all, the list would look like this:

1. Item One
a) This is (a) and it’s nested.

on

1. This is (b). The table is not nested inside (a). In fact, it’s not nested at all.

2. Back out again.

Notice how item (b) is not only no longer nested, but is also the first item of a new
list!

There’s another trap you can fall into: Nesting the table, but not going deep
enough. LyX then turns anything after the table into a new sublist.

1. Item One
a) This is (a) and it’s nested.

a) This is (b). The table is actually nested inside Item One, but not inside

(a).

2. Back out again.

As you can see, item (b) turned into the first item of a new list, but a new list inside
item 1. The same thing would have happened to a figure or an equation. So, if you
nest tables, figures or equations, make sure you go to the right depth!

30



3.4. Nesting Environments

3.4.4. Usage and General Features

Speaking of levels, LyX can perform up to a six-fold nesting. In other words, “level
#6” is the innermost possible depth. Here’s an example to display what we mean:

1. level #1 - outermost

a) level #2
i. level #3
A. level #4
o level #5

— level #6

There are two exceptions to the six-fold nesting limit, and you can see both of them
in the example. Unlike the other fully-nestable environments, you can only perform
a four-fold nesting with the Enumerate and ltemize environments. For example, if we
tried to nest another Enumerate list inside of item “A.”, we’d get errors.

3.4.5. Some Examples

The best way to explain just what you can do with nesting is by illustration. We
have several examples of nested environments. In them, we explain how we created
the example, so that you can reproduce them.

3.4.5.1. Example 1: The Six-fold Way and Mixed Nesting

#1-a  This is the outermost level. It’s a List environment.

#2-a  This is level #2. We created it by using M-Return followed by S-M-

Right.

#3-a  This is level #3. This time, we just hit Return, then used S-M-

Right twice in a row. We could have also created it the same
way as we did the previous level, by hitting M-Return followed
by S-M-Right.

This is actually a Standard environment, nested inside of “#3-
a”. So, it’s at level #4. We did this by hitting M-Return,
then S-M-Right, then changing the paragraph environment to
Standard. Do this to create list items with more than one
paragraph - it also works for the Description, Enumerate, and
Itemize environments!

Here’s another Standard paragraph, also at level #4, made with
just a M-Return.
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#4-a  This is level #4. We hit M-Return and changed the
paragraph environment back to List. Remember - we
can’t nest anything inside of a Standard environment,
which is why we're still at level #4. However, we can
keep nesting things inside of “#3-a”.

#5-a  This is level #5. ..

#6-a ...and this is level #6. By now, you
should know how we made these two.

#5-b  Back to level #5. Just hit M-Return followed by
a S-M-Left.

#4-b  After another M-Return followed by a S-M-Left, we're
back at level #4.

#3-b  Back to level #3. By now it should be obvious how we did
this.

#2-b  Back to level #2.

#1-b  And last, back to the outermost level, #1. After this sentence, we’ll hit Return
and change the paragraph environment back to Standard to end the list.

We could have also used the Description, Quote, Quotation, or even the Verse environ-
ment in place of the List environment. The example would have worked exactly the
same.

3.4.5.2. Example 2: Inheritance

This is the LyX-Code environment, at level #1, the outermost
level. Now we’ll hit Return, then S-M-

Right, after which, we’ll change to the Enumer-

ate environment.

1. This is the Enumerate environment, at level #2.

2. Notice how the nested Enumerate not only inherits its
margins from its parent environment (LyX-Code), but also
inherits its font and spacing!

We ended this example by hitting Return. After that, we needed to reset the para-
graph environment to Standard and resetting the nesting depth by using S-M-Left
once.

3.4.5.3. Example 3: Labels, Levels, and the Enumerate and Itemize
Environments

1. This is level #1, in an Enumerate paragraph environment. We're actually going
to nest a bunch of these.
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a) This is level #2. We used M-Return followed by S-M-Right. Now, what
happens if we nest an Itemize environment inside of this one? It will be at
level #3, but what will its label be? An asterisk?

o No! It’s a bullet. This is the first ltemize environment, even though it’s
at level #3. So, its label is a bullet. (We got here by using M-Return,
then S-M-Right, then changing the environment to ltemize.)

— Here’s level #4, produced using M-Return, then S-M-Right. We’ll
do that again. ..

i. ...to get to level #5. This time, however, we also changed
the paragraph environment back to Enumerate. Notice the type
of numbering, it is lowercase Roman, because we are in the
thirdfold Enumerate environment (i.e. it is an Enumerate inside
an Enumerate inside an Enumerate).

ii. What happens if we don’t change the paragraph environment,
but decrease the nesting depth? What type of numbering does
LyX use?

iii. Oh, as if you couldn’t guess by now, we’re just using M-Return
to keep the current environment and depth but create a new
item.

iv. Let’s use S-M-Left to decrease the depth after the next M-Return.
i. This is level #4. Look what type of label Ly X is using!

i. This is level #3. Even though we've changed levels, IxX is still using
a lowercase Roman numeral as the label. Why?

ii. Because, even though the nesting depth has changed, the paragraph
is still a thirdfold Enumerate environment. Notice, however, that LyX
did reset the counter for the label.

b) Another M-Return S-M-Left sequence, and we’re back to level #2. This
time, we not only changed the nesting depth, but we also moved back into
the twofold-nested Enumerate environment.

2. The same thing happens if we do another M-Return S-M-Left sequence and
return to level #1, the outermost level.

Lastly, we reset the environment to Standard. As you can see, the level number
doesn’t correspond to what type of labeling Iy X uses for the Enumerate and Itemize
environments. The number of other Enumerate environments surrounding it deter-
mines what kind of label I5/X uses for an Enumerate item. The same rule applies for
the ltemize environment, as well.
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3.4.5.4. Example 4: Going Bonkers

34

1. We're going to go totally nuts now. We won't nest as deep as in the other

examples, nor will we go into the same detail with how we did it. (level #1:
Enumerate)

(Return, S-M-Right, Standard: level #2) We'll stick an encapsulated description
of how we created the example in parentheses someplace. For example, the two
keybindings are how we changed the depth. The environment name is the name
of the current environment. Either before or after this, we’ll put in the level.

. (Return, Enumerate: level #1) This is the next item in the list.

Now we’ll add verse.
It will get much worse.

(Return, S-M-Right, Verse: level #2)

Fiddle dee, Fiddle doo.
Bippitey boppitey boo!
(M-Return)

Here comes a table:

one-fish ‘ two-fish
red-fish ‘ blue-fish

(M-Return, Table, S-M-Right 3 times, M-Return, Verse, S-M-Left)

. (Return, Enumerate: level #1) This is another item. Note that selecting a Table

resets the nesting depth to level #1, so we increased the nesting depth 3 times
to put the table inside the Verse environment.

We're now ending the Enumerate list and changing to Quotation. We're
still at level #1. We want to show you some of the things you can do
by mixing environments. The next set of paragraphs is a “quoted letter.”
We’ll nest both the Address and Right Address environments inside of this
one, then use another nested Quotation for the letter body. We’ll use M-
Return to preserve the depth. Remember that you need to use C-Return to
create multiple lines inside the Address and Right Address environments.
Here it goes:

1234 Nowhere Rd.
Moosegroin, MT 00100
9-6-96

Dear Mr. Fizlewitz:



3.5. Spacing, pagination and line breaks

We regret to inform you that we cannot fill your order for 50 LL
of compressed methane gas due to circumstances beyond our
control. Unfortunately, several of our cows have mysteriously
exploded, creating a backlog in our orders for methane. We will
place your name on the waiting list and try to fill your order
as soon as possible. In the meantime, we thank you for your
patience.

We do, however, now have a special on beef. If you are inter-
ested, please return the enclosed pricing and order form with
your order, along with payment.

We thank you again for your patience.

Sincerely,

Bill Hick

That ends that example!

As you can see, nesting environments in Ly X gives you a lot of power with just a few
keystrokes. We could have easily nested an ltemize list inside of a Quotation or Quote,
or put a Quote inside of an Itemize list. You have a huge variety of options at your
disposal.

3.5. Spacing, pagination and line breaks

3.5.1. Horizontal Space
3.5.1.1. Horizontal Fills

Horizontal Fills (HFills) are a special IyX feature for adding extra space in a uniform
fashion. An HFill is actually a variable length space, whose length always equals the
remaining space between the left and right margins. If there is more than one HFill
on a line, they divide the available space equally between themselves.

HFills can be inserted with Insert > Formatting Character > Horizontal Fill. Here a few
examples what you can do with them:

This is on the left side This is on the right
Left Middle Right
Left 1/3 Left Right
That was an example in the Quote environment. Here— +1is one in

a standard paragraph. It may or may not be apparent in the printed text, but it is
sitting in-between the two arrows.

There may be more than one set of margins on a line. Here’s an example with the
List environment.
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one two :three four five six

The “:” marks the beginning of the item. (There is actually a “hidden” HFill inside
of the label of the List environment; it’s put at the end of the label automatically.)
HFills work similarly in other “multi-margin” situations, like two-column mode.

Note: If an HFill is at the beginning of a line, and not in the first line in a
paragraph, X ignores it. This prevents HFills from accidentally being wrapped
onto a new line. If you need space in this case anyway, you have to use the IXTEX-
command \hspace*{\fill} in ERT. (ERT is explained in section 6.9.)

3.5.1.2. Other space variants

The following two sorts of spaces are not yet supported by LyX, so that you have
to use ERT, see section 6.9. That they are not supported is a hint that you need
them very seldom in LyX. So use them only if it is really necessary (remind the
WYSIWYM concept).

Defined space Sometimes one needs space with a defined length, e.g for forms and
questionnaires. This can be inserted by using the I¥TgX-command \hspace in ERT.
For example the command \hspace{2cm} produces 2 cm space within the following
line:

This is a line with— «— 2cm space between the arrows.

You can use all length units listed in Appendix C.

Phantom space Sometimes you want to insert space with exactly the length of a
phrase. E.g. you want to create the following multiple choice question:

What is correct English?:

Mr. Edge would have been jumps the gun.
has to be jumped
jumps

So that the choices appear exactly after the phrase “Mr. Edge ”. To get this, you
can use the WTEX-command \phantom in ERT. In our case write the command
\phantom{Mr. Edge } (note the space after “Edge”) at the beginning of the
last two lines. The command prints out the phrase within the the two braces, but

invisible. That is why it is named “phantom”*

3.5.2. Vertical Space

To add extra vertical space above or below a paragraph, use the Insert> Formatting >
Vertical Space dialog. There you find the following sizes:

4There exists also the commands \hphantom and \vphantom, but this too special for the IyX
Userguide. If you are interested in knowing more about this, have a look at [1, 2].
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SmallSkip, MedSkip and BigSkip are IXTEX sizes which depends on the font size of
the document. DefSkip is the skip adjusted in the dialog Document > Settings for the
paragraph separation. If you use indentation to separate paragraphs DefSkip is equal
to MedSkip.

VFill is a variable space, set so that the space is maximal within one page. An
example: You have only two short paragraphs on one page with a vfill between them.
Then the first paragraph is placed at the top of the page and the second one at the
bottom, because the space between them is then maximal. VFills work like HFills:
they fill the remaining vertical space on a page with blank space.® If there are several
VFills on a page, they divide the remaining vertical space equally between themselves.
You can therefore use VFills to center text on a page, or even place text 2/3 down a
page.

Custom are custom spaces in units explained in Appendix C.

Note: When the extra vertical space would be in the output at the top/bottom
of a page, the space is only added if you have also checked the option Protect.

3.5.3. Paragraph Alignment

You can change the paragraph alignment with the Edit>Paragraph Settings dialog.
There are four possibilities:

Justified

o Left
o Right

o Center

The default in most cases is justified alignment, in which the inter-word spacing
is variable and each line of a paragraph fills the region between the left and right
margins. The other three alignments should be self-explanatory, and look like this:

This paragraph is right aligned,

this one is centered,

this one is left aligned.

5HFills are described in section 3.5.1.
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3.5.4. Forced Pagebreaks

If you don’t like the way IXTEX does the pagebreaks in your document, you can force a
pagebreak where you want one. Normally this will not be necessary, because KIEX is
good at pagebreaking. Only if you use many Floats, ¥TEX’s page breaking algorithm
can fail.

We recommend not to use forced pagebreaks until the text is finished, and until
you have checked in the preview to see if you really have to change the pagebreaking.

There are two types of pagebreaks: One that ends the page without any spe-
cial action. This can be inserted above or below a paragraph by the menu Insertr
Formatting> Page Break. The second type ends a page, but stretches the content of
the page, so that it fills out the complete page. This type is useful to avoid whites-
pace when a pagebreak produces a page on which only the last few lines are absent.
This type is not yet supported by LyX, so that you have to use the ETEX command
\pagebreak[number] in ERTS. The number can vary between 0 and 4. If 4 or no
number is used, it will always be created a pagebreak”. The numbers 0 to 3 stand for
the increasing priority level — IXTEX decides, concerning the priority, if a pagebreak
is created or not.

You might try to use a pagebreak to ensure that a figure or table appears at the
top of a page. This is, of course, the wrong way to do it. LyX gives you a way of
automatically ensuring that your figures and tables appear at the top of a page (or
the bottom, or on their own page) without having to worry about what precedes or
follows your figure or table. See chapter 4 to learn more about Floats.

3.5.4.1. Clear Pagebreaks

Differently to forced pagebreaks where the content behind the break is directly placed
at the next page, pages can also be cleared while breaking them. That means that
the current paragraph is terminated and all, perhaps not yet processed floats from
previous document parts are placed behind it, if necessary by adding pages.

You can insert a clear pagebreak with the menu Insert> Formatting> Clear Page.
When you have a two-sided document like a book, you can use the menu Insert>
Formatting> Clear Double Page to insert a clear pagebreak that assures that the next
page is a right-hand page (odd-numbered), if necessary by adding a page.

3.5.5. Forced Linebreaks

Similar to pagebreaks there are two types of linebreaks: One that simply breaks the
line. You can force this line break within a paragraph by selecting Insert > Formatting >
Line Break or with C-Return. The other type breaks the line and stretches it so that
it fills out the whole space between the page margins. This is necessary to avoid
“fringes” in justifies paragraphs due to whitespace introduced by linebreaks. This

5For more about ERT see section 6.9.
"normally one uses simply \pagebreak without a number
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type is not yet supported by LyX, so that you have to use the KIEX-command
\linebreak[number] in ERT. The syntax is similar tho the command \ pagebreak,
described in the previous section.

You shouldn’t use forced linebreaks to correct IXTEX’s linebreaking, as IMTEX is very
good at linebreaking. There are, however, a number of situations where it is necessary
to actively set a linebreak, e.g. in a poem or for an address (see sections 3.3.5.1, 3.3.5.2
and 3.3.7.2).

3.5.6. Blanks / Spaces

A blank is a blank? Not in good typography. While you might be used to press the
space key anytime you want to separate two words in ordinary word processors, LyX
offers you more spaces: Spaces of different width and spaces which can or cannot
be broken at the end of a line. The following sections will show you some examples
where those spaces are useful.

3.5.6.1. Inter-word Space

Some languages (e.g. English) have the typographical convention to add extra space
after an end-of-sentence punctuation mark, and LyX honors those conventions (see
section 3.8.3.1). Sometimes, you want a normal space nevertheless. In this case,
insert one with Insert>Special Formatting> Inter-word Space (shortcut C-M-Space).

3.5.6.2. Protected Space
The protected space: It is used to tell IyX (and TEX) not to break the line at that

point. This may be necessary to avoid unlucky linebreaks, like in:

Further documentation is given in section
6.5.

Obviously, it would be a good thing to put a protected space between “section”
and “6.5”. A protected space is set with Insert>Special Formatting> Protected Space
(shortcut C-Space).

3.5.6.3. Thin Space

A “thin space” is a blank which has half the size of a normal space (and it is also
“protected”). The typographical conventions in a lot of languages propose the use
of thin spaces in cases where normal spaces would be too wide, for instance inside
abbreviations:

D. E. Knuth has developed our beloved typesetting program, i.e. TEX.
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or between values and units. Compare for example this:
10 kg (thin space)
10 kg (normal space
You can insert thin spaces with the menu Insert>Special Formatting> Thin Space
(shortcut C-S-Space).

3.5.6.4. More Spaces

Apart from the ones described, there are still some more spaces. Although IyX
supports them natively, they can only be reached via a formula as described in sec-
tion 5.1.8 or via the command buffer toolbar. Te latter means to type

space-insert <command>

into the command buffer, where <command> is one of the following:®

’ command ‘ width ‘ protected? ‘
normal 1/3 em 1no
protected 1/3 em yes
thin 1/6 em yes
enspace 0.5 em yes
enskip 0.5 em no
quad 1 em no
qquad 2 em no
negthinspace | -1/6 em yes

3.5.7. Horizontal Lines

In the dialog Insert > Formatting > Horizontal Line you can insert horizontal lines that
spans over the whole document columns width.

3.6. Fonts and Text Styles

3.6.1. Font Types

There are two types of fonts:

Vector fonts are fonts, built from outlines of the single glyphs (i.e. characters) in
the font. This means that each glyph is defined using mathematical curves that
are well suited for scaling to any requested size. This mathematical definition is
interpreted by the font renderer and the curve is filled out with pixels according
to the size and glyph. This means that outline fonts will look pretty good in all

8The unit “em” is explained in Appendix C.
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sizes. Only at very small sizes it might be hard to provide a good rendering at
very small sizes, where each pixel has to be very carefully computed to provide
a good image.

One could mean that one only needs to define one font size and scale them. But
to achieve a better quality, many fonts define several font sizes. That improves
the appearance, because you need more details at large font sizes than at small
ones.

The font types TrueType, OpenType, and Type 1 PostScript are vector fonts.

Bitmap fonts on the other hand, are defined by bitmap graphics from the start, so
they will look good at all the sizes they are meant for. However, they don’t
scale well, because in order to scale a glyph, each pixel is enlarged into several
pixels. It is the same effect that happens if you try to enlarge a picture in a
picture manipulation program. In order to relieve this effect, bitmap fonts are
typically provided in several fixed sizes typically from around 8 pixels high up
to 34 pixels or so high in steps according to what is believed to be useful. The
advantage of bitmap fonts is that no complicated computations are necessary
to display each glyph, so bitmap fonts are thus faster displayed than scalable
fonts. The disadvantage is that sizes that don’t exists as fixed versions have to
be scaled by doubling pixels, and thus look bad.

Bitmap fonts are named Type 3 in PostScript- and PDF-documents.

The result of all this, is that bitmap fonts are best for the size they are designed for,
while scalable fonts are good for nearly all sizes. So one need less font size definitions
for scalable fonts. That’s the reason why nearly all text render and typesetting
programs use scalable fonts.

To test which fonts are used in a PDF-document, you can have a look into its
document properties.

Many modern typesetting and markup languages have begun to move towards
specifying character styles rather than specifying a particular font. For example,
instead of changing to an italicized version of the current font to emphasize text, you
use an “emphasized style” instead. This concept fits in perfectly with [yX. In LyX,
you do things based on contexts, rather than focusing on typesetting details.

3.6.2. Document Font and Font size

You can set the document fonts in the Document>Settings dialog. There you can
specify which font should be used for the three different font shapes roman (serif),
sans serif, and typewriter and its scalings.

The possible options for the font include default and a list of fonts available on your
system. default uses the standard TEX fonts, known as “Computer Modern” (cm) or
“European Computer Modern” (ec).

As cm and ec are bitmap fonts, they often looks pixeled in PDF output, especially
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when you read the PDF in a zoomed size.” To get rid of pixeled fonts, you have to
use a vector font. There are three ways to use one:

e One way is to use the AE fonts. AE is a virtual font. Virtual means that it
“steals” outline cm-glyphs from other fonts. This has the disadvantage that
some characters are missing, like the French guillemets (“«” and “»”)!° and
that accented characters are not one glyph, they are build of two characters,
the accent and the letter. Therefore you can’t search in documents using the
AE fonts for words with accented characters. If you search for example for the
French word “reve” in a PDF, you won’t get any result, because the PDF-viewer
searches for the glyph “ & ” and not for the glyph “ e + ™ .

o Another possibility is to use three different outline fonts'*: Times Roman as
roman font, Helvetica scaled to 92 or 95% as sans serif font, and courier as
typewriter font.

The differences between roman, sans serif, and typewriter fonts are explained
in section 3.6.4.

The font Times Roman was originally designed for newspapers. That means its
glyphs are smaller than the one from other fonts to fit into the small newspaper
columns. Therefore Times Roman is not the optimal choice for larger documents
like books.

e The best solution is to use the Latin Modern fonts. These fonts are developed
in order of the KITEX community to replace cm as default font.

For the font size there are four possible values: default, 10, 11, and 12. The size of
default depends on your KTEX-system, normally it is equal to the font size 10.

The font sizes are the base size. LyX actually scales all other possible font sizes
(such as those used in footnotes, super-, and subscripts) by this value. You can fine-
tune the font size of text parts via the Text Style dialog if needed. The possible font
sizes for text parts are explained in section 3.6.4.

Note: When you choose a new font or font size, IyX does not change the screen
font! You will only see a difference in the printed output; this is part of the WYSI-
WYM concept. LyX’s screen fonts can be adjusted in the Tools> Preferences dialog,
see section B.1.2.

9This problem doesn’t appear if you read PDFs in Adobe Reader version 6 or later, because this
program includes a special bitmap font renderer.
0T 0ading the MTEX-package aeguill with the document preamble line
\usepackage|ec]{aeguill}
will fix the guillemet problem.
10Other fonts, like Latin Modern or Computer Modern, consists of these three main font types
sans serif, typewriter, and serif.
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3.6.3. Using Different Character Styles

As we've already seen, IyX automatically changes the character style for certain

paragraph environments. LyX supports two character styles, Emphasized and Noun.

You can activate both of these styles via keybindings, the menus, and the toolbar.
To activate the Noun style, do one of the following:

o click on the toolbar button w

o use the keybinding M-c ¢

These commands are all toggles. That is, if Noun style is already active, they deac-
tivate it.

One typically uses the Noun style for proper names. For example: “MATTHIAS
ETTRICH is the original author of LyX.”

A more widely used character style is the Emphasized style. You can activate (or
deactivate - it’s also a toggle) the Emphasized style by:

« clicking on the toolbar button E
» using the keybindings M-c e

Normally the Emphasized style is equivalent to an italic font but some document
classes or TEX-packages use a different font.

We’ve been using the Emphasized style all over the place in this document. Here’s
one more example:

Don’t overuse character styles!

It’s also a warning in addition to an example. One’s writing should parallel ordinary
conversation. Since we don’t all constantly scream at each other, we should also avoid
the common tendency to overuse character style.

You can always reset to the default font using the keybinding M-c Space or the
dialog Edit> Text Style.

3.6.4. Fine-Tuning with the Text Style dialog

There are always occasions when you’ll need to do some fine-tuning, so LyX gives
you a way to create custom character style. For example, an academic journal or
a corporation may have a style sheet requiring a sans-serif font be used in certain
situations. Also, writers sometimes use a different font to offset a character’s thoughts
from ordinary dialog.

Before we document how to use custom character style, we want to issue a warning
yet again: Don’t overuse character styles!
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Documents that overuse different fonts and sizes are not well readable and tend to
look like someone has knocked huge holes in it.

To use custom character styles, open the Edit> Text Style dialog. There are several
boxes on this dialog, each corresponding to a different font property which you can
choose. You can choose an option for one of these properties, or select No change,
which keeps the current state of that property. The item Reset will reset the property
to whatever is the default. You can use this to reset attributes across a bunch of
different paragraph environments in a snap.

The font properties, and their options (in addition to No change and Reset) are:

Family

Series

Shape

Size
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The “overall look” of the font. The possible options are:

Roman This is the Roman font family. Normally a serif font. It’s also
the default family. (keybinding M-c r)

Sans Serif This is the Sans Serif font family. (keybinding M-c s)
Typewriter This is the Typewriter font family. (keybinding M-c p)

This corresponds to the print weight. Options are:

Medium This is the Medium font series. It’s also the default series.

Bold This is the Bold font series. (keybinding M-c b)

As the name implies. Options are:

Upright This is the Upright font shape. It’s also the default shape.
ltalic This is the Italic font shape.

Slanted This is the Slanted font shape (although it might not be visible
in LyX, this is different from italic).

Small Caps THIS IS THE SMALL CAPS FONT SHAPE.
Alters the size of the font. You'll find no numerical values here; all possible
sizes are actually proportional to the document font size. Once again, you

don’t feed Ly X the details, but a general description of what you want to
do. The options are:

Tiny This is the “Tiny” font size. (k€ybinding M-s t or M-s 1)

Smallest  This is the “Smallest” font size. (keybinding M-s 2)

Smaller This is the “Smaller” font size. (keybinding M-s S or M-s 3)
Small This is the “Small” font size. (keybinding M-s s or M-s 4)

Normal This is the “Normal” font size. It’s also the default size. (key-
binding M-s n or M-s 5)

Large This is the “Large” font size. (keybinding M-s | or M-s 6)
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Larger This is the “Larger” font size. (keybinding M-s S-L
or M-s 7)

Largest 1'his is the “Largest” font size. (keybinding
M-s 8)

nege 1his is the “Huge” font size. -
binding M-s h or M-s 9)

nger 1 11is IS the “Huger” font size. -
binding M-s H or M-s 0)

We’ll warn you yet again: don’t go crazy with this feature. You should almost never
need to change the font size. LyX automatically changes the font size for different
paragraph environments - use that instead. This is here for fine-tuning only!

Misc

Color

Language

Here you can change a few other things at the character level. Options
are:

Emph This is text with emphasize on. This might seem like the
same as [talic, but it is actually a bit different. Emphasized
is a logical attribute. That means every document class can
define its own font used for emphasized text. Normally this
font is equal to italic.

Underbar  This is text with Underbar on. (keybinding M-c u)
Avoid using underbar if you can! It’s a holdover from the type-
writer days, when you couldn’t change fonts. We no longer
need to emphasize text by underscoring characters. It’s only
included in LyX because some people may need it in order to
follow style sheets for journal submissions.

Noun THIS 1S TEXT WITH NOUN ON. Like Emph, this is a logical
attribute. Normally it’s equivalent to Small Caps.

You can adjust the color of the text with this control. Notice that not all
dvi-viewers are are able to display colors. Besides No color, which is the
default “color” and means normally black, you can choose between Black,
White, Red, Green, Blue, Cyan, Magenta and Yellow text.

This is used to mark regions of text as having a different language from
the language of the document. Text marked in this way will be underlined
in blue to indicate the change (only within IyX).

So you have a huge number of combinations to choose from. Once you've chosen a
new character style via the Edit> Text Style dialog, the settings are saved. You can

Font
activate them using the toolbar button + . The button lets you toggle the state of
your custom character style even when the dialog isn’t visible.
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To completely reset the character style to the default, use M-c Space. If you want
to toggle only those properties that you have just changed (suppose you just set the
shape to “slanted” and the series to “bold”), set the Toggle all switch and press Apply.

You should also know something about the differences between the three main font
types serif, sans serif, and typewriter:

o Typewriter is a so called “monospaced” font, that means every character has the
same width, the “i” is as wide as the “m”. Here is an example
typewriter text
no typewriter text

o Serif fonts use characters with serifs. These are the small “appendices” at all
ends of of the streaks that form the character. The following example will show
the difference:
text with serifs
text without serifs
Serifs facilitates an easy and fast reading. They are therefore used as default
font (named roman).

o Sans serif don’t use serifs. This font type is therefore often used for headings
and short texts. We use it in this document to highlight menu names.

We conclude with the same warning once again: Don’t overuse the fonts. They are,
more often than not, a kludge and a bad substitute for good writing.

3.7. Printing and Previewing

3.7.1. Overview

Now that we’ve covered some of the basic features of document preparation using
LyX, you probably want to know how to print out your masterpiece. Before we tell
you that, we want to give you a quick explanation of what goes on behind-the-scenes.
We cover these informations in much greater detail in the Fxtended Features manual
as well.

LyX uses the program KTEX as its backend. KTEX is just a macro package for the
TEX typesetting system, but to prevent confusion, we’ll only refer to BKTEX. LyX is
what you use to do your actual writing. Then, [yX calls BTEX to turn your writing
into printable output. This happens in two stages:

1. First, IxX converts your document to a series of text commands for KTEX,
generating a file with the extension,

2

.tex".

2. Next, BTEX uses the commands in the .tex file to produce printable output.
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3.7.2. Qutput file formats
3.7.2.1. ASCII

This file type has the extension “.txt”. It contains your document as plain text
following the rules of the “American Standard Code for Information Interchange”

(ASCII).
You can export your document to ASCII by the menu Filer> Export> ASCII.

3.7.2.2. BTEX

This file type has the extension “.tex” and contains all commands that are necessary
for the I¥TEX program to process your document. If you know KTEX, you can use
it to find out I¥TEX-Errors or to process it manually with console commands. The
ETEX-file is automatically created in LyX’s temporary directory whenever you view
or export your document.

You can export your document as I¥TEX-file using the menu File> Export>LaTeX.

3.7.2.3. DVI

This file type has the extension “.dvi”. It is called “device-independent” (DVI),
because it is completely portable; you can move them from one machine to another
without needing to do any sort of conversion. At the time when this file-format was
developed, this was no matter of course. DVIs are used for quick previews and as
pre-stage for other output formats, like PostScript.

Note: The DVI file doesn’t contain images, they will only be a linked. So don’t
forget to deliver the images together with your DVIs. This property can also slow
down your computer when you view the DVI. Because the DVI-viewer has to convert
the image in the background to make it visible when you scroll in the DVI. So we
recommend to use PDF for files with many images.

You can export your document to DVI by the menu Filer> Exportr>DVI.

3.7.2.4. PostScript

(13 7

This file type has the extension “.ps”. PostScript was developed by the company
Adobe as printer language. The file contains therefore commands that the printer
uses to print the file. PostScript can be seen as “programming language”; you can
calculate with it and draw diagrams and images.'?> Due to this ability, the files are
often bigger than PDFs.

PostScript can only contain images in the format “Encapsulated PostScript” (EPS,
file extension “.eps”). As LyX allows you to use any known image format in your
document, it has to convert them in the background to EPS. If you have e.g 50 images
in your document, Ly X has to do 50 conversions whenever you view or export your

2If you are interested to learn more about this, have a look at the ITjX-package pstricks.
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document. This will slow down your workflow with IyX drastically. So if you plan
to use PostScript, you can insert your images directly as EPS to avoid this problem.
You can export your document to PostScript using the menu File > Export > PostScript.

3.7.2.5. PDF

This file type has the extension “.pdf”. The “Portable Document Format” (PDF)
is developed by Adobe as derivative from PostScript. It is more compressed and it
uses much less commands than PostScript. As the name “portable” implies, it can
be processed at any computer system and the printed output looks exactly the same.

PDF can contain images in its own PDF format and in the formats “Joint Pho-
tographic Experts Group” (JPG, file extension “.jpg” or “.jpeg”) and “Portable
Network Graphics” (PNG, file extension “.png”). You can although use any other
image format, because IiyX converts them in the background to one of these formats.
But as described in the section about PostScript, the image conversion will slow
down your workflow. So we recommend to use images in one of the three mentioned
formats.

You can export your document to PDF via the menu Filer> Export in three different
ways:

PDF This uses the program ps2pdf that creates a PDF from a PostScript-version
of your file. The PostScript-version is produced by the program dvips which
uses a DVI-version as intermediate step. So this export variant consist of three
conversions.

PDF (dvipdfm) This uses the program dvipdfm that converts your file in the back-
ground to DVI and in a second step to PDF.

PDF (pdflatex) This uses the program pdftex that converts your file directly to
PDF.

We recommend to use PDF (pdflatex) because pdftex supports all features of actual
PDF-versions, is quick and works stable without problems. The program dvipdfm is
no more under development and therefore a bit outdated.

3.7.3. Previewing

To get a look at the final version of your document, with all of the pagebreaks in
place, the footnotes correctly numbered, and so on, use the menu View and choose a
file type. A viewing program will popup showing the output. For Viewr DVI you can

use the toolbar button (shortcut C-d), for View>PDF (pdflatex) you can use the
toolbar button /ELD

If you have changed your document, you can refresh the output in the same viewer
window using the menu View > Update.
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When you preview a file, the output file is only generated in LyX’s temporary
directory. To have a real output, export your document.

3.7.4. Printing the File from within LyX

Instead of exporting your file and then printing them, you can also print it directly
from within IyX. To print a file, select the menu Filer Print or click on the toolbar

button Cﬁ LyX will internally call XTEX to produce a DVI. This file is then
processed by the program dvips to PostScript-file, which is finally printed using the
program Ghostscript. Due to these steps in the background, this method is not the
fastest.

You can choose to print only even-numbered or odd-numbered pages - this is useful
for printing on two sides: You can re-insert the pages after printing one set to print on
the other side. Some printers spit out pages face-up, others, face-down. By choosing
a particular order to print in, you can take the entire stack of pages out of the printer
without needing to reorder them.

You can set the parameters in the Print Destination box as follows:

Printer This is the name of the printer to print to.'* The printer should under-
stand PostScript.

File The name of a file to print to. The output will be a PostScript file. It will
be written in IxX’s working directory unless you specify the full path.

3.8. A few Words about Typography

3.8.1. Hyphens

In IyX, the “-“ character comes in three lengths, often called the hyphen, the en
dash, and the em dash:

1. hyphen - made with “-“
2. en dash - made with “--¢
3. em dash — made with “---%
4. minus sign — a “=“ in math mode

w_«

You generate them by inserting the character multiple times in a row. They are
automatically converted to the appropriate length dash in the final output, but not
in LyX.

13Note that this printer name is for the program dvips. That means dvips has to be configured for
this printer name. The default printer can be set in LiyX’s preferences dialog, see section B.5.1.
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The three dash types are distinct from the minus sign, which appears in math mode

and has a length of its own. Here are some examples of the “~* in use:
1. line- and page-breaks (hyphen)
2. From A-Z (en dash)
3. Oh — there’s a dash. (em dash)
4. 2% —y? = 22 (minus sign)

3.8.2. Hyphenation

Words aren’t hyphenated within [yX but automatically in the output. Hyphenation
is done by the ¥ TEX-package babel following the rules of the document language!.

KETEX hyphenates nearly perfectly, it has only problems with text in the font type-
writer and with unusual constructs, like “h3knix/mOnOwall”. If I¥TEX can’t break
a word correctly, you can set hyphenation points manually. This is done with the
menu Insert > Formatting > Hyphenation Point. These extra hyphenation points are only
recommendations to IXTEX. If no hyphenation is necessary, IXTEX will ignore them.

Sometimes you want to prevent words or constructs to be hyphenated. The key-
bindings/shortcuts in this document consists of three letters with a hyphen and a
space in the form “A-b ¢”. BTEX finds there the hyphen “-” as hyphenation possibil-
ity. Hyphenating at this point would look ugly. To prevent the shortcut from being
hyphenated, we can put it in the argument of the IXTEX-box-command \mbox, be-
cause text within IXTEX-boxes can’t be hyphenated. As IxX doesn’t support \mbox,
we have to use ERT. The result looks in IyX like:

wbox{ A-bc }

To learn more about ERT, have a look at section 6.9.

3.8.3. Punctuation Marks
3.8.3.1. Abbreviations and End of Sentence

When IyX calls BTEX to generate the final version of your document, KITEX au-
tomatically distinguishes between words, sentences, and abbreviations. KIEX then
adds the “appropriate amount of space”. That means sentences get a little bit more
space between the period and the next word. Abbreviations get the same amount of
space after the period as a word uses.

Unfortunately, the algorithm for figuring out what’s an abbreviation works not for
all cases. If a “.” is at the end of a lowercase letter, it’s the end of a sentence; if it’s
at the end of a capitalized letter, it’s an abbreviation.

Here are some examples of correct abbreviations and the end of a sentence:

14For German readers: That’s one of the main differences between the languages German and
German (new spelling) in the Document > Settings dialog.
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o M. Butterfly

e Don’t worry. Be happy.
And here’s an example of the algorithm going wrong:

e e. g. this is too much space!

e This is I. It’s okay.

You won’t see anything wrong until you view a final version of your document.
To fix this problem, use one of the following:

1. Use an Inter-word Space after lowercase abbreviations (see section 3.5.6.1).
2. Use a Thin Space between two tokens of an abbreviation (see section 3.5.6.3).

3. Use an End of sentence period found under the Insert > Special Character menu to
force the use of inter-sentence spacing. This function is also bound to C-period
for easy access.

With the corrections, our earlier examples look like this:

e e.g. this is too much space!

o This is [. It’s okay.

Some languages don’t use extra spacing between sentences. If your language is such
a language, you don’t need to worry, because the IXTEX will care about this.

For those that do need to bother, there is help to catch those sneaky errors: check
out the Tools> Check TEX feature described in section Checking TEpX of the Extended
Features manual.

3.8.3.2. Quotes

[yX usually sets quotes correctly. Specifically, it will use an opening quote at the
beginning of quoted text, and use a closing quote at the end. For example, “open
close”. The keyboard character, ", generates this automatically.

You can change the behavior of the " key using the submenu Language of the dialog
Document > Settings dialog.

You can also select quotes for different languages in the box Type option. There
are six choices:

“Text"” Use quotes like this “double” or ‘single’
"Text" Use quotes like "this” or 'this’
. lext” Use quotes like ,,this“ or ,this’
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. lext” Use quotes like ,,this” or ,this’
«Texty Use quotes like «this» or «this»
» Text« Use quotes like »this« or »this¢

These settings affects what character the " key produces.

3.8.4. Ligatures

It is standard typesetting practice to group certain letters together and print them
as single characters. These groups are known as ligatures. Since IXTEX knows about
ligatures, your documents will contain them too in the output. Here are the standard
ligatures:

o ff

o fil

Some languages uses other ligatures if the document font supports them.

Sometimes, you don’t want a ligature in a word. While a ligature may be okay in
the word, “graffiti,” it looks really weird in compound words, such as “cufflink” or
the German “Dorffest.” To break a ligature, use Insert>Formatting> Ligature Break.
This changes “cufflinks” to “cufflinks” and “Dorffest” to “Dorffest”.

3.8.5. LyX’s Proper Names

You have surely noticed, that the word “ITEX” appears always with characters in
different size and height. KTEX is the name of the program used by LyX and is
therefore recognized as proper name when you type it in [yX as “LaTeX”. Note the
order of the upper-and lowercase letters! Ly X recognizes the following proper names:

LyX The name of the game, write “LyX” to produce it.
TEX The program used by KIEX, write “TeX” to produce it.
BTEX The program used by IyX, write “LaTeX” to produce it.

BTEX 2¢ The actual version of IXTEX, write “LaTeX2e” to produce it.
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You might wonder why the ITEX-version is “2¢”. It’s an old tradition in the TEX-
world to give programs geek version numbers. For example the version number of
TEX converges to the number m: The actual version is “TEX-3.141592”, the previous
one was “TEX-3.14159".

If you don’t want to use proper names, e.g. in section headings, you can insert two

empty braces in ERT in the word. This will look in [yX like: &1 11 EX

For more about ERT, look at section 6.9.

3.8.6. Units

Generally the space between units and the number is smaller than the normal space
between two words. As you can see in the example below, it looks better when the
space is smaller. To get such a “half space” for units use the menu Insert > Formatting >
Thin Space (shortcut C-S-Space).
Here’s an example to show the differences:
24 kW-h space between number and unit
24kW-h half space between number and unit

3.8.7. Widows and Orphans

In the early days of word processors, page breaks went wherever the page happened
to end. There was no regard for what was actually going on in the text. You may
remember once printing out a document, only to find the heading for a new section
printed at the very bottom of the page, the first line of a new paragraph all alone at
the bottom of a page, or the last line of a paragraph at the top of a new page. These
dangly-bits of text became known as widows and orphans.

Clearly, IyX can avoid breaking pages after a section heading. That’s part of the
advantage of paragraph environments. But what about widows and orphans, where
the page breaks leave one line of a paragraph all alone at the top or bottom of a page?
There are rules built into KTEX governing page breaks, and some of those rules are
there to specifically prevent widows and orphans. This is the advantage [yX has in
using IXTEX as its backend.

There’s no way we can go into how TEX and IXTEX decide to break a page, or how
you can tweak that behavior. Some IXTEX books listed in the bibliography [such as [1]
or [2]] may have more information. You will almost never need to worry about this,
however.
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4. Notes, Graphics, Tables, and
Floats

The issues of this chapter are described in detail in the Embedded Objects manual.
There you’ll also find tips and tricks for special cases.

4.1. Notes

Ly X offers you a few types of notes to add to your document:

LyX Note This note type is for internal notes that won’t appear in the output.

Comment This note also doesn’t appear in the output but it appears as IXTEX-
comment, when you export the document to KTEX via the menu File> Export >

KTEX (pdflatex) / (plain).

Greyed Out This note will appear in the output as grey text.
This is text! of a comment that appears in the output as grey text.

As you can see in the example, the first line of greyed out notes is a bit in-
dented and greyed out notes can have footnotes.

Framed This note will appear in the output as framed text.

This is text in a note box that appears framed in the output.

In contrary to framed boxes like the one in section 6.9.1, the frame uses always
the whole text width and the note is set into its own paragraph.

Shaded This note will appear in the output with red background color.

IThis is an example footnote within a greyed out note. In this document the greyed out note color
is redefined to blue. How this can be done is explained in the Embedded Objects manual.
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In contrary to colored boxes, the note uses always the whole text width and the
note is set into its own paragraph.

Notes are inserted with the toolbar button or the menu Insert>Note. Right-click
on the appearing note box to select the note type.

4.2. Footnotes

LyX uses boxes to display footnotes: When you insert a footnote using the menu

Insert > Footnote or the toolbar button IE, you’ll see the following box: foot . This

box is LiyX’s representation of your footnote. If you left-click on the “foot” label,
the box will be opened and you can enter the footnote text into it. Clicking on the
box label again, will close the box. If you want to turn existing text into a footnote,
simply mark it and click on the footnote toolbar button.

Here’s an example footnote:?

The footnote will appear in the output as a superscript number at the text position
where the footnote box is placed. The footnote text is placed at the bottom of the
current page. The footnote number is calculated by Ly X, the numbers are consecutive,
no matter in which chapter the footnote is in. IyX doesn’t support other numbering
schemes yet, but you can get another scheme using special IXTEX-commands. They
are described in the Embedded Objects manual.

4.3. Marginal Notes

Marginal notes look and behave just like footnotes in IyX. When you insert a mar-

gin note via the menu Insert>Marginal Note or the toolbar button = [ you’ll see a
grey box with a red label “margin” appearing within your text. This box is LyX’s
representation of your marginal note.

This is a At the side is an example marginal note.
marginal Marginal notes appear at the right side in single-sided documents. In double-sided
note. documents they appear in the outer margin — left on even pages, right on odd pages.

2To close a footnote, click on the red box at the top left.
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4.4. Graphics and Images

To insert an image in your document, place the cursor at the text position you want

and click on the toolbar icon E or select Insert> Graphics from the menu. Then a
dialog will appear to choose the file to load.

This dialog has numerous mostly self-explanatory parameters. The Graphics tab
allows you to choose your image file. The appearance of the image inside IxX and
in the output is adjusted separately. The image can be transformed by setting a
rotation angle and a scaling factor. The scaling units are explained in Appendix C.

In the tab Clipping it is possible to set image coordinates to adjust the height and
width of the image in the output. The coordinates can also be calculated automati-
cally by pressing the button Get from file. The option Clip to bounding box will only
print the image region within the given coordinates. Normally you don’t need to take
care about image coordinates and can ignore the tab Clipping.

ETEX experts can specify additional IXTEX options in the Extras tab. You can
also set the Subfigure option here if the image is inside a figure float. This option
is explained in section 4.6.1.1. The option Draft mode effects that the image don’t
appear in the output, only a frame with the image size is printed.

The graphics dialog can be called at any time by right-clicking on an image. The
image will appear in the output exactly at the position where it is in the text. This
is an example image in the PDF format within a separate, horizontally centered
paragraph:

If you need image captions and want to reference images, you have to put the image
into a float, see section 4.6.1.1.

4.4.1. Image Formats

You can insert images in any known file format. But as we explained in section 3.7.2,

every output document format allows only a few image formats. X uses therefore

the program Imagemagick in the background to convert the images to the right

format. To increase your workflow by avoiding these conversions in the background,

you can use only the image formats listed in the subsections of section 3.7.2.
Similar to fonts there are two types of image formats:
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Bitmap images consist of pixel values, often in a compressed form. They are there-
fore not fully scalable and look pixeled in large zooms. Well-known bitmap
image formats are “Graphics Interchange Format” (GIF, file extension “.gif”),
“Portable Network Graphics” (PNG, file extension “.png”), and “Joint Photo-
graphic Experts Group” (JPG, file extension “. jpg” or “. jpeg”).

Scalable images consist of vectors and can therefore be scaled to any size without

data loss. The scaling ability is necessary if you want to create presentations,
because presentations are always scaled by the beamer. Scaling is also useful
for online documents to let the user zoom into diagrams.
Scalable image formats can be “Scalable Vector Graphics” (SVG, file extension
“.svg”), “Encapsulated PostScript” (EPS, file extension “.eps”), and “Portable
Document Format” (PDF, file extension “.pdf”). We say it can be, because
you can convert any bitmap image format to PDF or EPS and the result won’t
be scalable. In this cases only a header with the image properties is added to
the original image?.

Normally one can’t convert a bitmap image into a scalable one, only vice versa.

4.5. Tables
B

You can insert a table using either the toolbar button ™= or the menu Insert> Table.
A dialog will appear, asking you for the number of rows and columns. The default
table has lines around any cell and the first row appears separated from the rest of
the table. This separation appears due to a double line: The cells of the first row
have a line below them and the cells of the second row have a line above them. Here’s
an example table:

| [1]2]3]

A
B
C

4.5.1. The Table dialog

You can alter a table by clicking on it with the right mouse button, which brings
up the table dialog. Here you can adjust the settings of the cell and row/column
respectively where the cursor is placed currently. Most of the dialog options also
work on selections. This means that if you select more cells, columns or rows the
action is done on all of your selection.

Additionally to the table dialog the table toolbar, that appears when the cursor is
inside a table, helps you in setting table properties. It is for example currently only
possible to add / delete lines via the table toolbar.

3In the case of PDF, the original image is additionally compressed.
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In the tab Table Settings of the table dialog you can set the alignment for the
current row. If you add a row or column, it will be inserted right beside or below the
current cell respectively. The vertical alignment of a column can only be adjusted
when a column width is given. A given width will allow the cell to have linebreaks
and multiple paragraphs of text, see section 4.5.3.

You can mark multiple cells of one row as a multicolumn cell using the check box
Multicolumn. This will merge the cells to one cell, spread over more than one column.
Multicolumn cells are treated as own rows, so that the alignment, width, and border
settings affect only the multicolumn cell. Here’s an example table with a multicolumn
cell in the first row and one in the last row without the upper border:

\ abc \ def ghi \ jkl \
A |B|C|D
1 21 3 4

At the moment LyX doesn’t support multirow cells. Adept users can declare special
ETEX-arguments for the table. They are necessary for special table formatting, like
for multirow cells, explained in the tables section of the Fxtended Features manual.
You can also rotate the current cell or the whole table 90 degrees counterclockwise.
These rotations are not visible in LyX but in the output.

Note: Most DVI-viewers are not able to display rotations.

The Borders tab allows you to add and delete border lines for the current row/column.
The button Default adds lines for all cell borders.

4.5.2. Longtables

If the table is too long to fit on one page, you can use the option Use long table in
the tab Longtable of the table dialog to split the table automatically over more pages.
Doing this enables some check boxes and you can now define:

Header: The current row and all rows above, that don’t have any special options
defined, are defined to be the header rows of all pages of the longtable; except
for the first page, if First header is defined.

First header: The current row and all rows above, that don’t have any special options
defined, are defined to be the header rows of the first page of the longtable.

Footer: The current row and all rows below, that don’t have any special options
defined, are defined to be the footer rows of all pages of the longtable; except
for the last page, if Last footer is defined.

Last footer: The current row and all rows below, that don’t have any special options
defined, are defined to be the footer rows of the last page of the longtable.
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You can also specify a row where the table is splitted. If you set more than one option
in the same table row, you should be aware of the fact that only the first one is used
in the given table row. The others will then be defined as empty. In this context, first
means first in this order: Footer, Last footer, Header, First header. See the following

longtable to see how it works:

Example Phone List (ignore the names)

NAME TEL.
Annovi Silvia 111
Bertoli Stefano 111
Bozzi Walter 111
Cachia Maria 111
Cachia Maurizio 111
Cinquemani Giusi 111
Colin Bernard 111
Concli Gianfranco 111
Dal Bosco Carolina 111
Dalpiaz Annamaria 111
Feliciello Domenico 111
Focarelli Paola 111
Galletti Oreste 111
Gasparini Franca 111
Rizzardi Paola 111
Lassini Giancarlo 111
Malfatti Luciano 111
Malfatti Valeriano 111
Meneguzzo Roberto 111
Mezzadra Roberto 111
Pirpamer Erich 111
Pochiesa Paolo 111, 222
Radina Claudio 111
Stuffer Oskar 111
Tacchelli Ugo 111
Tezzele Margit 111
Unterkalmsteiner Frieda 111
Vieider Hilde 111
Vigna Jirgen 111
Weber Maurizio 111
Winkler Franz 111
Annovi Silvia 555
continue ...

60




Example Phone List
NAME TEL.
Bertoli Stefano 555
Bozzi Walter 555
Cachia Maria 555
Cachia Maurizio 555
Cinquemani Giusi 555
Colin Bernard 555
Concli Gianfranco 555
Dal Bosco Carolina 555
Dalpiaz Annamaria 555
Feliciello Domenico 555
Focarelli Paola 555
Galletti Oreste 555
Gasparini Franca 555
Rizzardi Paola 555
Lassini Giancarlo 555
Malfatti Luciano 555
Malfatti Valeriano 555
Meneguzzo Roberto 555
Mezzadra Roberto 555
Pirpamer Erich 555
Pochiesa Paolo 5b5, 222
Radina Claudio 555
Stuffer Oskar 555
Tacchelli Ugo 555
Tezzele Margit 555
Unterkalmsteiner Frieda 555
Vieider Hilde 555
Vigna Jirgen 999
Weber Maurizio 555
Winkler Franz 555
End

4.5. Tables

4.5.3. Table Cells

A table cell can contain text, inline equations, a figure, or another table. All these
kinds of objects can be placed in the same cell. Font sizes and shapes can also be
altered. But you can’t put a special environment in a cell (like Section*, etc.), nor
set spacing options etc. for the cell’s paragraph.

To have multi-line entries in table cells, you have to declare a fixed width for the
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column in the table dialog. Your text is then automatically split into multiple lines
and the cell is enlarged vertically when the length of the text exceeds the given width.
An example:

1 2 3
This is a multi- | 5
line entry in a
table.

6 | This is longer | 7
now.
8 | This is a multi- | 9
line entry in a
table.  This is
longer now.

Cutting and pasting between tables and table cells works reasonably well. You can
cut and paste even more than one row. Selection with the mouse or with Shift plus
the arrow keys works as usual. You can also copy and paste the entire table as a
single unit by starting the selection from outside the table.

4.6. Floats

A float is a block of text associated with some sort of label, which doesn’t have a
fixed location. It can “float” forward or backward a page or two, to wherever it fits
best. Footnotes and Margin Notes are also floats, because they can float to the next
page when there are too much notes at the page.

Floats makes it possible to get a high quality layout. Images and tables can evenly
be spread to the pages to avoid whitespace and pages without text. As the floating
often destroys the context between the text and the image/table, every float can be
referenced in the text. Floats are therefore numbered. Referencing is described in
section 6.1.

To insert a float, use the menu Insert > Floats. A box with a caption that has e. g. the
label “Figure #:” (# is the actual number) will be inserted into your document.
The label will automatically be translated to the document language in the output.
Behind the label you can insert the caption text. The image or table is inserted
above or below the caption in a separate paragraph within the float. To keep your
LyX-document readable, you can open and close the float box by left-clicking on the

hox label. A closed float box looks like this; Do2t Figne gray button with a red
label.

It is recommended to insert floats as a separate paragraph to avoid possible KTEX-
errors that can occur when the surrounding text is specially formatted.
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Figure 4.1.: A severely distorted platypus in a float.

Figure 4.2.: M.C. Escher on acid.

4.6.1. Float Types
4.6.1.1. Figure Floats

The menu Insert > Float> Figure inserts a float with the label “Figure #:”. Set the
cursor above this label (or before it and press enter) and insert the image as described
above to get the caption printed below the image. This is what we did for Figure 4.1.
If you want the caption to be above the image, set the cursor at the end of the caption,
press enter and insert the image. This was done in Figure 4.2.

This figure float show also how to set a label and create a cross-reference to it. As
described in section 6.1, you can simply insert a label in the caption using the menu
Insert>Label and refer to it using the menu Insert> Cross-Reference. It is important
to use references to figure floats, rather than using vague references like “the figure
above”, because as ITEX will reposition the floats in the final document; it might
not be “above” at all.

Normally one inserts only one image to a figure float, but sometimes you might
want to use two images with separate subcaptions. This can be done in the graphics
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(a) Undefinable structure (b) Platypus

Figure 4.3.: Two distorted images.

Table 4.2.: A table float.

ot o2 13 ]
Joe Mary Ted
[ 2%da ‘CL Z 1+1=2

dialog: Right-click on an image and go to the tab Extra options in the appearing
dialog, use the option Subfigure, and enter the subcaption for the image in the now
enabled caption field. Figure 4.3 is an example of a figure float with two images set
side by side. You can also set the images one below the other.

Note that the caption is added to the List of Figures as described in section 6.2.2.

4.6.1.2. Table Floats

Table floats can be inserted using the menu Insert> Float> Table. They have the same
properties as figure floats except of the different label. Table 4.2 is an example of a
table float.

4.6.1.3. Algorithm Floats

This float type is inserted with the menu Insert> Float> Algorithm. It is used for
program codes and descriptions of algorithms. A possible environment for algorithms
is the LyX-Code, described in section 3.3.9.

Note: that the float label is not automatically translated into the document
language. You have to do this manually by adding the following line
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\floatname{algorithm } {your name}
to the document preamble (menu Document>Settings). your name is the word
“algorithm” in your language.

4.6.1.4. Text Wrap Floats

This float type is used if you want to “wrap” text around a figure so that it only
occupies some fraction of the column width. It can be inserted using the menu
Insert> Float>Wrap Float if the KTEX-package
wrapfig is installed.* The width and placement
of the float is adjusted by right-clicking on the
float box. Figure 4.4 is an example Text wrap
float with a width of 40col%.> Some space was
added under the caption to separate it better
from the surrounding text.

Figure 4.4.: This is a wrapped fig- The I TEX-package wrapfig also supports ta-
ure, and this is the ple wrap floats, but they are not yet supported
brilliant caption that by IxX. If you need this, read the documentation
describes it of wrapfig [12].

Note: Wrap floats might be fragile! E.g. having a figure too close to the bottom
of the page can mess things up in the way that the float doesn’t appear in the output
or that it is placed over some other text. In general:

o Wrap floats should not be placed in paragraphs that run over a page break.
That means that wrap floats should better be inserted to the exact place when
the document is nearly ready and you are able to estimate where page breaks
will appear.

o Wrap floats should either be placed in an own paragraph before the paragraph
where they should wrap into or within a paragraph.

o Wrap floats in consecutive paragraphs may cause troubles, so assure that there
is a text paragraph between them as separator.

o Wrap floats are not allowed in section headings or tables.

4.6.2. Rotated Floats

Especially for wide tables you might have floats rotated. To rotate a whole float
including the caption, right-click on the float-box and use the option Rotate sideways.

Rotated floats are always placed on its own page (or column, when you have a two-
column document). They are rotated so that you can read them from the outside
margin. Forcing the rotation direction is explained in the Embedded Objects manual.

4Installing a IXTEX-package is explained it in the BTpX Configuration manual.
5 Available units are explained in Appendix C.
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Referencing rotated floats is the same like for normal floats, the caption format is
also the same: Table 4.3 is an example of a rotated table float.
Note: Not all DVI-viewers are able to display rotated floats.

4.6.3. Float Placement

Right-clicking on a float-box opens a dialog where you can alter the placement options
that IXTEX uses for positioning the float.
The option Span columns is only useful for two-column documents: If you select it,
the float will span across both columns on the page instead of being confined to just
one.
The option Rotate sideways is used to rotate floats, see section 4.6.2.

You can use one ore more of the following options in the float dialog to set the
placement for a particular float when you uncheck the option Use default placement:

Here if possible: try to place the float on the position where it is inserted
Top of page: try to place the float on the top of the current page
Bottom of page: try to place the float on the bottom of the current page

Page of floats: try to place the float on an own page

The order of the above option is always used by IXTEX. That means, if you use the
default placement, IXTEX will first try out Here if possible, then Top of page, and then
the others. If you don’t use the default, B'TEX will try only the checked options but
in the same order. If none of the 4 placements are possible the procedure is internally
repeated but it is tried to put the float on the following page.

By default, each options has its own rules:

Top of page only floats occupying less than 70 % of the page can be placed at the
top of a page

Bottom of page: only floats occupying less than 30 % of the page can be placed at
the bottom of a page.

Page of floats: only if more than 50 % of the page are occupied by floats, several
floats can be set together on a page.

If you don’t like these rules, you can ignore them by using the additional option
Ignore IXTEX rules.

Sometimes you might need, under all circumstances, a float to be placed exactly at
the position where it is inserted. For this case you can use the option Here definitely.
Use this option very rarely and only if the document is nearly ready to be printed.
Because the float is then no longer able to “float” when you change your document
and this will often destroy the page layout.

There are no placement options for text wrap floats, because they are always sur-
rounded by the text of a certain paragraph.

For more details about float placements, have a look at BTEX books like [1, 2, 3].
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4.7. Minipages

KETEX provides a mechanism to produce essentially a page within a page, called mini-
page. Within a minipage, all the usual rules of indentation, line wrapping, etc. apply.

Minipages in [yX have their own collapsible box inserted via the menu Insert>
Box. Right-clicking on the box allows you to alter the width of the minipage and its
alignment within the page.

This is a minipage. The
text is set in an italic
style.

Minipages are often used
for text in another lan-
guage or text that needs
another formatting.

If you place two minipages side-by-side, you can use Horizontal Fills as described in
section 3.5.1:

This is a minipage This is a minipage
with some stupid with some stupid
dummy text. This dummy text. This
dummy text is used dummy text is used
to increase the size to increase the size
of the minipage. of the minipage.

When you right-click on a minipage box, you can change the box from a minipage
to other box types. All box types and their settings are explained in detail in chapter
Bozxes of the Embedded Objects manual.
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The issues of this chapter are described in detail in the Math manual. There you’ll
also find tips and tricks for special cases.

5.1. Basic Math Editing

a+b
To create a math formula, you can just click on the toolbar icon € . That will create

a little blue rectangle, with purple markers around its corners. That blue rectangle
is the formula itself; the purple markers indicate what level of nesting within the
formula you are at. You can also choose a particular formula type to insert via the
Insert>Math menu.

Editing the parameters of a formula and adding math constructs can be done with
the math toolbar, that appears when the cursor is in a formula.

There are two main types of formulas: Inline formulas appear within a text line,
like this one:

This is a line with an inline formula A = B in it.

Displayed formulas appear outside the text like as they were in an own paragraph,
like this one:

A=DB

You can only number and reference displayed formulas.

LyX supports also many KTEX math commands. E.g. typing “\alpha”, followed
by a space, in a formula will create the Greek letter a. So typing commands might
sometimes be faster than using the Math Panel.

5.1.1. Navigating in Formulas

The best control over the cursor position within an existing formula is achieved with
the arrow keys. LyX uses small rectangles to indicate places where something can
be inserted. The arrow keys can be used to navigate between parts of a formula.
Pressing Space will leave a formula construct (a square root V/2, or parentheses (f),

or a matrix . Pressing Escape will leave the formula, placing the cursor after

1 2

3 4 )
the formula. Tab can be used to move horizontally in a formula; for example, through
the cells of a matrix or the positions in a multi-line equation.

Space, printed in this document as “ ", seems to do nothing in a formula, since it
does not add a space between characters, but it does exit a nested structure. For this
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reason, you have to be careful about using Space. For example, if you want /2x + 1,
type \sqrt ,2x+1 and not \sqrt ,2x,,+1, since in the latter case only the 2z will
be under the square root sign: v/2z + 1.

You can leave many parts of a formula, like this matrix, partially filled in, such as:

A1

An

If you leave a fraction only partially filled in, or a subscript with nothing in it, the
results will be unpredictable, but most constructs don’t mind.

5.1.2. Selecting Text

You can select text within a formula in two different ways. Place the cursor at one
end of the string of text you want, and press Shift and a cursor movement key to
select text. It will be highlighted as with regular text selection. Alternatively, you
can select text with the mouse in the usual way. That text can then be cut or copied,
and then pasted within any formula, but not in a normal text region in [yX.

5.1.3. Exponents and Subscripts

You can use the math panel to add super- or subscripts, but the much easier way
is to use a command. To get 22, type in a formula x~ 2. The final Space puts the
cursor back down on the base line of the expression. If you type x~ 2y, you will get
%Y, to get 2y, type X 2_y. If you use characters in the superscript, that could be
accented with the hat “~”, you have to use an extra Space to separate the hat and
the character. E.g. if you want x%, type x _a. Subscripts are similar: To get aq,
type a_ 1.

5.1.4. Fractions

a
Create a fraction with either the command \ frac or using the icon b in the Math Panel.
You will be presented with an empty fraction. The cursor is above the fraction line.
To move it to the bottom, simply press Down. To move back up, press Up. Any math
structure can be placed in a fraction, as this example shows:
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5.1.5. Roots

Roots can be created using the Math Panel button¥O or the commands \sqrt or
\root. With the command \root you can produce roots of higher orders, like cube
roots, while \sqrt produces always a square root.

5.1.6. Operators with Limits

Sum (3°) and integral () operators are very often decorated with limits. These limits
can be entered in IyX by entering them as you would enter a super- or subscript,
directly after the symbol. The sum operator will automatically place its “limits” over
and under the symbol in displayed formulas, and on the side in inline formulas. Such
as Yol % = e, Versus

<1

)

—n!
Integral signs, however, will place the limits on the side in both formula types.

All operators with limits will be automatically re-sized when placed in display
mode. The placement of the limits can be changed by placing the cursor directly
behind the operator and hitting M-m | or using the menu Edit>Math > Change Lim-
its Type.

Certain other mathematical expressions have this “moving limits” feature as addi-
tion, such as

lim f(z),

which will place the x — oo underneath the “lim” in display mode. In inline formulas
it looks like this: lim, .., f(x).

Note that the lim-function was entered as the function macro \lim. Have a look
at section 5.1.9 for an explanation of function macros.

5.1.7. Math Symbols

Most math symbols can be found in the Math Panel under one of several categories;
including Greek, Operators , Relations, Arrows. There are also the additional symbols
provided by the American Mathematical Society (AMS).

If you know the BIEX-command for a construct or symbol you wish to use, you
don’t have to use the Math Panel, but can type the command directly into the formula.
LyX will convert it to the corresponding symbol or construct.

5.1.8. Altering Spacing
You may want to create spaces that differs from the standard spacing that IXTEX

provides. To do this, type C-Space or to use the Math Panel button ™*. This
generates a small space, and shows a small marker on the screen. Here a example for
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Table 5.1.: Accent names and the corresponding commands.

‘ Name ‘ Command ‘ Example ‘

circumflex \hat a
grave \grave a
acute \acute a
umlaut \ddot a
tilde \tilde a
dot \dot a
breve \breve a
caron \ check a
macron \bar a
vector \vec a

the sequence a C-Space b: ab (appears in LyX as ol ). You can change the space
to different sizes when you set the cursor behind the space marker and hit space again
several times. With every space hit the size will be changed. Some markers for the
space size appear red in IyX, because they are a negative spaces. Here two examples:
a C-Space b and 3xSpace: a b
a C-Space b and 5xSpace:

5.1.9. Functions

BXP
The Math Panel contains under the button tati a number of functions, such as sin,

lim, etc. (you can also insert them in a formula by typing \sin etc.). Standard math-
ematical practice is, that functions are printed upright to avoid confusions, because
stn does normally mean stitin.

Using the function macros will also produce correct spacing around the function:
asin z is different from asinx

For some mathematical objects, like the limes, the macro changes the way that
subscripts are placed, like described in section 5.1.6.

5.1.10. Accents

In a formula you can insert accented characters in the same way as in text mode.
This may depend on your keyboard, or the bindings file you use. You can also use
KTEX commands to e.g. enter @ even if your keyboard doesn’t have hat-accents
enabled. Our example is entered by typing \hat a in a formula. Table 5.1 shows
the equivalences between the accent names and the commands.

You can choose one of the accents by selecting an item from the Frame decorations

symbol set button i..i in the math panel ; this will apply to any selection you have
made within a formula too.
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5.2. Brackets and Delimiters

There are several brackets available through IyX. For most purposes, using just
the keys [1{} (O |<> should suffice. But if you want to surround a large structure,
like a matrix or a fraction, or if you have several layers of brackets, is better using

Math Panel’s delimiter icon [u] For example, that’s how you would construct the
brackets around a standard matrix such as:

5 i)

and to make it easier to see the layers of parentheses as in:

1
1+ (wm))

The parentheses, and other brackets from that menu will automatically re-size to
accommodate the size of what is inside.

To construct brackets click on the button for the bracket you want on the left side
and right side. If you use the option Keep matched, the selected bracket type will be
used for the left and the right side. The selection will be shown below the button
field. If you want one side to not have a bracket, use the blank button. It will appear
in LyX with a dotted line, but nothing will be printed.

If you want to place brackets around math structures, like a square root, you can do
that by highlighting (selecting) the structure that is to go inside the brackets. Then
choose the appropriate brackets for left and right and click on Insert. The parentheses
will be drawn around the selected structure.

The next section explains how to insert a KTEX “{” for grouping.

5.3. Grouping

You may need to group a set of symbols. In BTEX, for example, the typesetting of
{x~y}~z is different from x~{y~z}:

. z
z¥*  differs from Y

To create this grouping, you need to use the key sequence “\{” then type space.
Inside IyX, you will see red braces indicating the grouping. Within this braces you
insert the grouped structure. The grouping braces won’t appear in the output in
contrary to normal braces.
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5.4. Arrays and Multi-line Equations

=]
Matrices are entered in LyX using the Math Panel matrix button B8 Tt will open a

dialog for you to choose the number of rows/columns. Here is an example:

N S

2
D
8

O O W

The parentheses aren’t automatic, but you can add them as described in section 5.2.
When you construct the matrix, you can decide whether the column entries will be
left-, right-, or center-justified. This alignment is set in the box Horizontal with the
letters “1”, “r”, and “c”. LyX proposes a “c” for every column as default. For example,
the sequence “Irc” means that the first column will be left-justified, the second will be
centered, and the third column will be right-justified, because each letter corresponds
to the relevant column. The result will look like this:

this this column this column
column has hasright .
hasleftalignment center alignment  alignment

You can add more rows to an existing matrix by hitting C-Enter while the cursor
is in the matrix. Adding or deleting columns can be done via the menu Edit>Math.

There are other arrays used in formulas, such as distinctions of cases. It can be
created with the menu Insert>Math>Cases Environment or the command \cases.
Here an example:

-1 <0
flx)=350 2=0
1 x>0

Multi-line formulas are created when you press C-Enter within a formula. In an
empty formula you can see that three blue boxes appear, one for each column. When
you press C-Enter in a non-empty formula, the part before the relation sign (equal
sign “=" etc.) will be inserted automatically to the first column, the relation sign
is in the second column, and the rest in the third column. A new row is created by
every further hit of C-Enter. Multi-line formulas are always displayed formulas. Here

is an example:

a2 — <b2 +62)(b2 . 02)
a = Vbt—ct (5.1)
To change the column assignment of the formula parts, place the cursor where you

want to start the shift and hit C-Tab. It shifts everything in the column which is
right beside the current cursor position to the next column. Note that the middle
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column is designed for relation signs, structures within this column will be printed in
a smaller size:

A

B

a4
B B

The multi-line formula type described here is called eqnarray. There are other
multi-line types being more suitable for certain situations, for example if you want
a better inter-line spacing than in formula (5.1). The other types are described in

section 5.8.2.

5.5. Formula Numbering and Referencing

To number a formula, set the cursor in the formula and use the menu Edit>Mathr
Toggle Numbering or the shortcut M-m n. The formula number appears in LyX
as “#”7 within parentheses. The "#” denotes, that the number will be calculated
automatically when the output is generated. The placement and format of the formula
number in the output depends on the document class. In this document the number
is printed together with the chapter number, separated by a dot:

1+1=2 (5.2)

Using M-m n in a numbered formula will switch off the numbering. You can only
number displayed formulas.

Multi-line formulas can be numbered line by line: Using the menu Edit>Math>
Toggle Numbering of Line or the shortcut M-m N will only toggle the numbering of
the line where the cursor is in:

1 = 3-2 (5.3)

IN
~J

(5.4)
To number all lines use the shortcut M-m n.

Every displayed formula can be referenced by its number using a label. A label is
inserted with the menu Insert> Label when the cursor is in the formula. This opens a
dialog to enter the label. It is recommended to use the proposed “eq:” as first part
of the label, because this helps later to identify the label type when you have many
labels in your document. We inserted in the following example the label “eq:tanhExp”
in the second line:

sinh(z)
cosh(x)
e?® — 1

e2w+1

tanh(z) =
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Every labeled line is automatically numbered. Therefore the label is shown in IyX
at the place of the formula number placeholder “#”. You can reference a labeled
formula using the menu Insert>Cross Reference. A dialog appears to choose a label
you want refer to. The reference appears in LyX as grey cross reference box and in
the output as the formula number:

This is a cross-reference to equation (5.5).

The properties of LyX’s cross-reference box are described in section 6.1. To delete
a label, set the cursor in the labeled formula, use the menu Insert>Label and delete
the label in the appearing dialog.!

5.6. User defined math macros

LyX allows you to define macros for formulas. For example we assume that solutions
of the quadratic equation often occur in our document in various forms and we want
to create a macro to print them.

The general form of a quadratic equation is:

0=X+pA+gq

The general form of its solution is:

P [P
Alg = 5 + 1 q

The macro should print the parameters A\, p and ¢ like in the equation above.

A macro is created by executing the command

math-macro_Name Number of Arguments

in the minibuffer at the bottom of the LyX screen. Name is the name of the new
macro which mustn’t contain numbers. The number of arguments can be a number
in the range 1-9. If you want to define a macro without arguments, don’t declare the
number of arguments.

We have three arguments and name the macro “qE”, so that the command is:

math-macro, qE, 3

This results in the following macro definition box: Macro: qE' E”El

The first blue box is for the definition, where you insert the formula via the math
panel or commands. The placeholder for the arguments are inserted as a backslash
and sharp followed by the argument number, e.g. “\#1” for the first argument.
Placeholders will be displayed in red. The second blue box is for the appearance in
LyX. This is useful when you have a large structure that shouldn’t be displayed in
LyX with its full size. If you want to see the macro as it is defined, leave the box
blank. In our example we insert the sequence

1This is a unintuitive and will be fixed in the next version of LyX.
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qE: \#1 , \#2 , \#3

The macro will then be shown as the macro name followed by the three arguments.
To use the macro in a formula, type its name as command, in our case “\qE”. The

macro is inserted with boxes for the arguments looking similar to this:

qE oF: #1 , #2 , #3
410
401
43

The arguments are inserted in the blue boxes. If the cursor is outside the macro,
the arguments are put in the macro. To change the arguments, put the cursor in the
formula before or after the macro and press the right or left arrow key respectively.
The arguments appear now again below the macro definition.

If you change the macro definition all macros are changed automatically to the new
definition. Here an example of our macro with the arguments z, In(z), and B:

In(y)
+
9 4

X1,2 = —

When the document is exported to IXTEX, the macro definition will be inserted as
the command:

\newcommand{\qE}[3]{#1_{1,\,2}=-\frac{#2}{2}\pm

\saqrt{\frac{#27{2} }{4}-#3}}

The command is not inserted in the document preamble. That means you can only
use macros in formulas that are below the macro definition box in your document.
There are also some other restrictions: The command \newcommand supports op-
tional arguments, which are not available in IyX’s macros. You can also not change
subsequently the name of the macro and the number of arguments.

5.7. Fine-Tuning

5.7.1. Typefaces

The standard font for text is italic, for numbers the standard is roman. To set a
A7
font in a formula, use the Math Panel button FFL, or enter its command, listed in

table 5.2, directly.
Note: that you can only print capital letters in the typefaces Blackbold and
Calligraphic.
When you use a typeface, a blue box is inserted in the formula. Every character in
this box will be printed in this typeface. Pressing Space within the box, will set the
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Table 5.2.: Typefaces and the corresponding commands.

‘ Font ‘ Command ‘
Roman \mathrm
Bold \mathbf
Italic \mathit
Typewriter \mathtt
BLACKBOARD \mathbb
Sraktur \mathfrak
CALLIGRAPHIC | \mathcal
SansSerif \mathsf

cursor outside, so that you have to use a protected space when you need a space in
the box. Here an example where a “N” in Blackbold denotes the set of numbers:

fl)=Va;2eN

The typefaces are nestable, which can cause confusion. You can e.g. put a character
in Fraktur in a box for Typewriter: abcde
So better don’t use this feature.

The typefaces have no effect on Greek letters: abcde
You can only print them emboldened using the command \boldsymbol, which works
like the other typeface commands: afBvyaB~y

\boldsymbol works for all symbols, letters, and numbers.

A number of other font options are available as well, in the menu Insert>Math>
Font Change.

5.7.2. Math Text

Typefaces are useful for entering some characters in some given font, but not for text.

For typing longer pieces of text use the math text, which is obtained using the entry
A~
Normal text mode of the Math Panel button Fifi (alternatively the shortcut M-m m).

Math text appears in IxX in black instead of blue. You can use spaces and accents
in math text like in normal text. Here is an example:

fla) = {x if I say so

—z unter Umstanden

5.7.3. Font Sizes

There are four font styles (relative sizes) used in math-mode, which are automat-
ically chosen in most situations. These are called textstyle, displaystyle, scriptstyle,
and scriptscriptstyle. For most characters, textstyle and displaystyle are actually the
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same size, but fractions, superscripts and subscripts, and certain other structures,
are set larger in displaystyle. Except for some operators, which resize themselves to
accommodate various situations, all text will be set in the styles as IXTEX thinks is

o
appropriate. These choices can be overridden by using the math panel button Zﬂ.
A box for the size will be created in which you can insert the math structure. For
3
four styles are used in the following example:

displaystyle, textstyle, scriptstyle, scriptscriptstyle.

All these math-mode font sizes are relative, that means, if the whole math inset is
set in a particular size with the menu Edit> Text Style, all sizes in the formula will
be adjusted relative to this size. Similarly, if the base font size of the document is
changed, all fonts will be adjusted to correspond. As example a formula in the font

size “largest”:

00
€ =220

1
example, you can set =, which is normally in textstyle, larger in displaystyle: 3 The

1
n!

5.8. AMS-BETEX

Ly X supports the packages provided by the American Mathematical Society (AMS)
that are in common use.

5.8.1. Enabling AMS-Support

Selecting the checkbox Use AMS math package in the Document > Settings dialog under
Math Options will include the AMS-packages in the document, and make the facilities
available. AMS is needed for many math-constructs, so when you get KTEX-errors in
formulas, assure that you have enabled AMS.

5.8.2. AMS-Formula Types

AMS-IXTEX provides a selection of different formula types. IyX allows you to choose
between align, alignat, flalign, gather, and multline. We refer to the AMS-
documentation for an explanation of these formula types.
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6.1. Cross-References

One of LyX’s strengths are cross-references. You can reference every section, float,
footnote, formula, and list in the document. To reference a document part, you have
to insert a label into it. The label is used as anchor and name for the reference. We
want for example refer to the the second item of the following list:

1. First item
2. Second item
3. Third item

First we insert a label into the second item with the menu Insert>Label or the by

pressing the toolbar button @ A grey label box like this: iy Lt is inserted

and the label window pops up asking for the label text. LyX offers as text the first
words of the item with a prefix, in our case the text “enu: Second-item”. The prefix
“enu:” stands for “enumerate”. The prefix depends on the document part where the
label is inserted, e.g. if you insert a label to a section heading, the prefix will be

To reference the item, we refer to its label using the menu Insert> Cross-Reference

Ref’ sec:Contrib
or the toolbar button tﬂ A grey cross-reference box like this: =k SECEH is

inserted and the cross-reference window appear showing all labels of the document.
We can now sort the labels alphabetically and then choose the entry “enu:Second-
item”. At the position of the cross-reference box the item number will appear in the
output. Here is our cross-reference:

Item 2

It is recommended to use a protected space! between the cross-reference name and
its number to avoid ugly linebreaks between them.

There are six varieties of cross-references:

<reference>: prints the float number, this is the default: 4.3

(<reference>): prints the float number within two parentheses, this is the style nor-
mally used to reference formulas, especially when the reference name “Equation”
is omitted: (5.5)

ldescribed in section 3.5.6.2
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<page>: prints the page number: Page 64
on page <page>: prints the text "on page' and the page number: on page 64

<reference> on page <page>: prints the float number, the text "on page', and
the page number: 4.3 on page 64

Formatted reference: prints a self defined cross-reference format.
Note: This feature is only available when you have the KTEX-package pret-
tyref installed.

Note that the style <page> won’t print the page number if the label is on the previous,
the same, or the next page. You will e. g. see the text “on this page” instead.

The number and current page of the referred document part in the output, is
automatically calculated by IXTEX. The varieties are adjusted in the field Format of
the cross-reference window, that appear when you click on the cross-reference box.

You can only use the style <reference> to reference numbered document parts,
while the reference style <page> is always possible.

If you want to reference a section, put the label in the section heading, to reference
a float, put the label in the caption. For footnotes you can put the label somewhere
in it. Referencing formulas is explained in section 5.5.

The button Go to Label in the cross-reference window sets the the cursor before the
referred label. The button text changes then to Go Back and you can use it to set the
cursor back to the cross-reference. Right-clicking on a cross-reference box also sets
the cursor before the referred label but without a possibility to go back.

You can change labels at any time by clicking on the label box. References to the
changed label will automatically change its link to the new label text, so that you
don’t need to take care about this.

If a cross-reference refers to a non-existing label, you'll see two question marks in
the output instead of the reference.

References are described in detail in the Embedded Objects manual.

6.2. Table of Contents and other Listings

6.2.1. Table of Contents and Outline

The Table of Contents (TOC) is inserted with the menu Insert > List/ TOC> Table of Con-
tents. Isis displayed in Iy X as a gray box. If you click on it, the TOC window appears,
showing you the TOC entries. You can jump to a document part by clicking on an
entry. Thus you can use this window as graphical alternative for the Navigate menu.
The TOC lists every numbered section automatically. If you have declared a short
title for a section heading, as described in section 3.3.4.4, it will be used in the TOC
instead of the section heading. Section 3.3.4.3 describes how the level is adjusted that
defines which section types are listed in the TOC. You can also adjust the level for
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the displayed sections in the TOC window using the grey fader at the bottom of the
window. Unnumbered sections are not listed in the TOC.

You can use the TOC window also as outline to move and rearrange sections in
your documents. The TOC window therefore also appears when you use the menu
Document > Outline.

6.2.2. List of Figures, Tables and Algorithms

Table, figure, and algorithm lists are very much like the table of contents. You can
insert them via the Insert>List / TOC submenus. The list entries are the float captions
and the float number.

6.3. URLs (Uniform Resource Locators)

It is often desirable to include long “verbatim” items in a document such as Web site
URLSs, e-mail addresses, etc. These things typically do not contain any spaces and
are thus difficult to typeset properly. Such items will often fall on a line boundary if
they cannot be split, resulting in an overfull line. To avoid this, use the menu Insert >
URL to enter a long URL and have it split gracefully, if necessary.

The URL dialog has two fields; the URL field and the Name field for the URL
description, which will be typeset as plain text immediately before the URL. Here an
example:

LyX-Homepage http://www.lyx.org.

Important notes:

n n-sn

e When you use the following characters: "%", "#", "~", you have to write them
with a backslash before, e.g. “\#”.

¢« URLSs must not end with a backslash!

6.4. Appendices

Appendices are created with the menu Document > Start Appendix Here. This menu
sets the document from the current cursor position to the end as appendix region.
The region is marked with a red borderline.

Every chapter (or section) within the appendix region is treated as an appendix,
numbered with a capital Latin letter. The appendix subsections are numbered with
this letter followed by a dot and the subsection number. All appendix sections can
be referenced as if they were normal sections, here two examples:

Appendix D; Appendix A.1.11
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6.5. Bibliography

There are two ways of generating the bibliography in a [yX-document. You can
include a bibliography database?, which is explained in the next subsection or you
can insert the bibliography manually. For the second method we use the paragraph
environment Bibliography, described in section 3.3.8.2.

Within the Bibliography environment, every paragraph begins with a gray bibliog-
raphy box labeled with a number. If you click on it, you will get a dialog in which
you can set a Key and a Label. The key is the symbolic name by which you will refer
to this bibliography entry. For example, our second entry in the bibliography is a
book about BKTEX and we used “latexcompanion”, a short form of its title, as key.

You can refer to the key of a bibliography entry using the menu Insert > Citation or

the toobar button & A citation reference box is inserted and a citation window
will appear in which you can select one or more keys in the available key list. The
citation reference box will be labeled with the referenced key. When you click on the
box, the citation window appears and you can change the reference.

Citation references appear in the output as number of the bibliography entry with
surrounding brackets. If you set a Label for the entry, the label will appear instead of
the number. Here two examples; the first without a label, the second with the label
“Credits”:

Have a look at the IKTEX Companion Second Edition: [1]

The Iy X-Team members are listed in the Credits: [Credits]

6.5.1. Bibliography databases (BibTgX)

Bibliography databases are useful if you use the same bibliography in different docu-
ments. It makes it also very easy to have a uniform layout for all bibliography entries.
You can collect the bibliography of all relevant books and articles of your working
field in a database. This database can be used for different documents, because only
the referenced entries of the database will appear in the bibliography list.

The database is a text file with the file extension “.bib” containing the bibliography
in a special format. The format is explained in ETEX books ([MG04, KD03, Lam94]).
Normally one uses a special program to create and edit entries of the database. Under
http://wiki.lyx.org/BibTeX/Programs
you find a list of programs for bibliography databases.

To use a database, use the menu Insert> List/ TOCr> BibTeX Bibliography. A grey
box will be inserted and a window appears. In this window you can load one or more
databases and a style file.

The style file is a text file with the file extension”.bst” that declares the layout of
all bibliography entries. Many publishers provide special style files, so that you don’t
have to take care of the layout.

Inserting a citation reference works like described above.

2Known under the name “BibTEX-database”.
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6.6. Index

To generate the bibliography from a database, the program BibTEX is used by LyX.
This program can be controlled with options that you can add in LyX’s preferences
dialog under Outputs, LaTeX in the field BibTeX command. Before adding options, it
is strongly recommended to read the manual of BibTEX.

We use two bibliographies in this document to show the difference between the two
methods of creating them. As you can see, the bibliography that is created from a
database lists only the database entries that are referenced in the document. We used
the style file alphadin.bst to get the complicated German reference key scheme in the
bibliography.

6.5.2. Bibliography layout

In the citation reference dialog you can set a special citation format. For this feature
you need to use the option Natbib enabled in the Document>Settings dialog under
Bibliography. Setting a citation style for a reference will overwrite the default. For the
global citation format use the BibTEX style files as explained in the previous section.

You can also set text, that should appear before or after a citation reference, in
the citation reference window. Here an example where we set the text “Chapter 3”
to appear after the reference:

Have a look at [1, Chapter 3].

6.6. Index

An index entry is created if you use the menu Insertr>Index Entry or the toolbar

button T, A gray box labeled “ldx” is inserted containing the text that appears
in the index. The word where the cursor is in or the currently highlighted text is
proposed by [yX as index entry.

Note: The index entry text field differs from all other text fields, because you
have to insert valid I¥TEX-code. Therefore you cannot insert

Find & Replace

to an index entry field, because the “&” character is used in IfTEX to separate table
columns, so that you will get KXIEX-errors. The correct entry is

Find \& Replace

This behavior is necessary because index entries can be formatted in many ways
using special ITEX commands. We give a short overview of the index command in
the next subsections. For a detailed description of KTEX’s index mechanism, have a
look at one of the TEX books [1, 2, 3].

You can change index entries by clicking on the index box.

The index list is inserted to the document with the menu Insert>List / TOCp
Index List. A light blue box labeled “Index” will show the place where the index is
printed in the output. The index list box is not clickable like other LyX-boxes.
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6.6.1. Grouping Index Entries

Index entries are often grouped to offer the reader a fast search in the index. We
want to group for example the index entries for itemized and enumerated lists under
the entry “Lists”. First we create the entry “Lists” in section 3.3.6. In the text field
for the itemized list index entry in section 3.3.6.2, we insert the command

Lists ! Itemize

and the command

Lists ! Enumerate

for the enumerated list in section 3.3.6.3.

The exclamation mark “!” marks the grouping levels. You can have three levels;
every index level is indented a bit more. An index entry for the higher levels is not
required. If we don’t have an index entry for “Lists”, it will be printed anyway, but
without a page number.

6.6.2. Page Ranges

Normally an index entry will appear with the page number of the indexed section.
But sometimes you want to index more pages under the same entry. E.g if we want
to index the paragraph environments, we create an index entry in section 3.3 with
the command

Paragraph environments|(

and another entry at the end of section 3.3.9 with the command

Paragraph environments|)

The commands “|(” and “|)” respectively starts and ends the index range. You can
also add the same index entry at different places in the document. They appear in
the output under one entry with a comma separated list of the pages of the indexed
document parts. An example is the index entry “Document ! Settings”.

6.6.3. Cross referencing

It is also possible to refer to another index entry. We referred for example in the
index entry “GIF” (in section 4.4.1) to the index entry “Image formats” in the same
section using the command

GIF |see{Image formats}

The text within the braces is the referenced entry. The reference will appear in the
output without a page number.

6.6.4. Index Entry Order

You can use accented characters in the index entry, but the entries might then not
follow the rules for the index order. The index entries are sorted alphabetically,
but TREX? doesn’t know how to sort accents in different languages. We created as

3The index generating is done in the background by an extra program, see section 6.6.6.
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bR

example the three dummy index entries “maison”, “mais”, and “maitre”. They will
be sorted in the order mais, maitre, maison, but we want the order mais, maison,
maitre. To achieve this, we use the command

previous entry@current entry

In our case we want to have “maison” after “mais” and write therefore for the index
entry of maison:

mais@maison

The previous entry needn’t to be a real existing entry, you can also use another
word to tell KTEX the entry order, see the next subsection for an example.

6.6.5. Index Entry Layout

You can insert entries together with K¥TEX-commands for the layout. If you need for
example an italic entry, you can write

\textit{This is an italic entry}

where the command \textit produces the italic layout. We refer to KTEX books
([1, 2, 3]) for an overview of layout commands. There is only the problem, that layout
commands destroy the sorting order. To avoid that our index entry appears as the
first one, we use the following command instead:

This@\textit{This is an italic entry}

You can also format the page number using the character “|” followed by a KTEX-
command without a backslash. We can write for example

old-style page number:|oldstylenums

to get the page number in an old-style layout. Normally all IXTEX-commands begin
with a backslash, but in this special case “|command” means \command{page num-
ber}. Have a look at section 6.9.2 to learn more about the KTEX-syntax.

You can also change the layout for the whole index. E.g. we marked the index list
box of this document as bold to get a bold font for all index entries.

6.6.6. Index Program

[yX uses for the index generation by default the program makeindex. It can be
controlled by options that can be set in Iy X’s preferences dialog, see section B.5.4.
The available options are listed and explained in [7].

You can also specify there another program to generate the index, for example
xindy.

6.7. Nomenclature / Glossary

Sometimes you need to compile a list of symbols that are mentioned in your document
with a brief explanation of them — a so called nomenclature or glossary.

To be able to create nomenclatures, you need the IXTEX package nomencl installed.
You find it in the TEX Catalogue, [5] or in the package manager of your IXTEX-system.
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A nomenclature entry is created if you place the cursor after a symbol entry and

then use the menu Insert> Nomenclature Entry or the toobar button &= A gray box
labeled “Nom?” is inserted and a window pops up asking for the nomenclature entry.
A nomenclature entry consists of two main entries. The first is the symbol that
you want to refer to. The second is the description of the symbol.
Note: Like for the index entry dialog, you have to enter valid KTEX-code for all
fields of the nomenclature dialog.

6.7.1. Nomenclature Definition and Layout

When you have symbols in formulas, you have to define them in the Symbol field as
BTEX-formula. For example to get “o”, insert this:

$\sigma$

The “$” character hereby starts/ends the formula. The IXTEX-command for the Greek
letter is the name of the letter beginning with a backslash “\”. For capital Greek
letters, start the command also with a capital letter, like \ Sigma.

(A short introduction to the KTEX-syntax is given in section 6.9.2.)

You cannot use the Text Style dialog to format the description text but have to use
BTEX-commands. For example the description of the nomenclature entry for the “o”
in this document is:
dummy entry for the character \textsf{sigma}

The command \ textsf sets the fonts to sans serif. To get bold font use the command
\textbf, for typewriter use \texttt, for emphasized use \emph.

6.7.2. Sort Order of Nomenclature Entries

The nomenclature entries are sorted alphabetically by the ETEX-code of the symbol
definition. This leads to undesired results when you for example have symbols in
formulas. Suppose you have nomenclature entries for the symbols a and o. They
will be sorted by “a” and “$\sigma$” — the o will be sorted before the a since the
character “$” is considered in sorting.

To control the sort order, you can edit the Sort as field of the nomenclature dialog.
Then the nomenclature entry will be sorted by this entry and not the symbol defini-
tion. For the given example, you can insert sigma to this field for the o, then a will
be located before o.

For subgrouping and tips for using sort entries see the nomencl documentation,

[10].

6.7.3. Nomenclature Options

The nomencl package offers some options to adjust the appearance of the nomen-
clature. Here are some of its options, for more have a look at its documentation:
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refeq Appends the phrase “, see equation (eq)” to every nomenclature entry, where
eq is the number of the last equation in front of the nomenclature entry

refpage Appends the phrase “, page (page)” to every nomenclature entry, where page
is the number of the page on which the nomenclature entry appeared

intoc Inserts the nomenclature in the Table of Contents

There are furthermore the options croatian, danish, english, french, german,
italian, polish, portuguese, russian, spanish, and ukrainian to print the refer-
ence texts and the nomenclature title in the corresponding language.

To use one or more of the options, add them to the comma-separated document
class options list in the Documentr Settings dialog. In this document the options
intoc and refpage are used.

You can also use the first two options above only for certain nomenclature entries
when you add one of the following commands as last entry to the Description field in
the nomenclature dialog:

\nomrefeq Like the refeq option
\nomrefpage Like the refpage option
\nomrefeqpage Short notation of \nomrefeq\nomrefpage

\nomnorefeq, \nomnorefpage, \nomnorefeqpage Turns off the corresponding op-
tions

6.7.4. Printing the Nomenclature

To print the nomenclature, use the menu Inserti>Lists / TOC>Nomenclature. A light
blue box labeled “Nomenclature” will show the place where the nomenclature is printed
in the output. Like the index list box, the nomenclature list box is not clickable.

In the printed output the title of the nomenclature appears as “Nomenclature”.
If you are not happy with the name, you can change it by redefining the command
\nomname in the preamble. For example, in order to change the name to List of
Symbols, add the following line to the preamble:

\renewcommand{\nomname}{List of Symbols}

If you are unhappy with the amount of space for symbols, you can alter it by adding
the following line to the preamble:

\renewcommand{\nomlabelwidth}{width}

Where the width is a value with one of the units listed in Appendix C. The default
value is 1 cm.
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6.8. Branches

Sometimes it is useful to hide some document parts in the output. For example a
teacher who is setting an exam obviously doesn’t want the pupils to see the answers,
but having questions and answers in the same document will make the life of the
markers of that exam much easier.

For these cases LiyX offers to put text into branches. The text will then only appear
in the output when its branch is activated. To create a branch, go in the Document >
Settings dialog to Branches. The name of the branch, its activation state and the
background color of the branches inside IyyX can be specified in this dialog.

Text that should be in a branch is set into branch inset boxes. These boxes are
inserted via the menu Insert>Branch where you can choose a branch. You can later
change the branch of the boxes by right-clicking on them.

Here is an example, where only the question text appears, the answer branch is
deactivated and does therefore not appear in the output:

Question: Who was the first physics Nobel prize winner?

To use conditional output inside places where you cannot insert branch insets, like
inside equations, you can code special KIEX definitions for each branch. For example
you can define for the question branch*

\newcommand{\question}[1]{#1}

\newcommand{\answer }[1]{}

and for the answer branch

\newcommand{\question}[1]{}

\newcommand{\answer }[1]{#1}

Now it is possible to use the commands \question{...} and \answer{...} to
obtain conditional output. Here is an example formula where only the \question
part appears:

x2—2x—2:>a:1:1+\/§.

Inside math, the same effect can be achieved using math macros, see section 5.6.

6.9. ERT and the BTEX Syntax

6.9.1. ERT Boxes

As LyX uses HTEX in the background, it supports many IKTEX commands and con-
structs, but not all. IATEX contains of hundreds of packages which provide different
commands. Every month many packages are updated and new ones added. This
has the advantage that you can typeset nearly everything, for every problem exists
a IHTEX-package. But IyX can of course not be up to date and support all these
packages and their commands.

4For an introduction to the BTEX-syntax, see section 6.9.2.
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But don’t worry, you can use any I¥TEX-command directly in IxX inside the ERT
box. ERT stands for “evil red text”, evil because LyX is designed to avoid that you
have to use ITEX-commands. An ERT box is created by the menu Insert>TEX or

by the toolbar button TEE The box itself can be displayed in three different styles:
Inline, Collapsed, and Open. To change the style, right-click on the box and use the
appearing dialog. Left-clicking on the box will switch between Collapsed and Open.

You can insert complete or incomplete commands into ERT. Incomplete means
that the command argument can be Standard LyX text. For example you want to
draw a frame around a word and uses therefore the KTEX-command \fbox, you can
write the command part \fbox{ in an ERT box before the word and the closing brace
} in a second ERT box behind the word. The word between the two ERT boxes is
then the argument as it is in the following example:

Thiz 15 a hine with a fbox{ framed } word.

gives

This is a line with a word.

Note: At the end of KIEX-commands without parameters, you have to insert a
space to let KTEX know that the command is finished.

6.9.2. Short Introduction to the BPTEX Syntax

When you write larger documents or books, you will need to know something about
the BTEX-commands that [yX uses in the background. Because KTEX is based on
commands, you can “program” your text. This has the advantage that the layout of
the document can be changed at every time if you know the right commands. E.g.
imagine you have to write a manual for a product and the deadline is at the end of
the day. Your boss just has complimented you for your good work but wants to have
all caption labels bold. But you have over hundred figure and table captions with
non-bold labels in your manual. Of course it’s impossible to change all caption labels
by hand in one day.

Now ITEX comes into play. As written above, for every problem exists a ETEX-
package. First you have to find out which and therefore look in the BKTEX package
database, [FW].

As result you know that the package caption is what you need. To use a package,
you have to load it in the document preamble (menu Document>Settings) with the
command

\usepackage[options]{package name}

All ITEX commands begin with a backslash, the command argument is set within
two braces, and the options are set within two brackets. Note that not all commands
have an argument and options.

In your case the package name is caption. After a look in the documentation
of the package, you know that the option labelfont=Dbf will change the font of all
caption labels to bold. So you add the command
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\usepackage[labelfont=bf]|{caption}

to the preamble and the problem is solved.®

Note that some document classes have built-in solutions for well known problems
like your case. For example if you use a koma-script class, you don’t need the package
caption, you can instead write

\setkomafont{captionlabel }{\bfseries}

in the preamble and the problem is solved. So if you plan to write a large document,
you should have a look at the documentation of the document class you want to use.
(\setkomafont is an example for a command with more than one argument.)

Commands in the preamble affects the whole document, while commands in the
text affects only the text after the command or only the text used as command
argument. To insert a KTEX-command in text, use the ERT box as described in the
previous section.

If you want to learn more about IXTEX and its syntax, have a look at the KITEX-
books [1, 2].

6.10. Previewing Snippets of your Document

LyX allows you to generate previews of sections of your document on the fly so you
can see how they’ll look in the final document without having to break your train of
thought with Viewr DVI.

If you would for example like to see in IyX your math formulas typeset by KTEX,
install the ATEX-package preview-latex as explained below, and turn on Instant pre-
view in the Tools> Preferences dialog under Look and feel > Graphics.

Previews are generated when you load a document into [yX and when you finish
editing an inset. Previews of an already loaded document are not generated just by
selecting the Instant preview check box, you have to reopen the documents to activate
the previews.

LyX will generate previews of math insets. It will also generate previews of included
insets if you select the Show preview check box in the insert dialog. This is useful if
you wish to generate a preview of a INTEX figure, for example.

To get previews working, you need the KTEX package preview-latex (on some
systems named simply preview) installed. In case it is not already installed, you
find it in the TEX Catalogue, [5] or in the package manager of your WTEX-system. You
obtain prettier results if you install the program pnmcrop from the netpbm package;
for IyX on Windows this program is automatically installed together with IyX.

You can furthermore preview the KTEX source of the whole document or parts of
it. Use the menu View > View Source and a window will be shown where you can see
the BTEX-source code. The window shows the source of the whole paragraph where
the cursor is currently in. You can also select document parts in IiyX’s main window,
then only this selection (when it is more than one paragraph) is shown as source code.

For more commands provided by the caption package, have a look at its documentation, [8].

92



6.11. Spell Checking

To view the whole document as source, enable the corresponding option in the source
view window.

6.11. Spell Checking

[y X itself has no built-in spell checker. Rather it uses one of the external programs
aspell, ispell, hspell, or pspell as backend. This section assumes you have already
installed and set up one of these programs. aspell can be seen as successor of
ispell, so that it is recommended to use aspell. hspell is a Hebrew spell-checker. The
used spell checker ind its settings are specified in [y X’s preferences under Language
Settings.

For IyX on Windows, the selection box for the spell checking program is greyed
out in the preferences dialog because only aspell can be used.

The menu Tools> Spellchecker starts the spell checking beginning from the current
cursor position. A dialog window will appear showing any incorrect (or unknown)
word found, allowing you to edit and replace it in a second line. Whenever an
unknown word is found, the word is highlighted and the text scrolled so that it is
visible. In the spell checker dialog, there is also a box showing suggestions for a
correction, if any could be found. Clicking on one of the corrections will copy to the
Replace field, double-click invokes directly the replacement. Unknown but correctly
typed words can be added to the personal dictionary.

By default, the used dictionary file is determined by the document language that is
set in the Document > Settings dialog. If you do not have a dictionary for the document
language, spell checking will bring an error message. In this case, you can specify
another dictionary file in the dialog by specifying a different Alternative language in
preferences dialog.

After a spell check you’ll informed about the number of checked words.

Limitations

It is not possible to change the spelling of a particular word globally, rather than
having to change the spelling separately for each occurrence of the word. But you
can use the Find & Replace dialog for that.

LyX cannot correctly spell check documents containing multiple languages. This
does work with pspell, assuming you have marked the different languages appropri-
ately.

Further Settings
The Spellchecker section in the preferences dialog has some additional options:
Escape characters Allows you to add non-standard characters that the spell checker

should consider, e.g. German umlauts although you spell check English docu-
ment. This should not normally be needed.
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Personal dictionary to use a different file than the spell checker’s default choice as
your personal dictionary

Accept compound words Prevent the spell checker from complaining about com-
pounded words like “passthrough”.

Use input encoding Uses the document encoding that is set in the Documentr
Settings dialog under Language also for the spellchecker.® Only enable this if
you use ispell and can’t spell check words with international letters in them.
There have been reports that this does not work with all dictionaries, so this is
disabled by default.

6.12. Thesaurus

Thesaurus currently only works when you use the document language English.
To start the thesaurus, highlight one word or set the cursor behind it, and use the

menu Tools> Thesaurus or the toolbar button lell A dialog pops up showing you
probably related words that you can use as replacement.

The shown related words are in many cases not really related to the word you are
currently checking, scrolling in the shown list might help in some cases to find related
words.

The thesaurus only works for single words, and also only when it is in the singular
form. For example starting the thesaurus with the word “reports” leads to no results,
while results are shown for the word “report”. To avoid this, you can highlight only
the part “report” of the word “reports” to get results.

6.13. Change Tracking

When you work on a document together with many people it is extremely useful to
see changes others made highlighted in the document. You can then decide if you
accept a change or not. This can be achieved by turning on change tracking in the
menu Document > Change Tracking> Track Changes.

Changes made in the document will then be highlighted by colors: Blue text is
an addition, red canceled text is a deletion. You can change the color in LyX’s
preferences dialog under Look and feel, Colors.

When change tracking is activated, you will see the review toolbar in LyX:

S = x 200 @

The review toolbar as shown above contains from left to right the following buttons:

5The encodings are explained in section A.6.6.
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Document > Change Tracking> Track Changes
Document > Change Tracking>Show Changes in Output
Jumps to the next change

Document > Change Tracking> Accept Change
Document > Change Tracking> Reject Change
Document > Change Tracking> Merge Changes
Document> Change Tracking > Accept All Changes
Document > Change Tracking> Reject All Changes

Insert > Note> LyX Note

TEL m 6 'G II]I L I'Iﬁ ﬁ ‘%

Navigate> Next Note

The review toolbar helps you to accept, reject, or merge changes — highlight the
change and press one of the desired toolbar buttons. When you merge changes, a
window pops up showing you informations about the next change behind the current
cursor position. So you don’t need to highlight a certain change. Within the merge
window you can decide to accept or reject changes and step to the next change. This
way you can jump through all changes of the document.

The toolbar has two buttons to handle notes because notes are often important to
describe a change.

To show made changes in the output you need the KTEX package dvipost installed.
You find it in the TEX Catalogue, [5] or in the package manager of your X TEX-system.

6.14. International Support

This section describes how to use LyX with any language you want. For some non-
western languages there are special Wiki-pages that explain how to set up LyX to use
them: [14, 15, 16, 17]

Besides languages, LiyX also supports phonetic symbols, see section A.4.2.
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6.14.1. Language Options

The Document > Settings dialog lets you set the language and character encoding for
your language.
Choose your language in the Language section of this dialog. The default is English.
The Encoding box lets you choose the character encoding map you want to use
for KTEX export. The option use language's default encoding is the preferred choice
and works well in most cases. For details abhout the different encoding options see
section A.6.6.

6.14.2. Keyboard mapping configuration

If you have for example a U.S.-style keyboard and want to write in a different language
than English, you can use an alternate keymap. For example, if you have a U.S.-
style keyboard but want to write in Italian, you can configure IyX to use an Italian
keymap. The preferences dialog allows you to choose up to two keyboard mappings,
see section B.1.5. You can choose primary and secondary keyboard languages and
then select which one you want to use.

Finally, you may just want to change a few key mappings or create an entirely
different keymap (for Vulcan, for instance). You may, for example, normally write in
[talian on a U.S. keyboard but want to include an occasional quotation in German. In
such a case, you can write your own keyboard mapping or modify an existing one to
support the characters you want. This and much more customizations are explained
in the Customization manual.

6.14.3. Character Tables

Table 6.2 shows the Latinl character set. You should be able to enter the characters
in the first eight columns directly from the keyboard.

There are a few things you need to know about this table. Here are some of the
details you’ll need to bear in mind when using characters from the Latinl character
set:

o Even if you have selected latinl in the Document>Settings dialog, users who
have only the Ti-fonts for ITEX [or who have the Ti-fonts but aren’t using
them| will still miss a few characters: D0, FO, DE, FE, AB, and BB — the
uppercase and lowercase eth and thorn, and the french quotes won’t show up.

The following is a full list of all of the accented characters IiyX can display directly.
It includes not only the accented characters from the previous table, but also the

characters from I508859--2 through 4.

e From IS08859--1:
CTABIOUAsiody diaeresis
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Table 6.2.: The 1atinl character set

’ H 00 ‘ 10 ‘ 20 ‘ 30 ‘ 40 50 ‘ 60 ‘ 70 ‘ 80 ‘ 90 ‘ A0 ‘ BO ‘ Co ‘ DO ‘ EO ‘ Fo ‘

00 ola@lP]| " |p clA|blalad

01 ! 1] A Q a | q i +| AN |4a|i

02 “12|B|R|[b]|r ¢c|2[A]O]a]o

03 # 3 C S C S £ 3 A O]a 0

04 $ 14| D|T|d]|t jof AlOlaloeo

05 % | 5 E U (S u ¥ n A O a 0

06 & | 6 F \% f A% : ﬂ Ped) O & | o0

o7 TG IW g | w § Clx|¢|~+

08 ( 8 H X h X B E @ e [0}

00 )19 T Y [ily o' [E[U|é |

oa 1 1J1z2j|z alolRlU|lelu

0B + 1 | K| [ | k|{ «|» [E|lU]&é|qa

0c i< | LN |1 - w101

0D - =M } m } - | % I Y i Sf

oE | >|N| " |[n]|~ “ I[P 1]Dp

OF / 710 _|o - A | i 1|y
~AEIOUaeidt circumflex
“AEIOUacion grave
"AEIOUYaéiduy acute
~ANOans tilde
.C¢ cedilla
- macron

e From IS08859--2 through 4:

HJ ﬁj@@gégé circumflex
S7szRLCN#lén acute
IiUa tilde
SsTIRLGrIgNKnk cedilla
EeAIOUaioi macron
OUst Hungarian umlaut

All the characters above are actively supported by TEX fonts. In addition TEX allows
diacritical marks on almost all characters. Also make sure you're using the T1 font-
encoding.
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A. The User Interface

This appendix lists all available menus and describes its functionality. It is designed
as quick reference if you are searching for a special topic inside the user’s guide.

A.1. The File Menu

Under the File menu are the basic operations in addition to some more advanced
operations. At the end of the menu the four last opened documents are listed.

A.1.1. New

Creates a new document.

A.1.2. New from Template

This menu prompts you for a template to use. Selecting a template will automatically
set certain layout features for the document, features you would otherwise need to
change manually.

A.1.3. Open

Opens a document.

A.1.4. Open Recent

The submenu shows a list of the recently opened files. Click there on a file to open
it.

A.1.5. Close

Closes the current document.

A.1.6. Save

Saves the actual document.
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A.1.7. Save As

Saves the actual document under a new name to create a copy.

A.1.8. Revert to saved

Reloads the actual document from disk.

A.1.9. Version Control

This is used when more people are working on the same document. It is described in
the section Version Control in LyX of the Extended Features manual.

A.1.10. Import

You can import there files from older LyX-versions, ITEX-files and plain text files
(ASCII-files). The files will be imported as new LyX-document.

When using the menu Plain Text, Join Lines, all lines will be imported consecutively
to one big paragraph. A new paragraph is started when there is a blank line in the
file. , the text is inserted as Paragraphs, where the line breaks of the text will start
a new paragraph.

A.1.11. Export

You can export your document to various file formats. The resulting files are placed in
the directory of your [y X-file. The menu entries are not the same on all installations.
They depend on the programs found by [yX while its configuration.

Here is a list of all available entries; they are explained in detail in section 3.7.2:

CJK LyX format of the special LyX 1.4.x versions for Chinese, Japanese, and Korean
(CJK); (Since LyX 1.5.0 CJK support is fully integrated to IyX.)

DVI DVI-format

HTML HTML-format (the HTML-converter is a third-party product and doesn’t
work in all cases)

HTML (MS Word) HTML-format specialized so that the result can be imported to
MS Word, as consequence of this formulas will be embedded as bitmap fonts
and not in the format MathML.

LaTeX (pdflatex) text file with the BKTEX source, additionally all images used in
the document will be converted to a format that is readable for the pdflatex
program (GIF, JPG, PDF, PNG)
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LaTeX (plain) text file with the IXTEX source code, additionally all images used in
the document will be converted to the EPS-format, only this format is readable
for the latex program

(1)

LyX 1l.y.x LyX-document in a format readable for the LyX versions l.y.x (“y” is
replaced by the version number)

OpenDocument OpenDocument-formatted text file, to be opened with OpenOffice,
KOffice, Abiword, etc. (the OpenDocument-converter is a third-party product
and doesn’t work in all cases)

PDF PDF-format using the program ps2pdf

PDF (dvipdfm) PDF-format using the program dvipdfm
PDF (pdflatex) PDF-format using the program pdflatex
Plain text text format

Plain text (ps2ascii) text format, the document will first be converted to Postscript
format and then exported as text using the program ps2ascii

Postscript PostScript format using the program dvips

Custom custom format

The program dvipdfm produces internally a dvi-file which is then converted to a pdf-
file. It is a bit out of date and therefore the output could look different from what you
want. pdflatex produces directly pdf-files and supports the latest pdf-file formats.

If one of the menu entries DVI, PDF (pdflatex) or Postscript is missing, you need
to update your KIEX installation. After updating you have to reconfigure IyX, see
section 1.4.

The menu Custom allows you to export your file by using special command line
options for the export program.

A.1.12. Print

With this menu you can print your document to a file in PostScript format or send
it to a printer. The printer will also use the document in PostScript format. The
conversion to PostScript is done in the background by IyX using the program dvips.
For more informations have a look at section 3.7.4.

A.1.13. New and Close Window

Opens a new instance of [yX with all currently opened documents. You can close it
later with the corresponding menu.
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A.2. The Edit Menu

A.2.1. Undo and Redo

Described in section 2.3.

A.2.2. Cut, Copy, Paste, Paste Recent, Paste Special

Described in section 2.2.

A.2.3. Select All

Selects the whole document.

A.2.4. Find & Replace

Described in section 2.2.

A.2.5. Move paragraph Up/Down

This shifts the paragraph where the cursor is currently in one paragraph up or down.

A.2.6. Text Style

Described in section 3.6.4.

A.2.7. Paragraph Settings

The settings in the paragraph dialog only affects the paragraph where the cursor is
in. Here you can set here the paragraph alignment and line spacing.

You can also prevent that the first line of the paragraph is indented. This op-
tion works only when you have chosen to separate paragraphs with indents in the
Document > Settings dialog under Text Layout.

A.2.8. Tabular and Math

These two menus are only active when the cursor is inside a table or a formula. The
properties of this table/formula can now be changed. The properties of tables are
described in section 4.5, the properties of formulas in chapter 5.

A.2.9. Increase / Decrease List Depth

These menus are only active when the cursor is in an environment that can be nested.
They in/decrease the environment nesting level as explained in section 3.4 and 3.3.4.3.
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A.3. The View Menu

The View menu contains a list of available formats in which you can view the actual
document with an external program. The menu entries for the viewing formats are
not the same on all installations - it depends on the TEX programs that are found
while LyX was configured. All possible formats are formats listed in section A.1.11.
You should at least see the menu entries DVI and PDF (pdflatex). If one of the two
is missing, you need to update your KTEX installation. After updating you have to
reconfigure I X, see section 1.4.

Invoking a menu will start a viewer program. The viewer can be set or changed in
the preferences, see section B.7. The default viewers are set by LyX while it is first
configured.

At the bottom of the View menu the opened documents are listed.

A.3.1. View Source

Opens a window showing the source code of the actual document, as described in
section 6.10.

A.3.2. Update

This menu allows you to update the view with your latest changes without opening
a new view window.

A.3.3. Toolbars

In this menu you can set the appearance of the different toolbars. All toolbars and the
Command Buffer can be turned on and off. The on state is denoted in the menu with
a checkmark. The Review, Table, Math Panels, and Math toolbars can be additionally
set to the state automatic that is denoted in the menu with the suffix (auto).

In the on state the toolbar is permanently shown, in the automatic state the toolbar
is only shown when the cursor is in a certain environment or when a certain feature
is enabled. That means that the review toolbar will only be shown when change
tracking is activated, the math and table toolbars are only shown when the cursor is
inside a formula or table, respectively.

LyX’s toolbars and its buttons are explained in section A.9.

A.4. The Insert Menu

A.4.1. Math

Inserts math constructs that are explained in chapter 5.
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A.4.2. Special Character

Here you can insert the following characters:

Ellipsis Inserts an ellipsis: ...

End of Sentence Inserts an end of sentence dot as described in section 3.8.3.1.

)

Ordinary Quote Inserts this quote: ”, no matter what quote type you selected in the
Document > Settings dialog under Language.

Single Quote Inserts this quote: °

Menu Separator Inserts the menu separator sign: >

Phonetic Symbols Creates a formula with a so called tipa inset. Here you can insert
commands to create IPA phonetic symbols. For this feature you must have the
ETEX-package tipa installed.
For more informations about this feature we refer to the documentation of tipa,
[11] and this Wiki-page:
http://wiki.lyx.org/LyX/LinguistLyX.

A.4.3. Formatting

Here you can insert the following format constructs:

Superscript Inserts an superscript: test®P

Subscript Inserts an subscript: testsy

Protected Space Inserts a protected space that is described in section 3.5.6.2.
Inter-word Space Inserts an inter-word space that is described in section 3.5.6.1.
Thin Space Inserts a thin space that is described in section 3.5.6.3.
Horizontal Fill Inserts an horizontal fill, see section 3.5.1 for a description.
Horizontal Line Inserts an horizontal line, see section 3.5.7 for a description.
Vertical Space Inserts vertical space, see section 3.5.2 for a description.
Hyphenation Point Inserts an hyphenation point, see section 3.8.2

Ligature Break Inserts a ligature break, see section 3.8.4

Line Break Inserts a forced linebreak, see section 3.5.5

Page Break Inserts a forced pagebreak, described in section 3.5.4

Clear Page Inserts a clear pagebreak, described in section 3.5.4.1

Clear Double Page Inserts a clear doublepage break, described in section 3.5.4.1
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A.4. The Insert Menu

A.4.4. List / TOC

Various lists can be inserted with this menu. The table of contents, the algorithm,
figures, and tables list are described in section 6.2. The index list is described in
section 6.6, the nomenclature in section 6.7, and the BibTEX bibliography in sec-
tion 6.5.1.

A.4.5. Float

To insert floats, described in section 4.6.

A.4.6. Note

To insert notes, described in section 4.1.

A.4.7. Branch

Inserts branch insets as described in section 6.8.

A.4.8. File

Here you can inserts files to include them or its content to your document. How this
can be done is in detail explained in chapter Ezxternal Stuff of the Embedded Objects
manual.

A.4.9. Box

Inserts a minipage box that is described section 4.7. All box types supported by LyX
are explained in detail in chapter Boxes of the Embedded Objects manual.

A.4.10. Citation

Inserts a citation as described in section 6.5.

A.4.11. Cross-Reference

Inserts a cross-reference as described in section 6.1.

A.4.12. Label

Inserts a label as described in section 6.1.
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A.4.13. Caption

Inserts a caption to floats or longtables. Floats are described in section 4.6, cations
in longtables are described in section Longtable Captions of the Embedded Objects
manual.

A.4.14. Index Entry

Inserts an index entry as described in section 6.6.

A.4.15. Nomenclature Entry

Inserts a nomenclature entry as described in section 6.7.

A.4.16. Table

Inserts a table. Tables are described in section 4.5.

A.4.17. Graphics

Inserts a graphic. Graphics are described in section 4.4.

A.4.18. URL

Inserts an URL box as described in section 6.3.

A.4.19. Footnote

Inserts a footnote, see section 4.2.

A.4.20. Marginal Note

Inserts a marginal note, see section 4.3.

A.4.21. Short Title

Inserts a short title, see section 3.3.4.4.

A.4.22. TeX Code

Inserts an ERT box, see section 6.9.1 for a description.
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A.4.23. Program Listing

Inserts a program listings box. Program listings are explained in chapter Program
Code Listings of the Embedded Objects manual.

A.4.24. Date

Inserts the actual date. The format dependends on the date format of the language
that is used for LyX’s menus. LyX offers another ways to insert a date which is
explained in section External Material of the Embedded Objects manual. There the
different methods are also compared.

A.5. The Navigate Menu

This menu lists the existing, chapter, sections, figures, and tables of the current
document. This allows you to navigate easily through you document.
The Navigate menu also offers to

A.5.1. Bookmarks

With this menu you are able to define your own bookmarks. This is useful when you
are working on a large documents and often have to jump e.g. between section 2.5
and 6.3. To create bookmarks for this example, go to section 2.5 and use the menu
Save Bookmark 1. Then go to section 6.3 and use Save Bookmark 2. Now you can
easily jump between these sections by using the menu or by the key bindings C-1 and
C-2.

You can also use bookmarks to jump between several opened documents. The
saved bookmarks are valid till the document is closed.

A.5.2. Next Note, Change, Cross-reference

Jump to the next note, change, or cross-reference following the current cursor position.

A.5.3. Go to Label

Only active when the cursor is in front of a cross-reference. Sets the cursor before
the referenced label, the same as if you right-click on a cross-reference box.

A.6. The Document Menu

A.6.1. Change Tracking

Change Tracking is described in section 6.13.
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A.6.2. LaTeX Log

After running BTEX by viewing or exporting a document, this menu will be enabled.
It shows the logfile of the used KTEX-program.
Here you can see how KTEX works in the background. Ezperts will find in it reasons

for I{TEX-errors.

A.6.3. Outline

Opens the TOC/Outline window as described in section 6.2.1.

A.6.4. Start Appendix Here

This menu will start the appendix of the document at the current cursor position as
described in section 6.4.

A.6.5. Compressed

Un/compresses the actual document.

A.6.6. Settings

This menu dialog contains some submenus to set properties for the whole document.

You can save your document settings as default with the Save as Document Defaults

button in the dialog. This will create a template named default.lyx which is auto-

matically loaded by LyX when you create a new document without using a template.
The different submenus of the dialog are explained in the following:

Document Class

Here you set the document class, class options, and a Postscript driver. Document
classes are described in section 3.1.2. The Postscript driver is used for IXTEX’s color
and graphics packages. When using Default, the default driver for the KTEX-packages
are used. It is recommended to use the default unless your know what you are doing.

Fonts

The document font settings are described in section 3.6.

Text Layout

You can specify if paragraphs should be separated by indentations or vertical skips.
The line spacing and the number of text columns can here also be specified.
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Note that IyX won’t show two columns or the set up line spacing on screen. That’s
impractical, often unreadable, and not part of the WYSIWYM concept. However, it
will be as you specified it in the output.

The listings settings are explained in the corresponding section in the Embedded
Objects manual.

Page Layout

A description of this menu is given in section 3.1.4 and 3.1.3.

Page Margins

Here you can adjust the paper margins, see section 3.1.5.

Language

The document language and quote styles are set here. The encoding specifies how
the document content is exported to BTEX (the IxX file is always encoded in utf8).
All characters that cannot be encoded using the specified encoding will be exported
as BTEX-commands (this can fail if a KTEX-command is not known for a particular
character).!

If you use the option use language's default encoding, [yX determines the encoding
of a portion of text from the language of this text. If the document contains text in
more than one language you may get more than one encoding in the KTEX file. If
you do not use this option then the complete document will always use exactly one
encoding. Checking this option is the preferred setting unless you use XeTpX? (see
below).

LyX also supports Unicode output, which is particularly useful if you need lots of
special symbols or non-alphabetic scripts, respectively. If you want to use this (and
your KTEX installation supports Unicode, for that matter), choose one of the four
utf8 variants from the list below. Unfortunately the unicode support of standard
KETEX is quite incomplete, so it is not uncommon that a file with lots of unicode
symbols works fine with use language’s default encoding (when IxX uses it’s list of
known BTEX-commands), but does not work with a fixed utf8 encoding (when the list
of known KTEX-commands is ot used, because all unicode symbols can be encoded
in utf8).

Here is a list with the important encodings:

BTEX default Same as use language's default encoding, but the IXTEX-package inpu-
tenc is not used. You probably need to load some other packages manually in
the preamble.

!The known commands are defined in a text file. You can add commands for unknown symbols to
that file yourself, see the Customization manual for details.

2XeTEX is a TEX typesetting engine, an alternative for MTEX. It natively supports Unicode while
its input file is assumed to be in UTF-8 encoding. More about using LyX with XeTEX can be
found in [13].
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armscii8 encoding for Armenian

ascii the ASCII encoding, covers only plain English, may result in a big file because
lots of KTEX-commands may be needed

cpl250 MS Windows code page for latin2

cpl251 MS Windows code page for Cyrillic

cpl252 MS Windows code page for latinl

cpl255 MS Windows code page for Hebrew, superset of the ISO-8859-8 encoding
cpl256 MS Windows code page for Arabic and Farsi

cpl257 MS Windows code page for Estonian, Latvian, and Lithuanian, the ISO-
8859-13 encoding that is a superset of the ISO-8859-4 encoding

is088595 the ISO-8859-5 encoding, covers Belorussian, Bulgarian, Macedonian, Ser-
bian, and Ukrainian

i50-8859-7 the ISO-8859-7 encoding, covers Greek
8859-8 the ISO-8859-8 encoding, covers Hebrew
koi8-r standard Cyrillic especially for Russian
koi8-u Cyrillic for Ukrainian

latinl the ISO-8859-1 encoding, covers the languages Albanian, Catalan, Danish,
Dutch, English, Faroese, Finnish, French, Galician, German, Icelandic, Irish,
Italian, Norwegian, Portuguese, Spanish, and Swedish; should be replaced by
latin9

latin2 the ISO-8859-2 encoding, covers Albanian, Croatian, Czech, German, Hun-
garian, Polish, Romanian, Slovak, and Slovenian

latin3 the ISO-8859-3 encoding, covers Esperanto, Galician, Maltese, and Turkish
latind the ISO-8859-4 encoding, covers Estonian, Latvian, and Lithuanian

latinb the ISO-8859-9 encoding, covers Turkish, like the I[SO-8859-1 encoding where
the Icelandic letters are replaced by Turkish ones

latin9 the ISO-8859-15 encoding, like the ISO-8859-1 encoding, but with the euro
currency sign, the ce-ligature and some characters used for French and Finnish;
latin9 should be the replacement for latinl

pt154 Cyrillic for Kazakh
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utf8 Unicode utf8 with the IXTEX-package inputenc (first variant, for latin symbols
and some others).

utf8x Unicode utf8 with the KTEX-package inputenc (second variant, for greek and
CJK symbols and some others).

UTF8 Unicode utf8 with the IXTEX-package CJK (for the languages Chinese, Japanese
and Korean)

utf8-plain Unicode utf8 to be used with XeTgX, which uses Unicode directly, without
the help of the ITEX-package inputenc 3

Numbering & TOC

You can adjust here the numbering depth of sections headings as described in sec-
tion 3.3.4.3.

Bibliography

You can specify here a citation style using the KIEX-packages natbib or jurabib.
For a further description see section 6.5.

Math Options

These options will force LyX to use the IXTEX-packages amsmath and esint or to
use them automatically when they are needed.

amsmath is needed for many constructs, so when you get KTEX-errors in formulas,
assure that you have enabled AMS.

esint is used for special integral characters.

Float Placement

The float placement options are described in section 4.6.3.

Bullets

Here you can adjust the characters for the itemize levels. The itemize environment
is described in section 3.3.6.2.

Branches

Branches are described in section 6.8.

3More about using LyX with XeTEX can be found in [13].
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LaTeX Preamble

In this text field are entered commands to load special BTEX-packages or to define
BTEX-commands. The preamble is a thing for BTEX-experts. You shouldn’t enter
commands here until you don’t exactly know what you do.

An introduction in the KTEX-syntax is given in section 6.9.2.

A.7. The Tools Menu

A.7.1. Spellchecker

Spell checking is explained in section 6.11.

A.7.2. Thesaurus

The thesaurus is described in section 6.12.

A.7.3. Count Words

Counts the number of words in the actual document or the highlighted document
part.

A.7.4. TeX Information

Shows you a list of the classes and styles installed in your K TEX-system.

A.7.5. Reconfigure

This menu reconfigures IyX. That means IyX looks for KTEX-packages and needed
programs, see also section 1.4.

A.7.6. Preferences

The preferences dialog is described in detail in chapter B.

A.8. The Help Menu

This menu opens the documentation files of LyX in the language of LyX’s menus.
The menu IATEX Configuration shows a Iy X-document with informations about the
IXTEX-packages and classes found by Ly X (see also section 1.5).
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A.9. Toolbars

How to show or hide toolbars is explained in section A.3.3.
It is also possible to define custom toolbars. This is described in the Eztended
Features manual.

A.9.1. Standard Toolbar
EStandard D,ﬂ@ﬂ&}“ﬂﬁ @ﬁ:} 2 .._-Z;.F';:. E 'H'FDN&TH;.EJ%@

The standard toolbar as shown above contains from left to right the following
buttons:

Standard
pull-down menu for the paragraph environments

..E Filer> New
5’ Filer- Open
Filer> Save
CQ File> Print

HE‘% Tools > Spellchecker
B Edits Undo
@ Edit> Redo
% Edit> Cut
Edit> Copy
Fé Edit> Paste
Edit> Find & Replace

m 5

Emphasize text, function of the Edit > Text Style dialog

Set text to noun style, function of the Edit> Text Style dialog

g oEe

iy
—

Formats text using the current settings in the Edit> Text Style dialog

B
+o+
o

Insert > Math > Inline Formula

°

i
Sl

Insert > Graphics

il
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Insert > Table

© H

Toggle outline window on/off, Document > Outline

[+
+
B

Toggle math toolbar on/off

I

Toggle table toolbar on/off

A.9.2. Extra Toolbar
CEERe BEE2RSE =2 EEEeEawy ap= U0

The extra toolbar as shown above contains from left to right the following buttons:

wrae
111

Default

Numbered list

LA

¥ F
I

Ttemized list

[ ]
I

List

Description list

E'} Edit> Increase List Depth
E‘ Edit> Decrease List Depth
gl Insert > Float > Figure

Insert > Float> Table

Insert > Label

Insert > Cross-Reference

RED

Insert > Citation

Insert>Index Entry
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Insert > Nomenclature Entry

Insert > Footnote

Insert > Marginal Note

Insert > Note> LyX Note

Insert > Box

Insert> URL
Insert> TeX

Insert > Filer> Child Document
Edit> Text Style

Edit> Paragraph Settings

& 2= & & m" Mm@

L}.-.I Tools> Thesaurus

A.9.3. View / Update Toolbar

EH®-OBE®

The view / update toolbar as shown above contains from left to right the following
buttons:

duil  Views DVI

dui}  View> Updater DVI
A< ViewsPDF

() Views Updater PDF*

View > Postscript

4This button is on some IyX for Windows installations not here because its functionality is merged
with Viewr PDF.
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(FE.-J View > Update > Postscript

A.9.4. Other Toolbars

The change tracking toolbar is explained in section 6.13, the table toolbar is explained
in the Embedded Objects manual.
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The preferences dialog is called with the menu Toolst Preferences. It consists of
submenus explained in the following.

B.1. Look and Feel

B.1.1. User Interface
Note: You have to restart LyX before changes in ui- and bind-files take effect.

B.1.1.1. User Interface File

The appearance of the menus and toolbars can be changed by choosing an user
interface (ui) file. An ui-file is a textfile where the toolbars and menus are listed.
The toolbar buttons and menu entries are specified in the files stdtoolbars.inc and
stdmenus.inc, respectively. Both files are loaded by the default.ui file. To create your
own menu and toolbar layout, start with a copy of these files and edit the entries.

The syntax of the .inc-files is straightforward: The Menubar, Menu and Toolbar
entries must be ended with an explicit End. They may contain Submenus, Items,
Optltems, Separators, Icons, and in the case of the “file” menus a Lastfiles entry. The
syntax for the entries is:

Item ”menu or button name” 7Ly X-function”
All LyX-functions are listed in [19].

An example: Assuming you use the menu Navigater>Bookmarks quite often and
therefore want six available bookmarks, you can add the line

Item "Save Bookmark 6" "bookmark-save 6"
to the navigate menu section in the .inc-file to have the sixth bookmark.

B.1.1.2. Bind-File

Bindings are used to bind a function to a key. Several binding files are available:

cua.bind typical set of PC keyboard shortcuts

(x)emacs.bind set of bindings like they are used in the editor programs Emacs
(XEmacs)

mac.bind set of bindings for Mac OS systems.
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There are also bind-files designed for special document classes, like broadway.bind,
and bind files for special languages. The name of language bind-files begin with a
language code, e.g. “pt” for Portuguese. If you use LyX in a certain language, IyX
will try to use the appropriate bind-file.

Some bind-files, like math.bind, have only a small scope. When looking at the the
end of the file cua.bind, you can see that they are included to keep the overview in
the bind-file.

If you like to customize the keybindings to your own taste, modify the bind-files
with a text editor. The syntax of the entries is:

\bind ”key combination” ”IyX-function”

All IyX-functions are listed in [19].

B.1.1.3. Session

When the option Save / restore window size, or use fixed size is not checked, you can
specify the size of LyX’s main window when [X is started.

With the option Save /restore window position IxX will be opened with its main
window at the last used position.

The option Restore cursor positions sets the cursor to the position in the file where
it has been the last time.

The option Load opened files from last session opens all files that were opened in
the last LyX session.

B.1.1.4. Documents

When the option Backup documents is set, you can specify the time between backup
saves.

Maximum last files is the number of last opened files that LyX should display in the
menu File>Open Recent.

B.1.1.5. Scrolling

The option Cursor follows scrollbar sets the cursor to the top of the currently displayed
document part when scrolling.

B.1.1.6. Pixmap Cache

With the option Enable Pixmap Cache enabled, IyX needs to redraw the screen less
often. This results in better performance, especially on slow systems. On the other
hand, the characters might look more fuzzy on screen. So whether you enable this
or not depends on whether you prefer speed over aesthetics. Note that the Pixmap
Cache is only available and useful under Mac OS and Windows.

118



B.2. Paths

B.1.2. Screen Fonts

These fonts are used to display your documents on the screen.

Note: This section only deals with the fonts inside the IyX window. The fonts
that appear on the output are independent from these fonts, and set in the menu
Document > Settings > Fonts.

By default, IyyX uses Times as roman (serif) font, Arial or Helvetica (depends
on the system) as sans serif font, and Courier as typewriter font.

You can change the font size with the Zoom setting.

Screen DPI is the screen resolution in dpi (dots per inch). The Font Sizes are
calculated as letter height in units of points. 72 points have the size of 1inch, see
Appendix C.

The default Font Sizes are the same as if a document font size of 10 pt would be
used. The sizes are explained in detail in section 3.6.2.

B.1.3. Colors

You can here change all colors used by IxX. Choose an item in the list and use the
Alter button.

B.1.4. Graphics

Here you can specify how graphics inside LyX are displayed.
Instant Preview enables previewing snippets of your document. This feature is
described in section 6.10.

B.1.5. Keyboard Map

Normally keyboard settings have to be done in a menu of your operating system. For
the case that this is not possible, LyX provides keyboard maps. If you have e.g. a
Czech keyboard but want to write with it like with a Romanian one, you can use the
keyboard map file named romanian.kmap.

Note: Keyboard maps are only provided as makeshift and don’t work on all
systems.

B.2. Paths

Working directory This is [y X’s working directory. It is the default when you Open,
Save or Save as files.

Document templates This directory will be opened when you use the menu Filer
New from Template.
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Backup directory Backup copies will be saved to this directory. When no directory
is given but backups are enabled as described in section B.1.1.4, the Working
directory will be used to save the backups.

The backup files have the ending “lyx~".

LyXServer-Pipe Here you can enter the name of a Unix-pipe. This pipe is used to
send data from external programs to LyX.
Note: This feature doesn’t work on Windows systems.

Temporary directory Temporary files will be saved in this directory.

PATH prefix This field contains a list of paths to external programs. When IxX
needs to use an external program, it looks in this list where to find it on the
system. The path list is automatically set up on Windows and Mac systems
while IxX is configured, so that you normally don’t have to modify it. On
Unix / Linux systems, the path list will need to be set only if there are external
programs you wish to use that are not in your normal system path ($PATH).

B.3. Identity

Here you can insert your name and email address. The identity will be used when
you have enabled change tracking as described in section 6.13, to mark changes you
make as yours.

B.4. Language Settings

B.4.1. Language

Default language is the language used in new documents

Language package is a I¥TpX-command to load a IXTEX-package that handles lan-
guage issues. The default is the ITEX-command \usepackage{babel} that loads
the package babel.!

The babel translates in the background automatically text labels of documents
to the document language. A text label is for instance the word “Table” at the
beginning of every table-caption.

Command start When a special BTEX-package is needed to write in a certain doc-
ument language, you can here specify the command to start the package. An
example is the start command \begin{arabtext} that is needed to write Arabic
using the package ArabTgX, see [14]. The default is the babel command
\selectlanguage{$$lang}.

'For an introduction to the IXTEX-Syntax, have a look at section 6.9.
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Command end Counterpart to Command start. Some packages, like the default,

don’t have an end command since the start command toggles the package on
and off.

Use babel Whether babel is used or not.

Global When this option is set, the languages used in the document will be added as
options to the document class options, so that they can be used by all I¥TEX-
packages. Otherwise they will only be used as options for the babel package.

Auto begin When this option is set, the documents starts with the chosen document
language. When this option is not set, the Command start is explicitly set to the
beginning of the document in the I¥TEX-output. This assures that the correct
language is used when you use another Command start than the default.

Auto end Counterpart to Auto begin. When it is not set, the Command end is set to
the end of the document.

Mark foreign languages Text marked formatted in a language different from the
document language will be underlined blue.

Right to left language support Enables the use of languages, written from right to
left, like Arabic, Hebrew, Farsi.

B.4.2. Spellchecker

The spellchecker settings are explained in section 6.11

B.5. Outputs

B.5.1. Printer

Default printer Here you can specify the name of your default printer. The name
will be used when the Printer command is executed.
Note: You can leave this field empty on Windows systems because it has
there no effect.

Adapt output to printer This option works only for the Printer command “dvips”. It
activates a configuration file for dvips. This is an option only for dvips experts.

Printer command is the command IyX / ETEX uses for printing. The default is on
most systems dvips.

Printer Command Options Here you can specify printer options. A list of printer
options with explanations can be found in the documentation of the program
that provides the Printer command you are using.
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B.5.2. Date Format

The date format can be one or a mixture of the formats listed here:
http://unixhelp.ed.ac.uk/CGI/man-cgi?date

For example the format

%d/%m /%y

prints the date as day/month/year.

B.5.3. Plain Text

Output line length sets the maximum number of characters printed in one line when
using the menu File> Export>Plain text. Setting the line line length to 0 means
all text is printed in one endless line.

roff command defines an additional command used to produce better ASCII tables
with the groff/troff/nroff UNIX-commands (refer to their manuals for more
information about them). Setting this as empty tells IxyX to use the internal
formatter.

B.5.4. LaTeX

TeX encoding This is the default encoding of the document font. T1 is the default
and covers western languages and symbols. T2A, T2B, T2C, LCY, and X2 are
for Cyrillic. Combinations of the encodings are possible, like "T1, T2B”. The
font encoding is normally automatically loaded by the language packages I X
sets up in the background. So there is no need to change the default encoding.

Default paper size This is the paper size that is used for new documents. The
Default value depends on your BTEX-system setup.

Reset class options when document classes changes Removes all manually set doc-
ument class options in the Document > Settings dialog when changing the docu-
ment class.

In the External Applications field you can specify commands with parameters for the
listed applications. Before you change something here, it is strongly recommended to
read the manuals of the applications. Currently the following commands can be set:

CheckTeX command Command for the program CheckTEX that is described in sec-
tion Checking TpX of the Extended Features manual.

BibTeX command Command for the program BibTEX that generates the bibliogra-
phy, see section 6.5.1.

Index command Command for the program that generates the index, see section 6.6.6.

DVI viewer paper size options They only have an effect when the program xdvi is
used as DVI-viewer.
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B.6. Converters

B.5.5. Paths

The submenu Paths is only available in the Windows version of IyX. The option Use
Windows-style paths in IKTEX files uses the Windows path style:

C:\test\ hello

instead of the Unix path style:

C:/test/hello

B.6. Converters

Here you find the list of defined converter commands to convert material from one
format to another. You can modify them or create new ones. To modify a converter,
select it, change the entry of the field Converter and/or Extra flag, and press the
Modify button. To create a new converter, select an existing one, select a different
format in the From format drop-down list, modify the Converter field, and press the
Add button.

When the Converter File Cache is enabled, conversions will be cached as long as
specified in the field Maximum Age (in days). This means that images don’t need
to be converted again when you reopen a document; the converted images from the
cache will be used instead.

More about converters, like the variables and flags that can be used in the converter
definition, is described in section Converters of the Customization manual.

B.7. File Formats

Here you find the list of defined file formats that I57X can handle. You can modify the
viewer and editor program that should be used for certain formats. To create a new
format, select an existing one, change the entry of the fields Format and GUI name,
and press the Add button.

More about formats, like the options that can be used in the format definition, is
described in section Formats of the Customization manual.

B.8. Copiers

Here you find the list of defined copiers. Since all conversions from one format to
another take place in Iy X’s temporary directory, it is sometimes necessary to modify
a file before copying it to the temporary directory in order that the conversion may
be performed. This is done by a Copier.

More about converters is described in section Copiers of the Customization manual.
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C. Units available in LyX

To understand the units described in this documentation, C.1 explains all units avail-
able in IyX.

Table C.1.: Units

unit ‘ name/description
mm millimeter
cm centimeter
in inch
pt point (72.27pt = 1in)
pc pica (1pc = 12pt)
sp scaled point (65536 sp = 1pt)
bp big point (72bp = 1in)
dd didot (72dd = 37.6 mm)
cc cicero (1cc = 12dd)
Scale% % of original image width
text% % of text width
col% % of column width
page% % of paper width
line% % of line width
theight% % of text height
pheight% % of paper height
ex height of letter x in current font
em width of letter M in current font
mu math unit (1mu = 1/18 em)
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The bibliography on the following page was created with the Bibliography environ-
ment.
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a dummy entry for the character a, page 88
C Control key, page 6

Esc Escape key, page 6

M Meta or Alt key, page 6

S Shift key, page 6

Tab Tabulator key, page 6

o dummy entry for the character sigma, page 88
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Dummy entries
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maitre, 87

old-style page number:, 87
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Editing, 4

EPS, see Image formats
ERT, 90

External Material, 105

File formats, 47, 123
ASCII, 47
DVI, 47
LaTeX, 47
PDF, 48
PostScript, 47
File Operations, 3
Find, 4
Floats, 62
Algorithm floats, 64
Captions, 62
Figure floats, 63
Placement, 66
Rotating, 65
Table floats, 64
Text Wrap Floats, 65
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Screen, 119
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Image formats, 57
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Cross referencing, 86
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Program, 87
Index generation, 85
Instant preview, 92
International support, 95
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Key Bindings, 6
Keyboard Map, 119

Language
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Options, 96
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Settings, 120
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LaTeX-packages

aeguill, 42

amsmath, 111

babel, 50

caption, 91, 129

CJK, 111
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dvipost, 95
esint, 111
fancyhdr, 12, 129
inputenc, 109, 111
jurabib, 111
natbib, 111
nomencl, 87, 129
prettyref, 82
preview-latex, 92
pstricks, 47
setspace, 14
tipa, 104, 129
wrapfig, 65, 129
Letters, 24
Ligatures, see Typography
Linebreaks, 38
Lists, 20
Description, 22
Enumerate, 21
Itemize, 20
LyX list, 23
Longtables, 59
Caption, 106
LyX
Basics, 9
Proper names, 52
Reconfigure, see Reconfigura-
tion of LyX

Marginal notes, 56

Margins, 13

Math, 69
Accents, 72
AMS, 79
Arrays, 74
Basics, 69
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Font sizes, 78
Formula numbering, 75
Fractions, 70
Functions, 72
Grouping, 73



Integrals, 71
Limits, 71
Macros, 76
Matrices, 74
Multi-line Equations, 74, 79
Navigating, 69
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Roots, 71
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Subscripts, 70
Sums, 71
Symbols, 71
Text, 78
Typefaces, 77
Menu
Document, 107
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Help, 112
Insert, 103
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View, 103
Minipages, 68
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Nesting
Environments, 27
Examples, 31
Tables etc., 29
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Layout, 88
Options, 88
Printing, 89
Sort order, 88

Notes, 55

Outline, 82

Pagebreaks
Clear, 38
Forced, 38
Paragraph
Environments, 14
Indentation, 13

Index

Line spacing, 14
LyX code, 26
Separation, 14
Settings, 102
Verse, 19
Paragraph environments, 14-27
Paste, 4
Paths, 119, 123
PDF, 48, 58
Phonetic symbols, 104
PNG, see Image formats
Poetry, 19
Preferences, 2, 117
Printer, 121
Program listings, 107
Punctuation marks, 50

Quotation, 19
Quotes, see Typography

Reconfiguration of LyX, 2, 101, 103,

112
Redo, 5
Replace, 4

Section headings, 16
Numbered, 16
Short titles, 18
Unnumbered, 17

Settings
Color, 119
Date format, 122
Directory, 119
Graphics, 119
Keyboard Map, 119
Language, 120
LaTeX, 122
Paths, 123
Printer, 121

Spaces, 39
inter-word, 39, 51
protected, 39
thin, 39, 51

Spell checking, 93

SVG, see Image formats
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