]> git.lyx.org Git - lyx.git/blob - src/mathed/math_symbolinset.h
rename MathBigopInset into MathSymbolInset. That's what it is nowadays...
[lyx.git] / src / mathed / math_symbolinset.h
1 // -*- C++ -*-
2 #ifndef MATH_SYMBOLINSET_H
3 #define MATH_SYMBOLINSET_H
4
5 #include "math_inset.h"
6
7 struct latexkeys;
8
9 /// big operators
10 class MathSymbolInset : public MathInset {
11 public:
12         ///
13         explicit MathSymbolInset(latexkeys const *);
14         ///
15         MathInset * clone() const;
16         ///
17         void write(std::ostream &, bool fragile) const;
18         ///
19         void writeNormal(std::ostream &) const;
20         ///
21         void metrics(MathStyles st);
22         ///
23         void draw(Painter &, int, int);
24         ///
25         bool isScriptable() const { return true; }
26 private:
27         ///
28         latexkeys const * sym_;
29         ///
30         string ssym_;
31         ///
32         MathTextCodes code_;
33 };
34 #endif