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1. Introduction

This document explains [y’X’s math features and is furthermore a collection of KTEX-
commands used for mathematical characters and constructs. The explanations are
designed for the usage of commands. It is therefore required that you have read the
section Mathematical Formulas of the User’s Guide.

Most of the characters and many constructs explained in this manual are also ac-
cessible via the menu Insert>Math or the math toolbar. But everybody who has to
write lots of formulas will notice that it is much faster to use commands instead of
the math toolbar. Therefore this manual is focused on commands but also mentions
the corresponding toolbar buttons when available.

If not specially mentioned the commands are only available within formulas. To be
able to use all commands explained in this document, the option Use AMS math pack-
age must be checked in the document settings (menu Document > Settings>Math Op-
tions).4

This document doesn’t list all Ap4S-math commands® for lucidity reasons.

2. General Instructions

To create an inline formula that is embedded into a text line, use one of the shortcuts

Ctrl4+M, Alt4+C M, Alt+M M or the toolbar button Z

To create a display style formula which will appear bigger, has a different format,
and will be in a separate paragraph, use one of these shortcuts: Ctrl+Maj+M, Alt+M
D.

To change a display style formula to an inline formula, set the cursor into the formula
and use one of the shortcuts Ctrl4+-M, Alt4+-C M, Alt+-M M or the menu Edit> Math>
Change formula type. The same way is used to change an inline formula to a display
style formula.

To display parts of an inline formula in the size of a display style formula, enter the
command \displaystyle to a formula. Then a new blue box appears in which the
desired formula part is inserted.

Only inline formulas are allowed inside tables.

The math toolbar can be turned on in the menu Viewr Toolbars. When you click
there on “Math” the toolbar will be shown permanently at the bottom; this state is
visualized in the Toolbars menu with a checkmark. When you click in this state again

4The option Use AMS math package automatically only uses Ap4S-math when math constructs are
found that are supported by LyX.

A list with all ApS-math commands is in the file amsguide.pdf, which is part of every I4TEX
standard installation.


https://www.ctan.org/tex-archive/macros/amstex/doc/amsguide.pdf

on “Math” in the Toolbars menu, the math toolbar is only shown when the cursor is
within a formula; this state is visualized by the renaming of the menu entry from
“Math” to “Math (auto)”.

The TEX mode is invoked by pressing the toolbar button % or by using the menu
Insert>TeX Code (shortcut Ctrl+L).

To change the KTEX-preamble, use the menu Document > Settings>LaTeX Preamble.

To edit matrices, case differentiations and multiline formulas subsequently, use the
menus Edit>Math and Edit>Rows & Columns, or the table toolbar. When lines and
columns are swapped via the menu, the column or line where the cursor is in is
exchanged with the column to the right or the line below, respectively. Is the cursor
in the last column or row, the exchange is done with the column to the left or the
line above.

To write text in formulas® mathematical text is used. This mode is invoked with the
shortcut Alt+C Espace or by the insertion of the command \text. The text appears
black in IyX and can therefore be distinguished from the other formula parts which
appear blue. In the output mathematical text is set upright, in contrary to other
formula parts.

Command Scheme

Most of the ITEX-commands for math constructs have the following scheme:
\commandname|optional argument|{required argument}

A command always starts with a backslash ,\“ To omit optional arguments, also
omit the associated brackets. The braces around the required arguments are named in
this document as TEX braces. If you add in a formula a left brace to a command name,
LyX automatically creates a TEX brace. In all other cases TEX braces are created
in formulas with the command \{. TEX braces appear red in LyX, in contrary to
normal braces which appear blue. In TEX mode no command is needed to get TEX
braces. TEX braces don’t appear in the output.

When commands without arguments, like commands for symbols are entered in TEX
mode, a space character must always be behind the command to end it. This space
doesn’t appear in the output. When the space should appear in the output, the space
must be followed by a protected space in normal text.

A protected space is inserted with indéfini.

6For multiline formulas the command \intertext is used, see sec. 18.7.



Syntax Explanation

e The symbol |, denotes a space character to be input.

o An arrow like — denotes the usage of the corresponding arrow key on the

keyboard. The Tab key can often be used instead of — and |, and Shift+Tab
instead of <+ and 1.

Available units

Table 1: Available units

Unit Name / Description
mm Millimeter

cm Centimeter

in Inch (1in = 2,54 cm)

pt Point (72.27pt = 1in)

pc Pica (1pc = 12pt)

sp scaled point (65536 sp = 1pt)
bp big point (72bp = 1in)
dd Didot (1dd = 0.376 mm)
cc Cicero (1cc = 12dd)

ex  Height of letter “z” in the current font
em  width of letter “M” in the current font
mu math unit (1 mu = /1sem)




3. Basic Functions

3.1. Exponents and Indices

Indices are created with an underscore “_” or via the math toolbar button Dn, expo-
nents with a caret “~” or via the math toolbar button O

Command Result

B_V By
BV BY
B™ A BA

As the caret is in some languages an accent, vowels will be accentuated in this case
and not set as exponents’. To get exponents in this case, press Space after the caret
as in the last example.

3.2. Fractions

Fractions are generated with the command \frac or via the math toolbar button
5. The font size is adjusted automatically, depending on whether the fraction is in
=y

an inline or display style formula. With the math toolbar button & you can select
different fraction types.

With the command \dfrac a fraction can be created that always has the size of a
display style formula. With \tfrac the fraction appears always with the size of an
inline formula. An example:

A line with the fraction % that was created with the command \frac.

1
A line with the fraction 3 that was created with the command \dfrac.

Command Result
\frac A|B 4
A
\dfrac A|B 5
1
\dfrac e \frac 1{2]]3 %

"Depending on the used keyboard settings this can also happen for characters other than vowels.



For nested fractions the command \cfrac can be used. Here is an example:

created with \frac created with \cfrac
A A
B —
B+ “5F c+ L
F
B+ I
* D

The command for the example above is:

\cfrac A|B+\cfrac C+\cfrac E|/F|D

\cfrac sets the fraction always in the size of a displayed formula, also when it is part
of another fraction.

It is possible to specify the alignment of the numerator. The command \cfracleft is
used to left align it, the command \cfracright to right-align it. \cfrac centers the
numerator. These fractions demonstrate the different alignments:

A A A
B+C " B+C  B+C

Note: \cfracleft and \cfracright are no real KTEX commands but represent the
command \cfrac[alignment]|{numerator}{denominator} . Therefore you can-
not use them in TEX code.

It is often advantageous to combine \cfrac and \frac:

A

C+£
B+ _F
+ D

For inline fractions with a sloped fraction stroke you can use the command \nicefrac:
5/31 or \unitfrac: 5/31 There is furthermore the command \unitfracthree that offers
to write a fraction in combination with a number: 21/3

Note: \unitfracthree is not a real ITEX command but the command
\unitfrac[number|{numerator }{denominator} . Therefore you cannot use it

in TEX code.

How to define own fractions where the fraction stroke can be changed, is explained
in sec. 24.4.

Multiline fractions are explained in sec. 18.1.4.



3.3. Roots

Square roots are created with \sqrt or the math toolbar button \/ﬁ, all other roots
with the command \root or with the math toolbar button Gl

Command Result

\sqrt,A-B VA—-B
\root 3JA-B vVA—-B

A square root can also be created with \root when the root index field is left empty.

With certain indices the distance to the root is too small, like in this formula: /B
The S touches the root. To avoid this, the commands \leftroot and \uproot are
used with the following scheme:

\leftroot{distance} and \uproot{distance}

Distance is the number of Big Points (unit bp; 72 bp = 1inch), that the index should
be moved to the left or top, resp.. The commands are written to the index. This way
the command

\root\leftroot{-1—\uproot{2—\beta ,—B

produces a correct typeset formula: VB

3.4. Binomial Coefficients

Binomial coefficients are inserted with the command \binom or with the submenu of
the math toolbar button ¥. As with fractions (\frac) in addition to \binom there
are the commands \dbinom and \tbinom. For other brackets around binomial
coeficients there are the commands \brace and \brack.

Command Result

\binom, A|B (g

Sy

)
\dbinom, A|B <A>
)
]
j

\tbinom, A|B (

\brack A|B [
\brace A|B {

e W e




3.5. Case Differentiations

Command Result

\cases A—B>0 {A B >0

A forz>0

\cases, ,Ctrl+Retour
B forx =0

After inserting \cases or pressing the math toolbar button {8 you can create new
lines with the shortcut Ctrl+Retour or the table toolbar button E=.

The command \cases is also available via the menu Insert > Math > Cases-Environment.

3.6. Negations

By inserting \not every character can be displayed canceled. The characters are
quasi accentuated by a slash.

Command Result

\not= #
\not \le L
\not \parallel ¥

The last example shows that not all negations look good. Therefore there are special
commands for some negations (see sec. 13.1 and sec. 14).

3.7. Placeholders

When displaying e. g. isotopes® the following problem occurs:

Indices created with sub- and superscripts: §°F

correct indices: F

The shorter index is by default placed below or above the first character of the longer
index. To avoid this there is the command \phantom or the math toolbar button ?
blue box appears that is superposed with two red arrows. The arrows indicate that
the complete width and height of the box content will be created as placeholder.
Phantom characters are accordingly placeholders with the size of the characters.

8Typesetting isotopes and chemical symbols is described in sec. 20.

9can be found in the submenu of the toolbar button e



Command Result

19, \phantom, 1—9 F F
7235, \phantom, 23—9 F 20F

\Lambda™ \phantom, ii—t _ MMt A,},,,

Furthermore there are the commands \ vphantom (toolbar button :Li) and \hphan-
tom (toolbar button ¥2). \hphantom creates only space for the maximal height of
the characters in the box but not for its width. \vphantom creates only space for
the width of the box content. Therefore the boxes of both commands have only one

red arrow.

For example the command \vphantom, a\int creates space for the height of the
integral sign,'” because this is the larger character. An example application is in
sec. 18.1.5.

Placeholders can also be used for text when they are inserted via the menu Insert>
Formatting > Phantom:

This is a sentence.
is a sentence.

3.8. Lines
Command Result
\overline A+B A+ B
\underline A+B A+ B

Sy

\overline \underline A+B A+

In the last example it doesn’t matter if first \overline or \underline is inserted.
To double underline use \underline twice.

It is possible to place up to 6 lines above or below characters.

Custom lines can be created using the command \rule which has the following
scheme:

\rule[vertical offset]{length}{thickness}

The optional vertical offset shifts the line upwards (or downwards, when the value
is negative). The units listed in Table 1 can be used for the values. Here are two

10The command \int creates an integral sign, see sec. 10.1.



example lines created with the commands
\rule[-2ex]{3cm}{2pt} and \rule{2cm}{1pt}:

This is a sentence _ with two lines.

\rule can also be used for text when a line is inserted via the menu Insert > Formatting >
Horizontal Line:

This is a sentence with one line.

3.9. Ellipses

There are different types of ellipses available.!! For listings dots at the baseline are
used (\ldots), while for operations dots are needed that are on the same height as
the operators (\cdots). When using the command \dots, XTEX decides on the basis
of the next character what type is used.

Command Result
Ailu,\dOtSL,Ain Al, . 7An
A_1, +\dots +A_n A +---4+ A,
A 1, \ldots ,A n A, A,
A 1 +\cdots +A_n A+ -+ A,
\vdots
\ddots
\iddots

A o A
3x 3 matrix with the different dots : .
A - Anm

The ellipses available in menu Insert>Special Character are \ldots.

To use \iddots, one of the options Use mathdots package (automatically) must be set
in the document settings under Math Options.

Using the option Use mathdots package will improve the appearance of all dots in the
documents if their font style or size is not the default.

Specially for matrices there are ellipses that span over several columns. They are
created with the command \hdotsfor, that has the following scheme:

HTp the math toolbar in the submenu of the button ...



\hdotsfor[distance]{number of columns}

The number of columns specifies how many columns should be spanned. Distance is
a factor for the distance between the dots.

In the following matrix the command \hdotsfor[2]{4} was inserted in the first box
of the second line, to get an ellipsis with a dot distance twice as long as with the
command \dots:

q w e T

Note that the matrix fields that should be spanned must be empty, otherwise you
get N TEX-errors.

Furthermore you can fill with the command \dotfill the rest of a line with dots. The
effect of these commands is the same as with \hfill, see sec. 8.2.

For example the command A\dotfill, B produces

A B
Similar to \dotfill there is for a line the command \ hrulefill:
A B

To use the commands for text, they have to be inserted in TEX mode.

4. Matrices

Matrices can be inserted via the math toolbar button && or the menu Insert>Math >
Matrix. In the matrix dialog you can specify the number of columns and rows, the
alignment and the decoration. The vertical alignment is only of importance for
matrices in inline formulas:

The first matrix is top , the second middle and the

QT =
blcle)
~ T Q
=~ =

A D G J
B F H K
third bottom C F I L aligned.

The horizontal alignment specifies how the column entries should be aligned. It is set
by entering a letter for every column. [ denotes left aligned, ¢ centered and r right
aligned. To create for example a 4x4 matrix where the first column is left aligned,
the second and third are centered and the last one is right aligned, one enters for the

10



horizontal alignment lccr. Normally in a matrix all columns are centered, therefore
the default for every column is a c.

Horizontal alignment:

10000 D G 10000 D G 10000 D G
n: B 10000 H , CCC : B 10000 H ,rrr: B 10000 H
C F 10000 C F 10000 C £ 10000

To add or delete rows and columns subsequently, the math toolbar buttons R, B,
etc., or the menu Edit> Rows & Columns can be used. New rows can also be created
with Ctrl+Retour.

The Decoration adds parentheses in the selected style around the matrix. Alterna-
tively, parentheses can can either be created with the commands \left and \right
(shortcut Alt+M Parenthesis), see sec. 5.1.2, or by using the following commands:

Command Result Command Result

. ) 0 -i . . 0 -1

\bmatrix 2 X2 matrix 0 \vmatrix, 2 X2 matrix 0
i i

) ) 0 -1 ) ) 0 -i

\Bmatrix, 2 X2 matrix - \ Vmatrix, 2 X 2 matrix -
i i

\pmatrix 2 X 2 matrix ( O 3 ) \matrix, 2X 2 matrix 8
i i

When e. g. \vmatrix is inserted, a blue box appears between two vertical lines where
the matrix is inserted.
Note that decorated matrices ignore the vertical alignment.

As all multiline formulas are matrices, the length \arraycolsep that is described in
sec. 18.1.2 can also be used to change the column separation of matrices.

To change the row separation, the command \arraystretch is used. It is used as
follows:

\renewcommand{\arraystretch}{stretch factor}

The command \renewcommand assigns the stretch factor to the predefined com-
mand \arraystretch. To double e.g. the row separation, use the factor 2. This is
then used for all following matrices. To go back to the original separation, assign the
factor 1 to \arraystretch.

To set matrices into a text line, the command \smallmatrix is used. When it is
inserted a blue box with two dashed lines appears. In this box the matrix is inserted.

This is a matrix (4 B) in a text line.

11



5. Brackets and Delimiters

5.1. Vertical Brackets and Delimiters

Command Result Command Result

( ( ) )

{ { } }

[ [ ] ]
\langle ( \rangle )
\lceil [ \reeil 1
\lfloor | \rfloor |

/ { \\ \

| \l I

Note: In TEX mode the command \textbackslash must be used for the backslash,
because the command \\ produces a line break there.

For all characters listed above the size can be adjusted with the commands described
in the following two subsections. When using these commands, the characters < and
> can directly be used instead of the commands \langle and \rangle.

5.1.1. Manual Bracket Size

The bracket size can be specified manually by the ETEX-commands \big, \Big,
\bigg and \Bigg. \big denotes the smallest and \Bigg the largest bracket size.

These commands are used to emphasize levels of brackets:

all brackets in the same size: ((A+ B)(A — B))“

c
this looks better: <(A + B)(A— B)>

For the second formula the command \Big((A+B)(A-B)\Big) " C has been used.

Here is an overview about all bracket sizes:

\Bigg(\exp\bigg<\Big[\big{\In(3x)\big} "2 \sin(x)\Big|] " A \bigg>\Bigg) 0,5

(exp < [{ In(3x)}” sin(x)} A>)

0,5

12



Besides the \big-commands there is the variant \bigm that adds a bit more space
between the bracket and its content, and the variant \bigl-\bigr, that don’t add
additional space. The [ at the end of the command \bigl is for a left bracket; for
a right bracket this will be replaced by an r. A left or right bracket can each be an
opening or closing bracket.

In the following table is a comparison of the variants:

Command Result
\Bigm (\bigm(\In(3x)\bigm) "2 \Bigm) ~((n(37) )°)
\Big(\big(\In(3x)\big)"2 \Big) (( 1n(3x))2)
\Bigl(\bigl(\In(3x)\bigr)"2.\ Bigr) ((1n(3a;))2>

\bigl)\In(3x)\bigr( )in(3z)

5.1.2. Automatic Bracket Size

Brackets with variable size can be inserted with the commands \left and \right
or via the math toolbar button [0l Directly behind \left and \right the wanted
bracket must be inserted. The bracket size will then automatically be calculated for
the output.

normal bracket: The command \In(\frac ;,A|C,)) creates

multiline bracket: The command \In\left(\frac,, A]C \right) creates

()

Instead of \left and \right the shortcut Alt+M Bracket can be used. This has the
advantage that you can see in LyX immediately the real bracket size and that the

matching right bracket will be created too.
The command for the last example would then be: \In Alt+M (\frac ,A|C

To omit a left or right bracket, a dot is inserted for the omitted bracket. For example
the command \left.\frac ,A|B \right} creates:

5!

13



The commands \left and \right will be converted by IyX to brackets in the right
size when the document is reloaded and an omitted bracket will appear as dashed
line.

Because all popular BTEX distributions use eTEX, an extension to KIEX, the com-
mand \middle is additionally available for all brackets and limits. With this com-
mand the height of the following character is adapted to the one of the surrounding
brackets, what is e. g. needed for physical vectors:

(] =33

For physical vectors there is a special I TEX-package, described in sec. 24.3.

5.2. Horizontal Brackets

Command Result
——
\overbrace A+B, "3 A+ B
\underbrace A+B,_5 A+ B
5
——
\overbrace \underbrace A+B_w. ., 7., . C A+ B,
———

7

In the last example it doesn’t matter if \overbrace or \underbrace is inserted at
first.

If you set in the document settings under Math Options for the package mathtools
the option Load always, you have access to square backets:

Command Result

;l

\overbracket{ A+B "3 A+ B

\underbracket{ A+B,_5 A+ B
5

|L|

\overbracket{\underbracket{A+B_w,, 7., . C A+ B,
7

For \overbracket and \underbracket you can change the thickness of the bracket’s
stroke by specifying the desired thickness in square brackets behind the command:

14



Command Result

—

\overbracket[3pt|\{A+B, "3 A+ B

\underbracket[1pt\{A+B, 5 A+ B
5

When brackets should overlap each other, multiline formulas, as described in sec. 18,
must be used:

A = gggg+ bbgq+ dddd
—_——

r

| ——
s

In the first row the formula is inserted together with the first brace. It is hereby
important that the space command'? \: is inserted before the first d, because the
brace that ends behind the ¢ prevents that the following “+” is surrounded by space.!?
In the second row the second brace is inserted. As it should begin before the b, first
the command \hphantom{gggg+\:} is inserted.!* This space is needed because
the “+” is also surrounded by space in the formula. The brace is placed under the
command \hphantom{bbqq+dddd}.

It gets more complicated when brackets overlap each other above and under the
formula, like in the following example:

s

——N—
A = gggg + bbqq + dddd
N————

r

The first formula row is the same as the second row of the previous example, with
the difference that the brace is above. The second row contains the formula together
with the second brace. To avoid that there is space between the upper brace in the
first row and the formula, the row spacing needs to be reduced. This is not easily
possible due to a bug in IyX.' As a solution for the problem, the global formula
row separation \jot must be changed to -6 pt before the formula with the command
\setlength{\jot}{-6pt} in TEX mode. \jot is set back after the formula to the
standard value of 3pt using the same command. More about the row separation in
formulas is explained in sec. 18.1.1.

128pace commands are explained in sec. 8.1.
Bhecause a bracket is not handled as a character, see sec. 10.4
Mmore about \hphantom see sec. 3.7

LyX-bug #1505
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6. Arrows

Arrows can be inserted via the math toolbar button « or the commands listed in
the following subsections.

6.1. Horizontal Arrows

Command Result Command Result
\gets — \to —
\ Leftarrow = \Rightarrow =
longleftarrow — longrightarrow —
\long grig
\Longleftarrow — \Longrightarrow —
\leftharpoonup ; \rightharpoonup —
\leftharpoondown \rightharpoondown — —
\hookleftarrow «— \hookrightarrow —
C d Result
orman e Command  Result
\leftrightarrow “ \mapsto R
\Leftrightarrow & P
. \longmapsto ~ —
\longleftrightarrow  +—
\Longleftrightarro = \leadsto -
ngleftrightarrow
& & \dasharrow  --»

\rightleftharpoons =

Arrows used as accents like e. g. vector arrows are listed in sec. 7.

Furthermore there are the labeled arrows \xleftarrow and \xrightarrow. When
inserting one of these commands in a formula, an arrow with two blue boxes appear
where the label can be inserted. The length of the arrow adapts to the label width.

Command Result

F(a)\xleftarrow, x=a|x>0—F(x) F(a) <x—zg F(x)

F(x)\xrightarrow, x=a|x>0—F(a) F(z) — F(a)

>0

If you set in the document settings under Math Options for the package mathtools
the option Load always, you have access to the following labeled arrows:
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Command Example Command Example

\xleftrightarrow &8 \xleftharpoondown %
r=a =

\xLeftarrow &0 \xleftharpoonup /i—iz
r=a =

\XRjghtarrow % \xrightharpoondown %
r=a =

: 0

\xLeftrightarrow <= \xrightharpoonup %
r=a —

. >0

\xhookleftarrow &L \xleftrightharpoons ;:T
r=a _

\xhookrightarrow 28 \xrightleftharpoons g

r=a r=a

The command scheme is for all these arrows:

Command Result

F(a)\xleftrightarrow[x=a]\ {x>0—F(x) F(a) &> F(x)

r=a

6.2. Vertical and diagonal Arrows

Command Result
Command Result
\uparrow 0
\ Uparrow 0 \nearrow Ve
\updownarrow ) \searrow N
\Updownarrow (x \swarrow v
\Downarrow (8 \nwarrow N
\downarrow {

Vertical arrows can be used also as delimiters together with the commands described
in sec.5.1.1 and sec. 5.1.2.

7. Accents

Accents can be inserted via the math toolbar button i.i or the commands listed in
the following subsections.
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7.1. Accents for one Characterl®

Command Result

Command Result

\dot, A A . .
\ddot. A i \tilde A A
L A
hat A A
\dddot, A A \haty .
\ddddot, A A \checkA A
\wee A 1 \acute A A
Ve, N
\bar A i \grave, A A
. . breve A A
\mathring, A A \

You can directly insert accents like é to formulas. IyX will transform them to the
corresponding accent command. For umlauts it is better to insert a quotation mark
before the vowel. These two characters are then treated by KTEX as one character
when the formula part with the umlaut is marked as German. In contrary to \ddot,
with this method “real” umlauts are created as demonstrated in the following exam-
ple:

Command Result

(Li

i

\ddot, i i

Another advantage to \ddot is that umlauts can directly be converted to mathemat-
ical text because the accent commands above are not allowed in mathematical text.
To convert an accented character to mathematical text, only the character under the
accent may be converted. This applies also for all other conversions, e. g. to italic or
bold.

In mathematical text, umlauts and other accented characters can directly be inserted.

LyX also supports a tilde under the character if the KIEX-package undertilde is
installed on your system:

You need to install the WTEX-package undertilde to see the rest of this subsection
in the output.

16accents in text see sec. 16.2
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7.2. Accents for several Characters

Command Result Command Result

|
1

\overrightarrow  A=B

\underrightarrow A=B A = B
\widetilde A=B A= B

\underleftrightarrow A=B A = B \widehat A=B A=RB

\overleftarrow, A=B

d

\underleftarrow, A=B

1]

\overleftrightarrow, A=B

With these commands as many characters as you like can be accented. But the
accents \widetilde and \widehat will only be set in the output with a length of
three characters, as shown in the following example:

A+B=C-D

With the commands \overset and \underset described in the previous subsection
it is also possible to accent several characters. The command \underset, ,A=B]***
creates:

A=DEB

koK

8. Space

8.1. Predefined Space

Sometimes it is necessary to insert horizontal space into a formula. This is done by
inserting a protected space (shortcut indéfini). A “ ” appears and by pressing Space
several times one can select one of eight different space sizes. The spaces can also be
inserted using the math toolbar button sa or special commands. Independent from
the inserted command, one can select the size again by pressing Space afterwards.

Command  Number of Result Command Number of  Result
Space Space
keystrokes keystrokes

\, 0 AB \hfill 5 A B

\: 1 AB \hspace*{lem} A B

\; 2 AB \hspace{lem} 7 A B
\quad 3 A B \i 8 AB
\qquad 4 A B \! 9 AB
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Space 5—7 are variable spaces which are explained in sec.8.2. Space 9 seems to
produce no space. It is displayed red in LyX contrary to the other sizes, because it
is a negative space. There are two more negative spaces:

Command \negmedspace \negthickspace

Number of Space keystrokes after
inserting the protected space

Result AB AB

10 11

Negative spaces can lead to characters overlapping each other. Thus they can be
used to enforce ligatures, which are e. g. useful for summation operators:

Command Result

\sum\\sum, f_kl > fu
\sum\negmedspace\sum, f kI >3 fu

Relations like for example equal signs, are always surrounded by space. To suppress
this, the equal sign is placed into a TEX brace. The following example demonstrates
this:

normal equation A=2RB
equation without space ~A=B

The command for the last formula is: A\{=—B

Spaces are needed for physical units, because the space between the value and the
unit is the smallest one and not a normal space. For units in text, the smallest space
is inserted via the menu Insert> Formatting > Thin Space (shortcut Ctrl+Maj+Espace).

An example to visualize the difference:

24 kW-h space between value and unit
24kW-h  smallest space between value and unit

8.2. Variable Space!’

Space with a defined length can be inserted with the command \hspace. Then a
long “ 7 appears. The length can be specified by left-clicking on the “ ”. The length
may also be negative. When a space would be the first character in a line it would
be omitted. To force its output use the command \ hspace* instead of \hspace or
left-click on the “ 7 and check the option Protect.

To insert as much space as is available, the command \ hfill is used.

7for vertical space in formulas see sec. 18.1.1
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Command (\hspace length) Result

A=B\hspace A\not=C (3cm) A=B A#C
A\hspace, A\not=A (-1 mm) AM#£A
A=A\hfill B=B A=A B=20B

In the last example the available space is given by the longest column entry of the
table. In an inline formula the space depends on the length of the line in which \ hfill
is inserted. Thus, when the line uses the full width, no space will be created. \hfill
only has an effect on displayed formulas when the formula style Indented is used.
(Formula styles are explained in sec. 17.)

Besides \hfill, there are the commands \dotfill and \hrulefill that fill the space

with a pattern, see sec. 3.9 for an example.
For text, variable space can be inserted via the menu Insert > Formatting > Horizontal Space:
This is a line with 2 cm space.

This is a line with maximum space.

8.3. Space besides inline Formulas

The space that surrounds inline formulas can be adjusted with the length \math-
surround. The value of a length is set with the command \setlength which has
the following scheme:

\setlength{length name}{value}

To set \mathsurround to the value 5 mm, the command
\setlength{\mathsurround }{5mm}

is inserted in TEX mode. 5 mm space will now be set around all inline formulas:
This is a line with an inline formula A =B  with 5mm surrounding space.

To return to the predefined value, \mathsurround is set to the value 0 pt.
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0. Boxes and Frames

Boxes for text are described in chapter Boxes in the Embedded Objects manual.

0.1. Boxes with Frame

It is possible to frame a formula or part of one with the commands \fbox and
\boxed.

When one of these commands is inserted in a formula, a blue box appears within
a frame to enter formula parts. For \fbox an additional formula has to be created
by Ctrl+M within this box, because the box content will otherwise be treated as
mathematical text. When \boxed is used, a new formula is automatically created
inside the frame.

The command \fbox is not suitable to frame displayed formulas because the formula
will always be set in the size of the text. \boxed is in contrary not suitable to frame
inline formulas, because the formula will always be set in the size of a displayed
formula.

An extension to \fbox is the command \framebox where additionally the frame
width and the alignment can be specified. \framebox is used in the following scheme:

\framebox[frame width][position]{box content}

The position can either be [ or r. [ left aligns, r right aligns the formula in the box.
When no position is given, the formula will be centered.

If no width is given, also no position can be given. In this case the frame width is
adjusted to the box content like for \fbox.

When the command \framebox is inserted, a box appears containing three blue
boxes. The first two boxes are surrounded by brackets and denote the two optional
arguments. The third box is for formula parts like for \fbox.

Command Result
\boxedu\intLA:B /A =B
A+\fbox, B A+
\framebox 20mm——Ctrl+M \frac A|B 4

The frame thickness can also be adjusted. To do this the following commands have
to be inserted in TEX mode before the formula
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\fboxrule “thickness” \fboxsep “distance”

“distance” specifies the minimal distance between the frame and the first character
in the box. An example for this is the following framed formula:

Before this formula the commands

\fboxrule 2mm \fboxsep 3mm

were inserted in TEX mode. The given values are used for all following boxes.
To return to the standard frame size, the command

\fboxrule 0.4pt \fboxsep 3pt

is inserted in TEX mode before the next formula.

0.2. Boxes without Frame

For boxes without a frame there are the following box commands: \mbox, \make-
box and \raisebox

With \raisebox a box can be super- or subscripted. But in contrary to normal
super- and subscripting, the characters in the box keep their font size. \raisebox is
used in the following scheme:

\raisebox{height }{box content}

When the box should contain a formula, an extra formula is needed like for \fbox.
Note: For \raisebox this extra formula is created by pressing Ctrl+M twice instead
of once because LyX doesn’t yet support \raisebox directly.

Command Result
H\raisebox{2mm—\{al— lo 10
H\raisebox{-2mm—\{al—lo H o

A=\raisebox{-2mm—\{Ctrl+M Ctrl+M \sqrt, B A = VB

The command \mbox is equivalent to \fbox and \makebox is equivalent to \frame-
box, with the difference that there is no frame.
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9.3. Colored Boxes

To be able to use all commands explained in this section, the IXTjzX-package color!®
has to be loaded in the WTEX-preamble with the line!”

\usepackage{color}

To color boxes, the command \colorbox is used in the following scheme:
\colorbox{color}{box content}

The box content can also be a box and a \colorbox can also be part of another box
(see the 2nd and 3rd example). When the box should contain a formula, an extra
formula has to be created, the same way as for \raisebox.?

One of the following predefined colors can be chosen:

black, blue, cyan, green, magenta, red, white and yellow

Command Result

\colorbox{yellow—\{A=B A=B

\colorbox{green—\{\fbox ,A=B
\fbox. \colorbox{green—\{Ctrl+M Ctrl+M \int C=D |f €' =D

\colorbox only colors the box but not the characters in the box. To color all charac-
ters, the whole formula is highlighted and the desired color is chosen in the Text Style
dialog. The dialog can be called with the toolbar button ©® or the menu Edit>
Text Styler> Customized. The formula number then has the same color as the formula.
When the formula number should get another color than the formula characters, the
color must be changed within the formula.

/A—B (1)
/A—B

18The I4TEX-package color is part of every INTREX standard installation.

19When text is colored somewhere in the document with a predefined color, IyX loads the BHTEX
package color automatically. Thus it is possible that the package is loaded twice, but this does
not cause problems.

An example:

20This also applies for the command \fcolorbox.
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Formula (1) is completely colored red.
Formula (2) was first completely colored green to set the color for the formula number.
Subsequently the formula characters were colored red.

To color the frame different than the rest of the box, the command \fcolorbox is
used in the following scheme:

\fcolorbox{frame color}{color}{box content}

So \fcolorbox is an extension of the command \colorbox. The frame width is set,
like for \framebox, with \fboxrule and \fboxsep. An example:

This formula was created with the command
\fcolorbox{cyan—\{magenta—\{A=B.

To use other colors than the predefined ones, they have to be defined first.
One can for example define the color “darkgreen” with the IXTEX-preamble line:
\definecolor{darkgreen}{cmyk}{0.5, 0, 1, 0.5}

cmyk is the color space that denotes the colors cyan, magenta, yellow and black.
The four comma separated numbers are the portion factor for the corresponding
colors of the color space. The factors can be in the range of 0-1. Instead of cmyk
also the color space rgb can be used for definitions. rgb denotes red, green and
blue, so that there are in this case three portion factors for the corresponding colors.
Furthermore there is the color space gray with one portion factor for the gray value.

As example a framed box with the new defined color darkgreen where the characters
have been colored yellow:

Self-defined colors can also be used for text with the help of the command \textcolor:
This sentence is “darkgreen”.

\textcolor is used in the scheme \textcolor{color}{characters to color}.

9.4. Paragraph Boxes

A box that can contain several lines and paragraphs, a so-called paragraph box
(parbox), can be created with the menu Insert>Box or the toolbar button [=..

The following example shows a framed parbox in a line:
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This is a paragraph box.
It is exactly 5cm long and
can also contain formulas:

[Ads=C

This is a line with a parbox.

Such a box is created by right-clicking on the gray box inset. A dialog pops up
showing the box properties. In our case set: Decoration: Rectangular box, Inner
Box: Parbox, Width: 5cm, Vertical Box Alignment: Middle

In ITEX a parbox is created with the command \parbox which has the following
scheme:

\parbox[position]{width}{box content}

The positions b and t are possible. b for “bottom” means that the box is aligned
within the surrounding text with its last line. With ¢ for “top” this is done with the
first line. When no position is given, the box will be vertically centered, see section
Bozxes of the Embedded Objects manual for examples.

To frame formulas completely, including the formula number, the formula must be set
into a parbox. To do this, the command \fbox{\parbox{\linewidth-2\fboxsep-
2\fboxrule}{ is inserted in TEX mode before the formula. \linewidth is hereby
the line width set for the document. Because the frame is outside the parbox, 2 times
the frame separation and the frame thickness must be subtracted from the line width.
To be able to multiply and subtract in arguments, the I TEX-package calc?' must be
loaded in the KTEX-preamble with the line

\usepackage{calc}

Behind the formula both boxes are closed by entering }} in TEX mode. Here is an
example:

As a parbox is used as the argument of \fbox, there is in this case no difference
between \fbox and \boxed.

Paragraph boxes are very useful to comment formulas directly. To do this, \parbox
is used in combination with the command \tag. (more about \tag see sec.19.5)

Zlcalc is part of every MTEX standard installation.
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An example of a formula commented with \ parbox:

This is a description. It
S5t — 7b = 3b is distinctly separated from
the formula and multiline.

Such a formula must be inserted completely in TEX mode because IyX does not
yet support the command \parbox in formulas. The formula is created with the
following command sequence:

The command \[5x-7b=3b\tag*\{\parbox{5cm}{ is inserted in TEX mode.??
Then the description follows as normal text and finally }}\] is inserted in TEX mode.
The commands \[ and \] hereby create a displayed formula.

The advantages of \ parbox can be seen in this example that was “commented” using
the mathematical textmode:

5r — 7b = 30This is a description. It is not separated from the formula ...

10. Operators

10.1. Big Operators

To be able to use all integral operators listed here, the option Use esint package
automatically must be set in the document settings under Math Options.

Command Result Command Result
\int Ik \sum >
\oint $ \prod I1
\ointctrclockwise ¢ \coprod 11
\ointclockwise ) \bigodot ©)
\sqint f \bigotimes ~ ®
\fint f \bigoplus @
\landupint F \bigwedge A
\landdownint 4 \bigvee V
\bigcap N \bigsqcup
\bigcup U \biguplus G

All big operators can also be inserted via the math toolbar button J .

2When the formula style Indented is used, \tag*\{ can also be replaced by \hfill. (formula
styles see sec. 17)
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The operators are called big because they are bigger than the sometimes equal look-
ing binary operators. All big operators can have limits as described in the next
subsection.

For all integral operators there is a second version available, ending in op: \intop,
\ointop etc.. These operators are different from \int etc. in the style the operator
limits are displayed, see sec. 10.2.

Advice for Integrals

The letter d in an integral is an operator, that therefore has to be set upright. This
is done by highlighting the d and using the keyboard shortcut Alt+C R?3. Finally the
smallest space is inserted before the d, as this is usual for operators. An example:
incorrect: [ A(z)dx

correct: [ A(z)dz

For multiple integrals there are the following commands:

Command Result Command Result
\iint If \iiint il
\oiint ¢ \iiiint Jin
\sqiint it \dotsint [+

10.2. Operator Limits

Limits are created by super- and subscripts:

Command Result

\prod™\infty, ,—_ 0—A(x) T[Ig° A(x)

Limits of inline formulas are set right beside the operator. Limits in displayed for-
mulas are set above or below the operator, except for integral limits.

To force that the limits are set beside the operator, the cursor is set directly behind
the operator and the limits type is changed with the menu Edit>Math> Change Limits
Type to Inline (shortcut Alt+M L). An example:

The default limits type is this:

D

2
=0 x

23Font styles see sec. 11.1
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This is how it looks when the limits type was changed to Inline:
1

szo ﬁ
For integrals, except those ending with op like \intop, \ointop etc., the limits are
by default set beside the operator. But for multiple integrals the limits are often set

below the operator. In the following example the limits type was therefore set to
Display and so set below the integrals:

// XdV = U (5)

To specify conditions for limits, the commands \subarray and \substack are used.
To create for example this expression

> kT (6)
0<k<1000
keN

the following has to be done:

First the command \sum ™ n,,__ is typed in. One is now in a blue box under the
summation operator and insert there the command \subarray,,. The blue box is
now within a purple box and now several lines can be written among each other. A
new line is created by inserting a line break (Ctrl+Retour). When now

0<k<1000 Ctrl4+Return

is typed in, a new box appears below for the new line.

The alignment of the lines can be changed to left aligned with the table toolbar or
the menu Edit>Rows &Columns. To get right alignment, \hfill , is inserted at the
beginning of the line.

The command \substack is equivalent to \subarray with the difference that the
lines are always centered.

Like in formula (6) there can be too much space beside an operator, because the
characters following the operator are set beside the limits. To avoid this the command
\smashoperator can be used. To activate it, set in the document settings under
Math Options for the package mathtools the option Load always. \smashoperator
sets the space besides the operator to 0 pt.

Applied on formula (6), one uses the command

\smashoperator{

and inserts the operator with its limits into the braces. Behind the brace one continues

the formula: .

>k
0<k<1000
keN
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It is possible to set the space of only one side of the operator to 0 pt. To do this write
either [1] or [r] between \smashoperator and its brace. 1stands for the left and r for
the right side of the operator. Here is an example of the possible \smashoperator
forms:

n=3456 n=3456 n=3456
YY Xy=Y) Xy=Y } Xy
1<iSj<n 1<i<i<n 1<i<j<n

When several consecutive operators have limits the typesetting of the limits looks
often imperfect in the output, see this example:

a) lim max b) lim max «¢) lim sup  d)limsupmax
n—00 p>n n—00 p2>np n—00 p2>nK n—oo p>n

To improve the typesetting set in the document settings under Math Options for
the package mathtools the option Load always. Then insert into your formula the
command \adjustlimits directly before the first operator. The example will then
look like this:

a) lim max b)lim max c¢)lim sup  d)limsupmax
n—roo pzn n—o0 p>n n—soo p2>nK n—oo  p>n

How to use one limit for several operators is described in sec. 10.5.

10.3. Decoration for Operators

With the commands \overset and \underset characters can be placed above or
below an operator, respectively. With the command \sideset characters can be set
before and behind a big operator.

There are 4 variants of \sideset:
« \sideset is used to set characters at the corners of the operator

« \sidesetn is used to set characters before and/or behind the operator (this
variant represents IXTEX’s original \sideset command)

 \sidesetl is used to set characters at the left corners and /or behind the operator

« \sidesetr is used to set characters at the right corners and/or before the op-
erator

For example the command \sidesetn, \sum, —’—_ k=1, "n produces:
n
!/

D

k=1
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Note: \sideset can only be used to decorate big operators, binary operators are
not allowed.

\overset and \underset can also be used to decorate symbols and characters. For
example, the command \overset, \maltese ta produces:

a

d

10.4. Binary Operators

Binary operators are surrounded by space when there is a character before and after
them.

Command Result Command Result Command  Result
+ + \nabla \Y \oplus @
- — \bigtriangledown \V4 \ominus o
\pm + \bigtriangleup A \otimes ®
\mp F \Box O \oslash @
\cdot : \cap N \odot ©)
\times X \cup U \amalg I
\div + \dagger T \uplus )
* * \ddagger I \setminus \
\star * \wr 2 \sqcap M
\circ o \bigcirc O \sqcup LJ
\diamond © \wedge A \triangleleft <
\bullet o \vee Y \triangleright >

All binary operators can also be inserted via the math toolbar button *.

To typeset the Laplace operator also \Delta or \nabla™2 (V?) can be used instead
of \bigtriangleup .

The character Menu Separator from the menu Insert > Special Character is the operator
\triangleright.

10.5. Self-defined Operators

With the help of the command \DeclareMathOperator custom operators can be
defined in the I¥TEX-preamble. Its command scheme is:

\DeclareMathOperator{new command }{display}

Display can be characters or symbols that define how the operator looks in the output.
To define a big operator a * is set behind the command. All self-defined big operators
can have limits as described in sec. 10.2.
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For example the IXTEX-preamble line
\DeclareMathOperator*{\Lozenge}{\blacklozenge}

defines the command \Lozenge, that inserts a big operator consisting of the lozenge
symbol from sec. 13.2:

¢
n=1
The command for this formula is: \Lozenge™ \infty—_ n=1
When self-defined operators are not used several times in the document, they can also

be defined with the commands \mathop and \mathbin, which have the following
scheme:

\mathop{display} and \mathbin{display}
\mathop defines big operators, \mathbin binary operators.

\mathop can e.g. be used to use one limit for several operators:

>3

ij=1

The command for the formula above is:
\mathop{\sum\negmedspace\sum, — "N, _ij=1

11. Fonts

11.1. Font Styles

Latin letters in formulas can be set in one of the following font styles:

Command Result Shortcut

\mathbb ABC  ABC .
\mathbf AbC AbC Ctrl+Alt+B
\boldsymbol AbC ~AbC Ctrl+-B
\mathcal ,ABC ABC -
\mathfrak_AbC  2Ab¢ .
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Command Result Shortcut

\mathit ,AbC  AbC -
\mathrm AbC  AbC Alt+C R
\mathsf ,AbC ~ AbC Alt+C S
\mathtt_AbC AbC  Ctrl+Maj+P
\mathscr , ABC o/ BE€ -

Note: The styles \mathbb, \mathcal and \mathscr can only be used for big
letters.

Predefined is the style \mathnormal.
The style commands work also for letters in mathematical constructs:

A= —
¢

Characters in mathematical text don’t appear in a math font style but in the text
font style \textrm. That their style can’t be set correctly via the text style dialog
is a bug in [yX.?*

Instead of the style commands the dialog Edit > Math > Text Style or the toolbar button
A4 can be used.

11.2. Bold Formulas

To make a complete formula bold, the command \mathbf from the previous sub-
section cannot be used, because it doesn’t work for small Greek letters. Furthermore
it prints Latin letters always upright, like in the following equation:

2
/ f(0) =T equation with \mathbf
To display the formula correctly, the command \boldsymbol is used:

2
/ f(@)=r equation with \boldsymbol

It is also possible to set the formula in a boldmath environment. This environ-
ment is created by inserting the command \boldmath in TEX mode. To end the
environment, the command \unboldmath is inserted in TEX mode.

2
/ f@) =r equation in a boldmath environment

AUy X-bug #4629
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11.3. Colored Formulas

Formulas can be colored like normal text: Highlight a formula or a formula part and
use the Text Style dialog. Here is a formula in magenta:

VB
/Ad.r = 7111 (lﬂ)

You can also define your own colors as described in sec.9.3. They can be used with
the TEX code command \textcolor in the scheme

\textcolor{color}{characters or formula}

The following example was colored completely dark green and partly red:

VB
/Ad;l, T <%>

Due to a bug in LyX only complete formulas can be colored with self-defined colors.?

11.4. Font Sizes

For characters in formulas there are, analog to characters in text, the following size
commands:

\Huge, \huge, \LARGE, \Large, \large, \normalsize, \small,
\footnotesize, \scriptsize and \tiny

The size produced by the commands depends on the document font size, which cor-
responds to the command \normalsize. The other commands produce smaller or
larger sizes than \normalsize. The font size can however not exceed a certain value.
Is for example the document font size 12 pt, the command \Huge switches to the
same size as \huge.

A size command is inserted in TEX mode before the formula and sets the size for
all following formula and text characters. To switch back to the initial size, the
command \normalsize is inserted behind the formula in TEX mode.

Within a formula the size can be changed using the following size commands or the
toolbar button Za:

2TyX-bug #5269
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Command Result

K
displaystyle B, = ——
\displaysty P = m
\textstyle Epot, = l+I(ﬂ
ny

\scriptstyle Bpoty =33

2

\scriptscriptstyle E K

After entering these commands, a blue box appears in which the formula parts are
inserted.

There is a further method to change the font size, that though only works for symbols
or letters in mathematical text. To use it, one of the above text size commands is
inserted in mathematical text. All following characters until the end of the mathe-
matical text or until another size command will have the selected size. Two examples:

M A A,

Before both formulas the command \ huge was inserted. The command for the second

formula is:
\maltese /A Alt+M M \Large \maltese \textit ,A——
Alt+M M \tiny \maltese \textit A

If a symbol cannot be displayed in different sizes, it will always be displayed in the
default size.

12. Greek Letters

Greek letters can also be inserted via the toolbar button @ . All international type-
setting norms purport that Greek letters in math have to be typeset italic/slanted.
In some languages, like French or Russian, they are nevertheless sometimes typeset
upright.
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12.1. Small Letters

Command Result

Command Result Command Result
iot
\alpha o \iota ‘ \varrho 0
\kappa K .
\beta 6] \sigma o
\gamma \varkappa o \varsigma
v
& 7 \lambda A 8 )
\delta J \ \tau T
mu
\epsilon € K \upsilon v
\varepsilon € \nu o \phi o)
\ \xi § .
zeta ¢ 5 ; \varphi ©
\eta n \pi - \chi X
\theta 0 \varpi - \psi Y
\vartheta 9 \omega w
\rho p

How to create special upright Greek letters is explained in sec. 24.9.

12.2. Big Letters

Command Result

\Gamma r

Command Result

\Delta A \Sigma - &
\Theta o \ Upsilon T
\Lambda A \Phi @
\Xi — \Psi v
\Pi - \Omega Q

That the big Greek letters appear upright is caused by a design bug when TEX
was developed. To get correct italic big letters, begin every command with var.
For example the command \varGamma produces I'. Another way is to load the
package fixmath? with the I TEX-preamble line

\usepackage{fixmath}

Then all big Greek letters in a document will automatically be typeset italic.

12.3. Bold Letters

Greek letters cannot be set with different font styles like Latin letters. They can only
be made bold with the command \boldsymbol.

Z6fixmath is part of the N TEX-package was.
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Command Result

\Upsilon\boldsymbol\Upsilon ~ TY
\theta\boldsymbol\theta 60

13. Symbols?’

Many of the symbols listed in this section can also be inserted via the toolbar buttons
V and F.

13.1. Mathematical Symbols

Command Symbol Command  Symbol Command Symbol

\neg - \forall \ \prime /
\Im & \exists 3 \backprime \
\Re R \nexists 3 \mho )
\aleph N \emptyset 0 \triangle A
\partial 0 \varnothing o \angle 4
\infty 00 \dag T \measuredangle £
\wp © \ddag I \sphericalangle <
\imath ? \complement C \top T
\jmath J \Bbbk k \bot 1

13.2. Miscellaneous Symbols

Command  Symbol Command Symbol Command  Symbol
\flat b \hbar h \diamondsuit O
\natural b \hslash h \Diamond <&
\sharp i \clubsuit L \heartsuit Q
\surd V \spadesuit [ ) \P q
\checkmark v \bigstar * \copyright ©
\yen ¥ \blacklozenge ¢ \circledR ®
\pounds £ \blacktriangle A \maltese {
$ $ \blacktiangledown v \diagup /
§ § \bullet ° \diagdown AN

Some symbols can be displayed in different sizes, see sec. 11.4.

2T A list with all symbols of most of the INTEX-packages can be found in [4].
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13.3. The Euro-Symbol €

To use the Euro symbol in formulas, the BTEX-package eurosym must be installed
and loaded with the I¥TEX-preamble line

\usepackage[gennarrow]|{eurosym}
The Euro symbol can now be inserted with the command \euro.

The Euro symbol can directly be inserted with the € key in mathematical text,
without having eurosym installed. When eurosym is installed, \euro can also be
inserted in TEX mode. The official currency symbol can then be inserted with the
command \officialeuro, that is only available in TEX mode.

An overview about the different Euro symbols:

Command  Symbol

formula \euro €
mathematical text € €
TEX mode \officialeuro €

14. Relations

All following relations can also be inserted via the toolbar button =.
Command  Relation Command Relation Command  Relation
< < = = > >
\le < \not= # \ge >
\11 < \equiv = \gg >
\prec =< \sim ~ \suce -
\preceq = \simeq ~ \succeq -
\subset C \approx ~ \supset D
\subseteq C \cong & \supseteq D
\sgsubseteq C \bowtie <] \sgsupseteq 3
\in € \notin ¢ \ni 3
\vdash - \perp 1 \dashv —|
\smile — \propto x \frown ~
\lhd < \asymp = \rhd >
\unlhd g \doteq = \unrhd >
\gtrless 2 \circeq = \lessgtr <
\mid | \models = \parallel [
\nmid " \widehat= = \nparallel K
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The characters \lhd and \rhd are bigger than the equal looking operators \trian-
gleleft and \triangleright, respectively.

LyX supports also many special relations. Use the toolbar button = to see a list of
these relations.
Relations are, in contrary to symbols, always surrounded by space.

Relations with labels can be created with the command \stackrel:

Command Result

7—00

A(r)\stackrel, r\to\infty |\approx . B A(r) = B

15. Functions

15.1. Predefined Functions

In general, variables are set italic in mathematical expressions, but not function
names, because sin could be misunderstood as s-7-n. Therefore there are predefined
functions which are additionally a bit separated from prefactors. They are inserted
as commands starting with a backslash before their name.

Command Result Command Result

Asin(x)+B  Asin(z)+ B A\sin(x)+B Asin(z) + B

The following functions are predefined:

Command Command Command Command

\sin \sinh \arcsin \sup
\cos \cosh \arccos \inf
\tan \tanh \arctan \lim
\cot \coth \arg \liminf
\sec \min \deg \limsup
\csc \max \det \Pr
\In \exp \dim \hom
\lg \log \ker \ged

exp

They can also be inserted with the math toolbar button “tan.
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15.2. Self-defined Functions

To use a function that is not predefined, like for example the sign function sgn(x),
there are two possibilities:

 Define the function by inserting the following line to the IXTEX-preamble®
\DeclareMathOperator{\sgn}{sgn}

Now the new defined function can be called with the command \sgn.

o Write the formula as usual, mark the formula name, in our example the letters
sgn, and change it to mathematical text. Finally, a space is inserted between
prefactor and function.

The result is the same with both methods as with a predefined function®:

Command Result
A\sgn(x)+B  Asgn(z) + B

A\, sgn (x)+B Asgn(z)+ B
~~
Alt-+M M

The first method is more suitable when the self-defined function should be used
several times.

15.3. Limits

For limits, in addition to the commands \lim, \liminf and \limsup the following
functions are defined:

Command Result

\varliminf ~ lim
\varlimsup  lim
\varprojlim Jim
\varinjlim lim

The limit is created by inserting a subscript. It is set right beside the function in an
inline formula:

ZFor more about \DeclareMathOperator see sec. 10.5.

In IyX self-defined functions are displayed red, predefined ones black.
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Command Result

\lim_x\to A x=B lim, ,ox =B
In a displayed formula the limit is set below the formula, as usual:

limzx =08
x—A

How to adjust the typesetting of the limits see sec. 10.2.

15.4. Modulo-Functions

The modulo-function is special, because it exists in four variants. The variants in a
displayed formula are:

Command Result
a\mod, b a mod b
a\pmod, b a (mod b)
a\bmod, b a mod b
a\pod, b a (b)

In an inline formula less space is set before the function names for all variants. By
default the modulo-functions take only the first following character into account. To
use more than one character, one has to put them into TEX braces:

Command Result
a\pod, bed a (b)ed
a\pod\{bc — d a (be)d

16. Special Characters

The characters ~ and  would normally create a superscript and subscript, respec-
tively. To get these characters you have to insert them with a leading \:

Command Result
\ 7 )
\_ -
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16.1. Special Characters in Mathematical Text

The following commands can only be used in mathematical text or in TEX mode:

Command Result Command Result
\oe e \o @
\OE E \O %)
\ae ) \1 1
\AE E \L L
\aa a Iy i
\AA A o i
\i 1 \j ]

The characters A and @ can also be inserted via the math toolbar button F .

An exception are the commands ! and ?¢, because they can be inserted in [yX
directly to text.

16.2. Accents in Text

With the following commands all letters can be accented. The commands must be
inserted in TEX mode.

Command Result Command Result

“e é \H e é
\‘e e e é
\"le é \~e é
\=e e \.e é
\u e e \vi. e é
\b_e e \d e e
\t ee ée \c e ¢

With the command \t also two different characters can be accented. The command
\t. sz creates: $z

The accents ¢ , > and ~ can in combination with vowels directly be inserted with the
keyboard without using TEX mode. The same applies for the tilde® ~ in combination
with a , n , or o.

The commands \b , \c , \d , \H, \t , \u, \v and accents that are inserted
directly with the keyboard are also available in mathematical text. For the other
accents there are special math commands to be used in formulas, see sec. 7.1.

30This only applies for keyboards where the tilde is defined as accent.
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Furthermore, with the command \textcircled all numbers and letters can be set
into a circle, quasi accented with a circle, similar to the copyright symbol.

Command Result

\textcircled{w} @
\Large \textcircled{\normalsize\protect\raisebox{-1.5pt }{W}} @

One has to take care that the character fits in the circle. \Large?! specifies thereby
the size of the circle. With the help of \raisebox3? the character can be centered.

16.3. Old-style Figures

Old-style figures (also known as old-style numerals) are created with the command
\oldstylenums. The command can be used in formulas and in TEX mode. The
command scheme is:

\oldstylenums{number}

The command \oldstylenums{0123456789 produces: 0123456789

17. Formula Styles

o There are two different alignment styles:
Centered is the predefined standard.

Indented this can be set using the menu Document > Settings under Math Op-
tions.

When Indented is used, the indentation can be adjusted. The default value
depends on the used document class.

e And two different numbering styles that can be set in the menu Document
Settings under Math Options:

Right is in most cases the default.
Left

The chosen styles are used for all displayed formulas of the document. When both,
centered and indented formulas should be created in a document, the style Centered
is used. The indented formulas are then set in a flalign environment, see sec. 18.2.3.

3lgee sec. 11.4

32gee sec. 9.2

43



18. Multiline Formulas

18.1. General

In IyX multiline formulas are created by pressing Ctrl4+Retour inside a formula. This
creates either an align environment that is described in sec.18.2.1 or, when au-
tomatically loading the package AMS math is disabled in the document settings, an
eqnarray environment that is described in sec.18.3. The align environment is
recommended because it provides in any case a typographically correct output.

There are other multiline formula environments that can be created via the menu
Insert>Math. These environments are described in the following sections.

In all multiline formula environments a new line is created by pressing Ctrl+Retour.
To add or delete lines, the math toolbar buttons &4 or F&, respectively, or the menu
Edit> Rows & Columns can be used.

18.1.1. Line Separation

There is sometimes not enough space in multiline formulas between the lines:

B*(B® — 217 + 22§ — 2r}) + 4afa® 4+ dwgxD = -42°B® + dxoxB?
42 (B + a3) + 4zox (D — B?) + B> (B* = 22 + 223 — 2r}) = 0

In XTEX additional line space is specified as optional argument of the new line com-
mand. This is not yet possible in IyX?3, therefore the whole formula must be inserted
in TEX mode. To add in our example space, the command \\[3mm)] is inserted at
the end of the first line. One gets:

B*(B® — 217 + 2af — 2r}) + 4afa® + dwgxD = -42°B® + dxoxB?

4a? (B + a3) +4zoz (D — B?) + B (B* = 202 + 22 — 2r}) = 0

To set the line separation for all lines in a formula, the length \jot is changed. The
definition is: line separation = 6 pt + \jot. Predefined for \jot is the value 3 pt. To
create 3mm additional line separation as in the previous example, the command

\setlength{\jot}{3mm-+3pt}

is inserted in TEX mode before the formula. This requires that the IXTEX-package
calc®** was loaded in IXTEX-preamble with the line

335ee LyX-bug #1505

3calc is part of every ITEX standard installation.
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\usepackage{calc}
One gets:

B?*(B? = 2r 4 223 — 2r}) + 4xga® + dwgxD = -42°B® + 40z B®
42 (B> + a3) + 4xox (D — B?) + B> (B* = 212 + 223 — 2r7) = 0
To get back to the predefined distance, \jot is set to the value 3 pt.

18.1.2. Column Separation

Multiline formulas form a matrix. A formula in the eqnarray environment is for
example a matrix with three columns. By changing the column separation in this
environment, the space beside the relation sign can be changed.

The column separation is specified with the length \arraycolsep according to:
column separation = 2 \arraycolsep
Thus, the command

\setlength{\arraycolsep}{lcm}

inserted in TEX mode, sets for all following formulas a column separation of 2cm. To
get back to the predefined distance, \arraycolsep is set to 5 pt.

A formula with 2 cm column separation:

A - B
C £ A

A formula with the predefined column separation for matrices of 10 pt:

A =B
C # A
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18.1.3. Long Formulas

Long formulas can be typeset using these methods:

o When one side of the equation is much shorter than the line width, this one is
chosen for the left side and the right side is typeset over two lines:

h? h? h? e?
H = Wsp+ Wy +Wp— —A— — Ay = Ay —
sB + +Wp 2mo 2m, ! 2ms 2 dmeg|r — Ry
2 2
. € n € (7)
47'('50’1'—R2| 47T€0|R1—R2|

The minus sign at the beginning of the second line does normally not appear
as an operator because it is the first character of the line. Thus it would not
be surrounded by space and could not be distinguished from the fraction bar.
To avoid this, 3 pt space was inserted behind the minus sign with the command
\hspace.?

o When both sides of the equation are too long, the command \lefteqn is used.
It is inserted in the first column of the first line and causes all further insertions
to overwrite the following columns:

4o <32 + x%) + 4xox (D — B2> + B? (B2 — 27‘2 + 223 — 27’,%) + D?

—BQ—QB\/rg—x2+2x0x—x%+r§—m2+2:p0x—:pg

2
) ) ) ) (7’2 + 2201 — a:% — 7“,%)
=B +2(rg+2x0x—x0—rk>—l— E (8)

After the insertion of \lefteqn, the cursor is in a purple box that is a bit shifted
to the left from the blue one. In this the formula is inserted.

The content of the further lines is inserted to the second or another formula
column. The greater the column number where it was inserted, the larger the
indentation.

Note the following when using \lefteqn:

* The formula doesn’t use the full page width. When e. g. the term —B? is
added to the first line in the above example, it would have been outside
the page margin. To better use the width, negative space can be inserted
at the beginning of the first line.

* Due to a bug in [yX the cursor cannot be set with the mouse into the first
line.?® One can only set the cursor at the beginning of the line and move
it with the arrow keys.

e Other methods to set long formulas are offered by the environments described
in sec. 18.5 and sec. 18.6.

35for more about \hspace see sec. 8.2
36LyX-bug #1429

46


https://www.lyx.org/trac/ticket/1429

18.1.4. Multiline Fractions

There are cases where the denominator and/or the numerator of a fraction is so long
that the fraction does not fit into one line. It is then necessary to add a line break
within the fraction. This can be done using the command \splitfrac. To activate
it, set in the document settings under Math Options for the package mathtools the
option Load always. \splitfrac has the scheme

\splitfrac{first line}{second line}

and is used as denominator and/or numerator:

ry + zy + zy + 2y + TY vy + 3 Fay +ay+ay
o= —i—wy#—wy—kwy—i—wy7é + 2y + 2y + 2y + Yy
z z

The command for the first numerator above is:

\splitfrac{xy+xy+xy+xy+xy \{+wy+wy+wy+wy

18.1.5. Multiline Brackets

For brackets spanning multiple lines the following problem occurs:

A = sin(x) Hl—l—
et
-+ B —D|

The closing bracket is smaller than the opening bracket because brackets with variable
size may not span multiple lines.

To set the bracket size for the second line correctly, the first line is ended with
\right. and the second line with \left.3”. After \left. the command \vphan-
tom \prod™ \infty | R=1} isinserted, because the multiplication operator with
its limits is the largest symbol in the first line and this should be the size for the
bracket in the second line.

The result is this:

A = sin(z) [ﬁ}%—i—

--.+B_D]

37for more about \left and \right see sec.5.1.2

47



18.2. Align Environments

Align environments can be used for every kind of multiline formulas. They are espe-
cially useful to set several formulas side by side.

Align environments consist of columns. The odd columns are right aligned, the even
ones left aligned. Every line in an Align environment can be numbered.

Align environments are created via the menu Insert>Math. With the menu Edit>
Math>Change Formula Type already existing formulas can be converted to Align
environments.

To add or delete columns, the math toolbar buttons B or E&ﬁ, respectively, or the
menu Edit>Rows & Columns can be used.

18.2.1. Standard align Environment

This Align environment is created by pressing Ctrl+Retour in a formula or by the
menu Insert>Math>AMS align Environment.

An example for two formulas set side by side, that are created with a four column
align environment:

A = sin(B) C=D
C#A B # D
As it can be seen, the formulas in this environment are placed so as if there would

be a \hfill®® before the first and after every even column. When the formula style
Indented? is used, the formula is set without the \ hfill before the first column.

18.2.2. Alignat Environment

The alignat environment has no predefined column separation. It can be inserted
manually with the spaces that are described sec. 8.

The above example in the alignat environment where 1 cm space was inserted at the
beginning of the second formula:

A = sin(B) C=D
C#A B+#D

Because the column separation can be set separately for every column, this environ-
ment is especially suitable to set three and more formulas side by side.

3¥more about \hfill see sec. 8.2

3formula styles see sec. 17
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18.2.3. Flalign Environment

In this environment the first two columns are always set as much as possible to the
left and the last two ones to the right. An example:

A=1 B =2 Cc=3
X:—l Y:—2 Z:4

By creating a flalign environment with an odd number of columns where an empty
TEX brace is inserted to the last column, several formulas in a document can be set
to the left, although the formula style Centered is used. As example the indented
formula (5):

// Xdv =U (9)

The first two columns contain the formula. To indent it as with the formula style
Indented, 30 pt space was inserted at the beginning of the first column.

18.3. Egnarray Environment

When this environment has been created, three blue boxes appear. The content of
the first box is right aligned, the content of the last one left aligned. The content of
the middle box appears centered and a bit smaller, because it is designed to insert
there only relation characters.

ABC . ABC
D P D
AB AB AB
A = A

18.4. Gather Environment

This environment consists of only one centered column. Every line can be numbered.

A=1 (10)
X =-1 (11)

18.5. Multline Environment

The multline environment consists, like the gather environment, of only one column.
But the first line is left aligned, the last one right aligned. All other lines are centered.
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Therefore this environment is suitable for long formulas. As example formula (8) in
the multline environment:

42? (B + ) + 4wox (D — B?) + B* (B* = 2 + 205 — 21}) + D?

—B2—2B\/r§—x2+2x0x—x%+r§—Jc2+2x0m—x§

2
2 2 _ .2
(rg + 2x01 — 15 — rk)

= (12)

:BQ+2(r§+2x0x—x3—ri)+

In the output only the last (first) line of a multline environment appears numbered
when the document numbering is right (left).*°

With the commands \shoveright and \shoveleft a centered line can be right or left
aligned, respectively. The commands are used as follows:

\shoveright{line content} and \shoveleft{line content}

The length \multlinegap specifies the distance of the first line from the left page
margin. Predefined is the length 0 pt.

As example the above formula where the command
\setlength{\multlinegap } {2cm}

was inserted in TEX mode before:

4a® (32 + x%) + 4xox (D — BQ) + B? (32 — 2r§ + 275 — 27",%) + D?

—Bz—QB\/rg—x2+2x0x—x%+r§—x2+2x0x—x(2)

2 2 _ .2
(rg + 20 — TG — 1]

BZ

2
:BZ+2(T§—I—2:U033—:U3—7“,%)+ ) (13)

The second line was left aligned using \shoveleft.

18.6. Multiline Formula Parts

To display only parts of a formula with multiple lines, one of the following environ-
ments is used: aligned, alignedat, gathered or split. They can be inserted via
the menu Insert>Math or by using the commands described in this section.

The first three have the same properties as the corresponding multiline formula en-
vironments, but it is possible to set further formula parts beside them. An example:

AzAp >
Uncertainty relations

AEAt >

NSO St

4Onumbering styles see sec. 17
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To get this formula, a displayed formula is created where the command \aligned is
inserted. A purple box appears around the blue formula box where now columns and
lines can be added. Outside the multiline environment other formula parts can be
set, like the brace.

The aligned environment is also suitable for long formulas whose lines are horizontally
aligned. Using aligned in a displayed formula has the advantage that the formula
number is vertically centered behind the lines. As example formula (7) in the aligned
environment:
h? h? h? e
H=W, Wi + Wp — A — Ay — Ay — —————
sp+ + b 2m0 2m1 ! 2m2 2 47T€0|I' — R1|

e? e?

B 47T€0|I’ — RQ‘ + 47T€0‘R1 — RQ‘

(14)

To use the environments alignedat, gathered, or split, the command \alignedat,
\gathered, or \split are inserted, respectively. The split environment has the same
properties as the aligned environment but it can only have two columns.

18.7. Text in multiline Formulas

In the Align environments, and the multline and gather environment, text can be
inserted that will appear in a separate line and doesn’t affect the column alignment.
To do this, the command \intertext is used in the following scheme:

\intertext{text}

The text should not be longer than a line because it cannot be hyphenated. As IyX
doesn’t yet support \intertext directly, the text is written as mathematical text.
\intertext must hereby be at the beginning of a line and appears in the output
above this line. An example where the text was inserted at the beginning of the
second line:

I=aV?2 /027r 1+ cos(¢) do (15)

integrand is symmetric to ¢ = m, therefore
= 2a\/§/ \/ 1+ cos(¢) do (16)
0

\intertext always creates some vertical space between the text and the formula lines.
To avoid this space, set in the document settings under Math Options for the package
mathtools the option Load always. Then you can use the command \shortintertext
instead of \intertext:
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I= a\/i/:ﬂ 1+ cos(¢) do (17)

integrand is symmetric to ¢ = m, therefore

= 2aV/2 / ’ 1+ cos(¢) do (18)

19. Formula Numbering

19.1. General

Numbered formulas can be created with the menu Insert>Math>Numbered Formula
(shortcut Ctrl+Alt N). Existing formulas can be numbered with the menu Edit>
Math > Toggle Numbering (shortcut Alt+M N). The formula number is displayed in
LyX behind the formula as a number sign in parentheses. The number sign is replaced
in the output by the formula number.

When numbering is turned on in multiline formulas, all lines will be numbered. But
the numbering can be controlled with the menu Edit > Math > Toggle Numbering of Line
(shortcut Alt+M Maj+N) for every line.

Except for inline formulas, all formulas can be numbered with two different styles,
see sec. 17.

19.2. Cross-References

All labeled formulas can be cross-referenced. A label is added by the menu Insert>
Label or the toolbar button . The cursor must hereby be inside a displayed formula.
Alternatively you can right-click on the formula and choose Equation Label. A dialog
pops up displaying the prefix eq: in a text field. The label is inserted there behind
the prefix. The predefined prefix means “equation” and makes it easier to find labels
in large documents because it marks it as formula label to divide it from e. g. section
labels. To change a label, the menu Insert>Label is used again or you right-click on
a formula and then on Equation Label.

The name of the label is displayed in IyX within two parentheses behind formula. A
formula with a label is always numbered.

Cross-references are inserted via the menu Insert> Cross-Reference or with the tool-
bar button =». A formula cross-reference appears in the output as formula number.
When in the cross-reference dialog window the format (<reference>) is chosen, the
cross-reference appears in the output as formula number in parentheses.

By right-clicking on a cross-reference in IyX, one jumps to the formula that is refer-
enced.
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Here are as examples cross-references to formulas of the following subsections:
The equations (something) and (20b) are equivalent. In (Y) big Latin letters are
used for the numbering in contrary to (XXIII).

When the argument of \tag*' contains a box like in sec. 9.4, the formula cannot be
referenced.

19.3. Subnumbering

Formulas can be numbered as subequations. To activate this feature, add the module
Subequations to the document in the menu Document> Settings>Modules. To insert
subequations use the menu Insert> Custom Insets> Subequations.

The equations to be subnumbered are put into the Subequations inset. An example:

A=C-B (19)
B=C-A (20a)
C=A+B (20b)
Every formula in the Subequations inset will be subnumbered with a, b, ¢, ... in the

output. For multiline formulas every line will be subnumbered.

Referencing subequations work like for normal equations: (20a), (20b). If you want to
reference the subequations collectively, insert a label as first thing in the Subequations
inset. Formula (21) is an example.

By inserting subequations vertical space is added before it. To remove this, insert
-5mm vertical space right before the Subequations inset. If the formula style In-
dented*? is used, insert -7 mm space instead.

To get another subnumber instead of small Latin letters, insert this command as TEX
code before the equations in the Subequations inset:

\renewcommand{\theequation}{\theparentequation -\roman{equation}}

\theparentequation creates hereby the parent number and \roman{equation}
adds a small Roman number as subnumber. For more information about the cus-
tomization of the numbering, see sec. 19.4.

Here is an example for a multiline formula where the numbering is customized and
turned off for the second line:

A = (B-2?*=(B-2)(B-2) (21-i)
= B?-7ZB-BZ+ 7*
= B>-2BZ + 7? (21-ii)

4\ tag is described in sec. 19.5.

42formula styles see sec. 17
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19.4. Numbering with Roman Numbers and Letters

Formulas can also be numbered with Roman numbers and Latin letters. To number
for example with small Roman numbers, the command

\renewcommand{\theequation}{\roman{equation}}

is inserted before the formula in TEX mode. \renewcommand redefines the prede-
fined command \theequation to the command \roman{equation}.** equation
is the formula counter. When the command \the is used as prefix for a counter,
the value of the counter is output as Arabic number. When a formula is num-
bered, INTEX sets internally the command \theequation behind the formula. \ro-
man{equation} outputs the counter as small Roman number.

All formulas behind the command \renewcommand are now numbered Roman. To
switch to numbering with big Roman numbers, the command is inserted again, but
\roman is replaced by \Roman. To “number” with small Latin letters there is the
command \alph, for big ones there is the command \ Alph.

Note: Only maximal 26 formulas can be numbered with Latin letters in one docu-
ment.

A = small roman (xxii)
B = big Roman (XXIII)
C' = small Latin (x)

D = big Latin (Y)

To switch back to the default numbering, insert the command:

\renewcommand{\theequation}{\arabic{equation}}

E = Arabic (26)

As you see, formulas are numbered serially independent from the numbering style.
When then numbering should start with “1” when the style is changed, new equation
counters have to be defined. A description about this can be found in the file Formula-
numbering.lyx.

43The command \renewcommand has the same scheme like the command \newcommand that
is described in sec. 22.1.
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19.5. User-defined Numbering

Note: If the document language is a right-to-left language such as Arabic, you must
add this to the to the KTEX-preamble to be able to use the commands described in

this section:

\AtBeginDocument{
\def\tagform@#1{\maketag@@@{(\ignorespaces#1\unskip)}} }

With the standard numbering parentheses are set around the formula number. To
replace the parentheses for example by vertical bars, the following line is added to
the BTEX-preamble:

\AtBeginDocument{
\def\tagform@#1{\maketag@@Q@{|#1|}} }

To use other characters, the vertical bars besides the #1 are replaced by one ore
more characters. To get only the formula number the vertical bars are omitted.

When there should be an expression of your choice instead of the consecutive formula
number in parentheses behind the formula, the command \tag is used:

A+B=C (something)

In this example the command \tag something was inserted in the formula.

When the command \tag* something is inserted instead, the star prevents the
parentheses around the expression:

A+B=C something

To restart the formula numbering with new document parts or sections, the following
command is used:

\ @addtoreset{equation}{part}
resp.
\@addtoreset{equation}{section}

To be able to use these commands in TEX mode, the “@” character has to be made
“active” for BTEX using the command \ makeatletter. The command \makeatother
reverts this. So the command sequence in TEX mode is:

\makeatletter
\@addtoreset{equation }{section}
\makeatother

In the KTEX-preamble \makeatletter and \makeatother can be omitted as they
are automatically internally inserted by LyX.
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To revert \@addtoreset, the file remreset.sty* has to be loaded in the KTEX-
preamble with the line

\usepackage{remreset }

Then the command \@removefromreset can be used with the same scheme as
\@addtoreset.

Sometimes formulas should be numbered in the following form:
(section number.formula number)
The formula number should start with every section with “1”.

For this case there is the command \numberwithin, which is used with the following
scheme:

\numberwithin{counter }{sectioning}

Counter denotes what kind of numbering is affected, sectioning denotes what number
is before the dot.

Thus in our case the following IXTEX preamble or TEX code line is used:
\numberwithin{equation}{section}
This is the result:

A+B=C (19.27)
To number e. g. tables so that the number of the part is the sectioning,
\numberwithin{table}{part} is used.

To go back to the standard numbering or to prevent this kind of numbering when it
is defined by the document class, the following command is inserted as TEX code or
to the KTEX preamble:

\renewcommand{\theequation}{\arabic{equation}}
or

\renewcommand{\thetable}{\arabic{table}}

\numberwithin uses internally the command \ @addtoreset, described above, that
also needs to be reverted.

20. Chemical Symbols and Equations

An example text from chemistry:

The SO} -ion reacts with two Nat-ions to sodium sulfate (NaySO,). The
chemical equation for this is:

2Na™ +SO3~ — NaySO, (28)
remreset is part of the N TEX-package carlisle that is part of every ITEX standard installation.
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This chemical equation can directly be created as formula. To avoid that the symbols
appear italic, everything is highlighted and changed by the shortcut Alt+C R to the
upright font style.?

A more convenient way to typeset chemical formulas is to use the command \ce that
is available when the IXTEX-package mhchem is installed. After inserting \ce to
a formula a new blue box appears where chemical formulas can be inserted in an
intuitive way.

Command Result
\ce H2CO3 H,CO,
\ce ,SO472- SO,*"
\ce (NH4)2S (NH,),S
\ce KCr(S04)2.12H20 KCr(S0O,),-12H,0
\ce ;,A-B\dbond, ,C\tbond, D A—-B=C=D
\ce "227]_90—Th+ 2 Tht
\ce \mu, \hyphen (Cl u-Cl
\ce.CO2 + C <=>2CO CO,+C==2CO

\ce CO2 + C ->[\alpha][\beta], 2C0} CO, + C —*+2CO

Note: It is not possible in [y X to use the character ~ to get an up-arrow as described
in the mhchem manual. One instead uses a negative thin space followed by the
command \uparrow: Fe + 2H" — Fe?* + Hyt

Using \ce the command for equation (28) is:
\CeuzNa+u+USO4A2-UU->|_JN&2SO4

To create multiline chemical equations first a multiline formula is created as described
in sec. 18. Afterwards the command \ce is used in every small blue box of the formula.
(29) and (30) are an example of a multi-stage chemical reaction where every equation
has its own number.

TEOS+40 —— Si(OH), + 4C,H,0 (29)
Si(OH), ——» SiO,+2H,0 (30)

Besides \ce the mhchem package provides the command \cf that has to be used
for special cases. For more information about \cf and more examples have a look at
the documentation of mhchem, [7].

4Sfont styles see sec. 11.1
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21. Diagrams

LyX supports two types of commutative diagrams: amscd and xymatrix that are
explained in the following.

21.1. Amscd Diagrams

Diagrams of this type visualize relations by vertical and horizontal lines or arrows:

A B > C
F < E D

To get them, the command \CD is inserted to a formula. A blue box appears with
two dashed lines where further commands can be inserted. With Ctrl+Retour a new
line is created. Horizontal relations are inserted in odd, vertical in even formula lines.

To create the relations there are the following commands:
o @< creates a left arrow, @>>> a right arrow and @= a long equal sign
o @AAA creates an up arrow, @VVYV a down arrow and @| a vertical equal
sign
e @. is a placeholder for non-existent relations
All arrows can be labeled as follows:

o If text inserted between the first and second < or >, resp., it is placed above
the arrow. When it is inserted between the second and third one, it appears
under the arrow.

o When text for vertical arrows is inserted between the first and second A or V,
resp., it is placed left beside the arrow. When it is inserted between the second
and third one, it appears right beside the arrow. If the text contains an A or
V, these letters must be set into a TEX brace.

As example a diagram with all possible relations:

A— 4B — C F
| ]
D E-‘*,sFr__¢C

The command for this is:

\CD A@>j>>B@>>k>C@=F Ctrl+Return
QAmMAAQ@.@QVV\{V—-V@Q| Ctrl+Return
DA<<j<EQ@Q>k>>FQ=C
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21.2. Xymatrix Diagrams

To be able to use xymatrices, the XTEX-package xypic must be installed. A xymatrix
is created by inserting the command \xymatrix in a formula. Then you are able to
add new matrix columns and rows like for normal matrices, see sec. 4.

In contrary to amscd diagrams, xymatrices supports diagonal and curved arrows, and
much more. All possibilities to create commutative diagrams and decorations are ex-
plained in detail in the X Y-pic manual that you find in the menu Help > Specific Man-
uals.

21.3. Feynman Diagrams

To be able to use FEYNMAN-diagrams, the IXTEX-package feyn must be installed.
A FEYNMAN-diagram is created by inserting the command \Diagram in a formula.
Then you are able to add new matrix columns and rows like for normal matrices, see
sec. 4.

Examples how to create FEYNMAN-diagrams in [yX is given in the Feynman-diagram
manual that you find in the menu Help > Specific Manuals.

22. User-defined Commands

Note: The names of user-defined commands and macros may only consist of Latin
letters.

22.1. The Command \newcommand

Many IXTEX-commands are too long to be used frequently. But it is possible to define
with the command \newcommand new shorter commands.

The command scheme of \newcommand is:

\newcommand{new command name } [number of arguments|[optional value]
{command definition}

Note: Assure that the name of the new command is not already used in your docu-
ment or by KTEX-packages that you use. When you for example define the command
\le for \Leftarrow, you get an error message because \le is already defined as
command for “<”.

The number of arguments is an integer in the range 0-9 and specifies how many
arguments the new command should have. With the optional value a value for an
optional argument can be predefined. When this is done, the first argument of the
new command is automatically an optional one.
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Here are some examples:
o To define the command \gr for \ Longrightarrow, the XTEX-preamble line is:
\newcommand{\gr}{\Longrightarrow}

o To define the command \us for \underline, the argument (that should be
underlined) must be taken into account. For this the preamble line is:

\newcommand{\us}[1]{\underline{#1}}

The character # acts as argument placeholder, the 1 behind it denotes that it
is the placeholder for the first argument.

« For \framebox one can e.g. define the command \fb:
\newcommand{\fb}[3]{\framebox#1#2{$#3%$}}

The two Dollar signs creates the extra formula needed for \framebox, see
sec.9.1.

+ To create a new command for \fcolorbox where the color for the box need not
be specified, the argument for the color is defined optional:

\newcommand{\cb}[3][white]{\fcolorbox{#2}{#1}{$#3%}}

When the color is not specified when using \cb, the predefined color white
will be used.

A test of the new defined commands:

Command Result
A\gruB A — B
\us{ABcd ABcd

\fb{[2cm]—=\{—=\{\int. A=B | [A=DB

\cb{red—\{\int A=B [A=B

\cb[green]\{red—\{\int,A=B [[fA=DB

22.2. Math Macros

User-defined commands are especially convenient for complex expressions. When
you are for example dealing with a document that has quadratic equations, the same
solution type occurs several times. The general form of a quadratic equation is

0=\ +pA+g

The general form of the solution is

A2 = —

NS
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To define a command for the solution formula where only the three parameters A,

p and g need to be specified and the index of A can be given optionally, the KTEX-

preamble line is

\newcommand{\aG}A][1,\,2]{#2_{#1}=-\frac{#3}{2}\pm
\sart{\frac{#37{2} }{4}-#4}}

To create with this the solution formula, the command
\gG{\lambda—\{p—\{q is inserted to a formula.

The definition of the new command is unintuitive because one has to know the
schemes of all used KTEX commands, e.g. that a fraction is inserted in IXTEX as
\frac{numerator } {denominator}. Furthermore one can easily forget a brace
in the definition and cannot see in IiyX what the new command is doing. To avoid
these problems Ly X offers the possibility to use math macros instead of the command
\newcommand.

A math macro is created by using the menu Insert > Math > Macro or the toolbar but-

ton 2. The math macro toolbar appears together with the following box where the

macro is defined:

HEWMACrorndme. = m"m

\newmacroname is the default name of the macro that should be changed to some-
thing sensible. The wanted formula is inserted in the first blue box. An argument
placeholder is inserted with the command \#argumentnumber, e.g \#1 or by
using the macro toolbar button }¥}. Argument placeholders are displayed red. A
maximum of 9 arguments are possible. Optional arguments are created with the
toolbar button [K}. The first non-optional argument can be transformed to an op-
tional one with the toolbar button #0. In the second blue box the appearance of the
macro in IiyX can be defined. Normally you want to see it as it is defined, so the box
is kept empty. But when you have created a macro that needs lot of space on the
screen, you can insert in the box for example

aG: \#1, \#2, \#3, \#4

For the macro only the arguments with the macro name in front of them will then be
displayed in LyX, leading to a better overview. The formula appears in the output
as defined in the first box.

The appearance of macros in formulas can furthermore be changed for single macros
by setting the cursor in the macro and using the menu View> (Un)fold Math Macro.

To use a macro, the macro name is inserted as command to a formula, in our case
\qG. Our macro looks in IyX like this:

[|:|:|= _ﬂ—'li_n
27\ 4

Here is our macro example with the arguments z, In(x) and B:
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In(x) " In(x)?
2 4

— B

T2 = —

LyX offers in the menu Tools> Preferences > Editing > Control different styles to edit
macros. To find the style that suits you the most, choose a style and set the cursor
in a macro formula to see the difference.

A math macro is transformed internally to a \newcommand command when ex-
porting the document. The created \newcommand command is not placed in the
ETEX-preamble, therefore macros can only be used in formulas that are in the doc-
ument below the macro definition box.

Math macros can also be directly created from a \newcommand command. When
writing for example the command

\newcommand{\larrow } [2]{\xleftarrow[#2]{#1}}

in yX as normal text, highlighting it completely and using then the shortcut Ctrl+M,
the command will be transformed to a math macro. Using this method you need to
be careful that the \newcommand command is typed correctly, otherwise you get
a faulty macro leading to KTEX errors.

Math macros currently have the problem that further formulas in macro definitions
are handled wrongly. Therefore the example \fb from sec. 22.1 cannot be created as
macro.

When the cursor is in a macro definition box, you will see the macro toolbar in IyX:

WY o oo [} 3 HE HEUE

The macro toolbar contains from left to right the following buttons:

#{}  Edit>Math>Macro Definition> Remove Last Argument
#y  Edit>Math>Macro Definition> Append Argument

i Edit>Math>Macro Definition> Transform First Non-Optional to
Optional Argument

v Edit>Math>Macro Definition> Transform Last Optional to
Non-Optional Argument

[} Edit>Math>Macro Definition> Remove Optional Argument
[} EditMath>Macro Definitiont>Insert Optional Argument

X¥  Edit> Math>Macro Definition > Remove Last Argument
Spitting Out To The Right

H¥  Edit> Math> Macro Definition > Append Argument
Eating From The Right
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1f  Edit> Math> Macro Definition > Append Optional Argument
Eating From The Right

23. Computer Algebra Systems

LyX offers the exchange between mathematical expressions written in LyX’s math
editor and external applications or user defined scripts. Currently supported appli-
cations are Maple, Mathematica, Maxima and Octave. Note that the set of supported
mathematical constructs is limited only to very simple cases.

23.1. Usage

Write some expression in a formula, go to the Edit>Math>Use Computer Algebra
System menu and choose the application you have installed on the computer. After
that the result of computation should show on the right side of the expression together
with the “=" operator.

Here are few simple examples (with results from Maxima) to show what kind of com-
putations can be performed:

3

37 G 22
o TR2—3 i =—%

3
. % = 12.33333333333333

. f12 sin(z)dz = cos 1 — cos 2

T G U S

6 V3 3
Note: One needs to use proper delimiter insets () instead of simple (" ’)’
characters.
1 6 7
3 4 17
e lim, ;0 (Smmﬂ) =1
 powerseries (—log (5 —x),z,1) = X7, 4*2*122($1)2+1 —logd
3_ -~ 3
o solve (w1 +y} =y +admr) = |ag = VI gy = VNN

23.2. Keyboard shortcut

Currently there is no keyboard shortcut for calling the algebra applications. One
can easily bind a shortcut to the math-extern LyX function (see the LyX Functions
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manual). One could e.g. bind the Return key inside the math editor. To bind it to
Maxima one would use this shortcut definition command:

command-alternatives paragraph-break;math-extern maxima

24. Miscellaneous

24.1. Negative Numbers

Negative numbers often look ugly in formulas because the minus sign before the
number is set with the same length as the minus operator sign. When writing the
negative number in normal text, the minus sign appears correctly.

Thus, the problem disappears when converting the minus sign to mathematical text.

An example to visualize the problem:

normal text: x = -2
formula: z = -2

solution: z =-2

24.2. Comma as decimal Separator
In BTEX a comma inside a formula is used, according to the English convention, as
number group separator. So there will be space added behind all commas in formulas.

To avoid this, the comma is highlighted and changed to mathematical text (shortcut
Ctrl4+M).

To use all formula commas in the document as decimal separator, the file icomma.sty*
is loaded with the IXTEX-preamble line

\usepackage{icomma}

24.3. Physical Vectors

Predefined vectors are offered by the I¥TEX-package braket that is loaded with the
ATEX-preamble line

\usepackage{braket }

The following commands are defined:

46jcomma is part of the INTEX-package was.
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Command Result

\Bra{\psi (V]
\Ket{\psi 1)
\Braket{\psi|\phi (¢ |¢)

The command \Braket assures that all vertical bars are set in the size of the sur-
rounding brackets:
3
T =5, My)
<¢‘ 27

The effect of \Braket can also be achieved using the command \middle, that is
described in sec. 5.1.2.

24.4. Self-defined Fractions

To define custom commands for fractions, the command \genfrac is used in the
following scheme:

\genfrac{left bracket}{right bracket }{fraction bar thickness}{style}
{numerator}{denominator}

The style is a number in the range of 0- 3.

Number Style (Size)
0 display style formula
1 inline formula
2 small
3 tiny

When no style is given, the size is adjusted to the surrounding environment like for
the command \frac.

When no fraction bar thickness is given, the predefined value of 0.4 pt will be used.

For example, the commands \dfrac and \tbinom from sec. 3.2 are defined with the
commands

\newcommand{\dfrac}[2]{\genfrac{ }{ }{ }{O}{#1}{#2}}

and
\newcommand{\tbinom}[2]{\genfrac{(}{) }{Opt }{1}{#1}{#2}}

To define a fraction where the fraction bar thickness can be given as optional argu-
ment, the following line is inserted to the XTEX-preamble:
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\newcommand{\fracS}[3][|{\genfrac{} { H{#1H H#2}{#3}}
A test:

Command \fracS[Imm]\{A — \{B \fracS[Smm]\{A — \{B
A
A
Result - B
B
B

As one can see, the distance of the numerator and the denominator to the fraction
bar is round about three times the bar thickness.

24.5. Canceled Formulas

There are four ways to cancel formulas or parts of formulas:

Command Result
\cancel \int, A=B [A=T
\bcancel \int A=B TA=B
\xcancel, \int, A=B [A=D
\cancelto, \int, A=B—1 [A=T" '

\cancelto is especially suitable to visualize the reduction of fractions within formu-

las: )
(29 + bB) x5+ B* =12

arwf T

To change the size of \cancelto’s “subscript” value one can add the KTEX-preamble
line
\PassOptionsToPackage{option}{cancel}

where option is either samesize which leads to the same size as for the canceled
value, or Smaller which makes is it a bit smaller than normal.

To color the cancellation bar one adds this command as TEX code:

\renewcommand{\ CancelColor }{\color{red}}
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red can be replaced by a color of your choice.

(vo +bB)*  aj+B*—r]

(1 +b2)”“ =

For further customizations, see the documentation of the package cancel, [5].

24.6. Formulas in Section Headings

When formulas are used in section headings, the following has to be taken into ac-
count:

When hyperref support is enabled in the document settings dialog under PDF Prop-
erties, PDF-bookmarks are created for every section heading in the table of contents.
If a section heading contains formulas, they are incorrectly displayed in the bookmark
text, because formulas in bookmarks infringe the PDF conventions.

Both problems can be solved by inserting at the end of the section heading a short
title with the menu Insert>Short Title. Short titles are used as alternative for multiline
section headings to keep the table of contents clearly arranged. Only the short title
appears in the table of contents and therefore also in the PDF-bookmark.

When formulas should be used in the table of contents but hyperref is used, one
can use the following command in TEX mode:

\texorpdfstring{part}{alternative}

Part is the part of the heading that shouldn’t appear in the PDF-bookmark. This
can be characters, formulas, footnotes, but also cross-references. The alternative is
used instead of the part for the bookmark.

Here are two example headings:

24.6.1. Heading without formula in table of contents /—1 =i
24.6.2. Heading with formula in table of contents /—1 =i

In the first heading a short title was used, in the second one \texorpdfstring.

To get the same formatting as for the other headings, the complete heading was set
into a boldmath environment?®”.

475ee sec. 11.2
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24.7. Formulas in multi-column Text

Formulas in multi-column text are often too wide to fit into a column and thus
need to be set over the whole page width. This is done by using the IXTEX-package

multicol®®, that is loaded with the ITEX-preamble line

\ usepackage{multicol}

Note that in this case the setting Two-column document in the menu Document>
Settings under Text Layout must not be selected.

Before the multi-column text the command

\begin{multicols}{column number}

is written in TEX mode. The column number is a number in the range of 2-10.
Before the formula the multi-column text is ended by inserting the command

\end{multicols}
in TEX mode.

Due to the command some space is automatically added before the formula.

To

revert this, -6 mm vertical space is inserted before the formula. When the formula
style Indented* is used, -9 mm space is inserted instead.

As example a multi-column text with a displayed formula:

Das Spektrum wird fouriertransformiert.
Die Fouriertransformation wird verwen-
det, um die tiberlagerten Signale (Netz-
werk, Losungsmittel) zu trennen. Nach-
dem wir die Phasenverschiebung bestim-
men konnten, interessiert uns nun das
Aussehen des Ausgangssignals. Im Expe-

5(t) = Soft) [

— 00

wobei Sy das Signal ohne Gradient
ist und die Normierungsbedingung
ffooo P(¢,t)d¢ = 1 gilt. Nun dirfen wir
aber nicht den Relaxationsprozess aufler
Acht lassen. Direkt nach dem 7/2-rf-Puls

riment haben wir es mit sehr vielen Teil-
chen zu tun, so dass man iiber alle Pha-
sen integrieren muss. Sei nun S unser nor-
miertes Ausgangssignal und P die Pha-
senverteilungsfunktion, so ergibt sich die
Beziehung

o0

P(¢,t)e’ d¢ (31)
beginnt sich die Magnetisierung zu ent-
fokussieren, wodurch sich das Signal zu-
sétzlich abschwécht. Diese Abschwéchung
verlauft exponentiell in Abhéngigkeit der
so genannten Th)-Zeit.

48multicol is part of every INTEX standard installation.

formula styles see sec. 17
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24.8. Formulas with Description of Variables

To describe variables within a formula, like in formula (32), a 2Xn matrix is used
with left aligned columns for the n used variables.®® To set the description in a
smaller size, before the matrix e.g. the command \footnotesize is inserted.!

When the formula style Indented® is used, a \hfill*® is inserted before and after
the matrix to have the same separation of the matrix from the equation and the side
margin.

When the formula style Centered is used, the method described in sec.18.2.3 is
used to indent formulas. Formula (32) consists of five columns where in the first two
columns contain the equation, the third the matrix and the last one an empty TEX
brace.

p  density
Fy=p-V-g V' volume (32)

g gravitational acceleration

24.9. Upright small Greek Letters

Most of the math fonts only provide italic small Greek letters. But for symbols of
elementary particles like pions and neutrinos, upright Greek letters are needed. The
file upgreek.sty® that is loaded with the IXTEX-preamble line

\usepackage{upgreek}

provides them. They are created when the command for a small Greek letter is
started with up. For example the command \uptau creates this: T

With these commands reactions of elementary particles can be typeset:
= put 4 v,

The upright letters are more bold and wider than the italic ones. They should
therefore not be used for units like “pm”.

24.10. Text Characters in Formulas

In some cases you might want to insert text characters directly into formulas. When
for example the centered dot - is often used in formulas like v = 5 - 10° Hz, one

*Omatrices see sec. 4

Sfont sizes see sec. 11.4

52formula styles see sec. 17

53\ hfill only works in formulas with the style Indented, see sec. 8.2.
S4upgreek is part of the WIEX-package was.
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would have to insert the command \cdot® all the time, because this character is
defined in all encodings as text character. But the encoding can be changed by this
ETEX-preamble line:

\Declare Inputtext{183}{\ifmmode\cdot\else\textperiodcentered\fi}

The character encoding (menu Document > Settings > Language) specifies what char-
acter appears when a keyboard key is pressed. When the key for the character " - is
pressed, internally the command \textperiodcentered is used. But this command
is not available in a formula so that you would get I¥TEX-errors. With the changed
encoding the right command is chosen automatically, depending on if the character
was inserted into a formula or not.

The encoding of several characters is saved in definition files. For example the encod-
ing latin9 is defined in the file latin9.def which is in the installation folder of KTEX.
Encodings should only be changed via the XTEX-preamble and not in the definition
files. Otherwise documents could not be edited by other IyX users working on other
computers.

Besides the centered dot, in this document the degree sign ° is defined with the
following KTEX-preamble line so that it can be directly inserted into a formula:

\DeclareInputtext{176}{\ifmmode™\circ\else\textdegree\fi}

24.11. BTgX-comments in formulas

In text you can insert a comment that will only be visible in the IXTEX source code
of your file with the menu Insert> Note> Comment. This is not possible in a formula
but you can insert IXTEX-comments with the command

\%

This creates a box in which you can write your comment. Due to a bug in IyX®¢
you cannot write normal text inside the comment, even when you use mathematical
text, you will see its TEX-commands in the ETEX-output.

This a formula with a ETEX-comment:

A=B

555ee sec. 10.4

56LyX-bug #9002
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https://www.lyx.org/trac/ticket/9002

A. Typographic Advice

This section is a summary of the most important typographic rules, listed in ISO
norms.

57

Physical units are always set upright®®, no matter if they appear in italic text:
30km/h

Between the value and the unit is the smallest space, see sec. 8.1.

This convention is automatically fulfilled when the command \unittwo is used.
When it is entered to a formula, two boxes appear. In the first one the value is
inserted, in the second one the unit, and one gets as above: 30 km/h. Note that
\unittwo is not a real BTEX command but the command \unit[value]{unit},
therefore you cannot use it in TEX code.

Percent and perthousand signs are set like physical units:
1.2 %o alcohol in blood

The degree sign follows directly on the value: 15°, but not when it is used in
units: 15°C

In numbers with more than four digits the smallest space is inserted before
every third digit to group them: 18473 588

For dimensions like 120x90x40 cm the multiplication sign “x” is used. It is
available either via the command \times or via the menu Insert>Special Char-
acter > Symbols.

Functions with names consisting of several letters are set upright to avoid con-
fusions, see sec. 15.1.

Indices consisting of several letters, are set upright: FEi;,
Components of matrices are set italic: Hy

The differentiation/integration operator 'd’, the Euler’s number e’ and the
imaginary unit i’ should be set upright, to avoid mixing them up with other
variables.

The character that denotes a FOURIER transformation is inserted either by the
command \mathscr F or via the menu Insert>Special Character>Symbolsr>
Letterlike Symbols: .7

5TThis collection was partly taken from the German semi-official dictionary called “Duden” [8] that
lists some of the ISO rules. More rules are listed in [9)].

58done with font styles, see sec. 11.1
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B. Synonyms

Some characters and symbols can be created with several commands. Here is a list
of the synonym commands:

Command

equivalent to

\ast
\choose
\geq
\lbrace
\Ibracket
\leftarrow
\leq
\lor
\neq
\slash
\vert

\binom
\ge
{
[
\gets
\le

\vee
\not=
/
|
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Command equivalent to
\backslash \\
\dasharrow \dashrightarrow
\land \wedge
\rbrace }
\rbracket ] List
\rightarrow \to
\Inot \neg
\ne \not=
\owns \ni
\square \Box
\ Vert \|



https://ctan.org/tex-archive/info/symbols/comprehensive/symbols-a4.pdf
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Description of IXTEX’s math abilities

Description of ApS-ETEX

List of all symbols available with KTEX-packages
Documentation of the KTEX-package cancel
Documentation of the KWTEX-package hyperref
Documentation of the KTEX-package mhchem
Duden Band 1. 22. Auflage, Dudenverlag, 2000

Check list for reviewing manuscripts

1] F. MiTTELBACH; M. GOOSSENS: The BTEX Companion. Addison Wesley, 2004
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https://www.tug.org/~hvoss/PDF/mathmode.pdf
https://www.ctan.org/tex-archive/macros/latex/required/amslatex/math/amsldoc.pdf
ftp://ftp.dante.de/tex-archive/info/symbols/comprehensive/symbols-a4.pdf
https://www.ctan.org/tex-archive/macros/latex/contrib/cancel/cancel.pdf
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https://www.ctan.org/tex-archive/macros/latex/contrib/mhchem/mhchem.pdf
https://www.nist.gov/physical-measurement-laboratory/special-publication-811
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as paragraph, 25
colored, 24
with frame, 22
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Bracket size
automatic, 13
manual, 12
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for multiline expressions, 47
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vertical, 12

Case differentiations, 7
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F

G
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\arraycolsep, 11, 45
\arraystretch, 11

\big, 12

\bigl - \bigr, 13
\bigm, 13
\binom, 6
\boldmath, 33
\boldsymbol, 36
\boxed, 22
\brace, 6
\brack, 6

\cases, 7
\CD, 58
\cdots, 9
\ce, 57

\cf, 57
\cfrac, 5
\colorbox, 24

\DeclareMathOperator, 31, 40
\dbinom, 6

\definecolor, 25

\dfrac, 4

\displaystyle, 1, 35

\dotfill, 10

\dots, 9

\euro, 38
\fbox, 22
\fcolorbox, 25
\frac, 4
\framebox, 22

\gathered, 51
\genfrac, 65

\hdotsfor, 9



\hfill, 20
\hphantom, 8
\hrulefill, 10
\hspace, 20, 46
I
\int, 27
\intertext, 51
J
\jot, 15, 44
L
\ldots, 9
\left, 11, 13, 47
\lefteqn, 46
\leftroot, 6
\lim, 40
\linewidth, 26
M
\makebox, 23
\mathbin, 32
\mathop, 32
\mathsurround, 21
\mbox, 23
\middle, 14
\multlinegap, 50
N
\newcommand, 59
\nicefrac, 5
\not, 7
\numberwithin, 56
O
\officialeuro, 38
\oldstylenums, 43
\overbrace, 14
\overbracket, 14
\overline, 8
\overset, 19, 30
P
\parbox, 26
\phantom, 7
\prod, 27

R
\Roman, 54
\raisebox, 23

\renewcommand, 11, 54
\right, 11, 13, 47
\roman, 54

\root, 6

\rule, 8

\setlength, 21
\shortintertext, 51
\shoveleft, 50
\shoveright, 50
\sideset, 30
\smallmatrix, 11
\smashoperator, 29
\split, 51
\splitfrac, 47
\sqrt, 6

\stackrel, 39
\subarray, 29
\substack, 29
\sum, 27

\tag, 55

\tbinom, 6
\texorpdfstring, 67
\text, 2
\textbackslash, 12
\textcircled, 43
\textcolor, 25, 34
\tfrac, 4

\unboldmath, 33
\underbrace, 14
\underbracket, 14
\underline, 8
\underset, 19, 30
\unitfrac, 5
\uproot, 6

\vphantom, 8, 47

\xleftarrow, 16
\xrightarrow, 16

Comparisons, see Relations
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Cross-references
to formulas, 52

Delimiters, 12

Diagrams
amscd, 58
Feynman, 59
xymatrix, 59

Ellipses, 9
Exponents, 4

Font
size, 34
style, 32
Fonts, 32
Formula
bold, 33
canceled, 66
colored, 34
display style, 1
in multi-column text, 68
in section headings, 67
inline, 1
long, 46
multiline, 44
align environment, 48
alignat environment, 48
Column separation, 45
eqnarray environment, 49
flalign environment, 49
formula parts, 50
gather environment, 49
Line separation, 44
multline environment, 49
text, 51
numbering, see Formula numbering
styles, 43
underlined, 8
with description of variables, 69
Formula numbering, 52
self-defined delimiters, 55
subnumbering, 53
user-defined, 55
with letters, 54
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multiline, 47
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Functions
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predefined, 39
self-defined, 40

Greek letters, 35
big, 36
bold, 36
small, 36
upright, 69

Indices, 4
Integrals, 27
Isotopes, see Chemical characters

KETEX-preamble, 2
ETEX-comments, 70
Limits, 40

Lines, 8

Macros, 60

Toolbar, 62
Mathematical text, 2
Matrices, 10
Miscellaneous, 64

Negations, 7
Numbers
negative, 64

Old-style Figures, 43
Operators, 27
big, 27
binary, 31
Decoration, 30
Limits, 28
self-defined, 31

Packages
braket, 64
cale, 26, 44



cancel, 67, 73
carlisle, 56
color, 24
eurosym, 38
fixmath, 36
hyperref, 67, 73
icomma, 64
mathtools, 14, 16, 29, 30, 47, 51
mhchem, 57, 73
multicol, 68
remreset, 56
undertilde, 18
upgreek, 69
was, 36, 64, 69

Placeholders, 7

Relations, 38
Roots, 6

Space
besides inline formulas, 21
horizontal, 19
predefined, 19
variable, 20
Special characters, 41
Subscripts, see Indices
Sums, 27
Superscripts, see Exponents
Symbols, 37
chemical, 56
Euro-symbol, 38
mathematical, 37
miscellaneous, 37
Synonyms, 72

TEX-braces, 2
TEX-mode, 2
Text

colored, 25

in formulas, 2, 51, 69
Tilde, 42
Typographic advice, 71

Umlauts, 18

User-defined commands, 59
Math macros, 60
\newcommand, 59

Vectors, 18
physical, 64
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