
LYX and Sweave with R on Windows XP or Vista

Jeff Laake Jeff.Laake@noaa.gov
(Updated by Dave Hewitt on 18 November 2010)

These are some notes I compiled to help others install LYX (http://www.lyx.org) and cre-
ate the links needed to get LYX working with R through Sweave (http://www.r-project.org/).
I wrote up an initial version of this document and subsequently both Dave Hewitt and Bret
Collier have tested the instructions and modified the wording and presentation based on
their sometimes frustrating experiences. When I first installed LYX/Sweave on my machine
running Microsoft Windows Vista, I depended heavily on Murat Yildizoglu’s blog entry, and
I’m quite grateful for his blog. His instructions were for machines running Windows XP, but
I found that they worked fine on my Vista machine. So when colleagues asked for instruc-
tions on how to set this up, I sent them to Murat’s blog. But their installation attempts were
unsuccessful. I subsequently tried to get things working on an XP machine and another Vista
machine and was unsuccessful as well. This befuddled me somewhat, but after much fuss-
ing I discovered in part why I was so lucky. I had a previous installation of MiKTEX on the
machine and had a local texmf directory, but I had forgotten how I created it because I had
only used LATEX for a single book project. But I ran into other differences on the XP machine
that I had to work through as well. For example, it turned out that I already had the LATEX
package ragged2e on my machine and it was not on the other machines.

I think Murat’s description is fine if you are already a regular LATEX user, but if you are
not then the instructions may not be sufficient. So, with that in mind, here are some more
complete instructions and tips that may help. Note that for some of the steps below you
must have Administrator privileges on the machine, and this may vary between XP and
Vista. For example, in Vista, make sure you open Command Prompts (what used to be DOS)
or text editors with “Run as Administrator” to save yourself frustration. If you work for the
government and they have stripped you of your Admin privileges, this will be much more
difficult than if you do have Admin privileges. For example, in XP, some of the steps must
be performed by an Administrator.

In all of the instructions below, you MUST modify the drive and directory/path names if
yours differ from the ones used here. For example, you may be using different versions of
R, LYX, or MiKTEX, or have installed the programs into different directories or on different
drives. I used default paths for R-2.12.0, MiKTEX 2.9, and LYX 1.6.8. On a Vista 64 bit system,
the default installation directory will be in C:\Program Files (x86).
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Installing LYX

Install a complete version of LYX. You will need Administrator privileges to do this. A
complete LYX installation takes a long time, so be prepared to spend some time on this step.
It’s worth it. There are two options for Windows users and either should work. See:
http://www.lyx.org/Download
and
http://wiki.lyx.org/Windows/LyXWinInstaller

Getting the Various Pieces to Talk to Each Other

You must have Administrator privileges to perform steps 1 and 2 below.

1. Go to the Windows Control Panel and double-click the System icon. Find the En-
vironment Variables (under Advanced System Settings). Click on the Environment
variables and under System Variables find Path in the list. Click on it and choose
Edit. At the end of the string, add the paths to the bin directory for each of MiKTEX
(e.g., C:\Program Files\MiKTEX 2.9\miktex\bin) and LYX (e.g., C:\Program Files\LYX

1.6.8\bin) [if they are not already present]. Each path here should be separated by a
semicolon.

2. Install the appropriate version of Rtools for R from:
http://www.murdoch-sutherland.com/Rtools/index.html
When you do the installation, near the end of the setup process be sure to check the box
to have the installer add the appropriate Rtools paths (this option is not checked by de-
fault). Make sure the drive and directories it uses in the paths are correct if you choose a
non-default location. It is not clear to me that you need Rtools for using Sweave through
LYX, but it adds several useful Unix utilities and you’ll need these if you choose to create
R packages.

3. Download the file noweb.sty from
http://tug.ctan.org/tex-archive/web/noweb/src/tex/
Also, get the file Sweave.sty from the share\texmf directory under your R installation
(e.g., C:\Program Files\R\R-2.12.0\share\texmf\tex\latex). Put both of these files
into your local texmf directory (if you have one) under texmf\tex\latex\misc. If you
have not used LATEX before, create a texmf directory in a place of your choosing. If you
are not an Administrator, do not create this folder using Administrator privileges (at
least on XP). Also, it’s probably best to avoid creating this directory in locations that are
protected for Administrators. Create the subdirectory structure noted above and put
the two files in the terminal directory misc. Next, open a Command Prompt (usually
found under All Programs -> Accessories; or Start -> Run... -> “cmd” [Enter]). If you
have followed the steps above to modify the system path then you should be able to
run MiKTEX programs from the command prompt. I have seen alternate forms of this
command given for Windows, but what I found that works is:

initexmf --user-roots=dir

where dir is the path to your local texmf directory (e.g., �C:\texmf�). If you did this
correctly then you should be able type
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initexmf --report

and you’ll see the path to your local texmf directory displayed in the list. You can
also perform these steps using the MiKTEX Settings application (from the Start Menu).
Under the “Roots” tab, you can add the path to your local texmf directory and also see
all of the paths that are assigned.

4. From the Windows Start Menu, run the MiKTEX Settings application (typically found
under MiKTEX -> Maintenance; NOT the one labeled “(Admin)”). Under the “Pack-
ages” tab (it may take a second), click the button at the bottom to start the Package
Manager. It will take a second or 2 and then you’ll see a list of pacakges. Scroll down the
list to the package named ms. If no date is displayed in the column “Installed on”, click
the “+” in the top left corner of the program window to install the package. MiKTEX
will go to a CTAN web repository to download and install the package. (This is how
you install LATEX packages in the future, and you can change the repository under the
Repository menu in the Package Manager. Note that you can configure MiKTEX to au-
tomatically download and install packages that you need “on-the-fly” – see the General
tab in the Settings program). Once the ms package is installed, close the Package Man-
ager and return to the General tab of the Settings program. Click the button labeled
Refresh FNDB and then click the one labeled Update Formats (I’m not sure this last
one is necessary). Now you can close out of the Settings program. If you get an error
like “Windows API error 87”, it is apparently because there are multiple instances of
MiKTEX running. If this happens, restart your computer before going on to the next
step. (You can search the web for “Windows API error 87: The parameter is incorrect”
for more details.)

5. Start LYX. On the menu bar under Tools, select Reconfigure. You’ll see a note in the
bottom left of the program window letting you know that the configuration script is
running. This might take a little while. When you get the message box letting you
know that configuration is complete, close LYX and then re-open it. Create a new file
(File -> New) and then select Document -> Settings from the menu bar. On the right,
click the down arrow to choose a document class. You should see “article (Noweb)”
as one of the choices. If the class only shows up at the bottom as “Unavailable: article
(Noweb)”, that’s not good and you probably didn’t complete steps 3 and 4 correctly. If
the class appears in the list as “article (Noweb)”, move on to the next step.

6. In a plain text editor, you need to create a batch script called Rweave.bat in the LYX
bin directory (e.g., C:\Program Files\LYX 1.6.8\bin). [At least on Windows XP, if you
don’t have Admin. privileges you may not be allowed to create a file in a directory
under Program Files. A great solution to this and other similar situations is to ask
an Administrator to grant your user account with Full Control privileges on top-level
directories for programs like LYX, MiKTEX, R, etc. That way you can move and edit
files and programs can work within these directories as needed.] The batch script file
should contain a single line (the line below is broken on purpose) with something like
the following (including the quotes):

"C:\Program Files\R\R-2.12.0\bin\i386\Rterm.exe" --no-save --args %1 <

"C:/Program Files/LYX 1.6.8/bin/MakeSweave.R"
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Note that you need to change the paths to match your versions of R and LYX and their
locations. Also, the directory separators are indeed \ for the first part and / for the
second part because the first part is for a DOS command and the second part is for R
(which either uses \\ or /). The above instruction that I got from Murat’s blog worked
fine on my Vista machine, but I’ve been unable to get it to work on 3 different XP
machines. I’m not sure why. However, the following works on XP:

"C:\Program Files\R\R-2.12.0\bin\i386\Rterm.exe" --no-save �f

"C:/Program Files/LYX 1.6.8/bin/MakeSweave.R" --args %1

7. In a text editor, create an R file called MakeSweave.R in the in the LYX bin directory. It
should contain the following lines:

library(tools)

args <- commandArgs()

filename <- args[length(args)]

basename <- sub("\\.(Rnw|Rtex|nw)$", "", filename)

Sweave(filename)

Stangle(paste(basename, ".nw", sep=""))

texi2dvi(paste(basename, ".tex", sep=""), pdf=TRUE)

This is essentially the same contents as given on Murat’s blog except that I added the
Stangle() command to extract all of the R code from the Noweb document and put it
into a file with the .R extension.

8. In LYX, go to Tools -> Preferences -> File Handling -> Converters. Below the box of
current Converter Definitions, choose “NoWeb” from the dropdown box for “From for-
mat:”. Then choose “PDF (pdflatex)” from the dropdown box for “To format:”. In the
Converter box, delete what’s there and type

Rweave $$i

Delete any Extra flags in the next box down (if present), then click the “Add” button at
the top right and then the “Save” button at the bottom.

9. You should be all set to start Sweaving with R through LYX. You can do a basic test by
opening Paul Johnson’s Gamma distribution LyX file and choosing “PDF (pdflatex)”
from the View menu on the menu bar (or, more commonly, the View PDF icon on the
View/Update toolbar). If you get an output PDF file with code chunks and R plots in
it, everything is working. (BUT before you do anything else, read the Tips below.)

If you get an error message that says there is no converter to create a PDF, then you
messed up with Step 8. If you get an error message that says “An error occurred whilst
running Rweave ’Gamma.nw”’, then something is amiss with Step 6. If LYX hangs up at
“Executing command Rweave ’Gamma.nw’”, that is also an indication that something
went wrong with Step 6. This is what happened to me with XP when I used the batch
script instruction from Murat’s blog. When I switched to the second form shown in Step
6, it worked. If LYX hangs up while showing “Waiting for Latex Run 1” in the bottom
left corner, this means that it did the Sweave command but is failing at the texi2dvi
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function in R that runs the MiKTEX executable texi2dvi.exe. I had this happen and I
debugged into the texi2dvi function in R and found that it turns off error messages.
That is unfortunate. As it turns out, the error resulted from missing the LATEX package
ragged2e which Paul uses in the Gamma distribution document. I had you install this
package as part of the larger ms package above. Also, this may not happen to you if you
have MiKTEX configured to install packages on-the-fly.

Tips

1. It is important to know where all of the files that are created during the Sweaving pro-
cess are stored. These will be under your user account in Documents and Settings on
XP and Users on Vista. For example, on Vista for me it is:

C:\Users\Jeff Laake\AppData\Local\Temp\lyx_tmpdir.Hp4980\lyx_tmpbuf0

On XP it might be something like this:

C:\Documents and Settings\jlaake\Local Settings\Temp\lyx_tmpdir.Hp4980\lyx_tmpbuf0

The directory like lyx_tmpdir.Hp4980 will vary with each session.

If something goes wrong during the Sweaving process, it may be helpful to look at
the files in this directory. It is also where your PDF and .R files (from Stangle) will be
located.

2. One of the ways you can learn about the location of the files mentioned in Tip 1 is to run
LYX from a Command Prompt. I suggest that you always do this when using LYX for
a Sweaved document. To start LYX from a Command Prompt, open a prompt window
and type lyx at the prompt. If you set up the system path correctly in Step 1 above, LYX
should launch and the command prompt window should remain open. Don’t close the
command prompt window or you’ll kill LYX.

Now open the Gamma distribution LYX Noweb file you downloaded earlier and start
the PDF production process. In the LYX window there will be a message like Executing

command Rweave �Gamma.nw� in the bottom left corner. You can also switch to the Com-
mand Prompt window to watch what’s happening. You’ll see the commands being
executed and the log of what has happened during the Sweaving and R code execu-
tion. The first command at the top of the log (the command from the batch script) will
show the first path as the path for the temporary directory where the files are stored.
Errors will also show up in the log, and if you aren’t running LYX with a Command
Prompt window open you’ll be in the dark about any errors.

Just for grins, you can screw up one of the R commands in the Gamma distribution
LYX file and see how errors are reported. You’ll see an error in the Command Prompt
window and also an error as a message box in LYX (“An error occurred whilst running
Rweave “Gamma.nw”). The error reported in the Command Prompt window is im-
portant for helping you debug your R code. A note of warning that on one of three
XP machines I’ve worked with the messages do not appear in the Command Prompt
window, and I’m not sure why. If you are new to LYX, as I am, I recommend doing
the PDF conversion frequently (even if the document isn’t a Noweb document) in case
something fails. That way you’ll be able to track down the error based on what you
changed recently.
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3. To learn more about how to properly include R code in LYX documents, see Section 6.3
(Literate Programming) of the Additional Features help manual in LYX (from the Help
menu).
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